[Ffmpeg-devel-irc] ffmpeg.log.20150217

burek burek021 at gmail.com
Wed Feb 18 02:05:01 CET 2015

[00:27] <latenite> Hi folks, I try to do something like: http://d1u2s20mo6at4b.cloudfront.net/wp-content/uploads/01_subkeys.gif
[00:28] <latenite> How do you think did he create the frames?
[00:28] <latenite> I did split the gif appart with:
[00:28] <latenite> convert Desktop/GIF-in-PDF/01_subkeys.gif -coalesce Desktop/1/animate_%d.jpg
[00:29] <latenite> and he somehow managed to get one frame per change/letter/output
[00:29] <latenite> but how?
[00:47] <latenite> Hi folks, how can I used ffmpeg to record my screen? -> NOT as mp4 or mkv or any movie format BUT with many many png image frames? I just need the frames!
[00:47] <c_14> Same way as normal just with out%03d.png as the output filename
[00:48] <ramiro> it might make sense to use -vsync so that you don't get duplicate or dropped frames
[00:53] <latenite> ramiro, somemow the resulting mp4 looks bad
[00:53] <latenite> ffmpeg -f x11grab -s 1440x900 -i :0.0  sc.mp4
[00:53] <latenite> I would like to habe lossless images eventually
[00:54] <c_14> Then use a lossless codec?
[00:57] <latenite> ffmpeg -f x11grab -s 1440x900 -i :0.0 Desktop/frames/out%03d.png
[00:57] <latenite> seems to work. But adding  -vsync gives me this error:
[00:57] <latenite> Expected number for vsync but found: -f
[00:57] <latenite> Conversion failed!
[00:57] <latenite> Is there a way to only get "new" frames?
[00:58] <latenite> I want to make an anitmation out of the frames and would like to omit the duplicates
[01:03] <grepper> use diff or md5sum ?
[01:06] <latenite> grepper, you mean to afterards sort the images out?
[01:06] <latenite> Is there a way to ONLY capture a frame when there is a change?
[01:09] <grepper> you mean like a sensor that activates a camera?
[01:31] <latenite> Sorry my DSL is bad
[01:32] <latenite> I make screen capture frames like this
[01:32] <latenite> http://i.imgur.com/IUs8ORs.png
[01:32] <latenite> next frame is:
[01:32] <latenite> http://i.imgur.com/HvRg8jD.png
[01:33] <latenite> with ffmpeg -f x11grab -s 1440x900 -i :0.0  $HOME/screencast-frames/out%010d.png
[01:33] <latenite> why is is missing so many frames?
[01:33] <latenite> I expected it to record every letter I type "l" "s" " " "-" "l" "a"
[01:34] <latenite> I am typing super fast. And it just got the whole string
[01:34] <c_14> Increase the recording fps
[01:34] <latenite> how?
[01:34] <c_14> -framerate number
[01:34] <c_14> As an input option
[01:34] <latenite> what is a "good" number? 30?
[01:35] <c_14> How many frames do you want per second?
[01:37] <spaam> over 9000
[01:46] <latenite> c_14, see
[01:46] <latenite> http://i.imgur.com/KttF1kn.png
[01:46] <latenite> and
[01:46] <latenite> http://i.imgur.com/q2i3kZm.png
[01:46] <latenite> the pfs was set to 30
[01:46] <latenite> and these are two consecutive frames
[01:47] <latenite> does that show/explain my problem?!
[01:49] <latenite> There are actually 30 pfs but they all look the same
[01:49] <latenite> fps
[02:02] <c_14> Works fine for me
[02:02] <c_14> Try updating your version of ffmpeg
[02:03] <c_14> with -framerate 30, and `while true; do echo 'foo'; sleep 0.1; done' I get 1 foo every 3 frames
[02:04] <latenite> ffmpeg version 2.2.11 Copyright (c) 2000-2014 the FFmpeg developers
[02:04] <latenite>   built on Jan 17 2015 17:03:30 with gcc 4.8.3 (Gentoo 4.8.3 p1.1, pie-0.5.9)
[02:04] <latenite> is that to old?
[02:05] <latenite> c_14, did you record to movie or to images?
[02:05] <c_14> latenite: images
[02:06] <c_14> `./ffmpeg/ffmpeg -video_size 1280x720 -framerate 30 -f x11grab -i :0.0 out%03d.png'
[02:06] <c_14> Don't think the video_size, should matter
[02:06] <latenite> just like I did it.
[02:06] <c_14> I can try it again without if you want though.
[02:06] <latenite> hmm???
[02:06] <latenite> no I want images
[02:06] <c_14> -video_size just limits the amount of my desktop that's captured
[02:06] <c_14> I was referring to that
[02:07] <latenite> yes
[02:07] <latenite> I did:
[02:07] <latenite> ffmpeg -f x11grab -s "$(xdpyinfo  | grep 'dimensions:' | awk '{print $2}')" -i $DISPLAY test.mp4
[02:07] <latenite> and in the mp4 I see all the minor changes
[02:07] <latenite> that is sooo weird?!
[02:09] <c_14> Try building from git master head with a minimal configure
[02:10] <latenite> I think I found it....let me experiment for a minute :D
[02:14] <c_14> Also, there's a 90% probability that you really don't want to disable threads in ffmpeg. Just wanted to point that one out.
[02:27] <latenite> c_14, its a performance issue
[02:27] <latenite> when I drop the fps to 10 i get decent results
[02:27] <latenite> almost evrey change is captured.
[02:28] <latenite> Now why is my performace so bad? I have a core i5 4th gen and 16GB ram intel grafics
[02:28] <c_14> Turn on threads
[02:28] <c_14> As a start
[02:30] <latenite> ok, let s see how that effects it.
[02:44] <latenite> c_14, thread is what made it work. I am all good now.
[02:44] <latenite> c_14, thank you tons for you help. :D
[02:47] <c_14> np
[06:32] <Matador> damn
[06:32] <Matador> having problems cross-compiling ffmpeg
[06:33] <Matador> libquvi not found using pkg-config
[06:33] <relaxed> config.log will show you the reason
[06:34] <Matador> I have libquvi installed though
[06:35] <relaxed> that doesn't matter, ffmpeg's configure runs tests to make sure it can be linked.
[06:35] <relaxed> and right now it can not be
[06:35] <Matador> I was doing this one on CentOS
[06:35] <Matador> https://github.com/rdp/ffmpeg-windows-build-helpers
[06:36] <Matador> http://pastebin.com/HbN2kRmv
[06:38] <relaxed> config.log
[06:38] <Matador> I have a build.log
[06:38] <Matador> ~19k lines
[06:40] <Matador> Package libquvi was not found in the pkg-config search path.
[06:40] <Matador> Perhaps you should add the directory containing `libquvi.pc'
[06:41] <Matador> its there @ /usr/lib64/pkgconfig/libquvi.pc  though
[06:44] <relaxed> Are you using the most recent version of that build script? I see mention of a quvi update on the github page.
[06:44] <Matador> ya I just grabbed it
[06:47] <relaxed> ok, then look at config.log in the ffmpeg source dir
[06:47] <Matador> How can I add the path to libquvi.pc to build ?
[06:47] <Matador> to the search path...
[06:48] <relaxed> PKG_CONFIG_PATH=/path/to/dir
[06:50] <Matador> http://smoothstreams.tv/tmp/config.txt
[06:52] <relaxed> cd ffmpeg; PKG_CONFIG_PATH=/path/to/pkgconfig ./configure --enable....
[06:54] <relaxed> although I find it hard to believe this script isn't building to a specific location and adding the pkgconfig path on its own
[06:54] <Matador> I dont know what to enable.. prefer script just do it
[06:54] <Matador> It did work before.. like last year
[06:55] <relaxed> http://ffmpeg.zeranoe.com/builds/
[06:55] <Matador> was just trying to upgrade my version
[06:55] <Matador> ya I'm aware of those builds.. but I want the better AAC
[06:55] <Matador> the libfdk-aac
[06:56] <relaxed> Then you need seek support with the authors of that script.
[06:57] <sekon> Matador: if you want .. people can be paid to look into it too ?? elance maybe ?
[06:58] <Matador> Sure
[06:58] <Matador> I appreciate your time relaxed
[06:58] <Matador> Would like the build to work on CentOS 7
[06:59] <relaxed> Do you even need libquvi support?
[06:59] <Matador> I dont know
[06:59] <relaxed> Then you don't :)
[06:59] <Matador> Just streaming flash
[07:00] <relaxed> Ok, then really don't need it. It's used for downloading video from streaming sites such as youtube.
[07:00] <Matador> ok much appreciated
[07:00] <sekon> Matador: just disable it and see if your site works as expected
[07:00] <sekon> if not .. you will need professional help most likely
[07:00] <Matador> I cleared whole sandbox
[07:00] <Matador> so rebuilding *
[07:01] <Matador> but I see the build path in the script, and will remove the --enable-libquvi if it comes up with a problem again
[07:02] <Matador> I set thread count to 8 so should build pretty fast :)
[07:23] <sekon> Hello i want a dummy ffmpeg opt of type OPT_STRING
[07:23] <sekon> it will bot be used anywhere in ffmpeg .. but it should not make ffmpeg crash
[07:23] <sekon> is there a way i can make it happen ?
[07:24] <sekon> *crash as in segfault in av_free
[08:07] <Matador> build w/o quvi
[08:16] <Matador> but error on encoding... Past duration 0.984367 too large
[08:21] <Matador> http://pastebin.com/H8a37b2c
[08:49] <k_sze[work]> Hello
[08:50] <k_sze[work]> I don't quite understand how to use codec options, like on this page: https://www.ffmpeg.org/ffmpeg-codecs.html#Codec-Options
[08:50] <k_sze[work]> In particular, I don't understand the time_base option
[08:50] <k_sze[work]> How do I specify a rational number on the command line?
[08:54] <k_sze[work]> Like, why can't I do this: `ffmpeg -i 'in.nut' -c:v copy -copyinkf -vsync drop -time_base '1 / 30' -r 30 -y ~/out.nut`
[08:54] <k_sze[work]> it tells me "Unrecognized option 'time_base'."
[09:01] <relaxed> I think it's an input option
[09:03] <relaxed> And I doubt you can drop frames while stream copying
[09:41] <k_sze[work]> I don't want to drop frames.
[09:41] <k_sze[work]> I want to change the time base.
[09:42] <k_sze[work]> relaxed: `-vsync drop` doesn't mean dropping frames.
[09:42] <k_sze[work]> it means the discard the video sync information from the input stream and completely recompute it.
[09:43] <relaxed> ah, did you try -time_base 1/30 as an input option?
[09:44] <k_sze[work]> relaxed: doesn't recognise it.
[09:44] <k_sze[work]> even as input option.
[10:02] <relaxed> Could someone please test alsa input using my builds? I just fixed a bug a user reported where it hardcoded the prefix of my build and was looking for alsa.conf in a non-stand location. It works here but I just want to be sure there's no other issues. http://johnvansickle.com/ffmpeg/
[10:17] <termos> Hi. Right now I'm generating hls segments and writing them to disk. Is it possible to push them directly to a http endpoint?
[10:18] <sekon> termos: write ffmpeg out to stdout capture in popen and push any  way you want it anywhere ?
[10:21] <termos> I'm using the library directly, and my program can have multiple ongoing encodings
[10:22] <sekon> termos: this might be better suited for ffmpeg-devel
[10:22] <ubitux> sekon: no.
[10:22] <ubitux> ffmpeg-devel is not for helping library users
[10:22] <sekon> ok .. sorry  my bad
[10:23] <sekon> i had it really wrong then
[10:26] <termos> Hehe :) I don't find it in the docs so I guess it won't do this. I could just try and see what happens
[15:04] <chris_g4> hello guys, i have something interesting here, i have a live stream which when i open it on vlc i can see on codec page this image http://postimg.org/image/hiwawurlt/ , i think the guy has put the epg info on the flow stream but when i try to do the same with ffmpeg i cant.. i tried to put for example only a title as metadata but nothing... is not working..
[15:04] <chris_g4> anyone have any idea
[15:04] <chris_g4> ?
[15:17] <chris_g4> also when i tried ffmpeg -i source -f ffmetadata metadata.txt to take the output i have this :error"
[15:17] <chris_g4> Output file is empty, nothing was encoded (check -ss / -t / -frames parameters if used)
[15:18] <robotbrain> can I spevify the starting frame for the input?
[16:24] <Cheenis> Due to a change in broadcast from the BBC I need to put FFMPEG on my synology DS210J NAS to enable my Squeezebox radio to work with the new BBC streams. From what I have read I need to get hold of a FFMPEG binary compiled for version 1.0 or higher for the Marvell Kirkwood mv6281 ARM. Can somebody point me to one as I can't seem to find it.
[16:24] <Cheenis> Please
[16:31] <Cheenis> Or any advice as to how I can do this for myself; i.e., create my own binary - not sure how realistic that is as I'm only partially technical. :$
[17:23] <circ-user-TNwVO> Hi, could anyone help me with this: http://stackoverflow.com/questions/28519403/ffmpeg-command-issue issue ?
[17:31] <t4nk370> Hi, could anyone help me with this: http://stackoverflow.com/questions/28519403/ffmpeg-command-issue issue ?
[17:52] <dimi> Hello, can you help me with the info how float conversion is implemented in libswresample and libavresample? Are the float conversion procedures identical in both? If i convert a float to s16 and back will i always get identical results?
[18:03] <circ-user-TNwVO> No point of asking from what I can see
[18:08] <hans_s> circ-user-TNwVO: fps=... is a video filter, you have to add -vf before that
[18:09] <circ-user-TNwVO> Hi, thanks for an answer!
[18:13] <circ-user-TNwVO> I have tried it in the past but all this resulted in was only one/two thumbnails being generated ( which shouldn't happen - at least according to where I got that command from: http://superuser.com/a/608125 )
[18:13] <circ-user-TNwVO> Really sorry for being an FFMPEG N00b
[18:19] <chris_g4> hello again , someone can help me about the metadata, i have a live stream as an example and i would like to make the same metadata output like this one, i can pay for this thanks
[18:25] <hans_s> circ-user-TNwVO: I think the "fps=fps=1/600" results in a frame rate of 1/600 fps (1 frame every 10 minutes), so maybe you have to adjust that to the length of your video
[18:26] <circ-user-TNwVO> hans_s Oooh, I see! Thank you very much!
[18:27] <hans_s> if you want 6 thumbnails, you probably have to replace 600 with <length of video in s>/6
[18:39] <z16> Hey guys, disclaimer: I know next to nothing about video conversion/encoding...
[18:40] <z16> I have ogg vorbis video files that I need to convert to FLV, and when I try to do that the resolution changes
[18:41] <z16> Er.... wait
[18:42] <z16> The input resolution *says* 720x480... but it's actually 640x480
[18:42] <z16> The converted file has the correct value oO
[18:42] <z16> That's... strange, but I guess not relevant to the channel anymore!
[18:45] <Mavrik> z16, oh you met your first anamorphic video :P
[18:48] <z16> Mavrik: Not sure what that is, but apparently!
[18:54] <Mavrik> It's when you have a video of resolution A that should be shown at resolution B
[18:54] <Mavrik> Because legacy! :P
[19:13] <Cheenis> Re: The question earlier requesting a FFMPEG binary V1.0 or higher compiled for the Marvell Kirkwood mv6281 ARM - is my question poor, is there nobody that can help me or am I in the wrong place? Sorry, I'm totally new to what I'm trying to do so I don't know what I don't know if that makes sense.
[19:22] <chris_g4> stronzi testi di cazzo che non rispondete mai.. che state facendo tutto il giono rompete coglioni!
[19:29] <Mavrik> Cheenis, if noone built ffmpeg for your NAS, you'd have to do it yourself - but setting up a proper toolchain (if it exists) and configuring ffmpeg with dependencies does require rather alot of technical knowledge
[19:30] <Mavrik> Cheenis, did you try to see if ipkg (optware) has it already built?
[19:32] <Matador> Anyone know what this -- Past duration 0.984367 too large -- error means ?
[19:32] <Cheenis> Thanks for the reply Mavrik! I'm currently trying to load bootstrap onto my NAS which I believe will then allow me to run ipkg, but when I try to run the .xsh script it tried to make a directory and fails due to permissions. I am logged in as admin and I am currently researching how I change permissions, but haven't been able to work it out so far.
[19:33] <Cheenis> If there is an easier way to get ipkg working then I'm all ears.
[19:33] <Matador> http://pastebin.com/H8a37b2c
[19:34] <Mavrik> Cheenis, sorry, I haven't really dealt with Synologies all that much :/
[19:36] <Mavrik> Matador, it looks conected to the video sync / framerate handling code
[19:36] <Mavrik> it seems like you might not be defining input framerate properly?
[19:36] <Cheenis> No probs. I'll have to do the hard yards in the forums. I really appreciate you replying in the first place Mavrik! The frustrating thing here really is the BBC changing the world on us without there being time to create a user friendly solution for those that haven't touched Vi in a good 15 years. It used to be my friend, but those days are clearly long gone :o
[19:36] <Mavrik> :))
[19:36] <Matador> It works fine on older ffmpeg build :|
[19:37] <Matador> input frame is correct
[19:37] <Matador> always been like that
[19:38] <Matador> bloody crazy :|
[21:34] <joeflateau> does anyone possibly have an example of using tee pseudo-muxer to output hls and flv from one encode?
[21:34] <joeflateau> keep banging my head against bitstream filters
[23:03] <Matador> hmmm
[23:04] <msmithng> joeflateau: did anyone come up with an example?
[23:33] <joeflateau> msmithng: no, i didn't
[23:33] <joeflateau> no, nobody did, i mean
[23:34] <joeflateau> msmithng: i'm stuck on global headers now
[23:35] <c_14> joeflateau: you could always scrap the pseudo-muxer, pipe the output of ffmpeg into a second ffmpeg process which uses -c copy and has 2 outputs
[23:35] <c_14> Can help get around bitstream filter/flag issues
[23:36] <joeflateau> i'm encoding different bitrates from one source (live stream)
[23:37] <joeflateau> so, 3 bitrates each to 2 outputs
[23:37] <msmithng> you mentioned you were working with hls as one of those outputs correct?
[23:37] <joeflateau> yes
[23:38] <joeflateau> 3 bitrates each to flv (rtmp) and hls
[23:38] <grepper> I am trying to use ffmpeg to identify if a file is a video or not. I have found the 'file' command to be somewhat problematic, depending on how updated the magic file is, and the video format/codec. One gottcha is that it will call images a video stream, but I am filtering on 'image2| _pipe'. Anything I am missing ?
[23:39] <grepper> current bash function is:   is_video()  {     local result=$($FFmpeg -i "$1" 2>&1); grep -E -qi 'image2|_pipe' <<< "$result" && return 1; grep -qi Stream.*Video <<< "$result"; }
[23:40] <joeflateau> http://pastebin.com/KtrJBjPs
[23:40] <joeflateau> this is my stripped down example
[23:42] <c_14> grepper: This might be easier to parse: `ffprobe -show_entries format=format_name -hide_banner'
[23:42] <joeflateau> flv freaks out without +global_header and hls freaks out with +global_header
[23:43] <c_14> joeflateau: can't you add ':flags=+global_header' into the [] for the rtmp stream?
[23:44] <grepper> c_14: yes, I like ffprobe and use it optionally for other things, but don't want to (yet) make it a dependancy. (yes I know it is almost always installed with ffmpeg)
[23:44] <joeflateau> then i get "Could not write header for output file #0 (incorrect codec parameters ?): Option not found
[23:44] <joeflateau> "
[23:50] <c_14> joeflateau: it seems to work for me (with the exception that I don't have an rtmp server so I can't answer the handshake)
[23:51] <c_14> grepper: is there a concrete problem or are you just wondering if there's an edge case you might miss?
[23:51] <grepper> c_14: yes, the latter. I know about image2 and {png,ppm,etc}_pipe , just wondering if there is anything I might miss with that
[23:52] <grepper> otherwise it seems to work well for the files I have tested
[23:52] <c_14> And that function is just for checking if it's a video or an image?
[23:53] <joeflateau> [NULL @ 0x3a66220] Packet header is not contained in global extradata, corrupted stream or invalid MP4/AVCC bitstream
[23:53] <joeflateau> [hls @ 0x3a656a0] Failed to filter bitstream with filter h264_mp4toannexb for stream 0 in file '/var/www/joef1/2100/playlist.m3u8' with codec h264
[23:53] <joeflateau> [mpegts @ 0x3a671c0] H.264 bitstream malformed, no startcode found, use the video bitstream filter 'h264_mp4toannexb' to fix it ('-bsf:v h264_mp4toannexb' option with ffmpeg)
[23:53] <joeflateau> av_interleaved_write_frame(): Invalid data found when processing input
[23:54] <joeflateau> that's with -flags +global_header
[23:54] <grepper> well, it assists with both image vs video checking, and also elsewhere to check if an output file is uncorrupted ... or just data ...  etc
[23:55] <grepper> I also test if its empty of course :)
[23:55] <joeflateau> when i move flags into [] I get:
[23:55] <joeflateau> [flv @ 0x40ff860] Codec for stream 0 does not use global headers but container format requires global headers
[23:55] <joeflateau> [flv @ 0x40ff860] Codec for stream 1 does not use global headers but container format requires global headers
[23:55] <joeflateau> [flv @ 0x40ff860] Unknown option 'flags'
[00:00] --- Wed Feb 18 2015

More information about the Ffmpeg-devel-irc mailing list