[Ffmpeg-devel-irc] ffmpeg.log.20150218

burek burek021 at gmail.com
Thu Feb 19 02:05:01 CET 2015

[00:04] <joeflateau> c_14: can you maybe send me the command you used that you said works? maybe there's something i'm overlooking?
[00:05] <c_14> `ffmpeg -re -i file -c:v libx264 -c:a aac -strict -2 -f tee -map 0:v -map 0:a "[f=hls:bsfs/v=dump_extra,h264_mp4toannexb]playlist.m3u8|[f=flv:flags=+global_header:bsfs/a=aac_adtstoasc]rtmp://"' is what I used.
[00:06] <joeflateau> i'll give that a shot...
[00:10] <c_14> grepper: looks fine to me, not sure if there's a funky edge case though
[00:10] <joeflateau> c_14: nope...
[00:10] <c_14> joeflateau: same error?
[00:10] <joeflateau> yessir
[00:10] <Matador> Anyone want to help solve something ? :|
[00:11] <joeflateau> ffmpeg -re -i "rtmp://$2/live/$1" -c:v libx264 -c:a libfdk_aac -f tee -map 0:v -map 0:a "[f=hls:bsfs/v=dump_extra,h264_mp4toannexb]/var/www/$1/2100/playlist.m3u8|[f=flv:flags=+global_header:bsfs/a=aac_adtstoasc]rtmp://fso.dca.
[00:12] <joeflateau> [flv @ 0x3c25540] Codec for stream 0 does not use global headers but container format requires global headers
[00:12] <joeflateau> [flv @ 0x3c25540] Codec for stream 1 does not use global headers but container format requires global headers
[00:12] <joeflateau> [flv @ 0x3c25540] Unknown option 'flags'
[00:13] <c_14> joeflateau: no idea, you can always try something like: `ffmpeg -re -i file -c:v libx264 -c:a aac -strict -2 -f matroska -map 0:v -map 0:a pipe:1 | ffmpeg -i - -map 0 -c copy -f hls -bsf dump_extra,h264_mp4toannexb playlist.m3u8 -map 0 -c copy -f flv -flags +global_header -bsf aac_adtstoasc rtmp://ip' though
[00:13] <c_14> Matador: what's the problem?
[00:14] <joeflateau> c_14: thanks for trying
[00:15] <Matador> http://pastebin.com/H8a37b2c
[00:15] <Matador> Past duration 0.984367 too large
[00:15] <Matador> doesnt happen on my late 2014 ffmpeg build
[00:16] <Matador> but new builds for last 2+ months gives me this
[00:19] <c_14> Is it a problem, or just the warning?
[00:19] <Matador> the stream doesnt work properly
[00:19] <c_14> Does it destroy/mangle the output?
[00:19] <Matador> it does
[00:19] <c_14> mhm
[00:19] <c_14> Might be a regression
[00:20] <c_14> How precise can you get the point where it starts happening?
[00:20] <Matador> I just know the current build I have
[00:20] <Matador> like late 2014
[00:20] <Matador> and current one doesnt have it
[00:21] <Matador> so the one that works fine with same syntax
[00:21] <Matador> N-68076-gea38e5a
[00:21] <Matador> build Nov 28 2014, gcc 4,8,2
[00:21] <c_14> Do you remember the first build it didn't work with? Or is this the first new build you've tried with?
[00:22] <Matador> its one of the first new builds
[00:22] <Matador> I tried like a few weeks ago
[00:22] <Matador> same deal
[00:23] <Matador> So between Nov. and now something happened
[00:25] <c_14> Probably a regression. Open a bugreport on trac mentioning the error, with the output (and commandline), that it worked in Nov 2014 and doesn't as of a few weeks ago. If you can bisect to find the exact revision that would be very helpful as well.
[00:25] <Matador> ya would be nice
[00:25] <Matador> I'm going to try some things
[00:25] <Matador> I saw I am using -f dshow
[00:26] <Matador> but I see there is a possibility of using -- -f decklink "Intensity Pro"
[00:26] <Matador> not sure if that will help
[00:56] <rlc> Has anyone dealt with black levels getting washed out (lifted up to grey) when transcoding mjpeg to h.264?
[01:05] <Matador> http://pastebin.com/quiVK23s
[01:05] <Matador> might solve issue by using actual format for the card
[01:05] <Matador> Really hope so :)  working on it :)
[01:06] <spaam> ntsc :(
[01:08] <troy_s> rlc: Scaling should autoset
[01:09] <troy_s> rlc: Probably easier to diagnose with command line.
[01:14] <Matador> seems to work so far
[01:27] <rlc> troy_s: http://pastebin.com/wQaYfM4j
[01:27] <rlc> troy_s: command line is: ffmpeg -i ramp.mov -pix_fmt yuvj420p -c:v libx264 -color_range 2 -crf 20 -profile:v ba seline -level 3.0 -vendor ap10 -movflags +faststart -b:a 128k ramp-h264-yuvj420p-cr2.mov
[01:29] <troy_s> rlc: Color range is probably wrong.
[01:30] <rlc> I have tried 0, 1, and 2
[01:30] <troy_s> rlc: then remove it.
[01:30] <rlc> I assume because my input is full range 0-255 I should be using -color_range 2?
[01:30] <rlc> ok I'll try with no color_range specified
[01:30] <rlc> thanks
[01:30] <troy_s> rlc: 95% of encodes are not full range.
[01:30] <troy_s> rlc: To be REC-709, it must be broadcast scaled.
[01:31] <troy_s> rlc: So what you are telling it to do is use full range, aka take value 16 (8 bit) and map it to value 16.
[01:31] <troy_s> Hence offset
[01:31] <troy_s> rlc: if it is scaled proper content, you desire 16 mapped to 0.
[01:32] <troy_s> rlc: Very few formats are encoded full range. DSLRs come to mind, but there be other dragons too. (601 encoding weights for example on Canon footage)
[01:32] <grepper> c_14: thanks
[01:33] <rlc> troy_s: these are rendered frames out of a vfx pipeline, they are full range at this point but their end target is Rec. 709 for sure
[01:33] <troy_s> rlc: My mistake then.
[01:33] <troy_s> rlc: How are they encoded?
[01:33] <troy_s> rlc: I would encourage you to use the scale command (newer)
[01:33] <rlc> mjpeg in a QuickTime .mov
[01:33] <troy_s> rlc: God no.
[01:34] <troy_s> rlc: Encode from stills. QT is an abortion.
[01:34] <troy_s> rlc: Anyways, the encode command you are looking for is something like:
[01:35] <troy_s> rlc:  -vf scale="in_range=full:in_color_matrix=bt709:out_range=tv:out_color_matrix=bt709"
[01:35] <rlc> thank you I will give that a shot
[01:35] <troy_s> rlc: Don't quote me, but that should get you closer. Assuming of course that QT hasn't totally mangled the crap up, which it likely has.
[01:36] <troy_s> rlc: If you want a little more debugability, I'd encourage you to skip QT, dump to JPEG or whatever format you deem decent enough (JPEG is likely plausible with the DCT probably being almost a noop?) and encode direct.
[01:37] <troy_s> rlc: If you are _really_ interested, you can also dump direct YCbCr (via OCIO) and then use a raw encode.
[01:42] <rlc> The trouble is that one of the web-based client review tools that we have to deal with apparently uses a very basic implementation of QuickTime for playback.  My input ramp.mov is just an 8-bit ramp from 0-255 across the frame.  When I look at the input ramp.mov in RV, I see RGB 0,0,0 on the left and RGB 255,255,255 on the right.  If I open my input ramp.mov in QuickTime player, I see RGB 16,16,16 on the left and RGB 235,235,235 on the rig
[01:43] <rlc> After transcoding with ffmpeg (even trying your latest suggestion), QuickTime shows me RGB 22,22,22 on the left.
[01:44] <rlc> Ideally I would hit 0,0,0 on the left, but I'll settle for 16,16,16 in an h.264 at this point.  Honestly I just want to know where the lift is coming from in the first place :-)
[02:06] <troy_s> rlc: As I said, QT is a mess. But needless to say, if you encode and your player is showing 16-235, then it isn't interpreting the flags properly.
[02:07] <troy_s> rlc: So what I suspect the player is doing is showing full range? That would be utterly wrong, but gosh, hard to tell.
[02:08] <troy_s> rlc: Also note, QT might not be the sole issue here. GFX cards, if it is offloading to GPU, can also mangle ranges. Best test is to try alternate players from different lineages such as VLC and MPlayer.
[02:09] <troy_s> rlc: (Yes, you can actually have wrong scaling if you flip between say, Vimeo in a web browser page and fullscreen because the damn GFX cards are botching the scale.)
[02:10] <troy_s> rlc: Anyways... There is no reason you should be seeing double scaled values. That's just whack. Completely.
[02:10] <troy_s> rlc: Please try a still test pattern from JPEG or such, and see how mangled the two different encodes are.
[02:11] <troy_s> rlc: As a final point I just noted, perhaps the web browser's plugin is also mangled. So you have three lovely things to try and sort out. Good luck with that; GFx card, QT encode, QT decode, and possible browser plugin / color management. Yay.
[02:13] <troy_s> rlc: (If my last scale suggestion failed, then I can pretty much assure you that the encode is in broadcast range, so change the first parameter from full-range (unless from stills) to tv)
[02:16] <rlc> troy_s: Thanks.  For what it's worth I agree that QuickTime is a frustrating mess, but unfortunately it's an ingrained part of certain pipelines :-( and like you say, other players can properly read the color atom and display everything correctly (all of my encodes, even the "worst" ones with the most apparent lift when viewed in QT Player, look perfectly fine when viewed in RV).  I'll keep poking at it.  Thanks again for your help.
[02:17] <troy_s> rlc: Please try the input set to tv and see if the scale is correct in Qt.
[02:18] <troy_s> rlc: I wonder what RV uses for a backend library. Any license information in there that might hint that it is using ff or something?
[02:18] <rlc> RV uses ffmpeg for encoding I'm fairly sure
[02:18] <rlc> they use some alternative QT library (not from Apple)
[02:20] <rlc> I just tested with -vf scale="in_range=tv:in_color_matrix=bt709:out_range=tv:out_color_matrix=bt709" and I still get 22 on the left side of my ramp when viewed in QT player
[02:20] <troy_s> rlc: Is that standalone QuickTime nightmare or via the browser?
[02:21] <troy_s> I'm sure you can flag the damn thing manually. No clue what it is doing.
[02:21] <troy_s> Ridiculous junk.
[04:36] <k_sze[work]> This is getting stupid.
[04:36] <k_sze[work]> How do I make ffmpeg use a sensible time base when I specify -vsync drop?
[04:38] <k_sze[work]> Right now it's using a time base of 1/1200000 even though the stream is supposed to be 30 fps (and I explicitly pass -r 30 to ffmpeg)
[04:51] <troy_s> 30000/1001
[04:51] <troy_s> Base has to be small.
[05:04] <olivierrr> Hello
[05:05] <olivierrr> I'm having trouble feeding data into ffmpeg via stdin
[05:05] <olivierrr> 'pipe:: Invalid data found when processing input'
[05:06] <olivierrr> ` cat *.png | ffmpeg -y -i - -f image2pipe out.mp4 `
[05:16] <YaMoonSun> If I have a .jpg and .aac file in the same directory, and I want to add the two to a webm with 96kbps vorbis audio, how do?
[05:18] <YaMoonSun> Ah, nevermind, apparently I just needed to modify my code.
[05:37] <YaMoonSun> Olivierrr, what's the objective? What are you trying to make?
[05:38] <k_sze[work]> troy_s: I don't get it.
[05:39] <pzich> olivierrr: when passing in an image sequence from a stream you need to specify the image format, using "-vcodec png" in your case
[05:42] <troy_s> k_sze[work]: Why does the timebase bother you exactly?
[05:43] <k_sze[work]> Because it seems to completely mess up seeking.
[05:45] <k_sze[work]> Like, right now, the time code on each frame is completely in the wrong scale. I know my video is 30 fps, but if I seek to 0.1s, it actually ends up waaaaay past that.
[05:46] <k_sze[work]> dts and pts are incrementing exactly by 1, and the frame time code increments by 1/1200000 second, it seems.
[08:43] <YaMoonSun> If someone is trying to charge for an application that's utilizing ffmpeg, is that illegal?
[08:43] <relaxed> no
[08:44] <YaMoonSun> Seems like it would be, that's odd.
[08:48] <YaMoonSun> Is there a way to make a .gif in ffmpeg that isn't lossless? 4chan keeps denying my files
[09:10] <JEEBsv> YaMoonSun: LGPL and GPL do not stop you from selling software. In case of LGPL you are giving the user the freedom to replace the library (so you have to give the source code for the LGPL thing, and if it's statically linked you also have to give object files so the user can link it)
[09:11] <JEEBsv> in case of GPL you have to give out the source code for the whole package (GPL is like a virus)
[09:11] <JEEBsv> but in either case, you are still free to have the software cost money, you just have to give some freedoms to the user in order to abide to the license
[09:11] <YaMoonSun> GPL is far from a virus, lol
[09:12] <JEEBsv> well, it will infect your stuff so it's a common way to describe its effect
[09:13] <JEEBsv> of course, some people don't think of actually following the (L)GPL license, which is what ends up being an act of not following the license of FFmpeg
[09:15] <YaMoonSun> Ayy http://webmshare.com/play/rGoee
[09:15] <YaMoonSun> I just want my .gifs to work =/
[09:16] <Mavrik> hmm
[09:16] <JEEBsv> anyways, no idea on the gif thing but at the same time gifs can't be lossless and they are always lossless. first because usually your pictures do not fall into <X amount of colors> and secondly because after the palette has been made it just gets compressed, so it's always lossless afterwards
[09:16] <Mavrik> I'm wondering if Plex guys are actually violating GPL for ffmpeg
[09:17] <YaMoonSun> Well, I made a .gif from .webm in an instant using ffmpeg and it was lossless, and then I made another one using photoshop after converting the webm to x264 and it looked shit and was larger in size.
[09:18] <YaMoonSun> Camtasia is, and DVDVideoSoft
[09:18] <JEEBsv> well, we have ubitux who played around dithering algorithms for hours :P
[09:18] <JEEBsv> Mavrik: I think we have a plex dev in -devel, and IIRC they do follow the license (LGPL I would think)
[09:18] <Mavrik> ah
[09:18] <Mavrik> ok
[09:19] <Mavrik> still wondering why they can't manage to whip up a ARMv7 build.
[09:19] <JEEBsv> of course they don't separate their patches because someone up the chain doesn't want them to be easily applicable, but they still do release the full source code for their FFmpeg
[09:19] <JEEBsv> at least that's the view I got from the guy and him linking to an archive
[09:20] <JEEBsv> feel free to stalk the plesk guy and ask him directly of course :P
[09:21] <Mavrik> :))
[09:21] <Mavrik> Don't care enough really... might ask them if they need help recompiling it so I can get it to work on my NAS :P
[09:24] <YaMoonSun> The comparison between the two .gif files. The smaller one, I can't upload it to 4chan for idk what reason http://i.imgur.com/2iPo7SS.jpg
[09:30] <relaxed> 4chan accepts webm, so why fight with gifs?
[10:19] <Ders> is it possible that trying to add zeroes (0) to the ffmpeg encoder with stdout doesn't do anything? I need to delay my sound for a very small bit
[10:30] <termos> Is there a known memory leak in avformat_new_stream? Valgrid is telling me there's lost memory, even though I'm calling avformat_new_stream as well as avcodec_close on each of it's codecs
[10:34] <ubitux> < YaMoonSun> Well, I made a .gif from .webm in an instant using ffmpeg and it was lossless // no
[10:34] <ubitux> it definitely wasn't lossless
[10:34] <ubitux> unless you had a black and white aweful source you didn't rescale
[10:35] <ubitux> and even that with the default palette you'd need to be very lucky
[10:35] <ubitux> especially if you didn't use palettegen/paletteuse
[10:35] <ubitux> are you sure you encode a gif?
[10:48] <iksik> hmmm, i'm wondering... is it somehow possible to get 2 files info using ffmpeg and determine which one has better quality?
[10:48] <slvmchn> i was just wondering something along the same lines, something like ffprobe but to compare two files
[10:48] <slvmchn> suppose could just ffprobe both and diff
[10:49] <iksik> right, i'm using ffprobe to index files meta
[10:49] <iksik> but i'm not video expert, not sure which data can help with comparision
[10:49] <BtbN> If you manage to define "better quality" in a propper way
[10:50] <iksik> yeahh, no.. :D
[10:51] <iksik> for me 'better quality' just looks better haha, not sure how to translate it to file parameters
[11:01] <JamJams> Hi! Is it possible to have ffmpeg not write the Writing application metadata to files?
[11:13] <relaxed> JamJams: try -metadate encoding_tool=""
[11:13] <relaxed> er, -metadata
[11:15] <JamJams> relaxed nope still there :(
[11:16] <relaxed> -map_metadata -1
[11:18] <JamJams> I tried that as well it didn't work
[11:21] <JamJams> http://pastebin.com/3MKSzkt0
[11:22] <relaxed> where's the output?
[11:25] <JamJams> The output is meaningless as is the command line params, the options don't do what they should.
[11:27] <relaxed> it's not meaningless
[11:27] <JamJams> If you ran the same old command locally, it would produce the same result. That being the metadata is kept
[11:31] <JamJams> I'll have to edit the source code and correct the issue myself.
[14:41] <djems54> hello
[14:42] <djems54> I have a question about ffserver, to MP4 streaming (libx264 + libfaac). I get an error "moov atom not found" I do not solve
[14:42] <djems54> Does anyone can help me?
[14:50] <BtbN> mp4 cannot be streamed.
[14:50] <djems54> Ok
[14:50] <BtbN> It needs a global header, which is written to the end of the file. It can be optionaly moved to the beginning, but this is a post-processing operation.
[14:51] <djems54> I get to do it in post processing, but I could not find to do with ffserver live
[14:51] <djems54> Thank you for confirming that it is not possible
[14:52] <djems54> What are the alternatives for HTML5 player that does not support webm ? without flash :-)
[14:53] <djems54> (for live streaming)
[14:53] <djems54> (IE9+, Safari and IOS devices)
[16:38] <martindelille_> Hi! Is it possible to add a metadata to an audio file preserving the bitdepth (24bit)?
[16:38] <martindelille_> I tried ffmpeg -i input.wav -metadata timestamp="01:02:03:04" output.wav
[16:38] <BtbN> Don't recode the audio.
[16:39] <martindelille_> but the output is converted to 16bit
[16:39] <BtbN> -c copy
[16:39] <Ders> use -acedec copy. ffmpeg will give a warning on -c
[16:39] <BtbN> although it shouldn't encode wav at all
[16:39] <Ders> -acodec*
[16:40] <BtbN> Isn't -c copy a special case?
[16:40] <martindelille_> -c copy works!
[16:40] <Ders> Not that I know. I've been using -acodec and -vcodec for my commands. I've seen ffmpeg throwing warnings that -c is ambiguous
[16:41] <Ders> you could use -c:a of -c:v as well
[16:41] <martindelille_> -c:a copy works too :-)
[16:42] <Ders> great :)
[16:44] <martindelille_> I think -c:v and -c:a are the new shortcut for ffmpeg codec specification
[16:45] <Ders> probably, -acodec and -vcodec are just aliases
[16:45] <Ders> for those two
[16:46] <BtbN> -c copy is in the main ffmpeg documentation
[16:46] <BtbN> i don't think it's wrong in any way.
[16:46] <BtbN> It's just a shortcut for "copy everything"
[16:47] <Ders> hmm. Okay then. I can't try it out right now but I'm sure that I had such a warning for something similar then
[16:47] <BtbN> "For each stream, the last matching c option is applied"
[16:47] <BtbN> So even combining -c something -c:a somethingelse is valid
[16:48] <Ders> good to know :)
[16:48] <Ders> sorry for correcting ;)
[17:25] <djems541> Hi! Is it possible to use ffserver as RTSP proxy? My source allows only RTSP streams at once, with ffserver I can stream the single stream to multiple clients ?
[19:06] <hanshenrik> so
[19:07] <hanshenrik> throughout the video, there's certain text at the middle of the video. the text is always there. i need to change the text
[19:07] <hanshenrik> it says "Cyber", i need to replace it with "Hell Kaiser Ryo"
[19:08] <BtbN> If the text is burned into the video, there is no way to remove the text, except for overlaying something that occludes it entirely.
[19:12] <hanshenrik> BtbN, yep that
[19:12] <hanshenrik> what you said
[19:19] <amalia> michaelni Will ffmpeg be participating in the OPW program this session ?
[19:20] <michaelni> if we find a sponsor to pay at least one slot
[19:21] <amalia> Last time you told there'll only be one slot but I saw 3 students selected
[19:22] <amalia> Were you leading me on ?
[19:22] Action: amalia thinks she was unfairly treated :(
[19:24] <hanshenrik> OPW?
[19:25] <amalia> yeah hanshenrik
[19:25] <hanshenrik> what is OPW?
[19:25] <c_14> Gnome's outreach program for women
[19:26] <michaelni> one slot was sponsored by samsung, opw later decided to fund a 2nd slot and we decided to fund a 3rd student
[19:26] <hanshenrik> c_14, gnome, the GUI thing?
[19:26] <hanshenrik> as in gnome.org ?
[19:27] <c_14> as in the GNOME foundation
[19:27] <c_14> Who do manage gnome.org, yes
[19:28] <hanshenrik> okay, so gnome host a "outreach program" for women.. reach out to what? for what?
[19:28] <hanshenrik> or, whom?
[19:28] <c_14> https://en.wikipedia.org/wiki/Free_and_Open_Source_Software_Outreach_Program_for_Women
[19:30] <hanshenrik> didn't know any1 kept tabs on the gender of people contributing code to open source projects, buuut should come as no surprise that males are the majority :o
[19:30] <amalia> hanshenrik to increase diversity in computing
[19:30] <hanshenrik> why does anyone care what gender the code contributors are?
[19:31] <hanshenrik> its the code that matters, not the gender of the code's author, i would imagine
[19:32] <amalia> hanshenrik People care bacause you've got a mother :)
[19:32] <amalia> s/bacause/because
[19:33] <hanshenrik> so, uh, when contributing code on git, i should add: ps, this code was written by a male
[19:33] <hanshenrik> as if that somehow matters? :o
[19:33] <ramiro> hanshenrik: the reason is completely non-technical
[19:34] <hanshenrik> finally some logic
[19:40] <amalia> Humans are both rational (as you're) and emotional.
[19:45] <hanshenrik_> gotta wonder if my gf is rational... she want to marry me!   hmm, nope, defintely not rational
[19:48] <DelphiWorld> hi ffmpegsters
[19:48] <DelphiWorld> Stream #0:0: Video: png, rgb24, 1196x672 [SAR 2834:2834 DAR 299:168], 25 tbr
[19:48] <DelphiWorld> , 25 tbn, 25 tbc
[19:48] <DelphiWorld> can this img be a cover art?
[19:48] <DelphiWorld> according to size
[19:56] <klaxa> why shouldn't it?
[20:00] <shakar> Hi, can someone please clarify a licensing question? If my company wants to use ffmpeg compiled with faac support to encode videos that it charges for access to, is that a license violation? Are we supposed to pay somebody? License rules are hard for me.
[20:02] <ramiro> shakar: if you don't distribute the ffmpeg binary, then it makes no difference whether you use faac or not (regarding ffmpeg's license)
[20:02] <JEEB> anything that needs --enable-nonfree in the configuration is something you can't distribute
[20:03] <ramiro> but you probably have to pay somebody for distributing aac content. we don't know about this either
[20:03] <JEEB> I think VIA licensing was handling AAC?
[20:03] <JEEB> no idea though
[20:03] <ramiro> the best answer we can come up with is "I think..."
[20:03] <ramiro> so, if in doubt, consult a lawyer =)
[20:04] <shakar> thanks. ramiro and JEEB
[20:04] <DelphiWorld> klaxa: i'm talking about size
[20:04] <JEEB> or ask MPEG-LA/VIA licensing about what licenses you need for distributing videos on the internet (or otherwise) that are not freely accessible
[20:04] <DelphiWorld> i dont know what's the recomanded sizes, klaxa
[20:04] <JEEB> that said, I agree that consulting a lawyer is a good idea
[20:05] <JEEB> DelphiWorld, cover art can be of any size, it should be tagged as such by lavf
[20:06] <DelphiWorld> JEEB: thank, my electronic eyes:P
[20:06] <DelphiWorld> JEEB: how to tag it?
[20:06] <JEEB> no, LAVF tags it :P
[20:09] <DelphiWorld> JEEB: explain...
[20:10] <JEEB> the video stream will have a tag in the API that notes that it is cover art
[20:10] <DelphiWorld> JEEB: ffmpeg -re -i JEEB.png -i JEEB.mp3 -map 0:0 -map 1:0 JEEB-NEW.mp3
[20:10] <DelphiWorld> is this way correct?
[20:10] <JEEB> I have no idea, I don't habla the cover art shit in the command line syntax
[20:13] <DelphiWorld> so if someone know tel me:P
[20:57] <c_14> DelphiWorld: https://ffmpeg.org/ffmpeg-formats.html#mp3 the second example
[21:11] <ristaloff> Hi! I'm trying to cross-compile ffmpeg for Raspberry pi model B. I followed the tutorial on this site: https://trac.ffmpeg.org/wiki/CompilationGuide/RaspberryPi . All is well until i try to run the ./configure command for ffmpeg. Then I get these warnings:
[21:11] <ristaloff> WARNING: /home/ristaloff/x-tools/arm-unknown-linux-gnueabi/bin/arm-unknown-linux-gnueabi-pkg-config not found, library detection may fail.
[21:11] <ristaloff> WARNING: using libx264 without pkg-config
[21:11] <ristaloff> Any tips? Setting the PKG_CONFIG_PATH does not help.
[21:14] <ristaloff> If I just disregard the warnings and run make && make install, the compiled ffmpeg will fail when trying to run it on the raspberry pi.
[21:38] <hanshenrik_> raspberry pi+ffmpeg, sounds like a good mix
[21:38] <hanshenrik_> the ultimate video encoding platform
[21:43] <BtbN> The rpi has a quite powerfull hardware encoder. But iirc ffmpeg can't use it.
[21:45] <JEEB> ahahahaha
[21:46] <JEEB> even with the hw video encoder you still have to deal with audio. and the last I saw the cpu on the first rpi couldn't even handle that by itself without doing /anything/ with the video
[21:46] <JEEB> that said
[21:46] <JEEB> rpi2 looks alright'ish
[21:51] <ristaloff> I was only going to use ffmpeg to convert the raw h.264 output from raspivid to mp4.
[23:01] <jabackes_> hello everybody
[23:03] <jabackes_> is there anybody that might have a way to extract audio that sits as two discrete tracks in a file and output that to two separate files? i can only ever seem to have one track output
[23:03] <c_14> ffmpeg -i file -map 0:a:0 out1 -map 0:a:1 out2
[23:03] <jabackes_> is it really that easy?
[23:03] <c_14> yes
[23:04] <jabackes_> i had been looking at the map command and didnt think that was what i was wanting (everything i was seeing said it was to map to a singular file in and then out)
[23:04] <jabackes_> i will try that right now. and that just passes through the audio/converts is with whatever .extension i feed it? input is a .mov, tracks are already AAC so i would use .m4a
[23:05] <kepstin-laptop> if you want to copy the audio without re-encoding, us -c:a copy (on both output files)
[23:08] <jabackes_> like this (repeating the -c:a for track 2)? ffmpeg -i file -c:a:0 copy track1.m4a
[23:11] <jabackes_> for the record, c_14, your's works great, while it re-encodes the audio (i don't care and ultimately it sounds as good as source for me) it does what i was hoping to do
[23:13] <c_14> jabackes_: ye, just like that, though you can leave off the :0
[23:14] <jabackes_> c_14: okay, assuming the program will just guess at the audio streams and assign each in order of the operations on the command?
[23:16] <olivierrr> cat ./frames/*.png | ffmpeg -y -c:v png -f image2pipe -i - -c:v libx264 out.mp4
[23:16] <olivierrr> What's wrong with that :L
[23:19] <jabackes_> c_14: the copy command i just tried just made two copies of the first track.
[23:20] <jabackes_> ffmpeg -i file.mov -c:a copy copytrack1.m4a -c:a copy copytrack2.m4a  that makes two files, but each one is the same content. (useful, but not desired)
[23:20] <olivierrr> log: http://pastebin.com/ErFSKaB7
[23:20] <c_14> You lost the map
[23:21] <olivierrr> c_14: me?
[23:21] <jabackes_> olivierrr: probably me
[23:22] <c_14> jabackes_:
[23:22] <c_14> olivierrr: you're using avconv from libav, either use ffmpeg from FFmpeg, or ask in #libav
[23:23] <olivierrr> okay, downloading ffmpeg. (i thought they were very similar)
[23:28] <jabackes_> AH HA! got it! thanks c_14: and kepstin-laptop: i figured out how to nest your solutions (i promise my brain works... sometimes)
[23:28] <jabackes_> now to save that syntax for future use!
[23:33] <jabackes_> thanks for all of your help guys/gals/things
[23:50] <olivierrr> c_14: works on ffmpeg :-)
[23:50] <olivierrr> i guess i was using an old version of avconv
[00:00] --- Thu Feb 19 2015

More information about the Ffmpeg-devel-irc mailing list