[Ffmpeg-devel-irc] ffmpeg.log.20150219

burek burek021 at gmail.com
Fri Feb 20 02:05:01 CET 2015

[00:02] <olivierrr> c_14: any tips on using data URI base64 PNG's as input?
[00:03] <c_14> not really
[00:04] <olivierrr> Alright, thanks again c_14
[00:04] <olivierrr> if anyone has some tips using URI base64 PNG's please let me know :-)
[01:32] <NoNet> When using ffmpeg, how do I formulate the option to copy all attatchments from input to output? From the documentation, I thought this would work, but it doesn't =>   ffmpeg -i input ..  -c:t copy  .. -o output
[01:33] <c_14> Did you map them?
[01:35] <NoNet> No - I didn't think mapping was needed in this case. I haven't needed mapping before because I've only been downscaling. I take it I should start using mapping? (current command is: ffmpeg -y -i \[SallySubs\]\ Ryuugajou\ Nanana\ no\ Maizoukin\ -\ 01\ \[BD\ 720p\ AAC\]\ \[978DA9B1\].mkv -vf scale=854:480 -c:v libx264 -crf 20 -rc-lookahead 16 -weightp smart -c:t copy /pubroot/HB\ Test/\[SallySubs\]\ Ryuugajou\ Nanana\ no\
[01:35] <NoNet> Maizoukin\ -\ 01C.mkv)
[01:36] <c_14> add -map 0 or -map 0:t
[01:36] <NoNet> OK. Will try. Thanks.
[01:39] <c_14> Also, you can use :-2 in the scale to auto calculate the width or -2: to auto-calc the height if you don't want to specify it manually every time to preserve the aspect ratio
[01:39] <c_14> And you might want to copy the audio track if you don't need to reencodi it.
[01:45] <c_14> *e
[01:48] <NoNet> OK - I saw only :-1 and -1: for scale in the docs. Prolly read over it. -1 gives an error because it tells me width must be a power of 2 for libx264. That's why I was explicit in scaling. Didn't get beyond default in audio track yet. ;) Playing with -map now.
[03:08] <olivierrr> is it just me or is -thread 1 faster
[07:58] <DevMac> hola
[07:58] <DevMac> alguien me podria ayudar tengo una duda para transmitir hacia icecast con ffmpeg
[07:59] <DevMac> no consigo hacerlo me tira un error de "End of File" en rojo y no transmite :(
[08:08] <DevMac> hello help please¿?
[08:35] <mac2devm> hello
[08:35] <mac2devm> someone?
[08:35] <mac2devm> anyone around here?
[08:38] <mac2devm> ??
[08:39] <relaxed> mac2devm: we're waiting for you to ask a real question
[08:44] <mac2devm> yes thks
[08:44] <mac2devm> i need help bout how stream ffmpeg con c# but in sharp develop
[08:44] Action: mac2devm slaps relaxed around a bit with a large trout
[08:44] <mac2devm> thks
[08:45] Action: relaxed eats the trout
[08:46] <relaxed> that's a vague question, but maybe someone else will chime in
[08:46] <mac2devm> ok zorry
[08:46] <mac2devm> i am begin with ffmpeg
[08:47] <relaxed> ffmpeg is writen in c
[08:47] <mac2devm> and besides that ffmpeg gives me an error when transmitting in command line with icecast: // source: pwd @ server: port / pointmont "end of file"
[08:47] <mac2devm> and not be due
[08:48] <relaxed> written*
[08:48] <mac2devm> 1 sec
[08:49] <mac2devm> ffmpeg -i TierraDesiertoGrieta.mp4 icecast:/my/source:pwd at server:port/video3.mp4
[08:49] <mac2devm> this error, end of file :(
[08:50] <mac2devm> again with video3.ogg and again error :(
[08:50] <mac2devm> <relaxed>
[08:52] <mac2devm> who is my error in sintaxys?
[08:58] <relaxed> try testing with an mp3
[08:59] <relaxed> the man page says it should look like, icecast://[<username>[:<password>]@]<server>:<port>/<mountpoint>
[09:00] <mac2devm> yes
[09:00] <mac2devm> ok i am testing
[09:01] <relaxed> ffmpeg -i test.mp3 -map 0:a -f mp3 icecast://[<username>[:<password>]@]<server>:<port>/<mountpoint>
[09:02] <mac2devm> again error
[09:02] <mac2devm> end of file error
[09:03] <relaxed> edit out your username/password
[09:03] <mac2devm> yes edit usernarm:pass, server, port, etc
[09:05] <relaxed> I don't have any experience with icecast, by the way
[09:06] <mac2devm> :8 funny
[09:19] <mac2devm> i cant :(
[09:22] <bencc> what is the lowest latency I can get with HLS and MPEG-DASH?
[10:14] <jeanre> hi all is there a way to speed up the seek on this command
[10:15] <jeanre> ffmpeg -i ' + filePath +' -s 192x168 -qscale 28 -vf "select=gte(n\\, ' + frame + ')" -vframes 1 -threads 10 /tmp/' + outputPath + ' -y';
[10:15] <jeanre> where the filepath is an http url
[10:15] <jeanre> it takes froever to seak
[10:16] <jeanre> s/seak/seek
[10:26] <ubitux> you can't seek to frame number
[10:27] <ubitux> you can fast seek to an approximate timestamp though
[10:27] <ubitux> and relatively fast to an exact one
[10:27] <ubitux> https://trac.ffmpeg.org/wiki/Seeking
[10:28] <jeanre> yeah I need the exact frame
[10:28] <jeanre> now the question is
[10:28] <jeanre> can I get ffmpeg to cache the file locally?
[10:29] <jeanre> e.g the first extract will be slow but subsequent commands are fast?
[10:29] <jeanre> @ubitux
[10:29] <BtbN> download it first?
[10:30] <jeanre> then I have to store it locally
[10:30] <jeanre> not enough storage
[10:30] <jeanre> its pulling from CDN
[10:30] <jeanre> its not super slow
[10:30] <BtbN> and how do you expect ffmpeg to cache it then?!
[10:30] <ubitux> depending on your input you can fast seek to like 10 sec before, and decode up to your frame
[10:30] <ubitux> see that page.
[10:31] <ubitux> but you have to target a timestamp anyway
[10:31] <BtbN> http isn't exactly a seek-friendly protocol.
[10:31] <jeanre> yeah I think the download will be the best way
[10:32] <jeanre> download should be fine
[10:34] <ubitux> BtbN: it's fine, range request works relatively fine
[10:37] <DelphiWorld> yo
[10:38] <DelphiWorld> if encoding to alac
[10:38] <DelphiWorld> is there any bitrate concideration?
[10:56] <jeanre> so this is more interesting
[10:56] <jeanre> ffmpeg -i /tmp/a2de4af8-b45e-4953-aad5-e2e800424ca2.mp4 -vf "select=gte(n\, 7792)" -vframes 1 /tmp/0a86d395-1e7e-4cf3-b65d-2262ca566c59.png -y
[10:56] <jeanre> that command is super slow
[10:58] <jeanre> @ubituxthats from local
[10:58] <jeanre> not even http
[10:59] <jeanre> and the seek is super slow, but I need it to be accurate
[11:00] <jeanre> 33 seconds to be exact
[11:16] <ubitux> the -ss 30 in input option and -ss 3 in output option
[11:16] <ubitux> then*
[11:25] <jeanre> I mean it took 33 seconds to extract the frame
[11:55] <ribasushi> hiya
[11:55] <ribasushi> keyint in 264/265
[11:55] <ribasushi> what is the actual unit? milliseconds? frames?
[12:43] <ribasushi> h no it seems it's actually amount of frames
[14:50] <termos> When muxing to smoothstreaming in ffmpeg I get playlists like <c n="18" d="100000000" /> for one segment. But when doing it using the library I get lines like <c t="14970000000" d="30000000" /> in the manifest. Is there some setting for getting n="" lines instead of t=""?
[14:51] <termos> I guess it's time dependant or segment number dependant
[15:52] <NoNet> I'm looking for a good example showing the transcoding of a group of VOB files (from mpeg2 to h.264) into a single mkv container. I've tried a number of things involving 'concat' and such but I appear to not understand what I'm reading. A simple working example will do.
[17:06] <fawick> hi
[17:38] <sine0> I have a really old MP3 player, that is just a flash drive/ usb key and holds 64MB. Im having trouble with it playing mp3 files, I wondered if there has been much change in the mp3 codec algo from back in the day and what would be the best bet to encode in?
[17:48] <Harzilein> sine0: still have the docs? is it chinese?
[17:49] <sine0> its ok I have fixed it
[17:49] <Harzilein> sine0: i think there are compatibility lists for "mp4 players". it's likely you are just exceeding its capabilities wrt bitrate/vbr
[17:49] <sine0> I broke it 10 years ago when i was still a nubian
[17:50] <sine0> i just formatted it properly and it works now.
[17:50] <sine0> my next step is to squash down my running mix to under 64mb lol
[17:50] <Harzilein> hehe
[17:51] <sine0> i have a big smart phone note2 and i cant run with it, but this is like a thumb drive it will be great
[17:51] <sine0> hmm 77MB at 128
[17:51] <Harzilein> yeah, i specifically asked my younger cousin for his "mp4 player" when he got his iphone, for similar reasons
[17:52] <sine0> is there a way I can set the output filesize and have it work out the bitrate
[17:52] <Harzilein> only problem is that it has _really_ shitty keypress detection i.e. not registering or not properly debouncing presses. but the other reason i got it was to program it in z80 assembly, maybe i can rectify it :)
[17:53] <Harzilein> dunno, i'd take a calculator and divide filesize/seconds
[17:53] <sine0> hmm asm
[17:53] <sine0> that was my first computer venture when i was 16. softice, hiew and win32asm
[17:53] <sine0> fun times
[19:10] <Blubberbub> Hello, i'm trying to stream aac+ to an icecast server using ffmpeg, but i have problems figuring out the right output format. I tried mpeg and mpegts, but these don't work.  :/
[19:18] <Ademan> sort-of off topic but can anyone recommend some good "intermediate" documentation of h264? If not I'm just going to read the libavcodec h264 code and/or the reference decoder. The ITU spec is a bit too mind-numbing for me for a "for fun" project
[19:18] <Matador> wont be those 2 Blubberbub
[19:18] <Matador> Blubberbub : https://www.ffmpeg.org/ffmpeg-protocols.html#Icecast
[19:18] <Blubberbub> Matador, yea, i figured, that these are mpeg2/3 and aac is kind of mpeg4, right? but what do i need to use then? simly 'aac' or 'mp4' or 'm4a' does not work
[19:20] <Blubberbub> when i use mp3 i can use mpegts - that works fine, so i think i got the 'protocol' setup correct. the problem is the output format (-f parameter)
[19:20] <Blubberbub> (i did set content_type to audio/aacp)
[19:20] <Matador> well ogg is one format you could use...
[19:21] <Blubberbub> i just tried 'adts' "ADTS AAC (Advanced Audio Coding)" and that appears to be working. there is not much documentation about that though
[19:22] <Blubberbub> i figured, that this could work because it has TS and AAC in it...
[19:23] <Blubberbub> so i guess i'm just going with that one... if someone can explain to me what that actually means - that would be awesome :D
[19:23] <Matador> was tryin to do a search and help you
[19:24] <Matador> I'm assuming its -f aac
[19:24] <Blubberbub> no, that does not work - i think because 'aac' is only demuxing and not muxing
[19:25] <Matador> gotcha
[19:25] <Blubberbub> (when running ffmpeg -formats)
[19:27] <Matador> ok cool mate.. good luck
[19:27] <Matador> I havent done icecast stuff in years
[19:27] <Blubberbub> thanks for trying to help me :)
[20:49] <NoNet> I go this: Data stream encoding not supported yet (only streamcopy) when I tried this: ffmpeg -y -i VTS_01_1.VOB -map 0 -c:v libx264 -crf 19 -c:a copy -c:s copy VTS_01_1_test-crf-A.mkv
[20:49] <NoNet> Unfortunately, I don't seem to 'get' why. Could someone enlighten me?
[20:50] <c_14> -c:d copy
[20:50] <c_14> You probably have a data stream somewhere in your source.
[20:50] <c_14> That ffmpeg doesn't know what to do with.
[20:50] <NoNet> OK. I'll try that.
[20:57] <NoNet> That was a little better but then it burped and complained that matroska only supports v, a and s. I've been trying to find examples of converting vob to mkv but not had any luck. I've given up on handbrake so I want to learn to do this directly.
[20:57] <NoNet> Any examples I can be pointed to?
[21:17] <NoNet> c_14: Thank you for your time. I was just reminded of 'mkvmerge' so I'll use that initially then convert/transcode to h.264 using ffmpeg. At some point, I still want to understand using CLI ffmpeg much better but I'm good for now. Again, thanks.
[21:55] <newbieF> Hi
[21:56] <newbieF> I'm using a command like this: ffmpeg -i merged.mp4 -i audio.mp3 out1.mp4 out1.webm to merge video and audio together and output both like mp4 and webm files
[21:56] <newbieF> the mp4 file looks very good
[21:57] <newbieF> however, the webm file loses a lot on video quality
[21:57] <c_14> https://trac.ffmpeg.org/wiki/Encode/VP8
[21:58] <c_14> Set at least low crf for the webm,  preferably also a bitrate, and -quality best or good
[21:59] <newbieF> aha so I need to play with the bitrate to get the desired quality, higher bitrate => better quality
[21:59] <c_14> pmuch
[22:01] <newbieF> ok great
[22:01] <newbieF> before I was merging only mp4 and it was fairly fast. now when I added the webm it takes like a lot of time to output :S
[22:02] <c_14> yep, libvpx doesn't support threading
[22:03] <newbieF> ughhh
[22:04] <newbieF> btw... I have also the audio file in aac
[22:05] <newbieF> will that speed up the conversion a little bit?
[22:06] <c_14> If you use -c:a copy in front of the mp4, you'll save yourself quality loss and some cpu cycles
[22:06] <c_14> (with the aac file, though actually ditto for the mp3)
[22:16] <newbieF> this webm conversion is like REALLY slow
[22:17] <newbieF> it took me ~1 min to convert it to mp4 before
[22:17] <newbieF> now it takes more than 7 mins for the webm
[22:18] <newbieF> May I describe the process I do?
[22:19] <newbieF> maybe you'll be able to find a spot where it can be improved
[22:20] <c_14> I just tested, and on my machine with my encoding settings libvpx takes 4 to 10 times as long as libx264 depending on encoding settings
[22:21] <c_14> The only way to speed up the vp8 encode is to drop the output quality, or to cut the video up into chunks beforehand, encode each of the chunks and then concat them
[22:22] <Nitori> I don't think libvpx uses threads
[22:22] <c_14> it doesn't
[22:23] <newbieF> hmmm
[22:23] <newbieF> well
[22:24] <newbieF> the input video is actually a merged video that consists of 9 smaller videos
[22:24] <c_14> merged as in concatenated?
[22:25] <newbieF> and those 9 videos are 2 types: 1st type is video created out of several images, 2nd type is static content so I can go preencode it as I like
[22:25] <newbieF> yes
[22:25] <newbieF> concatenated
[22:27] <c_14> In that case you can pseudo-thread the vpx encode process by encoding each of the "source" videos to vp8 and then concatenating them with the concat demuxer with -c:v copy
[22:28] <c_14> You could even do something like duplicating the video streams during the first encode and encoding one to h264 and the other to vp8, and then splitting them out into separate files in the concat phase
[22:31] <newbieF> aha
[22:31] <newbieF> I see
[23:05] <jthomas__> Good day!  Can anyone point me towards information about overlaying two different webcam streams to become one output stream?
[23:47] <kriskropd> hello, so today i discovered -metadata with ffmpeg - and this is great and all for my use-case, however im having trouble adding metadata to existing mp3 files that i simply want to add metadata to
[23:47] <kriskropd> what seems to happen when i add -metadata arguments with an input file and an output file of the same filename is only the first few seconds of the track is preserved and overwritten
[23:48] <kriskropd> is there a way to simply use ffmpeg to add metadata without trying to convert everything else? do i need to copy the audio track each time, perhaps?
[23:48] <c_14> yeah, don't do that
[23:48] <c_14> ffmpeg doesn't support overwriting input files
[23:53] <kriskropd> so i'll need to imply that audio tracks are copied and that a new file is generated, and then afterwards have the new file replace the old file - everytime
[23:53] <kriskropd> well okay then
[23:57] <c_14> That, or if you really only need to change the metadata, find a program/library that can in-place modify metadata.
[00:00] --- Fri Feb 20 2015

More information about the Ffmpeg-devel-irc mailing list