[Ffmpeg-devel-irc] ffmpeg.log.20150224

burek burek021 at gmail.com
Wed Feb 25 02:05:02 CET 2015

[00:10] <msmithng> are there any docs other than trac.ffmpeg.org/wiki/FATE that describe how to use FATE? Thats pretty high level and I was hoping for something a little more example(ish)
[00:13] <c_14> msmithng: https://ffmpeg.org/fate.html ?
[00:15] <msmithng> c_14: I guess I should have mentioned Ive been there too& point  being, Im using n2.4.2, pulling in an ts spts from a multicast source, streaming out and I eventually hit a conversion failed! error
[00:16] <msmithng> do you think that FATE would be something that could help me identify where the error is occurring?
[00:16] <LiaoTao> Mavrik, Just to be clear - the stuttering happens regardless if I choose 10, 30 or 60 as capture fps
[00:16] <msmithng> the error state is slightly sporadic
[00:16] <c_14> msmithng: probably not, do you have the full console output?
[00:16] <msmithng> sometimes I can keep a stream up for many hours& other times it will die fairly quickly
[00:17] <c_14> Might be corrupt input.
[00:18] <msmithng> hmm& I guess it could be. VLC plays the asset without any issue from the same subnet
[00:19] <msmithng> I do see errors like this before it will actually catch an i-frame
[00:19] <msmithng> [h264 @ 0x1df8e40] non-existing PPS 0 referenced
[00:19] <msmithng>     Last message repeated 1 times
[00:19] <Mavrik> LiaoTao, that honestly sounds like either capture or driver issue
[00:19] <Mavrik> but as I said, hard to say :/
[00:20] <msmithng> Ill grab the console output at the next failuer
[00:20] <msmithng> Im running valgrind against it now but Im guessing thats not going to give me any workable intel
[00:23] <c_14> probably not
[00:25] <msmithng> and& it just crashed
[00:25] <msmithng> hang on, Ill pastebin it
[00:37] <msmithng> c_14: had to sanitize it a little& http://pastebin.com/ZtSTG9aS
[00:38] <msmithng> the gist is that Im pulling in one input and outputing 4 individual variants
[00:39] <msmithng> using the same methodology while using a blackmagic intensity pro has worked without any issue for the last 2 weeks
[00:39] <msmithng> brb
[00:45] <c_14> msmithng: the fatal error looks to be '[h264 @ 0x5b9c6a0] no frame!', which is thrown when decoding h264 input
[00:54] <msmithng> I guess Im a little dense& what could be causing that?
[00:55] <msmithng> Im guessing a number of things
[00:56] <msmithng> Im just trying to wrap my head around troubleshooting it
[01:00] <Mugatu> Im trying to split a large mp3 into smaller chunks, in a way that is suitable for them to be later concatenated or queued for play back to back.  On every file past zero, I get a small amount of silence at the head of the split file.  (Roughly .040 seconds).  Not a lot, but audible.  Is there anything I can do differently?
[01:00] <Mugatu> Heres an example of the command Im using:  ffmpeg -y -ss 30 -i 'test.mp3' -t 30 -c copy chunk_000002.mp3
[01:01] <Mugatu> The next chunk would be -ss 60
[01:01] <c_14> msmithng: the input is corrupted in some way, not entirely sure what would cause that though
[01:03] <c_14> Mugatu: does it go away if you get rid of -c copy ?
[01:03] <Mugatu> c_14: nope
[01:04] <pzich> can you create a paste with the stream info from the input and output?
[01:04] <Mugatu> sure
[01:05] <Mugatu> pzich: http://pastebin.com/TU3ehqHk
[01:05] <Mugatu> Im so sorry - family issue, Ill be back in a bit.  I hate to leave :/
[01:08] <msmithng> c_14: are there any special techniques to be applied when pulling spts/mpts from a udp address? failing either fifo_size or overrun_nonfatal?
[01:10] <msmithng> and which should be used on the input side? buffer_size or fifo_size?
[01:10] <llogan> Mugatu: http://lame.sourceforge.net/tech-FAQ.txt
[01:12] <msmithng> whoa, wait a minute&
[01:12] <msmithng> the section under udp says: Set the UDP receiving circular buffer size, expressed as a number of packets with size of 188 bytes. If not specified defaults to 7*4096.
[01:13] <msmithng> for fifo_size=units
[01:15] <msmithng> so its 28K by default?
[01:56] <Mugatu> llogan: thanks for the link - I suspect that may be my issue.  Very helpful.
[08:34] <iksik> morning
[08:35] <iksik> is there any good tool which can help with stress testing of HLS streams produced by ffmpeg?
[11:42] <pomaranc> is there any way to only decode and throw away the result?
[11:44] <JEEBsv> "-" (a single dash) as the output file name, and -f null
[11:44] <pomaranc> -f null does encode
[11:44] <JEEBsv> but if you see it's raw video and audio, it decodes and leaves it as-is
[11:44] <JEEBsv> it's basically "does nothing after decode"
[11:45] <pomaranc> it throws away the encoded audio and video, not raw
[11:46] <pomaranc> I just tried it
[11:46] <JEEBsv> pastebin fill command line and terminal output
[11:46] <JEEBsv> and link here
[11:46] <JEEBsv> *full
[11:47] <pomaranc> I can't
[11:48] <JEEBsv> anyways, all of the ffmpeg versions I've tested only decode and the "encoding" is just throwing raw video and audio etc at /dev/null
[11:48] <JEEBsv> so if you cannot note what the fuck you are using or I cannot check if you are misunderstanding the logs, then "fuck you" :P
[11:48] <pomaranc> well, I changed the preset in x264 and the cpu usage increased :)
[11:49] <JEEBsv> are you setting encoders etc?
[11:49] <pomaranc> yes
[11:49] <JEEBsv> well d'oh
[11:49] <JEEBsv> if you override shit of course it will do what you ask for
[11:49] <JEEBsv> just -f null should already default to raw video and audio, which means that no real encoding takes palce
[11:49] <JEEBsv> *place
[11:50] <pomaranc> I'm testing a full command line from a configuration file
[11:50] <pomaranc> so I would have to strip it off
[11:50] <pomaranc> I just wanted to know if I can disable it by adding some option
[11:50] <pomaranc> and not by parsing the command line
[11:50] <pomaranc> and removing stuff
[11:51] <JEEBsv> no, if you tell ffmepg to fucking use encoders X and Y then it fucking fucking uses that
[11:51] <JEEBsv> it does exactly what you ask for, and if you need something else you set something else (and the defaults for -f null should be fine for "I don't want shit to be encoded")
[13:45] <madin60> Good morning
[13:45] <madin60> I'm trying to get subtitlle with a mp4 file but I can't use the -c:s mov_text option
[13:46] <madin60> when I look for the codecs , it seems that mov_text has no D and E letters
[13:47] <madin60> How can I get this capicity?
[13:47] <madin60> capacity
[13:57] <madin60> No answer
[13:59] <sekon> madin60: Good afternoon
[13:59] <sekon> i would suggest being a little more patient
[13:59] <sekon> and i have problems understanding your question
[14:00] <sekon> you could start with posting the output of ffprobe for that particular file
[14:00] <sekon> along with the command your are trying ( with console logs) to pastebin or other paste websites
[14:06] <madin60> I can't use the mov_text encoder with mp4 file
[14:06] <madin60> the ffprobe is here http://pastebin.com/0cC4knKT
[14:07] <madin60> and when I try the command ffmpeg -i 'La route d'Eldorado.mp4' -map 0:3 -c:s mov_text test.mp4
[14:08] <madin60> I get an error message 'Data stream encoding not supported yet (only streamcopy)'
[15:38] <eric_> Hey all, Now that we're not meant to use the stream->codec context for encoding, I'm still configuring the stream->codec with all the options, then creating a new context with avcodec_alloc_context3 / avcodec_copy_context / avcodec_open2, but do I still need to open the stream context ?
[15:42] <minos__> me have a broken screencast are your interested? audio isn't in sync with screen ...
[16:23] <cytec_> hi there, was anyone able to compile ffmpeg for armv7 or better said armada*? i always getting an undefined reference to ff_get_cpu_flags_arm like this
[16:23] <cytec_> ffmpeg-2.1.1/libavutil/cpu.c:57: undefined reference to `ff_get_cpu_flags_arm'
[16:58] <t4nk211> hi all
[16:59] <t4nk211> I have a codec challenge for some of you :P
[17:00] <t4nk211> I am working on hevc stream, I wanted to out my ffmpeg command with hvc1.1.4.L150.0 codec ... if some expert are here I will be glad :D
[17:00] <t4nk211> (i succeed to have hev1.1.6.L150.80,mp4a.40.2)
[18:14] <zumba_addict> hey folks, how do I record a lossless recording of my guitar or my daughter's piano?
[18:30] <klaxa> zumba_addict: ffmpeg -i <input> -c:a flac recording.flac
[18:30] <klaxa> if you are using pulse for example: ffmpeg -f pulse -i default -c:a flac recording.flac
[18:30] <zumba_addict> thanks klaxa. I should have been detailed
[18:30] <zumba_addict> do I need a special mic?
[18:31] <klaxa> if you can connect the guitar or the piano directly (through cables) you won't need a microhpone at all
[18:31] <zumba_addict> got it
[18:31] <klaxa> otherwise you will need a pretty good microphone if you want it to sound good
[18:31] <zumba_addict> i'll be able to connect my guitar directly but not my piano, it's an old one
[18:33] <klaxa> i play saxophone myself, i recently bought a microphone for ~100¬ this is the quality you can expect: http://dedi.klaxa.eu/public/sax_test.flac
[18:33] <klaxa> it's a usb-microphone
[18:33] <klaxa> getting better hardware will result in better quality (generally at least)
[18:36] <klaxa> if you want advice on that it will probably be best to go to a local music store and ask for help
[18:37] <cytec_> damn... this reference error sucks -.- tryed different options/switches for 3 hours now and still not closer to compiling :/
[19:55] <HebusLeTroll> Hello. With x264, do presets impact quality when using CRF mode without setting max bitrate ?
[19:55] <c_14> no
[19:55] <c_14> just filesize
[19:55] <JEEBsv> presets affect the result of crf
[19:55] <JEEBsv> which is both visual quaöity and filesize
[19:56] <JEEBsv> how much is a diff discussion of course
[19:57] <HebusLeTroll> ok thanks, and is there options that impacts only compression speed without impacting quality at all?
[19:58] <Mavrik> That wouldn't make sense.
[20:01] <__jack__> that will, see threading support (increase speed, same quality)
[20:01] <__jack__> (exception !)
[20:05] <ramiro> HebusLeTroll, if you disable asm optimizations, the image quality will remain the same, but the impact on compression speed will be considerable
[20:08] <HebusLeTroll> ramiro: you mean it will be faster with asm optimizations, right ?
[20:09] <JEEBsv> yes
[20:09] <__jack__> absolutely not : he means it can be slower without :) by default, it's almost all enabled
[20:10] <JEEBsv> yes, you actually have to tell the configure scripts of both ia32 and intel 64bit that you don't want asm
[20:11] <JEEBsv> becausr there's no reason really to not want it
[20:11] <JEEBsv> except for testing
[20:16] <HebusLeTroll> thanks again, i guess i'll have to be patient ^^
[20:26] <iive> to give a little bit more detail. generally quality is loss in the process of quantization. crf varies it based on a few parameters of the encode. but it would increase and decrease it around the value you specify.
[20:28] <iive> preset affect the features that are used for encoding. this on its own influence some of the parameters in crf.
[20:29] <iive> so, i'd say that presets might affect quality but it does so less than the -crf value.
[20:29] <iive> how much... jeeb can say :)
[23:16] <Trashlord> hey guys, I have an mkv files with multiple subtitle streams, how can I copy over all those streams to a new file? my TV doesn't support the file
[23:16] <Trashlord> I've tried -c:s copy, but that doesn't do it. it says it's copying the English subtitle stream, but when I play the finished file, there are no subtitles
[23:17] <Trashlord> when trying to convert from mkv to mp4, it doesn't work at all, says invalid parameter (IIRC)
[23:17] <Trashlord> from mkv to mkv, it'll perform the action, but then there are no subtitles
[23:32] <klaxa> use -map instead
[23:32] <klaxa> mp4 doesn't support .ass subtitles
[23:32] <klaxa> ffmpeg -i input.mkv -map 0 output.mkv
[23:32] <klaxa> that will copy all input streams
[23:35] <Trashlord> alright
[23:36] <Trashlord> what if I want to modify the audio codec, or a certain parameter in the audio codec, like -ab 192k?
[23:36] <Trashlord> won't -map override it?
[23:41] <Trashlord> hmm, seems to work so far, thanks klaxa
[23:41] <Trashlord> even though I have 6 cores and used -threads 0, the conversion rate is still very slow, only around 20 fps
[23:46] <klaxa> what
[23:46] <c_14> -map won't "copy" everything, it'll map everything. If you don't want to copy some or most streams, use -c copy and then explicitly set the codecs for the one's you want
[23:46] <klaxa> oh right, damn i forgot
[23:47] <c_14> ie: '-c copy -c:a:0 libopus' will copy all mapped streams except for the first audio stream which will be encoded using libopus
[23:54] <Trashlord> yes, I got that, thanks
[00:00] --- Wed Feb 25 2015

More information about the Ffmpeg-devel-irc mailing list