[Ffmpeg-devel-irc] ffmpeg.log.20150225

burek burek021 at gmail.com
Thu Feb 26 02:05:01 CET 2015

[03:37] <stormbytes> evening
[03:38] <stormbytes> i'm using ffmpeg-php v.6, with $movie = new ffmpeg_movie(String path_to_media) it works fine unless the path is 'https'
[03:38] <stormbytes> anyone know how to resolve that?
[03:46] <jeanre> why would ffmpeg not extract all the frames?
[03:47] <jeanre> it seems to stop at 35 seconds into the video
[03:47] <jeanre> its extracting 840 frames
[03:47] <jeanre> frame=  840 fps=175 q=24.8 Lsize=N/A time=00:00:35.03 bitrate=N/A
[03:47] <jeanre> video:26244kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: unknown
[03:47] <jeanre> but the video is over a minute long
[03:48] <jeanre> its like its ignoring some frames
[12:39] <poste9> Can anyone tell me if I get the muxing.c example and remove everything about audio, my pts and dts is gonna be correct? I think I am missing something since the   only thing left is
[12:39] <poste9> av_packet_rescale_ts(pkt, output_codec_ctx->time_base, output_stream->time_base); before av_interleaved_write_frame and decoded_frame->pts = ost->next_pts++;
[12:40] <poste9> the increment is after decoding input frame
[12:52] <poste9> also, can any of you guys recommend a book for a new adventurer at video compression?
[13:10] <JoshX_> Hello, Is it possible to get info about an mp4 file which should countain 1800 frames (60 seconds, 30fps) but only contains 1560 frames (240 frames missing, 8 seconds) to find out which frames are missing?
[13:10] <JoshX_> or to put it in other words, can i get a list of all the frames in the file with their start and end time and frame number for example?
[13:14] <c_14> JoshX: ffprobe -show_frames
[13:29] <intellidesk1> How do CCTV DVRs record 5 channel H264?
[13:36] <JoshX> that simple? :-D
[13:36] <JoshX> hang on
[13:38] <JoshX> well that is a promising start, now to find the gaps :)
[13:39] <JoshX> pkt_pts_time=59.627995
[13:39] <JoshX> pkt_pts_time=59.663997
[13:40] <JoshX> aha!
[13:40] <JoshX> a missing frame
[13:40] <JoshX> this could totally work!
[13:40] <JoshX> thanks!
[13:40] <ecraven> greetings :)
[13:41] <ecraven> I'm trying to recode a h264 to a lower-resolution lower-fps h264. I see some audio de-sync (just a fraction of a second, but enough to get lip-sync off). this *should* work, right? I'd just need to pass -vf scale=... and -r .. ?
[13:50] <c_14> ecraven: try using the fps filter instead of -r and aresample=async=1000
[13:51] <ecraven> c_14: thanks
[14:03] <poste9> I  am getting pkt_duration_time=0.033333 is there a efficient way to increase this?  I want my frame to have 0.3 and not 0.03
[14:04] <ecraven> c_14: seems to work fine, thank you very much!
[14:16] <poste9> nvm... I dont know whats going on... I have 30 fps duration 5 seconds... Im getting 150 frames! Nice.... but the speed of the video is like its fast forwarding
[14:17] <poste9> also when I play the video the bitrate is not the one I set
[14:37] <poste9> do I have to set the pkt_pos ? looks like thats my problem
[15:44] <poste9> can anyone pls help me make my pkt_size shrink ? when I record 5 seconds from camera using ffmpeg the pkt_size is x when I use my code its x * 4
[15:47] <poste9> actually setting the same bitrate it is x * 2
[15:52] <abTool> would like to know if ffmpeg on macOSX includes GPU (opencl) support automatically ?
[18:12] <ChocolateArmpits> I think I may have encountered a bug, why am I getting two mono outputs with this instead of one mono and one stereo? http://pastebin.com/4TgEVEhi
[18:13] <ChocolateArmpits> I have tried this one a few different Zeranoe builds 32-bit as well as 64-bit, same result
[18:15] <klaxa|work> can you add -ac 2 after -b:a 64k?
[18:15] <klaxa|work> and see if that yields the same result
[18:15] <ChocolateArmpits> It will output dual mono
[18:15] <ChocolateArmpits> Which is obviously not the original stereo
[18:16] <ChocolateArmpits> If I remove -ac 1 after -map [32a]:a then both outputs are stereo
[18:16] <klaxa|work> what happens if you move the mono output after the stereo output and specify -ac 1 there?
[18:16] <ChocolateArmpits> If I remove aresample filter, while the "-ac 1" is still there the second output is stereo
[18:16] <ChocolateArmpits> klaxa|work: same, both mono
[18:17] <ChocolateArmpits> There's probably some resampling conflict, because specifying sample rate through aformat also messes it up
[18:18] <ChocolateArmpits> while "-ac 1" is set for either output
[18:18] <klaxa|work> well i'm out of ideas, but it sounds like -ac has some sideffects
[18:19] <ChocolateArmpits> It's like it precedes the asplit filter somehow
[18:19] <ChocolateArmpits> Should I ask at #libav ?
[18:20] <ChocolateArmpits> specifying "-ar 44100" for each output rather than through aresample/aformat filter has no problems
[18:24] <c_14> Sounds a lot like -ac/the resample filter have side effects. I'd open a bug report on trac. It at least needs to be documented/fixed
[18:24] <foonix> im kinda lost with ffmpeg's keyboard interaction commands (c/C keys), i just need stop running encode on specified time (not using q to abort)
[18:24] <ChocolateArmpits> c_14: I haven't done this before, is there any short explanation on how to file it correctly ?
[18:25] <c_14> https://ffmpeg.org/bugreports.html
[18:25] <foonix> thinking about stopping x264 encode with stitchable option on some reasonable time and continue later..
[18:26] <ChocolateArmpits> c_14: Should I compile ffmpeg myself or will using latest Zeranoe build be sufficient ?
[18:26] <c_14> that'll be fine
[18:26] <ChocolateArmpits> k thanks
[18:26] <c_14> foonix: -t
[18:26] <c_14> that'll encode up to duration
[18:26] <c_14> then stop
[18:43] <kolix> hi guys
[18:44] <kolix> i need to "stream"  a remote mp4 file to _all_ mobile devices
[18:44] <kolix> what's a standard ffmpeg command that I can use to do this?
[18:45] <BtbN> mp4 isn't streamable. You can help it a bit by moving the moov atom to the front, but you can't do that when live-encoding.
[18:45] <foonix> c_14: still dont have idea howto achieve that, ie hitting C and: all 00:01:25.00 -t 5 does nothing
[18:45] <BtbN> I think the most widely used standard to stream to android and ios is HLS.
[18:48] <kolix> BtbN, what's another solution then?
[18:48] <c_14> foonix: why are you trying to use C ?
[18:48] <BtbN> Other than HLS? I don't think there is anything else.
[18:48] <foonix> c_14: when i hit help ? it looks it should serve my purpose
[18:49] <c_14> C only sends commands to certain filters, not to ffmpeg itself
[18:53] <foonix> ok, so thats no-way to stop running encode differently than using q ?
[18:53] <foonix> gracefully stop ofc :)
[18:54] <ChocolateArmpits> I think you can issue a command to let's say enable an overlay filter that would place a static image on top
[18:56] <ChocolateArmpits> Look into sendcmd, asendcmd  or zmq, azmq
[18:56] <foonix> ok
[18:56] <ChocolateArmpits> They are in the filter doc
[18:57] <abTool> ? does anybody know if ffmpeg in the macOSX binaries includes GPU (opencl) support automatically ?
[18:59] <c_14> check if the builds have --enable-opencl
[19:00] <c_14> You'll have to specify which opencl device to use with every command though
[19:02] <foonix> ChocolateArmpits / c_14: btw thx for fixing my wrong c/C idea..
[19:31] <mmance> Is there yet a standard compliance flag?
[19:38] <JEEB> mmance, output should be standards compliant (as far as it can be) by default, -strict experimental and such options enable features that might or might not be correct or contain hacks
[19:38] <JEEB> anything else should be a bug, basically
[19:42] <mmance> I am capturing raw video, was trying to go to ljpeg files, but seems the YUV is non-standard
[19:43] <mmance> the experimental option doesnt work
[19:43] <JEEB> feel free to go into details :P
[19:43] <mmance> [ljpeg @ 0x33e2180] Limited range YUV is non-standard, set strict_std_compliance to at least unofficial to use it.
[19:43] <mmance> thats my error
[19:43] <JEEB> yes, sounds like you're not supposed to be putting limited range YCbCr there
[19:43] <JEEB> post full command line and terminal output
[19:43] <JEEB> to a pastebin
[19:43] <JEEB> and link here
[19:44] <mmance> bmdcapture -C 0 -m 14 -F nut -o strict=experimental:syncpoints=none -f pipe:1 | avconv -strict experimental -r 2997 -vsync passthrough -y -i - -threads 4 -an -q 0 -f image2 -vcodec ljpeg "$filename-is/$filename_%05d.jpg"
[19:44] <ramiro> mmance, use ffmpeg instead of avconv, it has native support for directlink capture
[19:45] <mmance> man, I just got this to finally capture
[19:45] <mmance> like after a week of screwing with it
[19:45] <JEEB> post full terminal output to a pastebin
[19:45] <JEEB> and link here
[19:45] <ChocolateArmpits> c_14: Where do I get to attach a file? there's a checkbox...and that's it ?
[19:45] <mmance> http://www.fpaste.org/190429/42488995/
[19:46] <JEEB> thank you
[19:46] <JEEB> mmance, your input is limited range and ljpeg is supposed to only take in full range
[19:47] <JEEB> so using the -strict option on either side of the -i is not going to make your output compliant, it's going to force it to ignore the colorimetry restrictions :P
[19:47] <JEEB> (before -i = set the option for decoding, after -i = set the option for encoding)
[19:47] <JEEB> mmance, basically use some output that is OK with limited range YCbCr
[19:49] <mmance> hmm .. thats the thing the range is full.  There is a setting for it on the PS4
[19:49] <JEEB> well what is coming from the input is seemingly uyvy422 :P
[19:50] <JEEB> which would be limited range in the "legacy" colorspaces
[19:50] <mmance> thank you so much for your help
[19:50] <mmance> I will continue to play with it
[19:50] <mmance> I currently can't output to png, so I am going to play with getting that working and try that instead
[19:51] <JEEB> and that colorspace doesn't seem to have a J version, which would be the "legacy" full range option
[19:51] <JEEB> (in quotations because I think swscale still only functions "correctly" with the J ones regarding full range)
[19:51] <JEEB> (in quotations because swscale does not always do what you expect it to)
[20:07] <c_14> ChocolateArmpits: you probably won't need to attach a file since it's not input specific.
[20:08] <eFfeM> Hi, I have installed ffmpeg from ppa:mc3man/trusty-media but now I need libavutil-dev, I see the includes are in /opt/ffmpeg/include/libavutil but there seems to be no pkg-config or so, so configure does not find the lib, what is the best way to resolve this?
[20:17] <eFfeM> found it just changed PKG_CONFIG_PATH
[21:09] <mmance> I got png working now, had to recompile, but I can only get 7fps on my encoding now
[21:10] <mmance> i can do tiffs at 30fps no problem
[21:17] <mmance> http://www.fpaste.org/190488/24895467/
[21:18] <llogan> "avconv version 11.2, Copyright (c) 2000-2014 the Libav developers"
[21:18] <llogan> you're not using ffmpeg.
[21:20] <mmance> I didn't realize that there was a war going on.
[21:20] <mmance> I see now that I was misinformed on ffmpeg, I thought it was only avconv now.
[21:21] <kepstin-laptop> well, they're different programs/libraries with different features and bugs.
[21:21] <mmance> I know, but I see some controversy over how ubuntu approached the whole thing
[21:21] <kepstin-laptop> the ubuntu libav packages for a while shipped a program named "ffmpeg" with a misleading message, yeah.
[21:22] <mmance> can I compile and run it next to avconv or will I have to uninstall avconv?
[21:22] <kepstin-laptop> should install and work in parallel just fine.
[21:23] <llogan> mmance: it is confusing. their choice of names, and the various misleading "not developed anymore" and "deprecated" messages from Libav and then Ubuntu contributed to the confusion.
[21:32] <mmance> I am very pleased I can still have my working avconv setup and still mess with ffmpeg
[21:33] <mmance> I installed from binary
[21:33] <mmance> but now I can not get either of the tiff or png to work
[21:33] <mmance> http://www.fpaste.org/190492/14248963/
[21:35] <pzich> -r 2997 :O
[21:36] <mmance> the rate coming from the capture is 5994
[21:36] <mmance> but I want to capture at 2997
[21:36] <mmance> er encode
[21:37] <pzich> and you don't mean 29.97?
[21:37] <mmance> oh, ok
[21:37] <mmance> nope thats not it
[21:37] <llogan> don't you mean -r 30000/1001 or -r ntsc?
[21:38] <mmance> I dont know 2997 worked in avconv
[21:38] <mmance> I can try those
[21:38] <mmance> 29.97 doesnt work same error
[21:38] <llogan> 1.2.6 is old.
[21:38] <pzich> that may not be the only issue, but I'm pretty sure you don't want to generate almost 3000 images per second to disk
[21:38] <mmance> same error with all of those
[21:39] <mmance> ok, i will compile and retry
[21:39] <llogan> compile, or get a static build, or use mc3man's PPA.
[21:39] <mmance> that the jon sever ppa
[21:39] <mmance> that was
[21:39] <llogan> old branches
[21:40] <mmance> its on the ffmpeg.opg homepage
[21:40] <mmance> .org even
[21:40] <llogan> so is mc3man
[21:40] <llogan> the description mentiones that the severinsson builds are older for repo compatibility
[21:42] <mmance> ls
[21:43] <mmance> same error eith 2.5.4
[21:43] <mmance> http://www.fpaste.org/190499/97012142/
[21:44] <mmance> i also went through 29.97 ntsc 2997 and 30000/1001
[21:44] <llogan> your command is missing
[21:44] <mmance> bmdcapture -C 0 -m 14 -F nut -o strict=experimental:syncpoints=none -f pipe:1 | ffmpeg -r 29.97 -vsync passthrough -y -i - -threads 4 -an -vcodec png  "$filename/$filename_%05d.png"
[21:45] <mmance> same command
[21:49] <mmance> i cant even get ffmpeg -y -i - -vcodec png  "test/test_%05d.png" to work, same error
[21:49] <mmance> ramiro: you mentioned decklink support being built in, would that allow me to use ffmpeg direct and nix the bmdcapture?
[21:51] <mmance> looks like I have to compile to get decklink
[21:51] <mmance> ok, off to compile
[21:54] <ramiro> mmance, yes, that is it.
[21:54] <ramiro> you need the decklink sdk to build it. if you are on windows, you can get pre-built binaries from zeranoe
[21:56] <mmance> i have to redownload the sdk
[21:57] <mmance> on ubuntu
[21:58] <mmance> the link on BMD website is still broken
[22:00] <jbermudes> Is BMD's stuff pretty compatible with linux in general?
[22:01] <olivierrr> Getting 'libpng error: Write Error'
[22:01] <olivierrr> any ideas?
[22:03] <llogan> doesn't look like a message from ffmpeg
[22:04] <mmance> jbermudes: I thought they were, but it seems they drop the ball quite a bit because windows/mac is their main focus
[22:04] <jbermudes> mmance: I saw some discussion on their forums where people were requesting linux support for their usb3.0 capture box thingy and while the reps said that there is no target date, it was something they were considering and/or working on
[22:05] <jbermudes> So I guess it's hit or miss
[22:05] <jbermudes> Because I thought the intensity pro (or was it the decklink) was linux compatible from a sales rep I talked to a while back
[22:05] <mmance> their media express software only seems to sortof work
[22:06] <olivierrr> llogan: http://pastebin.com/TTWiDXYS
[22:06] <mmance> had lots of quarks, most people use bmdcapture or ffmpeg
[22:06] <olivierrr> i guess it could be phantom, let me check
[22:06] <mmance> I am using bmdcapture now and it has been rock solid
[22:07] <mmance> I am looking at ffmpeg to maybe reduce my file sizes
[22:08] <llogan> olivierrr: you forgot the ffmpeg console output, as per tradition
[22:08] <llogan> there must be something wrong with the message from fflogger because the console output seems to be omitted more than included
[22:54] <sweb> my timeout option dosnt work
[22:54] <sweb> ffmpeg -i 1.mp4 -timeout 5 2.webm
[22:55] <sweb> i need to tell ffmpeg dont convert file if convert time is more than 5 seconds
[22:55] <jbermudes> Could that be done with a separate monitoring script?
[22:57] <sweb> jbermudes: i dont get ! you say i run ffmpeg with special script ?
[22:57] <sweb> i run it directrly in terminal
[22:58] <jbermudes> sweb: No, I mean you have a separate shell script or something that either runs in a loop or gets called by cronjob every couple of minutes to convert files, but then it skips files longer than 5 seconds
[22:59] <jbermudes> But you first have to figure out how large of a file your computer can handle in 5 seconds. I don't think there's an exact algorithm that would tell you. You just have to use trial and error.
[22:59] <sweb> jbermudes: no it's the cli programm running when worker queue want to convert video
[23:00] <sweb> jbermudes: nope problem is i have limitation in my worker queue but ffmpeg take a long time to convert formats ... i need to tell ffmpeg if convert time is bigger than X sconds please dont convert it
[23:00] <onefix> I don't know if this would be useful to anyone else, but I wrote a perl script that uses an MPEG2 TS stream as input into FFMPEG and lets the user pick a "reduction" rate and it will resize the video to a dimension divisible by 4.
[23:03] <onefix> It's a script for TVHeadend that calls comskip.exe, cuts the program, then concatenates the files into a single file
[23:05] <jbermudes> sweb: Timeout might be an option for streams so they dont spend forever trying to reconnect. I can't find the timeout option on the ffmpeg man page right now for some reason.
[23:06] <jbermudes> sweb: There is a linux utility called timeout that you can use to abort any command given as an argument after so many seconds: https://forums.opensuse.org/showthread.php/484357-Need-help-on-use-of-timeout-utility-in-shell-script
[23:08] <onefix> Anyone know the status of H.264 Cuda acceleration for FFMPEG?  I've been wondering if it's even worth it...
[23:09] <iive> i thought opencl is preferred portable way for gpu acceleration.
[23:10] <onefix> live: Ok, but is it even worth it with say an 6-core 2.7GHz AMD Phenom II processor...
[23:14] <iive> i have no idea
[23:16] <onefix> The system doing the transcoding of these streams is functioning as a "headless" NAS box, so the only reason I would have to put in an OpenCL capable GPU would be to do h264 encoding
[23:17] <mmance> has someone compiled in ubuntu with decklink, I can't seem get it to make.
[23:17] <mmance> ./configure --enable-decklink --extra_cflags=-I/home/ubuntu/capture/bmd/Linux/include --extra-ldflags=-L/home/ubuntu/capture/bmd/Linux/include --extra-libs=-ldl
[23:17] <onefix> If I recall, from previous looks at OpenCL, software encoding was still preferred over hardware encoding
[23:25] <mmance> can someone look at http://ffmpeg.gusari.org/viewtopic.php?f=8&t=1789 and tell me if they mean to copy the entire output of make v=1 to a file and the sed remove and run that file?
[23:36] <c_14> I think so.
[23:36] <mmance> trying it now
[23:36] <mmance> will report back
[23:39] <iive> onefix: yeh, x264 devs say so.
[23:51] <mmance> c_14, no go on that, I left my findings in the forum however
[23:52] <c_14> You compiled it, right.
[23:52] <c_14> How are you executing ffmpeg?
[23:52] <c_14> ah
[23:52] <c_14> You probably have another ffmpeg in your path that is overshadowing the locally compiled one.
[23:52] <c_14> Try executing the local one with ./ffmpeg or /path/to/ffmpeg
[23:59] <Jesperhead> ffmpeg to stream to twitch. using -f alsa. can stream video with no problems. No audio though. Don't want to use pulse (or anything other than alsa for that matter). Cannot seem to find the correct way to "-i alsa"
[23:59] <c_14> -f alsa -i default
[00:00] --- Thu Feb 26 2015

More information about the Ffmpeg-devel-irc mailing list