[Ffmpeg-devel-irc] ffmpeg.log.20150226

burek burek021 at gmail.com
Fri Feb 27 02:05:01 CET 2015

[00:00] <c_14> probably
[00:00] <Jesperhead> c_14: thank you.
[00:00] <Jesperhead> worked
[00:00] <c_14> https://trac.ffmpeg.org/wiki/Capture/ALSA
[00:00] <c_14> For all the fun and games
[00:01] <Jesperhead> oh good stuff here
[00:07] <Jesperhead> c_14: default pulls in my mic fine, but nothing from the audio channels in my pc
[00:08] <Jesperhead> any tips?
[00:08] <Jesperhead> errr ill check that page first
[00:08] <c_14> The last section
[00:37] <llogan> Jesperhead: also see http://trac.ffmpeg.org/wiki/EncodingForStreamingSites for some basic VBV info
[00:39] <coeal> I am trying capture the screen of my macbook pro using the command "ffmpeg -f avfoundation -i "1" -pixel_format yuv420p test.mp4", as the recording begins the message "Selected pixel format (yuv420p) is not supported by the input device." What would cause this?
[00:41] <klaxa> displays use rgb, videos (for the most part) use yuv, is it a warning or an error?
[00:42] <coeal> error, it forces me to another format (uyvy422)
[00:43] <coeal> my end goal is to output a file immediately readable by quicktime when the ffmpeg process stops.  is my only option to then convert to yuv420p after the recording process has ended?
[00:45] <coeal> [avfoundation @ 0x7fc5c3026c00] Selected pixel format (yuv420p) is not supported by the input device.
[00:45] <coeal> [avfoundation @ 0x7fc5c3026c00] Supported pixel formats:
[00:45] <coeal> [avfoundation @ 0x7fc5c3026c00]   uyvy422
[00:45] <coeal> [avfoundation @ 0x7fc5c3026c00]   yuyv422
[00:45] <coeal> [avfoundation @ 0x7fc5c3026c00]   nv12
[00:45] <coeal> [avfoundation @ 0x7fc5c3026c00]   0rgb
[00:45] <coeal> [avfoundation @ 0x7fc5c3026c00]   bgr0
[00:45] <coeal> [avfoundation @ 0x7fc5c3026c00] Overriding selected pixel format to use uyvy422 instead.
[00:58] <klaxa> it should parse -pixel_format (or -pix_fmt) as an output option so it shouldn't even care about the input
[00:58] <klaxa> also, please don't paste in the channel, use pastebin or a similar site for larger pastes
[00:58] <klaxa> speaking of which
[01:06] <coeal> just as i was reading the pastebin i was about to post, i realized the problem was that it was telling me to use -pix_fmt and not -pixel_format. this fixed my problem. Sorry and thank you for being my rubber duck. :-)
[09:17] <jangam> hello developers
[09:20] <jangam> I am new to ffmpeg and on linux I want to play video on ffmpeg sever so what should be my steps to do it.
[09:38] <dsl420> 1. step: read the manual 2. step use google 3. shoot a command 4. if error pastebin command + output
[09:46] <relaxed> jangam: The two loeading formats for the web are https://trac.ffmpeg.org/wiki/Encode/VP8 and https://trac.ffmpeg.org/wiki/Encode/H.264
[09:46] <relaxed> leading*
[09:47] <relaxed> h264 and aac in the flv or mp4 container ^^
[10:22] <bencc> I'm trying to mix several audio and video streams and output HLS
[10:22] <bencc> the streams will be added and removed dyanmically
[10:22] <bencc> do I need to writea C app or can I use the command line?
[10:35] <shevy> I am a bit confused
[10:35] <shevy> I see an option such as:
[10:35] <shevy>   -pix_fmt gray
[10:35] <shevy> but I was told that this here should be the same:
[10:36] <shevy>   -vf format=pix_fmts=gray
[10:38] <_vaibhavingale_> am trying to transcode file from wav to different bitrates(320,128,64) along with metadata and albumart. Can I do it in single command? Am able to perform all these differently, but after transcoding, I have to trigger 2 seperate commands for metadata and album-art.
[14:47] <naschkater> Hi, I am trying to mux a video and an audiofile but I get "invalid data found when processing input" Error. here is the cli output: http://pastebin.com/Ge3cBATy any idea how to make it right?
[14:57] <c_14> Try updating your version of FFmpeg.
[14:57] <c_14> Or try with a static build
[14:58] <c_14> http://johnvansickle.com/ffmpeg/
[15:01] <c_14> Though, eh
[15:01] <c_14> The problem is that pcm isn't supported in mp4
[15:01] <c_14> You're going to have to use a format that isn't mp4, or reencode the audio to something mp4 supports.
[15:01] <naschkater> what would that mean? what format would I use? I am not bound to mp4
[15:01] <naschkater> ok
[15:02] <c_14> matroska
[15:02] <c_14> If the device that will be playing it supports it.
[15:05] <naschkater> yes, that seams to work! much thanks! :)
[16:09] <shevy> ffmpeg -flags +gray -i foo.avi grey.avi
[16:09] <shevy> hmm this does nothing?
[16:11] <slaan> Hi !
[16:15] <Ders> shevy what do you want it to do?
[16:15] <shevy> Ders I am trying to greyscale (get rid of colours) a video
[16:16] <Ders> hold on. I'm going to check something
[16:17] <Ders> try -flags:v
[16:17] <Ders> instead of regulr -flags
[16:17] <Ders> do you have any output from ffmpeg you could show me?
[16:19] <shevy> don't quite have any output to show for; I tried two different switches and ffmpeg encoded something (I think) but the resulting video was still colourized
[16:19] <shevy> I am recompiling ffmpeg right now, the old one did not have x264 support -  --prefix=/usr --enable-gpl --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libxvid --enable-nonfree --enable-postproc --enable-pthreads --enable-shared --enable-version3 --enable-x11grab --extra-libs='"-ldl"' --disable-libopenjpeg
[16:19] <Ders> ok. Let me know if it changed something
[16:20] <shevy> what should the commandline be, just so I know
[16:20] <shevy> ffmpeg -flags:vf -i foo.avi grey.avi
[16:20] <shevy> ?
[16:20] <Ders> just -flags:v without the f
[16:20] <Ders> well... hold on
[16:21] <slaan> Hi ! Did you know if it exist an equivalent option as "-preset ultrafast" with ffmpeg 2.5.4 ? Or how can i do a very fast encode ?
[16:21] <Ders> to get your video to be grey: ffmpeg -flags:v +gray -i foo.avi grey.avi
[16:21] <Ders> that should be it
[16:21] <shevy> ok
[16:21] <Ders> if that doesn't work you'd have to get me some more information
[16:22] <Ders> doesn't that still work slaan ?
[16:23] <slaan> non, i got an error :
[16:23] <slaan> Unrecognized option 'preset'.
[16:23] <slaan> Error splitting the argument list: Option not found
[16:23] <c_14> slaan: -preset is a valid option
[16:24] <slaan> okay, thx
[16:24] <Ders> yeah I thought so too
[16:28] <slaan> okay, i test 2 thing, one with "-preset" and one with "-pre:v" and i got this :
[16:28] <slaan> http://paste.ubuntu.com/10430584/
[16:29] <slaan> and i can't find ant preset name within my ubuntu with "ultrafast" anywhere
[16:31] <Zevv> Hi; I'm having issues with an embedded device using RTSP/multicase. The device requires me to specify the client_port in the Transport: header when using multicast
[16:31] <slaan> may i compile ffmpeg to have this presset ?
[16:31] <JEEBsv> slaan: libavcodec-extra
[16:32] <Zevv> this makes no sense to me, but from the RFC (2326) I'm not getting any conclusive info if the client_port is mandatory/optional/permitted for multicast
[16:32] <Zevv> anyone here with RTSP knowledge to give me some hints?
[16:32] <JEEBsv> otherwise x264 is not linked in
[16:32] <slaan> JEEBsv, okay, with the ./configure ?
[16:32] <JEEBsv> uuh
[16:33] <JEEBsv> you said ubuntu so I said the package name :p
[16:33] <JEEBsv> sorry, responding from a phone
[16:33] <slaan> :) okay, just install the package. No need to recompile ffmpeg ?
[16:33] <JEEBsv> uhh
[16:33] <JEEBsv> are you using your own ffmpeg?
[16:34] <JEEBsv> or packaged libav?
[16:34] <JEEBsv> (avconv)
[16:34] <Ders> you probably have to recompile ffmpeg with some more packages if you did that yourself in the first place slaan
[16:34] <slaan> i have compiled the last ffmpeg
[16:34] <slaan> okay
[16:34] <JEEBsv> ok then you need to compile GPL ffmpeg with libx264
[16:36] <slaan> so with ./configure --enable-gpl --enable-libx264 ?
[16:39] <slaan> Oh, a second question : Did you know if and how we can use hardware acceleration with a radeon R9 290 and ffmpeg ?
[16:39] <Ders> probably that should enable the right things (don't know the real command but it looks ok)
[16:39] <slaan> i can't find anything usefull on the net
[16:39] <slaan> ok, Thx Ders
[16:40] <Ders> I guess that it works on any gpu chipset. You just need to use the right encoder (that is what I understand from some quick google searches)
[16:41] <slaan> mmm, i don't find any example with radeon, still searching :)
[16:41] <slaan> thx
[16:42] <Ders> http://stackoverflow.com/questions/23289157/how-to-use-hardware-acceleration-with-ffmpeg
[16:42] <Ders> This might get you started I think
[16:43] <slaan> yeah, i have check that. it's a little hard to understand
[16:43] <slaan> but i will try
[16:43] <Ders> -hwaccel dxva2 should do the hardware acceleration with DirectX
[16:44] <Ders> http://ffmpeg.org/ffmpeg-all.html#toc-Advanced-Video-options
[16:44] <Ders> you can find it there
[16:44] <Ders> search for -hwaccel
[16:45] <slaan> mmm, and i have to install and configure DirectX on ubuntu
[16:47] <shevy> Ders I tried it
[16:47] <shevy> the video is still colourized
[16:47] <shevy> the original input video is: VIDEO:  [XVID]  608x256  12bpp  23.976 fps  750.9 kbps (91.7 kbyte/s)
[16:48] <shevy> Commandline I tried was: ffmpeg -flags:v +gray -i foo.avi grey.avi
[16:48] <klaxa|work> the kind of acceleration you are talking about right now is for decoding, you know that, right?
[16:48] <shevy> I read on the www that this might be a problem with the colourspace though or something, that sometimes it may not work because of a Y channel (or something... I understood only half)
[16:48] <Ders> weird. Try and get some ffmpeg output shevy . I don't really know what it could be without that
[16:49] <klaxa|work> encoding on GPUs is mostly limited to opencl stuff which is not really that much faster iirc
[16:49] <Ders> oh. klaxa|work I didn't know that
[16:50] <Ders> shevy yeah, frames can hold there data in different kinds of containers. For example, there's RGB, RGBA or something with the Y (can't remember :p )
[16:50] <Ders> I would be surprised though if ffmpeg doesn't take care of that for you
[16:50] <shevy> hmm
[16:51] <shevy> let me try on some other video
[16:51] <Ders> oh god, I made a there/their mistake...
[16:53] <shevy> hehe
[16:53] <Mavrik> Yeah, FFMpeg doesn't support the Radeon/nVidia built in encoders
[17:11] <slaan> Thx Mavrik for this info
[17:12] <slaan> mmm, i don't understand, when i try "./configure --enable-gpl --enable-libx264" i got : "ERROR: libx264 not found"
[17:12] <slaan> i don't understand
[17:13] <slaan> libavcodec-extra is ok
[17:13] <JEEB> config.log will tell you
[17:13] <JEEB> most probably you lack the libx264 development headers or something
[17:14] <slaan> but i have download the source here :https://www.ffmpeg.org/download.html
[17:15] <slaan> this make me crazy :)
[17:15] <slaan> i can't launch "-preset ultrafast" if libx264 don't here
[17:16] <JEEB> libx264 is a separate library
[17:17] <JEEB> "-preset" is an option specific to the libx264 wrapper in ffmpeg (and libx265 nowadays)
[17:17] <JEEB> to find out why libx264 was not found just pastebin config.log
[17:18] <JEEB> but I bet installing libx264-dev will most probably help unless your ubuntu is old
[17:18] <slaan> mmmm, i try with this package :)
[17:19] <JEEB> it contains the development headers, libraries and the pkg-config file
[17:19] <slaan> yeah, it's missing
[17:19] <JEEB> aka what you need to actually create a thing that uses libx264
[17:19] <JEEB> what?
[17:20] <slaan> sry, i'm french :) i have make a "sudo apt-get install libx264-dev"
[17:20] <slaan> .configure work now :)
[17:20] <slaan> thx
[17:20] <slaan> i recompile now  :)
[17:22] <slaan> i don't know why libx264-dev was not within ubuntu 14.04
[17:23] <JEEB> because you don't need it when you just use libx264?
[17:23] <JEEB> also it wouldn't be in it if you installed without format support for stuff that might require a license
[17:23] <JEEB> (I mean even the base libx264 package)
[17:27] <slaan> mm, i sse
[17:27] <slaan> see
[17:37] <slaan> okay, preset work now
[17:38] <slaan> but, lol, it's not faster than before, without libx264
[17:38] <slaan> 50fps now, for 80/90 before xD
[17:39] <slaan> mmm, ultrafast : 110
[17:39] <slaan> good
[18:09] <poste9> is h265 already better than h264 ?
[18:10] <JEEB> the format is better, the implementations are only better if you do both 1) very slow settings and 2) are aiming for very low bit rate scenarios
[18:11] <JEEB> or at least that was my decision from my testing in december
[18:12] <JEEB> at least with HEVC you can start using 10bit relatively easily since hardware solutions are supporting it \o/
[18:12] <JEEB> (although the format was in general improved from AVC so the gains from 10bit are somewhat smaller)
[18:13] <klaxa|work> i can't wait for the future!
[18:13] <JEEB> should do another round of testing soon'ish
[18:16] <poste9> Im building this streaming service where I cant send higher than 15kb/s  so... looks like I need hvec asap
[18:16] <JEEB> I guess that's in bytes so 15*8 kilobits
[18:17] <poste9> yep
[18:18] <JEEB> well at that point if you can limit yourself to specific software clients that should be OK
[18:19] <JEEB> of course if you are doing live streaming then it can get funky :P
[18:19] <JEEB> because libx265 (the least retarded implementation atm; not done by the x264 folk) is slow at the slower presets
[18:19] <JEEB> although I guess you're not exactly doing HD
[18:22] <poste9> 160x120 so nope
[18:22] <poste9> lol
[18:22] <poste9> what I need is rly higher compression
[18:23] <JEEB> so x264 isn't good enough even when you push the preset very, very slow?
[18:23] <JEEB> also have you tried the usual tricks of longer GOPs and stuff like that?
[18:24] <poste9> Im at the very beginning of it... atm looks like x264 is good enough
[18:25] <poste9> about a month ago I did my hello world at c++ using qt :P
[18:25] <poste9> but I learn fast
[18:26] <poste9> c->gop_size      = 250; should do the trick right?
[18:28] <JEEB> use whatever value sets it to libx264's infinite
[18:28] <JEEB> also setting the preset would be the first thing
[18:28] <JEEB> also what kind of service is this and what are the limitations?
[18:28] <JEEB> realtime encoding? encoding before hand and just pushing pre-encoded stuff out?
[18:29] <JEEB> is this for specific clients or needs to be hardware decodable with current stuff?
[18:32] <poste9> specific client. Im gonna capture stream from cameras(some raspberry or arduino project). They are inside ambulance cars and they are gonna send through 3G to a central server.
[18:33] <poste9> I will need to see this streaming live, but the quality and delay are not that important
[18:33] <JEEB> ok so the encoder side will be limited in cpu power
[18:33] <poste9> since I will have to record at a higher quality before sending
[18:33] <poste9> yep
[18:33] <JEEB> yeah, that sucks :P
[18:34] <poste9> but my boss is rich and I can ask for thousands of resources if needed
[18:34] <poste9> lol
[18:34] <JEEB> for rpi only the rpi2 is IMHO viable, and then there's f.ex. the minnowboard max
[18:34] <JEEB> minnowboard max would be quite sexy and in theory you could modify the board to be rather specific
[18:34] <JEEB> since it's open hardware
[18:35] <poste9> thats an execellent sugestion I will have my engineer look into this
[18:37] <JEEB> http://www.minnowboard.org/meet-minnowboard-max/
[18:39] <poste9> thanks
[19:07] <Popara> Hey guys, i have a ts stream that has many programs inside
[19:07] <Popara> How i can restream all of them using FFmpeg with the same structure, pid etc OR select one of them only?
[19:15] <Popara> Ok i found that using the -map 0:p:num will select the num program to be restreamed
[19:15] <Popara> however, how can i select all of them ? -map 0 is just messing all the codecs into one so its not an option
[19:36] <c_14> What do you mean messing all the codecs into one? Can you pastebin?
[20:30] <shevy> hmm first time I am seeing -strict experimental
[20:31] <shevy>  -strict experimental -vf "delogo=x=20:y=350:w=100:h=100:band=100:show=1"
[20:31] <JEEB> probably unrelated to the -vf part
[20:31] <JEEB> unless one of those filters is only enabled with it, but I would be surprised
[20:32] <JEEB> it basically puts FFmpeg into various hacks mode. mostly used for the lavc AAC encoder, which for whatever reason still needs that flag (even though it is better than libvo-aacenc for example, which is not needing of that flag)
[22:49] <msmithng> bummer& just hit this: https://trac.ffmpeg.org/ticket/2528
[23:03] <beaver> Why ffmpeg stop transcoding randomly?
[23:06] <beaver> -ss,00:00:00.00,-i,,-copyts,-sn,-vf,scale=trunc(iw/2)*2:trunc(ih/2)*&preset,ultrafast,-c:v,libx264,-c:a,libvorbis,-threads,0,-f,matroska,pipe:1
[23:11] <beaver> with gcc 4.8 (Debian 4.8.3-19) configuration: --enable-gpl --enable-version3 --disable-shared
[23:11] <msmithng> what error is it bailing out with?
[23:12] <beaver> --disable-debug --enable-runtime-cpudetect --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --disable-ffserver --enable-libass --enable-gnutls --cc=gcc-4
[23:12] <beaver> arf
[23:12] <beaver> msmithng: transcoding stops
[23:13] <msmithng> is that literally the error message?
[23:13] <msmithng> I cant say that Ive seen that one before
[23:15] <beaver> I have no error message transcoding stops in my video player
[23:15] <beaver> my options: 		args = ['-re','-i', 'pipe:0', '-sn', '-vf', "scale=trunc(iw/2)*2:trunc(ih/2)*2", '-c:v', 'libx264', '-preset', 'ultrafast', '-deinterlace', '-c:a', 'libvorbis', '-threads', '0','-f', 'matroska', 'pipe:1'];
[23:16] <c_14> First of all, you probably don't want -re, second -deinterlace is deprecated
[23:16] <c_14> Third, if we don't get some form of console output, we can't really help you
[23:17] <c_14> None of us (to my knowledge) are psychic
[23:19] <beaver> one minute please :)
[23:22] <beaver> c_14: http://paste.ubuntu.com/10437082/
[23:25] <c_14> And that's after it stops?
[23:26] <beaver> yes
[23:27] <beaver> after grep stderr: frame=  286 fps= 20 q=23.0 size=    4913kB time=00:00:12.24 bitrate=3286.6kbits/s  -> freezes daemon
[23:28] <beaver> it not transcode my file
[23:29] <c_14> Can you start ffmpeg with -report and then pastebin the 'ffmpeg-YYYMMDD-HHMMSS.log' file it creates? Just in case that has more information. Because I can't see anything explicitly wrong with that right now.
[00:00] --- Fri Feb 27 2015

More information about the Ffmpeg-devel-irc mailing list