[Ffmpeg-devel-irc] ffmpeg.log.20150227

burek burek021 at gmail.com
Sat Feb 28 02:05:01 CET 2015

[00:33] <Guest62704> I can't find a filter to convert ASS streams to hard-coded subtitles. I've tried the options available in https://trac.ffmpeg.org/wiki/HowToBurnSubtitlesIntoVideo but they seem to only work for ASS/SRT -> hard burned in the video stream
[00:44] <c_14> use the subtitles filter
[00:44] <c_14> with the source filename
[01:04] <Guest62704> I figured out my problem. -scodec doesn't support encoding to dvd_subtitle
[01:06] <c_14> There's an encoder for dvd_subtitle. Is the source text sub or picture subtitle?
[01:06] <Guest62704> the source is Substation Alpha (ASS)
[01:07] <c_14> ye, ffmpeg can't convert from text -> picture subs (afaik)
[01:08] <Guest62704> If I use another application to do the conversion, what picture subs format would I want the other application to output as for ffmpeg to recognize the stream?
[01:10] <c_14> Preferably the one you want to have in the output, but any format listed in ffmpeg -decoders | grep '^ S' should work (I can't recall off the top of my head which of those are picture and which are text though...)
[03:42] <haasn> In libavcodec, is it possible to PNG files with embedded gAMA and cHRM information?
[03:42] <haasn> to write*
[05:31] <DVJVOD> !rules
[05:31] <DVJVOD> #ffmpeg
[05:41] <pentanol> hello everyone,
[05:41] <pentanol> I've question about specify programm opening from .m3u8
[05:42] <pentanol> stream broadcasting fiew tv-programs, how an I open 1,5,11 of them?
[05:42] <pentanol> for instance this stream keep 2 programs http://alex-stream.rosebud-media.de:1935/live/alexlivetv.smil/hasbahca.m3u8
[13:12] <tyrolite> hi
[13:13] <tyrolite> I am unable to link a program(motion) with ffmpeg libraries
[13:14] <tyrolite> I've built ffmpeg with '--enable-libx264'
[13:15] <tyrolite> here are the linker errors: http://pastebin.com/G0Yj8aw3
[13:16] <tyrolite> I've tried to build ffmpeg with libx264 from Raspbian repository and a build of libx264 from latest sources
[13:19] <tyrolite> any clues?
[13:19] <Ders> You're probably missing something else in ffmpeg
[13:20] <Ders> Your ffmpeg command seems fine though ('--enable-libx264')
[13:20] <Ders> try adding --enable-gpl
[13:20] <Ders> to your ffmpeg compile command
[13:22] <tyrolite> I had that enabled in both builds
[13:22] <tyrolite> this is my ffmpeg config
[13:22] <tyrolite> ./configure --arch=armhf --target-os=linux --enable-gpl --enable-libx264 --enable-nonfree
[13:24] <Ders> hmm... I've never worked with Motion before. Do you need to link the libraries from x264 manually to motion perhaps?
[13:25] <Ders> -L/usr/local/lib <- like that but to your x264 lib folder?
[13:25] <tyrolite> I ran make install and libx264 is right there
[13:26] <tyrolite> ls /usr/local/lib | grep x264 libx264.a libx264.so libx264.so.146
[13:29] <Ders> I don't know how to fix it for you then :/ I'm sorry
[13:30] <Ders> I have no idea what might be wrong. If I have this kind of error in Visual Studio for example I'd presume that I didn't link my libraries correctly
[13:30] <Ders> That's all I can make of it
[13:33] <tyrolite> ok, thanks anyway
[14:05] <t4nk645> Hello ther
[14:05] <t4nk645> there*
[15:38] <selsta> i'll ask here too: is it normal that using libvpx inside a windows vm is way faster than using it natively on os x?
[15:41] <klaxa> no, maybe on osx you are encoding to vp9 and on windows to vp8?
[15:43] <selsta> i'm using the same command on both platforms, the output looks the same & both have the latest stable version
[15:44] <klaxa> huh
[15:44] <selsta> i get like 0.5fps on a 2014 mbpr
[16:18] <Demontager> Guys, could you help me to figure out how to get rid "rc buffer underflow" error while streaming webcam in ffserver ?
[16:19] <Demontager> Camera playing fine, but above error leads to high CPU load, I have 1.7 Ghz Single Core cpu and it is essential
[18:40] <msmithng> ugh& is there write ups on how to correctly create an MPTS file with ffmpeg?
[18:43] <msmithng> that is to say MPEG-TS
[18:44] <JEEB> if you want actually spec-compliant, you don't want libavformat's muxer, but rather something like OBE's muxing library
[18:45] <msmithng> OBE?
[18:45] <JEEB> open broadcast encoder
[18:48] <JEEB> libavformat can produce files kind of readable on various things, but IIRC kierank's muxer is actually something that goes through broadcast tests
[18:48] <JEEB> so if you meant the latter with your "correctly" wording, then that's the thing for the job
[18:48] <msmithng> fair enough& looking at the source now.
[18:49] <msmithng> cool. thanks!
[18:49] <msmithng> yeah, weve got a muxed version of bbb and Im dumping it onto the wire with vlc and while ffprobe doesnt have a problem, playback is another issue entirely
[18:51] <msmithng> however, I think the PS is incorrect. it seems that there are 24 individual indecies in a single PS
[18:51] <msmithng> which doesnt sound right
[18:52] <msmithng> http://pastebin.com/9LLjMJ2e
[18:52] <msmithng> does that look right?
[18:53] <msmithng> ;)
[19:58] <hjkjh> anyone know of a video editing tool for ubuntu, one that can help me focus on a licence plate?
[20:13] <haasn> When writing a PNG file with lavc, how can I add chunks like gAMA or cHRM?
[20:22] <haasn> JEEB: https://www.ffmpeg.org/doxygen/trunk/pixfmt_8h.html#ad4791ea14975f098b649db7fcd731ce6 seems to be missing a definition for AVCOL_TRC_BT1886 which is defined to be a pure power curve of 2.40
[20:23] <JEEB> I recommend taking this to #ffmpeg-devel
[20:24] <JEEB> since you're talking about development of stuff within FFmpeg
[20:29] <macmichael01> Is it possible to have ffmpeg encode audio such as LPCM or TrueHD into an mp4 container. If I recall correctly TrueHD and PCM is supported fro the mp4 container but ffmpeg does not. Wasnt sure if there a command to force this into the container.
[21:00] <poste9> hey I cant remember and I cant find it at google... do u guys remember the command to remove unused functions/libraries of my executable? (ubuntu)
[21:02] <poste9> figured it out, its "strip" btw.
[21:03] <JEEB> the stuff that removes is debugging information :P
[21:18] <c_14> macmichael01: use the mov muxer
[21:19] <macmichael01> whats that exectly?
[21:20] <c_14> -f mov
[21:22] <macmichael01> You are talking about the container? For constancy, Im seeking to encode all of my videos in the mp4 container. I dont particularly care about hardware support b/c VLC or plex will figure out how to play it regarless. Just an OCD thing.
[21:30] <c_14> mp4/mov are basically the same container. They just have some different tags.
[22:13] <Anom01y> Hi, I am trying to use the winFF tool to convert my AVI files to Mp4 ?
[22:13] <Anom01y> winFF does not show mp4 in the "convert to" dropdown,
[22:14] <JEEB> unrelated to ffmpeg itself
[22:14] <c_14> winFF isn't supported here, for help there's a mailing list mentioned on the homepage
[22:14] <c_14> *their
[22:31] <Anom01y> ok,
[22:31] <Anom01y> I found a way to fix it,  presets where not added,
[22:31] <Anom01y> however, I am getting an FFMpeg error now (via winff)
[22:32] <Anom01y> it says "unknown format libfaac"
[22:32] <Anom01y> unknown codec I mean
[22:32] <Anom01y> I am running Ubuntu 12.04, and I have this installed
[22:32] <Anom01y> libavcodec-extra-53
[22:33] <Anom01y> sorry for the bad question
[22:33] <c_14> Your version of ffmpeg probably wasn't compiled with libfaac support
[22:35] <JEEB> libfaac isn't GPL compatible so not surprising
[22:35] <JEEB> (it was found out that it was using reference implementation stuff which isn't compatible with GPL, thus the whole thing isn't GPL compatible)
[23:19] <diffuse> I've been using the ffmpeg C api and I am trying to figure out to further extend the AVIOContext I've created.  Currently i have a buffer that i malloc and contains content i want to run through ffmpeg...However, I have to av_malloc a buffer and memcpy the whole buffer in to get the AVIOContext to work.  Is there a way to simple use my malloced buffer instead of having av_malloc and memcpy?
[00:00] --- Sat Feb 28 2015

More information about the Ffmpeg-devel-irc mailing list