[Ffmpeg-devel-irc] ffmpeg.log.20151002

burek burek021 at gmail.com
Sat Oct 3 02:05:02 CEST 2015

[03:49:58 CEST] <t4nk879> hello
[03:51:00 CEST] Last message repeated 1 time(s).
[03:51:11 CEST] <t4nk879> I am building ffmpeg 2.8 with nothing disabled unless it's the default is that it's disabled
[03:51:24 CEST] <t4nk879> but there are many missing header files for libavformat
[03:51:29 CEST] <t4nk879> including network.h and rtsp.h
[03:51:35 CEST] <t4nk879> when I do an install after
[03:52:02 CEST] <t4nk879> it seems they are not copied over at all
[03:52:15 CEST] <t4nk879> even though the option to disable them had not been set
[03:59:38 CEST] <meh`> I'm having a hard time finding examples to generate and encode subtitles in a video using the library, could anyone point me to some?
[04:09:50 CEST] <SpootDev> t4nk879: doing install as admin/root/sudo/etc?
[04:29:51 CEST] <t4nk879> right now, root
[04:30:09 CEST] <t4nk879> and I think I found the issue
[04:30:42 CEST] <t4nk879> in libavformat/Makefile, it has this  in it
[04:30:45 CEST] <t4nk879> SKIPHEADERS-$(CONFIG_NETWORK)            += network.h rtsp.h
[04:31:13 CEST] <t4nk879> and CONFIG_NETWORK is set to yes in config.mak
[04:32:25 CEST] <t4nk879> so even though I have network enabled, it is not copying the headers because the variable SKIPHEADERS-yes includes those files and I think is supposed to not copy those files for some reason
[05:14:33 CEST] <t4nk879> ok so I found a way around it I think
[05:15:24 CEST] <t4nk879> add this to libavformat/Makefile right after the SKIPHEADERS- lines
[05:15:26 CEST] <t4nk879> HEADERS += $(SKIPHEADERS-yes)
[05:17:21 CEST] <t4nk879> and the same would have to be done on the other Makefiles like in libavcodec
[05:17:31 CEST] <t4nk879> are those files not meant to be used?
[08:51:09 CEST] <sopparus> hello, can ffmpeg make use of VCE (amd) for encoding these days?
[08:51:11 CEST] <sopparus> on linux
[11:19:07 CEST] <Jee> Hi guys :)
[11:20:14 CEST] <durandal_1707> Hi
[11:21:08 CEST] <Jee> I think i can ask for help here about ffmpeg integration in my project ? I'm a the good place ? :D
[11:21:26 CEST] <Jee> It's about G711 (PCM-ALAW) codec
[11:22:21 CEST] <Jee> Someone already tried to encode with this codec ?
[11:46:03 CEST] <durandal_1707> Jee: the encoding should be fine
[11:59:00 CEST] <Jee> Hum, actually i just found out that G711 codec is CODEC_CAP_VARIABLE_FRAME_SIZE, so the frame_size that avcodec2() should fill was 0, that bother me and make fail my algorithm. Now if i have CODEC_CAP_VARIABLE_FRAME_SIZE capability, i set a arbitrary frame_size of 10000. Seems to make the deal.
[15:40:57 CEST] <frenda> When I try 'ffmpeg -i input.ogg -strict -2 oupput.mp4' (oog-->mp4)
[15:41:07 CEST] <frenda> it reduce the quality of video
[15:41:10 CEST] <frenda> Oops
[15:41:17 CEST] <frenda> mp4 --> ogg
[15:41:45 CEST] <frenda> *'ffmpeg -i input.mp4 oupput.ogg'
[15:42:14 CEST] <DHE> what codecs do you expect? copying encoded video isn't the default
[15:42:51 CEST] <Mavrik> Yeah, that can't end well :)
[15:44:22 CEST] <dv_> I have a question regarding ffmpeg 2.8. gst-libav uses ffmpeg 2.8 internally (ignore the name confusion for now). in openembedded, this patch is applied against gst-libav: http://git.openembedded.org/openembedded-core/tree/meta/recipes-multimedia/gstreamer/gstreamer1.0-libav/workaround-to-build-gst-libav-for-i586-with-gcc.patch
[15:45:02 CEST] <dv_> as the commit message states, this was originally a fix in debian related to gcc 4.9.2's memcpy(). is this still relevant for ffmpeg 2.8? does anybody know more about this bugfix?
[15:45:26 CEST] <frenda> DHE > what codecs do you expect? --> default
[15:45:30 CEST] <frenda> -c copy?
[15:45:46 CEST] <dv_> err, memset, not memcpy
[15:45:52 CEST] <DHE> that will copy video as-is. very fast. not sure if .ogg will work but you can try it
[15:48:29 CEST] <frenda> '-c copy' didn't work
[15:48:34 CEST] <frenda> ERR: Could not write header for output file #0 (incorrect codec parameters ?): Invalid argument
[16:16:51 CEST] <alan01252222> hi all, hopefully a really simple question.. I'm getting this error from ffmpeg " Input format adts is not available" what flag do I need to enable in configure to get this to work? help greatly appreciated :)
[16:24:19 CEST] <DHE> has anyone successfully built ffmpeg with --enable-lto? I get errors in cabac.h. Running gcc-5.2.0 (gentoo built)
[17:02:04 CEST] <qpablito> hi I using FFmpeg version 0.6.5 and when i try to run "ffmpeg -i xxx.mp4 -vcodec copy -bsf:v h264_mp4toannexb teste.ts" had a error -> Unrecognized option 'bsf:v'
[17:24:24 CEST] <DHE> that's a very old version of ffmpeg...
[17:27:16 CEST] <iive> there is ffmpeg 2.8 at the topic :)
[19:08:35 CEST] <alan01252222> Hi everyone, anyone around who knows why ffmpeg would be giving me this "Error: Input format adts is not available" I know adts can be used as an input format because the codes working o my dev box, not on my staging server it's throwing this!
[19:09:17 CEST] <voice> same build?
[19:11:38 CEST] <alan01252222> using 2.8 on staging, dev running 2.7.1 ..
[19:12:13 CEST] <alan01252222> I'm trying to match all the configure flags now, not entirely sure which one is needed for that input format
[19:14:48 CEST] <voice> do a ./ffmpeg -version on the box with 2.8
[19:14:57 CEST] <voice> it should tell you the ./configure flags used
[19:15:47 CEST] <voice> sorry, misread, just do ./configure -version on the dev box :P
[19:16:16 CEST] <alan01252222> this is dev configuration: --extra-libs=-ldl --prefix=/opt/ffmpeg --enable-avresample --disable-debug --enable-nonfree --enable-gpl --enable-version3 --enable-libopencore-amrnb --enable-libopencore-amrwb --disable-decoder=amrnb --disable-decoder=amrwb --enable-libpulse --enable-libdcadec --enable-libx264 --enable-libx265 --enable-libfdk-aac --enable-libvorbis --enable-libmp3lame --enable-libopus --enable-libvpx --enable-libspeex
[19:16:27 CEST] <alan01252222> this is live
[19:16:29 CEST] <alan01252222> configuration: --prefix=/home/deploy/ffmpeg_build --pkg-config-flags=--static --extra-cflags=-I/home/deploy/ffmpeg_build/include --extra-ldflags=-L/home/deploy/ffmpeg_build/lib --bindir=/home/deploy/bin --enable-nonfree --enable-gpl --enable-version3 --enable-libx264 --enable-libfdk-aac --enable-libvorbis --enable-libmp3lame --enable-libopus --enable-libass --enable-avisynth --enable-libvo-aacenc --enable-libdcadec libavutil    
[19:16:49 CEST] <alan01252222> just going through trying to make live match dev... but it's never just that easy ;)
[19:17:26 CEST] <voice> let me ask you this, does it need to be a local build? :P
[19:18:16 CEST] <alan01252222> hmmmmm I guess not...
[19:18:56 CEST] <voice> I always had problems doing local builds which to me didn't make sense to do anyways unless you were trying to test out different builds/configurations
[19:19:28 CEST] <alan01252222> *nod* I think you're right, and to be honest I've wasted a bit too much time trying to get this to build...
[19:19:37 CEST] <alan01252222> thank you :)
[19:19:39 CEST] <voice> I'm sure thats not the right mind set to have but thats just what I do personally
[19:20:53 CEST] <martijnb> can't seem to get ffmpeg to take udp multicast as input
[19:21:09 CEST] <martijnb> don't see any join attempts on a tcpdump
[19:21:35 CEST] <martijnb> anyone spot anything wrong here;
[19:21:54 CEST] <martijnb> ffmpeg -i udp:// -codec copy -map 0 -loglevel debug output.mp4
[19:22:04 CEST] <DHE> martijnb: udp://   works just fine for me... make sure your routing table is correct if you have multiple NICs
[19:26:00 CEST] <martijnb> everything looks right, but maybe I've been staring at it for too long
[19:28:48 CEST] <martijnb> this can wait until monday, thanks DHE
[19:29:18 CEST] <martijnb> exit
[19:29:24 CEST] <martijnb> er.. irc isn't a terminal
[19:29:25 CEST] <martijnb> ;p
[19:29:49 CEST] <DHE> you want /quit probably
[19:30:21 CEST] <martijnb> yeah, I was shamelessly mashing exit closing terminals but irc snuck in
[19:30:39 CEST] <martijnb> have a good weekend gents
[21:57:06 CEST] <hwgasdfasdf> I'm trying to join a bunch of jpgs together into a video, and I'm using a command almost directly from the ffmpeg documentation, but it seems to only take the first frame like the glob isn't working
[21:57:28 CEST] <hwgasdfasdf> the command I'm using is: ffmpeg -framerate 2 -i %*.jpg -vf "crop=1296:988:0:1" -c:v libx264 test.mp4
[21:57:42 CEST] <c_14> Where is that in the docs?
[21:57:46 CEST] <c_14> That syntax is deprecated.
[21:57:49 CEST] <hwgasdfasdf> I've also tried putting quotes around the *.jpg
[21:57:52 CEST] <hwgasdfasdf> and omitting the %
[21:57:54 CEST] <c_14> use -pattern_type glob -f image2 -i *.jpg
[21:58:19 CEST] <durandal_1707> what are file names
[21:59:26 CEST] <hwgasdfasdf> filenames are like 20150930_1300.jpg 20151001_1300.jpg
[21:59:46 CEST] <hwgasdfasdf> c_14: I've tried that as well
[21:59:55 CEST] <hwgasdfasdf> no matter what I do, I only get 33 frames of video
[21:59:59 CEST] <hwgasdfasdf> and I don't see any errors
[22:00:39 CEST] <c_14> How many images are there?
[22:00:48 CEST] <hwgasdfasdf> roughly 160
[22:01:10 CEST] <hwgasdfasdf> and with an input framerate of 2, that should be a lot more frames of video
[22:02:02 CEST] <c_14> It should still be 160 frames. at 80s
[22:02:52 CEST] <hwgasdfasdf> is there a preferred pastebin to use here? I'll show the full output
[22:03:23 CEST] <c_14> Doesn't matter solang as it doesn't need weird js/has popups/whatever
[22:03:28 CEST] <hwgasdfasdf> shouldn't it be a lot more than 160 frames? 160 frames at 2 / sec * 25fps output (default framerate) is 80s * 25fps
[22:03:42 CEST] <c_14> The default framerate is the input framerate
[22:04:39 CEST] <c_14> Which in your case is 2
[22:06:43 CEST] <hwgasdfasdf> gah, stupid me... let's see what it does now...
[22:12:08 CEST] <hwgasdfasdf> also my fault, I think the first few frames were at half the resolution as the rest - that's why it was only encoding the first few before
[22:25:11 CEST] <hwgasdfasdf> ok, almost working
[22:25:25 CEST] <hwgasdfasdf> if I want to scale then crop, is that two separate -vf arguments?
[22:25:43 CEST] <c_14> -vf scale,crop
[22:26:07 CEST] <hwgasdfasdf> and how do I specify the arguments?
[22:26:15 CEST] <c_14> Same way you have before
[22:26:24 CEST] <hwgasdfasdf> doing it as two separate obviously didn't work - it only took the last one
[22:26:49 CEST] <c_14> -vf scale=x:y,crop=x:y etc
[22:27:09 CEST] <hwgasdfasdf> ok
[00:00:00 CEST] --- Sat Oct  3 2015

More information about the Ffmpeg-devel-irc mailing list