[Ffmpeg-devel-irc] ffmpeg.log.20151010

burek burek021 at gmail.com
Sun Oct 11 02:05:01 CEST 2015

[00:22:57 CEST] <wallbroken> http://pastebin.com/3GbkqKeH
[00:38:47 CEST] <yongyung> Not really an ffmpeg question, but I downloaded a video from YT and it uses 4:2:0 apparently. Do you guys think there's any value in uploading 4:4:4 content then (since they reencode the content) or nah?
[00:46:05 CEST] <chungy> I think some of the 1080p and 4K encodes from YouTube are available as 4:4:4, but I could be wrong
[00:46:44 CEST] <chungy> It's usually best to upload the highest quality you can manage. Not just because they re-encode, but YT also keeps the original files so it can update old videos with new standards.
[03:56:20 CEST] <yongyung> Can I somehow add motion blur/interpolate frames with ffmpeg so that the playback looks smoother? My source video has some micro jitter I'm basically trying to cover up. Sharpness isn't that nessessary, but smoothness is.
[04:56:07 CEST] <thebombzen> I had the same question before. Is it possible to interpolate frames?
[05:14:00 CEST] <wyatt8740> yongyung and thebombzen: this is basically what you want I think http://video.stackexchange.com/questions/13196/are-there-any-free-ways-to-increase-the-framerate-of-a-video
[05:14:19 CEST] <wyatt8740> I was going to suggest imagemagick because I don't think that's actually an ffmpeg filter atm.
[05:14:29 CEST] <wyatt8740> Maybe that would be a good feature request to put on the tracker?
[05:14:57 CEST] <wyatt8740> (I personally can't stand interpolated frames, but that doesn't mean it shouldn't be doable easily)
[07:05:04 CEST] <Prelude_Zzzzz> hey guys... 2 questions   ---> 1. is it possible to set ffmpeg to pull in a stream and never exit at all if stream has a problem. It will just sit and wait for it to come back. .. number 2 : i am using some transcoding and i have setup -minrate  1k -maxrate 5000k and -b 1500k .. i am not seeing huge jumps in the bandwdith when it is needed. Is there some param i am missing ot insure that VBR works correctly?
[07:12:20 CEST] <wyatt8740> I'd like to know too
[07:12:24 CEST] <wyatt8740> the first part anyway
[07:12:45 CEST] <Prelude_Zzzzz> well i am reading a bit about .. fifo_size=64000&overrun_nonfatal=1&buffer_size=10M&reuse=1
[07:12:59 CEST] <Prelude_Zzzzz> thinking the overrun_nonfatal part may be good for it
[07:13:19 CEST] <wyatt8740> fifo_sizes that big are, I think, what brought my computer to a halt the other day
[07:13:22 CEST] <wyatt8740> :\
[07:13:31 CEST] <wyatt8740> something did and it sure felt like  I ran out of RAM
[07:14:00 CEST] <Prelude_Zzzzz> :)
[07:14:15 CEST] <Prelude_Zzzzz> know anything about the second part ?
[07:14:34 CEST] <wyatt8740> I actually did an answer on superuser about minrate and maxrate a while back
[07:14:40 CEST] <wyatt8740> but I forgot what I said. Lemme look that up
[07:15:01 CEST] <wyatt8740> http://superuser.com/questions/945413/how-to-consider-bitrate-maxrate-and-bufsize-of-a-video-for-web
[07:15:06 CEST] <c_14> Prelude_Zzzzz: that's average bitrate mode, not variable bitrate mode
[07:15:51 CEST] <wyatt8740> the paragraph beginning 'If your maxrate is 640kbps' is the one that explains how you should set bufsize
[07:16:02 CEST] <wyatt8740> oh, he did say VBR didnt he
[07:17:56 CEST] <Prelude_Zzzzz> yup i tried all that already :(
[07:17:59 CEST] <Prelude_Zzzzz> still doesn't like me
[07:18:11 CEST] <Prelude_Zzzzz> jumps but not up to 5Mbit/s when needed
[07:19:46 CEST] <c_14> Well, of course. If it did it would have to drop down to 1k for about forever to compensate.
[07:19:50 CEST] <wyatt8740> it won't jump instantaneously.
[07:20:05 CEST] <wyatt8740> maybe you need to manually insert a keyframe?
[07:21:01 CEST] <wyatt8740> (at the times that require massive jumps)
[07:22:40 CEST] <wyatt8740> look for -force_key_frames here if that's the case https://ffmpeg.org/ffmpeg.html#Advanced-Video-options
[07:23:23 CEST] <pinPoint> has anyone here messed around with adobe premiere + frameserver and ffmpeg?
[07:23:31 CEST] <pinPoint> in the same workflow
[07:24:04 CEST] <wyatt8740> Not in same workflow. I used adobe premiere for a single week during an internship
[07:24:25 CEST] <wyatt8740> the video production were all mac users and weren't aware of ffmpeg's existence sadly
[07:25:43 CEST] <pinPoint> that is a bit sad. I was aware of ffmpeg just never jumped deeper.
[07:26:06 CEST] <pinPoint> now, in the past 2weeks I've messed around with it... I am just shocked at what it can pull off
[07:26:14 CEST] <wyatt8740> ffmpeg actually was my introduction to open source software :)
[07:26:30 CEST] <wyatt8740> I needed to encode a video for an ipod
[07:26:47 CEST] <wyatt8740> around 6th grade, I think.
[07:26:58 CEST] <pinPoint> wyatt8740: what?
[07:27:09 CEST] <pinPoint> you were messing around with ffmpeg at what age?
[07:27:21 CEST] <wyatt8740> pinPoint: I was about 12
[07:27:39 CEST] <pinPoint> you are in the US?
[07:27:40 CEST] <wyatt8740> most of it was copy pasting from other peoples commands at that point
[07:27:45 CEST] <wyatt8740> pinPoint: yes
[07:27:58 CEST] <pinPoint> maybe there is hope for us all. :D
[07:28:26 CEST] <wyatt8740> but eventually I started to figure out how the actual syntax worked, and from there got into linux because my dad thought I was spending too much time on my PC and locked my hard disk.
[07:28:32 CEST] <wyatt8740> So I booted a linux flash drive :)
[07:28:45 CEST] <pinPoint> @ 12?
[07:28:51 CEST] <wyatt8740> I was 13 when I started linux
[07:29:10 CEST] <wyatt8740> erased my drive a couple times accidentally but then started to get the hang of it
[07:29:52 CEST] <wyatt8740> the learning curve was real, though. And I'm ashamed to admit I am only a mediocre programmer (I actually love C and assembly but am not good at them, and am very annoyed by Java, and don't like python's performance)
[07:30:04 CEST] <wyatt8740> I'm 19 now btw
[07:31:09 CEST] <wyatt8740> but I really started getting interested in low level stuff when I learned about emulators when I was 11 or so. Wondered how they worked and such
[07:31:33 CEST] <wyatt8740> I know how now though I'm not sure I could actually write one
[07:31:56 CEST] <wyatt8740> but from there it got me interested in old computers like the NES and the VIC-20/C64
[07:32:14 CEST] <pinPoint> yeah I messed with ffmpeg couple weeks ago and wrote some tutorials that are in the background for now.
[07:32:14 CEST] <pinPoint> now I want to start writing with pro apps in mind.
[07:32:14 CEST] <pinPoint> I know ffmpeg supports DNxHD... but doing Premiere->Frameserver/AviSynth->FFmpeg. Word has it that there is some color loss.
[07:32:14 CEST] <pinPoint> because of using YUY...
[07:32:14 CEST] <pinPoint> at least from what I'm reading online
[07:32:17 CEST] <wyatt8740> found a VIC-20 free while I was volunteering some place, and got into assembly :D
[07:32:27 CEST] <wyatt8740> whoa, I think i desynced
[07:32:29 CEST] <pinPoint> right now as it stands, I can edit prores in premiere cc just fine. It just sending it out.
[07:33:08 CEST] <wyatt8740> what color space are you using for everything else?
[07:33:13 CEST] <wyatt8740> RGB?
[07:33:13 CEST] <pinPoint> yeah. all over sudden ten lines went by
[07:33:27 CEST] <wyatt8740> so you saw 'my life story'?
[07:33:48 CEST] <wyatt8740> heh
[07:33:56 CEST] <pinPoint> yes
[07:35:26 CEST] <wyatt8740> I think the first program I really compiled was ffmpeg, too.
[07:35:31 CEST] <wyatt8740> in MinGW on windows XP
[07:35:39 CEST] <wyatt8740> was a difficult but enriching experience
[07:36:21 CEST] <pinPoint> the colorspace for experiments was at least 4:2:2
[07:36:25 CEST] <pinPoint> 8-10bit
[07:37:11 CEST] <pinPoint> i took some mp4 off of youtube and moved them to prores 422 and final cut pro was happy to take them
[07:39:30 CEST] <wyatt8740> I don't think I've used anything but ffmpeg, imagemagick, shell scripts, and avidemux for editing in a year
[07:39:43 CEST] <wyatt8740> oh, and GIMP
[07:39:52 CEST] <wyatt8740> (for making things I overlay with imagemagick)
[07:41:16 CEST] <pinPoint> ah
[07:42:42 CEST] <pinPoint> frameserver and avisynth haven't gotten much action of late.
[09:08:58 CEST] <waressearcher2> what could that message mean:
[09:09:00 CEST] <waressearcher2> [libmp3lame @ 0x808f500] Trying to remove 1152 samples, but the queue is empty
[09:09:09 CEST] <waressearcher2> is it bad ?
[09:10:18 CEST] <waressearcher2> I'm trying to copy from "mp4 h264 aac" file to "avi mpeg4 mp3" file with reencoding
[09:57:23 CEST] <QTC`> Does ffmpeg support converting Audible AAX files on Linux? (or is it a Windows only feature?)
[09:59:21 CEST] <QTC`> [[ https://www.ffmpeg.org/ffmpeg-all.html#Audible-AAX ]]
[10:04:52 CEST] <c_14> Should work on linux as well.
[10:11:32 CEST] <QTC`> thank you c_14, I will try to redownload then
[10:12:47 CEST] <QTC`> [trying the FFmpeg Static Builds]
[10:19:26 CEST] <QTC`> thank you it works!
[10:42:42 CEST] <AlexRussia> Hey! I have directory whole of .vob, .ifo and .bup files. Can I somehow convert all the things to single mp4?
[10:43:47 CEST] <AlexRussia> or there's a better way to do this than ffmpeg?
[11:16:55 CEST] <waressearcher2> is it save to concatenate *ac3 files that way: "cat 1.ac3 2.ac3 > 3.ac3" ? does that *ac3 support that ?
[11:16:58 CEST] <waressearcher2> safe
[12:13:46 CEST] <StephenS> anyone up?
[12:16:51 CEST] <DHE> just ask your question
[12:20:10 CEST] <StephenS> ok, on centos7, I installed ffmpeg and ffmpeg-devel, and I got this from ffmpeg --help  configuration: --prefix=/usr --bindir=/usr/bin --datadir=/usr/share/ffmpeg --incdir=/usr/include/ffmpeg --libdir=/usr/lib64 --mandir=/usr/share/man --arch=x86_64 --optflags='
[12:20:27 CEST] <StephenS> I tried to configure, and I got this configure: error: ffmpeg headers not found. Make sure ffmpeg is compiled as shared libraries using the --enable-shared option
[12:20:52 CEST] <StephenS> ah
[12:21:08 CEST] <StephenS> this is ffmpeg-php extension not sure if is supported here?
[12:40:07 CEST] <BtbN> sounds horrible
[12:40:26 CEST] <durandal_1707> StephenS: but your ffmpeg is not compiled with -shared
[12:41:34 CEST] <StephenS> hmm
[12:41:45 CEST] <StephenS> can i do that from repo?
[12:42:03 CEST] <StephenS> as i installed it with yum install ffmpeg
[12:46:22 CEST] <durandal_1707> no
[12:47:05 CEST] <StephenS> eh so I had to remove ffmpeg and ffmpeg-devel and install it from source?
[13:03:58 CEST] <StephenS> According to this, each lib have -disable-shared
[13:04:09 CEST] <StephenS> is that fine, if I'm going to compile ffmpeg with -shared?
[13:04:21 CEST] <StephenS> link https://trac.ffmpeg.org/wiki/CompilationGuide/Centos#FFmpeg
[13:16:48 CEST] <StephenS> durandal_1707 ?
[13:17:26 CEST] <durandal_1707> yes, try to compile it yourself
[13:27:19 CEST] <StephenS> ok but my question is, durandal_1707 each lib can be compiled with --disable-shared and when I do final compile on ffmpeg I can just do --enable-shared correct?
[13:27:23 CEST] <StephenS> Because thats what I did :)
[13:28:48 CEST] <durandal_1707> make clean/distclean and reconfigure, etc
[13:29:52 CEST] <StephenS> durandal_1707 relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC
[13:29:52 CEST] <StephenS> /root/ffmpeg_build/lib/libx264.a: could not read symbols: Bad value
[13:29:52 CEST] <StephenS> collect2: error: ld returned 1 exit status
[13:29:52 CEST] <StephenS> make: *** [libavcodec/libavcodec.so.57] Error 1
[13:32:21 CEST] <c_14> Rebuild with --enable-pic
[13:32:45 CEST] <StephenS> ah ok thanks
[13:32:56 CEST] <c_14> And make sure to `make clean'
[13:33:09 CEST] <StephenS> before re-configure?
[13:33:15 CEST] <c_14> yes
[13:34:07 CEST] <StephenS> ok, one Q I have this PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig" ./configure --prefix="$HOME/ffmpeg_build" --extra-cflags="-I$HOME/ffmpeg_build/include" --extra-ldflags="-L$HOME/ffmpeg_build/lib" --bindir="$HOME/bin" --pkg-config-flags="--static" --enable-shared --enable-gpl --enable-nonfree --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-pic
[13:34:15 CEST] <StephenS> without libopus because url is wrong and not found
[13:34:20 CEST] <StephenS> will libopus cause some errors?
[13:36:02 CEST] <StephenS> c_14 ?
[13:36:48 CEST] <StephenS> and also I installed each lib for e.g. fdk-aac ./configure --prefix="$HOME/ffmpeg_build" --disable-shared
[13:37:41 CEST] <c_14> It'll decode fine, you just won't be able to encode it.
[13:38:05 CEST] <StephenS> that --disable-shared doesnt interact with main ffmpeg --enable-shared right?
[13:38:46 CEST] <c_14> shouldn't
[13:41:09 CEST] <Prelude_Zzzzz> hey guys.. anyone know the best setting for me to get more VBR.. currently i have something like.. " b: 1500k .. minrate 1k maxrate 5000k .. but i don't see large jumps in the VBR.. i see maybe 200K difference on files but nothing more.. I have the bufsize approx the maxrate or double that as per instructions but i can't seem to have it work properly.. i also have set 2pass . not sure what else to do.. any video encoding experts here ?
[13:42:43 CEST] <Prelude_Zzzzz> i am getting a lot of pixelation on scene changes and fast movements and i thought VBR would fix that
[13:46:08 CEST] <c_14> Try increasing bufsive, using a slower preset or a higher bitrate or maybe a lower scenedetect value
[13:46:09 CEST] <StephenS> c_14 still error
[13:46:10 CEST] <StephenS> /usr/bin/ld: /root/ffmpeg_build/lib/libx264.a(common.o): relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC
[13:46:10 CEST] <StephenS> /root/ffmpeg_build/lib/libx264.a: could not read symbols: Bad value
[13:46:10 CEST] <StephenS> collect2: error: ld returned 1 exit status
[13:46:10 CEST] <StephenS> make: *** [libavcodec/libavcodec.so.57] Error 1
[13:46:25 CEST] <StephenS> I did make clean
[13:46:29 CEST] <StephenS> and then
[13:46:30 CEST] <StephenS> PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig" ./configure --prefix="$HOME/ffmpeg_build" --extra-cflags="-I$HOME/ffmpeg_build/include" --extra-ldflags="-L$HOME/ffmpeg_build/lib" --bindir="$HOME/bin" --pkg-config-flags="--static" --enable-shared --enable-gpl --enable-nonfree --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-pic
[13:47:28 CEST] <c_14> Ah, you have to rebuild the dependencies with --enable-pic (or whatever option enables -fPIC for them)
[13:47:43 CEST] <StephenS> :O
[13:47:44 CEST] <StephenS> what
[13:47:50 CEST] <StephenS> each lib to configure again?
[13:47:57 CEST] <c_14> yep
[13:48:01 CEST] <StephenS> lol
[13:48:07 CEST] <StephenS> what lib do I need
[13:48:33 CEST] <StephenS> for simple php extension and video thumbnail and size check
[13:48:42 CEST] <c_14> none
[13:48:50 CEST] <c_14> If you're not encoding anything you don't need any external libs.
[13:49:26 CEST] <c_14> (with exception of some filters, but it doesn't sound like you're using any)
[13:50:03 CEST] <StephenS> so this should be fine PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig" ./configure --prefix="$HOME/ffmpeg_build" --extra-cflags="-I$HOME/ffmpeg_build/include" --extra-ldflags="-L$HOME/ffmpeg_build/lib" --bindir="$HOME/bin" --pkg-config-flags="--static" --enable-shared --enable-gpl --enable-nonfree --enable-pic ?
[13:50:48 CEST] <c_14> yep (you don't need --enable-nonfree though, or the extra-*flags parts, or teh --pkg-config-flags either)
[13:50:50 CEST] <StephenS> I have nonfree gpl shared and pic enabled
[13:59:42 CEST] <Prelude_Zzzzz> how does the screendetect settings work ?
[14:04:27 CEST] <Prelude_Zzzzz> i can't really find anything related to scene detect " https://ffmpeg.org/ffmpeg.html "
[14:04:42 CEST] <c_14> scenedetect is an x264 setting
[14:05:01 CEST] <Prelude_Zzzzz> what does it do exactly ?
[14:05:13 CEST] <c_14> It's called sc_threshold in ffmpeg iirc
[14:05:36 CEST] <c_14> It determines when x264 will insert a keyframe because of a scene change.
[14:06:09 CEST] <Prelude_Zzzzz> got it..
[14:06:12 CEST] <Prelude_Zzzzz> ok i have it -sc_threshold 40
[14:06:21 CEST] <Prelude_Zzzzz> i had already set that :(
[14:06:59 CEST] <c_14> 40 is default, try setting it higher
[14:07:18 CEST] <Prelude_Zzzzz> here is what i have so far " http://pastebin.com/qMmwvuG8 "
[14:07:50 CEST] <Prelude_Zzzzz> see anything wrong with it in terms of param.. i have processing power but not bandwidth and i want to get the best quality at the lowest bitrate
[14:08:01 CEST] <StephenS> c_14 compile and make install went without errors
[14:08:03 CEST] <StephenS> however ffmpeg --help
[14:08:03 CEST] <StephenS> ffmpeg: error while loading shared libraries: libavdevice.so.57: cannot open shared object file: No such file or directory
[14:08:38 CEST] <c_14> StephenS: export LD_LIBRARY_PATH=$HOME/ffmpeg_build/lib
[14:08:42 CEST] <c_14> then try again
[14:09:00 CEST] <StephenS> :O it worked
[14:10:05 CEST] <c_14> Prelude_Zzzzz: IF you have CPU but don't have Bandwidth, don't use nvenc
[14:10:12 CEST] <c_14> nvenc is for pretty much the exact opposite purpose
[14:10:35 CEST] <StephenS> I am still getting for ./configure on ffmpeg-php configure: error: ffmpeg headers not found. Make sure ffmpeg is compiled as shared libraries using the --enable-shared option
[14:10:52 CEST] <StephenS> I have ffmpeg-devel installed from yum but I think thats fine
[14:11:02 CEST] <c_14> export CFLAGS=-i$HOME/ffmpeg_build/include
[14:11:11 CEST] <c_14> Eh, -I instead of -i
[14:12:24 CEST] <StephenS> I even tried this ./configure --prefix=/root/ffmpeg_build
[14:12:48 CEST] <StephenS> hmm still the same ;(
[14:13:08 CEST] <c_14> does the configure have an --extra-cflags or something?
[14:13:26 CEST] <StephenS> yes
[14:13:27 CEST] <StephenS> built with gcc 4.8.3 (GCC) 20140911 (Red Hat 4.8.3-9)
[14:13:27 CEST] <StephenS>   configuration: --prefix=/root/ffmpeg_build --extra-cflags=-I/root/ffmpeg_build/include --extra-ldflags=-L/root/ffmpeg_build/lib --bindir=/root/bin --pkg-config-flags=--static --enable-shared --enable-gpl --enable-nonfree --enable-pic
[14:13:40 CEST] <c_14> Not for ffmpeg, for that php thingy
[14:13:48 CEST] <Prelude_Zzzzz> update... http://pastebin.com/tVv97NQP >>> any thoughts ?
[14:14:30 CEST] <StephenS>  cat configure | grep "extra-cflags"
[14:14:30 CEST] <StephenS>  returns nothing
[14:15:02 CEST] <c_14> Then no idea, you'll have to check if that php thing has support anywhere. (It's not supported here)
[14:15:09 CEST] <c_14> Though you could just call the ffmpeg binary from php.
[14:15:28 CEST] <StephenS> I could, with shell_exec() but I prefer to have a wrapper in PHP
[15:38:27 CEST] <BlackBishop> trying convert some .MOV's I made with my camera to .mp4 .. the .MOV's occupy way too much space .. I'm currently using ffmpeg -i file.MOV file.mp4 .. is there any special flag I should use to put my nvidia card to use ?
[15:39:27 CEST] <c_14> If you have a recent GPU and compile with nvenc, you can use that. But if you want to make the file smaller without ruining the quality, don't.
[15:40:01 CEST] <BlackBishop> well, the quality of the output so far is ok ..
[15:40:26 CEST] <BlackBishop> it's not like I shot the moon in excelent condition ... 'nor my eyes can see any differences ..
[15:40:31 CEST] <c_14> Comparing x264 and nvenc at the same bitrate is night and day.
[15:41:06 CEST] <BlackBishop> ow, so I should stick to x264 ...
[15:41:34 CEST] <BlackBishop> I was just wondering if I could make the gpu help the transition :)
[15:56:16 CEST] <wallbroken> there is somebody that could help me?
[15:56:24 CEST] <wallbroken> i'm trying to mux audio and video
[15:56:32 CEST] <wallbroken> but audio is desynced
[15:56:50 CEST] <wallbroken> the same thing on the same files was done by somebody else and it works well
[16:06:01 CEST] <Prelude_Zzzzz> hey guys.. new question.. i am using the hlsenc.c to encode a stream.. i am being told that the sync byte is ( 0447 ) is not there... why would the sync byte change ?  i encode with different software and the sync byte is accurate even after the encryption.. anything i am missing ?
[16:54:35 CEST] <JEEB> Prelude_Zzzzz: the mpeg-ts stuff should definitely have 0x47. no idea about 0x04 0x47
[16:55:22 CEST] <JEEB> also I dearly hope you are using the API or the command line ffmpeg and not actually hacking yourself into hlsenc.c :P
[16:55:41 CEST] <JEEB> because if you've hacked it up yourself with hlsenc.c then I cannot help you in any way or form
[17:01:05 CEST] <NapoleonWils0n> hi all
[17:01:31 CEST] <NapoleonWils0n> im trying to use ffpobe in a script to check for 404s but im having a few problems
[17:01:35 CEST] <NapoleonWils0n> ffprobe
[17:35:25 CEST] <andrelec1> hello
[17:35:35 CEST] <andrelec1> i need somme information aubout hos to use ffmpeg ...
[17:36:00 CEST] <andrelec1> i have a little project ...juste rescaling a video in 640*480 ...
[17:36:22 CEST] <andrelec1> but what is the most simple solution ? ( in C++ with ffmpeg )
[17:36:42 CEST] <andrelec1> demuxing => scalling => remuxing ?
[17:42:02 CEST] <JEEB> demux with lavf => decode with lavc => scale with swscale => encode with lavc => mux with lavf
[17:42:41 CEST] <JEEB> there are examples for pretty much all of this in the docs
[17:44:48 CEST] <StephenS> c_14
[17:45:15 CEST] <StephenS> everytime I login to ssh I need to export path, and also shell_exec() doesnt recognize ffmpeg command, how can I remove ffmpeg built from src?
[17:45:27 CEST] <StephenS> I think Im going to proceed with nux repo and install it with yum
[17:45:42 CEST] <c_14> just rm -r ffmpeg_build or wherever
[17:46:47 CEST] <StephenS> ah I did it :)
[17:46:48 CEST] <StephenS> rm -rf ~/ffmpeg_build ~/ffmpeg_sources ~/bin/{ffmpeg,ffprobe,ffserver,lame,vsyasm,x264,yasm,ytasm}
[17:46:51 CEST] <StephenS> that works fine
[17:47:09 CEST] <StephenS> ok ffmpeg works fine with shell_exec() now
[17:47:22 CEST] <StephenS> at least something, and I quit from trying to install that out of date wrapper
[17:47:25 CEST] <StephenS> Im going to write my own :)
[17:53:35 CEST] <andrelec1> ho thank JEEB
[17:56:35 CEST] <StephenS> [swscaler @ 0x1fbee40] deprecated pixel format used, make sure you did set range correctly
[18:01:25 CEST] <StephenS> is there any special perms needed for ffmpeg?
[18:01:42 CEST] <StephenS> I can run ffmpeg just fine inside terminal, but running php script, even as root gives me perm denied.
[18:02:20 CEST] <StephenS> error http://pastebin.com/M2nxnZyr
[18:03:28 CEST] <StephenS> script is 777 chmod and chowned to root
[18:05:26 CEST] <StephenS> nvm I solved it
[18:26:34 CEST] <YaMoonSun> Why is it that when I try to resize a .gif to half it's original resolution, my output is ten times the size, and it's low quality, undithered, ect
[18:46:53 CEST] <luc4> Hello! Does a verbose mode for ffmpeg configure exist? I cant find any option. I have a missing dependency but I do not understand why configure is not finding it.
[18:47:09 CEST] <c_14> That's what config.log is for
[18:47:38 CEST] <luc4> c_14: ah ok, thanks, that is what I was looking for :-)
[19:00:14 CEST] <wallbroken> i'm trying to mux audio and video
[19:00:18 CEST] <wallbroken> but audio is desynced
[19:00:24 CEST] <wallbroken> what can i do?
[19:00:30 CEST] <wallbroken> audio starts synced
[19:00:44 CEST] <wallbroken> but during playback it desyncs incrementally
[19:02:06 CEST] <YaMoonSun> What's the source file?
[19:26:19 CEST] <andrelec1> what is the differentce betwen muxing and remuxing ?
[19:27:24 CEST] <YaMoonSun> I would imagine remuxing is muxing from a .mkv file where as muxing is just from the DVD? There might not be a difference whatsoever.
[19:28:08 CEST] <JEEB> muxing is just muxing streams into a container, remuxing is demuxing data into streams, and then again muxing them into a container
[19:29:39 CEST] <JEEB> so if you have streams in, say, an flv file and you want them in an mp4 file. this is remuxing. demux from input, mux streams into output
[19:30:02 CEST] <JEEB> just muxing is usually described with demuxed content
[19:32:30 CEST] <andrelec1> ok
[19:51:23 CEST] <StephenS> hey c_14 why do I get duration 10seconds+ from the current one
[19:58:03 CEST] <Guest71531> hi everyone. if i have a 4 seconds movie, can i make it loop to extend it to 10 seconds (though i know that the third time will only be played by half) ? I know that this works via LOOP for images, but as i am not able to make this with GIF i am now trying a workaround with video.
[20:01:35 CEST] <qroft> Can anyone help me out with the command line i need?
[20:12:09 CEST] <Zeranoe_> qroft: What are you trying to do
[20:13:51 CEST] <qroft> i have a collection of GIF animations and i want to convert every gif into a mp4 movie and at the same time extend them to 5 seconds of duration. At the same time, those that are shorter than 5 seconds, shall loop until 5 seconds.
[20:14:04 CEST] <qroft> thanks for your time and help !
[20:14:33 CEST] <Zeranoe_> qroft: What do you have so far?
[20:15:58 CEST] <qroft> for /r %%X in ("*.gif") do (
[20:15:58 CEST] <qroft> # ffmpeg -loop 1 -i "%%X" %%X.mp4
[20:15:59 CEST] <qroft> # ffmpeg -i "%%X" -loop 1 -c:v libx264 -s 1920x1080 -preset veryfast -crf 28 -r 25 -pix_fmt yuv420p -t 00:30:00 "%%X.mp4"
[20:15:59 CEST] <qroft> # ffmpeg -i "%%X" -ignore_loop 0 -c:v libx264 -s 1920x1080 -preset veryfast -crf 28 -r 20 -pix_fmt yuv420p -t 00:00:05 -r 25 "%%X.mp4"
[20:15:59 CEST] <qroft>  
[20:15:59 CEST] <qroft> ffmpeg -i "%%X" "%%X.mp4"
[20:15:59 CEST] <qroft>  
[20:16:00 CEST] <qroft> )
[20:16:07 CEST] <Zeranoe_> Wohh, pastebin
[20:16:28 CEST] <qroft> damn sorry. wrong combo
[20:17:19 CEST] <qroft> Zeranoe_: sorry... here http://pastebin.com/Upeq9Ktw
[20:35:44 CEST] <StephenS> any ideas why I get wrong duration?
[20:35:59 CEST] <StephenS> code: $xyz = shell_exec("ffmpeg -i {$_FILES[image][tmp_name]} 2>&1");
[20:36:00 CEST] <StephenS>     
[20:36:00 CEST] <StephenS>     echo $xyz;
[20:36:17 CEST] <StephenS> ffmpeg -version
[20:36:17 CEST] <StephenS> ffmpeg version 2.6.3 Copyright (c) 2000-2015 the FFmpeg developers
[20:37:08 CEST] <voice> doesn't php have a built-in method to show what kind of image file has been uploaded?
[20:37:11 CEST] <qroft> Zeranoe_: could you give me a hint?
[20:39:45 CEST] <voice> StephenS, I'd say look into something like http://getid3.sourceforge.net/ for what you're doing
[20:40:18 CEST] <StephenS> its not image file, its just name of the field, its video
[20:42:25 CEST] <voice> what format?
[20:42:43 CEST] <StephenS> .mp4
[20:42:51 CEST] <StephenS> but I think thats manipulated
[20:42:52 CEST] <StephenS> sec
[20:43:16 CEST] <StephenS> yeah its not
[20:44:17 CEST] <voice> bah, I don't thin getID3 supports mpeg4 yet
[20:52:32 CEST] <StephenS> nah its fine
[20:52:39 CEST] <StephenS> I get almost correct playtime duration
[20:52:56 CEST] <StephenS> its missing .3s though but I guess thats due to transfer and android camera recorder
[20:53:07 CEST] <StephenS> way better than ffmpeg which seemed to gave me random results for duration
[20:53:24 CEST] <StephenS> however ffmpeg is awesome for generating thumbnails and manipulating with video ;)
[20:54:31 CEST] <voice> could also give ffprobe a shot
[20:57:00 CEST] <YaMoonSun> Is that essentially the same thing as MediaInfo?
[21:02:19 CEST] <qroft> can anyone tell me how i can extend a gif animation to 5 seconds including loop?
[21:15:07 CEST] <styler2go> Hey everyone. Just a quick question about quality: Is constant bitrate or VBR better?
[21:15:49 CEST] <iive> vbr
[21:16:17 CEST] <fritsch> that question cannot be answered for all cases
[21:17:01 CEST] <iive> keyframes by definition are bigger than intra-frames. at constant bitrate they would be clipped
[21:17:31 CEST] <iive> that's why even when encoding for constant bitrate channel, there is vbv
[21:17:32 CEST] <fritsch> I don't even know if he is talking about video or about mp3
[21:17:35 CEST] <styler2go> And one other question: which field order should i use? none? upper field, lower field?
[21:17:46 CEST] <styler2go> video :)
[21:17:58 CEST] <luc4> Hello! Im trying to cross build ffmpeg for an embedded linux system but Im getting an error during configure when testing for smbclient: http://pastebin.com/1HH41PYk. This seems wrong: for some reason the directory it is looking for the headers in relative to the toolchain, but it should be relative to the sysroot&
[21:18:00 CEST] <iive> that depends on your material.
[21:18:10 CEST] <styler2go> I didn't know where else to ask so i wanted to ask in here quickly. Hope that's not a problem
[21:18:57 CEST] <iive> interlace have fields,
[21:19:01 CEST] <Anoia> upper/lower sounds like it's interlaced...
[21:19:35 CEST] <iive> if you specify the wrong order, you would be having a jumping/jugged movement,
[21:19:52 CEST] <iive> like you've swapped every 2 frames.
[21:20:09 CEST] <iive> (if you play the result on crt or deinterlace it)
[21:20:44 CEST] <iive> my advice... avoid interlace when possible.
[21:20:55 CEST] <styler2go> so i set it to none
[21:21:15 CEST] <iive> again. it depends on your source material.
[21:21:20 CEST] <styler2go> hmm
[21:21:30 CEST] <iive> if it is progressive, then none is the correct.
[21:22:11 CEST] <styler2go> http://styler2go.de/screenshots/2015-10-10_21-22-10.png
[21:22:14 CEST] <styler2go> does that help you?
[21:23:54 CEST] <iive> no
[21:24:23 CEST] <styler2go> hum
[21:25:24 CEST] <Mavrik> Figure out if it's interlaced.
[21:25:32 CEST] <Mavrik> Deinterlace it if it is, other wise keep it progressive.
[21:25:37 CEST] <Mavrik> Just avoid interlaced video if possible.
[21:26:56 CEST] <YaMoonSun> xD
[21:27:15 CEST] <Mavrik> It's not 1994 anymore :P
[21:27:43 CEST] <luc4> Ok, sorry, probably not a configure issue. Seems a toolchain issue.
[22:03:39 CEST] <v3d> hey guys n get a precompiledCAVS doesn't show up in encoders in the latest packaged version in Ubuntu LTS
[22:03:45 CEST] <v3d> oops lol
[22:04:12 CEST] <v3d> hey giys does anyone know where I can get a precompiled binary with libxavs support?
[22:04:47 CEST] <v3d> cavs isn't listed in encoders
[22:05:00 CEST] <v3d> windows veersions appear to have it
[22:05:25 CEST] <v3d> tried it on both arch and Mint 14.04 LTS (ubuntu)
[00:00:00 CEST] --- Sun Oct 11 2015

More information about the Ffmpeg-devel-irc mailing list