[Ffmpeg-devel-irc] ffmpeg.log.20151013

burek burek021 at gmail.com
Wed Oct 14 02:05:02 CEST 2015

[00:16:46 CEST] <Ionic> Or was VDA not completely removed at all?
[00:27:33 CEST] <benbro1> what is the default keyframe interval in h264?
[00:27:36 CEST] <benbro1> I can't find it here
[00:27:37 CEST] <benbro1> https://www.ffmpeg.org/ffmpeg-codecs.html
[00:32:12 CEST] <chungy> benbro1: you'll have to look at x264, ffmpeg doesn't have a native encoder
[00:33:49 CEST] <benbro1> chungy: ok. thanks
[00:45:04 CEST] <grublet> benbro1: in x264 it's 240
[00:48:27 CEST] <benbro1> grublet: 240 what? time units or frames?
[00:49:00 CEST] <grublet> 1 in 240 frames
[00:49:17 CEST] <grublet> time unit would be whatever your fps is i assume
[00:49:36 CEST] <benbro1> I have 25 fps
[00:49:48 CEST] <benbro1> so it's about 10 seconds
[00:50:05 CEST] <grublet> 9.6 seconds
[00:51:03 CEST] <grublet> also unless you're streaming i'd aboid CBR since it's crap
[00:51:41 CEST] <benbro1> grublet: makes sense. when decreasing keyint to 25 I can cut the video anywhere and it looks good
[00:51:56 CEST] <benbro1> shouldn't I be able to cut the video anywhere also when using keyint of 240?
[00:52:31 CEST] <benbro1> with keyint=240, when I cut the video (without re-encode) the frame in the first few seconds is corrupted
[00:52:36 CEST] <grublet> benbro1: you could use a keyframe interval of 1 if you wanted, which would be like a fancy MJPEG
[00:52:53 CEST] <benbro1> grublet: that will increase the file size for no reason
[00:52:55 CEST] <grublet> benbro1: it's corrupted because whatever you're using to cut isn't decoding from the preceeding keyframe
[00:53:01 CEST] <grublet> well what are you trying to do
[00:53:07 CEST] <grublet> accurate seeking or what
[00:53:26 CEST] <grublet> afaik if you're cutting with ffmpeg just use -v:c copy
[00:53:34 CEST] <grublet> shouldnt have to set keyframe interval
[00:53:48 CEST] <benbro1> I'm trying to cut mp4 without re-encoding it
[00:53:50 CEST] <benbro1> ffmpeg -ss 00:08:02 -t 00:05:55 -i test.mp4 -c:v copy -c:a copy -movflags +faststart part1.mp4
[00:54:13 CEST] <benbro1> I tried putting "-ss ... -t ..." before and after "-i"
[00:55:05 CEST] <benbro1> I'm using git master from yesterday
[00:55:10 CEST] <grublet> well i've always had this issue with ffmpeg; if your cut is beyond a keyframe it will just copy the frames without a reference to it and so whatever you playback with will either ignore them until it hits a keyframe or show corruption
[00:55:30 CEST] <grublet> my ffmpeg is kinda outdated and its a windows build so i can't really help with version related stuff sorry
[00:55:49 CEST] <benbro1> grublet: just saying that my version isn't old :)
[00:56:15 CEST] <benbro1> grublet: is there another tool that can help me or a parameters that can fix the first few seconds?
[00:56:28 CEST] <grublet> it's not really something you can avoid
[00:56:37 CEST] <grublet> unless your cut includes a keyframe at the styart that will happen
[00:56:58 CEST] <grublet> actually
[00:57:02 CEST] <benbro1> but the video has 8 mintues before that point so there shouldn't be a problem cutting it at any step
[00:57:09 CEST] <grublet> benbro1: http://kicherer.org/joomla/index.php/de/blog/42-avcut-frame-accurate-video-cutting-with-only-small-quality-loss
[00:57:09 CEST] <grublet>  i was reading this yesterday
[00:57:16 CEST] <grublet> well that depends on your keyframe interval
[00:57:33 CEST] <grublet> like streaming video only does keyframes on connection loss afaik
[00:57:38 CEST] <grublet> so if its from a stream that can be an issue
[00:57:39 CEST] <benbro1> ffmpeg can construct enough frames before the point I'm cutting
[00:57:58 CEST] <grublet> well then i'm clueless so hopefully somsone else will be able to help you
[00:58:07 CEST] <benbro1> ok
[00:58:20 CEST] <benbro1> reading the link
[01:00:27 CEST] <grublet> benbro1: https://github.com/anyc/avcut
[01:02:00 CEST] <benbro1> thanks. still reading
[01:04:57 CEST] <benbro1> grublet: nice. it only re-encode the required part before the keyframe
[01:05:26 CEST] <benbro1> so the loss of quality will be unnoticeble if it's on 5 seconds for example
[01:06:14 CEST] <benbro1> is it your code?
[01:07:54 CEST] <grublet> benbro1: no it's not my code, but i found it while doing searches about cutting with ffmpeg
[01:10:50 CEST] <benbro1> grublet: did you try it?
[01:14:16 CEST] <grublet> no i haven't, cbf trying to make this work with cygwin
[01:14:29 CEST] <grublet> if i do i'll let you know
[01:16:04 CEST] <benbro1> thanks
[01:16:12 CEST] <benbro1> I'll try to compile it and test under ubuntu
[01:16:26 CEST] <grublet> i have a mint liveusb i could try on my thinkpad
[01:16:51 CEST] <othman3a> hi
[01:17:12 CEST] <othman3a> anyone know how to convert mp3 from 192 to 128
[08:31:40 CEST] <Guest95159> hello
[09:43:25 CEST] <anYc> benbro1: avcut is fairly new, I wasn't able to test it much yet.
[09:43:36 CEST] <anYc> let me know if you have any issues
[09:54:06 CEST] <Eduard> Hi, i am trying to capture from a DeckLink card in ProRes and I am getting no audio... any suggestions ?  C:\ffmpeg\bin\ffmpeg.exe -probesize 5000000 -f decklink -i "DeckLink SDI 4K at 15" -r 59.94 -c:v prores -profile:v 2 -c:a pcm_s24be -ar 44100  -pix_fmt yuv422p10le -threads 0 ProResTest.mov
[10:01:36 CEST] <seeit> Hi I'm trying to screen capture and i'm using the command line ffmpeg -f avfoundation -i "1:0" out.mov, as per https://trac.ffmpeg.org/wiki/Capture/Desktop but it scrambled like a 90s porn channel when I play the file
[10:02:14 CEST] <seeit> Any ideas? this is OS X
[10:10:27 CEST] <bencoh> scrambled as in "invalid strides" ?
[10:13:02 CEST] <seeit> can you link me an example of invalid strides so I can say yes or no
[10:13:05 CEST] <seeit> i don't know what those are
[10:17:33 CEST] <seeit> bencoh : https://vid.me/g5cU this is what the output is
[10:18:06 CEST] <bencoh> looks like it I'd say
[10:19:39 CEST] <seeit> at least i know what its called now
[10:19:56 CEST] <bencoh> seeit: try with a different picture size (multiples of easy numbers, like 16, 32 ...)
[10:20:22 CEST] <seeit> what's the flag for that?
[10:21:17 CEST] <bencoh> -s to rescale
[10:23:06 CEST] <bencoh> I dunno where in the pipeline the problem occurs though, so it might or might not work
[10:24:19 CEST] <seeit> I do have x11 installed, and it's a 720p screen, on a MacBook Air 11"
[10:24:46 CEST] <bencoh> how is it related to x11?
[10:25:08 CEST] <seeit> dunno if that might cause an issue, x11 is an optional package for OS X
[10:25:13 CEST] <seeit> not sure if it might cause an issue
[10:25:49 CEST] <bencoh> shouldnt
[10:26:51 CEST] <mateo`> seeit: which version of osx ?
[10:27:10 CEST] <seeit> 10.10.5
[10:27:56 CEST] <bencoh> seeit: what's the picture size?
[10:27:57 CEST] <seeit> I am using ffmpeg compiled through brew since the precompiled version through brew links to a missing library
[10:28:05 CEST] <seeit> 720p
[10:28:14 CEST] <bencoh> real 720p? 1280x720?
[10:28:20 CEST] <bencoh> is that your screen size as well?
[10:28:36 CEST] <seeit> oh it's 1366x768
[10:28:51 CEST] <seeit> just looked at the displays
[10:29:13 CEST] <bencoh> :)
[10:30:40 CEST] <seeit> so should I set -video_size or -s?
[10:31:17 CEST] <bencoh> no idea, check the doc and/or try both :)
[10:31:51 CEST] <mateo`> seeit: try video_set before the -i
[10:32:18 CEST] <seeit> well it's going to take a second, because I had uninstalled ffmpeg and am recompiling it
[10:34:11 CEST] <bencoh> -s[:stream_specifier] "As an input option, this is a shortcut for the video_size private option, recognized by some demuxers for which the frame size is either not stored in the file or is configurable  e.g. raw video or video grabbers."
[10:34:38 CEST] <bencoh> so both should work before -i, if it works at all with -f avfoundation
[10:34:38 CEST] <seeit> no option for video_set
[10:35:05 CEST] <mateo`> seeit: sorry i meant video_size
[10:35:38 CEST] <seeit> [avfoundation @ 0x7fca53822a00] Selected pixel format (yuv420p) is not supported by the input device.
[10:35:47 CEST] <seeit> Option video_size not found.
[10:38:10 CEST] <mateo`> you can paste somewhere the full output of the device
[10:39:12 CEST] <seeit> http://hastebin.com/lihizenopo.py
[10:40:55 CEST] <mateo`> seeit: you can update your ffmpeg installation ?
[10:41:14 CEST] <seeit> i'm downloading it from git right now to see if I can compile that version
[10:42:34 CEST] <seeit> Any particular flags I need to throw into ./configure ?
[10:43:40 CEST] <bencoh> --enable-libx264 if you want to encode to h264
[11:05:05 CEST] <seeit> bencoh : http://hastebin.com/esugamunid.vhdl
[11:05:47 CEST] <seeit> mateo`: ^^
[11:12:55 CEST] <bencoh> seeit: can you pastebin the output witout the -video_size option?
[11:13:52 CEST] <seeit> http://hastebin.com/kipesavaxu.vhdl
[11:14:49 CEST] <bencoh> and what if you set it to 1280x720?
[11:15:35 CEST] <seeit> http://hastebin.com/ikiwozuhuf.vhdl
[11:16:15 CEST] <bencoh> app error
[11:17:19 CEST] <seeit> am i sol?
[11:20:00 CEST] <seeit> trying it without libx264
[11:20:28 CEST] <bencoh> "app error" was for hastebin, but it works now. anyway, looks like video_size doesnt work with the avfoundation input
[11:22:22 CEST] <mateo`> bencoh: it should
[11:22:52 CEST] <mateo`> seeit: add -strict -2 before out.mov
[11:23:03 CEST] <bencoh> well ... it still says 1366x768 for Input
[11:28:01 CEST] <seeit> So i installed the static version from the website and the command line works, but its still not proper output
[11:28:30 CEST] <seeit> http://hastebin.com/etebulijop.vhdl
[11:28:54 CEST] <bencoh> what if you change output picture size?
[11:29:11 CEST] <bencoh> not sure how sws will handle that
[11:29:20 CEST] <bencoh> swscale*
[11:35:14 CEST] <mateo`> seeit: can you try with -pixel_format nv12 before -i
[11:35:32 CEST] <mateo`> and with the other pixels formats listed
[11:36:29 CEST] <seeit> still same
[11:37:00 CEST] <seeit> where are the pixel formats listen?
[11:37:22 CEST] <bencoh> in your paste
[11:40:46 CEST] <seeit> uyuy422 format not supported, and bgr0 and 0rgb give warning data is not aligned message and i have to ctrl-c 3 times to kill it
[11:41:27 CEST] <seeit> oh sorry i typed uyuy422 not uyvy422
[12:13:48 CEST] <PlanC> I'm trying to set the bitrate to CBR, but FFmpeg doesn't seem to provide the option
[12:14:07 CEST] <PlanC> the closest I got was "https://trac.ffmpeg.org/wiki/Encode/H.264" down at "CBR (Constant Bit Rate)"
[12:14:40 CEST] <PlanC> it simulates a constant bit rate by using ABR, but still players recognize it as VBR
[12:15:02 CEST] <PlanC> does anyone have a clue on how I can use CBR with FFmpeg?
[12:36:49 CEST] <BtbN> h264 encoders don't realy support cbr. The ABR aproximation is the best you'll get.
[12:43:05 CEST] <PlanC> BtbN: but I've seen MP3s with CBR
[12:43:08 CEST] <PlanC> how do those guys do it?
[12:44:19 CEST] <BtbN> By using an mp3 encoder for their mp3s.
[13:21:27 CEST] <bencoh> PlanC: what about nal-hrd=cbr?
[13:22:22 CEST] <BtbN> That only adds padding bytes that do nothing
[13:22:39 CEST] <BtbN> In case you have a strict cbr environment that can't transmit one byte less
[13:23:50 CEST] <bencoh> might help the picky player
[13:24:55 CEST] <BtbN> Players just throw that away
[13:25:15 CEST] <BtbN> It's designed for stuff like DVB broadcasting, where you can't vary at all.
[13:26:50 CEST] <bencoh> I mean, why does a player its "vbr" or "cbr"?
[13:26:54 CEST] <PlanC> ah I'll give nal-hrd=cbr a try
[13:26:54 CEST] <bencoh> says*
[13:27:02 CEST] <PlanC> so that adds the padding which makes it completely constant?
[13:35:06 CEST] <BtbN> It just adds zeroes until the bitrate over a certain amount of time is constant.
[13:35:19 CEST] <BtbN> but it's rather pointless and only needed in special cases, like for example DVB broadcasting
[13:46:57 CEST] <superware> can someone please try to reproduce a critical issue I'm having? http://trac.ffmpeg.org/ticket/4893
[14:12:42 CEST] <DHE> do you have a recording of said bad udp data?
[14:18:13 CEST] <superware> sure, see first comment in the ticket
[14:19:45 CEST] <superware> DHE: can you see it?
[14:30:30 CEST] <DHE> oh I see the file now...
[14:34:50 CEST] <DHE> is this raw H264 over UDP?
[14:36:01 CEST] <superware> yes
[14:36:41 CEST] <DHE> are you originating it? can you put a container onto it?
[14:36:46 CEST] <superware> very bad one, it managed to get ffmpeg (the decoder?) to a situation it cannot recover from.
[14:36:54 CEST] <superware> no
[14:37:09 CEST] <superware> it's coming from external hardware
[15:10:38 CEST] <superware> DHE :|
[15:11:25 CEST] <DHE> sorry, I don't have an answer. if you had any control over the source I'd recommend using some kind of encapsulation, probably mpegts
[15:49:48 CEST] <t4nk861> im using ffmpeg library in windows , vs2012,  Is there any option to write output file to memory instead of disc?
[15:57:28 CEST] <PlanC> I'm giving "--nal-hrd cbr", but it's not recognizing the option
[15:57:41 CEST] <PlanC> do I need to install an additional plugin for it to work?
[16:07:02 CEST] <superware> DHE: ok, thanks.
[16:28:53 CEST] <benbro1> anYc: is avcut supposed to work with mp4?
[16:29:14 CEST] <benbro1> you only tested with mkv?
[16:30:15 CEST] <benbro1> and does it require a specific version of ffmpeg?
[16:48:49 CEST] <anYc> I didn't try other containers yet, yes. But I will do. I only published it 3 days ago. As far as I remember, it does not depend on any "new" feature or specific fix. I think my machine at home has version 2.7.2
[16:49:48 CEST] <benbro1> anYc: what do I need to compile it?
[16:49:51 CEST] <benbro1> I'm using ubuntu 15.05
[16:50:39 CEST] <benbro1> libavcodec-dev?
[16:52:42 CEST] <anYc> good point, I would start with libavcodec-dev and libavformat-dev
[16:53:24 CEST] <anYc> I have an ubuntu machine at home, I can try it later and make a .deb
[16:53:41 CEST] <benbro1> that will be great
[16:54:03 CEST] <benbro1> I'm installing ubuntu now and will try to compile and test when it's done
[16:59:58 CEST] <benbro1> anYc: make failed
[17:00:00 CEST] <benbro1> http://pastebin.com/bX9uV58N
[17:00:11 CEST] <benbro1> I've installed libavcodec-dev and libavformat-dev
[17:03:20 CEST] <benbro1> installed libavcodec-dev, libavformat-dev, libavutil-dev, libavfilter-dev
[17:10:21 CEST] <anYc> Okay, looks odd. Those are things that are also used in older tutorials. Maybe I missed headers that are automatically included in newer versions. I'll try it when I come home. Thanks for the info!
[17:42:00 CEST] <benbro> anYc: thanks
[18:51:31 CEST] <anYc> benbro1: ok, looks like an libav vs. ffmpeg issue :/
[18:52:25 CEST] <anYc> the first challenge is how I detect in the code if I'm using the one or the other
[19:15:25 CEST] <benbro1> anYc: I prefer to use ffmpeg. what packages do I need to install for this?
[19:15:40 CEST] <benbro1> ubuntu and debian are moving to ffmpeg
[19:16:45 CEST] <benbro1> maybe this? libavcodec-ffmpeg-dev
[19:19:08 CEST] <benbro1> anYc: trying again with ffmpeg packages:
[19:19:09 CEST] <benbro1> libavcodec-ffmpeg-dev libavformat-ffmpeg-dev libavutil-ffmpeg-dev libavfilter-ffmpeg-dev
[19:27:12 CEST] <anYc> Unfortunately, I don't know how the older Ubuntus handle this. However, I think I found some workarounds for libav. I will push some commits in a few minutes
[19:36:00 CEST] <seeit> Has anyone run into aproblem with invalid strides on a MacBook Air 11" with OS X Yosemite?
[19:39:11 CEST] <anYc> benbro: I pushed the commits. I also tested mp4, it doesn't work out of the box with my h264 avi as input. I will check it later
[19:39:14 CEST] <anYc> [mp4 @ 0x236fc40] Tag H264/0x34363248 incompatible with output codec id '28' ([33][0][0][0])
[19:41:06 CEST] <benbro> anYc: I've installed the ffmpeg packages and now it compiles
[19:41:07 CEST] <benbro> libavcodec-ffmpeg-dev libavformat-ffmpeg-dev libavutil-ffmpeg-dev libavfilter-ffmpeg-dev
[19:41:19 CEST] <benbro> maybe you'll want to add it to the readme :)
[19:56:07 CEST] <anYc> I will, thank you!
[22:22:55 CEST] <fred1807> Is ffmpeg appropriate to extract the audio from a .mp4 without reencoding it ?
[22:23:14 CEST] <benbro> fred1807: yes
[22:23:32 CEST] <fred1807> benbro: can you give a command line example?
[22:23:54 CEST] <benbro> ffmpeg -i input.mkv -c:a copy -vn output.m4a
[22:24:01 CEST] <JEEB> or just -map 0:a
[22:24:02 CEST] <benbro> depends on the audio codec
[22:24:08 CEST] <JEEB> which maps all audio tracks from input
[22:24:27 CEST] <JEEB> since you can in theory have subtitle tracks etc, and having both -vn and -sn is :eff:
[22:24:32 CEST] <fred1807> m4a is still a movie conteiner (with the actual audio track inside) inst?
[22:24:41 CEST] <fred1807> for the output
[22:24:46 CEST] <JEEB> yes, but if you want raw tracks then you want to know what's inside
[22:24:54 CEST] <JEEB> .aac or .mp3 or whatever in that case
[22:25:12 CEST] <JEEB> I have no idea why you would want audio without a container, though
[22:25:22 CEST] <fred1807> because I dont want the movie, only the audio
[22:25:37 CEST] <JEEB> and that's what you get with m4a
[22:25:52 CEST] <JEEB> ffmpeg -i hurr.mp4 -map 0:a -c copy out.m4a
[22:26:10 CEST] <fred1807> ok..
[22:26:38 CEST] <JEEB> takes stuff from hurr.mp4, selects only the audio track(s) from first (zeroth) input, copy mode (instead of re-encode), out.m4a is the output file name
[22:27:30 CEST] <JEEB> having any modern audio format as raw bit stream is really uncomfortable for any use that doesn't have an external index
[22:27:42 CEST] <JEEB> and good riddance for that
[22:28:01 CEST] <JEEB> uhh
[22:28:09 CEST] <ChocolateArmpits> is there any difference between using .m4a and .aac ?
[22:28:17 CEST] <JEEB> .aac is raw aac bit stream
[22:28:18 CEST] <fred1807> ^
[22:28:29 CEST] <ChocolateArmpits> so no headers and the like ?
[22:28:30 CEST] <JEEB> .m4a is apple's extension for mpeg-4 container with audio only
[22:28:45 CEST] <JEEB> which also most mobile etc. things perceive as audio
[22:28:46 CEST] <ChocolateArmpits> oh ok
[22:28:48 CEST] <JEEB> instead of video
[22:28:50 CEST] <fred1807> I see
[22:29:10 CEST] <fred1807> ok, unless the audio inside my mp4 movie is mp3, wich in unlikely
[22:29:24 CEST] <JEEB> well in the case of the .m4a output that doesn't matter
[22:29:29 CEST] <JEEB> it's from container into a container
[22:29:35 CEST] <JEEB> just that it's the audio track(s) only
[22:30:08 CEST] <JEEB> and yeah, what I meant with the good riddance is that we no longer think of raw bit stream audio as normal after mp3 :
[22:30:11 CEST] <JEEB> :P
[22:30:17 CEST] <JEEB> because that was a major PITA
[22:30:33 CEST] <JEEB> most players that properly seek in mp3 files pretty much index the file
[22:30:37 CEST] <JEEB> by decoding it
[22:31:14 CEST] <JEEB> as it's a raw bit stream you literally have no other way of accurately doing seeking in such files
[23:44:34 CEST] <Plorkyeran> and with VBR you couldn't even accurately guess how long it was
[23:44:46 CEST] <Plorkyeran> without doing some work
[23:48:37 CEST] <JEEB> ye
[23:48:47 CEST] <TD-Linux> with new formats (opus) the raw bitstream isn't even decodeable
[23:49:15 CEST] <TD-Linux> (well, as a result there's no raw format)
[23:58:20 CEST] <Ionic> Ah... VDA is only deprecated in 10.11, not removed
[00:00:00 CEST] --- Wed Oct 14 2015

More information about the Ffmpeg-devel-irc mailing list