[Ffmpeg-devel-irc] ffmpeg.log.20151015

burek burek021 at gmail.com
Fri Oct 16 02:05:02 CEST 2015

[03:19:41 CEST] <kyleogrg> hi
[03:20:23 CEST] <kyleogrg> out of curiosity, what are some of the oldest video codecs supported by ffmpeg (for encoding)?
[03:20:42 CEST] <Max-P> kyleogrg: does rawvideo count?
[03:21:05 CEST] <kyleogrg> i guess, but what else?
[03:21:39 CEST] <kyleogrg> i don't necessarily know what's very old.  i just know the common ones...
[03:22:00 CEST] <kyleogrg> i guess i want to see what the most obscure codecs are that are supported
[03:22:41 CEST] <Max-P> Logically that probably would be mjpeg, as that's the obvious natural step to creating videos
[03:22:42 CEST] <Max-P> Or maybe gif
[03:23:12 CEST] <kyleogrg> ok
[03:23:23 CEST] <kyleogrg> what about a video codec
[03:23:35 CEST] <kyleogrg> cinepak is very old, i think
[03:26:29 CEST] <kyleogrg> okay, i just ran "ffmpeg.exe -codecs"
[03:26:32 CEST] <kyleogrg> wow
[03:26:42 CEST] <Max-P> I thing MPEG-1 is a tiny bit older than cinepak
[03:27:15 CEST] <Max-P> Ah nope, mpeg-1 was released a year later according to Wikipedia
[03:31:44 CEST] <TD-Linux> I would go with h.261
[03:33:40 CEST] <kyleogrg> never heard of that.
[03:33:45 CEST] <kyleogrg> 1988!
[03:47:10 CEST] <kyleogrg> i'm playing with h261 and i'm getting messages like "warning, clipping 1 dct coefficients to -127..127"
[03:49:23 CEST] <kyleogrg> how can i get all the settings available for h261?
[04:05:09 CEST] <waressearcher2> this is weird
[04:05:13 CEST] <waressearcher2> is anyone here ?
[04:07:42 CEST] <waressearcher2> I have script with few ffmpeg commands that are cut out piece of video and reencode it, so that whenever I run that script it should generate 18 files, and if the source file is unchanged and the script is unchanged it should generate the same files with the same md5 sum right ?
[04:07:58 CEST] <waressearcher2> wait
[04:08:22 CEST] <waressearcher2> not problems here, I actually changed bitrate from 5000 to 10000 thats why md5 sums of files are different
[04:09:35 CEST] <waressearcher2> false warning, you can all go to your solitary confinements now
[04:28:14 CEST] <pinPoint> is libaac finalized in latest 2.8.1?
[04:35:48 CEST] <pinPoint> nvm. still experimental @ 2.8.1
[04:37:56 CEST] <kyleogrg> what do you call these kinds of video artifacts?  there are subtle green-ish and purple-ish spots. here's a screenshot (see lower half of frame): http://imgur.com/cqoJmjs
[04:43:04 CEST] <klaxa> color distortion?
[04:43:38 CEST] <klaxa> looks like a variant of the morie effect to me https://en.wikipedia.org/wiki/Moir%C3%A9_pattern
[04:44:09 CEST] <pinPoint> chromatic abberations
[04:44:49 CEST] <pinPoint> poor quality, compression artifacts? :)
[04:45:02 CEST] <kyleogrg> okay
[04:45:30 CEST] <kyleogrg> it's relatively old footage from a "bullet camera" that recorded to mpeg
[04:45:57 CEST] <kyleogrg> it's since been recompressed, but that didn't cause this.  these colors came straight from the file from the camera
[04:46:24 CEST] <kyleogrg> so would you guess it's just poor compression?
[04:48:31 CEST] <kyleogrg> i mean, is that a common thing.
[04:51:15 CEST] <klaxa> i guess the camera is just not "good"
[04:51:56 CEST] <kyleogrg> yeah, i think that's the most obvious ansewr
[04:52:12 CEST] <kyleogrg> i wonder if there's a relatively easy way to filter this out with ffmpeg
[08:02:51 CEST] <_julian_> is ffmpeg capable of handling dynamic pmt changes when transcoding mpeg-ts livestreams?
[08:48:36 CEST] <JEEB> _julian_: if you mean stuff like pid switches then not
[08:49:10 CEST] <JEEB> if it's the same pid and the res changes, that should still be ok
[08:50:17 CEST] <_julian_> JEEB: actually I meant pid changes. are they even detected? so would it be possible to easily restart the transcoding process when it happens?
[08:52:56 CEST] <JEEB> not sure
[10:09:04 CEST] <dot> can someone help me with this: http://pastebin.com/N8aCgrPP
[10:15:35 CEST] <dot> anyone here ?
[10:16:08 CEST] <Mavrik> dot, 1.) You really really really don't wanna output to .mpg without setting a codec
[10:16:19 CEST] <Mavrik> 2.) add "-r 30" before "-i" to tell avfoundation you want 30fps input
[10:16:20 CEST] <dot> i see
[10:16:39 CEST] <dot> which codec do you suggest
[10:19:26 CEST] <dot> Mavrik: http://pastebin.com/N0zQndCd
[10:27:41 CEST] <dot> Mavrik*
[16:57:11 CEST] <benbro> how can I cut mp4 by start/end keyframes?
[16:57:19 CEST] <benbro> I know the index of the frames
[16:58:12 CEST] <benbro> I see trim with start_frame and end_frame
[16:59:19 CEST] <benbro> but it's -vf. will it re-encode?
[16:59:28 CEST] <benbro> I want to cut at keyframes without re-encoding
[17:00:29 CEST] <JEEB> use -ss and -t with the timestamps of those pictures, that's the best I can think of with ffmpeg
[17:00:45 CEST] <JEEB> vf is always done on decoded frames as far as I know
[17:00:45 CEST] <grublet> benbro: if you know the timecodes you might just try using -ss to do it
[17:00:53 CEST] <grublet> JEEB beat me
[17:01:33 CEST] <benbro> I need the 'pkt_pts_time' field of the frame?
[17:01:41 CEST] <benbro> or other field?
[17:02:15 CEST] <loopsmark> Hi o/
[17:04:49 CEST] <loopsmark> I am decompresing a custom stream that comes over the network, this stream is encoded in jpeg with 12 bits, for this I am using ffmpeg as library with the mjpeg codec, the thing is that I get something like one second of delay. Is there some kind of tweaking to be done to improve this latency?
[17:11:51 CEST] <Mico81> Hi guys, I need some help. I want to merge a 3gp video with a mp3 audio, but the two audio stream (one from video.3gp and the other from audio.mp3) need to be combine
[17:14:55 CEST] <Mico81> I'm using : -i video.3gp -i audio.mp3 -filter_complex [0:a][1:a]amerge=inputs=2[a] -map 0:v -map [a] -c:v libx264 -c:a aac -strict experimental -b:a 192k -shortest output.mp4
[17:27:02 CEST] <benbro1> I'm trying to cut a video with "-ss" and "-to"
[17:27:34 CEST] <benbro1> but the duration of the video is not correct event when -ss and -to are the pkt_pts_time of keyframes
[17:28:26 CEST] <benbro1> ffmpeg -ss 487.433333 -i in.mp4 -to 827.333333 -c:a copy -c:v copy out.mp4
[17:30:05 CEST] <benbro1> http://pastebin.com/CebuP0rD
[17:31:55 CEST] <benbro1> "-t" with the difference seems to work
[17:44:36 CEST] <grublet> benbro1: -t has been the only one that works for me as well
[17:50:42 CEST] <benbro1> grublet: thanks
[17:50:47 CEST] <benbro1> I'm trying to use concat now:
[17:50:49 CEST] <benbro1> ffmpeg -i concat:"start.mp4|middle.mp4|end.mp4" -c copy -movflags +faststart out.mp4
[17:51:01 CEST] <benbro1> but out.mp4 includes only start.mp4
[17:51:05 CEST] <benbro1> it ignores the other two files
[17:51:29 CEST] <grublet> benbro1: https://trac.ffmpeg.org/wiki/Concatenate
[17:51:47 CEST] <grublet> i had to look it up before
[17:51:52 CEST] <grublet> havent used concat i na while
[17:52:20 CEST] <benbro1> http://ffmpeg.org/faq.html#Concatenating-using-the-concat-protocol-_0028file-level_0029
[17:52:31 CEST] <grublet> that too
[17:53:06 CEST] <benbro1> docs says:
[17:53:07 CEST] <benbro1> ffmpeg -i "concat:input1.mpg|input2.mpg|input3.mpg" -c copy output.mpg
[17:53:12 CEST] <benbro1> trying
[17:53:50 CEST] <benbro1> same result
[18:03:56 CEST] <benbro1> with a text file I'm able to concatenate
[18:04:19 CEST] <benbro1> ffmpeg -f concat -i files.txt -c copy output.mp4
[18:04:36 CEST] <benbro1> but now I'm getting many warnings
[18:04:37 CEST] <benbro1> Non-monotonous DTS in output stream 0:0; previous: 97654, current: 95940; changing to 97655. This may result in incorrect timestamps in the output file.
[18:04:44 CEST] <benbro1> and the audio in the output is not synced
[18:05:39 CEST] <benbro1> http://pastebin.com/Xy8VDWde
[18:25:00 CEST] <iulhk> help me to install ffmpeg via yum at centos7 ? "no matches found"?
[20:13:02 CEST] <Nrj38j> hi guys. I have server with debian linux. And it's rebooting when i'm trying to convert video. I've tried to launch some stress tests but everything works fine. Looks like it's something between ffmpeg and linux. How to determine and fix the problem?
[20:16:18 CEST] <Nrj38j> tnx guys you always helping a lot
[20:21:40 CEST] <fritsch> do a memory test
[20:22:00 CEST] <fritsch> and check temperatures
[20:22:11 CEST] <fritsch> a system resetting is something very severe
[20:31:22 CEST] <Nrj38j> fritsch: everything is ok here
[20:31:39 CEST] <BtbN> ffmpeg does not have a reset feature. My guess would be broken ram.
[20:35:47 CEST] <Matador> Bloody heck
[20:35:48 CEST] <Matador> I'm dying
[20:36:07 CEST] <Matador> I keep getting "Larger timestamp than 24-bit: 0x****" errors
[20:38:40 CEST] <furq> isn't that an rtmpdump error
[20:38:52 CEST] <Matador> its ffmpeg encode
[20:40:08 CEST] <Matador> http://pastebin.com/RXRcY42S
[20:40:41 CEST] <Matador> I'll try to get a better one w/o debug_ts
[20:40:48 CEST] <benbro1> how can I reencode with the same codec parameters?
[20:41:11 CEST] <Matador> ffmpeg -loglevel info -copyts -start_at_zero -f decklink -threads 4 -rtbufsize 1800M -i "Intensity Pro 4K (1)@15" -r 30 -s 960x540 -aspect 16:9 -c:v h264_qsv -preset 4 -idr_interval 60 -profile:v main -b:v 2350k -maxrate 2500k -bufsize 10000k -c:a libfdk_aac -ar 48000 -b:a 96k -cutoff 19000 -f flv rtmp://LAN1...xxx
[20:41:17 CEST] <Matador> is my syntax
[20:41:32 CEST] <Matador> was trying to get timestamps down to 0, I dunno why its like this
[20:42:37 CEST] <hotwings> is there any way for ffprobe to report if a video stream is interlaced or progressive?
[20:43:25 CEST] <Matador> http://pastebin.com/H4vjRJR8
[20:44:29 CEST] <Nrj38j> BtbN: ECC memory
[20:44:48 CEST] <Nrj38j> another suggestion?
[20:44:49 CEST] <furq> ecc memory can still break
[20:47:11 CEST] <Matador> How can I fix this timestamp issue ? :|
[20:57:31 CEST] <Matador> I have no more hair left to pull out
[21:02:27 CEST] <DHE> hotwings: use -show_frames   but you'll have to deal with it dumping the whole movie to stdout
[21:09:58 CEST] <hotwings> DHE - thanks.. GAH!! thats lame as hell. think ill just try to get mediainfo working again. that was able to do it in like 2 seconds
[21:11:24 CEST] <benbro1> what h264 parameters are important when concatenating mp4 files without re-encoding?
[21:13:21 CEST] <Nrj38j> furq: BtbN fritsch already 30 min memtesting and still nothing. Temp is ok too. Another suggestions?
[21:13:31 CEST] <Matador> Any got an idea on how to eliminate this timestamp issue ? :(
[21:14:04 CEST] <BtbN> Well, as ffmpeg still does not have a reset feature, it has to be something wonky with your system.
[21:14:20 CEST] <BtbN> Also, 30 minutes of memtest is nothing.
[21:15:25 CEST] <DHE> hotwings: I just wait until I get my answer, then cut off ffprobe by killing it or closing its stdout pipe. I don't need to dump the whole video
[21:19:09 CEST] <Nrj38j> BtbN: what is optimal time then?
[21:20:35 CEST] <BtbN> a couple days
[21:21:46 CEST] <Nrj38j> BtbN: sound like trolling
[21:22:21 CEST] <Matador> easy now
[21:22:30 CEST] <Matador> 1-2h max for a memtest to complete
[21:23:07 CEST] <f0o> Evening
[21:23:34 CEST] <BtbN> I have seen memtests that started showing errors after two days, if you want to be sure it's not your ram, 24h+ it is.
[21:23:58 CEST] <BtbN> A reproducible crash is unlikely to be caused by an error like that though
[21:26:42 CEST] <f0o> I have to convert 1080p mov files (Video: h264 (High) (avc1 / 0x31637661), yuv420p(tv, bt709), 1920x1080 [SAR 1:1 DAR 16:9], 12940 kb/s, 25 fps, 25 tbr, 2500 tbn, 5k tbc + Audio: aac (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 114 kb/s) into mp4 and webm. Filesize is not crucial but it'd be cool if it's <100M for 10mins of video. Google brings me nowhere and my current commandline does 4fps on 8 cores and
[21:26:44 CEST] <f0o> plenty of free ram. I have 0 knowledge about video transcoding, these are intended to be streamed via HLS. Any pointers? (checked https://trac.ffmpeg.org/wiki/Encode/H.264 and http://www.webmproject.org/docs/encoder-parameters/ but if I add bitrates the video turns grey and pixels are as big as my fist...)
[21:27:05 CEST] <f0o> Sorry in advanced for this generic question. yell if you need more info
[21:40:39 CEST] <Matador> makes no sense
[21:46:57 CEST] <TD-Linux> f0lder, HLS usually uses mpeg-ts. Did you maybe mean DASH?
[21:47:32 CEST] <f0o> TD-Linux: perhaps
[21:48:03 CEST] <f0o> TD-Linux: could be that all this is just working 'wrong' - I really have no idea
[21:48:05 CEST] <TD-Linux> it's going to be really difficult to help you when you don't know what you need
[21:48:46 CEST] <f0o> yeah I know :/
[21:49:11 CEST] <TD-Linux> maybe explain at a much higher level what you're trying to do?
[21:49:39 CEST] <DHE> for mpeg-dash I hear you usually make a single.mp4 and then have mp4box have at it. for HLS there is an option "-f hls" to do the work for you (additional options highly recommended)
[21:51:57 CEST] <f0o> Ok, my client ordered a webapplication to serve videos to his visitors. He was supposed to manage the convertion from the uploaded source files (in .mov) to the finalized .mp4 and .webm files. However his solution ('-strict -2 -f mp4 -vb 1200000' and '-strict -2 -f webm -vb 1200000' respectively) takes literally hours for the job to be done. It works at about 3-5 fps on a beefy machine (8 cores, 16G ram, 3k
[21:51:59 CEST] <f0o> IO/s disks)
[21:52:40 CEST] <f0o> I got the impression that this sounds wrong, 10 minutes video cant take 2+ hours to convert from .mov -> .webm, can it?
[21:52:46 CEST] <TD-Linux> f0o, okay you don't need HLS or anything for this
[21:52:59 CEST] <TD-Linux> just a video in a <video> tag will do
[21:53:35 CEST] <f0o> oh sorry the 'he' was refering to the external freelancer who wrote the app
[21:54:26 CEST] <TD-Linux> that should work okayish though you can drop the -f if you specify the extension, also use -b:v instead of -vb and you don't need -strict
[21:54:45 CEST] <TD-Linux> you might also want to consider scaling down the resolution
[21:54:46 CEST] <f0o> TD-Linux: so those 2+ hours are legitimate?
[21:55:16 CEST] <TD-Linux> f0o, well you can change the speed of the encoder with cpu used
[21:55:20 CEST] <f0o> I ahve no experience, perhaps those transcoding times are all 'normal' and I'm just not used to that
[21:55:53 CEST] <f0o> l
[21:55:56 CEST] <f0o> k*
[21:55:58 CEST] <f0o> I'll try
[21:57:00 CEST] <TD-Linux> or preset for x264
[21:57:58 CEST] <f0o> dropping -strict -2 errors with [aac @ 0x259a6a0] The encoder 'aac' is experimental but experimental codecs are not enabled, add '-strict -2' if you want to use it.
[21:58:02 CEST] <TD-Linux> if you are really still unsure, maybe consider just uploading to youtube and embedding, or any of the other paid services
[21:58:22 CEST] <f0o> client wants to be itself a PayPerView thing
[21:58:27 CEST] <f0o> :|
[21:59:12 CEST] <f0o> I think I'll just let it be, not my problem if it takes him forever... the infrastructure is rock solid and that's basically what my job is about
[21:59:56 CEST] <f0o> just felt fishy for me that a process taking x264 and writing x264 takes 2hrs when the source is just 10m
[22:00:04 CEST] <f0o> contradicted my logic
[22:00:19 CEST] <f0o> but then, no idea about those video formats if that's all normal it's good to me
[22:50:10 CEST] <benbro1> anYc: how do you make sure the codec parameters of the three parts in avcut are the same?
[22:50:47 CEST] <benbro1> I've tried to create a python script that copies the middle part and encodes a small part at the beginning and end
[22:50:51 CEST] <benbro1> and concatenate
[22:51:14 CEST] <benbro1> but the end part is black probably because of timestamp issues or different codec parameters
[23:15:46 CEST] <Nrj38j> fuck
[23:15:57 CEST] <Nrj38j> got machine check exception
[23:24:05 CEST] <x86iac> any chance that ffmpeg and deal with trm files
[23:33:00 CEST] <benbro1> anYc: ok, I see this in your blog. you copy what's available and guess the rest
[23:33:05 CEST] <BullHorn> how can i quickly convert a video file that has 2 audio tracks into a video that has 1 track that combines both tracks into 1?
[23:34:44 CEST] <retard> BullHorn: see https://trac.ffmpeg.org/wiki/AudioChannelManipulation
[23:35:17 CEST] <retard> specifically the 2 x stereo -> stereo section
[23:35:39 CEST] <BullHorn> ye thats what im looking at
[23:35:43 CEST] <BullHorn> it uses .wav
[23:35:54 CEST] <BullHorn> but i guess itll know what to do if i use .mp4 or .flv or whatnot?
[23:36:10 CEST] <BullHorn> hmm
[23:36:18 CEST] <retard> if you use -vcodec none i *think* so
[23:36:20 CEST] <BullHorn> the 2 audio tracks are in the same file, not 2 wavs
[23:36:47 CEST] <durandal_1707> x86iac: what?
[23:36:56 CEST] <retard> either way you can split out the audio tracks first, mix them, then resynch it with whatever video
[23:37:01 CEST] <retard> if need be
[23:39:18 CEST] <x86iac> hi durandal_1707 http://arstechnica.com/civis/viewtopic.php?f=15&t=1192425
[23:42:55 CEST] <BullHorn> thanks
[23:55:36 CEST] <x86iac> durandal_1707: ..... are you working on a converter as we speak ? ;)
[00:00:00 CEST] --- Fri Oct 16 2015

More information about the Ffmpeg-devel-irc mailing list