[Ffmpeg-devel-irc] ffmpeg.log.20151016

burek burek021 at gmail.com
Sat Oct 17 02:05:01 CEST 2015

[00:44:41 CEST] <orbisvicis> does ffmpeg -i file.mp3 show the average bitrate of vbr files, or just the first frame ?
[01:34:40 CEST] <orbisvicis> is there a more approriate statistic flag than "ffmpeg -i"
[01:34:51 CEST] <orbisvicis> "ffmpeg -i" keeps complaining about incorrect syntax, missing files
[06:19:01 CEST] <Zeranoe> Is anyone familiar with data that comes from 8mm/Digital8 tapes and what the helical scan receives?
[09:15:55 CEST] <_julian> when using mpeg2video encoder are there any parameters outside of AVCodecContext which could influence the bitrate?
[09:20:07 CEST] <_julian> I'm trying to figure out why a vlc-transcoded video has twice the sice of the same video transcoded with ffmpeg directly. a diff of the AVCodecContext is not spotting any relevant diff (see: http://pastebin.com/tFCjuY22)
[09:21:37 CEST] <BtbN> Well, the mpeg2 encoder parameters.
[09:27:28 CEST] <_julian> ah yes, I should propably check the options AVDictionary on avcodec_open2...
[09:31:51 CEST] <anYc> benbro: I also started with a ffmpeg script but there were always glitches at the cutpoints. I think I found the issue with your video but I'm still thinking about how I should fix it without breaking other types
[09:39:53 CEST] <_julian> BtbN: is there anything else besides the options AVDictionary that could influence the encoder parameters? those are the same now as well (ffmpeg passet bitrate tolerenace in there, vlc did not). but still the vlc file remains unchanged in size
[09:45:24 CEST] <_julian> hm, surprisingly the bitrate does not change, no matter what avctx->bit_rate is set to
[09:48:07 CEST] <gr8> hi, I have an mkv file with two audio streams, 0: german dts and 1: english AC3. I want to extract the zero-th stream in a given time interval. How do I do that?
[09:48:22 CEST] <gr8> I want the quality to be very high, if possible
[09:50:34 CEST] <Nosomy> gr8 use -c:a copy option with map option
[09:50:35 CEST] <relaxed> gr8: ffmpeg -i input -map 0:a:0 output.flac
[09:51:53 CEST] <Nosomy> without "copy" ffmpeg will reencode.
[09:52:30 CEST] <gr8> relaxed: using that command, ffmpeg asks if I really want to replace $input ?!
[09:52:49 CEST] <gr8> ah no, sorry
[09:52:53 CEST] <gr8> pressed tab once too often
[09:53:54 CEST] <gr8> it results in an empty file
[09:56:34 CEST] <gr8> alright I think this works now
[10:02:13 CEST] <satiender> Hi any body use ffmpeg for android ???
[10:04:57 CEST] <benbro> anYc: if you cut at keyframes, why there are glitches?
[10:05:34 CEST] <benbro> anYc: you have three parts - beginning|body|end
[10:06:00 CEST] <benbro> you re-encode beginning and end. you cut body at keyframes and copy
[10:06:07 CEST] <benbro> shouldn't it fit exactly?
[10:11:22 CEST] <anYc> that's what I was thinking as well. maybe it has something to do with the starting offset of the streams. if you look at them with ffprobe, the video frames sometimes start at 0.08s while the audio starts earlier
[10:12:45 CEST] <gr8> yeah this is perfect, thanks a lot guys
[10:13:05 CEST] <pinPoint> gr8: what was the command you used?
[10:14:24 CEST] <gr8> ffmpeg -i input -ss $time -t $length -map 0:1 output.flac
[10:15:16 CEST] <anYc> benbro: it that is the issue, it may work if the streams are separated, concatenated and then muxed together. but I didn't try it and started to write avcut instead
[10:15:53 CEST] <pinPoint> gr8: you are going to rejoin the english with the mkv I assume?
[10:15:56 CEST] <benbro> anYc: ok
[10:17:08 CEST] <gr8> pinPoint: nope, working further with Audacity on the output
[10:17:18 CEST] <pinPoint> ok
[10:20:04 CEST] <benbro> anYc: I had a problem concatenating when crf between parts was wrong
[10:20:25 CEST] <benbro> anYc: is it possible to detect the quantization to make the three parts match?
[10:23:57 CEST] <gr8> curiously the index seems to be broken a bit, because when selecting a time with VLC, the time cursor jumps a bit forward
[11:09:08 CEST] <satiender> Hi , Anybody do working on ffmpeg for android
[11:25:25 CEST] <gr8> satiender: you need to ask correct questions.
[11:26:26 CEST] <satiender> gr8: I am doing work on ffmpeg more than 1.6 year but command line
[11:26:37 CEST] <gr8> ok
[11:26:39 CEST] <satiender> gr8: Now I want use it in android
[11:26:41 CEST] <gr8> ok
[11:26:47 CEST] <satiender> I done that
[11:26:53 CEST] <gr8> nice
[11:26:59 CEST] <satiender> ffmpeg working on android perfectly
[11:27:02 CEST] <gr8> great
[11:28:39 CEST] <satiender> but problem is that I want mix two videos
[11:29:04 CEST] <satiender> means one is text video and another is proper playback video
[11:29:30 CEST] <satiender> I search a lot on google I not get anything
[11:29:45 CEST] <satiender> gr8: can you help me
[11:29:48 CEST] <satiender> ??
[11:30:09 CEST] <gr8> nope. Wait until someone answers, it may take a while.
[11:31:18 CEST] <satiender> ok
[11:31:53 CEST] <satiender> gr8: Anothe thing is that how we can use ffmpeg binary in android apk
[11:45:32 CEST] <JEEB> the usual way? you build a shared library and load it up?
[11:45:43 CEST] <JEEB> in the NDK documentation you have plenty of information on this AFAIK
[11:48:07 CEST] <codingquark> Question: I have one video on top of another (scaled) via overlay. After fading out, it keeps a black area. Anyway I could remove that black area?
[12:20:19 CEST] <codingquark> Does it have to do something with video formats? Input and output are mp4
[13:00:38 CEST] <satiender> JEEB: you mean if I use .so files of ffmpeg then I can directly using following command :
[13:01:14 CEST] <satiender> ffmpeg -i /sdcard/video.ts -vcodec copy -acodec  copy  -f mpeg2video video.mp4
[13:05:10 CEST] <maseck> ffmpeg -i video.mp4 -threads 1 video.y4m doesn't seem to decode on one thread. Any advice?
[13:07:30 CEST] <qwebirc58121> hello
[13:07:42 CEST] <qwebirc58121> does anyone know how i trim mp4 video-only without reencoding it
[13:12:44 CEST] <maseck> Ok, I figured it out.
[13:13:15 CEST] <maseck> Ok, I figured it out. "ffmpeg -threads 1 -i video.mp4 video.y4m" was what I wanted.
[13:13:56 CEST] <maseck> Is ffh264 the default decoder for h264 video?
[13:23:56 CEST] <anYc> benbro: oh, I don't know that much about ffmpeg and h264, sorry
[14:12:03 CEST] <DHE> maseck: there are 2 h264 decoders. one is pure software, one uses vdpau on your graphics card but is only usable for video playback
[14:12:41 CEST] <maseck> Is the software on ffh264?
[14:12:49 CEST] <maseck> *one
[14:13:32 CEST] <DHE> probably...
[14:13:48 CEST] <DHE> a checking of the documentation says there are other h264 decoders and the two above are all I have available to me. :)
[14:27:23 CEST] <Duridurum> Hi there. Build of ffmpeg failed in fritzbox-freetz current trunk version.
[14:27:38 CEST] <Duridurum> ah, never mind. Forgot to set TMPDIR
[15:15:15 CEST] <Chagalle> I can't seem to read standard error/output from ffmpeg on Linux (from debian jessie package manager), what's wrong with it?
[15:16:02 CEST] <Chagalle> using Qt, while QProcess.waitForReadyRead() -> readAllStandardError/Output, neither outputs anything. Works on Windows
[15:28:51 CEST] <Chagalle> also is there any way to get progress with 2 pass encoding without calculating it based on duration and frame rate?
[15:53:38 CEST] <bove> Can a concat list file hold separate audio and video files?
[16:14:05 CEST] <waressearcher2> can I ask about audacity ?
[16:14:12 CEST] <waressearcher2> I loaded "project_name" and it showed dialog window with message "project check of project_name folder found 2 orphan block files, these files are unused by the project but might belong to other projects, they are doing no harm and are small", what could be the reason they appeared ? can I delete them ?
[16:16:16 CEST] <zenny> Hi how to pipe the ffmpeg output to the v4l2 looback device?
[16:18:51 CEST] <zenny> I am trying to capture a screen and then output to the v4l2 loopback device, fyi.
[16:26:21 CEST] <kiki67100> Hello everybody
[16:26:34 CEST] <kiki67100> I would to resize simple mp4 video but ffmpeg show error message
[16:26:55 CEST] <kiki67100> Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height
[16:26:59 CEST] <kiki67100> Someone help me ?
[16:27:45 CEST] <kiki67100> Here the output
[16:27:45 CEST] <kiki67100> http://pastebin.com/r1SujkaF
[17:00:41 CEST] <Duridurum> maybe incorrect parameters such as bit_rate, rate, width or height, kiki67100
[19:19:26 CEST] <zenny> Is there a way that I can output the ffmpeg capture to the v4l2 loopback device?
[19:19:36 CEST] <zenny> or say pipe to?
[19:20:22 CEST] <klaxa> you can output to a pipe like so for example: ffmpeg -i input.mkv -c copy -f matroska - | cat -
[19:25:56 CEST] <zenny> klaxa: That I know of. But how can I pipe to the v4l2loopback device?
[19:26:34 CEST] <klaxa> ooh, it's like a virtual device?
[19:26:42 CEST] <zenny> yes
[19:27:20 CEST] <klaxa> maybe like ffmpeg -i input.mkv -f v4l2 /dev/video0 or something?
[19:27:27 CEST] <klaxa> v4l2 is an output format at least
[19:27:33 CEST] <zenny> that is the capture part.
[19:28:33 CEST] <zenny> I guess this example will give you some idea. http://ubuntuforums.org/showthread.php?t=901612&p=5669427#post5669427 However, they are outdated and mjpegtools_yuv_to_v4l part in that instructions does not compile
[19:29:18 CEST] <klaxa> wait
[19:29:21 CEST] <klaxa> what do you want to do?
[19:29:21 CEST] <zenny> klaxa: I want to capture a screenshot and pipe to a virtual device.
[19:30:02 CEST] <klaxa> what's your virtual device called?
[19:30:26 CEST] <klaxa> like i said, it should be possible with ffmpeg [something something] -f v4l2 /device/name
[19:30:36 CEST] <klaxa> maybe it needs specific codecs
[19:31:36 CEST] <zenny> @klaxa: you are talking about capture part which I can do that with the x11grab, but how to output (pipe to the virtual device)?
[19:31:49 CEST] <klaxa> no i am not
[19:32:26 CEST] <klaxa> your recording probably looks like this: ffmpeg -f x11grab -framerate 30 -s 1920x1080 -i :0.0 output.mp4
[19:32:41 CEST] <klaxa> instead of output.mp4 you want to pipe it to a special device file
[19:32:49 CEST] <zenny> Something like: ffmpeg -f x11grab -s 640x480 -r 5 -i :0.0 -pix_fmt yuv420p -s 320x240 -r 5 -f yuv4mpegpipe -an - | | mjpegtools_yuv_to_v4l /dev/video2
[19:33:13 CEST] <zenny> I can get the first part, but not the latter part.
[19:33:19 CEST] <klaxa> replace -r with -framerate (it's "more correct", see the manpage)
[19:33:41 CEST] <klaxa> what's that double pipe doing there?
[19:33:46 CEST] <klaxa> pasting error?
[19:33:50 CEST] <zenny> that is a typo
[19:33:57 CEST] <klaxa> well what's not working?
[19:34:04 CEST] <zenny> single pipe and I would like to know how to pipe?
[19:34:04 CEST] <klaxa> can you pastebin the complete output?
[19:34:18 CEST] <klaxa> it looks correct
[19:34:53 CEST] <zenny> The mjpegtools_yuv_to_v4l tool from http://panteltje.com/panteltje/mcamip/mjpegtools_yuv_to_v4l-0.2.tgz is so old that it is not compiling. And I thought maybe ffmpeg has natively built this.
[19:35:26 CEST] <klaxa> have you tried using -f v4l2 /dev/video2 instead of using a pipe?
[19:35:38 CEST] <klaxa> or just -f v4l2 - > /dev/video2
[19:35:57 CEST] <klaxa> instead of -f yuv4mpegpipe -
[19:36:05 CEST] <klaxa> you can also get rid of the -an
[19:38:44 CEST] <klaxa> if there's something you don't understand just ask
[19:40:15 CEST] <zenny> ffmpeg -report -f x11grab -s 640x480 -r 5 -i :0.0 -pix_fmt yuv420p -s 320x240 -r 5 -f image2pipe - | ffmpeg -f v4l2 /dev/video7 tried with this, but didn't work.
[19:43:41 CEST] <zenny> Error: Output #0, v4l2, to '/dev/video7': Output file #0 does not contain any stream. /dev/video7 is the v4l2loopback device.
[19:47:12 CEST] <zenny> This works alright: $ ffmpeg -report -f x11grab -s 1920x1080 -r 5 -i :0.0 -pix_fmt yuv420p -f mjpeg -r 5 -f yuv4mpegpipe - | ffplay - &>/dev/null
[19:47:50 CEST] <zenny> but the question is how to pipe the screencast to v4l2loopback virtual device?
[19:48:49 CEST] <klaxa> well the first doesn't work, because you don't have an input for the ffmpeg process you called
[19:49:29 CEST] <klaxa> have you tried: ffmpeg -report -f x11grab -s 1920x1080 -framerate 5 -i :0.0 -pix_fmt yuv420p -c:v mjpeg -f v4l2 /dev/video7
[19:49:38 CEST] <klaxa> or replace v4l2 with yuv4mpegpipe
[19:49:41 CEST] <klaxa> not sure if that will work though
[19:51:05 CEST] <zenny> klaxa: yes I did and didn't work. Says "Incompatible pixel format 'yuv420p' for codec 'mjpeg', auto-selecting format 'yuvj420p' [swscaler @ 0x2e7d720] deprecated pixel format used, make sure you did set range correctly [v4l2 @ 0x2e76f40] V4L2 output device supports only a single raw video stream"
[19:51:17 CEST] <klaxa> ah
[19:51:21 CEST] <klaxa> try -c:v rawvideo then
[19:51:23 CEST] <zenny> And "Could not write header for output file #0 (incorrect codec parameters ?): Invalid argument"
[19:51:29 CEST] <klaxa> instead of -c:v mjpeg
[19:53:15 CEST] <zenny> @klaxa: thanks the latter worked. :D
[19:53:23 CEST] <klaxa> :)
[19:53:50 CEST] <klaxa> ok then off to the shower~
[19:54:06 CEST] <zenny> have a nice shower, then ;-) and thanks for helping!
[20:02:28 CEST] <blue_misfit> hey guys... anyone know offhand if XDCAM HD422 supports adaptive GOP or if it MUST be fixed for compatibility?
[20:07:20 CEST] <ChocolateArmpits> blue_misfit: should support
[20:07:31 CEST] <blue_misfit> neat :)
[20:07:55 CEST] <blue_misfit> I'm making some workflows to encode MEPG-TS with an XDCAM HD422 compatible essence that can be rewrapped to MXF for playout if necessary
[20:07:56 CEST] <ChocolateArmpits> Well if judging by the last gop is enough for you
[20:08:13 CEST] <ChocolateArmpits> Also I'm looking at an XDCAM HD 35 file
[20:08:23 CEST] <ChocolateArmpits> basically 4:2:0 35mbps equivalent
[20:08:29 CEST] <blue_misfit> hmmm
[20:08:43 CEST] <blue_misfit> yeah that may not be apples to apples, pretty sure XDCAM HD is VBR
[20:08:48 CEST] <ChocolateArmpits> it uses same mpeg2 encoding so I'm not all that worried
[20:08:50 CEST] <blue_misfit> whereas HD422 is CBR
[20:09:54 CEST] <ChocolateArmpits> Dang I only have color bars test footage here
[20:10:04 CEST] <ChocolateArmpits> So the bitrate viewer results may not be accurate
[20:10:09 CEST] <blue_misfit> gotcha
[20:10:11 CEST] <ChocolateArmpits> though it stays cbr
[20:10:14 CEST] <blue_misfit> welp I'll just test
[20:10:29 CEST] <blue_misfit> I'm using Harmonic WFS to make this file and can test with real playout gear so it shouldn't be too hard
[20:12:53 CEST] <ChocolateArmpits> There is bmx library for wrapping up mxf files, but you will have to unwrap the essence in the ts prior to wrapping the ts. With ffmpeg this is a one step process..
[20:13:15 CEST] <ChocolateArmpits> I mean wrapping the essence
[20:14:26 CEST] <ChocolateArmpits> It has plenty of nice tweaking options not really available with ffmpeg and can wrap to multiple flavours for delivery
[20:14:59 CEST] <ChocolateArmpits> I'm personally using it to concatenate mxf files for archival
[20:18:03 CEST] <blue_misfit> interesting!
[20:18:42 CEST] <blue_misfit> We use Telestream stuff to rewrap because we also usually need to merge in caption data from SCC files - e.g. taking the 608 data and synthesizing 708 data and then storing all of it in a SMPTE 436M VANC track
[20:18:53 CEST] <blue_misfit> FlipFactory and Vantage are out go-to apps for this
[20:25:14 CEST] <ChocolateArmpits> So does ffmpeg step into your workflow anywhere ?
[20:55:21 CEST] <bf_> Hey, can anybody help me to strip the audio track from an mkv into a mp3 file using liblame?
[20:55:35 CEST] <bf_> I have found some ffmpeg command from 2009, but it won't work
[20:57:26 CEST] <ChocolateArmpits> bf_: ffmpeg -i [input.mkv] -map 0:a -vn -acodec libmp3lame -b:a 256k   [output.mp3]
[20:57:28 CEST] <ChocolateArmpits> like this ?
[20:58:01 CEST] <ChocolateArmpits> this presumes that your mkv has only one audio track
[20:58:02 CEST] <bf_> oh thanks
[20:58:20 CEST] <bf_> I was stuck with having multiple map commands, and didn't know i could just use "a" (I suppose it means audio)
[20:58:37 CEST] <ChocolateArmpits> yeah it basically means "everything audio"
[20:59:02 CEST] <ChocolateArmpits> you can do a more specific map like 0:a:0 which would map the first audio track of the first input
[20:59:17 CEST] <bf_> thats pretty, cool. I think it works ChocolateArmpits, thank you so much
[20:59:34 CEST] <ChocolateArmpits> map_channel is even more specific allowing to remap channels in tracks
[20:59:35 CEST] <bf_> Previously I had a command with -map 0:0 - map 1:0 -map 2:0 iirc
[20:59:57 CEST] <ChocolateArmpits> well that's a confusing map
[21:00:25 CEST] <ChocolateArmpits> the mapper should have his cartography club membership revoked
[21:00:50 CEST] <ChocolateArmpits> but yeah, it helps if you the documentation
[21:00:55 CEST] <ChocolateArmpits> read *
[21:01:10 CEST] <ChocolateArmpits> the examples there are mostly common use case
[21:03:34 CEST] <onyx-> Im using nginx with the rtmp module that uses ffmpeg to transcode a live stream from an IP camera
[21:04:01 CEST] <onyx-> its working but after a few minutes it stops and I have to restart nginx for it to start working again
[21:04:14 CEST] <onyx-> any idea what can be causing this issue?
[21:06:48 CEST] <bf_> :D ChocolateArmpits good to see you take that with humor :
[21:06:49 CEST] <bf_> :)
[21:07:12 CEST] <bf_> onyx-: maybe nginx is really not made to be used in such a scenario?
[21:07:32 CEST] <bf_> I mean if there is a memory leak somewhere it might run out of memory and stop
[21:08:35 CEST] <onyx-> its a 2gb ram server, I been trying to see if nginx erros out but it doesnt
[21:10:52 CEST] <onyx-> how do I check the ffmpeg error log?
[21:11:27 CEST] <ChocolateArmpits> there's a -report command that outputs all log to a file
[21:11:49 CEST] <ChocolateArmpits> -loglevel sets the logging level, check documentation for accurate description of values
[21:11:56 CEST] <onyx-> ok
[21:32:16 CEST] <blue_misfit> ChocolateArmpits, not really :)
[22:21:24 CEST] <xrisk> Hello folks, I'm building ffmpeg with lame, and even though the lame binary is on my path, I get a libmp3lame not found. Any ideas?
[22:22:19 CEST] <BtbN> ffmpeg does not use the lame binary.
[22:24:14 CEST] <xrisk> BtbN: oh, I did not know that. Can you tell me how it works?
[22:24:24 CEST] <xrisk> A link to some doc would be fine.
[22:24:32 CEST] <BtbN> It just uses the library.
[22:24:45 CEST] <BtbN> Which you already named yourself.
[23:31:35 CEST] <TikityTik> i forgot how to calculate bitrate based off duration and filesize
[23:31:52 CEST] <Mavrik> O.o
[23:31:59 CEST] <Mavrik> divide filesize with duration? :P
[23:32:07 CEST] <Mavrik> The unit of bitrate IS bits/s :)
[23:32:46 CEST] <ln-> danger! if the duration is 0, do not divide by it, or bad things happen.
[23:33:19 CEST] <TikityTik> so how?
[23:33:50 CEST] <TikityTik> kbps = 4096 Kb / 1 min 30 seconds?
[23:34:15 CEST] <TikityTik> err nvm
[23:34:47 CEST] <TD-Linux> you need to convert from microwave time to seconds
[00:00:00 CEST] --- Sat Oct 17 2015

More information about the Ffmpeg-devel-irc mailing list