[Ffmpeg-devel-irc] ffmpeg.log.20151017

burek burek021 at gmail.com
Sun Oct 18 02:05:01 CEST 2015

[00:24:19 CEST] <Guest6668> d
[00:24:52 CEST] <Guest6668> Hello , I would love to help your on ffmpeg , in fact I try to apply a watermark text as follows DrawText = " fontfile = / var / www / test / arial.ttf : text = \" http © \ : \ / \ / www \ .test \ .com \ ' : fontcolor=white at 1.0 : fontsize = 36: x = ( w- text_w ) / 2 : y = h- th- 10: 1 box = : = black boxcolor @ 0.4 " this one applies well by cons on small size videos (height / width ) réelement the watermark is too big. I want to
[00:25:59 CEST] <Guest6668> the watermark text taking into account the size of the video, thank you very much for your help and sorry for my poor english lol
[00:26:18 CEST] <zenny> Hi, I have a multiseat setup. I am trying to capture the xserver running in :1 from the xerver running in :0, but reports "Cannot open display :1.0, error 1. :1.0: Input/output error"
[00:26:48 CEST] <zenny> Using a command, "$ ffmpeg -report -f x11grab -s 1920x1080 -framerate 5 -i :1 -pix_fmt yuv420p -c:v rawvideo -f v4l2 /dev/video7"
[00:30:41 CEST] <zenny> xservers are run with the commands as shown in http://picpaste.com/8S44ALch.png
[00:31:38 CEST] <Guest6668> what zenny my ?
[02:12:27 CEST] <BasisBit> Zeranoe, is ffmpeg 2.8.1 supposed to have an older version number for libavutil than 2.8.0?
[02:29:33 CEST] <BtbN> The libav* version numbers are not related to the main ffmpeg version number.
[02:30:29 CEST] <BasisBit> BtbN, I know. was talking about ffmpeg 2.8.1^^
[02:30:42 CEST] <BtbN> hm?
[02:31:43 CEST] <BtbN> the libav* version numbers should be the same within the same release. Or what do you mean?
[02:35:07 CEST] <BasisBit> I mean, that the libavutil version number in the ffmpeg 2.8.1 package is older then the libavutil version number in 2.8.0 release. nothing else.
[02:36:49 CEST] <BtbN> So what exactly are those two version numbers?
[03:28:15 CEST] <Prelude_Zzzzz> hey everyone.. good evening.. anyone know what this means ? Failed to open segment of playlist 0 .. keeps going and then shows up and then keeps going and shows up.. not sure what to do about it
[04:02:56 CEST] <DHE> playing an HLS stream? or other online streaming service
[04:06:50 CEST] <Prelude_Zzzzz> HLS stream
[04:07:06 CEST] <Prelude_Zzzzz> funny thing is.. i am playing in  VLC and it seems better
[04:07:22 CEST] <Prelude_Zzzzz> but soon as i pull with FFMPEG frame rate drops and the errors start
[04:17:56 CEST] <Zeranoe> BasisBit: where are you seeing that
[04:20:48 CEST] <DHE> is there a way to get the 'qp' value of an encoded h264 video frame? after the fact obviously. an estimate is fine. want to compare different encoders' quality
[04:26:05 CEST] <Prelude_Zzzzz> seesm that settings buffer_size=10000k helps
[04:26:12 CEST] <Prelude_Zzzzz> or maybe not
[08:27:58 CEST] <inflex> trying to adjust some source code to make ffmpeg generate fragmented mp4 files ( ie, moov atom at the start, not end ) but can't seem to get it to do that.  Have tried  av_opt_set(oc, "movflags", "+empty_moov", 0); and +frag_keyframe but still the same output.  Any recommendations?
[08:54:24 CEST] <inflex> tried faststart as well, still the same
[08:58:08 CEST] <v32itas> hi
[09:00:29 CEST] <v32itas> Maybe there is a simple way to do 'gif + ogg' or 'gif + mp3' ? I want to make video clips out of OpenBSD songs http://www.openbsd.org/lyrics.html for open source propoganda there are just a few available on youtube and I'm not ant expert on these things it looks tricky
[09:01:30 CEST] <v32itas> audio video codecs ... -_-
[10:15:35 CEST] <waressearcher2> is anyone here ?
[10:15:53 CEST] <waressearcher2> what are keyframes exist what is their purpose ?
[10:18:15 CEST] <xerox> waressearcher2: https://en.wikipedia.org/wiki/Video_compression_picture_types aka I-frames
[10:19:21 CEST] <waressearcher2> what
[10:19:26 CEST] <waressearcher2> you mean read ?
[10:20:13 CEST] <xerox> I mean read
[10:21:28 CEST] <inflex> nope nope nope and nope... just can't seem to get this mp4 to be written as fragmented mode :(
[10:25:08 CEST] <waressearcher2> inflex: smoking ?
[10:25:37 CEST] Action: inflex doesn't smoke.
[11:14:09 CEST] <Mavrik> inflex, how about switching to a container that's actually meant for streaming? :)
[11:29:33 CEST] <psiklops> Hi Does ffmpeg support https out of the box or must i enable this feature when configuring ?
[11:31:59 CEST] <Mavrik> psiklops, yes you need to enable the SSL lib - either gnutls or openssl.
[11:33:30 CEST] <psiklops> Mavrik, can i set both options in ./configure --enable-openssl --enable-gnutls  ?
[11:34:43 CEST] <psiklops> Mavrik, what effects would this have ?
[11:34:58 CEST] <psiklops> Mavrik, thanx
[11:35:47 CEST] <Mavrik> Uh.
[11:36:22 CEST] <Mavrik> Having two libraries doing the same thing will cause you compilation collisions :)
[11:40:35 CEST] <psiklops> ok
[11:40:39 CEST] <psiklops> :-)
[11:40:46 CEST] <psiklops> later
[11:44:20 CEST] <inflex> Mavrik: primarily the mp4 is being long-term stored / archival (security footage), it's just that during the writing process for each block it'd be nice to be able to play/view the partial file.  Switching to ismv format has resolved the issue partially, though bought about likely a new set of issues.
[12:00:01 CEST] <Mavrik> MP4 just isn't a streamable format in such a way :/
[12:00:15 CEST] <Mavrik> MOOV atom cannot be written before the file is complete and the fragmented mode is silly just for storage.
[12:00:24 CEST] <Mavrik> (Since it's not widely compatible with all players.)
[12:01:51 CEST] <inflex> Any suggestions/recommendations?  Right now the stream comes from rtsp h264 sources (ip security cams),  stream is simply put in to the mp4 container and saved in (say) 10 minute blocks
[12:04:12 CEST] <inflex> Existing commercial suites already do this and provide the ability to watch past events/time from 0 seconds.  Only thing I can think of is a temporary file suited for immediate playback (MJPEG?) though it's a bit of a CPU/IO hit.
[12:16:21 CEST] <Mavrik> Why not keep files in MPEG2-TS format?
[12:16:34 CEST] <Mavrik> It's built for streaming and can be arbitrarily seeked.
[12:16:53 CEST] <Mavrik> Other suites implement a full streaming server that fakes MOOV stuff.
[12:21:20 CEST] <inflex> Thanks.
[12:23:42 CEST] <noob> Hello. I'm on Windows, using zeranoe's ffmpeg bild (ffmpeg-20151017-git-e9299df-win64-static). Here is my question: I'm trying to cut an .mkv file with hevc (h265) codec, I want to keep the second part of it from a given point to the end of it.
[12:23:49 CEST] <noob> If I use either "ffmpeg -i a.mkv -acodec copy -vcodec copy -ss 00:00:01.25 1.mkv" or "ffmpeg -i a.mkv -ss 00:00:01.25 -acodec copy -vcodec copy 1.mkv" the resulting video has the correct length, but the video doesn't show at all (it remains black).
[12:23:54 CEST] <noob> But if I use "ffmpeg -ss 00:00:01.25 -i a.mkv -acodec copy -vcodec copy 1.mkv" it doesn't make any cut at all, it shows the video, but from the beginning, instead of starting at 1.25 seconds.
[12:23:59 CEST] <noob> If I don't chose -vcodec copy then it makes the cut and the video shows, but it uses h264 as default, but I need the video codec and everything to be exactly the same as the source video, since I want to merge it afterwards. Am I doing something wrong? Is there any way to achieve it? Thanks for any help you can provide me.
[15:55:51 CEST] <jebeke> hey folks, hoping someone can point me tothe right information. I am trying to set the "Alternate Group ID" when encoding a file and I can find no mention of how to do so in any of the documentation. Is it possible?
[16:31:47 CEST] <lenovo> Hey is there a way I can compile the lastest ffmpeg on FreeBSD system ?
[16:32:05 CEST] <klaxa> ./configure && make
[16:32:09 CEST] <lenovo> it seem that on NeXTBSD system in ports the ffmpeg is broken.
[16:32:41 CEST] <lenovo> it breaks at when trying to compile libavutil and stop at error.o
[16:32:52 CEST] <klaxa> pastebin your config.log
[16:32:56 CEST] <lenovo> sure
[16:33:03 CEST] <lenovo> give me a min here
[16:36:08 CEST] <lenovo> http://pastebin.com/2b26GEGa
[16:38:03 CEST] <lenovo> http://pastebin.com/gCPauR9c
[16:38:44 CEST] <klaxa> huh
[16:38:46 CEST] <waressearcher2> ./configure && make && make install && make clean
[16:38:46 CEST] <klaxa> that's weird
[16:40:03 CEST] <lenovo> i think it probably to do with the Mach IPC kernel bits on NeXTBSD, since NeXTBSD is using some Darwin stuff with freebsd-current branch
[16:40:23 CEST] <klaxa> ok
[16:40:29 CEST] <c_14> Can you upload /usr/include/sys/_lock.h ?
[16:40:30 CEST] <klaxa> i'm not familiar with *BSD
[16:40:40 CEST] <lenovo> sure
[16:40:50 CEST] <c_14> And maybe grep for u_int in /usr/include
[16:41:10 CEST] <c_14> preferably a typedef or a define
[16:42:06 CEST] <c_14> Is this a regression?
[16:42:12 CEST] <c_14> Have you ever compiled ffmpeg on NeXTBSD before?
[16:43:55 CEST] <lenovo> http://pastebin.com/Mij0pQfj
[16:44:51 CEST] <lenovo> well ffmpeg install ok on the pkg (binary source) but i need other features like x11grab and mp3lame so with the binary source its not preset with it
[16:45:46 CEST] <lenovo> so i need to use ports and usually i never had problems with ffmpeg so this will be the first time doing it on NeXTBSD i have done it many times of FreeBSD system and always work good.  NeXTBSD is basicly FreeBSD current using the core bits of darwin into the freebsd unstable branch
[16:50:37 CEST] <JEEB> well it's a whole different system :P
[16:50:47 CEST] <lenovo> not entirely
[16:50:57 CEST] <lenovo> it still uses FreeBSD userland
[16:51:01 CEST] <JEEB> yes, but in a lot of core system related ways
[16:51:33 CEST] <lenovo> Well yes i see where the error stops at the mach part in the error i get when trying to compile ffmpeg
[16:52:05 CEST] <lenovo> well you can compile ffmpeg on Darwin right ?
[16:52:16 CEST] <JEEB> the OS X flavour, yes
[16:52:34 CEST] <JEEB> basically somewhere deep in mach there's an 'u_int' required which is not included :P
[16:52:38 CEST] <JEEB> that could be a toolchain issue
[16:52:44 CEST] <lenovo> hmm
[16:53:42 CEST] <JEEB> I would recommend poking the nextbsd folk or whomever are dealing with the system libraries about this first
[16:53:54 CEST] <lenovo> i have mention it
[16:54:09 CEST] <lenovo> i'm just trying to get it to work as i ant to use ffmpeg :)
[16:54:21 CEST] <lenovo> but thanks i will mention this to them
[16:54:26 CEST] <JEEB> pretty hard when it's the system going nope :P
[16:56:14 CEST] <JEEB> does that happen when you just clone the FFmpeg repo and do './configure' in it?
[16:56:29 CEST] <JEEB> or only with all those over 9000 options that the ports system (?) is poking at it
[16:59:03 CEST] <lenovo> its ports
[16:59:18 CEST] <lenovo> i havn't got the src code should i try it alone
[17:00:36 CEST] <lenovo> i'm getting the ffmpeg git source now
[17:02:56 CEST] <lenovo> i don't think freebsd 10x and up can use gcc it is using clang
[17:03:08 CEST] <lenovo> could probably cross compile
[17:06:23 CEST] <lenovo> ok
[17:06:31 CEST] <lenovo> well it failed with a clean source too
[17:06:48 CEST] <lenovo> with the same error i'm guessing something is up with mach_time.h and mach_types.h
[17:07:13 CEST] <JEEB> and with a simple configure? can you look at how the binary package was configured?
[17:07:23 CEST] <JEEB> since you said you had a binary package
[17:08:08 CEST] <lenovo> Well yeah it install ffmpeg with a pkg install ffmpeg
[17:08:43 CEST] <UNIXn3rd> unless its not designed to be compiled on Oses with Mach Kernels yet
[17:10:16 CEST] <JEEB> lenovo: just find out how that was configured :P
[17:12:03 CEST] <lenovo> UNIXn3rd: it compiles on Darwin which is using a mach kernel, as to NeXTBSD is a simular model
[17:13:02 CEST] <lenovo> it does install using the binary package but with the source base package it won't install something is wrong here :/ i notice a ffmpeg0 in ports too
[17:13:05 CEST] <lenovo> hmm
[17:13:51 CEST] <DHE> Which is better for comparing video encoder quality? SSIM or PSNR? (using the ffmpeg filters of the same name for testing settings)
[17:13:58 CEST] <c_14> ssim
[17:14:12 CEST] <JEEB> neither of those is as good as human eyes
[17:14:16 CEST] <c_14> Your eyes are usually the best bet though.
[17:14:30 CEST] <JEEB> but generally SSIM is a more modern way of checking that doesn't like blur as much
[17:14:40 CEST] <lenovo> haha tahts the older ffmpeg version which doesn't work and i don't understand why thats still there :/
[17:14:43 CEST] <DHE> true, but when there's tons of results to go through it's nice to let the computer do the work
[17:15:27 CEST] <lenovo> thanks JEEB
[17:15:44 CEST] <lenovo> i suppose its up to the maintainer on NeXTBSD to fix this.
[17:15:47 CEST] <lenovo> cheers
[17:16:53 CEST] <JEEB> DHE: just remember that you are thus not really talking about quality but SSIM in that case. some psychovisual optimizations lower both SSIM and PSNR
[17:17:13 CEST] <JEEB> and encoders like x264 have specific tunings for ssim or psnr
[17:21:08 CEST] <DHE> I'm comparing quality for speed of encoding mostly... comparing nvenc settings and libx264 settings
[17:22:05 CEST] <DHE> nVidia's own presentation slides say nvenc can get better ssim/psnr vs x264. I'm calling test methodology looks flawed.
[17:22:55 CEST] <JEEB> well psnr or ssim are not quality
[17:23:00 CEST] <JEEB> that's what you check with your eyes
[17:23:19 CEST] <JEEB> anyways, just remember to use psnr or ssim optimizing settings with both encoders
[17:23:33 CEST] <JEEB> because any sane encoder optimizers for psy-opts by default
[17:23:37 CEST] <JEEB> *optimizes
[17:23:51 CEST] <JEEB> (including x264, and yes - that lowers both ssim and psnr score)
[17:26:15 CEST] <DHE> I was afraid of that...
[18:16:50 CEST] <StephenS> c_14, you are very active in here? :D
[18:17:25 CEST] <StephenS> btw, to ffmpeg users, how come that the same video, only taken in diff resolution cannot be played on old browsers, and the other one in smaller resolution, can? Its the same codec and all..
[18:18:07 CEST] <StephenS> I can paste ffmpeg -i vid if you want to take a look?
[18:19:58 CEST] <c_14> Either because the browser is stupid, or because you oversaw something.
[18:22:08 CEST] <StephenS> here is the paste http://pastebin.com/Q926QAnu
[18:22:16 CEST] <StephenS> c_14, you can take a look if you wish :D
[18:22:36 CEST] <StephenS> thats transcoded video, because of rotation tag, which android adds for portrait orientation, by default.
[18:22:42 CEST] <StephenS> both are transcoded btw
[18:24:53 CEST] <StephenS> bitrate is also different, alot, but everything else, is the same
[18:24:57 CEST] <StephenS> what might be the issue?
[18:25:34 CEST] Action: c_14 is going to go with browsers being stupid
[18:25:57 CEST] <StephenS> heh :D
[18:26:06 CEST] <StephenS> it was tested on firefox btw
[18:26:13 CEST] <StephenS> and both of my friends (one male and one female) have FF
[18:26:32 CEST] <StephenS> female friend have 27.0.1 of ff
[18:26:46 CEST] <StephenS> for a male one, I dont know, but its impossible that its so old version
[18:26:59 CEST] <StephenS> I mean, how on earth facebook and youtube have those failovers..?
[18:27:07 CEST] <StephenS> Actually its not about fallback either, its something with the video
[18:27:16 CEST] <StephenS> how can I make video available on older browsers?
[18:28:23 CEST] <c_14> webm/flash/hls probably all 3
[18:29:29 CEST] <StephenS> so what do you suggest?
[18:29:46 CEST] <StephenS> because for my friends, video diddnt worked when they accessed direct link, bla.com/vid.mp4
[18:29:52 CEST] <c_14> Don't use web browsers.
[18:30:04 CEST] <StephenS> yeah thats what I thought
[18:30:07 CEST] <c_14> They are without exception awful.
[18:30:10 CEST] <StephenS> but I need 3 different versions of the same video
[18:30:13 CEST] <c_14> (As are most things)
[18:30:27 CEST] <StephenS> or am I missing something? :D
[18:30:40 CEST] <c_14> If you want it to work everywhere, yes. You might even need 4.
[18:30:48 CEST] <StephenS> heh
[18:30:55 CEST] <StephenS> and for now I only have video in mp4 format eh..
[18:30:56 CEST] <StephenS> :D
[18:31:55 CEST] <c_14> webm should get you the newer browsers, hls should get you ios + presumably android, flash will give you cancer, and mp4 for wherever that works and the other stuff doesn't
[18:33:12 CEST] <grublet> i've had people unable to play webms on their android phones
[18:33:20 CEST] <grublet> is that normal?
[18:34:09 CEST] <c_14> probably, everything's broken somewhere
[18:34:11 CEST] <c_14> What version?
[18:34:12 CEST] <DHE> hls does work on android. the chrome browser will play .m3u8
[18:34:13 CEST] <StephenS> c_14, yeah but how do you explain that the same format (mp4), can be played in ff, and the other one video, also mp4 cannot?
[18:34:19 CEST] <StephenS> the diff is in bitrate and resolution, only
[18:34:22 CEST] <StephenS> thats so weird
[18:37:13 CEST] <grublet> c_14: i woudln't know; they don't know and im new to smartphones
[18:37:20 CEST] <grublet> mine plays them and it's 4.4
[18:46:34 CEST] <Zxcvb> is it possible to convert a mp4/h264 video from profile level 4 to profile level 3.2 without transcoding?
[18:50:50 CEST] <DHE> no. adhering to a level is a matter of encoding parameters (eg: reference frames, image size, framerate)
[18:51:20 CEST] <DHE> you can specify a target level of 4 but if the settings meet the criteria it might already be 3.2 compatible
[18:53:25 CEST] <c_14> He's already gone.
[18:53:44 CEST] <DHE> 3 minute wait... nice.
[18:55:53 CEST] <StephenS> heh :D
[18:56:05 CEST] <StephenS> thats why I'm always here :) really helpful answers you guys have ;]
[19:02:46 CEST] <DHE> my next line would have been: https://en.wikipedia.org/wiki/H.264/MPEG-4_AVC#Levels
[19:51:09 CEST] <ahoo> hey
[19:51:50 CEST] <ahoo> i have a still image, and an mp3 file (music for youtube). how would i create the smallest possible file?
[19:51:59 CEST] <ahoo> i'm currently using -loop 1 for the image and -shortest
[19:52:17 CEST] <ahoo> but it's nowhere near the size of jpeg+mp3
[19:52:26 CEST] <ahoo> and it doesn't look like the first frame is actually hold
[19:52:36 CEST] <ChocolateArmpits> I think both mp4 and webm should support using image as an album art, so you don't have to actually render a video track out of the image
[19:52:39 CEST] <captainkraft> I'm trying to stream to Twitch. When I attempt to stream with music, the sound pops and crackles and I can't figure out how to fix it. This is the script I use to start streaming: http://pastebin.com/0tRazihe
[19:54:56 CEST] <c_14> ahoo: lower the framerate, increase the crf
[19:55:20 CEST] <ahoo> thx i'll try that
[19:58:07 CEST] <c_14> captainkraft: have you tried without -ar
[19:58:51 CEST] <captainkraft> I have not
[20:01:28 CEST] <captainkraft> c_14, FLV does not support sample rate 48000, choose from (44100, 22050, 11025). Audio codec mp3 not compatible with flv.
[20:02:12 CEST] <c_14> put the ar in front of -i pulse
[20:02:14 CEST] <JEEB> which audio format are you using?
[20:02:17 CEST] <c_14> ah
[20:02:19 CEST] <c_14> use aac
[20:02:22 CEST] <JEEB> because flv does support 48kHz with AAC
[20:02:43 CEST] <JEEB> (or well, it supports pretty much everything with it because it just says "set this to 44.1kHz and actually read the AAC stream for actual details)
[20:03:39 CEST] <JEEB> if you are using AAC already, then you just have an old FFmpeg because it was more than a year ago that additional sample rates were enabled for AAC in FLV
[20:03:42 CEST] <captainkraft> so '-aac 2' ?
[20:04:22 CEST] <JEEB> switch the acodec to any aac encoder :P
[20:04:48 CEST] <JEEB> libmp3lame is an mp3 encoder
[20:06:24 CEST] <captainkraft> I see. Thanks. Trying that now.
[20:06:55 CEST] <JEEB> also wat
[20:07:04 CEST] <JEEB> your pastebin says you're setting the audio rate
[20:07:36 CEST] <captainkraft> I took this script from somewhere and edited a few values. That was in the script already, so I assumed it was OK
[20:08:31 CEST] <JEEB> I'm just going off a leg here, but your pastebin has no b:a set
[20:08:41 CEST] <JEEB> did you even check at which audio bit rate you were encoding? :P
[20:09:11 CEST] <ahoo> hm
[20:09:49 CEST] <captainkraft> I set that earlier but didn't hear any change so I took it back out
[20:10:08 CEST] <captainkraft> I know very little about audio, so I'm going by what I can find online.
[20:10:27 CEST] <JEEB> the question still remains that did you actually see what the audio bit rate was set to in either case :P
[20:10:33 CEST] <ahoo> my mp3+still frame jpeg have a total size of 12 mb. the resulting mp4, even with -crf 1 and -r 1 is somewhere around 18 mb - is that the best i can get? what i would like is a frame hold at frame 0 and a resulting file size of about 13-14 mb
[20:10:52 CEST] <captainkraft> JEEB, I don't remember what I set it to before.
[20:11:10 CEST] <JEEB> I'm just going to bet that you were setting it too low for mp3
[20:11:22 CEST] <JEEB> and the default probably was something as funky as that
[20:11:30 CEST] <captainkraft> Gotcha, so I should use b:a to pick one. What rate should I use?
[20:11:56 CEST] <JEEB> whatever rate you require :P with mp3 you definitely don't want to go under 128k
[20:13:22 CEST] <captainkraft> If I switch to an aac encoder, what range should I use? I don't know how to tell what rate I require.
[20:15:35 CEST] <JEEB> depends on the aac encoder. if you are using an older version then the internal aac encoder is rather bad, but the patches that are improving it have finally lately almost fully gotten in
[20:16:00 CEST] <JEEB> with the internal one I usually went for 128-192k if I had to use it
[20:16:20 CEST] <JEEB> with the latest improvements you could possibly use it for lower rates as well
[20:20:03 CEST] <captainkraft> That's very helpful, thank you.
[20:23:52 CEST] <captainkraft> Does a higher bitrate reduce popping noises if you hear them while streaming?
[20:24:38 CEST] <captainkraft> I don't hear much difference when I go from 128k to 192k
[20:25:13 CEST] <JEEB> depends on if it's created by the encoding or on the quality of the encoder
[20:25:30 CEST] <JEEB> I would say that even the internal encoder shouldn't produce audible artifacts like that at 192kbps
[20:25:40 CEST] <JEEB> it did in like 2010-11 or so, that was a lot of fun :P
[20:26:49 CEST] <JEEB> also if you are live streaming it could be something related to not having enough perf to do the video+audio transcoding together with capture fast enough, although I have no idea if it would lead to that kind of noise :P
[20:27:25 CEST] <JEEB> I would probably try to write audio as wav first locally, then add the aac encoder, then add the rest
[20:27:32 CEST] <JEEB> and see at which point your artifacts start
[20:32:11 CEST] <captainkraft> This creates a wav file with the same artifacts 'ffmpeg -f alsa -i pulse -b:a 128k test.wav'
[20:32:28 CEST] <JEEB> uhh
[20:32:33 CEST] <JEEB> leave the bit rate out
[20:32:36 CEST] <JEEB> doesn't make sense
[20:32:42 CEST] <captainkraft> I did that as well, same result.
[20:32:46 CEST] <JEEB> ok
[20:32:51 CEST] <JEEB> then it's your input, simple as that
[20:51:24 CEST] <ahoo> thank you for your help
[20:51:28 CEST] <ahoo> and thank you for the music
[21:02:58 CEST] <captainkraft> JEEB, I've found out that the audio is clear when I record from digital stereo output. I don't get sound to my speakers, but it records to the wav file nicely. Is there a way to get ffmpeg to record that channel while my speakers output analog stereo?
[21:27:10 CEST] <brotherBox> Hey people, I'm having some problem compiling ffmpeg from the git with libx265 support on Ubuntu 14.04. It cant seem to find the libx265.so.75. I have read that it has to do with disabling shared flags, but its not clear to me if i need to set those on libx265 or on ffmpeg. Either way, I cannot get it to run. would someone explain to me how i can successfully compile it?
[21:27:52 CEST] <c_14> LD_LIBRARY_PATH=install_prefix/lib ffmpeg
[21:30:46 CEST] <brotherBox> c_14: that does it, wonderful! Is there a way to remove the environment variable and run it just with ffmpeg or is that required for now?
[21:31:21 CEST] <c_14> recompile with LD_RUN_PATH set, or with static libraries for x264.
[21:31:47 CEST] <brotherBox> *x265
[21:32:19 CEST] <c_14> eh, that
[21:32:25 CEST] <c_14> same difference
[21:33:35 CEST] <JEEB> you can in theory add the dir of your custom prefix into a config file under /etc/ld.so.conf.d/ and then run ldconfig as root every time you remove or add a shared library from there
[21:33:48 CEST] <JEEB> or you just have that env variable set by default :P
[21:34:32 CEST] <brotherBox> I'll try to compile x265 statically, but all that cmake stuff doesnt make it easy to me, i find it convoluted
[21:35:44 CEST] <brotherBox> if that doesnt work I'll aslias it in the shell and leave it be
[21:35:47 CEST] <brotherBox> *alias
[22:07:37 CEST] <StephenS> c_14, so .webm .mp4 and .ogv ? That would be enough for browsers? And also I have fallback to flash, if all three fail... and whats hls?
[22:09:21 CEST] <c_14> Don't know of any browsers supporting ogv.
[22:09:23 CEST] <c_14> https://en.wikipedia.org/wiki/HTTP_Live_Streaming
[22:09:45 CEST] <c_14> ffmpeg has hls output, just need to offer it via a http server
[22:11:44 CEST] <furq> firefox, opera and chrome support theora
[22:11:56 CEST] <furq> all the major browsers support h264 in mp4 now though
[22:12:10 CEST] <StephenS> yeah but older ones, I have issue with them :D
[22:12:34 CEST] <TD-Linux> what exact browser versions do you need?
[22:12:51 CEST] <StephenS> well to cover all major ones and older ones, till 10+ release
[22:12:51 CEST] <TD-Linux> don't use HLS unless you need it for other reasons
[22:13:07 CEST] <TD-Linux> I suggest using caniuse.com
[22:13:08 CEST] <StephenS> I dont need HLS in fact
[22:13:12 CEST] <furq> http://caniuse.com/#feat=mpeg4
[22:13:54 CEST] <TD-Linux> for 10 versions back you don't need theora, you can use webm vp9
[22:14:12 CEST] <TD-Linux> which covers the same set that support theora, but is newer and shinier
[22:15:01 CEST] <TD-Linux> but if you can do all three you'll get support for everything back to the earliest fx
[22:15:04 CEST] <furq> firefox has supported mp4 since 21 on windows and 26 on linux
[22:15:30 CEST] <TD-Linux> firefox mp4 support depends on the OS though, so on linux it only works if you have ffmpeg locally
[22:15:44 CEST] <furq> Firefox supports H.264 on Linux since version 26 if the appropriate gstreamer plug-ins are installed.
[22:15:48 CEST] <TD-Linux> (or on non-nightly, gstreamer-plugins-ffmpeg
[22:15:50 CEST] <TD-Linux> )
[22:16:14 CEST] <TD-Linux> but regardless, do mp4 and a free format to be safe (ogv, webm vp8 or vp9)
[22:16:23 CEST] <StephenS> well my friend had a problem playing video on FF 27.0.1
[22:16:26 CEST] <StephenS> and format is mp4
[22:16:35 CEST] <furq> why is he using firefox 27
[22:16:36 CEST] <StephenS> however, the same format mp4, in lower resolution, it played fine
[22:16:42 CEST] <TD-Linux> yeah not surprising, it took a while to get the OS support working well for mp4
[22:16:54 CEST] <TD-Linux> also it won't work on windows xp
[22:16:56 CEST] <StephenS> furq, it's a "she" and I have no idea
[22:17:17 CEST] <StephenS> but I need a way to fix this for older browsers
[22:17:37 CEST] <StephenS> I could play'd her str8 from flash, but then I need to cut off html5 video, which I dont want to
[22:17:50 CEST] <TD-Linux> StephenS, yeah, don't use flash, webm or ogv will fix it for you
[22:18:15 CEST] <StephenS> I thought about dropping mp4, and using only .webm
[22:18:20 CEST] <StephenS> webm is more supported I guess?
[22:18:59 CEST] <StephenS> also here is info about two videos http://pastebin.com/Q926QAnu
[22:19:02 CEST] <furq> it's not supported in IE or safari
[22:19:16 CEST] <StephenS> first one doesnt work on ff 27.0.1 and second one works fine, because bitrate is lower and its in lower resolution
[22:19:19 CEST] <StephenS> which is really weird
[22:19:30 CEST] <furq> and weirdly it apparently only has partial support in android browser
[22:19:33 CEST] <furq> nice work google
[22:19:38 CEST] <StephenS> lol
[22:19:53 CEST] <StephenS> so if I have 3 formats, how would I show my users, which format?
[22:20:03 CEST] <StephenS> I cant render each browser and check does it supports it
[22:20:23 CEST] <TD-Linux> StephenS, use 3 sources in your <video> tag, the browser will pick which one it supports
[22:20:32 CEST] <StephenS> actually I can do <video><source src="bla.mp4"></source><source src="newone.web"></source></video>
[22:20:34 CEST] <StephenS> webm*
[22:20:47 CEST] <furq> i was going to suggest just using mp4 and having a flash fallback player
[22:20:54 CEST] <StephenS> furq, thats what I have
[22:20:56 CEST] <furq> but multiple sources might be simpler
[22:20:56 CEST] <TD-Linux> https://developer.mozilla.org/en-US/docs/Web/HTML/Element/video
[22:21:09 CEST] <StephenS> furq, no no, I have 2 sources and flash fallback :)
[22:21:16 CEST] <StephenS> Ill support mp4 and webm
[22:21:18 CEST] <TD-Linux> you just use multiple <source> tags inside the <video> element
[22:21:22 CEST] <furq> yeah i wouldn't bother with theora
[22:21:29 CEST] <StephenS> because whoever supports ogv/hls, must support webm
[22:21:48 CEST] <TD-Linux> hls is something different that only safari supports, don't get confused
[22:23:07 CEST] <furq> apparently chrome and edge support hls now
[22:23:23 CEST] <furq> oh nvm it's only mobile chrome
[22:23:49 CEST] <StephenS> ok, so I can forget about hls, ogg and ogv, right?
[22:23:55 CEST] <TD-Linux> yeah
[22:24:06 CEST] <StephenS> I can support mp4 and webm only and should work on most of the browsers? With flash fallback ofc.
[22:24:21 CEST] <furq> hls is a streaming protocol
[22:24:24 CEST] <TD-Linux> yes
[22:24:30 CEST] <furq> you don't need anything like that if you're just serving up videos
[22:24:31 CEST] <TD-Linux> you shouldn't even need the flash fallback then
[22:25:31 CEST] <furq> those two will support pretty much everything except IE8 and prior
[22:26:34 CEST] <furq> and i can't imagine anyone still using IE8 is surprised when things don't work
[22:26:37 CEST] <StephenS> what IE needs?
[22:26:41 CEST] <furq> flash
[22:26:48 CEST] <StephenS> well I have fallback for that
[22:26:51 CEST] <StephenS> so even IE should work :)
[22:27:08 CEST] <furq> 9+ supports mp4 natively
[22:28:45 CEST] <StephenS> cool
[22:32:15 CEST] <StephenS> how to convert types with ffmpeg?
[22:32:39 CEST] <StephenS> ffmpeg -i m.mp4 out.webm wont convert it, I guess
[22:33:57 CEST] <furq> it'll guess appropriate codecs from the output file extension
[22:34:13 CEST] <StephenS> with current configuration http://pastebin.com/Q926QAnu Im not able to convert video to webm?
[22:34:14 CEST] <furq> you'll need to provide encoder settings though
[22:34:24 CEST] <StephenS> I need a52 enabled from my understanding
[22:35:03 CEST] <furq> i think you just need libvpx and libvorbis
[22:35:29 CEST] <StephenS> that, I have :)
[22:37:29 CEST] <StephenS> furq, hmm, when converted that way, quality is really bad
[22:40:28 CEST] <furq> apparently it defaults to 256kbps video
[22:40:57 CEST] <furq> https://trac.ffmpeg.org/wiki/Encode/VP9#constantq
[22:41:42 CEST] <StephenS> well I tried ffmpeg -i in.mp4 -qscale 0 outx.webm
[22:41:49 CEST] <StephenS> but that gives me the same bad quality
[22:41:53 CEST] <furq> try -b:v 0 -crf 10
[22:42:13 CEST] <furq> you probably want to set -q:a as well
[22:42:42 CEST] <relaxed> StephenS: https://trac.ffmpeg.org/wiki/Encode/VP9
[22:43:02 CEST] <StephenS> ffmpeg -i in.mp4 -c:v libvpx-vp9 -crf 10 -b:v 0 -c:a libvorbis out.webm
[22:43:04 CEST] <StephenS> is very slow
[22:43:12 CEST] <furq> it sure is
[22:44:52 CEST] <StephenS> and its twice in size
[22:45:04 CEST] <StephenS> original mp4 is 1.8MB and new webm is 3.3MB
[22:45:04 CEST] <StephenS> :O
[22:45:12 CEST] <furq> try -crf 20
[22:46:13 CEST] <nerium> Is there a way to transcode a stream?
[22:46:39 CEST] <DHE> specify a codec besides 'copy'
[22:46:51 CEST] <StephenS> furq, still slow
[22:47:00 CEST] <nerium> The input would be a stream (m3u) and output an mp4 stream
[22:47:33 CEST] <furq> StephenS: iirc you need to explicitly pass -threads with libvpx
[22:48:03 CEST] <furq> it is generally really slow compared to x264 though
[22:48:30 CEST] <furq> maybe use vp8 if this is just for a fallback
[22:49:35 CEST] <StephenS> how?
[22:49:36 CEST] <nerium> Anyone know what to search for?
[22:50:09 CEST] <voice> what are you trying to use libvpx for?
[22:51:18 CEST] <furq> StephenS: -c:a vp8
[22:51:33 CEST] <relaxed> -c:v
[22:51:37 CEST] <furq> er, yeah
[22:51:48 CEST] <StephenS> Invalid encoder type 'vp8'
[22:51:50 CEST] <StephenS> eh
[22:51:58 CEST] <furq> try -c:v libvpx
[22:51:59 CEST] <voice> vp8 - libvpx
[22:52:06 CEST] <voice> vp9 - libvpx-vp9
[22:52:33 CEST] <StephenS> Invalid encoder type 'libvpx'
[22:52:49 CEST] <voice> you don't have libvpx or your ffmpeg wasn't compiled with vpx support
[22:53:11 CEST] <furq> you are using -c:v and not -c:a right
[22:53:11 CEST] <StephenS> it was..
[22:53:17 CEST] <StephenS> look at this http://pastebin.com/Q926QAnu
[22:53:20 CEST] <furq> and yeah he was just encoding vp9
[22:53:28 CEST] <StephenS> --enable-libvorbis --enable-libv4l2 --enable-libvpx
[22:53:46 CEST] <voice> ffmpeg -codecs | grep vp9
[22:55:14 CEST] <StephenS>  DEV.L. vp9                  Google VP9 (decoders: vp9 libvpx-vp9 ) (encoders: libvpx-vp9 )
[22:55:35 CEST] <voice> -c:v libvpx-vp9 didn't work?
[22:55:41 CEST] <StephenS> but why would I want vp8 anyway
[22:55:44 CEST] <StephenS> vp8 is older
[22:56:02 CEST] <StephenS> -c:v libvpx-vp9 works
[22:56:06 CEST] <voice> because some media players like VLC don't support VP9 unless you build from source
[22:56:33 CEST] <voice> anyways, heres a VP9 encoding set I typically use, -c:v libvpx-vp9 -qmin 30 -qmax 35 -crf 35 -threads 8 -speed 1 -tile-columns 6 -frame-parallel 1 -auto-alt-ref 1 -lag-in-frames 25 -c:a libopus -b:a 96
[22:56:56 CEST] <furq> also because it encodes faster
[22:58:03 CEST] <voice> -b:a 96k*
[22:58:32 CEST] <furq> you'll want -b:a vorbis if this is for the web
[22:58:54 CEST] <StephenS> so ffmpeg -i in.mp4 -c:v libvpx-vp9 -qmin 30 -qmax 35 -crf 35 -threads 8 -speed 1 -tile-columns 6 -frame-parallel 1 -auto-alt-ref 1 -lag-in-frames 25 -c:a libopus -b:a 96 o.webm
[22:58:57 CEST] <StephenS> should be faster?
[22:59:01 CEST] <voice> Chromium and Firefox support WebM w/ VP9 and Opus
[22:59:01 CEST] <furq> -c:a vorbis i mean ;_;
[22:59:10 CEST] <furq> it's for old browser compatibility
[22:59:13 CEST] <StephenS> ok
[22:59:19 CEST] <StephenS> ffmpeg -i in.mp4 -c:v libvpx-vp9 -qmin 30 -qmax 35 -crf 35 -threads 8 -speed 1 -tile-columns 6 -frame-parallel 1 -auto-alt-ref 1 -lag-in-frames 25 -c:a vorbis -b:a 96 o.webm
[22:59:35 CEST] <relaxed> 96k
[22:59:41 CEST] <voice> StephenS, adjust -threads to be the number of CPU cores you have, also -b:a 96k
[22:59:45 CEST] <furq> use -threads 4 unless you have an i7
[22:59:51 CEST] <StephenS> [vorbis @ 0x11533a0] The encoder 'vorbis' is experimental but experimental codecs are not enabled, add '-strict -2' if you want to use it.
[22:59:52 CEST] <StephenS> [vorbis @ 0x11533a0] Alternatively use the non experimental encoder 'libvorbis'.
[22:59:55 CEST] <furq> or one of those silly amd cpus
[23:00:08 CEST] <voice> use libvorbis
[23:00:54 CEST] <StephenS> model name	: Intel(R) Xeon(R) CPU E5-2680 v3 @ 2.50GHz
[23:01:07 CEST] <StephenS> cpu cores	: 1
[23:01:08 CEST] <StephenS> xd
[23:01:16 CEST] <voice> vps?
[23:01:26 CEST] <StephenS> yeah
[23:01:31 CEST] <StephenS> cloud though :D
[23:01:34 CEST] <StephenS> but VPS yap
[23:01:48 CEST] <voice> it'll just take longer to make
[23:02:08 CEST] <StephenS> so this is final one
[23:02:09 CEST] <StephenS> ffmpeg -i in.mp4 -c:v libvpx-vp9 -qmin 30 -qmax 35 -crf 35 -threads 8 -speed 1 -tile-columns 6 -frame-parallel 1 -auto-alt-ref 1 -lag-in-frames 25 -c:a libvorbis -b:a 96k o.webm
[23:02:12 CEST] <furq> libvpx's multithreading isn't very good in my experience
[23:02:27 CEST] <voice> -threads 1
[23:02:47 CEST] <furq> -tile-columns and -frame-parallel aren't needed without multithreading are they
[23:03:00 CEST] <voice> not really sure
[23:03:50 CEST] <furq> my experience with libvpx is spending ten minutes failing to get it to run faster than 5fps and then going back to x264
[23:08:06 CEST] <StephenS> ok
[23:08:07 CEST] <StephenS> ffmpeg -i in.mp4 -c:v libvpx-vp9 -qmin 30 -qmax 35 -crf 35 -threads 1 -speed 1 -tile-columns 6 -frame-parallel 1 -auto-alt-ref 1 -lag-in-frames 25 -c:a libvorbis -b:a 96k outnew.webm
[23:08:16 CEST] <StephenS> worked and I got even lower in size o.webm
[23:08:26 CEST] <StephenS> however its still slow.. maybe when I switch to dedi with more cores, it will get faster
[23:09:15 CEST] <furq> fwiw i get 10fps encoding a 480p clip on an i7
[23:09:20 CEST] <furq> vp9 is just slow
[23:09:37 CEST] <relaxed> x264 spoiled us
[23:09:46 CEST] <furq> good old x264
[23:10:07 CEST] <StephenS> can I do something with x264 :D
[23:10:27 CEST] <furq> yes, you can encode an mp4 and leave all the outdated browser users hanging
[23:10:53 CEST] <furq> that sounded negative but that is totally what i'd do
[23:11:29 CEST] <StephenS> heh :D
[23:17:50 CEST] <StephenS> thanks for help, im off to sleep ;]
[23:27:39 CEST] <nerium> Is there a way to set the output stream to tcp instead of udp?
[23:28:03 CEST] <nerium> I currently have this in the end udp://, but I want tcp
[23:29:56 CEST] <relaxed> nerium: yes, ffmpeg -protocols
[23:30:22 CEST] <relaxed> man ffmpeg-protocols
[23:31:25 CEST] <nerium> relaxed: Im justing getting Connection to tcp:// failed: Connection refused when trying http and tcp instead of udp
[23:32:33 CEST] <relaxed> you probably need ?listen on the end
[23:32:37 CEST] <nerium> relaxed: Do I need to set up a server of tcp, but not udp?
[23:33:19 CEST] <nerium> relaxed: Nope, same thing :/
[23:35:17 CEST] <TD-Linux> StephenS, you can also do a vp8 webm which is way faster but larger filesize for same quality
[23:35:37 CEST] <StephenS> but I dont have vp8
[23:35:46 CEST] <TD-Linux> -c:v libvpx is vp8
[23:36:07 CEST] <TD-Linux> I can pretty much guarantee you that you have vp8 :)
[23:38:40 CEST] <StephenS> wow, this is actually faster and Q is pretty decent
[23:38:44 CEST] <StephenS> and file size is not that big either
[23:38:51 CEST] <StephenS> its even smaller than the original one
[23:40:22 CEST] <nerium> relaxed: Any idea?
[23:42:11 CEST] <relaxed> nerium: this works for me, ffmpeg -i input.mp4 -c copy -f flv 'tcp://'
[23:42:43 CEST] <nerium> relaxed: What version of ffmpeg are u using?
[23:43:27 CEST] <StephenS> how hard is to add existing "transparent" fire ball on existing video?
[23:44:40 CEST] <relaxed> StephenS: someone should write a dhalsim filter
[23:45:02 CEST] <furq> StephenS: https://ffmpeg.org/ffmpeg-filters.html#overlay-1
[23:45:36 CEST] Action: relaxed yoga fire
[23:46:17 CEST] <StephenS> :O
[23:46:20 CEST] Action: StephenS do the happy dance
[23:46:31 CEST] <relaxed> nerium: recent git master, but it should work with any version
[23:53:09 CEST] <RedH8> Sweeeet an ffmpeg room!!! Total roll of the dice and it comes up big!
[23:53:30 CEST] <RedH8> <3 fellow transcoders.
[23:53:30 CEST] <TD-Linux> StephenS, cool, glad it worked. vp9 has a lot of potential but the encoder is still pretty slow. libvpx 1.5.0 will give it about 20% more but it's still not a super good choice for the impatient :)
[23:56:01 CEST] <voice> who knows how much longer Google will be focusing on VP9, it looks like VP10 is already showing up in the repos
[00:00:00 CEST] --- Sun Oct 18 2015

More information about the Ffmpeg-devel-irc mailing list