[Ffmpeg-devel-irc] ffmpeg.log.20151019

burek burek021 at gmail.com
Tue Oct 20 02:05:01 CEST 2015

[00:03:18 CEST] <BullHorn> https://mega.nz/#!KllDnDyL!NWN8vmzBZCkH2Q9z5HbTIKoYT4rIoh6fi9mbMasTnBw
[00:03:22 CEST] <BullHorn> if someone wants to take a look ;x
[02:33:46 CEST] <ChazNunz> Hi.  Any way to draw a progress bar on a video that would increase during playback?  This would not be in a player, but
[02:33:54 CEST] <ChazNunz> hardcoded and overlayed on the video.
[02:38:31 CEST] <ChazNunz> I'm not looking for progress bar to indicate when encoding is completed, but rather a "playback" progress bar.
[03:06:35 CEST] <kecharitomene> Hi. I have a video file, a film, with embedded subtitles (not hardcoded, if that's the right term, but stored in the video container).
[03:06:56 CEST] <kecharitomene> I'm trying to convert a clip from it with hardcoded subs.
[03:07:14 CEST] <kecharitomene> But I can only find instructions for where you have the .srt file.
[03:07:59 CEST] <edman007> kecharitomene, https://trac.ffmpeg.org/wiki/HowToBurnSubtitlesIntoVideo
[03:10:01 CEST] <kecharitomene> Do I want the ass filter then?
[03:10:46 CEST] <kecharitomene> no
[03:11:52 CEST] <edman007> ChazNunz, I would try something like -vf drawbox=h=10:w=n*2 (or if not, it should work with using drawtext to draw a box...
[03:12:18 CEST] <edman007> ffmpeg -i video.mkv -vf subtitles=video.mkv out.avi
[03:12:29 CEST] <edman007> reads the subtitles out of the video and draws them on
[03:12:32 CEST] <edman007> that's what you want
[03:12:46 CEST] <edman007> kecharitomene,
[03:14:58 CEST] <ChazNunz> edman007, how would i get the box to increment as the video playback progresses?  I see that drawbox has timeline editing support.  Suppose i don't know the number of frames or duration of the video before I start encoding.
[03:18:16 CEST] <kecharitomene> edman007: No such fillter: subtitles
[03:18:53 CEST] <relaxed> kecharitomene: your ffmpeg version must be old, try http://johnvansickle.com/ffmpeg/
[03:29:20 CEST] <edman007> ChazNunz, I would just do two passed and measure the duration first, it shouldn't be hard to script...
[03:30:02 CEST] <edman007> but 100*n/total_frames (with total frames being some number you know), would make it go from zero to 100px wide
[03:30:42 CEST] <DHE> or take a shot of ffprobe with -show_format assuming it's an intact file on disk
[03:31:09 CEST] <ChazNunz> OK, I'll look.  I was trying not to do a second pass as I already have a complex filtergraph.  I am concating 50 videos nightly and rendering is taking lots of time.
[03:32:07 CEST] <ChazNunz> DHE, I'll look at ffprobe as well.
[03:32:17 CEST] <DHE> 50 files? all concatenated?
[03:32:31 CEST] <DHE> wow I thought my job was big
[03:34:24 CEST] <ChazNunz> We are doing an efficiency study and pulling 20-30 sec clips from cameras.  We pull 50 a day from 20 cameras.  We then concat these and overlay them into 2x2 grid.
[03:45:38 CEST] <edman007> DHE, heh.. I'm doing a focus stacked timelapse...so far I got ~10,000 4MB JPGs...and ran them into a 11 second video
[03:46:04 CEST] <edman007> I'm starting to worry about my camera...I'll probably take another 10-20k pics this week...
[03:46:56 CEST] <edman007> https://www.youtube.com/watch?v=R2msivqnFdc in 4K!
[03:47:04 CEST] <edman007> not done yet
[03:48:01 CEST] <DHE> there was an outdoor webcam outside the building I work while it was being built. every 5 minutes I took a single jpeg from it (daylight hours only). there's nearly 32,000 jpegs in here. turned it into a time lapse of the construction
[03:50:47 CEST] <edman007> DHE, I got a shell script doing it, every five minutes it takes 25 pictures, changing the focus between every one, then I post process each of the 25 pics to find all the in focus bits and merge them into one jpg, then pass that to ffmpeg to get a video
[03:51:25 CEST] <DHE> you win
[03:51:47 CEST] <kecharitomene> edman007: I just updated to 2.8.1 and same thing
[03:51:50 CEST] <kecharitomene> I'll check use flags
[03:52:09 CEST] <edman007> kecharitomene, are you building it yourself?
[03:52:16 CEST] <kecharitomene> yeah
[03:52:23 CEST] <kecharitomene> from emerge
[03:53:08 CEST] <kecharitomene> Ah, it's the libass use flag I think
[03:53:23 CEST] <edman007> yea
[03:53:28 CEST] <edman007> you need libass
[03:53:34 CEST] Action: edman007 wonders who named that library
[03:53:39 CEST] <kecharitomene> lol
[03:56:16 CEST] <DHE> SubStation Alpha subtitles?
[04:19:53 CEST] <Prelude_Zzzzz> hello everyone
[04:23:31 CEST] <Prelude_Zzzzz> can someone help me.. i am using ffmpeg -i to get a stream and i keep getting errors like " Failed to open segment of playlist 0 , errro 500 internal server error on the stream. It freezes up a lot and frame rate drops like crazy. The interesting part is running from the same location with VLC the stream is clean. What am i doing wrong ?
[04:23:41 CEST] <Prelude_Zzzzz> is there a bug in ffmpeg ?
[04:54:01 CEST] <edman007> Prelude_Zzzzz, a "500 Internal Server Error" is an HTTP error thrown by the server hosting it
[04:54:15 CEST] <edman007> it's not ffmpeg, I think the server hosting the stream is down
[04:54:49 CEST] <edman007> 500 errors and just crappy streaming is pretty common if the server is at max capacity
[05:15:11 CEST] <Prelude_Zzzzz> doesn't seem that way though
[05:15:16 CEST] <Prelude_Zzzzz> vlc doesn't even hickup
[05:15:40 CEST] <Prelude_Zzzzz> is there some param that ffmpeg can use that download segments faster ? like download multiple at the same time if necessary ?
[05:16:03 CEST] <Prelude_Zzzzz> maybe it is falling behind due to speed issues and then because the segments are being removed on the oposite side .. maybe by the time it tries to get the next chunk it is gone
[05:16:29 CEST] <Prelude_Zzzzz> so, i am thinking .. there may be some variable that can get set to buffer or something the chunks to insure they are all available
[08:31:44 CEST] <satiender> hi one can help me , Can I call ffmpeg command from .so file
[08:32:22 CEST] <satiender> I mean I have all ffmpeg's .so file then can i call ffmpeg from them ??
[08:49:49 CEST] <JEEB> satiender: you can do what ffmpeg does but not command line of course
[08:51:36 CEST] <satiender> JEEB : Thanks for reply
[08:52:29 CEST] <satiender> You mean we can do only video programming like ffmpeg source
[08:52:53 CEST] <satiender> but that is very hard task
[08:52:57 CEST] <satiender> :(
[08:53:33 CEST] <satiender> Can you help me  for give some reference
[08:53:46 CEST] <JEEB> the examples in doc
[08:54:01 CEST] <JEEB> and the doxygen
[08:54:24 CEST] <satiender> ok
[08:54:43 CEST] <satiender> Yeah ! I already doing that
[08:56:20 CEST] <satiender> but that is very time spending task
[09:12:13 CEST] <claz> can I use ffmpeg to restream a rtsp stream?
[09:12:25 CEST] <claz> like a proxy
[10:10:42 CEST] <AndrewPRS> hi everyone!! I have compiled the example video encoder example and the video I'm getting is empty... I can't open it with vlc. Do you guys know what could be happening?
[10:15:10 CEST] <fritsch> how large is the file and what does ffprobe say?
[10:15:49 CEST] <k_sze> For videos encoded as yuv422p in H.264, is there a way to query how many bits or bytes where spent encoding a certain portion of a frame?
[10:18:01 CEST] <k_sze> I have two videos from the exact same model of camera, both encoded as yuv422p in H.264. One of them has part of the field of view covered, so it appears mostly black. But this video somehow results in double the file size as the other one, given the same libx264 preset.
[10:18:44 CEST] <k_sze> My hypothesis is that the covered area actually exhibits more noise, which means increased entropy.
[10:19:31 CEST] <k_sze> But I need a way to confirm. The logical way would be if I can ask ffmpeg how many bits where spent encoding the covered region.
[10:41:20 CEST] <satiender> Hi  anybody can give some Idea how we can understand the source code of ffmpeg ,
[10:41:46 CEST] <satiender> because reading code is very time spending
[10:42:00 CEST] <satiender> please help anybody know
[10:43:24 CEST] <Anoia> understand for what purposes?
[10:43:39 CEST] <Anoia> generally the documentation is the best place to start if you're using the library
[10:43:45 CEST] <Anoia> (created form inline comments)
[10:48:32 CEST] <satiender> Anoia : Actually I build ffmpeg for android , And I run some given simple examples of ffmpeg on android that is working perfectly
[10:48:48 CEST] <satiender> these are simple examples some I did it
[10:49:48 CEST] <satiender> But if I want create a ffmpeg any filter use its api for android that is very hard for me
[10:50:13 CEST] <satiender> because that is more than 1500 line code and that is very time spending
[10:50:49 CEST] <satiender> and in android I can only do programming not use command line because ffmpeg is not official for android
[10:51:06 CEST] <satiender> So , that is reason I asking ??
[10:51:11 CEST] <satiender> please help
[10:51:14 CEST] <satiender> :)
[10:51:25 CEST] <xsi> I want go ffmpeg twitch. Why does ffmpeg https://bpaste.net/show/be6685d2ed8b has :0.0: Invalid argument https://bpaste.net/show/696d19c96207? ffmpeg -formats : https://bpaste.net/show/a770c31faabc "D x11grab      X11 screen capture, using XCB"
[10:51:29 CEST] <xsi> [x11grab @ 0x21af630] Cannot open display 0.0, error 5.
[10:51:32 CEST] <xsi> 0.0: Input/output error
[10:51:38 CEST] <Anoia> so why not read the extensive documentation, dipping into the code where needed?
[10:52:14 CEST] <Anoia> if you think you need to read the code, but don't want to I don't know what I can suggest.
[10:55:00 CEST] <satiender> Anoia : as simple I tell you , In android can use native programming (C / C++) , ffmpeg is in C , So , I want design a blur filter using ffmpeg API
[10:55:12 CEST] <satiender> that is my target
[10:55:53 CEST] <Anoia> ok?
[10:55:54 CEST] <satiender> So , for that purpose I think Code reading is necessary
[10:56:13 CEST] <Anoia> and what cant you get from the documentation?
[10:56:37 CEST] <satiender> but in the documentation have only command line details
[10:56:53 CEST] <satiender> there have no detail about source code working
[10:57:03 CEST] <satiender> and about libraries
[10:57:23 CEST] <Anoia> no, the api documentation contains the api documentation
[10:57:48 CEST] <satiender> I following dranger.com tutorial , but that is only for make a player
[10:57:53 CEST] <satiender> ok
[10:58:30 CEST] <Anoia> https://www.ffmpeg.org/documentation.html
[10:58:56 CEST] <Anoia> scroll down
[10:59:42 CEST] <furq> satiender: http://www.ffmpeg.org/doxygen/2.8/dir_687bdf86e8e626c2168c3a2d1c125116.html
[11:01:04 CEST] <satiender> furq : Thanks for reply , I also following that link
[11:01:06 CEST] <Anoia> at the very least, Google for "ffmpeg functionname" gives the api docs
[11:02:20 CEST] <BullHorn> im getting a bunch of 'Past duration 0.999992 too large' errors when reencoding a video
[11:02:26 CEST] <BullHorn> i have no idea what might be causing the problem
[11:02:29 CEST] <BullHorn> it only happens when i use NVENC in OBS, doesnt happen with quicksync or x264
[11:02:36 CEST] <BullHorn> can someone take a look at the file? or should i provide something else ;x
[11:02:39 CEST] <BullHorn> https://mega.nz/#!KllDnDyL!NWN8vmzBZCkH2Q9z5HbTIKoYT4rIoh6fi9mbMasTnBw
[11:03:19 CEST] <satiender> furq : but there have very less details
[11:03:40 CEST] <furq> BullHorn: they're warnings, not errors
[11:03:54 CEST] <furq> if there's no issue with the output video then it's safe to ignore them
[11:03:56 CEST] <BullHorn> does this slow down the re-encode?
[11:04:05 CEST] <furq> i doubt it
[11:05:36 CEST] <furq> if the logging is slowing it down you can use -loglevel error
[11:15:17 CEST] <Anoia> satiender: the documentation will have less detail than the code by its very nature, but it gives you thebasic framework, which you can expand on by lookign at specific bits of the code
[11:22:30 CEST] <satiender> Anoia : Thankyou
[11:22:51 CEST] <satiender> There have no other resource for development
[11:22:53 CEST] <satiender> ??
[11:23:12 CEST] <Anoia> apart form the code and the documentation?
[11:23:17 CEST] <Anoia> I don;t know of any other
[11:23:30 CEST] <Anoia> various tutorials online
[11:23:43 CEST] <satiender> ok
[11:24:02 CEST] <Anoia> what is it you're not getting fromt he docs?
[11:24:25 CEST] <satiender> Anoia : Thanks for giving your expensive time to me :)
[11:24:26 CEST] <Anoia> you've not said what's missing bar "less details"
[11:24:56 CEST] <satiender> ????
[11:25:02 CEST] <satiender> missing bar ??
[11:25:24 CEST] <Anoia> except
[11:25:54 CEST] <Anoia> all you've said is wrong is that the docs have "very less details"
[11:27:00 CEST] <satiender> Anoia : ?????
[11:27:50 CEST] <satiender> I said regarding code elaboration only , docs have just for use of ffmpeg command line
[11:31:06 CEST] <Anoia> so you've not yet seen the code documentation I ave you link to?
[11:34:21 CEST] <satiender> Anoia : Sorry !
[11:34:26 CEST] <satiender> I got it
[11:34:38 CEST] <satiender> thanks I following now
[11:34:44 CEST] <satiender> :)
[11:37:24 CEST] <Anoia> there's wuite a bit more detail there :)
[11:41:15 CEST] <satiender> yes
[11:41:20 CEST] <satiender> I am wrong
[11:41:26 CEST] <satiender> :)
[11:44:50 CEST] <Anoia> it happens occasionally :p
[11:53:33 CEST] <BullHorn> when i use ffmpeg to reencode with veryfast preset, does it use fullrange color?
[11:53:35 CEST] <AndrewPRS> fritsch, sorry I forgot to answer. The problem is solved now I was not putting the encoded frames inside a container ... thank you
[11:59:56 CEST] <satiender> Anoia : I have one another question but that is related to command line
[12:00:36 CEST] <satiender> I have a .mp4 file I convert it in .ts because I want transfer it on the network and alos play live
[12:02:13 CEST] <satiender> but when I transfer it on over the network , at receiving end that not play proper that is very fast
[12:03:02 CEST] <satiender> I use : ffmpeg -i video.ts -vcodec copy -acodec copy -f mpegts udp://
[12:03:36 CEST] <satiender> so there have any solution ??
[12:03:42 CEST] <satiender> anyone can help me
[12:03:44 CEST] <satiender> ?????
[12:19:52 CEST] <martijnb> what is the problem?
[12:20:07 CEST] <martijnb> it doesn't play properly?
[12:28:57 CEST] <c_14> satiender: -re
[12:30:06 CEST] <satiender> I mean one end I transfer the video and same time that is playing on another side which one i transferring  that time
[12:30:32 CEST] <satiender> video transferring is very fast as compare to normal video playing
[12:30:39 CEST] <furq> satiender: listen to c_14
[12:30:58 CEST] <satiender> furq : ??
[12:31:04 CEST] <satiender> ok
[12:31:39 CEST] <martijnb> I still haven't decyphered what the problem is
[12:38:20 CEST] <satiender> matijnb : Can you give your few important mins , then I elaborate my problem , and believe me that is very interesting and also a big drawback in video streaming
[12:44:46 CEST] <satiender> c_14 :
[12:45:01 CEST] <satiender> matijnb :
[12:45:23 CEST] <satiender> I elaborate the biggest problem in video streaming
[12:46:12 CEST] <satiender> I capturing the destop and streaming that on network with multicast i
[12:46:14 CEST] <satiender> ip
[12:46:31 CEST] <satiender> at receiving end that is playing
[12:47:07 CEST] <satiender> but when i analysis it in stream guru or some other video detectors like dictac
[12:47:23 CEST] <satiender> there shows very large amount of jitters
[12:47:57 CEST] <satiender> aproxy mate  50.00 jitter value
[12:48:38 CEST] <satiender> but according to theory jitter value it 0.500 ns is acceptable
[12:49:02 CEST] <satiender> so problem is that how we can over cum the network jitter
[13:15:08 CEST] <satiender> ????????????
[13:19:51 CEST] <BtbN> sub 1ns jitter, what?
[13:29:01 CEST] <martijnb> so you're streaming it over an unstable network?
[13:30:30 CEST] <Mavrik> If I can understand anything through that english.
[13:30:36 CEST] <Mavrik> He's not syncing on PCR :)
[13:52:31 CEST] <superware> can someone please help me promote trac.ffmpeg.org/ticket/4893 ?
[15:03:03 CEST] <xsi> Is paid soft - xsplit better?
[15:40:33 CEST] <martijnb> better is a relative term
[15:40:47 CEST] <martijnb> better than what?
[15:41:00 CEST] <martijnb> to do what?
[15:44:40 CEST] <superware> can someone please help me verify http://trac.ffmpeg.org/ticket/4893#comment:19 ?
[15:45:02 CEST] <mat_ev> hi, I have a question about using ffmpeg to process and segment an mpeg-ts stream (into HLS), I used stream_segment format output, "-c copy -map 0" to copy all existing streams as-is, HOWEVER my problem is that the result Mpeg-ts chunks are missing some of the original mpeg-ts PIDs
[15:45:08 CEST] <mat_ev> namely ECMs
[15:45:19 CEST] <mat_ev> I tried using "-copy_unknown" but this doesn't help
[15:45:20 CEST] <durandal_1707> verify what?
[15:45:43 CEST] <mat_ev> any suggestion as how to preserve ALL original PIDs in mpeg-ts would be highly appreciated, thanks!
[15:45:55 CEST] <DHE> mat_ev: somewhat tangental, there is an -f hls format which may be better suited
[15:46:11 CEST] <superware> durandal_1707: that you can reproduce :)
[15:46:19 CEST] <mat_ev> DHE: I tried this as well, same result
[15:46:34 CEST] <mat_ev> resulting mpeg-ts has video, audio, subtitles, pat, pmt, sdt
[15:46:43 CEST] <mat_ev> but no other PIDs (like ECMs)
[15:46:59 CEST] <DHE> that's the crypto stuff right?
[15:46:59 CEST] <xsi> martijnb mb better for combining streaming
[15:47:24 CEST] <xsi> for expensive device support, more possibilities, more flexible?//
[15:47:45 CEST] <mat_ev> right, ECM carry crypto information, my mpeg-ts is already encrypted and ready for decryption on end-devices, it's only a matter of cutting it into small HLS chunks, which ffmpeg does well, only losing some of the PIDs :(
[15:47:55 CEST] <Mavrik> mat_ev, are other PIDs actually emitted often enough to make it in all segments?
[15:48:07 CEST] <martijnb> combining streaming meaning?
[15:48:16 CEST] <DHE> mat_ev: the HLS spec has its own encryption spec. you sure this is going to work in the first place?
[15:48:32 CEST] <martijnb> I'd only use xsplit to do stream live captured content
[15:48:59 CEST] <xsi> already captured?
[15:49:06 CEST] <xsi> *and more quick..
[15:49:14 CEST] <mat_ev> Mavrik: other PIDs make it fine
[15:49:21 CEST] <martijnb> if you're just streaming recorded content, there's hardly a point in using xsplit..
[15:49:44 CEST] <mat_ev> but even when ffmpeg starts processing the original mpeg-ts I can only see video audio and subs streams, no mention of other PIDs
[15:50:27 CEST] <Mavrik> mat_ev, it's totally possible that ECM just isn't recognised and it's discarded.
[15:50:28 CEST] <xsi> i'm new to this all i've just made a supposition that paid version is much more good
[15:50:37 CEST] <mat_ev> DHE: yeah, the solution we're using is based on Marlin DRM, they handle encryption a little differently than the original HLS specification, each chunk carries ECM info
[15:51:01 CEST] <xsi> i've never streamed or read smth .. to start with smth
[15:51:11 CEST] <mat_ev> Mavrik: probably you're right, my question is: is there a way to force copying it? as I said -copy_unknown does not seem to help
[15:51:45 CEST] <Mavrik> mat_ev, if the prober didn't detect it (you don't see the stream) then the command line switches probably won't do a thing
[15:51:48 CEST] <martijnb> ok, well, if you want to know the difference between the free trial and subscription versions of xsplit, I'm sure they have a lot of information on their website
[15:51:53 CEST] <Mavrik> mat_ev, should report a bug with a .TS sample
[15:52:27 CEST] <martijnb> if you want free alternatives like xsplit, there's OBS
[15:52:42 CEST] <xsi> ok it's a very nice point of theirs that they've got much info support
[15:52:59 CEST] <martijnb> but neither of those really relate to this channel :p
[15:53:49 CEST] <mat_ev> Mavrik: ok, so "the prober" will only know how to handle predefined stream types? like audio/video/subs? I can't use my private section data in mpeg elementary stream?
[15:54:15 CEST] <Mavrik> I'd have to check the source what it does about those streams :/
[15:55:23 CEST] <mat_ev> well it seems that way:( it's a shame, because otherwise it would really suit our needs
[15:55:32 CEST] <mat_ev> thanks for your help
[15:56:21 CEST] <xsi> does one need a deep background in bitrate theory or so.. to be truly a person who uses ffmpeg professionally?
[15:56:27 CEST] <DHE> mat_ev: I've dealt with a similar situation with a different DRM provider. mpegts chunk encryption isn't (officially) compatible with HLS which calls for a more
[15:56:29 CEST] <xsi> sorry for my "russian"
[15:56:38 CEST] <DHE> 'openssl enc' style of encryption
[15:57:07 CEST] <xsi> which branch of science lies under ffmpeg?
[15:58:06 CEST] <mat_ev> DHE: ok, what is your experience? did you end up using some other tool? or changing your encryption requirements?
[15:58:36 CEST] <mat_ev> DHE: the thing is we already have the content encrypted, how we just wanted to chunk it up for HTTP delivery
[15:58:50 CEST] <mat_ev> *now
[16:00:23 CEST] <rocktop> I have compiled libfdk_aac but I am still enable to use it with ffmpeg I have this issue :  Unknown encoder 'libfdk_aac'
[16:00:42 CEST] <c_14> Did you then compile ffmpeg against libfdk_aac?
[16:01:01 CEST] <rocktop> c_14: ./configure --prefix="$HOME/ffmpeg_build" --extra-cflags="-I$HOME/ffmpeg_build/include" --extra-ldflags="-L$HOME/ffmpeg_build/lib" --bindir="$HOME/bin" --pkg-config-flags="--static" --enable-gpl --enable-nonfree --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libopus --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265
[16:01:17 CEST] <rocktop> c_14: yes I did
[16:01:18 CEST] <c_14> Are you executing the correct version?
[16:01:31 CEST] <c_14> Check the configure flags ffmpeg prints when it's executing.
[16:02:00 CEST] <rocktop> c_14: ffmpeg version ?
[16:02:15 CEST] <c_14> ie: ffmpeg -version
[16:02:22 CEST] <c_14> The correct build per se
[16:02:31 CEST] <c_14> If you have more than one on your system (which does happen).
[16:04:19 CEST] <rocktop> c_14: ffmpeg version ?
[16:04:29 CEST] <c_14> ie: ffmpeg -version
[16:04:30 CEST] <c_14> The correct build per se
[16:04:32 CEST] <c_14> If you have more than one on your system (which does happen).
[16:04:47 CEST] <rocktop> I was disconnected
[16:06:00 CEST] <rocktop> c_14: http://pastie.org/private/xjfhn2ouhv5pgztznjlaw
[16:06:18 CEST] <c_14> >configuration: --enable-libx264 --enable-gpl
[16:06:23 CEST] <c_14> that's the wrong version
[16:06:35 CEST] <c_14> Did you run make install after compiling the new ffmpeg?
[16:06:44 CEST] <c_14> is $HOME/bin in your path
[16:06:59 CEST] <c_14> is $HOME/bin in your path ahead of other bin locations that might contain an ffmpeg binary
[16:06:59 CEST] <rocktop> c_14: yes I have
[16:07:42 CEST] <rocktop> c_14: no it is not in the path
[16:08:46 CEST] <rocktop> c_14: http://pastie.org/private/hhxjzfjojjmt6srm72apia
[16:09:16 CEST] <rocktop> c_14: still having Unknown encoder 'libfaac'
[16:09:36 CEST] <c_14> Because you didn't build with libfaac?
[16:09:39 CEST] <c_14> You built with libfdk_aac
[16:10:03 CEST] <rocktop> c_14: oh yes sorry
[16:11:31 CEST] <rocktop> c_14: thank you very much I really appreciate your help
[16:47:49 CEST] <efesto> Good afternoon all, has there been any regression reported on drawtext timecode ?
[16:48:54 CEST] <efesto> adding this to my command triggers a segfault :drawtext=fontfile=/home/efesto/devel/efesto/efesto-ftrack-deploy/modules/efestolab/efesto-submit/source/efesto_submit/profile/settings/fonts/lato.ttf:timecode=\'00:00:00:00\':r=25.0:fontcolor=white at 1:fontsize=28:x=50:y=50-text_h
[16:50:37 CEST] <c_14> What version are you using?
[16:52:28 CEST] <efesto> latest stable
[16:52:35 CEST] <efesto> here is a command to reproduce :
[16:52:38 CEST] <efesto> ffmpeg -thread_queue_size 512 -hwaccel auto -threads 0 -y -r 25.0 -start_number 1 -i "/usr/tmp/tmpyCJaTB.%4d.png" -c:v libx264 -crf 18 -preset slow -strict -2 -movflags faststart -pix_fmt yuv420p -filter_complex "[0:v]null,scale=1920:1080,
[16:52:38 CEST] <efesto> drawtext=timecode=\'00:00:00:00\':r=25.0:fontcolor=white at 1:fontsize=28:x=50:y=50-text_h[clip];[clip]scale=1920:1080, fps=25.0, setdar=16:9[v]" -map [v] /home/efesto/Desktop/foobar.mov
[16:53:09 CEST] <efesto> here is the version : ffmpeg
[16:53:09 CEST] <efesto> ffmpeg version 2.8.1-static http://johnvansickle.com/ffmpeg/  Copyright (c) 2000-2015 the FFmpeg developers
[16:53:09 CEST] <efesto>   built with gcc 4.9.3 (Debian 4.9.3-4)
[16:54:15 CEST] <efesto> replace timecode with text and it'll be working
[16:54:36 CEST] <efesto> do you want me to open a bug report ?
[16:56:59 CEST] <c_14> If you can reproduce with current git head, yes.
[16:57:07 CEST] <c_14> You can just take the git static build
[16:57:25 CEST] <efesto> I'll give it a shot now
[16:57:27 CEST] <efesto> hang on
[16:59:01 CEST] <efesto> yep
[16:59:04 CEST] <efesto> segfault
[16:59:11 CEST] <efesto> ffmpeg version N-50577-g777b305-static http://johnvansickle.com/ffmpeg/  Copyright (c) 2000-2015 the FFmpeg developers
[17:01:23 CEST] <c_14> Then yes, please.
[17:01:25 CEST] <c_14> https://ffmpeg.org/bugreports.html
[17:01:39 CEST] <efesto> on it
[17:01:40 CEST] <efesto> cheers
[17:01:45 CEST] <c_14> If you can provide the gdb backtrace etc as listed under the "crash bug" thing it would be very helpful.
[17:01:59 CEST] <efesto> I'll check
[17:02:39 CEST] <Sir_Leto> Question, is it possible to change a headers on a stream after encoding? I tried to copy an hevc stream from a TS file into and MP4, and now the stream is incorrectly labeled as mp4 instead of hevc
[17:03:48 CEST] <c_14> You mean metadata?
[17:03:52 CEST] <Sir_Leto> YES
[17:04:00 CEST] Last message repeated 1 time(s).
[17:04:34 CEST] <Sir_Leto> It's simply labeled wrong and therefor the video stream isn't playable
[17:05:29 CEST] <c_14> You can change most metadata.
[17:05:53 CEST] <c_14> https://ffmpeg.org/ffmpeg.html#Main-options look for -metadata
[17:07:23 CEST] <efesto> https://trac.ffmpeg.org/ticket/4945#ticket
[17:07:34 CEST] <efesto> done, couldn't use ffmpeg_g , so I did run with -v debug
[17:07:38 CEST] <efesto> hope is enough
[18:12:37 CEST] <BasisBit> I am using the shared ffmpeg library in my application. any suggestion on what would be the best way to sync video playback to my SDL/bass audio-file-playback?
[18:15:28 CEST] <JEEB> pts are for prewentation
[19:24:01 CEST] <maletor> can i use ffmpeg for passthrough audio to my audio card?
[19:37:09 CEST] <xsi> This config works but without sound. Sound appears only first seconds
[19:37:10 CEST] <xsi> ffmpeg -f alsa -ac 2 -i hw:0,0 -f x11grab -framerate 30 -video_size 1280x1024 -i :0.0+0,0 -vcodec libx264 -preset veryfast -maxrate 1984k -bufsize 3968k -vf "format=yuv420p" -g 60 -acodec libmp3lame -b:a 96k -ar 44100 -f flv
[19:37:34 CEST] <xsi> which bitrate and where to choose because: Past duration 0.994331 too large
[19:40:13 CEST] <xsi> https://bpaste.net/show/2892dc00ec3d
[19:40:22 CEST] <xsi> Here is the mouse-copied output
[19:51:39 CEST] <xsi> https://bpaste.net/show/ca46c5b25e94
[19:55:06 CEST] <Wader8> hello
[19:55:46 CEST] <Wader8> i do not know why does ffmpeg always say "input stream set from yuv420p to nv12" when i have the pix_fmt set in the cmd
[19:56:41 CEST] <Wader8> i am converting some apparently? non-interlaced dvd video with 2:3 pulldown
[19:57:42 CEST] <Wader8> I'm not sure what the FPS of the source film is, since it's not a hollywood film, but "amateur", it's, the DVD metadata says it's made for digital television
[19:58:39 CEST] <Wader8> mediainfo reports 23,976 in both the VOBs (and concated VOB which im using) and in MP4 HEVC
[19:59:39 CEST] <Wader8> i finally got the proper cmd to get the audio sync working, seems like decimate is not needed here, only pullup and not both, I will also try removing fieldmatch now
[20:00:06 CEST] <Wader8> to see if only pullup is needed
[20:02:19 CEST] <Wader8> i didn't change the size, i did had scale in vf (matching source) but i removed that and nothing negative happened, becuase it reports the size changed (same as input) but I'm not sure what's overrding pix_fmt
[20:02:30 CEST] <Wader8> oh maybe HEVC is overriding pix_fmt ?
[20:03:06 CEST] <JEEB> pastebin your command line and full terminal output
[20:03:08 CEST] <JEEB> and link it here
[20:04:40 CEST] <Wader8> http://pastebin.com/29kr6vJB
[20:06:28 CEST] <Wader8> i was doing some DVD conversion for the past year have finished that, only to find out today that DUP messages mean duplicated frames so even tho reading up on telecine, pulldown, i didn't do enough researching i guess
[20:06:56 CEST] <Wader8> so now I didn't got tons of dup messages, but this is unrelated to the other DVDs from months ago
[20:07:25 CEST] <JEEB> can insert -v debug somewhere before the input?
[20:07:35 CEST] <JEEB> it will output a lot of stuff but you can stop it right after it starts encoding
[20:07:40 CEST] <Wader8> -v 8 is not enough  ?
[20:07:58 CEST] <JEEB> no idea what log level that maps to
[20:08:04 CEST] <JEEB> I only use the named values
[20:08:10 CEST] <Wader8> i also found about -v 9 today lol
[20:08:31 CEST] <Wader8> no actually, i found someone using -v 9 and -loglevel 99
[20:08:32 CEST] <JEEB> anyways, nv12 should only happen when hw decoding is somewhere in the chain
[20:08:57 CEST] <Wader8> i also found about hwaccell today, never knew this command existed
[20:09:31 CEST] <JEEB> Input stream #0:0 frame changed from size:720x480 fmt:yuv420p to size:720x480 fmt:nv12 <- basically means that the decoded input became nv12 (which usually hints at HW decoding)
[20:09:48 CEST] <Wader8> literally hours ago I put it together, google worked good today, im not sure if the -vf fps=24000 is correct for my source DVD but seems like im on a proper road now that the audio works
[20:10:19 CEST] <JEEB> I am definitely not going to comment jack shit about your correctness of dealing with the content since I really don't feel like lecturing anyone tonight
[20:11:00 CEST] <JEEB> but yeah, seems like either there's some preference for nv12 with the mpeg-2 decoder, or you're using HW decoding (more probable) :P
[20:11:42 CEST] <Wader8> hehe okay, i was commenting, not asking, i have abandoned previous project cause I found someone has already mastered those DVDs for modern progressive, interlace removed and pulledup, and with advanced params it looks much better than source DVDs
[20:12:19 CEST] <Wader8> this here, is just a few DVDs for archival
[20:13:09 CEST] <Wader8> well i didn't abandon, i just switched the sources over to the x264 ones
[20:13:24 CEST] <Wader8> one moment pastebin asap
[20:14:06 CEST] <JEEB> also I find it funny how your buffer size is for... (300/2400) of a second
[20:14:26 CEST] <JEEB> + I will have to say to you that you never, ever want to use minrate
[20:14:31 CEST] <JEEB> maxrate+bufsize is all you need
[20:14:59 CEST] <JEEB> also if you are doing 1pass encoding, for the love of whatever on earth use crf rate control and limit it with maxrate+bufsize
[20:18:10 CEST] <Wader8> moment have problem copying cmd, have to add command to output to file
[20:21:25 CEST] <Wader8> JEEB: okay this is with -v 9 and -loglevel 99 http://pastebin.com/G9kaQS7g
[20:22:02 CEST] <Wader8> apparently loglevel 99 is above "debug" if the documentation is not obsolete, but i never saw -v before so not sure about that
[20:22:17 CEST] <Wader8> brb i have to go to WC i'll read when i come back
[20:25:12 CEST] <JEEB> Wader8: unfortunately it doesn't really tell much at all
[20:25:31 CEST] <JEEB> but I still hold onto my theory of it just getting HW decoded with DXVA2 or something
[20:25:38 CEST] <JEEB> nothing else outputs NV12 out of the decoder
[20:26:03 CEST] <JEEB> mostly because you then have to convert it to planar YCbCr (yuv420p) in order to do something with it in ffmpeg
[20:50:31 CEST] <Fozzy> I'm a newbie to ffmpeg, and was trying something out with ffplay.  I was curious about CPU usage, and noticed it was using about 5% cpu.  I specified "-nodisp -nostats" as arguments.  Is there something basic that ffmpeg does that causes it to use the extra CPU time, compared to a few other players which mostly hover at 0%?
[20:52:20 CEST] <JEEB> well if you are not doing decoding on the cpu and have no-copy rendering then of course you will have very low cpu usage (but on the other hand, higher (i)GPU usage because the ASIC is working for the decoding), although it still shouldn't be 0% because you have parsing and audio decoding as well as possible subtitles to deal with
[20:52:27 CEST] <JEEB> also ffplay should not be benchmarked against
[20:52:33 CEST] <JEEB> it's not a proper player
[20:52:45 CEST] <JEEB> it's a proof of concept basic player that lets you test some things, maybe
[20:54:53 CEST] <Fozzy> I apologize, I actually missed (an important?) note when I asked my original question.  The media I am playing is a simple wav file, no video involved.
[20:55:22 CEST] <Mavrik> I'm not sure what the question is :/
[20:55:47 CEST] <JEEB> Fozzy: in that case it's just ffplay's output not being exactly optimized - whatever audio output it uses
[20:56:03 CEST] <JEEB> in which case I will just point towards the fact that ffplay is not a "real player"
[20:56:22 CEST] <JEEB> you are of course free to improve it, but it is supposed to be just a thing to test with
[20:56:24 CEST] <Fozzy> JEEB: Thank you!  That does help a lot and I can look further
[20:56:26 CEST] <JEEB> not an actual player
[20:57:27 CEST] <Fozzy> I wasn't sure if it was naturally doing some FFT or histogram calculations (which might have been used for the display, if it had been activated)
[20:57:48 CEST] <Fozzy> but I'll look through it and see what I can find.  Thanks again!
[21:43:55 CEST] <tomas2> Hello
[21:45:45 CEST] <durandal_1707> hello
[21:46:27 CEST] <tomas2> I got one question. I compiled ffmpeg on raspbian with configuration  ./configure --arch=armel --target-os=linux --enable-gpl --enable-libx264 --enable-nonfree but when I write -vcodec libx264 I get error Illegal Instruction
[21:47:33 CEST] <Wader8> JEEB: but is NV12 anything special, will the video be less compatible, i am not as familiar but i will try to look up, if I fail i would appreciate your input
[21:47:54 CEST] <JEEB> same video data in another way
[21:47:57 CEST] <Wader8> it is working for me in MPC-HC but ...
[21:48:22 CEST] <JEEB> anyways, not like the input colorspace means anything as you are setting an output colorspace
[21:48:25 CEST] <Wader8> it may have some HDTV compatability issues?
[21:48:51 CEST] <Wader8> but it's not meant for HDTV, im just wondering
[21:49:09 CEST] <Wader8> it's meant for archival, at least something in the future to be able to open it
[21:49:37 CEST] <Wader8> sorry I am unfamiliar with colorspaces in the ffmpeg context, i do only know basics
[21:51:37 CEST] <anYc> benbro: I think I got it now. could you check if you can cut your h264 mp4 and mkv with avcut? (https://github.com/anyc/avcut)
[21:52:03 CEST] <tomas2> Thank you ... here is the pastebin: http://pastebin.com/NkF7Q5js
[21:52:37 CEST] <Wader8> mediainfo still says YUV 420 in the output
[21:52:55 CEST] <Wader8> but i've seen mediainfo not being accurate in the past so
[21:53:12 CEST] <JEEB> Wader8: pix_fmt yuv420p is 4:2:0 YCbCr.
[21:53:24 CEST] <JEEB> so, uh, yeah
[21:53:27 CEST] <Wader8> well I know that ...
[21:53:36 CEST] <JEEB> then what
[21:53:54 CEST] <JEEB> I don't think you have an issue do you :P
[21:54:05 CEST] <Wader8> well i didn't understand what you meant with one of the responses ... maybe i am also misunderstanding the log from ffmpeg
[21:54:30 CEST] <Wader8> but now i think I get it, you think it's being transformed to nv12 for the GPU then back to yuv420 ?
[21:54:39 CEST] <JEEB> nv12 is the source colorspace and it is also 4:2:0, a form of packing the chroma stuff together and luma being separate. GPUs love it and HW decoders output it
[21:55:05 CEST] <JEEB> so as ffmpeg gets it, it shuffles the bytes again in memory to get fully planar YCbCr again :P
[21:55:20 CEST] <Wader8> aha, so HW decoder outputs that, but ffmpeg puts it back into ordinary yuv420 then ?
[21:55:33 CEST] <Wader8> aha aha, okay, now i get it
[21:55:55 CEST] <JEEB> I actually wonder how much you are losing speed because of the conversion
[21:55:57 CEST] <durandal_1707> tomas2: open bug report on bug tracker
[21:56:04 CEST] <JEEB> compared to how much you are getting speed with the HW decoding
[21:56:42 CEST] <Wader8> well, i'm just testing, if it's faster without i'll turn it off, i'm not required to use HW
[21:58:37 CEST] <durandal_1707> tomas2: yes, that is our bot
[21:58:42 CEST] <Wader8> but,  i think it isn't being worded correctly, i'll test it without HW, then i'll objectively try to understand it to not make false assumption, only then i'll submit a tract
[22:01:20 CEST] <benbro> anYc: trying
[22:02:08 CEST] <benbro> anYc: in the readme, you mixed the installation instructions of libav and ffmpeg :)
[22:05:58 CEST] <anYc> uhm, doesn't libav*-ffmpeg-dev install ffmpeg on libav-based ubuntus?
[22:06:49 CEST] <JEEB> if it's new enough, yes
[22:06:56 CEST] <JEEB> starting with 15.04 I think
[22:13:22 CEST] <anYc> okay thanks! maybe benbro meant something else
[22:29:44 CEST] <Wader8> JEEB  CRF doesn't work in libx265 params, should this be noted in https://trac.ffmpeg.org/ticket/4284  or not, because the OP doesn't mention CRF.
[22:30:23 CEST] <JEEB> -crf XX should work, check the output that libx265 gives regarding the options it uses
[22:30:26 CEST] <Wader8> but i guess the guys who fix stuff might check all of them not just the one's mentioned, still, there's a lot of params i hope it's not a lot of code per param
[22:31:18 CEST] <JEEB> but yes, with many other parameters you have to use -x265-params <actual libx265 API settings in key=value pairs>
[22:31:23 CEST] <Wader8> well without the param comman CRF won't work, ffmpeg works otherwise, it just ignores the value, anywhere i set it below 28 it always used 300kbps bitrate
[22:31:55 CEST] <JEEB> tell me what libx265 tells you
[22:32:02 CEST] <JEEB> if you set -crf after input
[22:32:08 CEST] <JEEB> it should match
[22:32:16 CEST] <JEEB> if not, you have an old FFmpeg I'm pretty sure
[22:32:18 CEST] <Wader8> after input ?
[22:32:25 CEST] <Wader8> i downloaded it a few hours ago
[22:32:35 CEST] <JEEB> after the input, as in -i herpderp_input.file
[22:32:40 CEST] <Wader8> zeranoe winX64
[22:32:53 CEST] <JEEB> please answer the question
[22:33:03 CEST] <JEEB> if you set crf value to something, does libx265's output follow or not
[22:33:15 CEST] <JEEB> crf is an encoder setting, and thus you have to set it after the input
[22:33:34 CEST] <JEEB> (as opposed to decoder options that are put before the input)
[22:33:41 CEST] <Wader8> yeah i put it after the input, oh i mixed with "before" ... yes there is an error if it's used without the "param command" but if i do it properly, it doesn't do any errors or warnings
[22:33:53 CEST] <JEEB> jesus christ
[22:33:57 CEST] <Wader8> i can show you example with CRF at zero
[22:33:58 CEST] <JEEB> is it that hard to just asnwer
[22:34:00 CEST] <JEEB> *answer
[22:34:13 CEST] <Wader8> let me read what you wrote, moment
[22:34:15 CEST] <JEEB> if you put crf 14 f.ex. after -i
[22:34:21 CEST] <JEEB> as in, after the input file
[22:34:28 CEST] <JEEB> what does libx265 itself output to you
[22:34:38 CEST] <JEEB> it outputs the parameters it uses on the general level onto the terminal output
[22:34:43 CEST] <JEEB> CRF is there
[22:35:13 CEST] <JEEB> also just to count out stupidity and mistakes, please pastebin full command line as well and link it here
[22:36:09 CEST] <Wader8> roger, just, what I meant with "didn't work" wasn't literally
[22:38:00 CEST] <JEEB> just fucking post the information/result and we'll go further from there. not exactly rocket science, is it
[22:38:15 CEST] <benbro> For Ubuntu versions with libav as default, e.g., 15.04:
[22:38:22 CEST] <benbro> apt-get install libavcodec-ffmpeg-dev libavformat-ffmpeg-dev libavutil-ffmpeg-dev
[22:38:30 CEST] <benbro> it should be the instruction for ffmpeg
[22:38:38 CEST] <benbro> anYc: ^^
[22:38:59 CEST] <benbro> ok, maybe I missread the instructions
[22:42:48 CEST] <anYc> ok, I see what you mean
[22:44:01 CEST] <anYc> but it's time to go to bed know, good night
[22:44:29 CEST] <benbro> good night
[22:45:37 CEST] <Wader8> sorry jeeb i got a lot of stuff on taskbar had to save&close down, in a moment
[22:48:31 CEST] <Wader8> here http://pastebin.com/Ze2gswSU
[22:49:12 CEST] <JEEB> uhh
[22:49:21 CEST] <benbro> anYc: got an error: frame for pkt #214 (dts 16535900) not found
[22:49:21 CEST] <JEEB> try with -crf 18
[22:49:33 CEST] <JEEB> although wait
[22:49:35 CEST] <JEEB> uhh
[22:49:36 CEST] <benbro> anYc: on another mp4. I'll try to create a test case and share
[22:49:56 CEST] <JEEB> Wader8: I'll let you guess wtf you are doing wrong by this error message "[libx265 @ 0000000002b1b060] Unknown option: -crf."
[22:50:17 CEST] <JEEB> hint: -crf is an ffmpeg option, libx265 parameter is just "crf"
[22:50:50 CEST] <Wader8> well doesn't look like it appears visible in the CMD
[22:50:52 CEST] <JEEB> leave out the -x265-params and just do -crf XX
[22:51:13 CEST] <Wader8> i must have used the = back then they why it stopped in error
[22:52:29 CEST] <Wader8> but i am sure that there's a bug in the output color let me test
[22:52:43 CEST] <JEEB> you are setting -pix_fmt yuv420p and are getting 4:2:0 encoded as you are asking, please tell me more
[22:53:55 CEST] <Wader8> JEEB, well okay I surrender, because I use verbose output, the whole screen scrolled down as it was a lot of text, so the error is cyan-yellow and it appeares in early
[22:54:27 CEST] <Wader8> oh, it's not an error, a warning, so it doesn't stop the conversion
[22:54:33 CEST] <JEEB> ffmpeg -your -parameters 2> hurrdurr.log
[22:54:50 CEST] <JEEB> 2> redirects standard error
[22:55:02 CEST] <JEEB> which is where ffmpeg outputs its stuff
[22:55:16 CEST] <JEEB> (because standard output can be used for piping output of actual data)
[22:55:31 CEST] <Wader8> i forgot what 2> means, i just pulled it off the internet last time i needed logfile output
[22:55:51 CEST] <Wader8> because i neede it quickly i didn't read up on 2>
[22:58:26 CEST] <Wader8> well maybe i can put a suggestion into trac to treat -crf as error not warning
[00:00:00 CEST] --- Tue Oct 20 2015

More information about the Ffmpeg-devel-irc mailing list