[Ffmpeg-devel-irc] ffmpeg.log.20151025

burek burek021 at gmail.com
Mon Oct 26 02:05:01 CET 2015

[05:37:55 CET] <mischmerz> Quick question: Does current ffmpeg support dsd over pcm (decode) ?
[05:55:03 CET] <Technicus> Hello :)
[05:58:24 CET] <Technicus> I'm trying to figure out how to view a webcam, and record it at the same time.  Will someone please direct me to a suitable tutorial?
[05:58:46 CET] <mischmerz> Technicus: Pretty quiet in here :(
[05:59:03 CET] <Technicus> What are you doing over there?
[06:01:09 CET] <mischmerz> Waiting for an answer in regard to dsd over pcm.
[06:04:45 CET] <Technicus> What is dsd?
[06:07:21 CET] <mischmerz> Technicus: Digital audio format.
[07:25:20 CET] <Technicus> I feel like I am circling a solution with this: < http://superuser.com/questions/322216/how-can-i-pipe-output-of-ffmpeg-to-ffplay/489082#489082 >, but I do not understand how to pipe the captured video into ffplay.
[08:30:42 CET] <Technicus> I finally came up with a solution: < https://gist.github.com/Technicus/a923e0f6d60e42b40609 >. It is not optimum, but it satisfies my objective.
[10:26:46 CET] <comets> sup, is it possible to convert .mkv files (with HEVC) in .avi files without losing quality?
[10:35:24 CET] <JEEB> use a lossless video format and it will be lossless
[10:36:47 CET] <comets> such as? some do a movie in less than 5 minutes, others take longer that 2 hours :(
[10:37:33 CET] <JEEB> ut video or ffv1 or whatever :P
[10:37:51 CET] <JEEB> but most probably you don't want that because if you want AVI you want to play that shit on a crappy plastic toy?
[10:38:13 CET] <JEEB> which is so old it still doesn't have an AVC decoder and support for newer containers
[10:38:52 CET] <comets> probably :(
[10:39:01 CET] <JEEB> "probably"?
[10:39:11 CET] <JEEB> so what's your use case? does it really have to be AVI?
[10:39:39 CET] <comets> wanna watch it on TV lol connected via USB to the dvd player
[10:39:52 CET] <JEEB> which only supports AVI?
[10:40:07 CET] <comets> sadly, .avi is he only format apart from .vob that can work on tv's..
[10:40:13 CET] <JEEB> not really :P
[10:40:26 CET] <comets> wll maybe .mpg oo but thats it..
[10:40:28 CET] <JEEB> I have seen plenty of TVs that decode a whole lot of stuff
[10:40:38 CET] <comets> mines from 2002 :P
[10:40:43 CET] <JEEB> ok
[10:40:47 CET] <JEEB> rip then
[10:40:48 CET] <comets> with that big ass backside :P
[10:41:02 CET] <JEEB> mpeg-4 part 2 encoding is a pain in the arse
[10:41:50 CET] <JEEB> your best bet is to use libxvid and libmp3lame (I think lame was called like that in lavc) and use -q:v 2 + -b:a 192k or so
[10:41:54 CET] <comets> i used > ffmpeg -i Maze.mkv -vcodec mpeg4 -acodec libmp3lame -qscale:v 2 -qscale:a 5 output.avi
[10:42:11 CET] <comets> it can't seem to find libxvid and libmp3lame :/
[10:42:37 CET] <JEEB> the mpeg4 encoder is also acceptable but IIRC it's even more "fun" to set up
[10:42:56 CET] <JEEB> well then I guess you didn't build ffmpeg with those libraries
[10:42:59 CET] <comets> no wonder it takes forever :/
[10:43:12 CET] <JEEB> yes, the mpeg-4 part 2 encoders are not exactly optimized
[10:43:22 CET] <JEEB> it's funny when a newer video format's encoder is actually faster
[10:43:24 CET] <comets> 4 conversion i did ogot stuck at 99% .. that sucks ;/
[10:43:53 CET] <JEEB> although with HEVC the decoder might be the limiting part because that's not fully optimized yet (nobody paid for that yet)
[10:43:57 CET] <comets> yeah i used older tools for conersion like WinAvi 7.7 but those tools do not like HEVC..
[10:44:19 CET] <comets> handbrake fails epically..doesn't like source..
[10:44:30 CET] <JEEB> probably just old
[10:45:03 CET] <JEEB> I recommend a) making sure you've got the latest version and b) if the latest release is not good, try out the nightlies
[10:45:20 CET] <JEEB> handbrake is probably the simplest open source encoding UI :P
[10:45:21 CET] <comets> winavi is good to convert mp4 to avi for use on TV, does it within 12mins ..just failing with HEVC (mkv) formats..
[10:45:52 CET] <comets> i have the latest ffmpeg..
[10:47:21 CET] <JEEB> did you build it yourself or what?
[10:48:30 CET] <comets> i can't build...i can't even make paper planes :(
[10:49:03 CET] <JEEB> well I'm just asking because a) I'm guessing you're on windows and b) zeranoe's windows builds seem to include libxvid
[10:49:18 CET] <JEEB> and you're saying you don't have libxvid in there
[10:50:24 CET] <comets> its there, its just not used, i tried many variations of the name, won't use any..odd..
[10:51:01 CET] <comets> wow took 2 hours to convert a 110mb .mkv file into a 1.2gb mp4file :/
[10:51:38 CET] <JEEB> if it's that command line you pasted then it's not mp4
[10:51:58 CET] <JEEB> it's mpeg-4 part 2 in AVI and neither the HEVC decoder or MPEG-4 Part 2 encoder are optimized too hard
[10:52:14 CET] <comets> oh yeah, a.vi , my bad.. i converted like 7 films in both formats lol
[10:52:41 CET] <JEEB> also you didn't set a preferred bit rate but a quantizer (which kind of makes sense with MPEG-4 Part 2, although with any newer video format you wouldn't be using it)
[10:52:52 CET] <JEEB> so complaining about any file  size is kind of moot
[10:53:36 CET] <comets> yeah i'll set 600kbps in the next one..
[10:53:40 CET] <JEEB> also your input most probably was bit rate starved anyways and is encoded in a newer video format so it's not exactly surprising
[10:54:18 CET] <comets> yeah can you give me a good setting to use in the future?
[10:54:25 CET] <JEEB> if you are going to do bit rate based then you have to use 2 passes, otherwise you'll end up with a bad result
[10:54:54 CET] <JEEB> no, I don't know about mpeg-4 part 2 and it was before any video encoder started having presets or anything resembling user friendliness
[10:55:26 CET] <JEEB> I'm kind of happy all of my hardware boxes can decode AVC
[10:55:41 CET] <JEEB> that stuff has understandable profiles and levels, and easily usable + optimized encoders :P
[10:55:58 CET] <JEEB> even my 1st gen xbox from '01 can handle it :D (well, it's a celeron inside so welp)
[10:58:10 CET] <comets> anyone know a good film editor to cut off the end bit of a movie fast?
[10:58:27 CET] <JEEB> if you know the timestamps you can just use -ss and -t
[10:58:38 CET] <comets> its messing up wit hteh conversion i think, the idiots who 'pirated' the film decided to add their shitbit at the end :/
[10:59:10 CET] <JEEB> oh, then you can just set a -t that is just before the time that such things start
[10:59:20 CET] <JEEB> so it will only encode until that point
[10:59:45 CET] <comets> *facepalm* took me 2 hours to convert one vid :/
[11:00:27 CET] <JEEB> also you can cut matroska files on the random access points with mkvmergegui
[11:00:31 CET] <JEEB> without re-encoding
[11:00:35 CET] <JEEB> ffmpeg can also do it
[11:00:44 CET] <JEEB> that way you can cut it physically off of the source
[11:02:00 CET] <comets> damn, had mkvtoolnix, will get that one too..
[11:33:53 CET] <JEEB> ok, now bt.2020->bt.709 works with zimg :) https://github.com/sekrit-twc/zimg/commit/04076c121b4b078bff70972ce3cfa0df6aeae8b8
[11:34:17 CET] <JEEB> too bad the colorspace whiner is no longer here I see :/
[11:47:43 CET] <ChocolateArmpits> I think he was more outspoken about ffmpeg than colorspaces
[11:48:19 CET] <JEEB> well his bottom line seemed to be "swscale sucks"
[11:59:01 CET] <durandal_1707> he added avx optimizations
[12:59:42 CET] <Skippy_42> Hey, guys, can anyone tell me what is wrong with this command "ffmpeg -i "/my/test/folder/testfile with spaces.flv" -c:v libx264 -c:a copy "/my/test/folder/testfile with spaces.flv.mp4"
[13:00:20 CET] <Skippy_42> k sry
[13:21:47 CET] <Skippy_42> Another question: What is my mistake when a command works when directly written into the terminal, but not when called from a shellscript?
[13:22:21 CET] <c_14> probably escaping
[13:24:01 CET] <Skippy_42> as I thought, I am still searching for solutions, didn'T find anything yet, if you have an idea tell me
[13:26:34 CET] <ChocolateArmpits> use escape characters in paths or if the command has illegal characters then escape them too
[13:29:11 CET] <iive> in unix escape char is \, so "\ "
[13:30:52 CET] <Skippy_42> I thought I died, hehe
[13:31:08 CET] <furq> Skippy_42: you need more quotes
[13:31:13 CET] <Skippy_42> I am still searching for what is not escabed correctly
[13:31:14 CET] <furq> or you have too many quotes
[13:31:21 CET] <furq> or you have the right number of quotes distributed incorrectly
[13:31:32 CET] <Skippy_42> I post those 2 lines, I guess it doesnt need to be pastebin for that, right?
[13:31:54 CET] <furq> if you pastebin it then it's easier for us to fix it
[13:31:59 CET] <Skippy_42> kk
[13:33:09 CET] <Anoia> Skippy_42: at what point will a paste become an annoying paste? It's best to put anything that isn;t conversation elsewhere
[13:33:32 CET] <Skippy_42> http://pastebin.com/r7Mf4Fpi
[13:34:59 CET] <Skippy_42> ok wait that suxx I put the outputs there too, I just need afk aaaaaahhh everybody around me is driving me crazy, sry for wasting your click, I do a usefull post in 15 mn
[13:35:02 CET] <Skippy_42> min*
[13:35:27 CET] <furq> i take it you're storing ffcmd in a variable for a good reason
[13:37:17 CET] <furq> Anoia: i'm pretty sure the internationally recognised size for an annoying paste is three lines
[13:47:16 CET] <Skippy_42> I'm sorry for that. It works now when I don't put the command in a variable, so thx for that, I will check why another time
[13:54:32 CET] <JEEB> I have found that in the end things tend to work most expected when you create the parameters yourself and launch the application with an array you have created yourself. I don't think shells let you do such things, but python f.ex. should
[13:54:44 CET] <JEEB> or ruby
[13:55:48 CET] <furq> i generally stop writing shell scripts as soon as escaping becomes necessary
[13:56:05 CET] <c_14> bash/zsh etc have arrays, but they're really ugly to use
[13:56:18 CET] <c_14> As is most shell scripting
[13:56:29 CET] <furq> i also restrict myself to /bin/sh to further resist temptation
[13:57:10 CET] <JEEB> c_14: most specifically they probably lack and exec() that takes in an array
[13:57:19 CET] <JEEB> and properly separates the arguments thus
[13:58:02 CET] <JEEB> the good part is that you skip shell in that case, the bad part is that you have to create lists of files and stuff like that yourself
[16:56:39 CET] <inflex> Trying to enable 'faststart' to movflags programatically in C++,  already have dsr = av_dict_set(&pmetadata, "movflags", "faststart", 0);   but that doesn't seem to enable it.  Other attributes I set via av_dict_set() are working (such as stream title).
[16:59:18 CET] <BtbN> is your output seekable?
[17:00:41 CET] <inflex> once once the stream has been fully written, in which case it's no different to when I've not tried applying the faststart flag
[17:01:05 CET] <BtbN> what do you mean?
[17:01:30 CET] <BtbN> ffmpeg can't write the moov atom to the front imediately. It only does so at the end, seeking back to the front and writing it.
[17:01:42 CET] <BtbN> So if the output is not seekable, it has no effect.
[17:02:36 CET] <inflex> source is from a h264 security cam, being written in 10 minute blocks to mp4 files.  Sometimes it's desirable to download and view events prior to the termination of the 10 minute block
[17:02:56 CET] <inflex> (ie, partially complete file)
[17:03:04 CET] <BtbN> Don't use mp4 then?
[17:03:48 CET] <inflex> mp4 is preferrable because the stream is already h264 encoded and mp4 otherwise is well supported by most browsers with HTML5 players; also transcoding to another format adds quite a chunk of load
[17:04:07 CET] <BtbN> Well, watching before the file is done isn't going to happen then.
[17:05:19 CET] <inflex> So all the fragmented / moov options are more about making the mp4 seekable /post-completed/.
[17:05:38 CET] <BtbN> The information that's needed to create the moov atom does not exist before the file is complete.
[17:05:39 CET] <inflex> ie, no doubt I'd be able to seek/stream it just fine once the 10 minute block is done and the stream closed.
[17:05:45 CET] <BtbN> It's impossible to write it at the beginning.
[17:06:16 CET] <inflex> okay, np, that was my dud assumption then about the nature of the fragmenting process.
[17:06:45 CET] <inflex> mkv does work I've found (at least, partially), just that it's not supported too well in-browser.
[17:07:23 CET] <BtbN> nothing is supported too well in a browser.
[17:07:29 CET] <inflex> True enough.
[17:08:24 CET] <BtbN> Use flash if you want stuff that just works.
[17:12:09 CET] <DHE> is mpegts browser supported? it will hold h264 with only a -bsf required
[17:12:36 CET] <ChocolateArmpits> ts will most likely need a player
[17:13:22 CET] <JEEB> mpeg-ts is only supported with HLS playlists and only with mobile configurations
[17:13:24 CET] <JEEB> for whatever reason
[17:14:01 CET] <JEEB> I think edge is the only desktop browser that supports it
[17:14:24 CET] <DHE> damn
[17:17:46 CET] <inflex> thanks for the clarification BtbN
[17:18:12 CET] <inflex> Might have to go with mkv container + custom viewing clients for win/*nix
[17:24:24 CET] <pcroland> Hi
[17:24:59 CET] <pcroland> How can I concatenate multiple VOB files and using yadif at the same time?
[17:26:19 CET] <durandal_1707> with concat filter
[17:28:57 CET] <pcroland> Filtergraph 'yadif=deint=interlaced' was specified through the -vf/-af/-filter option for output stream 0:0, which is fed from a complex filtergraph.
[17:28:57 CET] <pcroland> -vf/-af/-filter and -filter_complex cannot be used together for the same stream.
[17:30:11 CET] <pcroland> I get this error when I try this command: http://pastebin.com/raw.php?i=JYBSRMSM
[17:35:32 CET] <durandal_1707> use only filter complex
[17:39:04 CET] <pcroland> How? :S
[17:39:28 CET] <fred1807> can I convert 1 png image to a 30 second movie?
[17:41:12 CET] <durandal_1707> yes
[17:42:04 CET] <fred1807> Am I missing anything here? ffmpeg -loop 1 -i image.png -c:v libx264 -t 15 -vf scale=1920:1080 out.h264
[17:42:08 CET] <durandal_1707> pcroland: -lavfi ...concat, yadif...
[17:44:06 CET] <fred1807> I see a tutorial with "-pix_fmt yuv420p"   <-- Is this related to 420p resolution? (I want 1080p...)
[17:44:59 CET] <c_14> If you want a 30s movie, why are you specifying a length of 15s?
[17:45:01 CET] <pcroland> fred1807, there is no connection with the 420p
[17:45:08 CET] <pcroland> to the resolution
[17:46:11 CET] <fred1807> this is what I did, ffmpeg -loop 1 -i fundoinsta1080p.png -t 15 -vf scale=1920:1080 out.h264
[17:46:12 CET] <fred1807>    I got a warning about yuv420p , but I guess I dont need to use it becuase my output is raw h264, am I right?
[17:47:17 CET] <pcroland> durandal_1707, Still have no idea how to deinterlace the concated video :S
[17:47:42 CET] <durandal_1707> with yadif
[17:48:30 CET] <pcroland> I know that I have to use yadif but as I said I get an error when I use it with the concat filter
[17:53:32 CET] <durandal_1707> Pastebin output
[17:57:26 CET] <pcroland> http://pastebin.com/raw.php?i=aPMyvNQ8
[17:58:10 CET] <ChocolateArmpits> fred1807: pixfmt sets chroma subsampling, basically the resolution of chroma channels. The subsampling model you use largely depends on video delivery.
[17:59:58 CET] <durandal_1707> pcroland: I told you to use only filter_complex , add yadif after concat
[18:01:37 CET] <ChocolateArmpits> That's not how you concat vob parts
[18:02:15 CET] <ChocolateArmpits> it should be -i concat:"VTS_01_1.VOB|VTS_01_2.VOB|VTS_01_3.VOB|VTS_01_4.VOB"
[18:02:26 CET] <ChocolateArmpits> upward slash is used to separate different files
[18:02:54 CET] <ChocolateArmpits> after that you can use normal video filters
[18:02:57 CET] <ChocolateArmpits> -vf yadif
[18:03:05 CET] <durandal_1707> no, concat protocol should not be used
[18:03:20 CET] <ChocolateArmpits> why ? I never had trouble with it with dvs
[18:03:23 CET] <ChocolateArmpits> dvds*
[18:03:45 CET] <durandal_1707> specially if vobs have different params
[18:03:59 CET] <ChocolateArmpits> Well the file names suggest same source
[18:04:18 CET] <ChocolateArmpits> and the format output does so too
[18:04:24 CET] <ChocolateArmpits> I really see no problem here
[18:05:19 CET] <pcroland> http://pastebin.com/86HQD2S9 durandal_1707
[18:05:56 CET] <ChocolateArmpits> filter complex isn't needed when using concat filter after that
[18:06:18 CET] <ChocolateArmpits> as it's treated as a single input
[18:06:34 CET] <pcroland> Those files have the same params
[18:06:40 CET] <pcroland> It's a film
[18:06:56 CET] <ChocolateArmpits> You might just want to map the video stream only -map 0:v
[18:06:56 CET] <pcroland> So what should I do?
[18:07:19 CET] <ChocolateArmpits> remove filter_complex, and replace existing -map to -map 0:V
[18:07:24 CET] <ChocolateArmpits> -map 0:v that is
[18:07:27 CET] <ChocolateArmpits> lowercase
[18:07:49 CET] <ChocolateArmpits> You can also disable audio with -an
[18:19:58 CET] <pcroland> It works, thanks
[18:20:02 CET] <pcroland> ChocolateArmpits
[18:20:08 CET] <ChocolateArmpits> pcroland: np
[18:24:20 CET] <pcroland> Is it possible tho crop odd pixel from the left and odd pixel from the right?
[18:25:50 CET] <ChocolateArmpits> pcroland: You can use a crop filter after yadif
[18:28:52 CET] <pcroland> yadif=0:0:0 should be good, am I right?
[18:30:03 CET] <ChocolateArmpits> If the source is top field first then yes
[18:32:52 CET] <pcroland> It is
[22:01:45 CET] <ribasushi> greetings
[22:02:00 CET] <ribasushi> https://github.com/FFmpeg/FFmpeg/commit/e786e96be <--- this commit broke some use of ffmpeg for me
[22:02:40 CET] <ribasushi> I use rtp as a *secondary* -c:v copy stream of a crappy built-in camera which produces non-standard jpeg frames
[22:03:04 CET] <ribasushi> the secondary stream is needed only to "tune-in" to the recording to check that focus/position are correct
[22:03:27 CET] <ribasushi> the result with older versions of ffmpeg is absolute crap, but it is sufficient for my purposes as stated above
[22:03:50 CET] <ribasushi> is there any way a "continue anyway" option could be added to the RTP muxer?
[22:04:53 CET] <c_14> It's possible, but I don't think support for creating invalid output streams should be commited to master. You could probably just revert that commit for local builds.
[22:04:56 CET] <ribasushi> alternatively if someone can suggest a different container to stream arbitrary (sometimes really broken) frames in copy-mode, I can simply switch away from RTP
[22:05:15 CET] <c_14> Just use udp or tcp?
[22:05:33 CET] <ribasushi> c_14: but which container format?
[22:06:35 CET] <ribasushi> "just use udp" is what's confusing for me...
[22:07:39 CET] <c_14> Maybe matroska, that usually supports all formats.
[22:08:41 CET] <ribasushi> this indeed works, I wasn't aware I can do that
[22:08:59 CET] <ribasushi> a "local build" is not possible as this is supposed to be a generic tool, supporting whatever one throws at it
[22:09:03 CET] <ribasushi> but this is good enough
[22:09:12 CET] <ribasushi> ... -c copy -f matroska  udp://
[22:09:19 CET] <ribasushi> c_14++ # thanks!
[23:59:16 CET] <pcroland> Is it possible that an tff interlaced (MediaInfo) PAL film is progressive regardless what MediaInfo says?
[23:59:54 CET] <iive> yes
[00:00:00 CET] --- Mon Oct 26 2015

More information about the Ffmpeg-devel-irc mailing list