[Ffmpeg-devel-irc] ffmpeg.log.20151027

burek burek021 at gmail.com
Wed Oct 28 02:05:01 CET 2015

[01:35:54 CET] <techtopia> o/
[01:36:22 CET] <techtopia> so when im encoding in windows, every update gets displayed as a new line like this
[01:36:30 CET] <techtopia> http://i.imgur.com/2PqKpek.jpg
[01:36:48 CET] <TD-Linux> that's because windows doesn't have proper terminal emulation
[01:36:54 CET] <techtopia> is there anything i can add to my command to make it just update in one line? instead of spamming the command window
[01:37:33 CET] <techtopia> any way around it TD-Linux?
[01:39:10 CET] <TD-Linux> -nostats, but that won't give you any progress
[01:40:05 CET] <furq> techtopia: resize your terminal
[01:40:15 CET] <furq> that only happens if the terminal is too narrow to fit a full line of stats
[01:40:20 CET] <DHE> looks like the line is just too long and wrapping around. so going back to the start of the line only goes back 1 byte, not 81
[01:40:35 CET] <DHE> and you can see if is too long. there's an 's' from "bits/s" that wrapped
[01:40:45 CET] <DHE> that's all it takes
[01:40:50 CET] <furq> right click the terminal titlebar and change screen buffer size in the layout tab
[01:41:10 CET] <furq> i can't believe it's 2015 and i still have to explain how to resize a window in windows. thanks bill gates
[01:41:53 CET] <TD-Linux> but now you can resize the environment variables GUI.
[01:42:09 CET] <DHE> I'm mildly annoyed it can be vertically resized by simple clikc+drag but not horiztonally
[01:42:24 CET] <furq> alternatively use console2 or conemu or mintty or some other competent terminal
[01:44:32 CET] <techtopia> i changed the width buffer in the settings but no change
[01:44:43 CET] <techtopia> i guess i would have to restart it to see the change?
[01:44:48 CET] <maduro_> hi all, is there any trick to getting octagonal audio (not 7.1 - don't want the LFE conversion) working in .m4a audio files?
[01:46:01 CET] <furq> techtopia: i guess you need to restart ffmpeg for it to get the new size
[01:46:09 CET] <techtopia> yes it worked furq
[01:46:14 CET] <techtopia> just tested it with a new session
[01:46:18 CET] <techtopia> thank you very much :D
[02:10:23 CET] <utack> Has one of you dealt with a SMPTE standard yet? I did not quite understand their license agreement, specifically what you are allowed to do if you buy access to the specs for a video codec, can you use that to program a free decoder? ( https://trac.ffmpeg.org/ticket/1087 )
[02:55:39 CET] <pikaren> im transcoding a rmtp stream to youtube live
[02:55:48 CET] <pikaren> what parameters should i use
[02:55:58 CET] <pikaren> the quality seems to be a bit low currently
[03:07:45 CET] <relaxed> pikaren: can you stream copy?
[03:39:53 CET] <pikaren> relaxed: nah youtube says unspported codec
[03:41:43 CET] <pikaren> currently im using this command: http://pastebin.com/gnBsZNSx
[03:44:01 CET] <furq> pikaren: you're not actually specifying a bitrate there
[03:45:09 CET] <pikaren> should i use b:v ?
[03:45:21 CET] <furq> apparently you can use -crf with maxrate so i'd do that
[03:45:57 CET] <pikaren> hmm
[03:47:34 CET] <pikaren> tbh i've trying a lot of these settings but cant tell any difference for most of them
[03:58:40 CET] <pikaren> how much of the video we see every day have been processed by ffmpeg?
[04:06:04 CET] <grublet> doesnt youtube use ffmpeg?
[04:46:58 CET] <relaxed> pikaren: did you see https://trac.ffmpeg.org/wiki/EncodingForStreamingSites
[04:49:12 CET] <pikaren> sure
[06:26:50 CET] <Matador> Keep getting bloody -- Decklink input buffer overrun
[06:44:43 CET] <Max-P> "Stream #0:0: Video: bintext, pal8, 1280x170384, 25 tbr, 25 tbn, 25 tbc" man ffmpeg really takes anything you throw at it as a valid input, crazy
[07:07:13 CET] <pikaren> zz
[08:09:21 CET] <cbsrobot> maduro: you can stick 8 channels into wav, but not sure about m4a
[08:09:36 CET] <cbsrobot> why do you need m4a ?
[09:30:42 CET] <Flerb> Hi. I have a series of timestamped jpgs that I want to put into a timelapse video at a particular speed - how can I do this with ffmpeg?
[11:21:17 CET] <Danielyan> Hi people, need your help, how can I set bitrate for output audio with fnExtractSoundToMP3 method?
[11:25:46 CET] <BtbN> No idea what that method should be, most likely not ffmpeg related.
[11:40:05 CET] <Ironhand> hello, I'm using ffprobe to classify a large set of video files with random sources, many of which were created using a crappy encoder and/or otherwise corrupted; I'm trying to determine with a reasonable level of confidence whether each file can at least be read from start to finish
[11:40:21 CET] <Ironhand> which values from ffprobe could I compare to get a decent idea of this?
[11:41:11 CET] <Ironhand> I thought of comparing the 'format' info, whether duration * bitrate approximately matches the filesize, but if ffprobe actually calculates the bitrate itself by dividing filesize and duration that won't do much good
[11:42:22 CET] <Ironhand> to be clear, what I'm trying to find is files which are, say 1 GB in size, but ffmpeg decoding stops at the 500 MB mark b/c it's too badly corrupted
[11:43:25 CET] <Mavrik> ffprobe really isn't going to help there
[11:43:34 CET] <Mavrik> And there's nothing you can really do except actually run a decode
[11:47:00 CET] <Mavrik> After all, you're trying to determine issues deep within the file while ffprobe is designed to collect data with as little file decoding / reading as possible.
[11:48:44 CET] <Ironhand> well, I am already using the -count_frames option, which causes ffprobe to actually decode the file and determine the number of frames it finds
[11:49:25 CET] <Ironhand> but I don't know which metadata I can reliably compare that number to in order to determine whether the detected frame count approximately matches how long the file really should be
[11:50:05 CET] <Ironhand> so I guess what I'm looking for is to find out which relevant values ffprobe provides that are actually read directly from the file's metadata and not interpreted based on other data by ffprobe
[12:17:09 CET] <ribasushi> greetings
[12:17:49 CET] <ribasushi> is there some way to add video delays (with a humongous buffer, ~10seconds of 1080p) within a complex filtergraph?
[12:17:56 CET] <ribasushi> similar to adelay, but for video
[12:18:11 CET] <ribasushi> I have two streams (so itsoffset can't work) that I need to align
[12:33:20 CET] <ribasushi> I can see the actual buffer implementation (the buffer video source), but I can't find info on how to glue that part to an actual delay loop
[13:16:55 CET] <rm-rvf> Hi everybody. I'm sorry for possible offtopic but where can I ask some questions on mpeg layer 3 streams/ I'm interested in stream that is responsible for audio normalization
[14:27:07 CET] <RobotsOnDrugs> normalization is something that is done to the audio itself
[14:27:52 CET] <RobotsOnDrugs> there is also replaygain which, iirc, is just a metadat field
[14:28:00 CET] <RobotsOnDrugs> metadata
[14:32:49 CET] <ribasushi> anyone on my question earlier? syncing streams by delaying one of them by a pre-determined amount of time?
[14:33:56 CET] <relaxed> ribasushi: use -itsoffset
[14:36:41 CET] <ribasushi> relaxed: both streams come in matroska over stdin, I can't use that, besides (as far as I can tell) -itsoffset doesn't work on live sources anyway, only on files
[14:36:50 CET] <ribasushi> s/files/seekable inputs/
[15:40:48 CET] <maduro> cbsrobot: compression, + going in an mp4
[16:16:15 CET] <yongyung> If I want to encode files for editing, basically "lossless" (I'm not doing any expert color correction etc., I just want high quality files that are compressed, but file size doesn't matter too much), does it matter if I use preset slow, medium or veryfast? I've read that if you plan to re-encode a file the faster presets are better at the same crf, is that true?
[16:20:10 CET] <Mavrik> yongyung, the slower presets are better :)
[16:20:18 CET] <Mavrik> but why not use the losless mode on x264_
[16:20:19 CET] <Mavrik> ?
[16:21:01 CET] <Mavrik> https://trac.ffmpeg.org/wiki/Encode/H.264#LosslessH.264
[16:23:31 CET] <yongyung> Mavrik: Are you sure the slower presets are better? Why would that be? Doesn't make much sense to me... - I'm not using the lossless mode because it's not really worth it, I have to use 4:2:0 chroma subsampling anyway to get vegas to eat the files and crf 8 seems to be a fine quality
[16:23:37 CET] <Hello71> yongyung: you need to figure out what you want.
[16:23:56 CET] <Hello71> speed, quality, size, pick 2 or fewer
[16:26:35 CET] <Mavrik> yongyung, slower presets take more CPU time to do search and lookahead and also enable certain bitstream features at time
[16:27:07 CET] <yongyung> Hello71: I want quality, but my question isn't about direct playback quality, it's about re-encoding the file later (after editing)
[16:28:42 CET] <yongyung> Mavrik: Wouldn't you say that slower presets imply a higher compression for the same visual quality in playback, so retain sort-of less of the original information? Why would the slower presets be better for re-encoding then, if used with the same CRF value?
[16:29:10 CET] <Mavrik> Technically yes.
[16:29:16 CET] <Mavrik> Practically... it's not that clear.
[16:29:36 CET] <Mavrik> Using very fast presets will turn off H.264 bitstream features that can cause more quality loss.
[16:30:56 CET] <theozaurus> Hi. We're having trouble with ffmpeg 2.8.1. When doing the command  `ffmpeg -f concat -i foo` it returns `Unrecognized option 'i foo'` but in 2.7.2 it correctly says `foo: No such file or directory`. Do we need to concatenate files in a different way?
[16:39:02 CET] <pikaren> zzz
[16:39:16 CET] <pikaren> ?
[16:55:35 CET] <yongyung> Hm, when I encode a .mp4 file to a .mkv file, for some reason vlc displays the frame rate as 120.004800 instead of 120 (which it should be). Even when I move the video stream from the mkv file (with -c:v copy) to an .mp4 file, the framerate stays, so I don't think it's VLCs fault. wtf is happening there? I can reencode the video with exactly the same settings to a .mp4 file and it has exactly 120 fps.
[17:03:43 CET] <BtbN> close enough to 120fps though
[17:21:29 CET] <yongyung> BtbN: I mean, it's not like I'd notice a difference, it's just awkward. Especially because it's connected to the container and not to the codec
[17:27:29 CET] <pikaren> hi
[17:27:55 CET] <pikaren> I'm trying to stream video with ffserver to my chromecast
[17:28:05 CET] <pikaren> what kind of format / encoding should i use?
[19:23:06 CET] <cousin_luigi> Greetings.
[19:23:43 CET] <cousin_luigi> How can I join two mp4 clips skipping either the tail of the first one or the head of the second one?
[19:34:51 CET] <fling> What is the difference between x264 and openh264? Which one is better?
[19:35:31 CET] <fling> cousin_luigi: first get the needed parts from your clips using -t and/or -ss
[19:35:46 CET] <fling> cousin_luigi: then join the parts using the concat filter
[19:35:53 CET] <furq> fling: openh264 is designed for realtime (e.g. webRTC)
[19:36:50 CET] <furq> if that's not your use case then x264 is definitely better
[19:37:14 CET] <fling> furq: thanks :>
[20:02:06 CET] <Bombo> hi
[20:04:51 CET] <Bombo> can ffmpeg extract (copy) titles out of a dvd.iso?
[20:05:54 CET] <Bombo> i need to get a list of available titles with playtime, then something like -dvdtitle 5 -c copy
[20:06:04 CET] <cousin_luigi> fling: won't that cause quality loss?
[20:06:30 CET] <Bombo> (without using mplayer or java tools ;)
[22:05:42 CET] <kepstin-laptop> ok, I'm passing a filter script to ffmpeg with the "-filter_complex_script" option; how do I escape a , in the value of a filter parameter in this file (I'm trying to write an expression for a select filter)
[22:05:47 CET] <kepstin-laptop> ?
[22:11:16 CET] <c_14> tried \ ?
[22:12:07 CET] <kepstin-laptop> i've tried between 0 and 3 \ before the ,
[22:12:54 CET] <kepstin-laptop> select=n=2:e=gte(t\,0.000)+gte(t\,257.152) gives "Missing ')' or too many args in 'gte(t'" and "Error initializing filter 'select' with args 'n=1:e=gte(t'"
[22:13:55 CET] <kepstin-laptop> fun, if I use 5 \, i get a different output:
[22:14:21 CET] <kepstin-laptop> select=n=2:e=gte(t\\\\\,0.000)+gte(t\\\\\,257.152) gives "Missing ')' or too many args in 'gte(t\,0.000)+gte(t\,257.152)'" and "Error initializing filter 'select' with args 'n=2:e=gte(t\\,0.000)+gte(t\\,257.152)'"
[22:16:21 CET] <kepstin-laptop> it gets even weirder if I start using single quotes :/
[22:19:25 CET] <c_14> hmm, works for me with one \
[22:21:27 CET] <kepstin-laptop> bah, simplified test case of only the select filter works fine
[22:21:42 CET] <kepstin-laptop> this is in a rather more complex script with multiple lines, etc.
[22:23:11 CET] <c_14> If you can pastebin it, I can look at it. Might be missing a '\' somewhere.
[22:23:38 CET] <kepstin-laptop> could be. let me poke at it a bit more here to see if I can simplify the test case
[22:28:12 CET] <kepstin-laptop> oh, right, all my fault. turns out that i had two places with unescaped commas in the file, and when i fixed one I got an error from the other
[22:28:19 CET] <kepstin-laptop> which made me think I hadn't fixed the first one
[22:29:33 CET] <kepstin-laptop> would be nice to have line numbers in the error reports :)
[23:24:24 CET] <jgarde> Does anyone know how to encode video into h264 Baseline instead of Constrained Baseline?
[23:26:18 CET] <Mavrik> not possible afaik.
[23:29:22 CET] <jgarde> Is there anything else currently available for the task?
[23:29:53 CET] <Mavrik> I guess some commercial encoders might do it.
[23:30:03 CET] <Mavrik> But non-constrained baseline is pretty much out of use for ages now.
[23:32:24 CET] <jgarde> Well, apparently Periscope, the mobile live streaming service, uses it pretty heavily. H264, Baseline at level 2.1
[23:40:01 CET] <furq> are you sure it's not constrained baseline
[23:40:07 CET] <furq> they use the same profile identifier
[23:40:22 CET] <kepstin-laptop> lets see... some older (obsolete) apple devices only support baseline 3.0 or 3.1.
[23:40:35 CET] <JEEB> that means constrained baseline in reality
[23:40:43 CET] <JEEB> nobody uses actual baseline profile features
[23:40:46 CET] <JEEB> :)
[23:40:53 CET] <furq> constrained baseline is a subset of baseline
[23:41:01 CET] <furq> (as the name implies)
[23:41:38 CET] <JEEB> jgarde: that means constrained baseline in practice :)
[23:47:11 CET] <kepstin-laptop> given the stuff i've seen with a quick look, periscope is almost certainly encoding with x264, which doesn't support the loss resistance features from baseline - and they aren't needed anyways, since the periscope streams are tcp (hls, it looks like)
[23:47:51 CET] <Mavrik> jgarde, there's literally no mobile video hardware decoder using baseline.
[23:48:02 CET] <Mavrik> or x264 if they use CPU encode.
[23:51:01 CET] <jgarde> I have a few clips off of the HLS stream and I've run ffprobe on them vs a stream that I've broadcast myself to their service - My encodes are h264 constrained baseline. They'res are just baseline.
[23:52:22 CET] <jgarde> Also, they use RTMP for the upstream. I'm not so sure about the downstream.
[23:52:38 CET] <jgarde> RTMPS as well.
[23:53:14 CET] <Mavrik> If you're half smart you'll beat them by using Main ;)
[23:54:24 CET] <jgarde> I'm trying to playback my streams using their client though. I'm upstreaming RTMP to their ingest server, but the iOS client keeps crashing when it tries to playback my stream.
[23:56:05 CET] <jgarde> Some type of custom RTMP client so I'm thinking it might be a encoder problem.
[23:56:28 CET] <jgarde> I'm trying to match my streams so that they're the same as native Periscope.
[00:00:00 CET] --- Wed Oct 28 2015

More information about the Ffmpeg-devel-irc mailing list