[Ffmpeg-devel-irc] ffmpeg.log.20151029

burek burek021 at gmail.com
Fri Oct 30 02:05:01 CET 2015

[00:09:26 CET] <pmow> llogan http://pastebin.com/4RPGb8FS
[00:11:41 CET] <furq> pmow: -c:s mov_text
[00:11:53 CET] <furq> mp4 doesn't support any other subtitle formats
[00:12:22 CET] <pmow> omg...I have been looking for a list of supported audio/sub formats for the last 20 min.  Thank you so much!
[00:13:03 CET] <pmow> sure enough, works like a charm.  Thanks.
[00:39:05 CET] <pmow> furq: Thanks, Wikipedia had me running around.  I fixed it as well, not much info.
[00:40:00 CET] <furq> fwiw `ffmpeg -codecs | grep ^\ ..S` will give you a list of supported subtitle codecs
[00:41:52 CET] <pmow> yes I saw that...but didn't seem to be by container
[00:42:36 CET] <pmow> thanks
[04:26:07 CET] <foreverska> I wish there was a build server I could get someone else to build a custom ffmpeg config for me
[05:25:25 CET] <jgarde> Can anyone tell me what exactly is going on in this file header?
[05:25:26 CET] <jgarde> https://i.imgur.com/pTZ5HYG.png
[05:25:35 CET] <jgarde> It's an H264 encode
[05:25:47 CET] <jgarde> with some type of proprietary header attached to it
[05:25:57 CET] <jgarde> It's not ID3
[05:27:39 CET] <jgarde> Also, is it possible to append file headers onto a ffmpeg encode?
[05:27:52 CET] <jgarde> In realtime, not post encode
[07:15:10 CET] <t4nk211> i have clone git in my netbeans project now how to run ffmpeg command from java file
[09:38:04 CET] <flux> so I want to pass some auxiliary data to movenc. is AVCodec::extradata the way to do it?
[11:45:34 CET] <SilverCode> when building from source, why would the result of ./configure say that vaapi and vdpau hwaccels are enabled, but the actual final built binary only lists vdapu for hwaccels?
[11:51:36 CET] <toriso> hello, I'm having trouble streaming with ffmpeg, I didn't before, I'm having this message: Using network protocols without global network initialization. Please use avformat_network_init(), this will become mandatory later.
[12:01:43 CET] <toriso> anyone?
[12:15:32 CET] <BtbN> SilverCode, because lavc hwaccels are not related to the ffmpeg cli util hwaccels.
[12:15:48 CET] <BtbN> Nobody felt like implementing vaapi for ffm
[12:15:52 CET] <BtbN> ffmpeg yet.
[12:38:53 CET] <SilverCode> BtbN: ok, but when I "waf configure" mpv, it can't detect vaapi support in libavcodec either (it does pick up vdpau though)
[12:39:09 CET] <SilverCode> so I thought they might be related
[13:02:56 CET] <toriso> I dont understand it works with another rtmp link, but not this one, and I use the same command
[13:03:03 CET] <toriso> how can that be
[13:10:09 CET] <toriso> what is global network initialization
[13:44:04 CET] <bencc> can ffmpeg act as a virtual camera under windows?
[13:44:44 CET] <BtbN> no.
[13:45:22 CET] <bencc> BtbN: maybe you are familiar with a separate project that I can use for a virtual camera?
[13:45:27 CET] <BtbN> no
[13:47:00 CET] <bencc> thanks
[13:49:19 CET] <Bibelen> Hi.
[13:49:19 CET] <Bibelen> I'm using this line in Subsonic for transcoding: ffmpeg -i %s -v 0 -map 0:0 -acodec flac -f flac -
[13:49:19 CET] <Bibelen> This works fine, but now I can't seek within the song. I have googled this for so long without any clear answer. Can anyone here help me?
[13:49:19 CET] <Bibelen> Thank you.
[14:07:20 CET] <Mavrik> Bibelen, that's probably because you don't put your audio in a container.
[14:07:26 CET] <Mavrik> You just dump it raw.
[14:08:24 CET] <Bibelen> What about the -f flac? Doesn't that count as a FLAC-container?
[14:09:12 CET] <Mavrik> There's no such thing as "flac container"
[14:09:13 CET] <Mavrik>  DE flac            raw FLAC
[14:09:29 CET] <Mavrik> Put it into ogg or something.
[14:09:43 CET] <Mavrik> Or  update your audio player to support seeking on raw flac
[14:12:03 CET] <Bibelen> it does support it as long as I don't stream from subsonic
[14:12:30 CET] <Bibelen> If I convert the file using the same line, it works fine.
[14:15:34 CET] <Mavrik> Um, subsonic is a streaming server I guess?
[14:15:47 CET] <Bibelen> Yes
[14:16:05 CET] <Bibelen> I tried ffmpeg -i %s -v 0 -map 0:0 -c:a flac -f ogg - . It did not work
[14:16:07 CET] <c_14> You can't seek in stdout per se, it'll give you output at a set rate and you have to live with it. You can only seek by discarding input if the application provides input faster than you need it.
[14:17:10 CET] <c_14> So the issue is not in ffmpeg, but in however subsonic processes the output and then streams it to your client.
[14:17:36 CET] <c_14> Or in that the cpu of the system encoding to flac cannot encode faster than realtime.
[14:18:06 CET] <Bibelen> Ok. I guess I'll have to take it up with Subsonic forum then.
[14:18:29 CET] <Bibelen> Thank you for your answers!
[14:21:08 CET] <Mavrik> That or your player of course.
[14:21:26 CET] <Mavrik> If subsonic just relays the streaming audio then you of course can't seek it.
[14:22:15 CET] <c_14> Well, seeing as he didn't have a -re in his commandline, I'm relatively sure subsonic must buffer the input somehow (unless the cpu really can't encode flac at faster than realtime)
[14:26:21 CET] <Bibelen> Seeking works with mp3 and ALAC in the same player
[17:39:01 CET] <fred1807> I am no satified with the quality I am getting in scaling 720 to 1080p, what can I add to improve ir?  Right now I am with defaults, my command is: ffmpeg -i input.mp4 -vf scale=1920:1080 out.h264
[17:41:42 CET] <jasom> fred1807: add something like -sws_flags lanczos+accurate_rnd+full_chroma_int+full_chroma_inp
[17:41:52 CET] <fred1807> wow
[17:43:16 CET] <jasom> fred1807: depending on your codec and playback device you might be better off just encoding at the original and letting the playback device upscale
[17:43:27 CET] <jasom> s/original/original resolution/
[17:44:12 CET] <RobotsOnDrugs> there is zero point in upscaling outside of rendering except in very specific edge cases
[17:44:37 CET] <fred1807> yep.. this is some solution.. the device is a raspberry, it has a hvs (hardware video scaler), but when the vhs is busy with many framebuffer overlays (images, interface), in sometimes get busy, and image blinks, so I better send videos in full 1080p already
[17:44:47 CET] <jasom> RobotsOnDrugs: some playback devices do a very poor job of upscaling at rendering time
[17:45:22 CET] <jasom> RobotsOnDrugs: I actually probably have one or two devices lying around that will only decode fixed set of resolutions
[17:45:35 CET] <fred1807> the raspberry gpu perform very well with video alone, but this is kind of a psychedelic project, with many overlays, images, 3d rendering... I am pushing over limits
[17:45:54 CET] <RobotsOnDrugs> one of those specific cases
[17:46:39 CET] <RobotsOnDrugs> unfortunate that some devices are that bad at upscaling, i suppose
[00:00:00 CET] --- Fri Oct 30 2015

More information about the Ffmpeg-devel-irc mailing list