[Ffmpeg-devel-irc] ffmpeg.log.20161231

burek burek021 at gmail.com
Sun Jan 1 03:05:01 EET 2017

[00:19:11 CET] <rjp421> JEEB, is that rtmp user-auth parsing something quick and easy to fix, or does it need a full bug report etc?
[00:20:51 CET] <JEEB> no idea, never worked with rtmp
[00:48:41 CET] <rjp421> youre missing out ;)
[00:49:51 CET] <rjp421> im not sure if its a problem with librtmp or ffmpeg, to know where to submit the "bug"
[00:51:15 CET] <rjp421> what else from cmdline can i use to test publishing to an rtmp endpoint using user auth?
[00:52:06 CET] <rjp421> that uses librtmp, to know if that is the culprit, or not
[01:11:05 CET] <JEEB> rjp421: libavformat has its own internal rtmp implementation
[01:11:15 CET] <JEEB> which is getting used there as far as I can tell
[01:11:48 CET] <JEEB> there used to be a separate librtmp based thing which might still exist and you might be able to use it if you build FFmpeg with librtmp
[01:12:41 CET] <JEEB> and I know enough about RTMP that it doesn't match my use cases
[01:12:49 CET] <rjp421> JEEB, on the static x86_64 linux nightly, it shows --enable-librtmp
[01:13:15 CET] <JEEB> ffmpeg -formats |grep "rtmp" then, or maybe -protocols?
[01:13:26 CET] <rjp421> ok ill look ty
[01:13:38 CET] <JEEB> the thing in the FFmpeg git log you posted before was the internal thing
[01:13:52 CET] <rjp421> ah
[01:14:05 CET] <JEEB> anyways, see if you can find the two implementations so you can switch between them
[01:15:44 CET] <rjp421> ty, ill try.. ill build it with each and see if theres a difference
[01:16:07 CET] <JEEB> uhh, no. just check your static build if it says it's built with librtmp
[01:16:20 CET] <JEEB> filter the output of -formats and -protocols
[01:16:27 CET] <JEEB> for rtmp
[01:16:34 CET] <JEEB> (the grep line I posted)
[01:23:16 CET] <rjp421> JEEB, on the top part the configuration shows --enable-librtmp, but i dont see any output from formats. grep -i rtmp shows " D  live_flv        live RTMP FLV (Flash Video)"
[01:30:30 CET] <rjp421> looking through -formats without grep, i notice a separate line " DE flv             FLV (Flash Video)", but they are different so i assume thats not a problem
[01:43:57 CET] <rjp421> on rpi2, the ffmpeg package shows --enable-librtmp, also with the same grep results
[01:44:23 CET] <rjp421> and also has the issue with rtmp user-auth
[01:45:59 CET] <rjp421> well rpi2 with debian-based os (kali)
[02:21:29 CET] <zZap-X> can ffmpeg do bit perfect playback?
[02:21:45 CET] <zZap-X> or would i be better off using decoders like mad, etc
[02:30:02 CET] <kepstin> it can do bit perfect playback of codecs that have bit perfect decoding defined
[02:30:37 CET] <kepstin> which is, i guess, most lossless codecs, and a few lossy codecs that exactly specify a decoder
[02:30:47 CET] <kepstin> well, all lossless codecs :)
[02:31:08 CET] <kepstin> (provided you don't do any colorspace or sample rate or whatnot conversions)
[02:34:46 CET] <zZap-X> kepstin: aye good
[02:34:58 CET] <zZap-X> libreelec uses ffmpeg with mpd
[02:35:00 CET] <zZap-X> so was just checking
[02:35:12 CET] <zZap-X> all my music files are flacs
[02:35:16 CET] <kepstin> keep in mind that the number of codecs that actually exactly define decoders is ... small
[02:35:49 CET] <kepstin> many popular codecs, e.g. mp3, don't.
[02:35:56 CET] <kepstin> iirc
[02:36:04 CET] <zZap-X> yep i expect that
[02:36:27 CET] <zZap-X> if ffmpeg can play a flac file 16-bit / 44100 then im happy
[02:36:38 CET] <c_14> (also, mad is audibly terrible don't use it)
[02:36:42 CET] <zZap-X> without any conversion
[02:39:11 CET] <kepstin> well, it's up to the app using ffmpeg to decide to do any conversions :)
[02:41:29 CET] <zZap-X> its mpd
[02:42:10 CET] <zZap-X> should be ok:
[02:42:11 CET] <zZap-X> https://www.musicpd.org/doc/user/advanced_usage.html
[02:43:00 CET] <zZap-X> so ffmpeg it is :D
[02:43:09 CET] <zZap-X> at least it does all the main audio formats
[02:43:22 CET] <zZap-X> does ffmpeg 3.1 support opus?
[02:43:47 CET] <furq> it's supported opus for ages
[02:43:48 CET] <c_14> ffmpeg supports opus since forever
[02:43:56 CET] <zZap-X> ace
[02:44:02 CET] <furq> it's supported decoding it without libopus for a while
[02:44:02 CET] <zZap-X> ffmpeg can also play internet streams
[02:44:07 CET] <zZap-X> so its a all in one solution
[02:44:11 CET] <furq> but it's supported both through libopus for years
[02:44:17 CET] <zZap-X> ace
[02:44:48 CET] <zZap-X> well that makes libre elec a awesome distro for kodi + mpd
[02:44:59 CET] <zZap-X> for audiophiles
[02:45:40 CET] <zZap-X> it only uses pulse audio for bluetooth playback, everything else is alsa
[03:34:25 CET] <damdai> if you have a video that is 1280x1080p ,  is this 1080p or 720p
[03:35:17 CET] <furq> well it's definitely not 720p is it
[03:35:51 CET] <damdai> is it 1080p then
[03:37:07 CET] <damdai> Video: WVC1 1440x1080 (16:9) 29.97fps [V: vc-1 advanced L3, yuv420p, 1440x1080]
[03:37:29 CET] <damdai> Video: WVC1 1280x1080 (16:9) 29.97fps [V: vc-1 advanced L3, yuv420p, 1280x1080]
[03:51:18 CET] <JonFreed> Why am I getting error "RTMP_Connect0, failed to connect socket. 10061 (Unknown error)" when I try the following command on Windows?  (The same command works on Linux without any problems.)  ffmpeg -listen 1 -timeout 60 -i rtmp:// -c copy -f flv rtmp://us-east.restream.io/live/mysecretstreamkey
[06:19:56 CET] <Kirito> How do I have ffmpeg extract every frame from a video that may have a variable framerate?
[06:20:38 CET] <Kirito> every example I see provides an explicit framerate when doing this, and that shouldn't be required. If I don't provide one will it work as intended?
[06:21:38 CET] <Kirito> actually that appears to be correct, I should have tested first
[06:50:23 CET] <rjp421> damdai, those are odd sizes, like some weird desktop resolutions
[15:49:07 CET] <darsain> any reason to not use ffmpeg for resizing images?
[15:51:23 CET] <darsain> is there a dimension limit on how big images it can process or something like that?
[15:51:52 CET] <BtbN> your RAM
[15:56:21 CET] <darsain> cool :)
[15:57:17 CET] <darsain> and how would you remove an alpha channel without introducing the usual png fragments?
[15:57:28 CET] <darsain> like in png -> jpg conversion
[15:59:02 CET] <BtbN> the usual png fragments? png is lossless.
[16:00:00 CET] <darsain> no I mean those colors, parts of the image that were hidden by alpha channel
[16:00:08 CET] <darsain> sec Ill provide an example
[16:00:50 CET] <darsain> here is before and after conversion to jpg: https://imgur.com/a/Imqsu
[16:25:49 CET] <durandal_170> darsain: don't use jpg
[16:30:48 CET] <darsain> durandal_170: the main concern here is size and compatibility, so it has to be jpg
[16:31:20 CET] <darsain> but I just can't figure out how to proparly convert png with alpha channel to jpg :/
[16:32:54 CET] <durandal_170> darsain: you can use one of filters
[16:33:52 CET] <darsain> durandal_170: been hunting in docs for the past 20 minutes. can't figure out which one does it
[16:35:45 CET] <durandal_170> darsain: for example with mergeplanes or zscale filter or you could disable alpha premultiply in swscale
[18:03:07 CET] <darsain> durandal_170: any pointers? documentation to none of those filters makes it obvious how to achieve what I'm after
[18:05:22 CET] <durandal_170> darsain: there's docs for mergeplanes filter
[18:07:03 CET] <darsain> durandal_170: yes, I've rad it. from what I understand it merges several streams into one. but I have only one stream
[18:07:39 CET] <darsain> so I ether have to create a separate video to merge into this, or mock a solid color stream with some param, or, .... no idea
[18:08:39 CET] <darsain> as I've said, docs don't make it obvious, and I'm not familiar with undocumented sideffects of each filter to leverage that
[18:11:26 CET] <durandal_170> darsain: by default you need to set pix fmt to which you want your file to have
[18:11:59 CET] <durandal_170> darsain: don't you need yuv420p in jpg?
[18:12:02 CET] <darsain> I was playing with pix_fmt param, but only got warning trying to go rgb24
[18:12:16 CET] <darsain> it reverted back to whatever it needed
[18:12:35 CET] <durandal_170> darsain: jpg in ffmpeg doesn't do rgb24
[18:13:26 CET] <furq> i didn't even know there was such a thing
[18:15:54 CET] <darsain> yuv420p produces exactly same warning as rgb24: wrong, fuck you, I'm using whatever I want (paraphrasing)
[18:18:23 CET] <furq> darsain: yuvj420p
[18:18:33 CET] <furq> or 422, or 444
[18:19:15 CET] <furq> apparently jpeg does support rgb but i've never seen that used and i can't imagine the compatibility is any good
[18:19:48 CET] <darsain> now It doesn;t say it is reverting, but I get deprecated pixel format
[18:20:13 CET] <darsain> it works, but I still get ugly output
[18:20:33 CET] <furq> i don't think you've actually changed anything from the default
[18:20:34 CET] <darsain> (as in the example in the imgur link I posted above)
[18:20:45 CET] <darsain> yeah me neither
[18:21:04 CET] <furq> if you used yuvj420p you might have made it worse
[18:21:22 CET] <furq> i think it'll use yuvj444p by default when converting from rgb
[18:21:35 CET] <darsain> damn it. I've already spent 1 whole day trying to write a scaling param so ffmpeg will downscale-only to fit a megapixels target. can't someone just give me a param that will add white background to transparent images? T.T
[18:21:54 CET] <darsain> why is this so hard
[18:27:37 CET] <furq> darsain: ffmpeg -f lavfi -i color=white:r=1:d=1:s=516x516 -i 2xlG1P1.png -filter_complex overlay dest.jpg
[18:27:56 CET] <furq> i can't imagine that's the best way to do it, but it works
[18:30:41 CET] <darsain> oh wondreful. now I get:
[18:30:45 CET] <darsain> Filtergraph 'scale=trunc(min(sqrt(1860000/(iw*ih))*iw\,iw)/ohsub)*ohsub:trunc(ow/a/ovsub)*ovsub' was specified through the -vf/-af/-filter option for output stream 0:0, which is fed from a complex filtergraph.
[18:30:45 CET] <darsain> -vf/-af/-filter and -filter_complex cannot be used together for the same stream.
[18:30:52 CET] <furq> oh.
[18:32:24 CET] <furq> -filter_complex "overlay,scale=trunc(min(sqrt(1860000/(iw*ih))*iw\,iw)/ohsub)*ohsub:trunc(ow/a/ovsub)*ovsub"
[18:32:42 CET] <furq> you need to know the dimensions of the input image for the colour source, though
[18:34:18 CET] <darsain> damn. than that's unusable. the whole point of this script is to be able to throw any iamge at it :)
[18:46:55 CET] <c_14> well, if you have a script you can parse the dimensions beforehand
[18:50:02 CET] <darsain> it's a batch script. doing fancy stuff like that would mean another couple hours of research :)
[18:53:58 CET] <c_14> eval `ffprobe -show_entries stream=height,width -select_streams v -of default=nw=1 -hide_banner -loglevel quiet blah`
[18:54:32 CET] <c_14> you'll now have $height and $width (probably)
[18:55:03 CET] <c_14> might want to set them to 0 before and then check that they're not 0
[18:58:20 CET] <darsain> my point was that parsing values out of the output in .bat scripts is a nightmare
[18:58:38 CET] <c_14> wait, batch
[18:58:40 CET] Action: c_14 read bash
[18:58:44 CET] <c_14> well
[19:00:01 CET] <darsain> yeah. I think I'd have to save the output to a tmp file, than parse it with some other tool, and probably some other black magic on top of that...
[19:00:49 CET] <c_14> Well, you could always use a decent language
[19:02:22 CET] <darsain> if I could. but I want a script file into which I can just drag and drop files and have it do something to them
[19:03:00 CET] <darsain> and any other solution would mean either compiling, or having a 2nd bat file that would invoke the script
[19:08:52 CET] <crstin_> Can this be optimized "ffmpeg -i IN.mp3 -af aresample=resampler=soxr -ar 11025 OUT.mp3" I want to have the audio recording as small as possible. ffprobe: Stream #0:0: Audio: mp3, 44100 Hz, mono, s16p, 129 kb/s
[19:09:41 CET] <c_14> darsain: can you not drag and drop onto python scripts?
[19:10:51 CET] <c_14> crstin_: well, you can lower the bitrate, use a codec that compresses better than mp3 and lower the bitrate
[19:15:41 CET] <crstin_> c_14: oh yeah, forgot to mention, it should play on iphones... so there's mp3 or aac, I think. I played around with bitrate: ffmpeg -i IN.mp3 -af aresample=resampler=soxr -ar 11025 -ab 9k OUT.mp3 But the outcome is a bit too extreme.
[19:16:27 CET] <c_14> you can probably take AAC HE down to 64k for a mono stream
[19:16:31 CET] <c_14> maybe lower
[19:16:34 CET] <c_14> depends on content
[19:16:42 CET] <c_14> do iphones do AAC HE?
[19:16:50 CET] <Mavrik> HE-AAC shouldn't be used over 64k anyway :)
[19:16:55 CET] <Mavrik> and yes they do
[19:17:21 CET] <c_14> then that's probably your best bet
[19:26:03 CET] <crstin_> Nice! "ffmpeg -i IN.mp3 -c:a libfdk_aac -profile:a aac_he -b:a 16k OUT.m4a" sound so much better than the command above and size is even smaller.
[19:29:11 CET] <crstin_> lol, 8k is even bearable
[19:41:46 CET] <furq> 16k is probably about right for 11khz mono
[19:42:15 CET] <furq> oh nvm you got rid of the resample
[19:42:49 CET] <furq> you could also try opus if your targer supports it
[19:42:52 CET] <furq> target
[19:51:20 CET] <crstin_> Unfortunately I'm having problems with the output, itunes doesn't take it even though it officially supports AAC HE. Is my command not good enough?
[19:53:27 CET] <crstin_> furq: I think you're right the output doesn't seem to be resampled, It's 44100 Hz
[20:01:52 CET] <crstin_> furq: just made a test with opus, it sound even better, is a little bit smaller, but doesn't work with itunes (barghhh)
[20:56:15 CET] <RiedFrice> Does anyone know how to compile ffmpeg in osx with libsnappy? (Hap Encoder)
[21:05:33 CET] <psyduck`> is xmedia recode better than ffmpeg?
[21:06:24 CET] <RiedFrice> psyduck`: Never heard of it. Checking it out now
[21:08:09 CET] <RiedFrice> psyduck`: Pretty sure i see all of the same codecs and formats in xmedia recode, that ffmpeg supports
[21:09:10 CET] <RiedFrice> psyduck`: Plus its GUI could be limited. IF you're comfortable with a command line/terminal then ffmpeg has a lot of possibilities and combinations of commands
[21:10:54 CET] <RiedFrice> psyduck`: If you're looking for a GUI, this is the best ffmpeg one ive found yet that has almost everything you would need
[21:10:57 CET] <RiedFrice> http://corz.org/windows/software/ffe/
[21:12:13 CET] <RiedFrice> huh well that link doesnt want to work. Just google FFe if you're interested :p
[21:13:28 CET] <RiedFrice> Also I just figured out how to compile with libsnappy, so nevermind hah
[21:13:56 CET] <RiedFrice> It was --with-snappy instead of --with-libsnappy
[00:00:00 CET] --- Sun Jan  1 2017

More information about the Ffmpeg-devel-irc mailing list