[Ffmpeg-devel-irc] ffmpeg.log.20170102

burek burek021 at gmail.com
Tue Jan 3 03:05:01 EET 2017

[02:41:16 CET] <Seylerius> Okay, I'm trying to render a series of 9000 frames into a video, at 50fps. Unfortunately, it's dropping all the frames after about 52s.
[02:43:47 CET] <Seylerius> The command I'm using is ffmpeg -r 50 -i /tmp/slimed/%04d.png -c:v libx264 -pix_fmt yuv420p -qp 0 out.mp4
[03:46:16 CET] <c_14> Seylerius: use -framerate instead of -r
[03:49:41 CET] <Seylerius> Okay.
[05:28:45 CET] <damdai> is there a difference between  .ts  and .m2ts  container?
[05:31:32 CET] <Seylerius> Okay, so, I've tried switching to -framerate, I've tried using video profiles, if anything some of these changes make it worse. I really just want to encode a sequence of images to a video, and the result keeps glitching at the same point.
[05:32:01 CET] <furq> damdai: yes
[05:32:13 CET] <furq> m2ts has an extra header per packet
[05:32:18 CET] <damdai> furq what is the difference, and what is better
[05:32:27 CET] <damdai> furq i see
[05:32:31 CET] <damdai> is that header makes it better
[05:32:41 CET] <furq> it makes it better for blu-ray
[05:32:44 CET] <furq> it's probably not better for you
[05:35:00 CET] <Seylerius> https://pastie.org/10987127
[05:36:22 CET] <Seylerius> c_14: Here's the paste output: https://pastie.org/10987127
[05:37:09 CET] <damdai> furq  can i ask you a favor
[05:37:52 CET] <c_14> Seylerius: looks like it's working
[05:38:10 CET] <c_14> 9000 frames at 50fps = just about 3 minutes
[05:38:44 CET] <Seylerius> c_14: The problem is that it gets a heavy video artifact at about 10 seconds in.
[05:39:04 CET] <Seylerius> c_14: I've examined the raw frames, and they look fine.
[05:39:19 CET] <Seylerius> There's another one towards the end.
[05:39:23 CET] <c_14> What does the artefact look like?
[05:39:28 CET] <c_14> screenshot or something maybe
[05:39:59 CET] <Seylerius> c_14: coming up.
[05:41:43 CET] <Seylerius> c_14: https://imgur.com/a/FYTuT
[05:42:55 CET] <c_14> my goodness, that's some pretty terrible artefacting
[05:42:58 CET] <damdai> i found a huge bug in  ffmpeg
[05:42:58 CET] <Seylerius> What causes that kind of glitch when all the source frames are fine?
[05:43:15 CET] <Seylerius> c_14: I know, right?
[05:44:05 CET] <c_14> Can you try a different encoder?
[05:44:21 CET] <c_14> anything builting and fast should do, ffv1, mpeg4 or whatever
[05:44:23 CET] <c_14> *builtin
[05:44:42 CET] <Seylerius> So -c:v mpeg4 ?
[05:44:45 CET] <c_14> yes
[05:45:03 CET] <c_14> damdai: open a bugreport?
[05:45:21 CET] <damdai> c_14  can you do me a favor
[05:45:36 CET] <Seylerius> Running.
[05:45:38 CET] <Seylerius> Thanks.
[05:45:41 CET] <furq> Seylerius: what player are you using
[05:46:24 CET] <Seylerius> furq: VLC and Dragon. Screencap in VLC.
[05:46:40 CET] <furq> it might be worth double checking in mpv
[05:47:24 CET] <furq> i don't think it'll be the decoder but mpv should conclusively rule it out
[05:47:48 CET] <Seylerius> furq: Testing.
[05:47:51 CET] <Seylerius> Installing now.
[05:52:59 CET] <Seylerius> Ach. Have to update a crap ton of other shit I don't have time for right now. Try that again in a minute.
[05:53:17 CET] <Seylerius> Or install it on a different computer and copy there.
[05:53:40 CET] <damdai> i know ffmpeg support .ts  but does ffmpeg support m2ts ?
[05:53:53 CET] <c_14> sure
[05:54:31 CET] <Seylerius> c_14: First glitch didn't happen, playing to end to see if there are any others.
[05:55:00 CET] <Seylerius> Halfway through and safe.
[05:55:28 CET] <c_14> so it's (probably) either the H.264 encoder or decoder
[05:55:42 CET] <Seylerius> Yeah.
[05:55:52 CET] <c_14> What distro are you on? (assuming your version of ffmpeg is built by your distro)
[05:55:55 CET] <Seylerius> ffmpeg
[05:56:01 CET] <Seylerius> This machine is behind on a few updates.
[05:56:31 CET] <c_14> you could try reencoding the file with libx264 using a static build to see which it is
[05:56:33 CET] <c_14> http://johnvansickle.com/ffmpeg/
[05:57:29 CET] <Seylerius> I'll try that in a minute.
[05:57:43 CET] <Seylerius> What's the best audio codec to go with mpeg4?
[05:57:46 CET] <damdai> i know ffmpeg support .ts  but does ffmpeg support m2ts ?
[05:57:55 CET] <furq> still yes
[05:58:01 CET] <c_14> Seylerius: whatever the thing that's supposed to be playing it supports
[05:58:04 CET] <damdai> furq is that answer to me?
[05:58:06 CET] <furq> Seylerius: if you're doing a lossless encode you probably want to use ffv1
[05:58:08 CET] <furq> damdai: yes
[05:58:14 CET] <Seylerius> For the audio?
[05:58:23 CET] <Seylerius> Also, What options can I reencode this with to get lossless?
[05:58:27 CET] <Seylerius> For the video?
[05:58:32 CET] <furq> -c:v ffv1
[05:58:40 CET] <furq> there is nothing you can do to get lossless mpeg4
[05:58:41 CET] <Seylerius> And when I add the audio to it?
[05:58:45 CET] <furq> flac i guess
[05:58:51 CET] <furq> or just pcm
[05:59:36 CET] <furq> or copy the source audio
[05:59:40 CET] <damdai> furq can you help me?
[05:59:50 CET] <Seylerius> furq: ffv1 doesn't like the png images.
[05:59:58 CET] <furq> what's the error
[06:00:36 CET] <damdai> furq  does  ffmpeg support .evo container
[06:00:51 CET] <furq> evo is just mpeg-ps so probably
[06:01:40 CET] <furq> whether it can write bd-compliant m2ts or hddvd-compliant evo i have no idea, but it should read them both
[06:01:55 CET] <Seylerius> furq: https://pastie.org/10987129
[06:02:47 CET] <Seylerius> What do I need to change to make those two play nice?
[06:03:18 CET] <c_14> You can't put ffv1 in mp4, use mkv
[06:03:22 CET] <Seylerius> Oh.
[06:03:24 CET] <Seylerius> Lol
[06:03:25 CET] <furq> ^
[06:03:25 CET] <c_14> Do you need mp4?
[06:03:44 CET] <Seylerius> Nope.
[06:03:55 CET] <furq> on a side note, do you need yuv420p
[06:04:02 CET] <furq> rgb to yuv420p is lossy
[06:04:02 CET] <Seylerius> Probably not.
[06:04:06 CET] <damdai> how come this doesn't work:   ffmpeg -i R:\test.mkv -vcodec copy -acodec copy R:\test.evo
[06:04:24 CET] <Seylerius> furq: Eventual destination is YouTube.
[06:04:27 CET] <furq> oh right
[06:04:32 CET] <furq> you might as well do the conversion yourself then
[06:04:47 CET] <Seylerius> Are they going to yuv420p it for me if I don't?
[06:04:49 CET] <furq> yes
[06:04:53 CET] <Seylerius> Lol
[06:04:58 CET] <furq> everything on youtube is yuv420p
[06:05:03 CET] <c_14> damdai: many possible reasons, what does the output say?
[06:05:15 CET] <damdai> [NULL @ 0000000000d67480] Unable to find a suitable output format for 'R:\test.evo'
[06:05:15 CET] <damdai> R:\test.evo: Invalid argument
[06:06:12 CET] <furq> try adding -f vob
[06:06:17 CET] <Seylerius> c_14, furq: Thanks! It's encoding currently.
[06:06:28 CET] <damdai> furq is that answer to me?
[06:06:31 CET] <furq> yes
[06:07:21 CET] <furq> like i said, i have no idea whether that will produce an hddvd-compliant file
[06:07:33 CET] <furq> if it doesn't then you probably need to use some dedicated hddvd authoring tool
[06:07:39 CET] <furq> if such a thing still exists these days
[06:08:22 CET] <damdai> furq   -f vob  creates a .evo file but no video
[06:08:28 CET] <damdai> only audio played
[06:08:42 CET] <damdai> what does -f vob exactly do
[06:09:10 CET] <furq> it sets the output format to vob
[06:09:16 CET] <furq> that's the only mpegps muxer in ffmpeg
[06:10:52 CET] <furq> that works fine for me fwiw
[06:10:58 CET] <damdai> so -f vob  is same thing as    ffmpeg -i R:\test.mkv -vcodec copy -acodec copy R:\test.vob ?
[06:11:16 CET] <furq> ffmpeg -f lavfi -i testsrc=d=30 -c:v libx264 -f vob test.evo
[06:11:18 CET] <furq> gives me a playable file
[06:11:37 CET] <furq> playable in mpv, at least
[06:15:46 CET] <damdai> furq can you do me a favor
[06:16:47 CET] <damdai> ??
[06:19:48 CET] <damdai> can somebody help me
[06:21:23 CET] <Seylerius> Now when I try to add the audio, it's giving me "Format mov,mp4,m4a,3gp,3g2,mj2 detected only with low score of 1, misdetection possible!""
[06:21:31 CET] <Seylerius> (Using the mpeg4)
[06:21:53 CET] <Seylerius> (The ffv1 didn't play back the motion in the video correctly.
[06:22:24 CET] <Seylerius> (Sat on the same frame the whole time, but if you jumped to a different timecode, it would display the correct frame)
[06:22:29 CET] <Seylerius> Any ideas, furq, c_14?
[06:25:13 CET] <Seylerius> Guys?
[06:25:37 CET] <c_14> Is that with the mp4 or the mkv?
[06:25:46 CET] <Seylerius> mp4
[06:25:53 CET] <c_14> you can add -f mp4 before -i
[06:25:59 CET] <c_14> not sure why the score would be that low though
[06:26:09 CET] <Seylerius> moov atom not found
[06:26:46 CET] <c_14> did you abort the encoding process?
[06:26:49 CET] <Seylerius> No
[06:26:55 CET] <Seylerius> Oh, I know what's wrong.
[06:27:08 CET] <Seylerius> I tried to reencode into the same spot with the ffv1
[06:27:09 CET] <Seylerius> Right.
[06:27:16 CET] <Seylerius> Need to reencode the mp4 then.
[06:27:22 CET] <Seylerius> Any options to squeeze higher quality out of it?
[06:27:29 CET] <Seylerius> Bitrate maybe?
[06:28:11 CET] <c_14> https://trac.ffmpeg.org/wiki/Encode/MPEG-4
[06:28:22 CET] <c_14> -qscale:v lower is better
[06:35:47 CET] <Seylerius> c_14: Thanks!
[13:53:37 CET] <rindolf> Hi all! How can I tell ffplay to play using vaapi? I'm trying to test something
[13:55:04 CET] <BtbN> ffplay does not support vaapi video output.
[13:56:36 CET] <rindolf> BtbN: ah
[13:57:19 CET] <rindolf> BtbN: I'm running into a very similar bug in both mpv --vo=vaapi and vlc
[13:57:31 CET] <BtbN> Not even sure if you can make it decode using vaapi, might be only ffmpeg.c that can do that.
[14:01:33 CET] <rindolf> BtbN: can I try usign the "ffmpeg" cmdline program?
[14:02:19 CET] <BtbN> try what?
[14:03:23 CET] <rindolf> BtbN: can I try usign the "ffmpeg" cmdline program to play an .flv using vaapi?
[14:04:18 CET] <BtbN> sure, but ffmpeg.c is not a video player, but a headless commandline tool.
[14:05:36 CET] <jkqxz> You can transcode it to something else, then play that file.  That would show if the VAAPI decode is causing your problem.
[14:06:02 CET] <rindolf> jkqxz: ok
[14:06:11 CET] <rindolf> jkqxz: how?
[14:09:16 CET] <jkqxz> "ffmpeg -hwaccel vaapi -i blah.flv -c:v libx264 -crf 12 out.mp4"?
[14:10:12 CET] <jkqxz> It might help if you could offer more information about what is going wrong for you.
[14:11:57 CET] <rindolf> jkqxz: <rindolf> Hi all! I see many artefacts on the screen when playing http://www.shlomifish.org/Files/files/video/The%20all%20american%20rejects%20new%20song%20w-Lyrics%20-%20Gives%20you%20hell-hamHPC7BuIc.flv using mpv --vo=vaapi (or VLC).
[14:14:21 CET] <fritsch> not a single artifact using mpv
[14:14:36 CET] <fritsch> do you by chance have some shitty fglrx? that tries to use vaapi?
[14:15:22 CET] <fritsch> for listening for this song for 60 seconds costs 2 dollars, though ...
[14:16:39 CET] <jkqxz> Yeah, works for me with i965.  I can try mesa as well if that's possibly different?
[14:16:59 CET] <fritsch> let's first ask for the basics :-)
[14:17:04 CET] <fritsch> rindolf: vainfo | pastebinit
[14:17:15 CET] <fritsch> having seen too many shitty wrappers over my life
[14:17:18 CET] <fritsch> so want to be sure
[14:21:29 CET] <rindolf> fritsch: see http://paste.debian.net/906016/
[14:31:25 CET] <jkqxz> Hmm, that looks sensible.  Does it work in mpv with vo=opengl rather than vo=vaapi?  (I assume you have hwdec=vaapi anyway.)
[14:31:26 CET] <Kadigan> Hello. I would like to know if there's a way to have ffmpeg to roughly, without complete encoding, calculate a minimum bitrate for a video file, when given the intended size?
[14:32:30 CET] <jkqxz> Like bitrate = size / length?
[14:32:33 CET] <Kadigan> Alternatively, given a filesize constraint, would it be able to tell me what viewing size I could use w/o it looking like crap? I know this is subjective, but maybe someone thought of this and there's a guide?
[14:33:39 CET] <Kadigan> jkqxz: something like that... I don't know enough about how encoding actually works to know if determining minimum number of bits per frame (only) is any faster than actually encoding.
[14:34:28 CET] <Kadigan> Now that I think about it more, it may not be... But still, I was considering it, hence my question.
[14:35:15 CET] <Kadigan> What I actually need: a client has applied seemingly impossible constraints (10min of video in 50MB filesize), and I'm trying to figure out if there's a way I could fulfill that request...
[14:39:22 CET] <rindolf> jkqxz: yes, it is working fine with --vo=opengl and other --vo s i tried
[14:40:30 CET] <jkqxz> Kadigan:  Two-pass encoding is what you need to get the best result you can for a specific file size.  Yes, you do have to go through the whole input twice.
[14:41:24 CET] <jkqxz> rindolf:  So it's something wrong with the vaapi output, and the decode isn't actually relevant?
[14:42:07 CET] <rindolf> jkqxz: don't know
[14:42:08 CET] <Kadigan> jkqxz: not quite what I was going for. I need a fairly quick way of determining what is the optimal size (according to ffmpeg) for a given filesize and maybe minimal q setting.
[14:42:38 CET] <Kadigan> Or, rather, whether if I decide on a minimal q, minimal X Y size, max filesize, can ffmpeg meet that.
[14:43:27 CET] <Kadigan> Right now, client requested 50MB of size or less. I don't know if ffmpeg can somehow meet that for, say, 800x450, or if I should just flat-out refuse to even try.
[14:45:19 CET] <jkqxz> Well, try making a 50MB file with that resolution and see what it looks like.  There is no support in ffmpeg for automatically selecting lower resolutions, you have to do that explicitly.
[14:47:35 CET] <Kadigan> Okay, I'll try to get it as plain as I can: I would like to know if there's any combination of input commands I can give, so that ffmpeg would tell me "for a given Width:Height at qscale X, the minimum filesize would be XXXXX MB"
[14:48:06 CET] <Kadigan> Or, alternatively, "For a given maximum filesize XXXXX MB and qscale X, the maximum resolution (considering AR) would be W:H"
[14:48:36 CET] <jkqxz> For the first, only by actually making the file.  (It has to do everything because there is no way to predict how complex any bit it doesn't do would be.)
[14:48:50 CET] <jkqxz> For the second, no.
[14:49:23 CET] <Kadigan> Okay, that's what I wanted to know. I kind of expected it to be this way, because essentially the answer to my question IS the encoded file, but...
[14:49:30 CET] <Kadigan> ... one can dream. :)
[14:54:26 CET] <Kadigan> Can I ask ffmpeg to tell me more when it gets an "Error while opening encoder for output stream"?
[14:54:49 CET] <Kadigan> I get that the parameters are probably what's incorrect (I'm messing with them right now), but maybe a bit more about which parameter it is?
[14:55:38 CET] <jkqxz> There's generally an error further back in the log.
[14:56:09 CET] <Kadigan> Ah, I can see it. You're right.
[14:56:39 CET] <Kadigan> Funny. So ffmpeg can calculate a width with scale=-1:X
[14:56:49 CET] <Kadigan> but this width can be non-divisible by 2.
[14:58:22 CET] <jkqxz> Put -2 instead of -1.
[15:01:16 CET] <Kadigan> Thanks, that helped. I can see that's explained in the filters documentation, but sadly it's not on the page that comes up first when googling for "ffmpeg scale"
[15:01:31 CET] <Kadigan> which is "Scaling (resizing) with ffmpeg" (Wiki)
[15:03:13 CET] <jkqxz> It's a wiki, feel free to add it.
[15:40:43 CET] <fritsch> rindolf: kernel < 3.18?
[15:40:54 CET] <fritsch> mmh, looks quite new the vaapi stuff
[15:41:43 CET] <rindolf> fritsch: no - 4.9.0
[15:41:56 CET] <fritsch> what happens with kodi?
[15:41:57 CET] <fritsch> :-)
[15:42:37 CET] <rindolf> fritsch: I didn't try
[15:43:12 CET] <fritsch> btw. now that I know that you run debian. Is this their fucked up mpv or something sane?
[15:44:19 CET] <rindolf> fritsch: it's mageia - not Debian
[15:44:32 CET] <fritsch> ah okay, was confused then from the pastebin
[15:44:36 CET] <fritsch> and wondered that new vaapi
[15:44:40 CET] <fritsch> :-) that clears things up
[15:44:49 CET] <fritsch> do you know how they built mpv?
[15:47:01 CET] <rindolf> fritsch: who?
[15:47:22 CET] <rindolf> fritsch: kodi plays that flv fine - no artefacts
[15:58:41 CET] <tjf> hello, folks.  I see there's a 'use_localtime_mkdir' option for the hls muxer, but nothing like it for the segment muxer --
[15:59:14 CET] <tjf> I'm going to attempt a patch to add it, but I'm curious if (assuming it works and all that) it would be something the team would possibly merge?
[15:59:43 CET] <tjf> or, if there's already a way to accomplish something similar
[18:20:04 CET] <DrManhattan> I've been reading the manuals like crazy and I was hoping to get some opinions of the users here, if I'm using ffmpeg for compression of my Dr Who blu-rays to h265, what effect would using the grain tune be vs using no tune?
[18:21:07 CET] <DrManhattan> Do you need to be actually compressing from a grainy source to see the benefits of using the grain tune, or does it help with live-action video quality even if ones source isn't grainy?
[18:21:47 CET] <c_14> http://x265.readthedocs.io/en/default/presets.html
[18:21:51 CET] <c_14> search for grain
[18:22:02 CET] <c_14> rather "Film Grain"
[18:28:27 CET] <furq> http://x265.readthedocs.io/en/default/presets.html#film-grain
[18:28:28 CET] <furq> hth
[18:28:58 CET] <c_14> Oh, it was linkable. oops
[18:36:02 CET] <DrManhattan> Yes, I've read that, what I was hoping to get was feedback on real-world experiences of using the grain tune on non-grainy video
[18:36:36 CET] <furq> at least with x264 it'll spike the bitrate for no real discernible quality gain
[18:36:55 CET] <DrManhattan> if I am encoding a video like my Dr Who blurays, will it help preserve detail or is it just completely unnecessary?
[18:37:08 CET] <DrManhattan> Ok, thanks!
[18:37:08 CET] <furq> but i notice x265 doesn't have a film tune so it's probably worth testing
[18:37:29 CET] <furq> either way it won't preserve detail that won't be preserved by using a lower crf
[18:39:28 CET] <DrManhattan> my 264 videos have been turning up with a lot of compression artifacts lately - I thought perhaps I had a computer issue but I handbraked it on 3 diff computers and had the same results, using the same settings I used a few months ago to compress the same disks
[18:39:57 CET] Action: DrManhattan shrugs
[18:40:25 CET] <DrManhattan> so I'm moving on up to 265, which appears to make Dr Who look spectacular without the artifacting
[19:01:42 CET] <fahadash> I tried to trim portions of a video and string them together, the output should be about 25 seconds long, but all I get is a 2.87 seconds output with a pause starting at 1.00 seconds continuing till the end, here is my output http://pastebin.com/raw/k57WFAb8
[19:02:24 CET] <fahadash> Here is my script: http://pastebin.com/cYQN7GyN
[19:02:28 CET] <fahadash> What am I missing?
[19:04:39 CET] <fahadash> dang it, I found the problem
[19:04:40 CET] <fahadash> nevermind
[20:43:14 CET] <Agiofws> hello
[20:43:39 CET] <Agiofws> i'm trying to join some video files in a directory all the same codecs and resolution
[20:43:52 CET] <Agiofws> i'm getting this output
[20:43:54 CET] <Agiofws> http://pasteall.org/176119
[20:44:21 CET] <Agiofws> and the command i'm issuing is ffmpeg -f concat  -safe 0 -i mylist.txt  -ss 00:00:01 -t 00:00:06 -c output.avi
[20:44:28 CET] <Agiofws> can nayone help me out please?
[20:44:34 CET] <Agiofws> can anyone help me out please?
[20:45:29 CET] <doogaille> try : ffmpeg -f concat  -safe 0 -i mylist.txt  -ss 00:00:01 -t 00:00:06 -y output.avi
[20:47:17 CET] <doogaille> try : ffmpeg -f concat  -safe 0 -i mylist.txt  -ss 00:00:01 -t 00:00:06 -c copy -y output.avi
[20:49:36 CET] <Agiofws> ok for some reason its just giving me 5 seconds of video any idea?
[20:49:39 CET] <Agiofws> doogaille, ?
[20:49:44 CET] <doogaille> sure
[20:49:50 CET] <doogaille> remove -ss and -t
[20:50:01 CET] <doogaille> try : ffmpeg -f concat  -safe 0 -i mylist.txt -c copy -y output.avi
[20:50:08 CET] <Agiofws> mylist has about 300 paths to files in it
[20:50:33 CET] <Agiofws> doogaille,  is there a way to get like 5 secs from each video?
[20:51:52 CET] <furq> https://www.ffmpeg.org/ffmpeg-formats.html#concat-1
[20:52:00 CET] <furq> add inpoint/duration to every entry in mylist.txt
[20:52:11 CET] <furq> or inpoint/outpoint
[20:52:20 CET] <doogaille> like this one :
[20:52:21 CET] <doogaille> 1.webm 00:00:00
[20:52:21 CET] <doogaille> 2.webm 00:00:10
[20:52:22 CET] <doogaille> 3.webm 00:00:20
[20:52:40 CET] <furq> like in the examples
[20:54:06 CET] <Agiofws> doogaille,  file '/media/agiofws/WINDOWS7/vids4baby/mp4s/VID_20160820_103009539.mp4'
[20:54:32 CET] <Agiofws> how would i add an in and out point in that line for example?
[20:54:42 CET] <furq> https://www.ffmpeg.org/ffmpeg-formats.html#Examples
[20:54:44 CET] <furq> like that
[20:55:06 CET] <doogaille> like say furq follow examples section 3.5.3
[20:55:17 CET] <Agiofws> file file-1.wav
[20:55:17 CET] <Agiofws> duration 20.0
[20:55:25 CET] <Agiofws> is that 20 secs?
[20:55:40 CET] <doogaille> yep
[20:55:44 CET] <Agiofws> so after each file line i would add the duration ?
[20:55:49 CET] <Agiofws> in a new line?
[20:57:28 CET] <doogaille> never try, but i guess so
[21:00:36 CET] <Agiofws> [avi @ 0x1c4b660] Non-monotonous DTS in output stream 0:0; previous: 92099, current: 21226; changing to 92100. This may result in incorrect timestamps in the output file.
[21:10:11 CET] <Agiofws> [concat @ 0xa1b7a0] Line 2: unknown keyword 'inpoint'
[21:10:12 CET] <Agiofws> mylist.txt: Invalid data found when processing input
[21:10:12 CET] <Agiofws> ?
[21:11:20 CET] <Agiofws> what wrong with my ffmpeg ?
[21:16:58 CET] <doogaille> I dont know, but without more information about exact contact of mylist.txt, a sample of ffprobe of your files, your ffmpeg command line and ffmpeg -v output it's difficult to help you
[21:17:16 CET] <doogaille> brb
[21:18:53 CET] <Agiofws>  libpostproc    53.  3.100 / 53.  3.100
[21:18:53 CET] <Agiofws> mylist.txt: could not seek to position 1.000
[21:18:53 CET] <Agiofws> Input #0, concat, from 'mylist.txt'
[21:20:23 CET] <Agiofws> doogaille,  http://pasteall.org/176158
[21:20:48 CET] <stringtheory> I'm trying to add a third party utility written in python to ffmpeg, what are the steps I need to do?
[21:21:25 CET] <Agiofws> doogaille,  http://pasteall.org/176161
[21:22:21 CET] <Agiofws> doogaille, http://pasteall.org/176164
[21:23:16 CET] <Agiofws> http://pasteall.org/176167
[21:24:38 CET] <furq> Agiofws: 2.6.9 is pretty old
[21:25:47 CET] <fahadash> Can I do ffplay -i /path/to/video -af "filters" ?
[21:25:56 CET] <fahadash> I want to test out some trim filters
[21:32:43 CET] <Agiofws> http://i.imgur.com/gsw60li.png
[22:18:55 CET] <DrManhattan> is the --tune grain for x265 beneficial if your video isn't grainy?
[22:19:23 CET] Action: DrManhattan has to wait for the kids to go to bed to bust out Ripbot264 anymore todaay
[22:21:17 CET] <phillipk> something is not working in my concat command:
[22:21:42 CET] <phillipk> ffmpeg -i 'concat:file1.mp4|file2.mp4' -c copy 'combined.mp4'
[22:21:50 CET] <phillipk> seems to only grab file1.mp4
[22:23:50 CET] <whitekidney> phillipk: can you try with " instead of ' ?
[22:23:55 CET] <whitekidney> I think I had the same problem previously
[22:24:17 CET] <whitekidney> remember they have to be the *exact* same codec with params etc
[22:25:13 CET] <phillipk> same codec for sure...tried with " vs ' ...
[22:27:35 CET] <furq> you can't use the concat protocol with mp4
[22:27:38 CET] <furq> use the demuxer
[22:27:46 CET] <furq> https://trac.ffmpeg.org/wiki/Concatenate#demuxer
[22:39:35 CET] <phillipk> furq, you're saying I can't use      -i  "concat:file1|file2|file3"  ??   and instead use              -f concat -i textFileWithListOfFiles.txt   ?
[22:44:37 CET] <furq> yes
[22:48:21 CET] <whitekidney> just ffmpeg things
[22:49:03 CET] <phillipk> yeah, the -i somefile approach works when I do it straight in the command line--but I'm using node with this library which seems to be the issue...
[22:49:12 CET] <phillipk> https://github.com/fluent-ffmpeg/node-fluent-ffmpeg/issues/376
[22:49:37 CET] <phillipk> I can create true mpg files I suppose and see if that works
[22:51:11 CET] <phillipk> or ".ts" files...
[23:28:04 CET] <phillipk> in order to make the concat work, I figured I could just generate "mpg and mpeg streams" instead of the mp4s I was using.
[23:29:13 CET] <phillipk> but when i'm writing the files--I WAS using -movflags -profile:v main and level 3.1.... what should I use for a -f (format) to make true mpg/mpeg stream?
[23:29:30 CET] <phillipk> I tried -f mpegts and the image was not visible in the final concat (which was mp4)
[23:41:41 CET] <mosb3rg> -f flv
[23:41:48 CET] <mosb3rg> should work fine for .mp4
[23:47:06 CET] <furq> mpegts should work fine
[00:00:00 CET] --- Tue Jan  3 2017

More information about the Ffmpeg-devel-irc mailing list