[Ffmpeg-devel-irc] ffmpeg.log.20170103

burek burek021 at gmail.com
Wed Jan 4 03:05:02 EET 2017

[00:09:34 CET] <phillipk> maybe I'm not making the .ts files correctly.  can I make them or do they necessarily have to start as .mp4s?
[00:10:18 CET] <phillipk> I'm creating all the segments which I'm trying to concat--so I figured instead of creating mp4s and then converting to .ts, I could just create .ts to begin with (when I'm creating the segments getting concat'd at the end)
[01:21:15 CET] <Hfuy> Hello. I have what's supposed tog be a quicktime file of 9GB which contains 4K ProRes. It appears to have been truncated and is unreadable to common tools, including ffmpeg. Can anyone recommend a tool that might be able to analyse it and construct a new end for it, so what we have is playable?
[01:25:15 CET] <furq> Hfuy: https://github.com/ponchio/untrunc
[01:25:34 CET] <furq> there are other tools but they all need another file from the same source
[01:25:47 CET] <Hfuy> I have lots of good files made by the same hardware recorder.
[01:25:58 CET] <Hfuy> I'm on windows.
[01:26:02 CET] <furq> well yeah just google "mp4 repair index" or something
[01:26:07 CET] <furq> i've never needed to do it
[01:26:23 CET] <Hfuy> I'm not sure if these are strictly mp4. They're filetype MOV
[01:26:33 CET] <furq> they're close enough for this purpose
[01:26:52 CET] <Hfuy> I'm aware of roughly what it needs to do, it needs to rebuild a MooV atom and work out all the frame offsets.
[01:26:57 CET] <Hfuy> But I'd really rather not have to write that.
[01:27:03 CET] Action: Hfuy looks a bit glum
[01:27:25 CET] <furq> there are loads of tools which will do it but most of them are paid
[01:27:39 CET] <Hfuy> I don't mind paying a reasonable fee.
[01:27:46 CET] <Hfuy> I mean, that's days of coding.
[01:28:30 CET] <furq> aha
[01:28:32 CET] <furq> http://slydiman.me/eng/mmedia/recover_mp4.htm
[01:28:39 CET] <furq> i remember recommending that one before
[01:29:30 CET] <Hfuy> I'll give it a try.
[01:30:16 CET] <Hfuy> Right now I'm making a backup copy of the duff file, in case some dodgy tool decides to try an inplace repair and humps the bunk.
[01:30:44 CET] <furq> that's probably a good idea
[01:32:13 CET] <Hfuy> Hmm, I fear this recover_mp4 thing may not like non-AVC content, but I'll give it a go
[01:35:11 CET] <furq> oh right, prores
[01:35:18 CET] <furq> yeah that probably makes things a lot harder
[01:36:16 CET] <Hfuy> Hm. No. "This program does not support video format 'apch'."
[01:38:57 CET] <furq> https://github.com/ponchio/untrunc/pull/20/files
[01:39:07 CET] <furq> looks like untrunc supports it if you can get it to build
[01:39:17 CET] <Hfuy> Well. Windows.
[01:39:43 CET] <Hfuy> Also this is apch, which is a slightly different flavor of ProRes.
[01:40:47 CET] <Hfuy> Web searches suggest that building untrunc for windows is a nightmare's nightmare.
[01:47:07 CET] <Hfuy> Hah. It's certainly fixable. These guys want $49 a file.
[01:47:11 CET] <Hfuy> I'm not sure whether to object to that :)
[04:01:45 CET] <fahadash> I added a background music to my video through a separate mp3 file using -map, the mp3 is longer than the video so I used -shortest... How do I make it so the mp3 fades out at the end?
[04:04:01 CET] <furq> https://ffmpeg.org/ffmpeg-filters.html#afade-1
[04:26:30 CET] <fahadash> furq: Thanks
[05:19:53 CET] <JeffATL> i want to do some piping from file through mpeg to mpv just to check some crop and pad settings but i can't just use -c:v copy or the filtering won't work. what are the faster encoders so that ffmpeg can keep up with the frramerate?
[05:27:35 CET] <furq> if you're piping then just use rawvideo
[05:27:51 CET] <furq> just `-f nut -` should do the job
[05:29:23 CET] <JeffATL> furq: thanks - rawvideo works perfectly
[05:33:31 CET] <Ammler1> can anybody convert this video to  .ts or .m2ts?  http://www.filedropper.com/handbrakeproblemvideo
[05:33:33 CET] <Ammler1> using ffmpeg
[05:37:13 CET] <Ammler1> furq what about you?
[07:34:41 CET] <bms20> I have a question r/e avcodec_receive_frame and libva decoding regarding ownership of the underlying surfaces; can anyone help?
[08:47:47 CET] <DHE> bms20: just ask the question and patiently wait for an answer
[08:48:01 CET] <bms20> I think I worked it out in the meantime!
[08:48:08 CET] <DHE> and I do mean patiently since it's between midnight and 7am in places most likely to answer
[08:48:24 CET] <JeffATL> i have a 10-year-old Athlon 64 X2 4200+ 2.2GHz doing my ffmpeg work. the CFLAGS i used for ffmpeg build were "-O2 -pipe -march=k8-sse3 --param l1-cache-line-size=64 --param l1-cache-size=64 --param l2-cache-size=512". 3-5fps the best i can expect for libvpx encoding?
[08:49:22 CET] <DHE> JeffATL: libvpx is, unfortunately, pretty slow yes. and on an old basic dual-core CPU that somehow seems about right
[08:49:38 CET] <DHE> not that libvpx threading is very good
[08:50:06 CET] <JeffATL> DHE: it seems to want to bang on only one core at a time
[09:41:57 CET] <moniliformis> hello
[09:42:27 CET] <moniliformis> any cygwin user?
[09:43:17 CET] <moniliformis> good morning
[12:15:26 CET] <maheart> Hi all. Can ffmpeg provide a file extension for an output file (or a list of possible options), based on what it knows about the input audio codec? e.g. say I have an .mp4 video, which has a h264 vid, and mp3 audio. Can ffmpeg somehow intelligently recommend/suggest .mp3 as the extension when isolating the audio track?
[12:16:17 CET] <maheart> My approach may be totally wrong, but I'm a newbie when it comes to this
[12:16:26 CET] <maheart> (Feel free to suggest better solutions)
[12:19:18 CET] <maheart> Found a solution: http://askubuntu.com/a/221069
[14:11:56 CET] <nielsm> I'm trying to stream from a (rather bad) D-link IP camera to youtube, I have it basically working, but have two issues
[14:12:42 CET] <nielsm> first issue is that the output framerate is unstable, and often drops too low. I have tried specifying "-r 30" on the commandline, as far as I understand that should convert the input to 30 fps, right?
[14:13:04 CET] <nielsm> (no quotes around the arguments on the actual commandline)
[14:13:19 CET] <kerio> will that really help?
[14:13:32 CET] <kerio> it depends on where you put it
[14:14:03 CET] <kerio> if you put it after the input, it'll duplicate/drop frames as needed i think
[14:14:23 CET] <nielsm> and the second issue is that the mjpeg over http input from the camera causes me to get an endless stream of warnings about SAR being 0/0
[14:14:58 CET] <nielsm> I can suppress that with "-v error" but then I don't get any other status messages either, except what's printed by -stats
[14:15:48 CET] <nielsm> my current commandline:
[14:15:49 CET] <nielsm> ffmpeg -hide_banner -v error -stats -f lavfi -i anullsrc -f mjpeg -framerate 30 -i http://user:pass@ -c:v libx264 -b:v 1000k -minrate 800k -maxrate 2000k -bufsize 1000k -x264opts keyint=30:min-keyint=10 -s 640x480 -r 30  -strict experimental -c:a aac -f flv rtmp://x.rtmp.youtube.com/live2/my-stream-key
[14:16:51 CET] <kerio> why do you have that anull?
[14:17:06 CET] <nielsm> youtube seems to not pick up my stream if I don't have audio in it
[14:17:18 CET] <ChocolateArmpits> Yeah that's one of the requirements
[14:18:20 CET] <ChocolateArmpits> If you're using any newer version you don't need -strict experimental to use aac
[14:19:47 CET] <kerio> nielsm: does mjpeg not specify a framerate?
[14:20:21 CET] <nielsm> ChocolateArmpits: apparently my version is old enough to require it
[14:20:52 CET] <nielsm> kerio: not per se, it's really just a sequence of jpeg images delivered as they are ready
[14:21:47 CET] <nielsm> at least in the over-http implementation of mjpeg
[14:22:13 CET] <nielsm> (I believe it uses the MIME multipart "replaces" method)
[14:22:35 CET] <kerio> are you actually getting 30fps?
[14:22:44 CET] <nielsm> I don't know for sure...
[14:23:32 CET] <nielsm> the camera also has h264 output, but it suffers the same framerate issues, even despite the camera being configured to deliver 30 fps
[14:23:45 CET] <nielsm> the h264 output is also worse quality than the mjpeg
[14:23:47 CET] <ChocolateArmpits> nielsm, are you on Windows ?
[14:23:49 CET] <nielsm> yes
[14:24:02 CET] <kerio> nielsm: sounds lovely
[14:24:23 CET] <ChocolateArmpits> you should try using -rtmp_buffer_size 64k to set rtmp buffer, if there's a lot of latency between your location and youtube it won't receive the stream at enough pace with default windows socket size
[14:24:24 CET] <kerio> what happens if you drop the -framerate 30 at the beginning?
[14:25:35 CET] <nielsm> ChocolateArmpits: trying that, it doesn't seem to have an effect
[14:25:44 CET] <ChocolateArmpits> Ok we can try further
[14:25:58 CET] <ChocolateArmpits> Use -vsync 1 to force specified framerate by the -r option
[14:26:23 CET] <nielsm> kerio: it's one of the last things I added while experimenting myself, it doesn't seem to really do anything with or without either
[14:27:13 CET] <nielsm> -vsync 1 has brought it slightly up, from 15 to 20
[14:27:19 CET] <nielsm> but it seems to be dropping again :(
[14:27:58 CET] <ChocolateArmpits> nielsm, Is the input received correctly if you're not streaming ?
[14:28:22 CET] <ChocolateArmpits> Could you run something like ffmpeg -f mjpeg -framerate 30 -i http://user:pass@ -vcodec copy -f null
[14:28:27 CET] <ChocolateArmpits> and check if the framerate is what you expect
[14:28:35 CET] <ChocolateArmpits> ffmpeg -f mjpeg -framerate 30 -i http://user:pass@ -vcodec copy -f null -
[14:28:41 CET] <ChocolateArmpits> yeah that needs a pipe at the end
[14:30:13 CET] <nielsm> yeah that reports 16 fps
[14:30:40 CET] <ChocolateArmpits> IS the framerate option needed though ?
[14:30:55 CET] <ChocolateArmpits> Usually it's used for uncompressed and unflagged sources
[14:30:56 CET] <nielsm> no it works the same without
[14:31:12 CET] <kerio> drop the one before the input then
[14:31:19 CET] <kerio> add -r 30 after it
[14:31:26 CET] <kerio> iirc that will duplicate frames to achieve 30
[14:31:32 CET] <nielsm> I'd consider the mjpeg-over-http source as true variable framerate
[14:32:08 CET] <nielsm> -r 30 after the input url still gives me 16 fps on the output
[14:32:12 CET] <ChocolateArmpits> kerio, I don't think that'll duplicate, it sets the rate, you want -vsync 1 with that on top or use a filter -vf fps=30 ; latter actually duplicates and drops frames
[14:32:29 CET] <kerio> oh hm
[14:32:53 CET] <ChocolateArmpits> Is this framerate thing only about to achieve youtube's requirements ?
[14:33:15 CET] <kerio> just stream it without framerate changes tbh
[14:33:50 CET] <nielsm> youtube's output will tend to "bunch up", showing a frozen frame for a while, then play the bunched up frames at fast-forward
[14:33:52 CET] <nielsm> as far as I can tell
[14:34:00 CET] <kerio> that could be because of your -r 30
[14:34:11 CET] <ChocolateArmpits> nielsm, did you preview the stream let's say via ffplay ?
[14:35:03 CET] <nielsm> I can open the mjpeg.cgi url directly in my browser and it just shows the moving image
[14:36:47 CET] <ChocolateArmpits> nielsm, What about ffplay -f mjpeg http://user:pass@ ?
[14:37:20 CET] <kerio> ChocolateArmpits: doesn't even need the -f mjpeg i bet
[14:37:30 CET] <ChocolateArmpits> Well that can't hurt
[14:38:01 CET] <nielsm> actually it does
[14:38:16 CET] <nielsm> [ingenient @ 02664900] Could not find codec parameters for stream 0 (Video: mjpeg, none(bt470bg/unknown/unknown)): unspecified size
[14:38:47 CET] <ChocolateArmpits> That's unrelated , it needs format settings
[14:38:53 CET] <nielsm> and when running ffplay -f mjpeg http://... I get spammed with:
[14:38:54 CET] <nielsm> [mjpeg @ 0084eae0] ignoring invalid SAR: 0/0
[14:39:06 CET] <ChocolateArmpits> so wait does it work without specifying the format ?
[14:39:30 CET] <nielsm> no it aborts when I don't specify -f mjpeg
[14:39:50 CET] <ChocolateArmpits> unrecognized format or something ?
[14:40:08 CET] <nielsm> "could not find codec parameters"
[14:40:17 CET] <kerio> nielsm: can you actually test a recent version of ffmpeg?
[14:40:18 CET] <ChocolateArmpits> ok so the format must be specified
[14:40:30 CET] <kerio> it seems so weird that it identifies it as mjpeg but then fails
[14:40:55 CET] <ChocolateArmpits> kerio, the format info isn't present with the stream so ffmpeg doesn't recognize how to read it
[14:41:07 CET] <kerio> ChocolateArmpits: but it says "Video: mjpeg"
[14:41:08 CET] <kerio> :|
[14:41:16 CET] <ChocolateArmpits> then that's clearly not enough
[14:41:25 CET] <kerio> why is "-f mjpeg" enough then
[14:41:50 CET] <ChocolateArmpits> kerio, well reading before it's not, unless there's something funny with ffplay
[14:42:06 CET] <nielsm> ffmpeg also aborts without -f mjpeg
[14:43:02 CET] <ChocolateArmpits> nielsm, do you have the resolution, framerate and pixel format of the camera ?
[14:44:14 CET] <ChocolateArmpits> specify as input options:  ffplay -video_size 640x480 -pixel_format yuv420p -framerate 16  -f mjpeg http://user:pass@
[14:44:30 CET] <ChocolateArmpits> framerate might be different
[14:44:36 CET] <nielsm> grabbed a new version of ffmpeg, now dated 20161230
[14:44:38 CET] <ChocolateArmpits> and the pixel format may be rgb
[14:44:44 CET] <ChocolateArmpits> rgb24
[14:47:31 CET] <kerio> ChocolateArmpits: they said it's working just with -f mjpeg
[14:51:29 CET] <kerio> your server is going down, connect to the main rotation!
[14:51:31 CET] <kerio> that will definitely work!
[14:51:52 CET] <kerio> what did i miss
[14:52:06 CET] <nielsm> okay the newer ffmpeg version no longer spams me about bad SAR values at least, so I don't have to silence all the info messages etc
[14:52:11 CET] <kerio> yay
[14:52:12 CET] <nielsm> you missed nothing :)
[14:52:36 CET] <nielsm> the new version has also added another thing on the status line
[14:52:40 CET] <nielsm> speed=0.621x
[14:53:23 CET] <nielsm> speed realtive to what? the process is using about 40% of a single core on my machine
[14:53:39 CET] <JEEB> random timestamps vs some other time thing
[14:53:44 CET] <JEEB> ffmpeg.c and timestamps is a funky thing
[14:53:55 CET] <JEEB> (don't try to look at the vsync mode stuff, ever)
[14:53:59 CET] <nielsm> right, so useless
[14:54:02 CET] Action: JEEB did, and needed brain bleach afterwards
[14:54:03 CET] <kerio> nielsm: does it work without -f?
[14:54:06 CET] <nielsm> (hi JEEB)
[14:54:15 CET] <nielsm> kerio nope, but new error
[14:54:52 CET] <kerio> what's the best encoding for null audio, i wonder
[14:55:22 CET] <nielsm> "http://camera/mjpeg.cgi: Invalid data found when processing input"
[14:55:28 CET] <nielsm> when specifying without -f mjpeg
[14:56:33 CET] <kerio> this makes sense at least
[14:58:03 CET] <nielsm> okay this is insane
[14:58:12 CET] <nielsm> if I specify 15 fps instead of 30 for the output, I get 10 fps
[14:58:21 CET] <kerio> 🤔
[14:58:31 CET] <kerio> just don't do that
[14:58:39 CET] <kerio> and use -vf fps=30 maybe
[14:59:19 CET] <nielsm> tried -vf fps=30, no effect
[15:10:46 CET] <kepstin> nielsm: where are you seeing '10 fps'? The fps printed on the ffmpeg status line is the speed that the encoder is running at, has nothing to do with the framerate of the video itself.
[15:11:16 CET] <nielsm> that's where I see it yes
[15:11:38 CET] <nielsm> but since it's a live streaming the encoder ought to run at the same speed as the input, right?
[15:46:54 CET] <nielsm> path of least resistance: I figured out how to make OBS receive video from the camera instead, and then do the streaming that way instead; it handles the framerate issue better
[16:32:28 CET] <mbarisa> hey guys, any idea why when I compile ffmpeg I don't get a binary that I can just use afterwards, but it just spits files in include/ and lib/
[16:32:41 CET] <mbarisa> I am using --enable-static
[16:44:23 CET] <DHE> mbarisa: you should still get an ffmpeg binary that is only dynamically linked against standard libs
[16:44:34 CET] <DHE> you'll know because it'll be big - like around 20 megabytes
[16:44:51 CET] <mbarisa> Yeah, that is what I want, but it doesn't exist
[16:45:04 CET] <mbarisa> I can show my .configure if that will help
[16:45:26 CET] <DHE> if you run "make ffmpeg" what does it say?
[16:46:45 CET] <mbarisa> if compiles and finishes
[16:46:47 CET] <mbarisa> and generates
[16:47:12 CET] <mbarisa> include and lib folder and there is no binary
[16:47:43 CET] <mbarisa> http://pastebin.com/7jidMdVe
[16:52:59 CET] <mbarisa> any idea what can be wrong here?
[17:14:21 CET] <mbarisa> DHE: any idea?
[17:16:26 CET] <DHE> mbarisa: I asked for the output of "make ffmpeg"
[17:25:32 CET] <mbarisa> I can't find it, the whole script runs, and it seems to succeed, i get output folder as I said, so I guess that is output from my make
[17:29:25 CET] <DHE> that's not output. that's just your script
[17:30:15 CET] <mbarisa> where does output go usually to /usr/bin?
[17:30:17 CET] <mbarisa> something like that
[17:30:29 CET] <mbarisa> but this i  am building for android not for this machine
[17:30:32 CET] <DHE> you're not disabling the building of the main ffmpeg binary, so it should go into your .../ffmpeg/armeabi/bin directory
[17:30:51 CET] <DHE> which would be alongside your include and lib directories that got created
[17:31:05 CET] <mbarisa> unfortunatelly it does not exist :/
[17:31:32 CET] <mbarisa> i tried to find / -name "ffmpeg" and can't find that one, only finds folder ffmpeg that I already see
[17:32:29 CET] <DHE> does your cross-compiler support making binaries? there are some compiler resources needed to do that which you might be missing
[17:32:52 CET] <mbarisa> I guess so
[17:33:16 CET] <jkqxz> You've disabled avfilter, which ffmpeg depends on.
[17:33:26 CET] <jkqxz> Remove the --disable-avfilter.
[17:34:06 CET] <jkqxz> Also swresample.
[17:34:40 CET] <mbarisa> ok, giving it a try. :)
[17:40:32 CET] <mbarisa> still no binary
[17:41:44 CET] <jkqxz> What is your configure line now?
[17:42:36 CET] <mbarisa> http://pastebin.com/nwtdVWs4
[17:43:15 CET] <jkqxz> You still have --disable-avfilter.
[17:43:15 CET] <furq> that still contains --disable-avfilter
[17:44:07 CET] <mbarisa> sorry bout that :)
[17:44:15 CET] <mbarisa> spinning again
[17:44:37 CET] <mbarisa> It is 8 hours in terminal, I can't see anymore :)
[17:49:24 CET] <mbarisa> thanks guys, works
[18:43:59 CET] <szymon> hey, I've got a question about sound files with speech. I need to find out segments of the file when someone is speaking. I have tried many different ideas, but none of them creates satisfying output.
[18:46:13 CET] <szymon> The desired output can be text list of speech segments like (1.1, 2.0) or a sound file with non speech sounds trimmed to 0dB, I can take care of that later.
[18:46:50 CET] <szymon> using `silencedetect` doesn't find proper places, and is too automatic
[18:54:34 CET] <aulederhosen> Hi there. I have a question about porting an app that uses ffmpeg libraries from 2 to 3
[18:57:56 CET] <fritsch> aulederhosen: and what is the question?
[18:58:16 CET] <fritsch> fixing it properly or just getting it compiled with all the deprecation warnings?
[18:58:37 CET] <aulederhosen> Well, I hate to ask FAQs, so first would be: is there a porting guide? I have looked around and not found one
[18:59:00 CET] <aulederhosen> ... and I'd rather fix properly, no deprecation warnings
[18:59:35 CET] <fritsch> basically: does it still compile?
[18:59:58 CET] <fritsch> out of my head the only breaking changes were some defines AV_PIX_whatever
[19:00:02 CET] <DHE> deprecation warnings are safe (for now). there should be documentation about what to do instead around the comments where the deprecation warning comes from
[19:00:19 CET] <fritsch> yeah, +1 on that
[19:00:47 CET] <aulederhosen> Alright, I'll just hold my nose for now ;-)
[19:01:31 CET] <aulederhosen> But in case you are bored, this is the code: AVStream* st=...; const AVPixFmtDescriptor * pfmtd = av_pix_fmt_desc_get(st->codec->pix_fmt)
[19:01:52 CET] <aulederhosen> but st->codecpar does not have a pix_fmt field.....
[19:12:16 CET] <fritsch> aulederhosen: what about codecpar->format?
[19:14:55 CET] <aulederhosen> fritsch: ah, that's an int that I need to interpret as enum AVPixelFormat if codecpar->codec_type==AVMEDIA_TYPE_VIDEO?
[19:15:47 CET] <fritsch> https://ffmpeg.org/pipermail/ffmpeg-cvslog/2016-April/099163.html
[19:16:32 CET] <aulederhosen> awesome, that makes sense. Thank you so much!
[19:18:23 CET] <aulederhosen> really appreciate your help fritsch. I just compiled and tested and it works
[19:18:35 CET] <fritsch> any other deprecations?
[19:19:08 CET] <fritsch> some are very easy to solve, others like decode / encode api is more hard to do
[19:19:09 CET] <aulederhosen> No, most other things were handled by s/codec/codecpar/ and a couple macro renames that were easy to find.
[19:19:23 CET] <fritsch> cause that new api only makes sense when not used like the old one
[19:19:29 CET] <fritsch> cool
[19:19:54 CET] <aulederhosen> A porting guide (or wiki page, so I can add this little tidbit) would have been helpful
[19:20:18 CET] <fritsch> mmh, i think the deprecation message is quite detailled here
[19:20:43 CET] <aulederhosen> yeah, semantic changes (how you have to structure your client code) are harder. So far everything still seems to work....
[19:21:37 CET] <aulederhosen> Detailed? I must have looked in the wrong spot. The .h file only says "use codecpar" where the .codec member is declared
[19:22:34 CET] <fritsch> most of them have been renamed 1:1
[19:24:31 CET] <aulederhosen> I actually kind of like the code, what I've seen so far in doxygen. Involved, but fairly straightforward C
[19:31:54 CET] <mantas322> Hello, anyone here?
[19:33:22 CET] <aulederhosen> *crickets*
[19:33:28 CET] <aulederhosen> ;-)
[19:33:30 CET] <ChocolateArmpits> mantas322, you have a question ?
[19:33:34 CET] <mantas322> yes
[19:33:46 CET] <mantas322> However it's loosely related to ffmpeg.
[19:33:56 CET] <mantas322> My question is about avi's exported from Blender
[19:33:59 CET] <mantas322> Raw AVI
[19:34:24 CET] <mantas322> I am able to export raw avi 5 to 10 seonds in length at a size of 4 to 6 GB
[19:34:26 CET] <mantas322> no problem
[19:34:32 CET] <mantas322> plays a little choppy but thats okay.
[19:34:35 CET] <mantas322> Now
[19:34:49 CET] <mantas322> If I export a raw AVI 1.2 GB in size, and 20 seconds in length
[19:34:58 CET] <ChocolateArmpits> From Blender too ?
[19:34:59 CET] <mantas322> for some reason on my windows 7 machine it doesnt recognize it
[19:35:03 CET] <mantas322> COrrect
[19:35:12 CET] <mantas322> all raw avis in my question are related to blender.
[19:35:32 CET] <kerio> why is the 20sec one so much smaller than the rest
[19:35:34 CET] <mantas322> I just dont know enough baout video, to understand WHY this is happening.
[19:36:10 CET] <mantas322> I geenrated a 20 second 1.2 GB avi.  and it refuses to be accepted by ffmpeg, camtasia, or windows media player
[19:36:23 CET] <mantas322> kerio, just how it came out.
[19:36:25 CET] <kerio> does anything play it
[19:36:26 CET] <mantas322> more white background
[19:36:29 CET] <mantas322> less content.
[19:36:32 CET] <ChocolateArmpits> Now a canned response I could give would be to go over to #blender, but I know enough of the software to ask, what are your export settings ?
[19:36:35 CET] <mantas322> it works fine
[19:36:44 CET] <mantas322> when i upload it to youtube there are no issues
[19:36:47 CET] <mantas322> only on my own pc.
[19:36:58 CET] <mantas322> I've never been so confused!
[19:37:17 CET] <furq> mantas322: ffprobe -show_streams
[19:37:24 CET] <mantas322> https://www.blender.org/manual/render/output/video.html
[19:37:31 CET] <mantas322> defaults.
[19:37:32 CET] <ChocolateArmpits> mantas322, what are the export settings, encoding format used namely
[19:38:02 CET] <mantas322> AVI Raw Audio-Video Interlaced (AVI) uncompressed frames.
[19:38:07 CET] <furq> also "refuses to be accepted by windows media player" is the normal state of affairs
[19:38:22 CET] <ChocolateArmpits> mantas322, what about the previous file that takes more space ?
[19:38:28 CET] <mantas322> same thing
[19:38:41 CET] <mantas322> no format changes
[19:38:43 CET] <furq> what error does ffmpeg give you
[19:38:49 CET] <ChocolateArmpits> No, how does it take less space when it's lengther and both are uncompressed
[19:38:54 CET] <mantas322> I forget, thi was at home
[19:39:12 CET] <mantas322> ChocolateArmpits, resolution
[19:39:24 CET] <mantas322> also a white frame takes less space than a colorfull frame.
[19:39:27 CET] <mantas322> even in raw
[19:39:29 CET] <kerio> no
[19:39:30 CET] <mantas322> I might be wrong ^
[19:39:32 CET] <kerio> it doesn't
[19:39:33 CET] <ChocolateArmpits> What version of ffmpeg are you running, are you sure it's latest ?
[19:39:43 CET] <mantas322> probably not the latest.
[19:39:56 CET] <ChocolateArmpits> mantas322, frame content has no relation to size when it's all uncompressed
[19:40:07 CET] <ChocolateArmpits> doesn't matter how detailed or empty a frame is
[19:41:18 CET] <mantas322> understood.
[19:41:19 CET] <furq> there's not much we can do without at least an error message
[19:41:22 CET] <mantas322> hmmm
[19:41:30 CET] <mantas322> frame rate
[19:41:33 CET] <mantas322> also different
[19:41:37 CET] <furq> "it doesn't work" is a description of 100% of issues
[19:41:53 CET] <mantas322> it's hard when all of this is on my home pc
[19:42:08 CET] <ChocolateArmpits> mantas322, Best I can advise is to return when you have more information and can provide your command line
[19:42:12 CET] <mantas322> im here moreso for just general troubleshooting as to why one avi wont work when a larger one will
[19:42:18 CET] <mantas322> the only difference seems to be in length.
[19:42:27 CET] <mantas322> thx thx.
[19:42:29 CET] <mantas322> I appreciate that
[19:42:32 CET] <mantas322> I shall return.
[19:42:45 CET] <kerio> anyway, test the latest ffmpeg version first
[19:42:58 CET] <mantas322> im sure mine is out of date by years.
[19:43:01 CET] <kerio> is it really a video file if ffmpeg doesn't parse it? 🤔
[19:44:57 CET] <mantas322> well, it ends in avi!
[19:45:05 CET] Action: mantas322 silly  :/ 
[19:45:24 CET] <furq> http://a5.files.biography.com/image/upload/c_fit,cs_srgb,dpr_1.0,h_1200,q_80,w_1200/MTE5NTU2MzE2MzY4ODk3NTQ3.jpg
[19:45:27 CET] <furq> is he a video file
[19:51:05 CET] <mantas322> I was kidding furq
[20:00:08 CET] <mantas322> oh by the way
[20:00:22 CET] <mantas322> let me show you the actual video which was exported "corrupt"
[20:00:40 CET] <mantas322> check it out https://www.youtube.com/watch?v=pEq_wp2VoOA
[20:00:54 CET] <mantas322> nice eh?
[20:00:58 CET] <mantas322> EH!!?!??!?!
[20:04:30 CET] <mantas322> I need validation.
[20:16:42 CET] <generalUser> Hello, I am having a lil trouble on understanding decoding in 3.2. What I don't get is how should a AVPacket be filled before tossing it to avcodec_send_packet
[20:17:47 CET] <fritsch> https://ffmpeg.org/doxygen/3.1/group__lavc__encdec.html <- you already had a look here, right?
[20:18:11 CET] <fritsch> and, with a bit more text: https://blogs.gentoo.org/lu_zero/2016/03/29/new-avcodec-api/
[20:23:29 CET] <generalUser> yes, i have looked at both; For the former I am not particularly sure what "send valid input" means, is it just initialize the AVPacket via av_init_packet?. As for the latter would i use get_packet()? I just mentions calling a function with AVPacket and im not sure how that was allocated/created/init
[20:23:43 CET] <generalUser> *It just mentions calling
[20:25:56 CET] <fritsch> you want to decode right?
[20:26:52 CET] <fritsch> that means sending in packets and receiving frameds
[20:28:20 CET] <generalUser> yes, i have a flv file ("test.flv", video h264 encoded, audio - i dont care). Should i just fopen it and send raw bytes from it?
[20:29:26 CET] <fritsch> how did you do it before you used the send / receive api?
[20:29:28 CET] <generalUser> (rather i think that's what i tried, just not sure if i did it right)
[20:29:42 CET] <fritsch> the transition from old api to new is not that hard
[20:29:55 CET] <generalUser> I didnt. First time, and i'm trying to figure out how to use the new api
[20:30:46 CET] <fritsch> http://ffmpeg.org/doxygen/trunk/decoding__encoding_8c-source.html <- see
[20:31:30 CET] <fritsch> that's how it's done with old api
[20:32:04 CET] <fritsch> but getting the avpkts and howto init them, read stuff
[20:32:09 CET] <fritsch> is the very same no matter new or old api
[20:38:49 CET] <generalUser> yeah, i read that too. I got a funny invalid nal unit size. Anyways, thanks ill try poking around there more
[20:39:22 CET] <generalUser> although if you have a more direct example with the new api, that'd be appreciated
[20:39:52 CET] <fritsch> I can give you some code I used for a 1:1 transition, but that's not a good example
[20:40:01 CET] <fritsch> as it gets 1 out for 1 in
[20:40:25 CET] <fritsch> but that's a special case where using new api is very same as before
[20:41:03 CET] <fritsch> https://github.com/FernetMenta/kodi-agile/blob/master/xbmc/guilib/FFmpegImage.cpp
[20:41:52 CET] <generalUser> thanks, much appreciated
[20:42:19 CET] <fritsch> we use it in kodi as an FFmpeg based picture viewer
[21:16:00 CET] <generalUser> oh, everything was working fine. Just im having legitimate decoding errors :/
[21:16:07 CET] <generalUser> alright, thanks
[21:18:25 CET] <fritsch> cool
[22:02:04 CET] <thebombzen> so it's known that upscaling 8bit to 10bit before encoding with something like H.264 helps the quality to bitrate ratio
[22:02:37 CET] <thebombzen> but what if you were to upscale yuv420p to yuv420p10le and then encode losslessly? would that help at all?
[22:03:04 CET] <fritsch> what do you think you upscale from yuv420p to yuv420p10le?
[22:03:08 CET] <mosb3rg> hey guys, is it possible to use a proxy to connect with ffmpeg, to fake a location, for example my main servers are often blocked from dumping some material, where as some local areas arent.. and with them being at data centers on fast gbit or 10gbit lines i dont want to use a vpn or anything like this.. and often that wont work anyway due to it being in data centers.
[22:03:24 CET] <mosb3rg> i can run the proxy on local linux machines just for example.
[22:04:21 CET] <Maverick|MSG> is there a known issue which ffmpeg stalling out when encoding using intel hevc_qsv?
[22:08:05 CET] <klaxa> mosb3rg: https://ffmpeg.org/ffmpeg-protocols.html#http
[22:08:08 CET] <klaxa> see http_proxy
[22:08:43 CET] <mosb3rg> i feel like i tried this method and it failed to work last time.
[22:08:50 CET] <mosb3rg> so this is a current function not broken
[23:13:58 CET] <Saget> Hi all I was hoping to get some help with an issue transcoding a file is this the right place?
[23:15:23 CET] <c_14> probably
[23:15:53 CET] <Saget> We use ffmpeg to convert all of our files to a standard format but we are seeing a bunch of these messages "Non-monotonous DTS in output stream 0:1;" when converting wmv/wma to mp4/m4a
[23:16:14 CET] <Saget> Some of these files end up with very short gaps and pops as well.
[23:16:37 CET] <Saget> However if I convert to wav first and then to m4a there are no error messages and no gaps
[23:21:07 CET] <Saget> We compile our own version of ffmpeg with lib fdk but I have tried many different versions on different os's. For some reason zeranoes build has less gaps but they are still present in some files. The gaps and error messages are present on all of the builds I have tried.
[23:30:25 CET] <c_14> Probably something about the input timestamps that ffmpeg doesn't like that the wav muxer fixes
[23:30:39 CET] <c_14> you could try -fflags +igndts as an input option
[23:38:12 CET] <Saget> Thanks I will give that a try.
[23:38:55 CET] <Saget> My guess was that it was a muxer problem as well, the mp4 and ipod muxer both have the same issue.
[23:42:30 CET] <Saget> -fflags +igndts did not help
[23:42:59 CET] <Saget> I also get Queue input is backward in time
[23:54:59 CET] <Maverick|MSG> when encoding with hesv_qsv, 50% of the time ffmpeg stalls: http://pastebin.com/0ctK40Ct
[23:55:25 CET] <Maverick|MSG> 100% of a single core is used by ffmpeg, but it never progresses past the "Press [q] to stop, [?] for help" stage
[23:57:02 CET] <Maverick|MSG> running the command again may produce the same result, or sometimes ffmpeg will progress as usual and encode the file just fine
[23:57:58 CET] <Maverick|MSG> I can enable more logging if anyone wants to see it
[23:59:35 CET] <Maverick|MSG> *hevc_qvc
[00:00:00 CET] --- Wed Jan  4 2017

More information about the Ffmpeg-devel-irc mailing list