[Ffmpeg-devel-irc] ffmpeg.log.20170109

burek burek021 at gmail.com
Tue Jan 10 03:05:01 EET 2017

[00:36:48 CET] <thebombzen> rjp421: can you give me a pointer on that
[00:36:56 CET] <thebombzen> or at least a link? not sure what this is
[01:25:24 CET] <rjp421> thebombzen, either locate or find the path to the file on your system, and replace my path with yours:  LD_PRELOAD=/usr/lib/arm-linux-gnueabihf/libv4l/v4l1compat.so ffmpeg ...
[01:25:48 CET] <thebombzen> I found it. on mine it's /usr/lib/libv4l/v4l1compat.so
[01:25:54 CET] <thebombzen> what's weird is mpv doesn't want to
[01:28:23 CET] <rjp421> LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so ffmpeg -f v4l2 -list_formats all -list_standards all -i /dev/video0
[01:28:40 CET] <rjp421> vs
[01:28:47 CET] <rjp421> ffmpeg -f v4l2 -list_formats all -list_standards all -i /dev/video0
[01:32:16 CET] <rjp421> then try with the command which gave you the "expected X got Y bytes"
[01:32:39 CET] <rjp421> with and without LD_PRELOAD, see if it helps
[01:33:14 CET] <rjp421> please let me know if so, im curious
[01:41:48 CET] <thebombzen> it did help
[01:41:52 CET] <thebombzen> it fixed it
[01:44:54 CET] <rjp421> thebombzen, awesome :)
[01:45:49 CET] <rjp421> why thats needed, idk.. maybe someone has proper/better solution
[01:49:09 CET] <outcast> Hi can I ask help for a ffmpeg build with custom libraries , i can pastebin the config options. ?  http://pastebin.com/Wa3SthpS
[01:50:02 CET] <klaxa> just ask and if you are lucky someone can help
[01:50:58 CET] <outcast> Well I have the av* .dll files , I need to make ffmpeg with the exact config options used in those av* .dll files
[01:51:36 CET] <outcast> I need it to demux a video after getting the ffmpeg created.
[01:51:46 CET] <outcast> http://pastebin.com/Wa3SthpS - config options
[01:52:04 CET] <outcast> I am having trouble compiling them all.
[01:52:12 CET] <furq> why do you need this exact set of options
[01:52:31 CET] <furq> also wtf is lua doing there
[01:53:03 CET] <outcast> I need it to demux a video created with ffmpeg created with this config options. I do not have the ffmpeg.exe but have these av .dlls
[01:53:25 CET] <furq> that doesn't make any sense
[01:53:30 CET] <outcast> I am a newbie in compiling and I dont know if lua is there or not.
[01:54:01 CET] <outcast> The video is encrypted.
[01:54:28 CET] <furq> none of those options have anything to do with encryption, so ffmpeg isn't going to help you decrypt it
[01:54:57 CET] <outcast> The avcodec dll is custom made which I have.
[01:55:26 CET] <outcast> So if I can compile with these config options , I will get ffmpeg and av dlls.
[01:55:50 CET] <furq> sure
[01:55:55 CET] <furq> you still won't be able to decrypt anything though
[01:56:15 CET] <outcast> The avcodec .dll will be replaced with the one I have.
[01:56:40 CET] <outcast> This avcodec was custom made to encrypt video.
[01:57:13 CET] <outcast> I will give you another config options which has the muxer name.
[01:58:14 CET] <outcast> Check this - http://pastebin.com/qpiJc4j2
[01:58:46 CET] <outcast> --enable-muxer=encx - this is the format they named for the encryption
[01:59:03 CET] <furq> so what makes you think compiling your own ffmpeg without that muxer is going to help anything
[01:59:25 CET] <outcast> I have all the dll files.
[01:59:43 CET] <outcast> I need the ffmpeg.exe
[02:00:04 CET] <outcast> I believe using the old custom made dlls and the new ffmpeg.exe , i can demux the encryption
[02:00:16 CET] <klaxa> but the ffmpeg.exe won't know about the encx muxer if you don't have the source afaict
[02:01:23 CET] <outcast> http://pastebin.com/QnqccwKj - this is the video detail from mkvinfo
[02:01:27 CET] <furq> yeah that's not going to work for a large number of reasons
[02:01:47 CET] <furq> what might conceivably work is writing your own demuxer using those libs, but you're on your own there
[02:02:04 CET] <outcast> So the avcodec .dll does not have the necessary information to demux the video ?
[02:02:16 CET] <thebombzen> well demuxing is done by avformat
[02:02:23 CET] <thebombzen> so avcodec shouldn't contain the information to demux
[02:02:35 CET] <outcast> Okay have the avformat dll also
[02:02:57 CET] <thebombzen> well libavformat has the necessary routines to demux the video but you need to either program your own frontend or just use ffmpeg
[02:03:51 CET] <outcast> I want to use ffmpeg , so If i compile ffmpeg with the same conifg options given in the dll , I will be able to demux the video ?
[02:04:01 CET] <furq> no
[02:04:05 CET] <thebombzen> no
[02:04:12 CET] <outcast> Ok
[02:04:26 CET] <outcast> What do you guys meant writing your own demuxer ?
[02:04:48 CET] <thebombzen> well for example avformat can demux video but you need to send it data. it doesn't do file i/o or anything like that
[02:04:48 CET] <furq> https://ffmpeg.org/doxygen/trunk/demuxing_decoding_8c-example.html
[02:04:52 CET] <thebombzen> so you need a frontend for that
[02:05:01 CET] <thebombzen> ffmpeg.c does that but you can't use it so you need to write your own for example
[02:06:03 CET] <furq> if you write something like that and link it against the dlls you already have then you might be able to use the custom demuxer
[02:06:15 CET] <furq> but you're pretty much on your own there
[02:06:28 CET] <thebombzen> speaking of ffmpeg.c, interestingly, I if I use ffplay -f v4l2 -probesize 32 -video_size_and_etc_settings -i /dev/video0 it plays with no delay, but if I use s/ffplay/ffmpeg I get a buffer delay
[02:06:35 CET] <thebombzen> and -fflags +nobuffer -avioflags +direct doesn't disable it
[02:06:35 CET] <furq> nice segue
[02:06:37 CET] <outcast> Okay there is hope , but on my own which is not much right now
[02:07:02 CET] <thebombzen> can someone help me out here?
[02:07:02 CET] <furq> https://ffmpeg.org/doxygen/trunk/remuxing_8c-example.html
[02:07:05 CET] <furq> that might be a better example
[02:07:10 CET] <thebombzen> cuase I'm not sure how to totally disable the buffers
[02:22:03 CET] <outcast> Anyway I will try compiling. will learn something out of it.
[02:22:27 CET] <outcast> Whats the easiest method of compiling ? Any link to guides plz ?
[02:22:52 CET] <klaxa> https://trac.ffmpeg.org/wiki/CompilationGuide
[02:22:55 CET] <klaxa> outcast: ^
[03:54:33 CET] <thebombzen_> Gimp has a "selective gaussian blur" filter which is gaussian blur but with a max delta
[03:55:06 CET] <thebombzen_> it's useful for blurring the background away cause it might have distracting blocking ringing banding or noise
[03:55:15 CET] <thebombzen_> without affecting the foreground
[03:55:32 CET] <thebombzen_> can I do this with avfilter?
[05:23:45 CET] <JeffATL> my vid cap card outputs hardware-encoded MPEG2. sometimes i need to process the audio independently of the video (in e.g. audacity). But sometimes the audio will be 20m44.061s long and ffprobe will report a duration for the original file as 20m44.09 long. It may not matter for a 20m video but for a 3h+ video i'm worried about having a sync mismatch at one end or the other. how should I handle this?
[05:57:52 CET] <markw_> Hello, my first IRC experience - sorry if my bad .... I read ffmpeg will not work with GoDaddy's shared hosting .... anyone here know better?
[06:18:05 CET] <markw_> Hello, my second IRC experience - sorry if my bad .... I read ffmpeg will not work with GoDaddy's shared hosting .... anyone here know better?
[06:36:01 CET] <teratorn> markw_: no idea, but it's probably a question for godaddy support :)
[06:41:02 CET] <teratorn> markw_: a lot of el cheapo shared hosting won't let you run custom processes
[06:55:41 CET] <markw_> thank you both ... appreciate the replies ...
[08:55:41 CET] <oxhak> hello
[08:57:29 CET] <oxhak> there is a glitch audio noise on all dvb-t tuners with ac3 audio, since last year now I seen some post about it, I created a ticket on ffmpeg website but someone just closed it and said nothing, what can I do ?
[08:58:53 CET] <oxhak> can someone take a look it was here https://trac.ffmpeg.org/ticket/6010#comment:2
[08:59:56 CET] <oxhak> this random noise is really annoying when watching tv
[09:15:45 CET] <rjp421> i want to infinitely loop https://i.imgur.com/V4uHqs5.gif and scale it to fit centered in a 360p flv/rtmp output stream, keeping the original aspect ratio...
[09:18:53 CET] <rjp421> or better yet, output to a loopable file to use as the source for a v4l2loopback device and/or the rtmp livestream
[09:22:31 CET] <rjp421> but i want to keep the animation quality as much as possible, so it still looks smooth, and trippy
[09:35:15 CET] <durandal_170> oxhak: provide sample
[13:26:02 CET] <mbarisa_> can someone help me with compilation issues on ffmpeg with ssl, http://pastebin.com/yFzFaeuX -> here you can see latest configure but I have 10 different configs, and none of them work, I just want to get static ffmpeg binary with ssl included in it for android. If someone has any experience I am willing to listen and try. Lost 5 days on it at least and no luck!
[14:39:45 CET] <ZexaronS> hello
[14:40:20 CET] <ZexaronS> VF select filters can only be used when transcoding, or also with muxing only ?
[14:49:06 CET] <DHE> you can't use a video filter if you don't run an codecs
[14:49:27 CET] <DHE> you can use a -bsf but those are highly limited and are more special case
[16:14:51 CET] <Fyr> guys, when converting a FLAC file into an MP3 one, ffmpeg converts also mjpeg cover art into PNG cover art. how to prevent conversion of cover art, keeping the same image?
[16:18:19 CET] <kerio> -c:v copy
[16:18:30 CET] <kerio> idk if jpeg can be used as cover art tho
[16:18:42 CET] <Fyr> i.e. covert art == video?
[16:19:13 CET] <kerio> that's why it says mjpeg instead of jpeg
[16:19:43 CET] <Fyr> kerio, what on Earth makes it say that?
[16:19:53 CET] <kerio> it's cover art
[16:19:54 CET] <kerio> it's a static picture
[16:20:14 CET] <kerio> but jpeg is literally 1-frame mjpeg
[16:20:25 CET] <kerio> and ffmpeg is meant to deal with video, not pictures
[16:59:28 CET] <nicolas17> I'm making a video from JPEG images, is it possible to have ffmpeg use the orientation EXIF tag to rotate images if necessary?
[17:00:05 CET] <durandal_170>  kerio: ffmpeg works with images just fine
[17:00:08 CET] <nicolas17> currently I'm passing -vf vflip,hflip if that particular photo sequence ends up upside down, but that's a manual process
[17:00:14 CET] <kerio> durandal_170: ye but they're video streams
[17:06:40 CET] <durandal_170> nicolas17: what ffmpeg version?
[17:06:57 CET] <nicolas17> any, I'll upgrade if needed :P
[18:40:54 CET] <dine909> hi there - we need a person to write a video player based around libav for Unity, for cash! anyone able to help?
[19:18:47 CET] <rjp421> v4l2-ctl -d /dev/video4 --set-fmt-video=width=1280,height=720,pixelformat=1 --overlay=0 --set-ctrl video_bitrate=15000000
[19:19:06 CET] <rjp421> raspivid -t 0 -w 1280 -h 720 -vf -hf -pf main -fps 24 -g 48 -b 15000000 -ih -v -o - | ffmpeg -loglevel info -fflags nobuffer -r 24 -re -i - -c:v copy -preset ultrafast -x264opts keyint=48 -an -sn -timecode `date '+%H:%m:%S.00'` -f flv 'rtmp:// flashver=FMLE/3.0\20(compatible;\20FMSc/1.0) live=1'
[19:20:54 CET] <rjp421> output fps is stuck at 25, i want 24 (with gop 48 for hls downstream)...
[19:23:30 CET] <rjp421> i did build with --enable-omx-rpi --enable-mmal.. does that mean ffmpeg can take place of raspivid, using the hw accel? that cmd doesnt let me Q to quit gracefully, have to ctrl+c
[19:26:55 CET] <furq> rjp421: yes
[19:29:39 CET] <rjp421> furq, ty, i have only found howto's using raspivid piped to ffmpeg... ill keep looking
[19:37:50 CET] <rjp421> furq, i found -re to seemingly work better than without.. the rate= was all over the place, and the output stream was very choppy.. also i was fighting wit the fps in that cmd, hence the redundant args again
[19:40:27 CET] <furq> -f v4l2 -i /dev/video0 -c:v h264_omx
[19:40:48 CET] <rjp421> ty
[19:41:02 CET] <furq> other than that it should work the same as any other v4l2 capture
[19:41:32 CET] <rjp421> i take it i can only do that with the pi-cam?
[19:41:36 CET] <nicolas17> -c:v won't do any reencoding at all
[19:41:48 CET] <nicolas17> so I bet the bandwidth was your limit :P
[19:42:28 CET] <pumpkinz> I noticed audio quality in obs is terrible. Using ffmpeg on the command line, duplicating the same settings, produces clean audio. Any ideas how to narrow this down?
[19:42:41 CET] <furq> rjp421: no idea, i've never used a webcam with a pi
[19:42:51 CET] <furq> i'd have thought any usb webcam would work
[19:42:53 CET] <pumpkinz> I can produce samples if desired.
[19:43:19 CET] <furq> it's just regular v4l2, the only difference is you're using the builtin h264 encoder
[19:44:04 CET] <nicolas17> does it still go from the camera to main memory, and then to the hardware encoder?
[19:44:38 CET] <kerio> if it's not the builtin camera then of course
[19:44:44 CET] <kerio> usb doesn't have DMA to the gpu
[19:44:55 CET] <nicolas17> no, I meant with the builtin camera
[19:45:16 CET] <kerio> i think there's a way to get h264 directly
[19:46:01 CET] <rjp421> set the format with v4l2-ctl?
[19:47:11 CET] <furq> probably
[19:48:26 CET] <furq> nicolas17: i can't imagine ffmpeg would be able to encode it if it wasn't in memory
[19:48:43 CET] <rjp421> afaik only raspivid is able to set the profile etc :(
[19:49:06 CET] <rjp421> for the camera directly
[19:49:25 CET] <furq> rjp421: https://www.ffmpeg.org/ffmpeg-devices.html#video4linux2_002c-v4l2
[19:50:06 CET] <rjp421> the h264 profile etc*
[19:50:25 CET] <kerio> does raspivid do any muxing
[19:50:36 CET] <furq> h264_omx is always main profile afaik
[19:51:55 CET] <furq> or maybe not
[19:51:56 CET] <rjp421> kerio, idk :(
[19:52:07 CET] <furq> even the rpi decodes high profile though
[19:54:17 CET] <Fyr> guys, I found out that when converting FFMPEG copies the CUE from the original FLAC file while cutting the original CD into pieces. how to prevent this?
[19:54:41 CET] <furq> what do you expect it to do
[19:54:42 CET] <Fyr> AIMP seems to use the CUE embedded instead of file's tags.
[19:55:11 CET] <furq> oh is it giving you a flac with embedded cue
[19:55:13 CET] <furq> that's dumb
[19:55:28 CET] <Fyr> I want CUE to disappear in the FLAC files obtained.
[19:55:39 CET] <furq> shrug
[19:55:44 CET] <furq> i've only ever used cuetools for this
[19:55:49 CET] <furq> ffmpeg seems like a bad choice
[19:55:56 CET] <Fyr> why?
[19:56:14 CET] <Fyr> I experienced some troubles with CUETools.
[19:56:18 CET] <furq> well for starters because ffmpeg won't create a noncompliant cue
[19:56:32 CET] <furq> but also because i want accuraterip and ctdb verification
[19:56:47 CET] <furq> and also tags
[19:57:26 CET] <furq> unless i'm way behind the curve and ffmpeg actually understands cuesheets now
[19:58:17 CET] <Fyr> I used a python wrapper to cut the FLAC into pices with CUEsheets.
[19:59:48 CET] <furq> https://wiki.archlinux.org/index.php/CUE_Splitting
[19:59:52 CET] <furq> if you don't want to use cuetools
[20:00:19 CET] <furq> (the cuetools mentioned in that article is not the same cuetools)
[20:00:22 CET] <kerio> high def digital releases > redbook cd
[20:01:26 CET] <furq> http://vgmdb.net/album/3906
[20:01:33 CET] <furq> do you want to find me a 24/192 release of this
[20:02:17 CET] <kerio> but sadly, whatcd is kill
[20:02:27 CET] <furq> they probably didn't even have the cd of it
[20:02:58 CET] <kerio> i wouldn't put it past whatcd tbh
[20:03:12 CET] <kerio> ;-;
[20:03:21 CET] <kerio> now you've gone and made me sad again
[20:03:24 CET] <furq> nah there's no extant 100% rip of it so nobody would bother because nobody would autosnatch it
[20:04:10 CET] <furq> what pretty much sucked for vgm
[20:05:23 CET] <kerio> i bet those tracks weren't 44.1 originally
[20:06:45 CET] <furq> it'll have been an analog capture so it's whatever you want it to be
[20:06:48 CET] <kepstin> if they're off an arcade game, there's half a chance they're analog recordings off the actual game hardware, then digitized.
[20:06:53 CET] <furq> ^
[20:07:08 CET] <kerio> hold on lemme check
[20:07:10 CET] <furq> there's more than half a chance of that being the case in 1989
[20:07:48 CET] <kepstin> I mean, the other option is that they stuck a (fancy new tech!) CD player inside the arcade machine itself to do cd-quality music :)
[20:07:49 CET] <kerio> i... don't even know
[20:07:57 CET] <phillipk_> I'm turning still images into short .ts files which need to later get concat'd.  But when scaling the images, the output .ts files report the correct dimensions, but appear in some video players at their original aspect ratio (no black bars to fit my -s 1920x1080).
[20:07:59 CET] <furq> yeah i have no idea what you were going to check
[20:08:12 CET] <kerio> i thought there was a way to get the audio output format
[20:08:18 CET] <furq> phillipk_: -vf setsar
[20:08:23 CET] <furq> or setdar
[20:08:36 CET] <furq> https://ffmpeg.org/ffmpeg-filters.html#setdar_002c-setsar
[20:08:48 CET] <phillipk_> I don't mind about how they play in other players, but when I concat, it's the first one's playback size that determins the size of concat'd file.  I'll try furq!
[20:09:01 CET] <furq> or you can use -aspect to set the dar without reencoding
[20:09:40 CET] <kepstin> phillipk_: it's not clear what you're trying to do - are the input images arbitrary aspect ratios, or all 16:9?
[20:10:59 CET] <phillipk_> inputs are all over the place--I want them "best fit" into my 16:9
[20:11:14 CET] <furq> kerio: fwiw the same sound chip in the x68000 output at 62.5khz
[20:11:26 CET] <furq> idk if that used the same dac though
[20:11:27 CET] <kerio> the YM2151, or the "Irem M72 Audio Custom"?
[20:11:31 CET] <furq> the ym2151
[20:12:13 CET] <furq> that other chip was the sound cpu
[20:13:07 CET] <furq> i'm pretty sure it's just a z80
[20:13:56 CET] <phillipk> setdar=dar=16/9 "works" but now my images are stretched
[20:14:06 CET] <furq> you probably want -vf setsar=1
[20:14:11 CET] <kerio> furq: obviously it's all moot because the interesting thing in that cd is that medley
[20:14:30 CET] <kerio> and that's not extractable from MAME :c
[20:17:17 CET] <furq> i mean
[20:17:26 CET] <furq> if i wanted to cheat i would just use this
[20:17:28 CET] <furq> https://vgmrips.net/packs/pack/image-fight-irem-m72
[20:18:06 CET] <furq> but i do not want to cheat because i am a man of decency
[20:37:51 CET] <phillipk> I'm still producing videos that report to be 1920x1080 but don't fill the empty space when played in some players (and, more importantly, get messed up with a concat of otherwise legit 1920x1080 vids)
[20:37:56 CET] <phillipk> am using:
[20:38:19 CET] <phillipk> -s 1920x1080 -vf setsar=sar=1,setdar=dar=16/9
[20:38:21 CET] <phillipk> or
[20:38:35 CET] <phillipk> -s 1920x1080 -vf setsar=1
[20:49:56 CET] <phillipk_> I can use just -s 1920x1080 and it LOOKs good in some players (other players trim the excess black bars on playback)... but the output doesn't work in a concat because other files getting concatenated don't have this "trim the black bars" issue.
[21:26:07 CET] <phillipk> i'm getting confused with sar/dar and scaling.  I'm basically, doing:
[21:26:49 CET] <phillipk> -loop 1 -f image2 -i oddSized.jpg -s 1920x1080 -f mpegts outfile.ts
[21:27:26 CET] <DHE> sar is the size of the pixels. 1/1 means square pixels, which PC monitors (and modern TVs) almost always are. dar is the display aspect ratio, which is the size of the image.
[21:27:30 CET] <phillipk> but I want it to scale without distorting--which it does.  But, the output ts file thinks its an aspect ratio matching the original .jpg
[21:27:38 CET] <DHE> by default -s will skew sar to keep dar constant
[21:28:24 CET] <phillipk> I can make it stretch to fit 1920x1080 and then it works fine in my later -concat.  But, it's stretched.  If I don't see it stretched, it never has the black bars (on the side because the original is like a 3:4 where 1920x is 16:9)
[21:29:07 CET] <phillipk> I tried using -vf scale vs. -s
[21:30:48 CET] <llogan> phillipk: so you want to fix a specific size box, but also preserve aspect ratio? that will require pillar or letter boxing, or cropping depending on how you want to handle the difference.
[21:31:27 CET] <phillipk> yes, I want letterbox/pillar
[21:32:00 CET] <llogan> -vf "scale=1920:1080:force_original_aspect_ratio=decrease,pad=1920:1080:(ow-iw)/2:(oh-ih)/2"
[21:33:34 CET] <llogan> this also works if sequential image inputs vary in size.
[21:33:59 CET] <DHE> wonder if maybe you should use the concat filter and concatenate the videos after a filtering pipeline has had at them
[21:36:41 CET] <phillipk> awesome, thanks llogan
[21:38:15 CET] <llogan> if you decide to take a crop instead change to "increase,crop=1920:1080"
[21:39:09 CET] <pumpkinz> when recording with this: ffmpeg -f pulse -i default -ac 1 -c:a aac -b:a 96k test-ffmpeg.m4a ... The time goes up in minutes rather than seconds.
[21:43:48 CET] <pumpkinz> can someone else try that command to see?
[21:50:14 CET] <klaxa> works on my machine"
[21:50:50 CET] <klaxa> git from mid december
[21:54:00 CET] <pumpkinz> just updated from git and it works. nvm sorry guys.
[21:54:08 CET] <pumpkinz> interesting stuff thanks klaxa
[21:55:47 CET] <klaxa> :)
[22:31:52 CET] <josuebc> Hi there. I have this DVR which has a JPEG stream. It is not an MJPEG because it's a url that will give you a still image every time you do a GET. I'm trying to use ffmpeg to create an rtsp stream for this but I can't make it work. Any idea where can I find an example of this?
[22:32:08 CET] <kerio> that sounds... implausible
[22:32:43 CET] <josuebc> kerio: Really? I've seen a few posts of people creating a video from a file that gets overwritten over and over again. I thought it might be the same idea.
[22:32:53 CET] <kerio> no i mean
[22:32:57 CET] <kerio> there's no way that's a live video
[22:33:03 CET] <kerio> if you have to GET every frame
[22:33:28 CET] <josuebc> kerio: No, it is not a live video. It's very weird, but you know, chinese people.
[22:34:14 CET] <josuebc> Well, that might be taken in the wrong way. What I meant is that sometimes there's not a ton of documentation and that's what I've been able to get.
[22:34:59 CET] <kerio> did you sniff the traffic from the official windows 98 program or whatever it is
[22:36:32 CET] <josuebc> kerio: Yes, that's pretty much what they do. They just get a still image over and over again and render that as a "video". It is not a smooth video and there's some lag
[22:36:43 CET] <josuebc> Also, the client keeps disconecting every few seconds.
[22:38:45 CET] <kerio> what kind of framerate are you expecting?
[22:38:53 CET] <kerio> can the server do keepalive on the connection?
[22:38:59 CET] <kerio> can you get the same frame twice?
[22:39:10 CET] <kerio> like
[22:39:16 CET] <kerio> can you just spam a bunch of GETs
[22:39:39 CET] <josuebc> kerio: at least, 24 fps. No Keepalive. You can just do a bunch of GETs without an issue.
[22:40:10 CET] <josuebc> That's what I thought would be the solution with ffmpeg. I tried using `-loop` but I'm probably doing it wrong.
[22:41:17 CET] <kerio> is it not working?
[22:41:31 CET] <kerio> aiui -loop would just reopen the input over and over again
[22:41:41 CET] <kerio> anyway, if you can just make a script that uses curl or whatever
[22:41:45 CET] <kerio> and outputs concatenated jpegs
[22:41:49 CET] <kerio> that would be a valid mjpeg stream
[22:42:06 CET] <josuebc> Oh, really?. But outputs it into a file?
[22:42:11 CET] <kerio> well no
[22:42:14 CET] <kerio> to stdout
[22:42:14 CET] <josuebc> Because I'd like to turn this into an rtsp
[22:42:19 CET] <kerio> and then you use ffmpeg to do whatever
[22:42:21 CET] <TD-Linux> josuebc, it's probably actually multipart, e.g. it constantly sends new mjpegs
[22:42:49 CET] <josuebc> kerio: TD-Linux: Maybe then pipe it to ffmpeg to create the rtstp?
[22:42:55 CET] <kerio> yes
[22:43:22 CET] <TD-Linux> I don't know if ffmpeg will succesfully read that as a video, though.
[22:44:00 CET] <TD-Linux> but yeah external script with lots of GETs or parsing multipart will work
[22:44:40 CET] <kerio> josuebc: what model is the camera?
[22:44:43 CET] <kerio> or... dvr?
[22:44:52 CET] <josuebc> kerio: Icantek mydvr 1640
[23:41:28 CET] <mosb3rg> hey guys, im getting an error when trying to dump 4k material @ 20mbps headers. regarding ssl, but again -enabletls is for sure configured. heres the error:
[23:41:29 CET] <mosb3rg> http://pastebin.com/7iELSeqm
[23:42:08 CET] <mosb3rg> if anyone could please shed some light on the subject. im anxious to get alot of this material locally. since it wont stream correctly in that high of a bandwidth.
[23:44:25 CET] <frenda> Hi there
[23:44:51 CET] <frenda> ffmpeg -i Keyhan.S01E05.1080p.mkv -ss 00:07:27.000 -to 00:19:38.010 1.mkv
[23:46:15 CET] <frenda> I use that command to crop part of a film. The film has been dubbed! But by cropping, the cropped file play the video in original language! the dubbed voice is gone!
[23:47:09 CET] <frenda> Is there any option missing?
[23:48:49 CET] <mosb3rg> you could use the -map 0:0 -map 0:1
[23:49:11 CET] <mosb3rg> to for example state first video first audio assuming thats the order its multiplexed in the mkv source container.
[23:49:20 CET] <mosb3rg> if you want to verify these values.
[23:49:27 CET] <mosb3rg> use the following command first:
[23:49:39 CET] <mosb3rg> ffprobe -i Keyhan.S01E05.1080p.mkv
[23:49:51 CET] <mosb3rg> then you will notice the Stream #0:0
[23:50:29 CET] <mosb3rg> whatever the values happen to be, use the ones you expect to keep, you can refer to both instances of map one after another, and in my experience you want to use video, then audio.
[23:51:24 CET] <mosb3rg> ffmpeg -i Keyhan.S01E05.1080p.mkv -map 0:0 -map 0:1 -ss 00:07:27.000 -to 00:19:38.010 -c copy output.mkv
[23:51:53 CET] <mosb3rg> this would be if you are assuming first video and first audio, and that happens to be how its multiplexed in the original mkv container. (you can probe to find the correct map values)
[23:52:24 CET] <frenda> mosb3rg: http://paste.ubuntu.com/23773083/
[23:52:58 CET] <frenda> yes, Stream #0:0(eng)
[23:53:20 CET] <mosb3rg> so you want 0:0 and 0:1 ?
[23:53:26 CET] <mosb3rg> you verified this ?
[23:53:52 CET] <frenda> ?
[23:53:52 CET] <frenda> is -map 0:1 enough/
[23:54:01 CET] <frenda> I just wnat to keep dubbed one
[23:54:02 CET] <mosb3rg> i would argue it isnt.
[23:54:12 CET] <mosb3rg> you need to specify the video and audio you specifically want
[23:54:26 CET] <frenda> Stream #0:1(per)
[23:54:38 CET] <mosb3rg> so which is video ?
[23:55:14 CET] <frenda> Ah, I get it
[23:55:18 CET] <frenda> got*
[23:55:29 CET] <mosb3rg> oki :> good deal
[23:55:53 CET] <mosb3rg> if you ever use this on the web, and you get an error where it cannot decode some stuff, add -ignore_unknown
[23:55:56 CET] <mosb3rg> up front.
[23:56:12 CET] <mosb3rg> and use the map. and it will just point to whats needed and skip the rest as quickly as possible.
[23:56:24 CET] <frenda> Stream #0:0(eng): Video: h264 (High) VS Stream #0:1(per): Audio VS Stream #0:2(eng): Audio
[23:56:25 CET] <mosb3rg> or disregard the streams you dont want, but at the same time very specifically choosing them.
[23:56:27 CET] <frenda> thank you
[23:56:40 CET] <mosb3rg> sure man, so you got the full command and it makes sense ?
[23:57:00 CET] <mosb3rg> so video would be -map 0:0
[23:57:07 CET] <mosb3rg> and audio would be -map 0:2
[23:57:13 CET] <mosb3rg> if you wanted the one you claim is english.
[23:57:35 CET] <mosb3rg> per meaning peruvian ?
[23:57:42 CET] <frenda> nope
[23:57:44 CET] <frenda> Persian
[23:57:50 CET] <mosb3rg> sorry but still not english :D
[23:58:07 CET] <mosb3rg> so ya, if you wanted english, and video then -map 0:0 -map 0:2
[23:58:15 CET] <mosb3rg> in that order based on what you explained.
[23:59:07 CET] <frenda> Thnx, thnx
[00:00:00 CET] --- Tue Jan 10 2017

More information about the Ffmpeg-devel-irc mailing list