[Ffmpeg-devel-irc] ffmpeg.log.20170112

burek burek021 at gmail.com
Fri Jan 13 03:05:01 EET 2017

[00:16:35 CET] <arog> hi i want to convert a series of jpgs into a video so i ran it with ffmpeg -f concat -i myjpgs.txt -c copy output.mp4 -vcodec libx264
[00:16:43 CET] <arog> when i open the file in mediainfo i see the video codec is JPEG though
[00:16:55 CET] <arog> how do i convert it to h264 so i can play it in my web browser
[00:17:25 CET] <BtbN> don't tell it to copy
[01:10:27 CET] <ZexaronS> Hey guys, I think I have a cool idea, but it's a few sentences, since I posted this somewhere else, I was told I should try here because of technical reasons
[01:10:47 CET] <ZexaronS> 1. I was watching some timelapse videos, and I thought some of them may not be optimal, the source FPS, the quality, and then well, also it's costly to record months of HD video and then speed it up or throw out a lot of frames
[01:11:05 CET] <ZexaronS> 2. Then I thought well there must be some kind of timeplapse-specific tech that only snaps a frame every second or so ... to save on memory. Then this idea popped up. I'll just mention it, if it's not something handbrake can do or cares, i won't discuss it further.
[01:11:38 CET] <ZexaronS> 3. So, with consturction work timelapses, sometimes a lot is going on, sometimes less, movement, so I thought there could be a hybrid solution, that a camera would record full FPS, but an advanced encoder would take all the data, analyze it of how much movement there is for a section, inside the buffer, inside of a let's say 5 or 10 minute buffer, so those 5-10 minutes would take full filesize, the advanced analyzer would keep more
[01:11:38 CET] <ZexaronS> frames when there's a lot going on, pixel movement detection inside a pre-determined timespan for example, but eventually when you have days of footage, you'd have many hours already finalized
[01:14:36 CET] <ZexaronS> 4. Now, if there's no demand for this to be implemented as a hybrid real-time on-fly solution, nor I do expect the companies to use ffmpeg to replace their own firmware, it can still be done with offline videos (full sources), but you'll get the same type of high quality timelapse output, you just won't get the extra feature of doing it real-time to save space
[01:14:53 CET] <ZexaronS> 5. The frame skipping intensity based on the intensity of movement inside a buffer, when movement is more, skip less frames. That's the idea.
[01:18:34 CET] <ZexaronS> 6. Possibly this could be done by a separate movement analysis "encoder" scanner that would be independent of the underlying codec, or somewhow as a script injected in-between the encoding process
[01:19:26 CET] <ZexaronS> This would totally revolutionarize timelapses since they have to do it manually by slowing down time or framerate
[01:46:14 CET] <TD-Linux> ZexaronS, the open source webcam software "motion" can do this
[01:48:45 CET] <ZexaronS> How is it called?
[03:37:28 CET] <arog> hi, I have a list of images with durations of 0.033XXXXX and for some reason frames are being dropped even when I specified -r 30
[03:37:29 CET] <arog> any idea?
[03:37:37 CET] <arog> frame= 5682 fps=222 q=-1.0 Lsize=   50619kB time=00:03:47.20 bitrate=1825.1kbits/s dup=0 drop=1128     video:50566kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.106222%
[03:37:50 CET] <furq> pastebin the full command line
[03:38:15 CET] <arog> the output or my command?
[03:38:33 CET] <furq> the command, but both would be good too
[03:39:03 CET] <arog> okay give me 1 minute
[03:39:11 CET] <arog> ffmpeg -f concat -i ./pgcamflea/pgcamflea.ffmc -c h264 ./pgcamflea.mp4 -r 30 this is mine
[03:39:21 CET] <arog> oops its -r:v
[03:39:43 CET] <arog> rerunning it to get the output hold on a second
[03:40:05 CET] <furq> what's in the concat file
[03:40:44 CET] <furq> if it's just a list of images then you probably don't want -f concat
[03:40:52 CET] <arog> its both images + duration
[03:41:05 CET] <furq> are the durations variable
[03:41:19 CET] <arog> ill give an example hold on
[03:41:26 CET] <arog> http://pastebin.com/MXHhXve5
[03:41:35 CET] <arog> duration 0.033338 duration 0.033362
[03:41:42 CET] <arog> 33.XXXX ms
[03:41:54 CET] <arog> i may be able to round it off to 33ms and see if that helps
[03:42:13 CET] <arog> one minute still waiting for output
[03:42:13 CET] <furq> well yeah if 30fps exactly is close enough then don't do that
[03:42:17 CET] <arog> its about 7000 images
[03:42:30 CET] <furq> -framerate 30 -i tmp%04d.png out.mp4
[03:42:54 CET] <arog> let me try that
[03:42:58 CET] <arog> hold on 2 minutes
[03:43:02 CET] <furq> and if that's not close enough then don't use -r 30 (although you had it after the output filename so it wasn't doing anything anyway)
[03:43:09 CET] <arog> oh
[03:43:11 CET] <arog> hahah
[03:43:12 CET] <arog> :D
[03:43:47 CET] <furq> i assume you'd just need -vsync vfr
[03:44:00 CET] <furq> but yeah doing it with concat is dumb unless you actually need sub-ms precision, which you probably don't
[03:44:25 CET] <arog> ideally id like that
[03:44:28 CET] <arog> subms precision
[03:44:44 CET] <arog> essentailly we are capturing from a camera saving to jpgs
[03:44:48 CET] <furq> do you have a display which refreshes that fast
[03:44:49 CET] <arog> and then recreating the mp4
[03:45:01 CET] <arog> our camera records at 120fps
[03:45:11 CET] <arog> right now we are limiting it to 30
[03:45:23 CET] <arog> whats the difference between -framerate and -r?
[03:45:27 CET] <arog> i dont see framerate in the man
[03:45:37 CET] <furq> https://www.ffmpeg.org/ffmpeg-formats.html#image2-1
[03:45:54 CET] <furq> framerate is an input option specifically for that demuxer
[03:45:58 CET] <furq> r is an output option
[03:46:20 CET] <arog> oh i see ok
[03:46:24 CET] <arog> derp
[03:46:25 CET] <arog> thanks
[03:46:36 CET] <furq> r will drop and dup frames as required, so you don't want that at all
[03:47:06 CET] <arog> hah ok
[03:47:35 CET] <arog> hold on
[03:47:40 CET] <arog> it was waiting to see if i wanted to overwrite
[03:47:40 CET] <arog> lol
[03:48:04 CET] <furq> oh apparently you can set the frame timestamp from the file modification time with image2
[03:48:42 CET] <arog> http://pastebin.com/F6MYFYGm
[03:48:43 CET] <furq> so even if you need greater resolution, there's no need to use concat
[03:48:44 CET] <arog> here you go
[03:49:11 CET] <arog> still dropping frames
[03:49:18 CET] <arog> should i try removing the duration
[03:49:23 CET] <furq> what's the command that goes with this
[03:49:55 CET] <furq> oh this is still using concat
[03:50:11 CET] <arog> ffmpeg -f concat -i ./pgcamflea/pgcamflea.ffmc -framerate 30 -c:v libx264 ./pgcamflea.mp4 &> output.txt
[03:50:24 CET] <furq> -framerate doesn't do anything there
[03:50:25 CET] <arog> http://pastebin.com/F6MYFYGm
[03:50:29 CET] <furq> it only works with -f image2
[03:50:46 CET] <arog> oh i see
[03:50:55 CET] <furq> and it's an input option, so it would go before -i
[03:51:43 CET] <arog> oh instead of concat use image2
[03:51:43 CET] <arog> hmm
[03:51:55 CET] <furq> 02:42:30 ( furq) -framerate 30 -i tmp%04d.png out.mp4
[03:52:33 CET] <arog> ah oops
[03:52:39 CET] <arog> hmm
[03:52:58 CET] <furq> or: -f concat -i pgcamflea -vsync vfr out.mp4
[03:53:14 CET] <arog> let me try that
[03:53:16 CET] <furq> i'd use image2 though, i'd trust that more and it's less effort
[03:53:35 CET] <arog> okay
[03:53:42 CET] <arog> see problem with image 2 is that
[03:53:51 CET] <arog> so what im really trying to do is create 2 sets of images into a mp4
[03:54:01 CET] <arog> into 2 mp4s
[03:54:17 CET] <arog> like 1 camera dumps a bunch of images, convert that into mp4 and camera #2 dumps its images and convert that into mp4
[03:54:38 CET] <arog> however, since camera 2 started after camera 1 I want the videos to be synchronous so camera 2 needs to initially show a black screen
[03:54:41 CET] <arog> then when it has images
[03:54:47 CET] <arog> i guess i can do that with timestamps
[03:55:08 CET] <arog> black-image:timestamp start         image-1:timestamp_captured  image-2:timestamp_captured
[03:55:13 CET] <arog> with image2 i can name the files
[03:56:12 CET] <furq> there's probably a better way to do it
[03:56:13 CET] <arog> i should look into that a bit
[03:56:19 CET] <furq> the one that comes to mind requires ffmpeg 3 though
[03:57:31 CET] <furq> -f lavfi -i color=s=1280x720:d=60 -i test%04d.jpg -filter_complex concat
[03:57:46 CET] <arog> vfr is dropping frames
[03:57:56 CET] <arog> frame= 5681 fps=223 q=-1.0 Lsize=   50623kB time=00:03:47.16 bitrate=1825.6kbits/s dup=0 drop=1129     video:50569kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.106168%
[03:58:04 CET] <arog> ffmpeg -f concat -i ./pgcamflea/pgcamflea.ffmc -c:v libx264 -vsync vfr ./pgcamflea.mp4 &> output.txt
[03:58:12 CET] <furq> i've never actually done vfr output so i can't really help there
[03:58:21 CET] <arog> thats fine you ahve been very helpful already
[03:58:35 CET] <arog> so what is your suggestion for ffmpeg3?
[03:58:45 CET] <arog> i dont think image2 is going to work for me right?
[03:58:53 CET] <furq> image2 will work fine if you don't mind cfr output
[03:59:00 CET] <arog> whats cfr
[03:59:00 CET] <furq> i was talking about delaying the second video with a black screen
[03:59:04 CET] <furq> constant framerate
[03:59:13 CET] <arog> oh i want constant framerate i thini
[03:59:31 CET] <furq> then yeah just use image2
[04:00:17 CET] <furq> the command i posted a minute ago was to delay the input video, but the concat filter is new in ffmpeg 3 so you'd need to upgrade
[04:00:24 CET] <furq> there's probably a million ways to do that though
[04:02:00 CET] <arog> hmm
[04:02:06 CET] <arog> what if the delay needs to be like 2 ms lol
[04:02:12 CET] <arog> probably not worth it right
[04:02:18 CET] <arog> in that case just show the first frame
[04:02:22 CET] <furq> yeah you wouldn't even notice that
[04:02:33 CET] <arog> ffmpeg -f image2 -i tmp%04d.jpg -c:v libx264 ./pgcamflea.mp4 &> output.txt
[04:02:39 CET] <arog> [image2 @ 0xc270a0] Could find no file with path 'tmp%04d.jpg' and index in the range 0-4
[04:02:54 CET] <arog> i assure you the files are there
[04:03:03 CET] <arog> oh
[04:03:10 CET] <arog> does 0 need to be 0000 and 0001
[04:03:12 CET] <arog> gah
[04:03:21 CET] <furq> it does by default but you can change that
[04:03:28 CET] <furq> -start_number 1 before -i
[04:03:47 CET] <furq> or -start_number 1234 or whatever the first image is
[04:04:06 CET] <furq> the images need to be sequential after that though, otherwise you need to use a glob
[04:04:35 CET] <arog> so -start_number 1 -i tmp%??.jpg
[04:04:41 CET] <arog> %04d doesnt work there either
[04:04:46 CET] <furq> what's the first image called
[04:04:55 CET] <arog> tmp0.jpg
[04:05:03 CET] <furq> oh
[04:05:13 CET] <arog> tmp0 tmp1 tmp10 etc.
[04:05:15 CET] <c_14> you'll have to rename
[04:05:17 CET] <arog> yeah
[04:05:20 CET] <arog> thats fine
[04:05:23 CET] <c_14> because tmp10 sorts before tmp2
[04:05:24 CET] <furq> i think tmp%d will work?
[04:05:29 CET] <furq> oh right yeah
[04:05:37 CET] <furq> yeah i guess glob_sequence won't work either then
[04:05:59 CET] <c_14> tmp%d will work as long as you never have leading zeros
[04:06:54 CET] <arog> i dont!
[04:07:34 CET] <arog> will try it
[04:09:08 CET] <arog> http://pastebin.com/xxd1PauC
[04:09:13 CET] <arog> is it possible to check if frames have dropped
[04:09:21 CET] <arog> ffmpeg -f image2 -i ./pgcamflea/tmp%d.jpg -c:v libx264 ./pgcamflea.mp4 &> output.txt
[04:09:40 CET] <furq> that shouldn't ever drop frames unless you set -r
[04:09:47 CET] <furq> although that'll be 25fps because you didn't set -framerate
[04:09:57 CET] <arog> oops
[04:09:59 CET] <arog> yes
[04:10:06 CET] <arog> so that has to be before the output file
[04:10:09 CET] <furq> if any frames are dropped it'll show up in the stats line
[04:10:12 CET] <furq> and no, -framerate goes before -i
[04:10:17 CET] <arog> Oh ok
[04:11:51 CET] <arog> cool!
[04:11:55 CET] <arog> worked :)
[04:15:23 CET] <arog> thanks a lot for your help!
[04:24:20 CET] <rjp421> furq, is -r the same as -framerate for v4l? on the ffmpeg v4l2 help it only shows -framerate
[04:31:26 CET] <furq> shrug
[04:31:34 CET] <furq> sometimes it's aliased as an input option but that's not always documented
[04:31:43 CET] <furq> you're better off just using the documented option names
[04:32:22 CET] <furq> oh nvm
[04:32:23 CET] <furq> https://ffmpeg.org/ffmpeg.html#Video-Options
[04:32:24 CET] <furq> so no, then
[07:09:15 CET] <Diag> Does the ff really stand for fastforward
[07:14:04 CET] <furq> http://ffmpeg.org/pipermail/ffmpeg-devel/2006-February/010315.html
[07:15:37 CET] <Diag> huh
[07:15:42 CET] <Diag> *The more you know*
[07:15:51 CET] <Diag> Aint very fast forward without vce cough cough
[07:16:37 CET] <furq> is vce still not supported
[07:19:12 CET] <Diag> dont believe so
[07:19:14 CET] <Diag> slackers
[07:19:18 CET] <Diag> come on, what are we paying you guys for
[07:19:24 CET] <furq> i'm pretty sure it sort of works through vaapi
[07:19:30 CET] <Diag> through what now
[07:19:40 CET] <furq> assuming you're on linux
[07:19:46 CET] <furq> i don't think it works at all on windows yet
[07:19:49 CET] <Diag> who uses linux
[07:21:03 CET] <furq> people who want to use vce with ffmpeg
[07:21:12 CET] <Diag> does it /actually/ work
[07:21:18 CET] <Diag> and is it /actually/ fast
[07:21:24 CET] <furq> no idea
[07:21:26 CET] <Diag> because handbrake had vce for a while
[07:21:30 CET] <furq> last i heard it had a pretty high chance of segfaulting
[07:21:35 CET] <Diag> and it was about tied with the cpu
[07:21:43 CET] <furq> why would you use vce with handbrake anyway
[07:21:52 CET] <Diag> because it was fast as fuck?
[07:22:00 CET] <furq> well yeah so is x264 ultrafast
[07:22:05 CET] <Diag> nah
[07:22:05 CET] <furq> they both suck
[07:22:11 CET] <Diag> fury x was much faster
[07:22:33 CET] <furq> handbrake implies you're encoding something where you give a shit about quality though
[07:22:45 CET] <furq> in which case all the consumer hardware encoders are useless
[07:22:47 CET] <Diag> it was actually pretty good quality
[07:22:53 CET] <Diag> and decent filesize
[07:23:08 CET] <Diag> +20% of x264 on slow, ran twice as fast or so
[07:23:20 CET] <furq> 20% is quite a lot
[07:23:22 CET] <Diag> comparing a i7-3820 @4.75 to a fury x
[07:23:36 CET] <Diag> Sure, but to get twice the speed out of it
[07:23:44 CET] <Diag> it /trumped/ x264 ultrafast
[07:23:59 CET] <furq> what cpu have you got where ultrafast isn't twice as fast as slow
[07:24:11 CET] <Diag> i just said, that was on a 3820
[07:24:22 CET] <Diag> i have not benched it on my 6850k yet
[07:25:12 CET] <Diag> anyways
[07:25:22 CET] <Diag> the point of vce was fast compression that was decent
[07:25:39 CET] <Diag> and it beat the cpu as far as speed/quality/size if you average it all
[07:26:22 CET] <Diag> in order to get similar visual quality (going by eye) x264 was on slow and vce was on quality
[07:26:30 CET] <Diag> i messed with it for an hour or two
[07:26:58 CET] <Diag> like i said though, that was on a fury x, it looks like shit and my 2600k was faster than it on my 7970
[07:27:01 CET] <Diag> no b frames, etc
[08:29:43 CET] <F00D> #mkv
[08:29:46 CET] <F00D> woops
[08:29:57 CET] <F00D> figures
[09:18:26 CET] <RiedFrice> Evenin' gents
[09:19:39 CET] <F00D> :/ well this is fun
[09:19:53 CET] <F00D> h264 > mkv is failing due to the h264 having no timestamp
[09:20:58 CET] <RiedFrice> Is it possible to copy the resolution of an input file when encoding it? I have a batch file encoding and piping a series of images bmp's, but it resizes them to 1920x1080 by default if I dont specify a resolution
[09:21:15 CET] <RiedFrice> *into bmp's
[09:21:50 CET] <F00D> have something determine the input size and use that as an arg for the rest of the batch?
[09:23:11 CET] <RiedFrice> F00D: But I'm trying to retain the original resolution of the images, not change them x-x
[09:24:11 CET] <F00D> RiedFrice, right. so get imagemagic to parse the first frame of the each set of BMPs to be done. It should have a way to get the resolution of the current ones.
[09:26:01 CET] <RiedFrice> F00D: Hmm alright, I'll give that a go. Thanks
[09:26:45 CET] <F00D> there might be a way to set ffmpeg to preserve the size but I'm not knowledgeable enough
[09:26:51 CET] <F00D> what are you encoding anyway
[09:31:20 CET] <RiedFrice> F00D: I'm making glitch art >.>
[09:31:32 CET] <F00D> ah ok
[09:32:13 CET] <RiedFrice> F00D: https://a.pomf.cat/dbpizv.bmp
[09:37:42 CET] <kerio> is that rick astley
[09:42:35 CET] <RiedFrice> kerio: Thats Fred Muthafuckin' Jones
[09:43:18 CET] Action: F00D screams internally
[09:43:27 CET] <F00D> Unfortunately the Haali Muxer cannot handle this source file.
[09:43:28 CET] <F00D> It doesn't contain enough seek/recovery points.
[09:43:38 CET] <F00D> every single muxer has some variation on this
[09:43:57 CET] <F00D> well aside from mkvmerge, that one just freaks out and eats ram until I kill it
[09:55:29 CET] <thebombzen> RiedFrice: is it supposed to look corrupted?
[09:55:32 CET] <thebombzen> cause it definitely does
[10:15:07 CET] <RiedFrice> thebombzen: Ye its supposed to
[10:19:21 CET] <RiedFrice> Its A R T
[10:19:45 CET] <F00D> you have got to be kidding me
[10:20:03 CET] <F00D> unseekable god damn file
[10:20:05 CET] <F00D> ahhhhh
[10:27:42 CET] <RiedFrice> F00D: Have you tried like, copying the input to a new file and seeing if that rebuilds the timestamps?
[10:27:51 CET] <RiedFrice> F00D: like ffmpeg -i input -c:v copy -c:a copy output
[10:28:12 CET] <F00D> that's what I'm doing...
[10:28:18 CET] <F00D> unless you mean h264 to h264
[10:30:09 CET] <squ> RiedFrice: nice pic
[10:30:30 CET] <RiedFrice> squ: thanks fam
[10:30:40 CET] <RiedFrice> F00D: Are you trying to copy the input into an mkv container?
[10:30:51 CET] <F00D> indeed
[10:31:03 CET] <F00D> give me a moment I'll just upload the file I'm working with
[10:31:39 CET] <F00D> https://p.fuwafuwa.moe/zonixk.h264
[10:31:40 CET] <RiedFrice> Alrighty
[10:32:40 CET] <RiedFrice> I'm no pro but I'll see what I can do, haven't messed around with that format before
[10:33:42 CET] <RiedFrice> F00D: fucking lol
[10:33:46 CET] <RiedFrice> nice meme
[10:34:25 CET] <F00D> it's just a file I had on hand that I could make a bad file out of
[10:35:41 CET] <F00D> http://pastebin.com/raw/uCQNMyXU
[10:36:04 CET] <F00D> wait wrong format
[10:36:26 CET] <RiedFrice> kek
[10:37:31 CET] <F00D> http://pastebin.com/raw/Agwz28Ki
[10:37:42 CET] <F00D> [matroska @ 000000000052e980] Timestamps are unset in a packet for stream 0. This is deprecated and will stop working in the future. Fix your code to set the timestamps properly
[10:37:43 CET] <F00D> [matroska @ 000000000052e980] Can't write packet with unknown timestamp av_interleaved_write_frame(): Invalid argument
[10:37:46 CET] <F00D> key issues there
[10:38:37 CET] <F00D> hmm I wonder if an old build would repair the stream
[10:39:35 CET] <RiedFrice> worth a try
[10:42:25 CET] <RiedFrice> Well, I get the error message "Access is denied."
[10:42:29 CET] <RiedFrice> o.O
[10:43:45 CET] <RiedFrice> nvm.
[10:47:17 CET] <furq> F00D: an h264 elementary stream doesn't have timestamps
[10:47:27 CET] <furq> it'll probably work if you set the input framerate
[10:47:31 CET] <furq> i.e. -framerate 30 before -i
[10:52:27 CET] <F00D> furq, nope
[10:55:25 CET] <furq> i meant -r, not -framerate, but that still doesn't work for mkv
[10:55:27 CET] <furq> works with mp4 though
[10:55:45 CET] <RiedFrice> http://pastebin.com/raw/k4DxDeSz
[10:56:24 CET] <RiedFrice> I doubt this is anything, but I notice adding "-f mkvtimestamp_v2" removes that error but makes it jump 557 frames in and only encodes one frame I think.
[10:56:43 CET] <F00D> furq, it works without -r too for mp4. The issue is that the track isn't seekable. Using mkvmerge you can get the file into an mkv but that mkv won't seek
[10:56:57 CET] <relaxed> "ffmpeg -h demuxer=h264" says -framerate
[10:57:40 CET] <F00D> is there any way to modify the elementary steam so it's seekable?
[10:57:55 CET] <furq> seeking works for me
[10:58:02 CET] <F00D> in an MKV?
[10:58:12 CET] <furq> and yeah -framerate exists for that demuxer, it just doesn't seem to do anything when muxing to mp4
[10:58:53 CET] <relaxed> isn't the framerate from the demuxer passed to the muxer unless you change it?
[10:59:17 CET] <F00D> yeah once you put the file into an mkv any attempt at seeking just restarts it
[11:02:14 CET] <furq> i don't have mkvmerge installed on this box so i can't comment on what that does
[11:02:16 CET] <furq> seeking works fine in mp4
[11:02:31 CET] <furq> and it wouldn't surprise me if muxing to mp4 and then remuxing to mkv worked fine
[11:02:52 CET] <furq> ffmpeg often doesn't get along well with elementary streams
[11:03:22 CET] <F00D> is there any way to repack an elementary stream into something else, adding whatever metadata ffmpeg likes
[11:03:33 CET] <furq> well yeah you can repack it into mp4
[11:04:33 CET] <F00D> that's just a wrapper around the h264 though, is there no way to add what I assume is SEI data.
[11:04:36 CET] <furq> also yeah, going ES -> mp4 -> mkv works fine
[11:04:41 CET] <furq> including seeking
[11:04:48 CET] <F00D> doesn't seek for me :/
[11:05:03 CET] <furq> are you sure your ES has more than one gop
[11:05:21 CET] <F00D> uh not sure how I'd know that
[11:05:27 CET] <F00D> also not sure what gop is
[11:05:31 CET] <furq> group of pictures
[11:05:35 CET] <furq> you can only seek to the start of a gop
[11:05:47 CET] <F00D> it should be open gop
[11:06:15 CET] <furq> is that even a thing with h264
[11:06:27 CET] <furq> either way i don't think it'd make a difference
[11:06:47 CET] <furq> if you only have one gop then you can't seek
[11:07:05 CET] <RiedFrice> I tried ffmpeg -r 30 -f h264 -i C:\Users\meme\shitpostpack.h264 -codec copy -f mp4 shitpostpack.mp4 and from that, to ffmpeg -i C:\Users\human_000\shitpostpack.mp4 -codec copy shitpostpack.mkv
[11:07:12 CET] <RiedFrice> Works but not seekable. And laggy.
[11:07:13 CET] <furq> i can't imagine any other reason why you wouldn't be able to seek after remuxing
[11:07:22 CET] <thebombzen> F00D: did you try using -vsync drop
[11:07:37 CET] <F00D> thebombzen, on which step?
[11:07:45 CET] <thebombzen> after -i
[11:07:55 CET] <thebombzen> with -c copy that is
[11:08:21 CET] <thebombzen> it causes ffmpeg to destroy the timestamps of the input video and regenerate them based on the framerate of the video stream
[11:08:57 CET] <thebombzen> you probably need -framerate or -r before -i otherwise how does it know what the actual framerate is
[11:09:01 CET] <F00D> doesn't work
[11:09:02 CET] <furq> F00D: ffprobe -v error -show_frames test.h264 | grep -c pict_type=I
[11:09:30 CET] <thebombzen> F00D: "doesn't work"
[11:09:32 CET] <thebombzen> be specific
[11:09:38 CET] <furq> assuming you have grep there
[11:09:51 CET] <F00D> I do not :<
[11:09:58 CET] <thebombzen> I mean ffmpeg -framerate 30 <other options> -i input -c copy -vsync drop output.mkv
[11:10:08 CET] <F00D> Timestamps are unset in a packet for stream 0. thebombzen
[11:10:26 CET] <thebombzen> full error and location?
[11:10:48 CET] <thebombzen> you know the drill. full output.
[11:11:04 CET] <furq> http://vpaste.net/EDJiv
[11:11:06 CET] <furq> hth
[11:11:18 CET] <thebombzen> wow vpaste is slowaf
[11:11:32 CET] <thebombzen> it still hasn't loaded
[11:11:35 CET] <F00D> yeah it's the error furq posted, same as I was having before
[11:11:40 CET] <furq> isn't there an outstanding bug for this
[11:11:51 CET] <furq> i'm sure there's a bug for which the solution is "remux it to mp4 first"
[11:12:00 CET] <furq> s/solution/workaround/
[11:12:24 CET] <thebombzen> did you try -fflags +genpts
[11:12:25 CET] <thebombzen> mightwork
[11:12:32 CET] <furq> it doesn't
[11:12:35 CET] <F00D> also tried
[11:12:36 CET] <F00D> doesn't work
[11:13:48 CET] <RiedFrice> same
[11:13:49 CET] <RiedFrice> http://pastebin.com/raw/xWchkkTS
[11:14:03 CET] <thebombzen> try remuxing in something like ts first
[11:14:12 CET] <thebombzen> sounds like a bug in the mkv muxer
[11:14:15 CET] <thebombzen> cause I feel like that should work
[11:14:21 CET] <thebombzen> what happens if you transcode it?
[11:14:22 CET] <F00D> I think mp4 is the correct way to do this
[11:14:25 CET] <furq> https://trac.ffmpeg.org/ticket/3339
[11:14:26 CET] <furq> nice
[11:14:48 CET] <F00D> I'm going to work on a larger file here and see if seeking works by doing h264>mp4>mkv
[11:14:48 CET] <furq> that's actually a different issue but the workaround is the same
[11:15:02 CET] <furq> F00D: -f lavfi -i testsrc=d=60 -c:v h264 out.h264
[11:15:06 CET] <furq> that's what i was testing with
[11:15:15 CET] <furq> -c:v libx264, rather
[11:15:19 CET] <thebombzen> that's weird
[11:15:28 CET] <F00D> furq, wait are you encoding it or copying it
[11:15:38 CET] <furq> well if i don't encode it it'll be rawvideo
[11:16:03 CET] <thebombzen> theoretically if you want to transcode it you could use -vf setpts=N/(30*TB)
[11:16:05 CET] <furq> testsrc is a source, it generates rawvideo
[11:16:08 CET] <thebombzen> but that requires you to transcode
[11:16:18 CET] <furq> i'm encoding that to an h264 es and then muxing that with -c copy
[11:16:19 CET] <F00D> transcoding isn't an option here
[11:16:35 CET] <thebombzen> I figured
[11:16:51 CET] <thebombzen> especially since you should be able to accomplish this anyway without doing it
[11:17:20 CET] <thebombzen> but doing ffmpeg -framerate 30 -i input -vsync drop output.mkv should work
[11:17:25 CET] <furq> yeah
[11:17:31 CET] <thebombzen> what happens if you put -fflags +genpts before -i?
[11:17:33 CET] <furq> i don't see why you'd even need -vsync drop tbh
[11:17:41 CET] <furq> let me try genpts again with vsync drop
[11:17:46 CET] <furq> it didn't work without it and i'm not optimistic
[11:17:49 CET] <thebombzen> cause vsync drop destroys timestamps and rewrites them
[11:17:56 CET] <thebombzen> according to "man ffmpeg" at least
[11:18:12 CET] <furq> http://vpaste.net/v4oRc
[11:18:13 CET] <furq> yup
[11:18:13 CET] <F00D> ugh ok the mp4 isn't seekable when doing this with a 26GB file
[11:18:28 CET] <furq> what ffmpeg version is that
[11:18:37 CET] <F00D> latest nightly
[11:18:40 CET] <mrAZ> i am looking for source of testing samples, different sub, audio, metadata, hd, changing aspect during play, just any possible problematic videos.
[11:18:41 CET] <furq> fun
[11:18:47 CET] <furq> that works fine here
[11:19:16 CET] <RiedFrice> mrAZ: https://samples.mplayerhq.hu/
[11:19:51 CET] <furq> also fwiw -framerate 30 doesn't work when muxing to mp4
[11:20:01 CET] <furq> not sure what the deal is there
[11:20:10 CET] <furq> it works with -r
[11:21:15 CET] <F00D> So I'm going to level here. I have a functional file I can mux to mkv and will seek just fine.
[11:21:32 CET] <furq> is the file an es
[11:21:36 CET] <F00D> The issue is it has x264 metadata and for various reasons the end file can't have that.
[11:22:27 CET] <furq> i'm sure they're very good reasons
[11:22:40 CET] <F00D> hardware decoder chokes
[11:22:44 CET] <furq> aww
[11:22:52 CET] <furq> i was hoping it wouldn't be the only good reason i've ever heard before
[11:23:19 CET] <furq> normally it's "so other l33t p2p groups can't steal my psy-rd settings!!"
[11:23:28 CET] <F00D> yeah no like I give a shit
[11:24:02 CET] <doebi> how do i concat multiple files?
[11:24:09 CET] <furq> so how did you demux this stream in the first place
[11:24:16 CET] <furq> doebi: https://trac.ffmpeg.org/wiki/Concatenate
[11:24:24 CET] <doebi> -i concat:file1|file2 yields "protocol not found"
[11:24:34 CET] <doebi> i only have avconv, not ffmpeg
[11:24:41 CET] <furq> oh dear
[11:24:49 CET] <furq> you should try to not have avconv any more
[11:24:53 CET] <F00D> furq, https://forum.doom9.org/showthread.php?t=152419
[11:24:54 CET] <thebombzen> darn
[11:24:57 CET] <furq> although you should use the demuxer anyway
[11:25:04 CET] <thebombzen> I prefer the concat filter
[11:25:11 CET] <furq> the filter is better if you're reencoding
[11:25:14 CET] <thebombzen> the demuxer is only useful if everything is the same
[11:25:17 CET] <furq> doebi: https://www.johnvansickle.com/ffmpeg/
[11:25:36 CET] <thebombzen> so I just tried to give it timestamps with -map syncing but to no avail
[11:25:48 CET] <furq> F00D: that's not what i asked but ok
[11:25:58 CET] <F00D> oh sorry what were you asking
[11:26:08 CET] <furq> how you demuxed it from the container it was in originally
[11:26:09 CET] <doebi> so, seriously the fix is to dump the more latest package provided from my system and install a custom built older version?
[11:26:11 CET] <thebombzen> I tried ffmpeg -framerate 30 -f h264 -i out.h264 -f lavfi -i 'nullsrc=d=60,setpts=N/(30*TB)' -c copy out.mkv
[11:26:21 CET] <furq> doebi: "older"?
[11:26:24 CET] <thebombzen> >older
[11:26:44 CET] <F00D> furq, uh you mean the x264 output?
[11:26:48 CET] <doebi> avconv is the predecesor of ffmpeg ( i am told)
[11:26:49 CET] <furq> what distro are you on which still provides libav in the newest version
[11:26:56 CET] <doebi> debian
[11:27:00 CET] <furq> and no, avconv is a short-lived fork
[11:27:07 CET] <thebombzen> so doebi here's the gist of ffmpeg vs avconv. a few years ago some devs forked ffmpeg and made "libav". Libav has avconv, FFmpeg has ffmpeg
[11:27:10 CET] <furq> oh yeah i forget that some people don't use debian testing
[11:27:16 CET] <RiedFrice> doebi: ffmpeg -f concat -safe 0 -i MyList.txt -codec h263p -f avi out.avi
[11:27:19 CET] <furq> but you can get real ffmpeg from jessie-backports
[11:27:32 CET] <RiedFrice> doebi: Try having the list.txt in the same location as ffmpeg
[11:27:34 CET] <furq> i'm told that causes some dependency fuckups though
[11:27:50 CET] <thebombzen> why the devs broke off and made Libav separate from FFmpeg is somewhat irrelevant nowadays
[11:28:19 CET] <furq> one of the people on the libav team also happened to be the debian ffmpeg maintainer
[11:28:20 CET] <thebombzen> whta does matter is that the FFmpeg project pulls patches made to Libav, but the other way around is not true
[11:28:24 CET] <furq> and so started three years of hell
[11:28:34 CET] <furq> or maybe two, i forget now
[11:28:46 CET] <furq> what's important is that debian testing is back on ffmpeg and so all of my boxes are too
[11:28:54 CET] <thebombzen> beacause of this, all the bugfixes and improvements in Libav immediately appear in FFmpeg
[11:29:01 CET] <thebombzen> but the other way around is not true
[11:29:02 CET] <doebi> ok, now installing ffmpeg from backports
[11:29:15 CET] <furq> doebi: you might be better off installing the static build
[11:29:21 CET] <doebi> sry, for not knowing the details about the libav fork and stuff
[11:29:26 CET] <furq> you don't need to uninstall libav
[11:29:32 CET] <thebombzen> it's fine. I happened to be there when it happened so I remember it
[11:29:41 CET] <JEEB> thebombzen: let's say there's about 800+ commits not merged for a few months now
[11:29:51 CET] <thebombzen> really? okay
[11:29:58 CET] <F00D> furq, I'm still not clear on what you were asking
[11:29:59 CET] <thebombzen> but I didn't realize that people still used LIbav
[11:30:00 CET] <furq> iirc some people have had other apps break because they installed ffmpeg from backports
[11:30:30 CET] <thebombzen> but either way, the Libav devs were salty after the fork (I mean that's why they forked - they were disatisfied) and printed misleading error messages in avconv
[11:30:33 CET] <furq> that's not an issue with the static build because it's static, you're not installing conflicting lib versions which other apps depend on
[11:30:50 CET] <thebombzen> if you had Libav installed and not FFmpeg and ram "ffmpeg" instead of "avconv" it would tell you that FFmpeg was deprecated
[11:30:58 CET] <thebombzen> this of course is not true. FFmpeg is not deprecated.
[11:31:07 CET] <doebi> ffmpeg works like a charm
[11:31:09 CET] <doebi> thanks, guys
[11:31:11 CET] <thebombzen> lol
[11:31:17 CET] <furq> we sure talk a lot
[11:31:39 CET] <furq> F00D: i don't think it really matters anyway
[11:31:40 CET] <JEEB> thebombzen: yeah, ffmpeg was deprecated in Libav because they did the avconv rework
[11:32:04 CET] <JEEB> FFmpeg merged those to ffmpeg of course
[11:32:07 CET] <thebombzen> I know the error message mades sense if you know the context
[11:32:16 CET] <thebombzen> but to users who didn't it was misleading
[11:32:35 CET] <F00D> furq, do you have any insight into a better way to strip that data to get a stream that will play and be seekable via that decoder?
[11:32:40 CET] <furq> not really
[11:32:54 CET] <furq> the x264 guys specifically don't support that
[11:33:06 CET] <F00D> they actually do
[11:33:15 CET] <F00D> there's an undocumented flag to turn it off
[11:33:34 CET] <F00D> these files would just take weeks to redo
[11:33:43 CET] <furq> huh
[11:33:44 CET] <furq> that's news to me
[11:33:51 CET] <JEEB> no, there is none. there's an unofficial patch for it.
[11:34:27 CET] <JEEB> i think the most you get is the stitchable option which I'm not aire it touches that sei
[11:34:30 CET] <F00D> oh perhaps it's that idk, either way it's possible to have a modern build that doesn't write it
[11:34:42 CET] <thebombzen> but yea speaking of Libav developer salt
[11:34:53 CET] <thebombzen> Michael Niedermeier is still banned from #libav-devel
[11:35:03 CET] <thebombzen> (he's the FFmpeg maintainer)
[11:35:10 CET] <JEEB> anyways there's other ways to find out it's x264 but you can just remove that sei :p
[11:35:18 CET] <furq> i thought michael niedermayer was the ffmpeg maintainer
[11:35:20 CET] <JEEB> that's the simplest way :p
[11:35:35 CET] <furq> neidermeier probably got banned for being an impostor
[11:35:38 CET] <F00D> JEEB, but how is it removed?
[11:35:58 CET] <F00D> the current thing I'm doing produces a fairly unworkable file
[11:35:58 CET] <JEEB> like any other nal unit
[11:36:14 CET] <JEEB> yes because you probably break something
[11:36:42 CET] <F00D> yeah so I don't know how nal units are typically dealt with
[11:36:47 CET] <furq> have you considered just buying a new hardware player
[11:36:50 CET] <furq> it sounds like it'd be less effort
[11:37:14 CET] <F00D> furq, let me just get a few thousand of those ordered at ~300 USD each
[11:37:31 CET] <furq> i guess that's borderline then
[11:37:35 CET] <F00D> lol
[11:40:56 CET] <thebombzen> https://github.com/haasn/mpvhq-old/wiki/FFmpeg-versus-Libav
[11:41:06 CET] <thebombzen> somewhat old (1.5 years) but it's the gist of things
[11:43:57 CET] <F00D> JEEB, before I run off can you point me in the direction of info about stripping it out? I've not done any work with NAL before
[11:47:11 CET] <thebombzen> F00D: stupid question
[11:47:19 CET] <thebombzen> did you try -bsf h264_mp4toannexb?
[11:47:39 CET] <F00D> I've not no
[11:47:53 CET] <thebombzen> nvm I just tried it and it didn't do anything
[11:47:54 CET] <thebombzen> worth a try haha
[11:48:36 CET] <F00D> I've tried remove_extra however and that doesn't work
[11:53:09 CET] <thebombzen> lol I have to get to bed
[11:53:30 CET] <thebombzen> I have class in four hours
[11:53:53 CET] <thebombzen> you jerks keeping me up wasting my time talking bout computers
[11:54:03 CET] <thebombzen> I could just like skip class but I actually like this class
[11:54:35 CET] <thebombzen> in four hours I have my class in Mathematical Logic
[11:54:56 CET] <thebombzen> I technically could skip it, but not really much benefit because the class right after it is mandatory
[11:55:06 CET] <thebombzen> which is stupid because we haven't done anything
[11:55:48 CET] <thebombzen> I'm taking Mathematical Logic, Algebraic Combinatorics, as well as a linguistics and a philosophy class #humanitiesdistribution
[12:01:47 CET] <kerio> mathematical logic is cool
[12:01:51 CET] <kerio> but i doubt you'll go into much detail
[12:01:58 CET] <kerio> and the details are what's important, in formal systems
[12:06:22 CET] <RiedFrice> pipe rawvideo inside of my uncompressed decoder Senpai
[12:13:00 CET] <daslicht> hi is it normal that if you convert a mp4 to ogv, webm the latter both have a different color balance ?
[12:14:56 CET] <ritsuka> there could be a lot of reasons
[12:15:30 CET] <ritsuka> the video format might not signal the right color space, the player could be broken, ecc&
[12:19:48 CET] <doebi> what codec and settings would you suggest for a webm embedded in a website? (ie. minimal file size)
[12:46:00 CET] <mosb3rg> vpX is generally used for webm
[12:46:08 CET] <mosb3rg> latest
[13:01:56 CET] <daslicht> ritsuka: thanks , we a analysing :)
[13:02:01 CET] <daslicht> re
[13:04:14 CET] <ritsuka> daslicht: where are you seeing different colors? in which player/browser?
[13:04:41 CET] <daslicht> a customer complaied that they get different colors
[13:05:06 CET] <daslicht> but as far as we can see it s the source video , which already 'toggles ' colors
[13:12:12 CET] <mrAZ> is it actually possible to join several files with different resolution? i tried with ffmpeg -i concat:"1.mp4|2.mp4|3.mp4" -acodec copy 3out.mp4, but how do i verify that? it looks like output has only one resolution.
[13:12:29 CET] <furq> it's probably just the first file
[13:12:35 CET] <furq> you'll presumably need to use the scale and concat filters
[13:16:28 CET] <mrAZ> furq: even if files 1.mp4 2.mp4 and 3.mp4 are already scaled?
[13:16:57 CET] <furq> you just said they were different resolutions
[13:17:58 CET] <furq> you don't need scale if they're the same
[13:18:51 CET] <mrAZ> they are different and i want them different. for player testing purpose.
[13:19:06 CET] <furq> well you can't concat them then
[13:23:06 CET] <mrAZ> if i just cat them together, i get same Duration with 3 Stream  Video and 3 Stream Audio
[13:32:58 CET] <tommy``> hi, it's possible extract from an mkv the timecodes and relative timestamp?
[13:53:15 CET] <tommy``> ffmpeg -i "rtv.mkv" -f ffmetadata file.txt give me an empty .txt, why?
[13:53:22 CET] <karchnu> hello, I searched to perform unix-like audio (audio with pipes), such as "(get audio from any source) | volume 80 | saturation 30 | reverb 5 > /dev/audio0" but I found no project like this, so I started to do "ffmpeg -i INPUT -f s16le -acodec pcm_mulaw - | ffmpeg -f s16le -acodec pcm_mulaw -i - blah.mp3" and when I play my mp3 file I have to speed 2x the audio to get it right, what I am doing wrong ? After
[13:53:24 CET] <karchnu> that I will implement few programs like "volume", "saturation" and such, but right now I need to know why this audio is 2x slower than expected.
[13:55:12 CET] <karchnu> full disclosure: I don't have strong audio engineering background. Still, I like to dream.
[13:58:39 CET] <mrAZ> i have such a file, it is switching 4:3 and 16:9. forgot how i made it.
[13:59:19 CET] <mrAZ> i try to experiment more, not mp4 but ts, maybe format is a problem.
[14:52:48 CET] <Mavrik> mrAZ, can you explain more what the issue is?
[15:29:14 CET] <libertyernie> This might not really be an ffmpeg question, but is there a way to submit a patch to rtmpdump (https://git.ffmpeg.org/rtmpdump)? Their mailing list seems to be broken (emails not going through.)
[15:36:52 CET] <bittin> o/
[15:40:50 CET] <tommy``> ffmpeg -i file.mkv -vf blackdetect=d=1:pix_th=0.00 -f null NUL <------ why this command doesn't detect a black frame @ 16 minutes ?
[15:44:24 CET] <durandal_170> tommy``: because of wrong options you gave
[15:44:41 CET] <tommy``> the frame it's about 2 secs
[15:44:56 CET] <tommy``> i choose the options from documentation
[15:45:15 CET] <mrAZ> Mavrik: i am trying to make file where resolution and aspect is changing. it is for testing of player. not practical use.
[15:48:00 CET] <tommy``> ( durandal_170 ): you mean to change the threshold from 0.00 to 0.10 ?
[15:48:51 CET] <durandal_170> tommy``: depends how much black is your black
[15:49:03 CET] <tommy``> ( durandal_170 ): pitch black
[15:49:24 CET] <tommy``> ( durandal_170 ): it's a chapter transition
[15:49:36 CET] <durandal_170> see it with signalstats
[15:49:50 CET] <durandal_170> thats another filter
[15:50:13 CET] <durandal_170> it reports luma max and min for each frame
[15:50:44 CET] <tommy``> you mean this https://ffmpeg.org/ffmpeg-filters.html#signalstats-1 ?
[15:52:12 CET] <durandal_170> yes
[15:52:40 CET] <tommy``> ok
[15:53:08 CET] <durandal_170> or use datascope filter it will display hex values used in picture
[15:54:49 CET] <tommy``> i have to do step by step, i'm newbie, that's too much for me :D
[15:56:59 CET] <tommy``> ( durandal_170 ): black_start:375.2 black_end:377.16 ---> those values are in seconds right?
[15:57:23 CET] <durandal_170> yes
[15:57:47 CET] <tommy``> how can i convert in minutes in video?
[15:57:55 CET] <tommy``> 375/60 ?
[15:58:18 CET] <durandal_170> yes, how old are you?
[15:58:33 CET] <tommy``> why my age concern this?
[15:58:55 CET] <durandal_170> calculating minutes from seconds
[15:59:19 CET] <tommy``> so my age is relevant?
[15:59:51 CET] <durandal_170>  not for calculating/math
[16:00:29 CET] <tommy``> for what is relevant?
[16:00:44 CET] <durandal_170> you need to not forget remaining seconds
[16:01:30 CET] <durandal_170> seconds% 60
[16:01:44 CET] <durandal_170> modulo operator
[16:03:06 CET] <tommy``> k tnx
[17:23:05 CET] <Nanashi> Anyone knows the commands youtube uses to process videos?
[17:23:53 CET] <ikevin-> i think youtube don't use ffmpeg :x
[17:26:09 CET] <Diag> Any yall seen dont be a menace
[17:29:34 CET] <kerio> youtube uses ffmpeg yea
[17:33:38 CET] <JEEB> Nanashi: you under no circuimstance want to copy what youtube is doing
[17:33:39 CET] <JEEB> just saying
[17:33:42 CET] <kerio> LOL
[17:34:00 CET] <Nanashi> just for uh, comparison's sake
[17:34:14 CET] <kerio> it's some ffmpeg from 2011 or so
[17:34:52 CET] <JEEB> and I'm not even saying this because I'd want a system to use slower settings. it's just pants-on-head kind of stuff that is optimized for their exact use case and stuff that has nothing to do with you
[17:34:52 CET] <kerio> at least for the ingets
[17:34:55 CET] <kerio> ingest
[17:35:12 CET] <kerio> also, they keep the source material
[17:35:15 CET] <kerio> so they can change encodings
[17:35:26 CET] <kerio> see all the very old videos that are available in vp9/opus
[17:39:54 CET] <Diag> kerio: what does youtube use now?
[17:40:14 CET] <kerio> vp9/opus for chrome and h264/aac for iphone i think
[17:40:28 CET] <kerio> or maybe vp8?
[17:40:34 CET] <Diag> huh
[17:40:37 CET] <kerio> the vpX that roughly matches h264
[17:40:41 CET] <Diag> ive always thought youtube looked quite alright
[17:43:57 CET] <root-x> Hi. i create a file m3u8  -segment_list_size 10 with mp4 files... you recomend me a video streamer for html5?
[17:44:06 CET] <kerio> Diag: ye they're using vp9
[17:44:56 CET] <Diag> http://www.ebay.com/itm/Radeon-R9-280-HD-7950-Graphics-Card-w-fan-upgrade-for-mining-gaming-video-/262783827808?&_trksid=p2056016.l4276
[17:44:59 CET] <Diag> "fan upgrade"
[17:45:01 CET] <Diag> whoops wrong channel
[19:01:23 CET] <Miyagui> Hello !
[19:01:44 CET] <Diag> yo
[19:01:53 CET] <Diag> whats poppin dawg
[19:07:45 CET] <Miyagui> i'm ok . i start working with ffmpeg
[19:08:07 CET] <Miyagui> and i think that is cool to join here
[19:08:11 CET] <Miyagui> :)
[19:08:30 CET] <Diag> ehhh, the x264 people are cooler
[19:08:38 CET] <Diag> :P
[19:09:52 CET] <Miyagui> lol
[19:10:22 CET] <Miyagui> i am from Argentina so sorry for my english :3
[19:11:49 CET] <Diag> Ha, well you know what they say
[19:11:55 CET] <Diag> skeezer and booket XD
[19:14:36 CET] <Miyagui> :p
[19:14:54 CET] <Miyagui> Any experience with ffmpeg in Android?
[19:15:02 CET] <Diag> nope
[19:15:11 CET] <Diag> wait, encoding FOR android or ON android
[19:15:55 CET] <Miyagui> on android  , i use  the ffmpeg library for android and i am running a command to resize video
[19:16:01 CET] <Miyagui> but it's taking too long
[19:16:18 CET] <Diag> yeah well, its a mobile phone, not a rocket shit
[19:18:16 CET] <Miyagui> well ok xD
[19:18:31 CET] <Miyagui> but a 3 second video takes 30 seconds to resize
[19:18:33 CET] <Miyagui> wat
[19:18:38 CET] <Diag> sounds about right
[19:19:37 CET] <Miyagui> yes? oh ok
[19:19:55 CET] <Diag> Miyagui: well think about how much faster your computer is than your phone
[19:20:07 CET] <Diag> my phone has a "2.7ghz quad core" processor
[19:20:15 CET] <Diag> but its basically risc
[19:20:25 CET] <Diag> and you have no idea how many cycles things take
[19:20:26 CET] <Diag> etc
[19:20:54 CET] <Miyagui> yes sure , maybe i need to give some quality in exchange of some speed
[19:21:04 CET] <Diag> heh
[19:21:36 CET] <Miyagui> thanks , i will test it :)
[19:21:53 CET] <Miyagui> i will be here for a while lol
[20:37:03 CET] <shincodex> How to disable YASM-OBJS
[20:37:20 CET] <shincodex> cant find idctdsp.o linker error
[20:37:33 CET] <shincodex> rather
[20:38:35 CET] <shincodex> It exists and ff_init_scantable_permutation is in the object file
[20:38:45 CET] <shincodex> But linker thinks its unresolved
[20:58:05 CET] <Nanashi> eh windows ffmpeg doesn't come with ff-prompt.bat anymore
[20:58:56 CET] <shincodex> Wtf?
[20:59:01 CET] <shincodex> Who the hell uses a batch
[20:59:13 CET] <shincodex> im almost at the pinacle of Blowing the fucking make file away
[20:59:23 CET] <shincodex> and making a visual studio project for it
[20:59:35 CET] <shincodex> almost.... there
[20:59:57 CET] <shincodex> I think my problem is RM was not cleaning up my .o and it was using olds
[21:00:05 CET] <shincodex> Probably not that would be awesome if it was that
[21:00:32 CET] <Nanashi> all the prompt does is set path to ./bin lol
[21:00:42 CET] <shincodex> but I will say
[21:00:46 CET] <shincodex> Im glad its not using cmake
[21:01:03 CET] <shincodex> failed
[21:01:24 CET] <shincodex> The reason its failing is im trying to make it build debug msvc correctly
[21:01:44 CET] <shincodex> 		bash ./configure --toolchain=msvc --enable-pic \ 				--disable-everything --disable-sdl --disable-avdevice --disable-swresample --disable-postproc --disable-avfilter \ 				--enable-parser=mjpeg --enable-decoder=mjpeg --enable-demuxer=mjpeg --enable-demuxer=smjpeg --enable-muxer=mjpeg \ 				--enable-parser=h264 --enable-decoder=h264 \ 				--enable-demuxer=rtsp \ 				--enable-protocol=http --enable-protocol=httpproxy --enable-prot
[21:02:01 CET] <shincodex> oh what a shame
[21:02:04 CET] <shincodex> it cut off my string
[21:02:29 CET] <shincodex> --disable-optimizations --disable-asm
[21:02:33 CET] <shincodex> those are probably important
[21:03:30 CET] <shincodex> here is a sample cl
[21:03:31 CET] <shincodex> cl -I. -I./ -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_WIN32_WINNT=0x0502 -DPIC -DHAVE_AV_CONFIG_H -nologo -D_USE_MATH_DEFINES -D_CRT_SECURE_NO_WARNINGS -Dinline=__inline -FIstdlib.h -Dstrtoll=_strtoi64   -MDd -Z7 -W0    -Od -DDEBUG   -c -Folibavutil/display.o libavutil/display.c
[21:04:41 CET] <shincodex> huh
[21:04:51 CET] <shincodex> the hell... it looks like its trying to turn everything on that i dont have
[21:04:59 CET] <shincodex> or link in encoders... i dont need this noise
[21:07:57 CET] <JEEB> so you enable the AVC decoder but kill off all SIMD?
[21:08:26 CET] <JEEB> unless you have some very specific use case for that I'm going to say that's a very bad idea
[21:09:46 CET] <shincodex> Your saying leave the yasm in
[21:10:27 CET] <shincodex> No. Im running into debug /MDd and /MD issue
[21:11:02 CET] <shincodex> so getting that on, i then ran into basically 1100 undefined symbols
[21:13:12 CET] <JEEB>  /MD is tested by nev at least, MDd I haven't seen but I would guess you don't need much more than --extra-cflags="-MDd" instead of --extra-cflags="-MD" which nev uses in his test builds
[21:13:35 CET] <JEEB> http://fate.ffmpeg.org/ and ctrl+f "microsoft"
[21:13:39 CET] <shincodex> its worse than that
[21:13:59 CET] <JEEB> here's the configure line for the latest shared one http://fate.ffmpeg.org/report.cgi?time=20170102134638&slot=x86_32-msvc14-dll-md-windows-native
[21:14:02 CET] <shincodex> ill pull it up
[21:14:11 CET] <JEEB> just use pastebins for anything longer :P
[21:14:43 CET] <JEEB> also if you are testing, I deeply recommend doing out-of-tree builds so you can just poof your build dir instead of the source dir
[21:15:12 CET] <JEEB> although `git clean -dfx && git reset --hard HEAD` will kill everything nearby in the source repository
[21:15:52 CET] <shincodex> http://pastebin.com/YmtEnCTA
[21:15:57 CET] <shincodex> Look at if enabled debug
[21:16:07 CET] <shincodex> that wasnt in there it used to be replace fpic with -MD
[21:16:21 CET] <shincodex> Also,
[21:17:21 CET] <JEEB> also I think the "enabled debug" means "--enable-debug" is set?
[21:17:41 CET] <shincodex> Really cause when I scan the whole configure
[21:17:50 CET] <shincodex> I don't see it hooked up to anything
[21:18:06 CET] <JEEB> plus, you can thus just stop setting --enable-pic and instead use --extra-cflags="-MD" or "-MDd"
[21:18:17 CET] <shincodex>        --enable-debug=*)             debuglevel="$optval"
[21:18:25 CET] <JEEB> right
[21:18:36 CET] <shincodex> hmm ... i cant remember where version is anymore
[21:18:49 CET] <shincodex> FFMPEG released version I have my own copy of it not tied to source control
[21:18:50 CET] <JEEB> so which one of those are you trying to build?
[21:18:52 CET] <JEEB> MD or MDd?
[21:18:57 CET] <shincodex> MDd
[21:18:59 CET] <shincodex> MD is fine
[21:19:16 CET] <JEEB> ok, let's see if I can follow what the FATE station is doing and build shared with -MDd
[21:19:39 CET] <JEEB> since you seem to have issues with that
[21:19:40 CET] <shincodex> My release version takes libswscale, libavformat avcodec avutil static links them all into a wrapper
[21:19:50 CET] <shincodex> and its one DLL
[21:19:59 CET] <shincodex> That version is fine
[21:20:50 CET] <JEEB> also I see the FATE stations do --extra-ldflags='-NODEFAULTLIB%3alibcmt' but I've no idea what the hell that is supposed to be doing because a normal static build just finished fine without that
[21:21:55 CET] <shincodex> I did have a issue with that earlier but thats gone now
[21:21:59 CET] <JEEB> but yeah, MSVC --enable-shared --disable-static --extra-cflags="-MDd" going
[21:22:12 CET] <JEEB> since that seems to be what you're having issues with?
[21:22:45 CET] <shincodex> Well here is bizarre part
[21:22:46 CET] <shincodex> ff_yuv2rgb_init_tables_ppc
[21:22:53 CET] <shincodex> Im not using a ppc processor lol
[21:23:03 CET] <shincodex> Assuming its code tailored towards ppc
[21:23:19 CET] <JEEB> I wonder if what --disable-optimizations does with MSVC disables dead code elimination
[21:23:29 CET] <JEEB> because it sounds like that :P
[21:23:30 CET] <BtbN> are you building with optimizations disabled, or some compiler that doesn't support Dead Code Elimination.
[21:23:46 CET] <JEEB> yeah, he had disable-optimizations there :P
[21:24:17 CET] <shincodex> If those functions are exported at headers
[21:24:22 CET] <shincodex> it wont be considered dead code
[21:24:35 CET] <shincodex> allcodecs.o
[21:24:35 CET] <shincodex> hmmm
[21:24:38 CET] <shincodex> allformats.o
[21:24:55 CET] <shincodex> all*.o is a majority of complains
[21:25:19 CET] <JEEB> ok, my enable-shared, disable-static, extra-cflags="-MDd" worked JustFine
[21:25:39 CET] <shincodex> So your thinking
[21:25:55 CET] <shincodex> drop --disable-optimizations
[21:26:20 CET] <JEEB> yes, and instead use --extra-cflags to set some optimization mode that has dead code elimination if you want a less optimized binary
[21:26:22 CET] <shincodex> im gonna try it i suppose
[21:26:39 CET] <JEEB> (for debug or whatever reasons)
[21:27:15 CET] <JEEB> also if you're using MSVC 2015U3 I recommend you apply the hotfix that fixes MS's new optimizer
[21:27:31 CET] <JEEB> https://support.microsoft.com/en-us/kb/3207317
[21:27:33 CET] <shincodex> When you say new
[21:27:35 CET] <shincodex> how new lol
[21:27:55 CET] <JEEB> new as in which they suddenly popped in 2015U3
[21:28:02 CET] <JEEB> which was totally a Great Idea
[21:28:12 CET] <JEEB> FFmpeg disables it currently automagically though
[21:28:28 CET] <shincodex> 12/19/2016
[21:28:31 CET] <shincodex> what the crap
[21:28:42 CET] <JEEB> there's a patch in the mailing list to re-enable it if you have that hotfix installed
[21:29:00 CET] <JEEB> because the FFmpeg test suite once again passes after that hotfix
[21:29:13 CET] <shincodex> now i know why i did disable opt
[21:29:14 CET] <shincodex> 1>cl : Command line warning D9025: overriding '/O2' with '/Od'
[21:29:16 CET] <shincodex> yuck
[21:29:28 CET] <JEEB> wat
[21:29:36 CET] <shincodex> Then again if you just see cc vorbis_parser.c
[21:29:44 CET] <shincodex> youll be alright and everything will be fine
[21:30:15 CET] <JEEB> uhh, I can grep my logs but I don't think I saw it overriding the level like that :P
[21:30:29 CET] <shincodex> older version
[21:30:34 CET] <shincodex> somewhere last year
[21:32:37 CET] <JEEB> but yeah, I've tried both static and shared builds with MSVC, even with extra-cflags="-MDd" and it JustWorked, so your problem comes from something specific to what you're doing.
[21:34:15 CET] <shincodex> ahh found it
[21:34:25 CET] <shincodex> thats my copy
[21:34:33 CET] <shincodex> but i wasnt looking for that specifically anymore
[21:35:23 CET] <JEEB> that's unfortunately not very specific, so I would recommend you tag your things that you use
[21:37:40 CET] <shincodex> Hmm
[21:38:05 CET] <shincodex> DEBUG is a known define used in windows and I dont really know if its reserved like it is in linux
[21:38:22 CET] <shincodex> NDEBUG is for release related versions
[21:38:39 CET] <JEEB> I think those relate to these, right? https://msdn.microsoft.com/en-us/library/2kzt1wy3.aspx
[21:38:40 CET] <shincodex> is there perhaps a different meaning for these defines in ffmpeg?
[21:38:42 CET] <rozag> Hi everyone! I've got a task to draw frame-by-frame a video on an Android. And it looks like ffmpeg is the best choice for the task. I'm not very familiar with it, so maybe you can help me with an advice? What parts of it should I take a look at or what docs to read first?
[21:39:03 CET] <JEEB> which you can control with --extra-cflags="-MDd" or "-MTd"
[21:39:32 CET] <JEEB> rozag: I recommend you look into libraries that utilize android in the background
[21:39:47 CET] <JEEB> unless you want the raw YCbCr data and like masochism
[21:40:09 CET] <JEEB> libvlc and libmpv are two examples of a library that wraps (among other things) FFmpeg's libraries
[21:40:32 CET] <JEEB> if you want a wrapper to just get the decoded pictures, something like libffms2 is for you
[21:41:31 CET] <shincodex> Deleted my configure edits
[21:41:37 CET] <shincodex> and trying --extra-cflags="-MDd -Od"
[21:43:12 CET] <shincodex> this lol
[21:43:13 CET] <shincodex> EFINES -D_CRT_SECURE_NO_WARNINGS -Dinline=__inline -FIstdlib.h -Dstrtoll=_strtoi64 -MDd -Od    -Z7 -W0 -O2
[21:43:16 CET] <JEEB> also one of my recommendations is to use out-of-tree compilation (I think mentioned that already) so if you f.ex. have the FFmpeg sources in ffmpeg/ and then you make a directory called msvc_build next to it, you can then do ../ffmpeg/configure to call the configure script and it will work (unless you have already configured in that one)
[21:43:29 CET] <JEEB> and thus when you switch your configuration you can either just switch to another build dir
[21:43:30 CET] <shincodex> 1>cl : Command line warning D9025: overriding '/Od' with '/O2'
[21:43:33 CET] <shincodex> NOOOOOO!
[21:43:35 CET] <JEEB> or you can wipe and re-create
[21:43:39 CET] <shincodex> i gotta stop that from happening
[21:44:02 CET] <BtbN> msvc is not exactly good at keeping track of object files. Anything but a clean build from an empty build tree is risky.
[21:44:29 CET] <shincodex> agree
[21:44:34 CET] <JEEB> that's kind of why I was recommending out-of-tree builds, because it makes nuking things from the orbit quite simple
[21:44:43 CET] <shincodex> Linker problem gone
[21:44:49 CET] <BtbN> git clean -fxd also gets the job done
[21:44:51 CET] <shincodex> but now I have the O2 problem
[21:44:59 CET] <JEEB> BtbN: yeah I noticed that too
[21:44:59 CET] <BtbN> just make sure there's nothing important in the source tree
[21:45:05 CET] <shincodex> 1>  cl -I. -I./ -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_WIN32_WINNT=0x0502 -DPIC -DHAVE_AV_CONFIG_H -nologo -D_USE_MATH_DEFINES -D_CRT_SECURE_NO_WARNINGS -Dinline=__inline -FIstdlib.h -Dstrtoll=_strtoi64 -MDd -Od    -Z7 -W0 -O2     -c -Folibavutil/xtea.o libavutil/xtea.c
[21:45:07 CET] <JEEB> s/noticed/mentioned/
[21:45:13 CET] <shincodex> You see the -O2
[21:45:23 CET] <shincodex> I need to place Od at the end without editing configure script
[21:45:33 CET] <JEEB> `git clean -dfx && git reset --hard HEAD`
[21:45:34 CET] <shincodex> Is there osmething im not aware of like extra_extra_flags
[21:45:59 CET] <JEEB> shincodex: hmm, I would have thought -Od which was an extra cflag would come after -O2...
[21:46:02 CET] <JEEB> but what do I know
[21:46:58 CET] <shincodex> It mystically replaced MD
[21:47:01 CET] <shincodex> That part i dont get
[21:47:30 CET] <JEEB> also in the latest code unsurprisingly Od support was removed
[21:47:35 CET] <JEEB> because of the dead code emulation thing
[21:47:45 CET] <JEEB> at least git grep "Od" returns nada
[21:48:17 CET] <JEEB> s/emulation/elimination/
[21:48:39 CET] <shincodex> Now hold up
[21:48:41 CET] <shincodex> my problem is solved
[21:48:47 CET] <shincodex> Im not really debugging ffmpeg
[21:49:00 CET] <shincodex> I just need the CRT to pick same one to stop access violations
[21:49:02 CET] <shincodex> i might be done here
[21:49:47 CET] <JEEB> so you defined MD in extra-cflags but MDd was picked?
[21:50:08 CET] <JEEB> oh, nope
[21:50:11 CET] <JEEB> you set -MDd there
[21:50:21 CET] <JEEB> and -MDd was on the command line
[21:50:53 CET] <JEEB> but yeah, as MS itself says dead code elimination is disabled with Od and FFmpeg doesn't build with it disabled
[21:51:10 CET] <JEEB> which is why you don't get Od with disable-optimizations
[21:51:12 CET] <JEEB> any more
[21:53:54 CET] <shincodex> It worked
[21:54:06 CET] <JEEB> well, there you go
[21:54:14 CET] <shincodex> But hold on a second
[21:54:22 CET] <shincodex> Dead code is generally eliminated from linker
[21:54:34 CET] <shincodex> And it wont do squat without /OPT:REF /OPT:ICF
[21:54:40 CET] <JEEB> compiler also
[21:54:41 CET] <JEEB> https://blogs.msdn.microsoft.com/vcblog/2013/08/09/optimizing-c-code-dead-code-elimination/
[21:54:56 CET] <shincodex> well
[21:54:57 CET] <JEEB> Optimizing C++: dead code elimination. and that uses simple cl commands
[21:55:18 CET] <shincodex>  CL /Od /FA Sum.cpp
[21:55:23 CET] <shincodex> yeah but hes linking in here
[21:55:32 CET] <shincodex> I think thats /FA
[21:55:32 CET] <JEEB> so whichever part of cl it is, it's not doing dead code elimination in there with Od
[21:55:34 CET] <shincodex> one sec
[21:55:47 CET] <shincodex> and if you think about it
[21:55:56 CET] <shincodex> you make a static lib just a library of... well object files
[21:56:03 CET] <JEEB> yes
[21:56:22 CET] <shincodex> So thats interesting
[21:56:30 CET] <shincodex> Why doesnt ffmpeg build without dead code
[21:56:39 CET] <shincodex> it should be able to...
[21:56:45 CET] <JEEB> because in various places it uses if (this_never_happens)
[21:56:49 CET] <shincodex> I mean with dead code
[21:57:01 CET] <shincodex> But that shouldn't stop the compiler
[21:57:04 CET] <JEEB> instead of #ifdef THIS_NEVER_HAPPENS_ON_YOUR_ARCH
[21:57:11 CET] <shincodex> even a if(0) {
[21:57:21 CET] <shincodex> Oh hah
[21:57:24 CET] <shincodex> You know what
[21:57:26 CET] <shincodex> IF YOU DO THAT
[21:57:34 CET] <shincodex> like if(0) { ppccode } instead of what you said
[21:57:35 CET] <shincodex> lol
[21:57:45 CET] <shincodex>  /wrist is all I have for that
[21:58:06 CET] <JEEB> well yeah, I'm pretty sure there's plenty of in-ifdef stuff
[21:58:19 CET] <JEEB> but there's some if (define-set-to-zero-with-your-arch) {} stuff
[21:58:25 CET] <JEEB> which requires dead code elimination
[21:58:33 CET] <shincodex> Someone should get on that.... someday
[21:58:34 CET] <JEEB> which is why you end up with that swscale ppc thing
[21:58:46 CET] <JEEB> I think there was a discussion on that on the mailing list
[21:58:47 CET] <shincodex> So lets go way back
[21:59:14 CET] <shincodex> The real root of this was I required optimizations too allow the if(Archs) to take a hike
[21:59:25 CET] <shincodex> And I had access violation cause of mix MD MDd
[21:59:38 CET] <shincodex> naturally when one debugs they will use MDd and Od
[22:00:05 CET] <JEEB> well, Od is not really that required but that is indeed the least optimized binary you can get
[22:00:06 CET] <shincodex> release is MD O2 or Ox in msvc or flto.... maybe and O3 in linux
[22:00:11 CET] <shincodex> or you can do o2 i guess
[22:01:16 CET] <JEEB> https://ffmpeg.org/pipermail/ffmpeg-devel/2016-December/204530.html
[22:01:22 CET] <JEEB> this was related to DCE requirement in FFmpeg
[22:01:35 CET] <JEEB> where it was last discussed that is
[22:02:41 CET] <shincodex> heh
[22:06:29 CET] <shincodex> if(0)
[22:06:40 CET] <shincodex> I have a coding standard where I got nix that kind of code
[22:06:42 CET] <shincodex> or #if 0
[22:06:46 CET] <JEEB> of course the zero itself is a define :)
[22:06:51 CET] <JEEB> so it depends on your arch
[22:06:52 CET] <shincodex> Thou shall have defines that mean something
[22:06:54 CET] <JEEB> if it's zero or not
[22:07:08 CET] <shincodex> Thou shall not check in dead code on purpose
[22:07:43 CET] <JEEB> but yeah, for now at least we have DCE-using code
[22:07:58 CET] <JEEB> so compilers that disable dead code elimination will barf
[22:08:14 CET] <shincodex> MSVC and GCC arnt those compilers
[22:08:23 CET] <shincodex> arm x86 x64 mips... lol
[22:08:32 CET] <shincodex> Actuatelly I'm not sure about mips i didnt try with that processor
[22:08:45 CET] <shincodex> but i did do opencv with it and I barfed at how slow it went
[22:09:01 CET] <JEEB> well yeah, slowness is something different but GCC on all of those seems to build FFmpeg OK
[22:09:09 CET] Action: JEEB has built FFmpeg for the PSP
[22:09:24 CET] <JEEB> (yes, the portable MIPS console by Sony)
[22:09:29 CET] <shincodex> Oh heh
[22:09:33 CET] <shincodex> I didnt know it used mips
[22:09:39 CET] <shincodex> Did it have a floating point processor
[22:09:47 CET] <shincodex> Cause the one I had DIDNT
[22:09:56 CET] <JEEB> yea, that just means even more slowness
[22:10:02 CET] <shincodex> and they were like hue hue hueh ueh ueh ue TEEHEE USE FIXED POINT
[22:10:06 CET] <shincodex> NOPE!
[22:10:28 CET] <JEEB> in my case I think it just lacked virtual memory because you had to use uclinux if you wanted to play around linux
[22:10:54 CET] <shincodex> was your psp homebrew use
[22:11:18 CET] <JEEB> yeah, I started poking around homebrew right from '05 or so, first by using stuff and then compiling stuff myself
[22:11:36 CET] <shincodex> I made a sprite move around collide with screen and that was it
[22:11:40 CET] <shincodex> then threw it all out
[22:12:06 CET] <shincodex> portable FF7 was great though
[22:24:06 CET] <bencoh> huhu video stuff on mips was quite .... "slow" back then indeed :D
[22:24:53 CET] <bencoh> I had the exact same FP issue :)
[22:57:01 CET] <shincodex> So uh
[22:57:09 CET] <shincodex> should i expect avi to not be supported cause of windows
[22:57:34 CET] <shincodex> OR maybe I didnt look hard enough in docs decoders section
[22:59:24 CET] <drv> if you configure with --disable-everything and didn't explicitly enable the avi (de)muxer, it won't be supported
[22:59:56 CET] <shincodex> https://ffmpeg.org/ffmpeg-codecs.html
[23:00:14 CET] <shincodex> is it
[23:00:15 CET] <shincodex> avio?
[23:02:11 CET] <drv> AVI is a container format, not a codec, so it's in https://ffmpeg.org/ffmpeg-formats.html
[23:02:26 CET] <shincodex> YEs
[23:02:35 CET] <shincodex> sorry the link you posted
[23:02:43 CET] <shincodex> i mean to paste
[23:02:52 CET] <shincodex> Nothing about avi
[23:02:54 CET] <drv> (although I don't think there's any actual docs for avi)
[23:02:56 CET] <drv> yeah
[23:03:00 CET] <shincodex> note even audio video interleaved
[23:03:03 CET] <c_14> check `ffmpeg -formats'
[23:03:16 CET] <shincodex> its fine its supported in there
[23:03:23 CET] <shincodex> somewhere
[23:04:10 CET] <drv> you would need to configure with --enable-demuxer=avi or something similar
[23:04:27 CET] <drv> or just use the default configuration without --disable-everything to avoid hair loss ;)
[23:07:09 CET] <shincodex> hair loss
[23:07:12 CET] <shincodex> HAIR LOSS?
[23:07:19 CET] <shincodex> The configure script is hair loss
[23:07:36 CET] <shincodex> and the whole.... conversation earlier
[23:08:03 CET] <shincodex> i just asked because in my copy of this I stripped the hell out of codec code thats unused
[23:08:20 CET] <shincodex> and put it somewhere else for safe keeping until some clown is like blah blah blah mpegs!
[23:08:23 CET] <shincodex> avis
[23:08:28 CET] <shincodex> Matroska!
[23:08:33 CET] <shincodex> lalalalaa apple!
[23:36:28 CET] <kerio> do you guys have a sample fragmented mp4 file downloadable via http?
[23:37:00 CET] <JEEB> you can create one yourself rather easily
[23:37:13 CET] <BtbN> youtube should have plenty
[23:37:33 CET] <JEEB> ffmpeg -i file -c copy -movflags frag_keyframe+empty_moov+separate_moof out.mp4
[23:37:37 CET] <JEEB> if I got those options right
[23:57:24 CET] <karchnu> TL:DR: from previous comment, does someone know why "ffmpeg -i INPUT -f s16_le -acodec pcm_s16le - | ffmpeg -f s16le -acodec pcm_s16le -i - file.mp3" produces an mp3 file 2x slower than expected?
[23:59:05 CET] <BtbN> because the first one is sending out two channels, and the second one thinks it's only one?
[23:59:38 CET] <karchnu> BtbN: oh. So I should put another argument to the second ffmpeg invocation?
[00:00:00 CET] --- Fri Jan 13 2017

More information about the Ffmpeg-devel-irc mailing list