[Ffmpeg-devel-irc] ffmpeg-devel.log.20170112

burek burek021 at gmail.com
Fri Jan 13 03:05:02 EET 2017

[00:04:17 CET] <cone-465> ffmpeg 03Martin Vignali 07master:682769d3d3a4: fate/psd : add test for 256 color
[01:11:03 CET] <BtbN> https://bpaste.net/show/4fb564dcc1f9 something seems to have gone wrong with moving bitswap_32. I guess the header is missing an include.
[01:11:21 CET] <BtbN> The one for ff_reverse
[01:20:06 CET] <cone-465> ffmpeg 03James Almer 07master:e71b8119e7db: avcodec/mathops: add missing header for ff_reverse
[01:20:23 CET] <jamrial> BtbN: odd, i didn't get that error on mingw-w64
[01:21:34 CET] <jamrial> and in any case including the missing header was probably needed so checkheaders doesn't fail
[01:22:32 CET] <BtbN> Maybe qdm2_tablegen.c just wasn't compiled, and everything else just happens to include the needed header first
[09:07:14 CET] <wm4> jkqxz: do you have a git tree with your vaapi decode API patches?
[09:21:52 CET] <jkqxz> Not conveniently.  The current patch series is at <http://ixia.jkqxz.net/~mrt/ffmpeg/vaapi-merge/>, including a few minor fixups vs. the mailed set.
[09:22:17 CET] <wm4> managed to apply it manually now
[09:22:36 CET] <wm4> for some reason "git apply" doesn't actually add new files to git, which was annoying
[09:22:48 CET] <wm4> (I'm sure there's an obscure option to make it do the right thing...)
[09:25:21 CET] <jkqxz> Use "git am"?
[09:33:38 CET] <rcombs> yeah, for format-patch files you want am
[09:33:41 CET] <wm4> oh, I knew I did something wrong
[09:33:54 CET] <wm4> not sure why I didn't think of that
[09:36:52 CET] <wm4> jkqxz: is sw_format guaranteed to be equivalent to what vaDeriveImage would reveal in VAImage.format.fourcc?
[10:28:05 CET] <jkqxz> wm4:  You mean AVHWFramesContext.sw_format?  Yes, it must be.
[10:30:59 CET] <wm4> just asking because I generally don't trust this stuff at all (also remembering https://bugs.freedesktop.org/show_bug.cgi?id=79848)
[10:36:25 CET] <jkqxz> VASurfaceAttribPixelFormat is always set explicitly, so there isn't any opportunity for it to screw around the way there is with just RT_FORMAT.  (Well, excepting driver bugs.  But it is very obviously a driver bug if it ever does anything funny here.)
[10:36:57 CET] <cone-646> ffmpeg 03Matthieu Bouron 07master:b1f68f00b12a: lavfi/framepool: rename FFVideoFramePool to FFFramePool
[10:36:57 CET] <cone-646> ffmpeg 03Matthieu Bouron 07master:eb3368178ed9: lavfi/framepool: add audio support
[10:36:57 CET] <cone-646> ffmpeg 03Matthieu Bouron 07master:e2d336cf6499: lavfi/framepool: re-indent after previous commit
[10:36:57 CET] <cone-646> ffmpeg 03Matthieu Bouron 07master:b1ed7957b835: lavfi/framepool: cosmetic style fixes
[10:36:57 CET] <cone-646> ffmpeg 03Matthieu Bouron 07master:e1f49712099d: lavfi: use an audio frame pool for each link of the filtergraph
[10:37:05 CET] <jkqxz> (Now just wait for the next attribute to set the tiling format explicitly as well...)
[11:11:51 CET] <ubitux> michaelni: i'm going to need some little refactor in this area, do you plan to send a patch soon?
[11:21:08 CET] <Chloe> Compn: did you get round to registering the freenode group?
[11:29:55 CET] <ubitux> ah, cool thing, the next h264 commit will allow us to drop the SLICE_ thing we kept in previous commits
[11:45:43 CET] <Chloe> michaelni: apparently cloaks need *your* explicit approval. Could you /msg kline and clarify this. (if you approve, of course)
[12:12:11 CET] <michaelni> ubitux, patch sent, but didnt test if it works
[12:15:59 CET] <ubitux> michaelni: why not the frame reconstruction?
[12:25:16 CET] <michaelni> ubitux, not sure i understand but i just copy and pasted this from the non flush case ...
[12:30:26 CET] <ubitux> michaelni: the code duplicating the missing fields
[12:30:38 CET] <ubitux> the whole block just above the output_frame() call
[12:30:51 CET] <ubitux> why isn't this done for the flushed frames
[12:30:54 CET] <ubitux> ?
[12:33:26 CET] <michaelni> ubitux, i guess the flushed case was forgotten
[13:45:04 CET] <cone-502> ffmpeg 03Bodecs Bela 07master:8811d6d9a07f: avformat/hlsenc: hls_start_number_source and start_number
[14:15:37 CET] <cone-502> ffmpeg 03Nicolas George 07master:57789cfb9d89: lavf/hlsenc: fix typo in last commit.
[14:15:38 CET] <cone-502> ffmpeg 03Nicolas George 07master:0b66c456f9ca: lavfi, ffmpeg: simplify filter names.
[14:15:39 CET] <cone-502> ffmpeg 03Nicolas George 07master:dbe9dbed31f0: lavfi/buffersink: add accessors for the stream properties.
[14:15:40 CET] <cone-502> ffmpeg 03Nicolas George 07master:d9b311d44c5d: ffmpeg: use buffersink accessors.
[14:15:41 CET] <cone-502> ffmpeg 03Nicolas George 07master:448f2972f9f9: ffplay: use buffersink accessors.
[14:15:42 CET] <cone-502> ffmpeg 03Nicolas George 07master:063b1a42c65c: lavd/lavfi: use buffersink accessors.
[14:15:43 CET] <cone-502> ffmpeg 03Nicolas George 07master:e9ecada1d43d: lavfi/tests/filtfmts: include internal.h.
[14:15:44 CET] <cone-502> ffmpeg 03Nicolas George 07master:485617ea0f7b: lavfi: document that AVFilterLink is not for applications.
[14:15:45 CET] <cone-502> ffmpeg 03Nicolas George 07master:4c24f3ac166a: lavfi: add ff_inlink_acknowledge_status().
[14:15:46 CET] <cone-502> ffmpeg 03Nicolas George 07master:918891e1468f: lavfi: export ff_filter_set_ready() to the library.
[14:15:47 CET] <cone-502> ffmpeg 03Nicolas George 07master:28c62df67286: lavfi: implement ff_inlink_make_frame_writable().
[14:15:48 CET] <cone-502> ffmpeg 03Nicolas George 07master:846f1421349e: lavfi: merge two variables after a recent commit.
[14:15:49 CET] <cone-502> ffmpeg 03Nicolas George 07master:0e3d2496e2ee: lavfi: add ff_inlink_process_commands().
[14:15:50 CET] <cone-502> ffmpeg 03Nicolas George 07master:e7e4c8dfbe9d: lavfi: add ff_inlink_evaluate_timeline_at_frame().
[14:15:51 CET] <cone-502> ffmpeg 03Nicolas George 07master:2e5af443c376: lavfi: pass min explicitly to samples_ready().
[14:15:52 CET] <cone-502> ffmpeg 03Nicolas George 07master:d360ddf03b84: lavfi: add helpers to consume frames from link FIFOs.
[14:15:53 CET] <cone-502> ffmpeg 03Nicolas George 07master:db4a71c0ff4a: lavfi: use the consume helpers in ff_filter_frame_to_filter().
[14:15:54 CET] <cone-502> ffmpeg 03Nicolas George 07master:3ff01feda30a: lavfi: add AVFilter.activate.
[14:15:55 CET] <cone-502> ffmpeg 03Nicolas George 07master:7910127a8ee1: lavfi: cosmetic: remove forward declaration.
[14:15:56 CET] <cone-502> ffmpeg 03Nicolas George 07master:d3cb140433fe: lavfi: move ff_update_link_current_pts() into the utility functions.
[14:15:57 CET] <cone-502> ffmpeg 03Nicolas George 07master:9eb4c79afd43: lavfi: add ff_inlink_request_frame().
[14:15:58 CET] <cone-502> ffmpeg 03Nicolas George 07master:ae4650f0b9cb: lavfi: disallow ff_request_frame for filters using activate.
[14:15:59 CET] <cone-502> ffmpeg 03Nicolas George 07master:c619a4e5259b: lavfi: make two functions static.
[14:16:00 CET] <cone-502> ffmpeg 03Nicolas George 07master:32c59a115d3c: lavfi: do not call ff_filter_frame() with activate.
[14:16:01 CET] <cone-502> ffmpeg 03Nicolas George 07master:912969a33e31: lavfi/buffersink: move to the new design.
[14:16:02 CET] <cone-502> ffmpeg 03Nicolas George 07master:aaae459a850e: lavfi: reindent after previous commit.
[14:16:02 CET] <wm4> lol pushed it without providing the information I requested
[14:38:54 CET] <Compn> Chloe : yes, they are working on it :D
[14:54:50 CET] <wm4> getting this from some CI that just compiled ffmpeg git: libavformat/hlsenc.c:995:44: error: HLS_START_SEQUNCE_AS_SECONDS_SINCE_EPOCH undeclared (first use in this function)
[14:58:56 CET] <durandal_170> wm4: nicolas fixed it
[15:04:07 CET] <jkqxz> Did anyone even build that at all?  The most recent version posted on the ML, which was then applied, doesn't build.
[15:04:54 CET] <wm4> who pushed it?
[15:06:01 CET] <cone-502> ffmpeg 03Carl Eugen Hoyos 07master:f31bac596f93: lavf/dss: Do not fail randomly if dss_sp input contains 0xff.
[15:11:45 CET] <cone-502> ffmpeg 03Nicolas George 07master:f7191ccad663: lavfi: remove stray semicolons.
[15:42:36 CET] <libertyernie> This might not really be an ffmpeg question, but is there a way to submit a patch to rtmpdump (https://git.ffmpeg.org/rtmpdump)? Their mailing list seems to be broken (emails not going through.)
[15:53:04 CET] <Chloe> Compn: yep, they've done it now :D I believe it should be easy for people who want cloaks to get them
[15:57:52 CET] <Chloe> jkqxz: Master builds on macOS 10.12, running FATE now
[16:04:48 CET] <Chloe> jkqxz: FATE passes as well
[16:11:06 CET] <jkqxz> I was talking about that HLS patch.  Nicolas fixed the build error, but not even having been built doesn't offer much confidence about whether it does anything sensible.
[16:12:19 CET] <wm4> heh
[16:14:55 CET] <Shiz> where's mpv/bdfl/wm4
[16:14:59 CET] <Shiz> or maybe mdfl
[16:15:25 CET] <Sesse> malicious dictator for life
[16:15:34 CET] <wm4> what
[16:15:54 CET] <Sesse> mdfl!
[16:15:57 CET] <wm4> do you expect me to bark at that hls guy or what
[16:18:08 CET] <Shiz> malevolent
[16:43:47 CET] <durandal_170>  is the chinese guy responsible for hlsenc on irc?
[16:46:56 CET] <JEEB> I don't think so at least?
[16:49:32 CET] <durandal_1707> Compn: give me cloak
[18:04:21 CET] <ubitux> ETA: mateo` & i have been working for 3 days on the 2 next h264 commits from libav. we're not yet sure how to properly handle the first one (maybe we'll noop it) and the second is still buggy
[18:04:41 CET] <ubitux> if anyone is interested in the process, i can post something about the first commit
[18:04:50 CET] <ubitux> so we can move on for at least this one
[18:17:56 CET] <Compn> michaelni : did the guy tell you how to set cloaks ?
[18:18:32 CET] <Compn> durandal_1707 : each person has to ask in #freenode to get a cloak, afaik. then the guy has to ask me to approve it
[18:18:48 CET] Action: Compn looks at Chloe's spiffy new cloak
[18:19:23 CET] <Compn> didnt know Chloe was a developer... needs the +v ...
[18:20:15 CET] <Compn> btw if anyone asks, i am also the rtmpdump ml admin
[18:20:23 CET] <durandal_1707> Compn: only you and michaelni can give perma voices
[18:21:17 CET] <Chloe> Compn: I havent been on the ML for a little while because of college mostly.
[18:24:00 CET] <Compn> [09:42] <libertyernie> This might not really be an ffmpeg question, but is there a way to submit a patch to rtmpdump (https://git.ffmpeg.org/rtmpdump)? Their mailing list seems to be broken (emails not going through.)
[18:24:18 CET] <Compn> hmmmm i wonder if he sent mail to rtmpdump at ffmpeg.org ? i see no mails in the mod queue :\
[18:31:44 CET] <wm4> spiffy
[18:34:08 CET] <Compn> wm4 : do you use librtmp or just the rtmp in libavformat ? :P
[18:35:17 CET] <BtbN> So, I just ask in #freenode, and then someone has to confirm, and that's it?
[18:35:48 CET] <Compn> BtbN : yes, lets try to see if that is the suggested way
[18:35:53 CET] Action: Compn sits in freenode
[18:36:05 CET] <Compn> BtbN : ask anytime :)
[18:38:28 CET] <Compn> :\
[18:43:10 CET] <Compn> there you go durandal_1707
[18:43:14 CET] <Compn> anyone else want a cloak ?
[18:43:24 CET] <Compn> wm4 ? 
[18:43:31 CET] <BtbN> you yourself? :D
[18:44:13 CET] <Compn> kierank ?
[18:45:48 CET] <michaelni> Compn, to give cloak, asking in #freenode or asking someone from staff direcly is the way to do it
[18:45:58 CET] <Compn> yes i see , thank you
[18:46:20 CET] <Compn> i guess the developers dont need to ask themselves, just i can ask for anyone to get a cloak
[18:46:31 CET] <Compn> even if they dont want one ! mad with power etc
[18:46:49 CET] <durandal_1707> Compn: thx
[18:48:34 CET] <BtbN> you can also appoint other representatives and assign them arbitrary roles, so you're not alone with that power.
[18:48:47 CET] <BtbN> according to https://freenode.net/groupreg
[18:48:53 CET] <Compn> thats nice
[18:49:07 CET] <Compn> should do that if there are volunteers
[18:50:07 CET] Action: Compn goes back to trolling under rocks
[18:51:14 CET] <Compn> libertyernie  :oh hey
[18:51:24 CET] <Compn> i thought i saw you  rejoin but i was not paying attention :D
[18:51:43 CET] <Compn> libertyernie : where did you send your rtmpdump mail to ?
[18:51:48 CET] <Compn> what email addy i mean
[18:52:49 CET] <libertyernie> rtmpdump at mplayerhq.ru
[18:53:25 CET] <Compn> .ru ?
[18:53:49 CET] <libertyernie> oh, it's .hu isn't it?
[18:53:54 CET] <Compn> quite :D
[18:54:04 CET] <libertyernie> thanks :)
[18:54:13 CET] <Compn> easy problems are easy :)
[18:54:52 CET] <wm4> Compn: I don't care about rtmp, but I heard they have both problems
[19:02:35 CET] <Compn> libertyernie : rare windows git user :D
[19:03:23 CET] <libertyernie> Compn: yeah - although ultimately this was to fix a problem i was only having on linux
[19:07:27 CET] <Compn> libertyernie : ksv has a rtmpdump patch with his binary, i wonder if it has the fix you made? probably not. but it includes support for other encryption... https://github.com/K-S-V/Scripts/releases/download/v2.4/rtmpdump-2.4.zip
[19:08:50 CET] <Compn> rtmpdump development split up and i havent been able to get them to recombine :\
[19:09:33 CET] <libertyernie> thanks for the info.
[19:09:55 CET] <Compn> and possibly other fixes not in mphq git repo
[19:10:08 CET] <Compn> been a while since i reviewed it
[19:10:28 CET] <libertyernie> Would this be it? https://github.com/BurntSushi/rtmpdump-ksv/commit/7491f321b65ea2d524cff276e4890d863ee75196
[19:11:03 CET] <Compn> yes but he has updated it since 2013, thats why i linked the zip file which contains 'patch.diff' ...
[19:11:13 CET] <libertyernie> ok, i'll check it out
[19:11:54 CET] <Compn> unforatunately that burntsushi repo has not updated :\
[19:12:05 CET] <bencoh> I guess it's a thing to split up development :>
[19:12:26 CET] <bencoh> (mybad)
[19:12:29 CET] <Compn> people do not like working together
[19:14:25 CET] <Compn> dunno why people thought ffmpeg was any different. every major software project has forks (bsd! firefox! chromium! linux distros! even mplayer has a bunch of forks)
[19:19:00 CET] <Compn> now videolan... that project needs a fork :P
[19:19:07 CET] Action: Compn runs
[19:53:52 CET] <cone-569> ffmpeg 03Sergey Kudryashov 07master:a9b33b5a37ad: libavfilter/af_biquads: warn about clipping only after frame with clipping
[22:36:36 CET] <BtbN> jamrial, https://bpaste.net/show/90beb5f4ee55 Not sure what's going on yet.
[22:37:45 CET] <BtbN> Not even sure if it's related to the bitswap move from yesterday, but I'd very much guess so.
[22:40:49 CET] <BtbN> configure line in question: https://bpaste.net/show/fd497c2ff6f5
[23:02:26 CET] <BtbN> Ok, it's also triggered by a simple ./configure --enable-hardcoded-tables
[23:08:26 CET] <BtbN> Seems like what's going on is that for building the tools with HOSTCC, -DHAVE_AV_CONFIG_H is not set via cli, which makes sense, which in turn enables all the replacements in avutil/libm.h, even though they are supposed fine by the host system, and thus they collide.
[23:08:40 CET] <BtbN> *supported fine
[23:08:58 CET] <BtbN> I have no idea how to address this.
[23:09:52 CET] <BtbN> Can't immediately think of a good solution that's not a massive rework of stuff. So this might need some reverting to keep it from breaking the build.
[23:16:44 CET] <iive> BtbN: i don't understand, is -DHAVE_AV_CONFIG on present, or is HAVE_AV_CONFIG defined in header file?
[23:17:04 CET] <BtbN> iive, not on the compiler call for the tablegen via hostcc
[23:17:34 CET] <iive> oh, cross compilation.
[23:17:37 CET] <BtbN> no
[23:18:02 CET] <BtbN> The tablegen tools are just allways compiled via HOSTCC, as they generate the hardcoded tables.
[23:18:10 CET] <BtbN> No matter if cross compiling or not.
[23:18:22 CET] <iive> yes, they are compiled in host machine code, not the target machine.
[23:18:29 CET] <jamrial> BtbN: i guess we could just add the "extern const uint8_t ff_reverse[256];" line to mathops.h instead of including internal.h
[23:18:34 CET] <iive> I confused it with DISTCC
[23:18:55 CET] <BtbN> jamrial, hm, yeah, that should at least get it to build again for now.
[23:19:11 CET] <BtbN> But the issue will still be lingering
[23:19:18 CET] <jamrial> yeah
[23:20:02 CET] <jamrial> going to test if it works then push it
[23:20:50 CET] <nevcairiel> hardcoded tables should just go =p
[23:21:48 CET] <BtbN> it works, but triggers a lot of "warning: redundant redeclaration of ff_reverse"
[23:26:02 CET] <cone-569> ffmpeg 03Carl Eugen Hoyos 07master:2f94b305acfb: lavf/mxf: Add a universal label for ProRes used in FCP.
[23:26:26 CET] <ruste> I have a hopefully brief question and I think this is the appropriate channel for it.
[23:27:38 CET] <iive> ruste: have you tried #ffmpeg first? in case you are not sure if this is the right channel ;)
[23:27:45 CET] <ruste> I'm experimenting with my own video codec and I'd like to add it to ffmpeg to experiment with. Any documentation on this sort of thing?
[23:28:16 CET] <iive> (looks like this is the right channel)
[23:28:31 CET] <ruste> iive: Yeah, wasn't entirely sure. :)
[23:30:03 CET] <jamrial> ruste: no documentation afaik, but you could look at how other codecs glue themselves to the framework
[23:30:11 CET] <Compn> there is a wiki article actually
[23:30:13 CET] <Compn> on how to add codec
[23:30:26 CET] <jamrial> especially external library wrappers like libopus, libvorbis and such, which are short and simple
[23:30:29 CET] <jamrial> oh, that's nice
[23:30:32 CET] <Compn> https://wiki.multimedia.cx/index.php?title=FFmpeg_codec_HOWTO
[23:30:34 CET] <Compn> might be outdated :D
[23:30:36 CET] <Compn> old api too
[23:31:05 CET] <ruste> I'll check it out! Thanks!
[23:31:20 CET] <ubitux> ruste: add a codec id in libavcodec/avcodec.h if it doesn't exist, add it in libavcodec/{allcodecs.c,Makefile,codec_desc.c}
[23:31:30 CET] <ubitux> then pick a random codec and copy the structure
[23:31:48 CET] <ubitux> typically what you see on top (includes, private headers) and the bottom struct definition with the callback
[23:32:05 CET] <ubitux> then re-run configure and make
[23:32:13 CET] <ubitux> that's probably the fastest way to get something working asap
[23:33:22 CET] <ruste> Perfect! That's pretty much exactly what I wanted to know! Thanks!
[23:34:17 CET] <Compn> ruste : are you taking the mit course that says add a codec to ffmpeg ?
[23:34:40 CET] <ubitux> ruste: side note: allcodecs.c is parsed by the configure script; after re-running ./configure you can check if your codec is properly registered with a grep -i yourcodec config.h
[23:34:53 CET] <ubitux> hf.
[23:35:52 CET] <Compn> ruste : are you doing this in school? https://github.com/petersn/video-compression-lab/blob/master/lab.html
[23:40:46 CET] <Compn> wonder if we are going to get a lot of homework questions in here 
[23:41:02 CET] <Compn> we may need to take over this video compression lab assignment to avoid this...
[23:41:27 CET] <jamrial> BtbN: https://bpaste.net/show/dac5f008b7ca
[23:41:41 CET] <BtbN> ugh
[23:42:05 CET] <BtbN> (might want to update that Copyright-Header)
[23:42:15 CET] <jamrial> copy pasted from reverse.c
[23:42:18 CET] <jamrial> so i thought it was ok
[23:42:29 CET] <BtbN> hm, yeah, I guess that should be fine.
[23:43:24 CET] <jamrial> if libavutil/eval.c didn't use ff_reverse i'd just add the declaration to mathops.h and be done with it
[23:44:16 CET] <BtbN> it seems to work, no warnings. I'll wait for the build to finish.
[23:50:05 CET] <ruste> Compn, I'm not. Just a personal project.
[23:52:05 CET] <BtbN> Yeah, compile and I see no extra warnings.
[23:52:07 CET] <BtbN> +s
[23:53:16 CET] <jamrial> BtbN: ok, will push in a minute
[23:59:33 CET] <Compn> ruste : ah, good luck then! :)
[00:00:00 CET] --- Fri Jan 13 2017

More information about the Ffmpeg-devel-irc mailing list