[Ffmpeg-devel-irc] ffmpeg.log.20170115

burek burek021 at gmail.com
Mon Jan 16 03:05:01 EET 2017

[01:35:52 CET] <Seylerius> Okay, I've realized what the problem probably is: the audio in the original video has some wibbly-wobbly timecodes going on, and when I was adjusting it needed more padding that it actually would. Making a new audio track in audacity ate up the wibbly-wobbliness, leading to the excess padding becoming obvious.
[02:41:39 CET] <grublet> Seylerius: what do you mean by "wibbly-wobbliness"
[02:45:12 CET] <Diag> grublet: i thinkhes ona them doctor what fanboys
[03:57:35 CET] <docmax> ffmpeg -re -i /mnt/store/Media/Movies/new/Terminator.1984.German.DL.1080p.BluRay.AVC-KULTFiLME.mkv -an -vcodec copy -f rtp rtp://t420.lan:1234 -vn -acodec copy -f pulse default
[03:57:50 CET] <docmax>  Stream #0:0 -> #0:0 (copy)
[03:57:50 CET] <docmax>   Stream #0:1 -> #1:0 (copy)
[03:57:51 CET] <docmax> Could not write header for output file #1 (incorrect codec parameters ?): Invalid argument
[03:57:57 CET] <docmax> how can i fix this?
[04:00:37 CET] <thebombzen> docmax: most likely -f pulse doesn't take the audio codec you had in the mkv file
[04:01:19 CET] <thebombzen> pulseaudio is the server that plays the audio on your computer so it needs PCM samples
[04:01:54 CET] <thebombzen> try at the end, instead of "-vn -acodec copy -f pulse default" try "-vn -c:a pcm_s16le -f pulse default"
[04:02:21 CET] <hayha> anybody here use VLC
[04:02:23 CET] <thebombzen> -c:a is just a better way of saying -acodec. and pcm_s16le is uncompressed samples
[04:02:29 CET] <thebombzen> hayha: only if absolutely necessary
[04:02:39 CET] <hayha> thebombzen then what do you use  mainly?
[04:02:43 CET] <thebombzen> mpv
[04:02:58 CET] <thebombzen> it's a fork of mplayer/mplayer2 that has the upside of still being actively developed and maintained
[04:04:10 CET] <docmax> now i have this:
[04:04:11 CET] <docmax> Unable to receive RTP payload type 96 without an SDP file describing it
[04:04:24 CET] <thebombzen> well you need an SDP file to recieve RTP
[04:05:07 CET] <docmax> ffmpeg -re -i /mnt/store/Media/Movies/new/Terminator.1984.German.DL.1080p.BluRay.AVC-KULTFiLME.mkv -an -vcodec copy -f rtp rtp://t420.lan:1234 -vn -f pulse default
[04:05:39 CET] <docmax> i cant create a SDP every time... can i avoid this? with UDP perhaps?
[04:05:39 CET] <thebombzen> I'm not entirely sure why you're doing this anyway
[04:05:55 CET] <thebombzen> why are you streaming the video over RTP while playing hte audio on your local box
[04:06:05 CET] <thebombzen> why not just... play both of them
[04:06:09 CET] <docmax> the video goes to my projector
[04:06:34 CET] <docmax> and the audio remains on my server hifi system
[04:06:37 CET] <thebombzen> ah
[04:06:52 CET] <docmax> but i need a way without SDP file
[04:07:03 CET] <thebombzen> but either way paste the full command and output
[04:07:09 CET] <thebombzen> not just the error message
[04:07:19 CET] <docmax> on server:
[04:07:23 CET] <docmax> ffmpeg -re -i /mnt/store/Media/Movies/new/Terminator.1984.German.DL.1080p.BluRay.AVC-KULTFiLME.mkv -an -vcodec copy -f rtp rtp://t420.lan:1234 -vn -f pulse default
[04:07:36 CET] <docmax> this works, and on client:
[04:07:51 CET] <docmax> ffplay rtp://localhost:1234
[04:08:04 CET] <docmax> but client stops with:
[04:08:12 CET] <docmax> Unable to receive RTP payload type 96 without an SDP file describing it
[04:08:46 CET] <c_14> docmax: add -sdp_file foo.sdp
[04:08:50 CET] <c_14> then pass that to the player
[04:09:11 CET] <c_14> (add the arguments to the first command, and pass the file to the player)
[04:10:02 CET] <docmax> i dont fand to fiddle around with files
[04:10:12 CET] <docmax> want
[04:10:30 CET] <docmax> is there another way without files? udp:// perhaps?
[04:10:44 CET] <c_14> sure
[04:11:16 CET] <c_14> -f mpegts udp://t420.lan:1234
[04:11:27 CET] <docmax> does this transcode?
[04:11:32 CET] <docmax> i need copy
[04:11:47 CET] <c_14> shouldn't
[04:11:52 CET] <c_14> just replace the -f rtp part with that
[04:12:09 CET] <docmax> and ffplay? ffplay udp://localhost:1234?
[04:12:24 CET] <c_14> ffplay udp://t420.lan:1234?listen
[04:12:53 CET] <c_14> you can replace t420.lan with
[04:19:54 CET] <hayha> i found a huge bug in VLC and they are not willing to fix it
[04:24:00 CET] Last message repeated 1 time(s).
[04:29:56 CET] <docmax> is there a alternative to mpegts? i get distorted picture
[04:29:58 CET] <docmax> artefacts
[04:29:58 CET] <furq> the container format shouldn't be to blame for that
[04:29:58 CET] <furq> if you're on wifi then maybe udp packets are being dropped
[04:29:58 CET] <docmax> yes i'm on wifi
[04:29:59 CET] <docmax> is there any solution for wifi?
[04:30:05 CET] <klaxa> use tcp?
[04:30:10 CET] <klaxa> but it might result in desync
[04:30:21 CET] <docmax> whats the command for thisß
[04:30:22 CET] <docmax> ?
[04:30:27 CET] <hayha> i found a huge bug in VLC and they are not willing to fix it
[04:30:31 CET] Last message repeated 1 time(s).
[04:30:31 CET] <furq> i think you can just replace udp with tcp
[04:30:39 CET] <docmax> ok
[04:30:56 CET] <furq> hayha: what do you want us to do about it
[04:34:33 CET] <hayha> furq boycott vlc
[04:34:42 CET] <furq> already taken care of
[04:34:47 CET] <hayha> lol okay
[04:34:53 CET] <hayha> furq then what do you use
[04:35:09 CET] <furq> mpc-hc or mpv
[04:35:16 CET] <hayha> mpv is horrible
[04:35:21 CET] <klaxa> haha what
[04:35:32 CET] <hayha> klaxa what is funny?
[04:35:49 CET] <klaxa> mpv is currently the best player on *nix imo
[04:36:04 CET] <klaxa> what would you suggest i use instead? windows media player?
[04:36:16 CET] <hayha>  mpc-hc is good
[04:36:34 CET] <hayha> how is mpv best player
[04:36:43 CET] <klaxa> it's fast and doesn't suck
[04:37:23 CET] <hayha> i tried using it: it's horrible
[04:37:52 CET] <furq> i like mpv because when i find huge bugs in it they are willing to fix it
[04:37:53 CET] <klaxa> that's just like, your opinion man
[04:37:55 CET] <furq> that's just me though
[04:38:22 CET] <hayha> i cannot even play dvd using mpv
[04:39:08 CET] <hayha> klaxa what do you say to that
[04:39:36 CET] <klaxa> i say: i don't have an optical disc drive
[04:39:46 CET] <furq> i've never tried because it's not 2005, but you should be able to
[04:39:49 CET] <furq> it has libdvdnav support
[04:39:51 CET] <klaxa> i'm fairly sure i managed to play dvds with mpv
[04:39:59 CET] <klaxa> i even managed to play one bluray
[04:40:09 CET] <hayha> then how come i cannot do it
[04:40:17 CET] <klaxa> you don't push the right buttons
[04:40:18 CET] <furq> it can definitely play decrypted IFOs, i do that all the time
[04:40:31 CET] <hayha> what about encrypted ifos
[04:40:35 CET] <furq> shrug
[04:40:51 CET] <hayha> ifos are encrypted as well?
[04:40:56 CET] <furq> well
[04:41:01 CET] <furq> ifos of decrypted vobs
[04:41:03 CET] <hayha> i knows vobs are encrypted
[04:41:17 CET] <furq> i assume it works if your libdvdnav was built with libdvdcss support
[04:41:26 CET] <furq> some distros are probably still funny about that though
[04:41:58 CET] <furq> there's no libdvdcss in debian so it probably won't work there unless you build it yourself
[04:42:35 CET] <hayha> https://trac.videolan.org/vlc/ticket/17882#no1
[04:50:59 CET] <hayha> what is the deal with MPV hype these days
[04:51:16 CET] <klaxa> it's actively developed
[04:51:37 CET] <hayha> but it's so bad
[04:52:01 CET] <klaxa> <klaxa> that's just like, your opinion man
[04:52:09 CET] <furq> actually, it's good,
[04:52:10 CET] <klaxa> if it's so bad, write a better one
[04:52:11 CET] <hayha> does mpv work in android too?
[04:52:17 CET] <furq> yes
[04:52:20 CET] <hayha> i see
[04:52:53 CET] <hayha> klaxa gui is horrible, you can't argue that one
[04:53:01 CET] <klaxa> what gui
[04:53:27 CET] <klaxa> you mean the OSC? you can disable that afaik
[04:53:56 CET] <hayha> gui that you see in this website:  https://mpv.io/
[04:53:59 CET] <klaxa> the last update made it less horrible
[04:54:12 CET] <klaxa> yeah that one is less horrible than the one before imo
[04:54:41 CET] <c_14> write your own gui using libmpv
[04:55:00 CET] <furq> i've seen vlc's ui, there's no way this criticism is real
[04:55:05 CET] <hayha> i have to use drap and drop method
[04:55:23 CET] <hayha> i don't want to use drag and drop method
[04:55:29 CET] <klaxa> use the cli?
[04:55:33 CET] <klaxa> like sane people
[04:55:41 CET] <furq> or you know
[04:55:43 CET] <furq> file associations
[04:55:58 CET] <hayha> furq you cannot do file association with dvd
[04:56:05 CET] <furq> maybe you can't
[04:56:10 CET] <hayha> see
[04:56:16 CET] <hayha> so i cannot play dvd
[04:56:33 CET] <c_14> write a script
[04:56:37 CET] <c_14> place it on your desktop
[04:56:42 CET] <c_14> double click it when you want to play a dvd
[04:56:48 CET] <furq> i'll be honest, i stopped caring what video player you use a while ago
[04:57:18 CET] <hayha> at least vlc plays dvd
[04:57:28 CET] <hayha> mpv cannot even play it
[06:07:32 CET] <hayha> i found a huge bug in VLC and they are not willing to fix it
[06:08:00 CET] Last message repeated 1 time(s).
[06:22:20 CET] <furq> hey i heard there's big news: amd destroys intel
[06:22:22 CET] <furq> what do you think about that
[06:28:25 CET] <hayha> furq ??
[11:05:29 CET] <furq> does anyone know a way to edit the creation_date metadata of an mp4 in place
[11:05:42 CET] <furq> or removing it would work too
[11:07:23 CET] <JEEB> in place I don't think... you would probably want to check in which box and offset it is included with boxdumper --box file.mp4 and then looking at the specs modify the box
[11:08:18 CET] <furq> well the point of this is to save time, so if i have to hand-edit all these files i'd rather just remux them all
[11:17:52 CET] <JEEB> sounds like a reasonable action :P
[11:18:05 CET] <JEEB> you didn't mention that so I gave you the one way I could think you could (possibly) edit it in place
[11:18:29 CET] <JEEB> if it was a variable-length field/box then you wouldn't be able to do it in-place anyways
[11:25:38 CET] <furq> well it's a date so i assume i can edit it in place
[11:31:30 CET] <JEEB> right, you said *edit* not *remove*
[11:31:52 CET] <JEEB> but yeah, no automatic tool as far as I can tell
[11:32:07 CET] <furq> well either works for me
[11:32:48 CET] <furq> http://vpaste.net/QZD6J
[11:32:53 CET] <furq> i found it but i'm not really sure what to do with this information
[11:34:39 CET] <JEEB> you grab the freely available 14496-12 spec and look at the definition of mvhd :)
[11:35:07 CET] <JEEB> the box itself starts from offset 28 it seems
[12:32:19 CET] <furq> the mvhd version should be the first byte after "mvhd", right
[13:16:12 CET] <thebombzen> what is the format to read/write -c:s text?
[13:16:51 CET] <thebombzen> ffmpeg -codecs says "DES... text, raw UTF-8 text" but this isn't helpful unless you can mux it
[13:22:07 CET] <BtbN> mkv should be able to
[13:22:12 CET] <BtbN> And probably nut as well
[13:23:12 CET] <BtbN> For a plain subtitle format, srt I think.
[13:25:22 CET] <thebombzen> but like if I want to dump it as a textreadable thing
[13:26:34 CET] <thebombzen> yea that did it, but there's a speed issue for some reason hmmm
[13:26:35 CET] <c_14> thebombzen: -f data
[13:26:47 CET] <thebombzen> -f data? hmm I didn't know about that. what does that do in general
[13:27:14 CET] <c_14> write data
[13:27:21 CET] <c_14> raw codec packets appended to each other
[13:27:34 CET] <thebombzen> oh okay. how is that any different than, say, -f h264 for an H.264 stream?
[13:27:34 CET] <c_14> in this case, a bunch of text (without newlines afaik)
[13:28:22 CET] <thebombzen> yea it's "without newlines"
[13:28:34 CET] <thebombzen> there's a cap on the line length though so it wraps at weird places
[13:28:46 CET] <thebombzen> or rather, idk if there's a cap. it just wraps a lot
[13:29:31 CET] <BtbN> srt is as close to plain text as it gets.
[13:31:04 CET] <thebombzen> -c text -f srt is very similar to -c srt -f srt
[13:31:18 CET] <thebombzen> the difference is -c text -f srt strips off the xml that gives the font
[13:33:28 CET] <thebombzen> so yea the most primitive thing appears to be -c text -f srt. thanks
[13:36:28 CET] <lmm> Hi, I got a problem converting an RTMP stream to mpeg-dash. Wit ffmpeg 2.8.10 everything works well up to this commit: 6f69f7a8bf6a0d013985578df2ef42ee6b1c7994 Due to the huge code changes in this commit I would like to double check that this is a bug and not a user error...
[14:04:28 CET] <EDAKIRI> To make an excerpt of a video, can FFMPEG be told to be precise with the ending time, reencoding if necessary, but copy the rest ?
[14:05:44 CET] <JEEB> no
[14:05:59 CET] <JEEB> also the ending time usually isn't an issue, just the fact that you start with an IRAP
[14:06:28 CET] <JEEB> I remember someone making a wrapper for that on the lav* libraries
[14:06:37 CET] <JEEB> no idea how it was called though, it was on github
[14:22:30 CET] <FrogCast> this command, "ffmpeg -i Stagflation__0117.wav -map_metadata comment=test some.ogg" is generating myself the error "Invalid metadata type o." -- What does this mean?
[14:23:05 CET] <c_14> replace -map_metadata with -metadata:g
[14:23:14 CET] <c_14> You are trying to set a metadata tag, yes?
[14:23:24 CET] <FrogCast> Yeah, the whole list c_14
[14:23:51 CET] <FrogCast> I can use :g for comment, title, album, etc?
[14:23:59 CET] <c_14> -map_metadata is for selecting which source file's metadata to copy, -metadata is for actually setting metadata
[14:24:14 CET] <c_14> I'm pretty sure those are all global metadata, yes
[14:24:27 CET] <FrogCast> c_14, cool; thanks
[15:50:31 CET] <DocMAX> ffmpeg -i /mnt/sdb/Media/Movies/Forrest.Gump.1994.German.AC3.1080p.BluRay.x264-SEKTiON9.mkv -bsf:v h264_mp4toannexb -an -c copy -f mpegts udp://game:1234 -vn -c copy -f pulse default -server game
[15:50:44 CET] <DocMAX> Could not write header for output file #1 (incorrect codec parameters ?): Invalid argument
[15:50:59 CET] <DocMAX> what i'm doing wrong with pulse?
[15:53:28 CET] <c_14> get rid of -c copy for the pulse output
[15:54:17 CET] <furq> did you get udp working then
[15:55:47 CET] <DHE> "pulse default" ?
[15:56:01 CET] <DocMAX> udp works
[15:56:29 CET] <furq> DHE: https://ffmpeg.org/ffmpeg-devices.html#pulse
[15:56:45 CET] <furq> what a nice young man
[15:57:06 CET] <DHE> connection reset by peer is rarely a user choice...
[15:57:23 CET] <DocMAX> ffmpeg -i video.mkv -bsf:v h264_mp4toannexb -an -c copy -f mpegts udp://game:1234 -vn -f pulse default -server
[15:57:39 CET] <DHE> furq: when the last 2 options are "-server xxxx" it doesn't look right at all
[15:57:41 CET] <DocMAX> whats the "default" thing?
[15:57:53 CET] <furq> i'm guessing -server game should go before default
[15:58:05 CET] <DHE> that sounds better
[15:58:37 CET] <DocMAX> furq, you were right! :-)
[15:58:44 CET] <DocMAX> WORKS!
[15:58:46 CET] <furq> i wouldn't have noticed that tbf
[15:59:03 CET] <DocMAX> pretty amazing what ffmpeg can do!
[15:59:29 CET] <DHE> syntax is: ffmpeg [input1 options] -i input1 [input2 options] -i input2 [...]   [output1 options] output1 [output2 options] output2 [...]
[15:59:46 CET] <DHE> so your output filename/target must be last
[16:01:09 CET] <furq> "-server xyz default" still looks really weird but i guess it's better than inventing a url scheme
[16:01:27 CET] <DHE> 'default' is the target name for the alsa driver
[16:01:31 CET] <DHE> I guess...
[16:02:10 CET] <furq> yeah it's just the opposite of how you'd normally specify that
[16:02:27 CET] <furq> which is quite unlike anything else lennart poettering is responsible for
[16:02:47 CET] <DHE> zing!
[16:15:46 CET] <bencoh> :]
[17:23:24 CET] <DocMAX> how can send audio via udp?
[17:23:35 CET] <c_14> same way as video
[17:23:40 CET] <DocMAX> the equivalent to mpegts for video
[17:24:05 CET] <furq> mpegts carries video and audio
[17:24:06 CET] <DocMAX> mpegts for audio?
[17:24:17 CET] <DocMAX> ok
[17:24:23 CET] <furq> amongst other things
[17:31:00 CET] <bencoh> you can send audio over rtp as well
[17:31:04 CET] <bencoh> (rtp over udp)
[17:38:33 CET] <DHE> Pure UDP mode (udp:// is highly unreliable though. Using the bitrate option helps to a point. RTP or running it over TCP instead is much better
[17:38:54 CET] <DocMAX> RTP needs that SDP file
[17:39:04 CET] <DocMAX> i dont want to create one every time
[17:43:47 CET] <bencoh> RTP doesnt need sdp
[18:17:47 CET] <kerio> DHE: isn't mpegts over udp reliable tho
[18:31:32 CET] <thebombzen> what's wrong with pure UDP
[18:31:49 CET] <thebombzen> udp:// seems fine with a container designed to be loss-resilient, right?
[18:32:10 CET] <thebombzen> and if you're doing audio as opus you should be extra fine
[18:42:41 CET] <DHE> besides UDP being inherently unreliable, not using the bitrate=xxx parameter results in little packet bursts which are easily dropped on some network paths.
[18:43:23 CET] <DHE> a gigabit sender and 100meg receiver, for example
[19:08:14 CET] <TD-Linux> thebombzen, with pure UDP (like one opus packet per UDP packet) you don't get a sequence number and so you can't use opus error concealment
[19:16:26 CET] <MastaKillah> Hi! I'm currently trying to use ffmpeg to build a video stream from a jpeg image + a local icecast audio stream, and send it to facebook live. This works but with freezing issues. Please, is it possible to get some help ? I wrote more details about this problem on StackOverflow, including the ffmpeg commands I used : http://stackoverflow.com/questions/41651248/streaming-from-icecast-to-facebook-live-with-ffmpeg-on-
[19:16:26 CET] <MastaKillah> ubuntu-16-04 Thanks :)
[20:03:51 CET] <antlarr> hello, I have a small problem with metadata extraction from flac files with ffmpeg. I'm using "ffprobe -v error -show_format -show_streams file.flac" or "ffprobe -v error -select_streams a:0 -show_format -show_streams -of flat -i file.flac"
[20:04:30 CET] <antlarr> for some reason, it seems the files have metadata at the beginning and also at the end of the file, and ffmpeg is giving me both values at the same time, so I'm getting things like:
[20:04:32 CET] <antlarr> TAG:ARTIST=Lito Vitale cuarteto;Lito Vitale Cuarteto
[20:04:47 CET] <antlarr> TAG:TITLE=Basta de fingir;Basta de fingir
[20:05:01 CET] <furq> vorbis comments can have multiple entries for the same tag
[20:05:27 CET] <antlarr> is there any way to request only one of them?
[20:05:34 CET] <furq> probably not
[20:05:42 CET] <antlarr> all applications I use to edit the metadata show only one entry
[20:05:47 CET] <furq> and tags can contain ; so i can't imagine there's a robust way to deal with that
[20:05:59 CET] <furq> i don't really use ffprobe for audio metadata though
[20:07:29 CET] <antlarr> so ... what can I do about it? is there some way to remove one of the entries?
[20:07:44 CET] <furq> well you can't edit metadata in place at all with ffmpeg
[20:07:53 CET] <furq> i'd probably use something like mutagen
[20:30:43 CET] <antlarr> furq: mutagen seems to work great, thanks!
[20:31:30 CET] <antlarr> at least with the file that was giving me problems with ffprobe, I still have to test it with others, but my main app is even written in python, so it even integrates better than running an external application and parsing the output
[20:33:02 CET] <antlarr> as a curious note, mutagen returns a list when requesting the title tag, but for that file for which ffprobe returns two titles, mutagen returns a list with only one element...
[20:33:06 CET] <dannyzb> Hey -- I want to extract the audio track of a video+audio file to a segmented HLS stream. How do I make sure the audio segments are aligned to the video ? ( like what would happen if I output them at the same time )
[20:33:44 CET] <dannyzb> explanation: it's for outputting an alternate audio track. It's m3u8+ts with audio only
[20:58:39 CET] <Sashmo> does anyone know if a way to do a type of QOE test on a source, without have a respective sample to compare it to?  sort of a blind QOE test
[21:21:02 CET] <phillipk> I'm trying to layer multiple audio files on top of one long video (with audio).  when I had just one audio to add (at the beginning), a simple "-filter_complex amix" was working.  Now, I'm seeing something like this (with a more complex filter):
[21:22:11 CET] <phillipk> ffmpeg -i main.flv  -i audio1.wav  -i audio2.wav -filter_complex  <pseudo code>start audio1.wav at 20 seconds, start audio2.wav at 45 seconds...etc</pseudo code>
[22:23:12 CET] <phillipk> the following works as I want--maybe there's a more elegant way?
[22:23:12 CET] <phillipk> ffmpeg -i main.flv -i audio1.wav -i audio2.wav -filter_complex "[1]adelay=20000[b];[2]adelay=45000[c];[0][b][c]amix=3" -f mp4 out.mp4
[22:25:15 CET] <JEEB> you don't need the -f mp4 since it guesses that based on the extension, but that looks like correct and since you will be encoding the audio anyways, the filter way isn't any worse than itsoffset or anything like that
[22:43:50 CET] <rkantos> Could anone point me to some direction with this? http://ffmpeg.org/pipermail/ffmpeg-devel/2015-August/176603.html
[22:44:08 CET] <rkantos> I need QSV JPEG decoding support
[22:44:31 CET] <rkantos> 1. where can I find the patch 2. how can I patch my install / binary
[22:46:42 CET] <JEEB> the patch is there in that very e-mail as the attachment
[22:47:09 CET] <JEEB> although I think the QSV stuff got reworked since and since there were no users for the JPEG decoder I think that might have gotten cut
[22:47:21 CET] <JEEB> so that patch once got in, and then got cut when the QSV interfaces got improved
[22:47:39 CET] <rkantos> Yeah..
[22:47:47 CET] <JEEB> let me double-check so I know I don't speak out of my arse :P
[22:48:57 CET] <rkantos> I wonder why people don't understand the importance or want to use such a thing
[22:49:12 CET] <rkantos> since most of your webcams stream jpegs anyway
[22:49:19 CET] <rkantos> everybody has more money for HW than me :((
[22:49:23 CET] <JEEB> well what do you gain from decoding that with QSV?
[22:49:27 CET] <JEEB> JPEG decoding is fast as hell
[22:49:35 CET] <JEEB> I mean, with something that has QSV
[22:49:46 CET] <rkantos> I dunno
[22:50:05 CET] <JEEB> with 5USD ARM chips it makes sense... kind of
[22:50:14 CET] <JEEB> s/chips/SOCs/
[22:50:15 CET] <rkantos> my x5-z8300 doesn't seem to be able to decode 1280x720 webcam @ 30fps with ffmpeg
[22:50:24 CET] <rkantos> it's a 2W TDP chip..
[22:50:46 CET] <JEEB> ffmpeg -i INPUT -f null -
[22:50:48 CET] <JEEB> try that
[22:50:54 CET] <JEEB> see how fast it goes
[22:50:55 CET] <rkantos> this with just plain ffmpeg and OBS
[22:51:16 CET] <JEEB> well that's a decoding benchmark :P
[22:51:22 CET] <JEEB> INPUT being your input
[22:51:29 CET] <rkantos> it's weird too since with obs at least cpu and gpu never goes above 50%, but it still lags. With plain ffmpeg I get framebuffer nagging etc
[22:51:36 CET] <rkantos> just a sec..
[22:51:56 CET] <JEEB> and yes, there's a trailing "-" because ffmpeg cli wants an output file with null output as well
[22:51:59 CET] <JEEB> "-" means stdout
[22:52:13 CET] <JEEB> which will output nothing there since -f null discards the decoded samples
[23:01:53 CET] <faLUCE> (libavcodec question) Hello. I can grab frames from a v4l2 device, resample them (yuyv422 to yuv420p) , x264-encode them and save the encoded stream into a output.h264 file, which I can see with players. Unfortunately, It's all ok, but I can't mux with libavformat the encoded frames. I used:  "avformat_alloc_output_context2(&avFormatOutputContext, NULL, "mpeg", "foobar"); .....;  av_interleaved_write_frame(
[23:01:54 CET] <faLUCE> avFormatOutputContext, &encodedPkt);"   <----- but I obtain a segfault when I call av_interleaved_write_frame(). Is there something basically wrong with that or I have to valgrind the program?
[23:02:39 CET] <faLUCE> encodedPkt is not  null. And I can write it to the otuput file, and see the output file with a player
[23:04:48 CET] <faLUCE> In addition: I used "foobar" instead of filename. I don't know what to insert as filename, given that there's not a file, but a living source
[23:12:48 CET] <faLUCE> basically the question is: how can I init a format context for a live source?
[23:18:11 CET] <faLUCE> or should I create a buffer file and stream it?
[23:21:01 CET] <BtbN> use a container, don't write a raw h264 file.
[23:22:01 CET] <faLUCE> BtbN: I know that, but for using a container, I have to init a format contect.
[23:22:06 CET] <faLUCE> *context
[23:22:56 CET] <faLUCE> which is the function that I have to call, in order to create this context for a live source?  avformat_alloc_output_context2 seems to be good for a file
[23:25:12 CET] <rkantos> JEEB: I'm getting 1.01x speed with what I presume 1280x720 res... hmm
[23:25:31 CET] <JEEB> rkantos: with live input that's not surprising
[23:25:47 CET] <rkantos> can i just displayit from there with ffplay?
[23:26:01 CET] <JEEB> I would recommend an actual player like mpv
[23:26:08 CET] <faLUCE> sorry I could not read any answer, I had a connection problem
[23:26:08 CET] <faLUCE> [23:22] <faLUCE> which is the function that I have to call, in order to create this context for a live source?  avformat_alloc_output_context2 seems to be good for a file
[23:26:41 CET] <rkantos> JEEB: now it randomly stopped though.. hmm
[23:27:10 CET] <rkantos> JEEB: when I force stopped it I got real-time buffer [video input] too full or near too full..
[23:33:30 CET] <rkantos> JEEB: If I try to stream flv with h264_qsv to a rtmp server, everything just gets dropped because of the same error
[23:34:06 CET] <faLUCE> I alseo tried:    avFormatOutputContext = avformat_alloc_context(); avFormatOutputContext->oformat = "mpegts";   av_interleaved_write_frame(avFormatOutputContext, &encodedPkt);   ----> I have a segfault as well
[23:55:30 CET] <rkantos> JEEB: hmm.. it actually seems to be running.. for some reason though it seems the capture stops if the camera is not moved !
[23:59:59 CET] <rkantos> JEEB: the framebuffer just fills up? :S
[00:00:00 CET] --- Mon Jan 16 2017

More information about the Ffmpeg-devel-irc mailing list