[Ffmpeg-devel-irc] ffmpeg.log.20170118

burek burek021 at gmail.com
Thu Jan 19 03:05:01 EET 2017

[00:00:04 CET] <thebombzen> kepstin: well why not?
[00:00:35 CET] <thebombzen> afaik if you have, say, 24000/1001 as your framerate, PTS should be multiples of 1/1001 afaik
[00:01:09 CET] <thebombzen> wait no hmm there's a reciprocol somewhere
[00:01:59 CET] <furq> actually will that setpts work
[00:02:05 CET] <thebombzen> I don't think so
[00:02:35 CET] <thebombzen> I think you have to use setpts=N/TB
[00:03:05 CET] <thebombzen> it might be N*TB though. I don't know the units of TB
[00:03:10 CET] <furq> that sounds more likely
[00:03:27 CET] <thebombzen> eh, I think the setpts filter says how in the docs
[00:03:59 CET] <thebombzen> it's probably N/(r*TB) where R is the target framerate
[00:04:13 CET] <furq> maybe NB_CONSUMED_SAMPLES/25*TB
[00:04:18 CET] <thebombzen> definitely audio
[00:04:20 CET] <furq> plus some parens
[00:04:36 CET] <thebombzen> consumed_samples is audio afaik. N is the equivalent for video
[00:04:50 CET] <furq> also yeah you'll need corresponding aselect,asetpts if you want to cut the audio as well
[00:05:05 CET] <furq> oh yeah NB_CONSUMED_SAMPLES is audio
[00:05:08 CET] <thebombzen> I've always found asetpts awkward
[00:05:26 CET] <thebombzen> cause asetpts is useful for shifting or standardizing timestamps
[00:05:41 CET] <thebombzen> but setpts, can change the speed and asetpts can't
[00:06:01 CET] <thebombzen> cause if you use asetpts the waveform isn't stretched, just frame-aligned-chunks are
[00:06:18 CET] <furq> i guess that makes sense
[00:06:30 CET] <thebombzen> I know you can fix this with atempo, but atempo doesn't take an expression
[00:06:53 CET] <thebombzen> you can use setpts for cool things like getting the speed up to be quadratic.
[00:07:01 CET] <thebombzen> atempo can't tho
[00:07:23 CET] <furq> i still don't understand why atempo is clamped to [0.5, 2.0]
[00:07:58 CET] <thebombzen> probably internal design stuff
[00:08:03 CET] <thebombzen> but the thing where it asks you to chain it
[00:08:06 CET] <thebombzen> it should just do that itself
[00:08:11 CET] <furq> yeah
[00:08:36 CET] <thebombzen> like have atempo_actual be an internal filter and have atempo chain atempo_actual or something
[00:08:50 CET] <furq> granted i've got no cause to use atempo for anything other than pal to film
[00:08:54 CET] <furq> but still, it's dumb
[00:09:32 CET] <thebombzen> pal to film?
[00:10:15 CET] <furq> 25fps to 24(ish) fps
[00:10:46 CET] <furq> so -af atempo=24000/25025
[00:25:59 CET] <thebombzen> why would you want to convert 25fps to 24000/1001
[00:26:15 CET] <thebombzen> I mean why not just leave it at 25 fps
[00:28:13 CET] <furq> it's not something i do very often
[00:28:48 CET] <furq> and if i do it's normally because i have pal video and ntsc audio
[01:00:56 CET] <phillipk> I'm processing a variety of inputs (well, one at a time) but want to later concat them all.  Some of the inputs have audio in the first stream and others have video in the first stream (and some have no audio)....
[01:01:40 CET] <phillipk> is there an easy way to specify the output to all have identical layout (say, video in first stream and audio in second)?
[01:01:56 CET] <phillipk> seems with concat--they all have to be identical.
[01:03:18 CET] <phillipk> ffmpeg -i randomInput.flv -vcodec mpeg2video -acodec mp2 -f mpegts -ac 2  my_inconsistent_output.ts
[01:04:29 CET] <Afdal> Hey all, I'm trying to pipe the video output indirectly from another program (with a named pipe via mkfifo) that dumps to AVI and I'm getting the following errors
[01:04:37 CET] <Afdal> [avi @ 0xd77100] Format avi detected only with low score of 1, misdetection possible!
[01:04:37 CET] <Afdal> pipe.avi: Invalid data found when processing input
[01:04:43 CET] <Afdal> What do?
[01:05:15 CET] <Afdal> raw AVI, I should say
[01:08:44 CET] <Afdal> Here's some sample command: "mkfifo pipe.avi; mame -aviwrite pipe.avi & ffmpeg -i pipe.avi blahblahblah"
[01:08:54 CET] <Afdal> Am I even doing this right?
[03:01:27 CET] <faLUCE> hello. I created an AVIOContext with a dyn buffer (avio_open_dyn_buf(...)) and a read_packet callback function. Then I linked it to an AVFormatContext pb, When I call av_interleaved_write_frame(AVFormatContext), the read_packet callback function is not automatically called. Do I miss anything?
[04:10:47 CET] <kepstin> phillipk: the stream layout in the output is done with the -map option. So if you add e.g. "-map 0:v -map 0:a", then the output will have 2 streams, the first video stream from the input followed by the first audio stream from the input.
[04:13:53 CET] <phillipk> thanks.  I thought I understood the -map option more for saying what part of a filtergraph to export--I'll test this out!
[04:15:10 CET] <phillipk> I have two inputs: a video (that sometimes has 2 streams, sometimes with audio first, sometimes second) plus an audio.
[04:26:46 CET] <phillipk> I'm not sure -map 0:a will work if the first input has no audio.
[04:57:59 CET] <kepstin> hmm, you might have to just use ffprobe to see what's in the file, and use a script to make the ffmpeg command then
[05:13:52 CET] <alexspeller> I'm trying to scale a video with a filter, the filter is: scale='if(lt(PTS, 10),1920,300)':1080:force_original_aspect_ratio=decrease:eval=frame
[05:14:32 CET] <alexspeller> I'm getting "Undefined constant or missing '(' in 'PTS,10),1920,300)'"
[05:14:56 CET] <alexspeller> So I guess that PTS is not defined there. Is there a constant I can use for the current timestamp of the video?
[05:14:59 CET] <c_14> escape the commas with \
[05:15:20 CET] <c_14> although
[05:15:43 CET] <alexspeller> If I replace it with scale='if(lt(1, 10),1920,300)':1080:force_original_aspect_ratio=decrease:eval=frame it works fine
[05:15:52 CET] <alexspeller> i.e., replacing "PTS" with "1"
[05:16:41 CET] <alexspeller> that makes it look to me like the expression syntax is correct, and I should just be using something different to PTS, if this approach is even viable in the first place
[05:18:31 CET] <c_14> I'm not sure the scale filter supports using timestamps as variables
[05:20:46 CET] <alexspeller> Ah I worried about that, OK thanks!
[05:56:01 CET] <kepstin> I don't think the scale filter supports per-frame evaluation of the parameters - it's just once at startup.
[06:06:17 CET] <damdai>  i found a huge bug in VLC and they are not willing to fix it  http://imgur.com/a/yvyyO
[06:07:48 CET] <kepstin> ... what bug? that image doesn't show anything obvious...
[06:09:03 CET] <kepstin> none of those players are showing the same frame, and the timestamps all only have second accuracy, so ...
[06:12:55 CET] <damdai> kepstin  vlc doesn't match with other 2
[06:13:14 CET] <kepstin> none of those images match
[06:13:28 CET] <kepstin> all three are showing different frames
[06:14:07 CET] <damdai> kepstin  what do you mean image doesn't match
[06:14:19 CET] <damdai> of course it matches
[06:14:32 CET] <kepstin> you have three players open, and all three are showing different frames from the video
[06:14:44 CET] <damdai> within 1 second
[06:14:45 CET] <kepstin> so the fact that the timestamps don't match is completely unsurprising
[06:15:02 CET] <damdai> i am not worreid about 0.01 second difference
[07:42:20 CET] <thebombzen> ohgod this guy
[07:42:34 CET] <thebombzen> ignore them. they've already spammed us enough
[07:45:02 CET] <NiceShot_1> thebombzen who?
[07:46:33 CET] <thebombzen> damdai
[07:46:56 CET] <NiceShot_1> i see
[07:47:12 CET] <NiceShot_1> thebombzen what do you want to do to them
[07:48:56 CET] <thebombzen> lol idk
[07:49:03 CET] <thebombzen> but the previous username was hayha
[07:49:05 CET] <thebombzen> now it's damdai
[07:49:33 CET] <thebombzen> they've been telling us that there's a huge bug in VLC and that the devs don't want to fix it for the last 4 or 5 days
[07:50:04 CET] <NiceShot_1> is it true, the devs don't want to fix it?
[07:50:30 CET] <thebombzen> the "bug" in question is that the timestamps that players show for dvd-video is off
[07:51:01 CET] <NiceShot_1> did anybody else confirm that the bug do exist?
[07:51:04 CET] <thebombzen> we've told this person that the "bug" that the timestamps in dvds are inaccurate because DVDs themselves don't have a format that's perfectly accurate
[07:51:11 CET] <thebombzen> we as in several people on this channel
[07:51:37 CET] <thebombzen> essentially if the player has to guess the timestamp if you pause a dvd after seeking
[07:51:47 CET] <thebombzen> and different players have differnent ways of guessing, which is why vlc is different
[07:51:57 CET] <thebombzen> we've explained this
[07:52:30 CET] <thebombzen> and even if it were true that there were a big bug that VLC devs don't want to fix, #ffmpeg and #mpv are not the place to spam it for four days straight
[07:52:40 CET] <thebombzen> and probalby some other a/v channels I"m not in
[07:52:52 CET] <NiceShot_1> wow #mpv too?
[07:52:54 CET] <thebombzen> yea
[07:53:01 CET] <thebombzen> I have the logs
[07:53:03 CET] <NiceShot_1> and what other channels
[07:53:12 CET] <thebombzen> I don't know. I'm only in these two on freenode
[07:53:30 CET] <thebombzen> but I have logs that he's been going at it since the 14th
[07:53:49 CET] <NiceShot_1> why are you only in  those 2?
[07:54:04 CET] <thebombzen> ¯\_(Ä)_/¯
[07:54:31 CET] <NiceShot_1> thebombzen sounds like you are really upset at this person
[07:54:41 CET] <thebombzen> well it's annoying and spammy
[07:54:49 CET] <NiceShot_1> thebombzen is there anything i can do
[07:55:00 CET] <thebombzen> no there isn't
[07:55:11 CET] <thebombzen> other than ignore this person
[07:55:23 CET] <NiceShot_1> can i curse at this person
[07:56:03 CET] <thebombzen> other than
[07:56:07 CET] <thebombzen> not impersonate that person
[07:56:09 CET] <thebombzen> like I know it's you
[07:56:29 CET] <thebombzen> I'm just entertaining it
[07:56:56 CET] <NiceShot_1> somebody is impersonating this person too?
[07:57:27 CET] <thebombzen> [01:02:32] damdai [~janeja at 2001:0:9d38:6abd:4c8:1cb8:9fcd:ca55] has quit IRC: Ping timeout: 252 seconds
[07:57:27 CET] <thebombzen> [01:23:14] NiceShot_1 [~bmx at 2001:0:9d38:6abd:3414:1cb8:9fcd:ca55] has joined #ffmpeg
[07:57:45 CET] <thebombzen> yes and you're not particularly good at it
[07:58:14 CET] <NiceShot_1> i will be happy to curse at this spammer
[07:58:50 CET] <thebombzen> I'm not sure how long I want to keep this up lol
[07:59:14 CET] <NiceShot_1> cojabo thebombzen is upset
[08:02:23 CET] <CoJaBo> NiceShot_1: ?
[08:03:00 CET] <NiceShot_1> cojabo  according to thebombzen there has been some annoying person that exist in here.  are you aware of this?
[08:03:30 CET] <CoJaBo> it's called a troll
[08:03:45 CET] <NiceShot_1> cojabo did you encounter with this person too?
[08:04:08 CET] <CoJaBo> What nick?
[08:04:23 CET] <NiceShot_1> [22:45] <NiceShot_1> thebombzen who?
[08:04:23 CET] <NiceShot_1> [22:46] <thebombzen> damdai
[10:06:44 CET] <cableguy> team
[10:06:56 CET] <cableguy> how do i join 2 mp3 files into one
[10:07:19 CET] <cableguy> i also looked on eac3to wiki but it doesnt say
[10:07:25 CET] <kerio> join how
[10:08:31 CET] <cableguy> you take 1 mp3 file that is 1h long
[10:08:38 CET] <cableguy> you take 2 mp3 file that is 1h long
[10:08:44 CET] <cableguy> you join them into 1 mp3 file
[10:08:51 CET] <cableguy> and it becomes 1 mp3 file 2h long total
[10:08:55 CET] <cableguy> you know, merge
[10:09:52 CET] <kerio> i can think of at least a couple different ways "join" can be understood
[10:09:56 CET] <kerio> but thanks for being condescending
[10:10:07 CET] <kerio> i want to help you so much now
[10:10:36 CET] <cableguy> whats with the sarcasm
[10:31:38 CET] <cableguy> not sure what >eac3to m1.mp3+m2.mp3 1.mp3 does
[10:31:58 CET] <cableguy> output is the size of both files, but length is only first file's length
[10:33:04 CET] <furq> fwiw i am a certified expert at being condescending on the internet and that barely registered
[10:33:39 CET] <furq> the concat demuxer in ffmpeg should probably work
[10:34:28 CET] <wouter> "ffmpeg -loop 1 -i foo.png -c:v libx264 -pix_fmt yuv420p -framerate 25 -frames:v 125 foo.ts" -- how can I tell ffmpeg that it should add (empty) stereo audio to that?
[10:36:04 CET] <furq> -f lavfi -i anullsrc -c:a aac
[10:36:55 CET] <wouter> furq: thanks
[10:44:24 CET] <furq> also you'll need either -shortest or nullsrc=d=5
[10:45:31 CET] <kerio> is aac the best codec for null audio
[10:48:32 CET] <furq> i'd have to see a listening test
[10:48:40 CET] <kerio> ayy
[10:49:05 CET] <wouter> it is in my situation
[10:49:20 CET] <kerio> furq: well it's like 4kbps
[10:49:30 CET] <wouter> the file is a preroll (opening credits) for some other video
[10:49:36 CET] <kerio> so it's 4kbps of overhead
[10:49:45 CET] <wouter> which I then copy together with concat: and -c copy
[10:49:54 CET] <wouter> so if they're the same codec, that's useful :-)
[10:50:07 CET] <kerio> furq: flac is 4 times smaller
[10:50:16 CET] <furq> why are you telling me this
[10:50:41 CET] <kerio> is there a RLE audio codec
[10:50:55 CET] <furq> you mean like flac
[10:51:05 CET] <kerio> dumber
[11:43:47 CET] <fling> Which app do I need for receiving and sharing rtmp streams?
[11:43:59 CET] <fling> I want something like erlyvideo but better :P
[11:49:17 CET] <BtbN> nginx with the rtmp module.
[12:14:07 CET] <Xys> Hello, is there anyone here ?
[12:20:17 CET] <fling> BtbN: does it support auth and everything?
[12:20:53 CET] <BtbN> I think so, not sure how strong the auth of rtmp is though
[12:21:07 CET] <fling> It looks solid!
[12:23:10 CET] <furq> it doesn't support auth itself but you can do it yourself with on_publish
[12:27:20 CET] <Xys> When I launch a command on MAC OSX, the log in the terminal gets overwritten, especially the frame ones "frame=  548 fps= 91 q=-1.0 Lsize= "
[12:27:29 CET] <Xys> Is there a way to prevent this >?
[12:34:03 CET] <faLUCE> furq: finally I succeded in receiving the mpegts stream with ALL the players :-)
[12:35:01 CET] <fling> furq: by auth we mean something jwplayer sending to the nginx to get the stream access?
[12:35:24 CET] <fling> furq: does the same thing works the either way when we are sending a stream to the server?
[12:35:48 CET] <faLUCE> furq: now I only have to understand how to add an event catcher with libavcodec. Currently I do a main loop() with  av_read_frame(), which returns EAGAIN if the v4l2 frame is not available yet. Then I have a 100%c cpu process
[12:37:16 CET] <faLUCE> is there a select() like function in avlibrary ?
[12:38:10 CET] <Mavrik> I don't think so.
[12:39:31 CET] <faLUCE> Mavrik: then, how can I do an av_read without blocking and without having a huge cpu bound loop?
[12:40:18 CET] <Mavrik> hmm, av_read should be blocking by default
[12:40:22 CET] <Mavrik> did you change the flags?
[12:41:01 CET] <faLUCE> fmt_ctx->flags |= AVFMT_FLAG_NONBLOCK;
[12:41:06 CET] <faLUCE> but I don't want it to block
[12:41:06 CET] <Mavrik> sooo
[12:41:17 CET] <faLUCE> I want to catch the event
[12:41:21 CET] <Mavrik> What event?
[12:41:32 CET] <Mavrik> You said you don't wanna spinlock to wait for av_read_frame
[12:41:39 CET] <Mavrik> So make it blocking, and it'll block until frame is ready.
[12:41:40 CET] <faLUCE> Mavrik: frame from v4l device available
[12:41:51 CET] <faLUCE> Mavrik: no, I'm saying something else
[12:42:34 CET] <faLUCE> I want to manage multiple v4l sources, and catch the events that say when a source has grabbed a frame
[12:42:38 CET] <faLUCE> like select()
[12:42:56 CET] <Mavrik> That's not how ffmpeg API works sadly.
[12:43:03 CET] <Mavrik> Either you'll spinlock and check all the av_read_frame calls
[12:43:14 CET] <Mavrik> Or you create threads for each source with blocking reads that generate events
[12:43:53 CET] <faLUCE> no, I don't want to use threads for that, it's bad coding and designing
[12:45:20 CET] <faLUCE> if libavcodec doesn't have its event catcher, I wonder if it can be used an external event catcher, and link it to the library
[12:45:24 CET] <faLUCE> for example: libevent
[12:52:35 CET] <faLUCE> otherwise I have to call the v4l2 user api without libav
[12:53:20 CET] <faLUCE> bu it would be not portable
[12:53:24 CET] <faLUCE> *but
[12:55:52 CET] <Mavrik> Wth are you talking.
[12:56:14 CET] <Mavrik> That's just hiding threads behind another library.
[12:57:04 CET] <faLUCE> Mavrik: I hate threads used for decoupling stuff. It's bad design, bad coding
[12:57:41 CET] <faLUCE> threads are not intended for decoupling functions an tasks.
[12:58:12 CET] <faLUCE> all the libs should have an event looper
[13:02:54 CET] <faLUCE> Mavrik: are you sure there's not an event catcher/looper in the avlibrary ?
[13:17:00 CET] <furq> fling: https://github.com/arut/nginx-rtmp-module/wiki/Directives#on_play
[13:17:22 CET] <furq> on_play for playback auth, on_publish for streaming auth
[13:17:33 CET] <furq> you just have it redirect somewhere that returns 200 or non-200
[13:18:09 CET] <furq> if you build nginx with the lua module you can do it within the process, but you can use just about anything
[13:19:41 CET] <faLUCE> otherwise, is there a way to obtain the fd of the opened v4l device, so I can put it into the select() function ?
[14:28:08 CET] <olgson> Is there a place with FancyFilters ? :)
[14:28:15 CET] <olgson> or some good tutorial how to create one ?
[14:33:40 CET] <DHE> well, there's this: https://trac.ffmpeg.org/wiki/FancyFilteringExamples
[14:34:00 CET] <DHE> and the technical documentation on the individual filters is at: https://ffmpeg.org/ffmpeg-filters.html
[15:20:25 CET] <olgson> DHE, thnx
[17:21:19 CET] <Diag> Sorry for any spam
[17:48:21 CET] <Xys> Hello, I can't concatenate 2 mp4 videos (the second part is frozen when I play the result). Can I ask for help here please ?
[17:48:40 CET] <BtbN> Are the formats compatible? How are you trying to concat them?
[17:49:02 CET] <Xys> With the concat demuxer : ffmpeg -f concat -safe 0 -i concat.txt -c copy -y result.mp4
[17:49:15 CET] <Xys> Both are mp4 videos
[17:49:35 CET] <Xys> With different resolutions and bitrate, but I'm not sure what is the problem
[17:49:58 CET] <Xys> I can give you more infos if needed ? Thanks in advacne
[17:50:41 CET] <Xys> How do I know if the formats are compatible ?
[17:55:08 CET] <BtbN> Diffrent resolution is enough for it to not work.
[17:55:27 CET] <BtbN> They need to be the exact same codec, resolution and some other critical things
[18:30:39 CET] <zeryx_> duration too I think
[18:30:50 CET] <zeryx_> but that can be fixed pretty easily by adjusting the fps
[18:31:12 CET] <BtbN> uh, no, definitely not the duration
[18:31:34 CET] <BtbN> fps should match though
[18:31:51 CET] <zeryx_> I've concatted videos with quite different fps
[18:31:53 CET] <zeryx_> worked fine
[18:32:15 CET] <BtbN> I think you're not thinking of concatenating.
[18:32:25 CET] <zeryx_> actually you're right
[18:32:35 CET] <zeryx_> I merged video files and ran them simutainously
[18:32:37 CET] <zeryx_> https://www.youtube.com/watch?v=iVsuL8Edqbo
[18:32:55 CET] <zeryx_> concat means different things in different contexts unfortunately
[18:33:06 CET] <BtbN> concat just means appending one after the other.
[18:33:09 CET] <zeryx_> duration no, fps yea
[18:33:20 CET] <zeryx_> resolution, encoding too
[18:33:34 CET] <BtbN> you can concat almost anything if you re-encode at the same time
[18:33:40 CET] <BtbN> But for a -c copy concat, you are very constrained
[18:35:48 CET] <zeryx_> ya true
[18:56:30 CET] <Afdal> I just don't understand why this named pipe to ffmpeg isn't working for me
[18:56:37 CET] <Afdal> I've got this program that dumps to AVI
[18:56:53 CET] <Afdal> raw AVI
[18:56:55 CET] <Afdal> ffmpeg normally can work on said AVI just fine
[18:57:11 CET] <Afdal> but when I try to dump to a named pipe with mkfifo
[18:57:18 CET] <Afdal> and attempt to import that in ffmpeg
[18:57:27 CET] <Afdal> [avi @ 0x2299260] Format avi detected only with low score of 1, misdetection possible!
[18:57:27 CET] <Afdal> pipe.avi: Invalid data found when processing input
[18:57:58 CET] <kepstin> Afdal: I'm guessing your source application is writing AVI in a way that doesn't work properly with pipes - e.g. it does back and fills in some header info after writing the file
[19:01:52 CET] <Afdal> mmm
[19:01:55 CET] <Afdal> doesn't appear to
[19:02:07 CET] <Afdal> I can work on said AVI while the program is actively still dumping to file
[19:02:13 CET] <Afdal> import it to ffmpeg
[19:08:11 CET] <Afdal> Am I even doing this right though?
[19:08:18 CET] <Afdal> mkfifo pipe.avi
[19:08:36 CET] <Afdal> [myprogram's dump] pipe.avi
[19:08:44 CET] <Afdal> ffmpeg -i pipe.avi blahblahblah
[19:21:50 CET] <rjp421> JEEB, using the nightly static git build, the rtmp://user:pass@server output doesnt work, but building without enable-librtmp works
[19:35:14 CET] <klaxa> Afdal: i think it should be: [myprogram's dump] > pipe.avi
[19:37:15 CET] <Afdal> My program doesn't output to sdout though
[19:37:25 CET] <Afdal> that's the whole reason I'm using a named pipe
[19:37:53 CET] <Afdal> pipe.avi would be a normal file if I don't create it with mkfifo first
[19:38:35 CET] <Afdal> stdout*
[19:44:51 CET] <dooome> I have a source-file with res. 704x576, and after crop I have 704x574. SAR=10:11 DAR=16:9. But I cant get the output to be 704x394 it always ends at 704x574.. -vf "crop=...,setsar=sar=1/1,scale=704:-2" does not do the trick or any other line of scale I've tried, except 704:394 ofc. What am I missing?
[19:47:28 CET] <Afdal> setsar=sar=1/1 can be setsar=1/1
[19:50:00 CET] <dooome> Afdal: thx, missed to short that part, but it does not do the trick about the res thou :(
[19:50:12 CET] <Afdal> yeah that's all I know :)
[19:50:32 CET] <Afdal> I've messed around with that sort of thing before but I can't spot your problem
[19:50:48 CET] <Afdal> one other thing to consider is that some codecs only work in 4x4 resolution chunks
[19:52:18 CET] <furq> i don't think there's any way to do that without just working out the resolution
[19:52:37 CET] <furq> although unless your player doesn't support it then you should encode anamorphic anyway
[19:52:49 CET] <furq> also fwiw you can use setsar=1
[19:53:09 CET] <dooome> thx furq
[19:53:45 CET] <dooome> then I will have to do the math before encode
[19:53:59 CET] <furq> why not encode anamorphic
[19:56:47 CET] <dooome> furq: not looking for that in this project :/
[20:05:30 CET] <kepstin> it shouldn't be that hard to build an expression in the scale filter arguments that converts anamorphic to 1/1 sar - I think all the info is available in variables there.
[20:06:46 CET] <furq> maybe
[20:06:58 CET] <furq> it just makes me upset when someone encodes a widescreen dvd non-anamorphic
[20:15:33 CET] <kerio> furq: i wish twitch supported anamorphic video :<
[20:16:18 CET] <dooome> furq: sry for upset you, but to do this I need to get non-anamorphic
[20:16:35 CET] <furq> as long as you have a good reason
[20:17:03 CET] <furq> e.g. "they've kidnapped my wife"
[20:17:13 CET] <dooome> no...
[20:17:20 CET] <dooome> my child
[20:17:26 CET] <furq> you can just have another one
[20:17:49 CET] <dooome> no thanks
[20:18:04 CET] <furq> actually i guess you can't if they've kidnapped your wife
[20:18:13 CET] <furq> fair enough then
[20:19:22 CET] <dooome> its hard to get a new wife also
[20:21:56 CET] <furq> i guess you want scale=h=floor(in_w/dar/2)*2
[20:47:57 CET] <dooome> furq: thx
[20:47:59 CET] <dooome> !
[21:43:40 CET] <auxy> hello ^^ when using x264 CLI I use -seek command to step forward in the video by number of frames; I know with avconv CLI I can use -ss to set a time offset, but is there a way I can set a start time in frames?
[21:44:56 CET] <Guest48412> Hello guys, why my ffmpeg stucks when i try to captire udp stream ? ffmpeg -i udp://IP
[21:45:02 CET] <Guest48412> http://pastebin.com/LZWXg8wJ
[21:53:59 CET] <BtbN> because it's waiting for data
[21:57:05 CET] <sebash> Hi everyone, I am trying to build a simple HLS streaming server just for fun to learn ffmpeg and audio/video stuff (I know there is stuff out there). Basically I am using the segmenter to create 5 seconds segments from a file. The video get's played but it seems there are weird hiccups in the audio between segment boundaries. Does anyone have an idea how to investigate? The command I'm using is here: http://pastebin.com/C58kBeWh
[21:58:21 CET] <Guest48412> BtbN, i sending data and see on interface
[21:58:51 CET] <BtbN> you're sending it to the wrong IP then, or are listening on the wrong.
[21:59:00 CET] <BtbN> And/or port
[22:00:01 CET] <Guest48412> BtbN, i am snding to and listening on triplecheked
[22:00:27 CET] <BtbN> does it work if you just listen on
[22:00:49 CET] <Guest48412> 1 min
[22:02:00 CET] <Guest48412> no same problem
[22:02:14 CET] <BtbN> is ffmpeg listening on the IP/Port you'd expect?
[22:02:33 CET] <Guest48412> yes ./ffmpeg -i udp://
[22:02:42 CET] <BtbN> well, and is it actually doing that?
[22:04:54 CET] <Guest48412> I tryed udp://, udp://, udp://, no success
[22:35:12 CET] <Polochon_street> Hi! I've had an issue where FLAC files with ID3 tags (don't ask me why) shows up as duplicates for ffmpeg. I was about to submit a shitty patch, but actually somebody did https://ffmpeg.org/pipermail/ffmpeg-devel/2015-February/168538.html before me; however, it is still not merged into master. Where do you think I should go to have this merged someday into ffmpeg?
[23:07:29 CET] <infinito> BtbN: this is the gpu select error that might it be a bug http://pastebin.com/bCshKfQt
[23:09:54 CET] <BtbN> Is it possible to launch an ffmpeg process to use gpu 0 at all
[23:10:12 CET] <infinito> no, isnt
[23:10:34 CET] <infinito> the only way to do that is change the azure vm configuration to get only 1 gpu
[23:10:53 CET] <BtbN> Can you add -v trace to the -gpu list command?
[23:11:01 CET] <infinito> yes shure
[23:12:25 CET] <infinito> BtbN: here is the trace http://pastebin.com/p5QTKfPe
[23:13:10 CET] <BtbN> this is weird, with list, if it says "2 CUDA capable devices found", there should also two GPU names follow, no matter what.
[23:15:21 CET] <BtbN> The only case in which this would happen is if cuDeviceGetName or cuDeviceComputeCapability failed.
[23:17:14 CET] <infinito> let my check if i stop one instance of ffmpeg process running (they are in production) it shows again
[23:17:40 CET] <BtbN> Can you test patches?
[23:18:49 CET] <infinito> yes, overnight
[23:19:34 CET] <infinito>  http://pastebin.com/LbVX2Xuh
[23:19:55 CET] <infinito> when i dont use all the ffmpeg instances (6 max) list will work
[23:21:22 CET] <BtbN> this has to be something weird going on with CUDA, can't see what'd be going wrong on the lavc side
[23:22:03 CET] <infinito> im using cuda-8 instead 7.5, can be that?
[23:22:51 CET] <infinito> i can try to recompile all whit cuda 7.5 and test if it runs and report you
[23:22:57 CET] <BtbN> ffmpeg does not use any external cuda headers anymore
[23:23:10 CET] <infinito> ha ok
[23:23:29 CET] <BtbN> it only loads some driver libraries, no need for the CUDA SDK at all
[23:23:55 CET] <infinito> i use it for nppscale
[23:24:05 CET] <BtbN> yeah, that one still needs it
[23:24:12 CET] <BtbN> and that also won't change
[23:24:32 CET] <BtbN> https://github.com/BtbN/FFmpeg you can just compile from here, or apply the two latest commits there to your code
[23:25:17 CET] <infinito> ok BtbN
[23:25:39 CET] <infinito> give me a cupple of hours and i report you
[23:25:59 CET] <BtbN> It's way past 11pm here, so I'll reply tomorror.
[23:26:02 CET] <BtbN> *w
[23:26:08 CET] <infinito> perfect dont worry
[23:26:33 CET] <BtbN> The first patch slightly overhauls the GPU ids, making them persistent independend of supported capabilities
[23:26:49 CET] <BtbN> and the second one just adds more logging for some error cases that "should never happen"
[23:27:33 CET] <infinito> perfect
[23:27:48 CET] <infinito> i try this and back to you tomorrow with the pastebins
[23:28:34 CET] <BtbN> it's really weird and I can't see a reason why it'd only list one of the two GPUs
[23:29:16 CET] <infinito> the reason for me is when ffmpeg try to launch a process in a gpu at top off capacity, it keeps waiting
[23:29:40 CET] <infinito> can't access to resource because it is full, and hangs
[23:29:43 CET] <BtbN> yeah, it has no clue about video engine usage
[23:30:42 CET] <infinito> im just using it troght ffmpeg, im not an expert, but in other instances i get this kind of behaviours from ffmpeg. when gpu is at full capacity new process dont crash, just wait
[23:31:07 CET] <BtbN> That'd be something the nvidia driver does.
[23:31:20 CET] <BtbN> If any of the CUDA or NVENC calls would fail, ffmpeg would abort
[23:31:54 CET] <infinito> yes i undestand
[23:32:05 CET] <infinito> m60 devices using another branch of nvidia drivers
[23:32:28 CET] <infinito> i have a beta version for try overnight today
[23:33:30 CET] <BtbN> I'm also missing some log output
[23:36:16 CET] <BtbN> That's what I'd expect it to look like: https://bpaste.net/show/06027d8bdcc0
[23:36:29 CET] <BtbN> specially the "supports NVENC" part is missing
[23:45:21 CET] <infinito> yes, it happens when the gpu 1 is full
[23:45:56 CET] <infinito> is like hangs waiting for something from nvidia
[23:47:57 CET] <BtbN> oh
[23:48:06 CET] <infinito> but when the gpu 1 is full (only support 6 simultaneous encodings in this case) hangs waiting response of the gpu 1. but, if gpu 1 are ready again, dont continue
[23:48:13 CET] <BtbN> yeah, the first patch should help you then
[23:48:50 CET] <infinito> excelent!
[23:49:07 CET] <BtbN> it skips needlessly initializing all GPUs, but only the requested one. So when GPU #0 is full, right now it also goes through the init of that one, and hangs there
[23:49:49 CET] <infinito> yes, exactly i think whats append
[23:50:15 CET] <infinito> nvidia driver must handle that in other way maybee
[23:50:30 CET] <infinito> i can report that to nvidia if it works well
[23:50:34 CET] <BtbN> hanging doesn't seem like a good option in any case, yes
[23:52:41 CET] <BtbN> list still won't work though, one second
[23:57:04 CET] <BtbN> ok, updated the patches. Now list also won't hang.
[23:57:21 CET] <BtbN> At least I hope so. If it hangs even earlier than that, well, hm
[23:58:01 CET] <infinito> i hope too!
[23:58:15 CET] <infinito> ok, in a few hours i be able to test it
[23:58:27 CET] <infinito> cross fingers xD
[23:59:31 CET] <BtbN> did you also contact nvidia about that issue, by any chance?
[23:59:56 CET] <BtbN> They sent a patch today that would have also fixed it
[00:00:00 CET] --- Thu Jan 19 2017

More information about the Ffmpeg-devel-irc mailing list