[Ffmpeg-devel-irc] ffmpeg.log.20170119

burek burek021 at gmail.com
Fri Jan 20 03:05:01 EET 2017

[00:02:21 CET] <infinito> i will contact them, before chatting whit you i dont have the certainly of nvidia driver bug
[00:02:40 CET] <BtbN> I wouldn't even call it a bug, just odd behaviour
[00:20:40 CET] <pbos> can I capture mjpeg off /dev/video0 easily without transcoding it?
[00:23:15 CET] <thebombzen> pbos: if v4l2 provides mjpeg you can use -c copy
[00:23:36 CET] <thebombzen> but mjpeg is just sequences of jpeg frames so I would recommend transcoding it for most purposes
[00:23:42 CET] <thebombzen> cause mjpeg is huge
[00:28:47 CET] <pbos> thebombzen: thanks :)
[05:03:52 CET] <THB> anybody here?
[05:50:46 CET] <JeffATL> i know how to use "-map" to merge an video stream with a separate audio stream. is there a way i can take the v and the a from a video and route it through sox to do some on-the-fly filtering?
[05:54:41 CET] <JeffATL> whether i'd need to spilt off the audio into a 2nd file or not
[05:55:00 CET] <JeffATL> i can imagine doing something like:
[05:59:00 CET] <Diag> JeffATL: filtering on the fly like this? http://i.imgur.com/tVj9biw.jpg
[06:00:49 CET] <JeffATL> sox -foo  audiofile.wav -bar - | ffmpeg -i videofile.mpg -i  -map 0:v -map 1:a blah blah blah
[06:00:54 CET] <JeffATL> Diag: cute
[06:00:57 CET] <Diag> :P
[06:01:32 CET] <JeffATL> oh wait, let me try again
[06:01:39 CET] <JeffATL> sox -foo  audiofile.wav -bar - | ffmpeg -i videofile.mpg -i - -map 0:v -map 1:a blah blah blah
[06:01:51 CET] <JeffATL> forgot a dash
[06:37:06 CET] <Nosomy> ffmpeg have problem to decode FPS1 format? (Fraps Codec).
[06:43:37 CET] <satendra> Hi .....
[06:43:50 CET] <Diag> yo
[06:43:57 CET] <satendra> hello sir
[06:44:21 CET] <satendra> I have confusion , I am working with ffmpeg from more than 1 year
[06:44:47 CET] <Diag> aight whats up fam
[06:45:01 CET] <satendra> I want make a video conference server more than 5 users at a time , Is that is possible with ffmpeg or ffserver
[06:45:40 CET] <satendra> I did only point to point communication never did with server
[06:45:54 CET] <Diag> That is an excellent question, and someone else could probably answer that
[06:46:08 CET] <satendra> thank you
[06:53:23 CET] <Nosomy> http://pastebin.com/q7tVfxXi <-> https://ffmpeg.org/pipermail/ffmpeg-devel/2005-May/003544.html,  old problem?
[07:14:31 CET] <satendra> which video tool is best and high performance  for make a linux based video conferencing server and also recorder more than 5 users at a time
[07:14:43 CET] <satendra> please anyone hemp me
[07:15:23 CET] <Diag> satendra: sometimes ircing takes some patience
[07:15:34 CET] <Diag> you gotta figure its 1am here in the usa
[07:15:56 CET] <satendra> ohhh
[07:16:01 CET] <Diag> lol
[07:46:39 CET] <JeffATL> satendra: there was a videoconference reflector for linux in the 1990s but i have not looked into the concept since.
[07:49:06 CET] <JeffATL> satendra: in any case, what you probably are looking for is googlable under "videoconference reflector" and associated clients.
[07:51:25 CET] <satendra> JeffATL : hi
[07:51:30 CET] <satendra> thanks for reply
[07:51:46 CET] <JeffATL> satendra: you'e welcome and good luck.
[07:52:17 CET] <satendra> I am confusing which one is good and high performance tool which one I can use like ffmpeg , gstreamer or webrtc
[07:52:44 CET] <satendra> for streaming server
[07:53:27 CET] <JeffATL> satendra: also, the standard you are probably looking for is h.263; i don't know if h.264 supplanted it since or jsut what
[07:54:08 CET] <satendra> no I want h.264
[07:54:14 CET] <JeffATL> satendra: if you wanted to come up with a reflector or client from scratch, ffmpeg might be one of the moving parts. perhaps in the client, not the server.
[07:54:55 CET] <JeffATL> satendra: see https://books.google.com/books?id=n9YVhx2zgz4C&pg=PA87&lpg=PA87&dq=h.263+reflector&source=bl&ots=8ZbLZpmLl7&sig=aNxXFgautDXFGdVYAnfws0AFFOw&hl=en&sa=X&ved=0ahUKEwj7ruXGz83RAhXLSyYKHcGvCB4Q6AEIITAB#v=onepage&q=h.263%20reflector&f=false
[07:55:26 CET] <satendra> I want 5 clients do chat via a video server that server can pass stream to each client and also record
[07:56:02 CET] <satendra> ok
[08:24:31 CET] <JeffATL> satendra: the key is, do you want a dedicated v'conf client app or something that appears in a browser window. those are two different approaches to the basic problem
[08:25:50 CET] <satendra> there will be a browser window or there will be our own video window like skype
[08:26:14 CET] <satendra> JeffATL :
[08:26:48 CET] <satendra> I give you complete picture which I want
[08:27:13 CET] <JeffATL> satendra: that's kind of a repeat of what i said
[08:29:28 CET] <satendra> Suppose there have 5 clients , they want a video conference call , they want connect via video call  so each client have 5 windows one of his and four of their friends that communication will be established via a server which can connect clients with each other and also record there video
[08:29:49 CET] <satendra> I want which tool is best for me make client and server
[08:29:52 CET] <satendra> ??
[08:30:44 CET] <Diag> Skype?
[08:31:26 CET] <JeffATL> diag: think non-corporate skype
[08:33:00 CET] <JeffATL> satendra: i would say that unless you want to deal with all manner of cross-browser weirdness, developing a client app and a server app is probably what I would do but i'm not a developer
[08:37:15 CET] <JeffATL> satendra: but do survey what is already out there
[08:40:41 CET] <JeffATL> satendra: good luck
[09:00:38 CET] <satendra> thank you sir
[09:01:32 CET] <satendra> I will be handle but I always need this channel because during my initial period of career I get many solutions from there
[09:01:47 CET] <satendra> I hope someone help me again
[09:01:50 CET] <satendra> :)
[12:22:41 CET] <thebombzen> durandal_1707: shouldn't the title be changed to ffmpeg 3.2.2
[12:23:03 CET] <thebombzen> you're also wearing the +o hat so now's a good time
[12:23:03 CET] <durandal_1707> yes, and?
[12:23:08 CET] <thebombzen> just wondering
[12:23:15 CET] <thebombzen> you've got the authority to do it
[12:23:31 CET] <thebombzen> but it's out of date. like idc much just figured I would let you know
[12:23:37 CET] <durandal_1707> too busy
[12:23:45 CET] <thebombzen> whatevs
[13:38:54 CET] <DeathShot> I'm having trouble building ffmpeg in a freeNAS freeBSD 10.3 jail: http://pastebin.com/EiBhXPyw
[13:43:14 CET] <DeathShot> I have perl 5.24.1 installed which pkg tells me is the latest version, I saw in the dependencies for ffmpeg that it needs perl under 25, ideally 24, so I don't see why this doesn't work.
[13:56:57 CET] <thebombzen> DeathShot: is there a reason you're using such an old version of FFmpeg
[14:00:21 CET] <DeathShot> thebombzen, it's what freeBSD has apparently
[14:00:42 CET] <DeathShot> I ran portsnap fetch update
[14:00:46 CET] <DeathShot> make config
[14:00:59 CET] <DeathShot> and then make install clean
[14:01:10 CET] <DeathShot> before that pkg update && pkg upgrade
[14:03:11 CET] <thebombzen> well I would recommend cloning the git master and try again
[14:03:24 CET] <thebombzen> because that's an old version
[14:04:03 CET] <DeathShot> well that would be a fun advanture
[14:04:10 CET] <DeathShot> in a few hours I have to go now
[14:04:13 CET] <thebombzen> it would be, but ffmpeg shouldn't need perl to install itself
[14:04:30 CET] <thebombzen> I'm not sure why you need perl and if you were to build from upstream then there should be no issue
[14:05:13 CET] <thebombzen> either way if you don't want to do that, then the Makefile is improperly detecting perl for some reason
[14:05:30 CET] <thebombzen> that reason could be relevant or insiginficant but either way you could just edit the Makefile
[14:32:29 CET] <DeathShot> thebombzen, pearl got installed with vim
[14:33:16 CET] <DeathShot> I'm pretty sure either BSD 10.3 repos are out of date, or FreeNAS uses special repos which are out of date.
[14:33:27 CET] <DeathShot> Also I'm on a train so connection will be iffy
[14:36:38 CET] <DeathShot> mfw there are no official guides as to how to compile ffmpeg on freebsd
[14:42:53 CET] <DeathShot> I'll see if emby can work with the latest ffmpeg on freebsd
[14:58:53 CET] <DeathShot> I'll see if I can figure out how to compile ffmpeg on freebsd first
[14:59:10 CET] <Xys> Hello, where can I ask for help regarding an ffmpeg command please ? Can I send a mail to ffmpeg-user at ffmpeg.org ?
[14:59:42 CET] <Xys> Are there particular rules ?
[15:03:49 CET] <DeathShot> Idk but that's something the wiki probably does
[15:55:52 CET] <andrey_utkin> funny thing about ffmpeg's default option -stdin:
[15:56:01 CET] <andrey_utkin> (echo ffmpeg -f lavfi -i testsrc=duration=1 -codec:v rawvideo -f null null; echo echo) | bash -e -x
[15:56:16 CET] <andrey_utkin> gives "bash: line 2: cho: command not found"
[15:56:24 CET] <andrey_utkin> add -nostdin to fix that
[15:59:01 CET] <Xys> Is anyone using ffmpeg on mac ?
[16:00:00 CET] Last message repeated 1 time(s).
[16:00:13 CET] <Xys> When I execute a command, all the "current frame processed" progress infos are written on one line only, it overwrites the previous info
[16:00:42 CET] <BtbN> you mean the status line? Yes, that's how it works.
[16:13:18 CET] <thebombzen> Xys: that's intentional
[16:13:21 CET] <thebombzen> otherwise it'll be spam
[16:13:51 CET] <Xys> Is there any way to prevent it ?
[16:14:00 CET] <Xys> I would like to copy all the infos
[16:14:07 CET] <Xys> thanks for your answer !
[16:14:16 CET] <thebombzen> you could pipe it into tr '\r' '\n'
[16:14:25 CET] <thebombzen> like ffmpeg <stuff> | tr '\r' '\n'
[16:14:43 CET] <thebombzen> the way it does that is a carriage return character '\r' move the cursor to the front of the line
[16:14:50 CET] <thebombzen> if you replace that with newline it'll just start a new line
[16:15:18 CET] <thebombzen> although afaik if you redirect stderr to a file, ffmpeg will do that for you, but I might be wrong.
[16:16:18 CET] <thebombzen> nvm no it won't, they'll still be \r, but you can copy them if you open in a text editor
[16:16:52 CET] <thebombzen> my bad, piping won't work because it's standard error
[16:17:05 CET] <thebombzen> you can redirect stdandard error to stdout before piping but then you must be outputting ffmpeg to a file
[16:18:17 CET] <thebombzen> i.e. if you do ffmpeg <stuff> 2>&1 | tr '\r' '\n' that'll work
[16:18:25 CET] <thebombzen> but you must be writing to a file otherwise it'll get messed up
[16:28:39 CET] <thebombzen> You can actually do it like so as well
[16:28:56 CET] <thebombzen> ffmpeg stuff 2> >(tr '\r' '\n')
[16:28:58 CET] <thebombzen> but this requires BASH
[16:29:02 CET] <thebombzen> not sure if OSX has it
[16:29:10 CET] <thebombzen> Xys: did that answer your question?
[16:29:11 CET] <furq> it does but it's an old bash
[16:29:17 CET] <furq> it probably has that though
[16:30:30 CET] <thebombzen> lol bash 1.14 has it
[16:30:32 CET] <thebombzen> vintage 1994
[16:30:34 CET] <thebombzen> they're good
[16:36:53 CET] <Xys> thebombzen : Yes thank you very much !
[16:36:57 CET] <Xys> 2> >(tr '\r' '\n') did the trick !
[16:37:00 CET] <andrey_utkin> Xys, this info may be not intended for parsing by scripts... usually scripts are supposed to use -nostats option which avoids that output completely... there may be some another option which would be handy for you
[16:38:35 CET] <Xys> andrey_utkin : do you mean there should be an ffmpeg option to avoid the overwrite ?
[16:38:43 CET] <Xys> Sorry not sure to understand ^^
[16:39:30 CET] <andrey_utkin> Xys, are you writing a wrapper script/app which wants to parse and visualize ffmpeg progress report?
[16:39:40 CET] <andrey_utkin> or are you just interested in detailed log of ffmpeg's work?
[16:40:01 CET] <Xys> just interested in detailing the log :D I'm used to the android log, which stacks those infos
[16:40:22 CET] <Xys> Not sure if they are really relevant though..
[16:41:06 CET] <Xys> Actually I have a problem with contatenating 2 mp4 videos, with the concat demuxer. The result is not playable
[16:41:24 CET] <Xys> Do you know if DTS errors/warning in the concat log could cause a problem in the playback ?
[16:41:50 CET] <andrey_utkin> Xys, discover "-loglevel debug"
[16:42:31 CET] <andrey_utkin> DTS errors can be sympthoms of problems in playback
[16:42:59 CET] <andrey_utkin> Xys you shouldn't use concat demuxer on files which are not of same origin or are not of same properties
[16:44:29 CET] <Xys> andrey_utkin, so the only solution would be the concat filter you think ?
[16:44:44 CET] <andrey_utkin> Xys, depends on files you need to concat
[16:44:50 CET] <andrey_utkin> on their origin
[16:45:12 CET] <Xys> only mp4 videos, from different origins (different resolution, bitrate etc)
[16:45:43 CET] <andrey_utkin> if demuxer works at last some times, you may be opportunistic and  try demuxer first, then analyze for errors (by running ffmpeg to decode all files and listening for errors in output), then incase of problems retry with filter
[16:45:48 CET] <Xys> It seemed so far that I could concat several videos with different resolutions / bitrate, with the concat demuxer, without any problem
[16:46:04 CET] <andrey_utkin> you'll be safer with filter of course
[16:46:08 CET] <kerio> i find that hard to believe tbh
[16:46:17 CET] <kerio> would video players even play that
[16:46:37 CET] <andrey_utkin> kerio, i guess he could achieve that, at last with some container formats like mpegts :)
[16:47:13 CET] <andrey_utkin> flv also seemed robust in terms of sudden change of resolution in middle of video
[16:48:22 CET] <Xys> Yes I tested with the android player, VLC, and quicktime
[16:48:38 CET] <Xys> worked fine, except with this one video...
[16:49:31 CET] <Xys> Concat 2 videos with the concat filter on android is taking ages, that's why I would like to avoid it, but if I don't have the choice..
[16:50:12 CET] <Xys> thank you a lot everyone
[16:50:17 CET] <kerio> remux into mpegts, cat them together, try to read back?
[16:53:05 CET] <Xys> Lets say you have 2 videos with different formats, one that lasts 2min, the other one 1,5 seconds. You want to concat them, but not re-encode 2min+ of video time
[16:53:29 CET] <Xys> I guess you can only re-encode the 2nd video to match the first one no ?
[16:53:43 CET] <andrey_utkin> Xys, you can't if you haven't reencoded the first one
[16:54:15 CET] <andrey_utkin> you may be unable to match "global headers" of first file in second file
[16:54:52 CET] <andrey_utkin> that's hard business, stitching files :)
[16:55:09 CET] <andrey_utkin> try ultrafast preset of libx264 encoder
[16:56:44 CET] <Xys> Oh really ? But the concat demuxer works and it does not re-encode everyting ?
[16:58:43 CET] <andrey_utkin> Xys you see yourself that it doesn't always work
[16:59:45 CET] <andrey_utkin> Xys also check x264 option "stitchable"
[17:09:51 CET] <DeathShot> so I am building latest ffmpeg from source, I ran ./config and am now running gmake
[17:10:11 CET] <DeathShot> will I have lame amongst other thigns in here? Do I enable that later? Did I miss a step?
[17:11:17 CET] <DeathShot> I believe they are disabled by default but I don't know how to enable them
[17:12:20 CET] <DeathShot> ahh they are flags on ./configure
[17:12:24 CET] <DeathShot> fml
[17:24:59 CET] <dynamikus> Hi guys i am trying to find a list of video mime types that are used to serve fragmented video streams so far I have come across video/mp2t, video/f4f,video/f4m. Does any of you have any information if there are other mime types?
[17:27:53 CET] <Xys> andrey_utkin Okay thanks, so I guess concat filter is the only option :p
[17:31:54 CET] <DeathShot> fml
[17:32:13 CET] <DeathShot> thank God I'm back to normal font size
[17:36:50 CET] <andrey_utkin> DeathShot, check output of your ./configure
[17:37:54 CET] <DeathShot> andrey_utkin, I canceled the gmake and I'm doing ./configure again because I didn't specify any flags
[17:38:08 CET] <DeathShot> right now I'm seating at: ./configure  --enable-gpl --enable-nonfree --enable-libass --enable-libfdk-aac --enable-libx264 --enable-libmp3lame --enable-libx265 --enable-openssl
[17:38:30 CET] <DeathShot> I just need opus
[17:38:36 CET] <DeathShot> and I need to make sure I can get subtitles on all of those
[17:39:04 CET] <c_14> If you only need opus, why are you enabling libfdk-aac etc
[17:39:15 CET] <DeathShot> I mean in addition to those
[17:39:26 CET] <c_14> --enable-libopus
[17:39:28 CET] <c_14> probably
[17:39:39 CET] <c_14> check ./configure --help
[17:39:40 CET] <furq> you probably also want fontconfig and libfreetype for subtitles
[17:39:47 CET] <furq> and maybe libfribidi
[17:39:58 CET] <DeathShot> yeah so I have been going through ./configure --help
[17:40:13 CET] <DeathShot> it's just that there are so many flags and I don't nkow what most do, so its easy to miss some that I probably need
[17:40:17 CET] <furq> what os is this
[17:40:26 CET] <DeathShot> FreeBSD
[17:40:32 CET] <furq> why not build from ports
[17:40:36 CET] <DeathShot> too old
[17:40:41 CET] <furq> 3.2.2 is in ports now
[17:40:42 CET] <DeathShot> apperantly
[17:40:45 CET] <DeathShot> not for me
[17:40:48 CET] <furq> weird
[17:40:53 CET] <furq> i'm still on 9.3 and it's in ports here
[17:41:01 CET] <DeathShot> when I tried it I was getting 2.7
[17:41:04 CET] <furq> it was stuck on 2.8 until fairly recently
[17:41:14 CET] <c_14> It's there for me
[17:41:15 CET] <DeathShot> maybe it's freeNAS
[17:41:20 CET] <furq> yeah i'm on freenas
[17:41:29 CET] <furq> not the latest either
[17:41:40 CET] <DeathShot> are you on 9.3?
[17:41:43 CET] <DeathShot> maybe that's the reason
[17:41:51 CET] <furq> did you run portsnap fetch update
[17:41:55 CET] <DeathShot> I did
[17:41:59 CET] <furq> weird
[17:42:09 CET] <DeathShot> says I'm up2date
[17:42:17 CET] <furq> maybe you need a newer jail template
[17:42:29 CET] <DeathShot> its a FreeBSD 10.3 template
[17:42:33 CET] <furq> oh
[17:42:35 CET] <furq> that's very weird then
[17:42:38 CET] <furq> mine's still running 9.x
[17:42:50 CET] <DeathShot> its possible they updated it for 9.3 but not 10.3
[17:42:54 CET] Action: DeathShot shrungs
[17:42:57 CET] <DeathShot> shrugs*
[17:43:04 CET] <furq> that doesn't seem right but i'm not an expert
[17:43:08 CET] <DeathShot> doesn't matter, at this point I'm commited to building it from scratch!
[17:43:21 CET] <DeathShot> build all the things from source
[17:43:23 CET] <DeathShot> MWAHAHAHA
[17:43:47 CET] <c_14> You probably don't need more than what you have already and what furq mentioned
[17:43:59 CET] <c_14> And you probably don't even need fribidi
[17:44:09 CET] <furq> yeah fribidi is for bidirectional text layout
[17:44:14 CET] <furq> if you just want english subs you don't need it
[17:44:43 CET] <furq> you'll definitely want fontconfig, and iirc you need libfreetype to build libass, so you might as well add that
[17:44:57 CET] <furq> i forget what that actually gets you in ffmpeg but it obviously does something
[17:45:00 CET] <c_14> Well, you don't _need_ fontconfig
[17:45:10 CET] <c_14> It's just a pain if you don't add it
[17:45:11 CET] <furq> you don't need it but life is much more annoying without it
[17:45:12 CET] <DeathShot> yup
[17:45:17 CET] <DeathShot> I'm building an Emby server
[17:45:21 CET] <DeathShot> so I think I got all I need
[17:45:31 CET] <furq> you need to burn in subs right
[17:45:36 CET] <furq> otherwise you don't need any of this
[17:45:58 CET] <c_14> freetype is only drawtext afaik
[17:45:58 CET] <DeathShot> I need all the subs
[17:46:13 CET] <furq> well yeah but if they're softsubs then ffmpeg will handle that regardless
[17:46:13 CET] <DeathShot> also not all my subs are in English, or left to right for that matter
[17:46:23 CET] <DeathShot> and I'm not just talking about random subs off theitnernet, I'm talking about subs that I read.
[17:46:24 CET] <furq> you only need libass et al if you want to burn them into the picture
[17:47:07 CET] <DeathShot> yeah it's helpful to have
[17:47:18 CET] <furq> probably
[17:47:21 CET] <DeathShot> I'm pretty sure Emby will bitch without it
[17:47:27 CET] <furq> it's not a big deal to add it anyway
[17:47:45 CET] <DeathShot> the official requirements are: # enable the lame option
[17:47:45 CET] <DeathShot> # enable the ass subtitles option
[17:47:45 CET] <DeathShot> # enable the opus subtitles option
[17:47:45 CET] <DeathShot> # enable the x265 subtitles option
[17:47:54 CET] <DeathShot> I have ./configure  --enable-gpl --enable-nonfree --enable-libass --enable-libfdk-aac --enable-libx264 --enable-libmp3lame --enable-libx265 --enable-openssl --enable-libopus --enable-libfontconfig --enable-libfreetype --enable-libfribidi
[17:47:56 CET] <furq> "opus subtitles" what
[17:48:12 CET] <furq> that looks like a bad cut&paste job
[17:48:21 CET] <DeathShot> it's not
[17:48:29 CET] <c_14> I think it's just --enable-fontconfig and --enable-freetype
[17:48:29 CET] <DeathShot> https://emby.media/freebsd-server.html
[17:48:41 CET] <furq> i meant on their part
[17:48:41 CET] <c_14> eh -fontconfig but libfreetype
[17:49:21 CET] <DeathShot> well I also have x265 HEVC 4K videos too
[17:49:26 CET] <furq> that's a worrying selection of codecs
[17:49:32 CET] <c_14> libx265 isn't used for decoding video at all
[17:49:44 CET] <furq> i doubt your nas is going to handle x265 encoding
[17:49:50 CET] <furq> and not much will play that back
[17:50:02 CET] <DeathShot> plex let me play it :|
[17:50:13 CET] <c_14> I doubt the NAS will handle 4K HEVC decoding (unless you have a hardware chip)
[17:50:18 CET] <furq> yeah that too
[17:50:29 CET] <DeathShot> I do have a GeForce card in there
[17:50:42 CET] <furq> i've never really understood these media servers though
[17:50:58 CET] <DeathShot> well I had it in there, I'll put it back now I suppose
[17:51:09 CET] <DeathShot> anything I need to add to the flags to get it to play with nvidia cards?
[17:51:21 CET] <c_14> vdpau
[17:51:37 CET] <c_14> That's autodetect though
[17:51:38 CET] <furq> is cuvid still an option or did that get folded into vdpau
[17:51:40 CET] <c_14> so it should be fine
[17:51:50 CET] <c_14> cuvid is also autodetect
[17:51:53 CET] <DeathShot> okay so I wont add that flag
[17:51:57 CET] <furq> assuming your card is new enough to support that
[17:52:01 CET] <DeathShot> okay I'm just going to use what I have and hope for the best
[17:52:11 CET] <DeathShot> well that's a problem
[17:52:18 CET] <c_14> You should check the configure output to make sure it got activated though
[17:52:20 CET] <DeathShot> does the card ahve to be in when I run ./configure
[17:52:27 CET] <c_14> No
[17:52:30 CET] <c_14> But you need the libraries
[17:52:32 CET] <BtbN> neither cuvid nor vdpau decoding "just work" though
[17:52:35 CET] <furq> i assume you need the drivers installed yeah
[17:52:36 CET] <BtbN> they all need special treatment
[17:53:08 CET] <c_14> I assume the media server should be capable of handling that though
[17:53:19 CET] <DeathShot> so I'm currently about 30 miles from home, I wont be home for another 2 hours at least, but I will probably pass out when I get there.
[17:53:26 CET] <BtbN> for cuvid, you don't need any libraries at buildtime, it's pretty much always built when building on x86/amd64
[17:53:41 CET] <DeathShot> I would rather build it now
[17:54:06 CET] <c_14> Do you have a libvdpau.so lying around somewhere?
[17:54:10 CET] <DeathShot> so if I build it with what I have now, and add the card later, it will work.
[17:54:21 CET] <DeathShot> libvdpau :?
[17:54:33 CET] <c_14> yes
[17:54:46 CET] <c_14> If that's installed (and you have the correct headers etc) it should work even if the card isn't in there
[17:54:55 CET] <c_14> s/work/configure+compile/
[17:54:58 CET] <DeathShot> I don't think I do
[17:55:40 CET] <DeathShot> is it a part of the gfx drivers for freebsd?
[17:55:56 CET] <c_14> multimedia/libvdpau
[17:55:57 CET] <BtbN> oh, bsd
[17:56:00 CET] <BtbN> no cuvid on bsd
[17:58:05 CET] <DeathShot> should I insall te driver anyways?
[17:58:11 CET] <c_14> can't hurt
[17:59:15 CET] <BtbN> well, without the drivers, you won't have any kind of acceleration
[18:00:03 CET] <DeathShot> well then drivers are downloading
[18:01:58 CET] <DeathShot> I think I downloaded the x86 drivers tand they aren't compatible with x64
[18:26:07 CET] <DeathShot> what I am doing here cannot leave this room
[18:29:39 CET] <DeathShot> this most minimal install of x is taking such a long time to build
[18:30:40 CET] <DeathShot> I'm never going to run it even I just need it to install the nvidia drivers
[18:31:22 CET] <DeathShot> x blows so many duck dicks anyways, its dumb to force it on you
[18:31:45 CET] <BtbN> vdpau only works via X
[18:31:51 CET] <BtbN> There is no other interface to it
[18:32:11 CET] <DeathShot> yeah, that's why I'm installing it
[18:32:26 CET] <DeathShot> but very minimally
[18:32:34 CET] <DeathShot> since I'll never actually run the ui
[18:32:50 CET] <BtbN> it needs to run though, with the nvidia driver active
[18:32:56 CET] <DeathShot> yeah I know
[18:33:13 CET] <DeathShot> I mean like I'm never going to have a DE running
[18:33:21 CET] <DeathShot> there will never be a single graphical image on this box
[18:33:29 CET] <DeathShot> ever
[18:34:23 CET] <DeathShot> honestly I might be over doing it, most of the transcoding could be done on theclient anyways
[18:34:37 CET] <DeathShot> by default I don't have my server doing transcodes unless there is no alternative
[18:35:08 CET] <BtbN> If you had no bsd on that thing, cuvid would work fine fully headless
[18:36:04 CET] <DeathShot> no bsd? at in linux?
[18:36:07 CET] <DeathShot> as*
[18:36:19 CET] <BtbN> Well, it's supported on Linux and Windows
[18:39:48 CET] <DeathShot> will this never end?
[18:40:06 CET] <DeathShot> BtbN, just how many spare servers do you  think I have :P
[18:45:09 CET] <DeathShot> it has easily been 25 minutes now
[18:45:19 CET] <DeathShot> is x rebuilding my computer from sand?
[18:46:34 CET] <DeathShot> is it transforming sand into silicon and laying down gold tracks?
[19:26:08 CET] <thebombzen> if you're not going to be displaying video
[19:26:13 CET] <thebombzen> why do you need to be able to decode it
[19:26:17 CET] <thebombzen> via hardware that is
[19:26:31 CET] <thebombzen> what's wrong with avcodec's h.264 decoder if you're not displaying the video
[19:28:58 CET] <DeathShot> thebombzen I don't know, i thought it would help with thranscoding on the fly to the client
[19:29:22 CET] <thebombzen> is your nasbox going to have the cpu power to transcode on the fly?
[19:29:36 CET] <thebombzen> because if it doesn't have the cpu power to decode on the fly
[19:29:43 CET] <thebombzen> it definitely won't have the cpu power to encode on the fly
[19:30:12 CET] <thebombzen> you'd have to use Nvenc to get realtime speeds, but hardware encoders are bad so you're probably best just not transcoding
[19:30:20 CET] <thebombzen> if you have to use a hardware encoder that is
[19:30:54 CET] <DeathShot> I thought having a gfx would make it faster :(
[19:31:09 CET] <DeathShot> Via hardware acceleration
[19:31:46 CET] <thebombzen> well it will, but keep in mind that encoding is far more expensive that decoding
[19:32:02 CET] <thebombzen> so cpu encoding + gpu decoding is only marginally better than cpu encoding + cpu decoding
[19:32:26 CET] <thebombzen> gpu encoding is much much faster (can be done in realtime!) but it's also got a terrible quality to bitrate ratio
[19:32:59 CET] <thebombzen> so transcoding it would either require you to up the bitrate significantly or drop the quality significantly (probably) compared to the source
[19:33:05 CET] <thebombzen> in which case why bother transcoding in realtime
[19:33:12 CET] <thebombzen> there might be a reason but I'm skeptical
[19:33:48 CET] <thebombzen> to give you an idea, hevc_nvenc is worse than x264 in quality-per-bitrate
[19:34:04 CET] <thebombzen> and h264_nvenc is far worse
[19:39:07 CET] <furq> what cpu have you got in there
[19:40:10 CET] <BtbN> decoding 4K HEVC can easily use more CPU than encoding 720p h264 or something.
[19:40:24 CET] <furq> certainly with libavcodec
[19:41:08 CET] <DeathShot> I won't watch it if it's less than 8mb/s
[19:41:16 CET] <DeathShot> My phone crashed
[19:42:02 CET] <DeathShot> However some of my less compressed video sometimes surpasses my outdoor connection speed
[19:42:02 CET] <BtbN> 8mbit/s is excessive for 720p
[19:42:23 CET] <DeathShot> There are some exceptions
[19:42:28 CET] <DHE> Sports channels might run that fast
[19:42:39 CET] <DeathShot> However generally I don't watch under 1080p br
[19:42:52 CET] <DHE> (speaking as someone who does deal with TV feeds regularly)
[19:43:08 CET] <DeathShot> My phone is qhd my laptop is uhd my monitor is uhd
[19:43:11 CET] <furq> why would you watch 1080p over 720p on a phone
[19:43:33 CET] <furq> next you'll be telling me you only listen to flac on there
[19:43:38 CET] <DeathShot> Because my phones resolution is like 4x 1080p?
[19:43:39 CET] <thebombzen> cause some phones have 1080p screens
[19:43:43 CET] <furq> so?
[19:43:44 CET] <DeathShot> I do
[19:43:53 CET] <thebombzen> so you can actually tell believe it or not
[19:43:57 CET] <DeathShot> Most of my music is flac
[19:43:58 CET] <furq> i do not
[19:44:07 CET] <thebombzen> well then you wouldn't :P
[19:44:16 CET] <thebombzen> although I have lossless on my phone because that's what I have
[19:44:20 CET] <thebombzen> and my phone has hard drive space
[19:44:21 CET] <thebombzen> I
[19:44:27 CET] <thebombzen> I'll down sample it as soon as I run out of space
[19:44:40 CET] <thebombzen> not downsample but
[19:44:45 CET] <furq> also qhd is 4x 720p, not 1080p
[19:44:48 CET] <thebombzen> downgrade to 160 kbps or something sufficiently high
[19:44:49 CET] <DeathShot> With my car stereo and good headphones you can tell. My phone can't do it justice, but you can still hear a difference usually over 320cbr.
[19:45:04 CET] <thebombzen> what encoder do you have?
[19:45:06 CET] <furq> what about with a good audio codec
[19:45:07 CET] <DeathShot> In the car depending where and how fast somewhat less so
[19:45:16 CET] <thebombzen> 320 kbps with a good encoder should be transparent
[19:45:20 CET] <DeathShot> Yeah 4x 720p
[19:45:35 CET] <DeathShot> Oh no i said 1080
[19:45:48 CET] <DeathShot> I've been awake for 30+ hours
[19:45:53 CET] <DeathShot> Cut me some slack
[19:45:57 CET] <furq> never
[19:46:17 CET] <thebombzen> but nowadays good encoders have transparency a lot lower than 320
[19:46:19 CET] <BtbN> 4 times 720p... so 1080p?
[19:46:27 CET] <thebombzen> 4x 720 isn't 1080
[19:46:28 CET] <furq> 1440p
[19:46:36 CET] <thebombzen> 2560x1440
[19:46:43 CET] <BtbN> 1080p contains exactly 4 720p images
[19:46:50 CET] <furq> what
[19:46:53 CET] <furq> no it doesn't
[19:46:55 CET] <furq> 1440p does
[19:46:55 CET] <thebombzen> uh
[19:47:01 CET] <thebombzen> take 1280:720
[19:47:02 CET] <thebombzen> and double
[19:47:06 CET] <thebombzen> 720 x 2 = 1440
[19:47:10 CET] <thebombzen> 1280 x 2 = 2560
[19:47:28 CET] <BtbN> hm, yeah. Then that odd resolution comes out.
[19:47:38 CET] <DeathShot> When you double the resolution you quad the pixels
[19:47:43 CET] <thebombzen> 1080 is 1.5x720, not 2x720
[19:47:49 CET] <furq> 2.25x
[19:47:57 CET] <thebombzen> yea
[19:48:02 CET] <furq> well yeah 1.5 in each dimension
[19:48:06 CET] <thebombzen> yea
[19:48:12 CET] <BtbN> But much more important, why do you need/want 1080p or even higher on your tiny ass phone
[19:48:16 CET] <DeathShot> So double the resolution
[19:48:16 CET] <furq> yeah
[19:48:24 CET] <thebombzen> cause the phone has a 1080p screen?
[19:48:32 CET] <BtbN> yeah, exactly
[19:48:33 CET] <BtbN> why?
[19:48:35 CET] <DeathShot> My phone has an qhd screen
[19:48:40 CET] <furq> if you can tell the difference between a good 720p and a good 1080p encode on a 5" display i'll be pretty shocked
[19:48:40 CET] <thebombzen> why do you have a phone with a hugeass screen?
[19:48:43 CET] <DeathShot> It looks nice
[19:48:53 CET] <DeathShot> It's a 5" phone
[19:48:58 CET] <furq> i'd be surprised if you could tell the difference on a 10" display
[19:49:01 CET] <thebombzen> so the silly answer is "because a hugeass screen is nice"
[19:49:01 CET] <DeathShot> 5.2" maybe?
[19:49:09 CET] <BtbN> 5", "hugeass screen"
[19:49:12 CET] <DeathShot> Sure you can
[19:49:14 CET] <thebombzen> for a phone yea
[19:49:18 CET] <thebombzen> it's a hugeass screen for a phone
[19:49:22 CET] <BtbN> So far I'm satisfied with 1080p on my 24" screen
[19:49:33 CET] <DeathShot> I have a 15" uhd screen on my laptop
[19:49:37 CET] <DeathShot> Night and fucking day
[19:49:46 CET] <DeathShot> I don't even touch 1080p anymore
[19:50:01 CET] <thebombzen> but the reason you'd have a phone scren that large is it's actually really useful for navigating with google maps for example
[19:50:06 CET] <DeathShot> I use 1080p as peripheral screens
[19:50:12 CET] <thebombzen> having the screen real estate makes the phone much easier to use
[19:50:13 CET] <furq> i hope you've got plenty of free disk bays in your nas then
[19:50:26 CET] <furq> isn't 5" pretty standard now
[19:50:32 CET] <thebombzen> yea and those screens are 1080p
[19:50:35 CET] <furq> granted 1440p
[19:50:37 CET] <furq> seems silly
[19:50:38 CET] <BtbN> 5" seems like normal phone size to me, for a non-mini model
[19:50:39 CET] <DeathShot> Most of my movies are 1080p
[19:50:51 CET] <furq> i can't say i've ever seen a 1440p phone though so maybe you really can tell the difference
[19:50:55 CET] <thebombzen> well the iphone screen is actually larger than 1080p
[19:50:55 CET] <BtbN> I have 720p on my 5" phone, and never seen a pixel so far.
[19:50:59 CET] <thebombzen> it's 1200 something
[19:51:10 CET] <thebombzen> the physical device is 1200 something
[19:51:21 CET] <thebombzen> but it's downscaled to 1920x1080 for whatever reason
[19:51:28 CET] <thebombzen> and it doesnt' reallly make any sense. hwscaled not swscaled
[19:51:41 CET] <thebombzen> I mean you can change that if you jailbreak but it doesn't really make any sense
[19:51:46 CET] <furq> i mean i can tell the difference between my 720p phone and an iphone screen in the ui and stuff
[19:51:50 CET] <furq> but not with video
[19:52:03 CET] <thebombzen> I can but only if the video is super crisp and it's like a screengrab
[19:52:07 CET] <thebombzen> if it's like a movie I can't tell
[19:52:08 CET] <furq> other than the colours
[19:52:23 CET] <furq> that's not a property of pixel density though
[19:52:53 CET] <furq> i hope it's not one of those things where once you've seen it you can never go back
[19:52:59 CET] <furq> i'm running out of disk space already
[19:53:21 CET] <thebombzen> oh if I run out I'll just change my lossless to 256k probably
[19:53:37 CET] <thebombzen> I would do 128k opus but apple refuses to support opus or vorbis
[19:53:40 CET] <thebombzen> for some shit reason
[19:53:51 CET] <furq> you must have a vast amount of music if it's taking up a significant amount of your disk space
[19:53:54 CET] <furq> or a tiny disk
[19:54:11 CET] <furq> or maybe you're one of those 24/192 people
[19:54:34 CET] <fritsch> :-)
[19:54:39 CET] <fritsch> you can skip the maybe
[19:55:42 CET] <DeathShot> 24/192 makes no sense in almost any situation
[19:55:56 CET] <DeathShot> But I've got close to a tb of music at this point
[19:56:06 CET] <DeathShot> Oh fuck
[19:56:12 CET] <furq> idk how people manage that
[19:56:14 CET] <DeathShot> I got on the wrong train
[19:56:17 CET] <furq> nice
[19:56:23 CET] <thebombzen> well for me it's not 24/192 or somethingsilly
[19:56:29 CET] <thebombzen> I just have my music as lossless
[19:56:34 CET] <thebombzen> cause that's what I already had it as
[19:56:40 CET] <DeathShot> 16/48
[19:56:47 CET] <furq> most of my music is lossless and i'm only at about 300GB
[19:56:51 CET] <furq> which is nothing really
[19:56:58 CET] <thebombzen> hard disk of my phone
[19:57:00 CET] <thebombzen> not my computer
[19:57:05 CET] <furq> oh right
[19:57:06 CET] <thebombzen> my phone is 64 GB
[19:57:10 CET] <furq> well yeah having flac on your phone is just silly
[19:57:11 CET] <thebombzen> total
[19:57:21 CET] <DeathShot> My phone is 64gb too on sdcars
[19:57:28 CET] <DeathShot> Card*
[19:57:30 CET] <thebombzen> well it's only silly if I'm running out of space
[19:57:34 CET] <thebombzen> given that my music was already lossless
[19:57:36 CET] <DeathShot> I swap all the music every few weeks
[19:57:44 CET] <furq> i just put all my music on google play music
[19:57:45 CET] <thebombzen> putting the lossless on there is less effort than converting it first
[19:57:55 CET] <thebombzen> for me cloud music is silly
[19:57:59 CET] <furq> and i try not to listen to it much if i'm not on wifi
[19:57:59 CET] <thebombzen> requires internet, uses bandwidth.
[19:58:11 CET] <thebombzen> I only listen to music on phone when going for a wlak
[19:58:15 CET] <DeathShot> I have unlimited 4g
[19:58:21 CET] <thebombzen> good for you
[19:58:24 CET] <furq> i hardly ever listen to music on my phone tbh
[19:58:39 CET] <thebombzen> I'm one of those people who wasn't grandfatered into unlimited lol
[19:58:39 CET] <DeathShot> I don't steam aside from my server because no one streams at high enough quality
[19:58:48 CET] <DeathShot> For my car spotify us decent
[19:59:00 CET] <thebombzen> eh I only ever listen to music on my phone when I'm going for a walk outside
[19:59:02 CET] <thebombzen> like between locations
[19:59:07 CET] <DeathShot> Tmobile and sprint both do unlimited
[19:59:08 CET] <thebombzen> otherwise I'll just use the computer near me
[19:59:16 CET] <thebombzen> >tmobile
[19:59:17 CET] <thebombzen> >sprint
[19:59:30 CET] <furq> i mean when i'm in a place where my phone is the only thing near me with music on it
[19:59:33 CET] <furq> i tend to just not bother
[19:59:37 CET] <DeathShot> You British or something?
[19:59:42 CET] <thebombzen> so the actual reason I use at&t is my mom gets at&t through her work
[19:59:59 CET] <furq> me?
[20:00:03 CET] <thebombzen> so my parents do the phone bill for both me and my two brothers at uni
[20:00:11 CET] <DeathShot> I would rather not have a phone than go back to att or God forbid ever get Verizon
[20:00:13 CET] <thebombzen> cause like I'm 21 I don't have the money for a phone bill lol
[20:00:19 CET] <thebombzen> what's better about verizon?
[20:00:33 CET] <DeathShot> Verizon is worse
[20:00:41 CET] <thebombzen> oh I misread you
[20:00:56 CET] <thebombzen> honestly all the companies are scumbags and there's no good carrier choice
[20:01:08 CET] <thebombzen> I just use at&t b/c of my mom's work
[20:01:09 CET] <DeathShot> If I was going to have att I may as well just get a prepaid flipphone
[20:01:13 CET] <thebombzen> it pays our bill cause I'm at uni
[20:01:23 CET] <thebombzen> why
[20:01:30 CET] <DeathShot> Because no data
[20:01:35 CET] <thebombzen> huh?
[20:01:40 CET] <furq> do apple have a service where you can upload unlimited music of dubious legality
[20:01:41 CET] <thebombzen> I'm not sure I understand?
[20:01:42 CET] <DeathShot> Shity speecs
[20:01:43 CET] <furq> i'm guessing they don't
[20:01:50 CET] <DeathShot> Speeds
[20:01:51 CET] <furq> (for free)
[20:01:55 CET] <DeathShot> And high prices
[20:01:59 CET] <thebombzen> why would I want to upload unlimited music of dubious legality
[20:02:15 CET] <thebombzen> shitty speeds? I mean idc that much about speed I don't stream videos over data
[20:02:17 CET] <furq> i was wondering if such an option was even available to you
[20:02:20 CET] <thebombzen> it's good enough
[20:02:33 CET] <thebombzen> furq what are you even referring to
[20:02:39 CET] <furq> google play music
[20:02:40 CET] <DeathShot> You mean for for me to listen to?
[20:02:45 CET] <DeathShot> I have my own server
[20:02:48 CET] <thebombzen> If you're talking about apple music
[20:02:50 CET] <thebombzen> yea I turned that off
[20:02:55 CET] <thebombzen> cause it's annoying
[20:03:00 CET] <furq> i'm asking if apple music lets you upload music
[20:03:07 CET] <thebombzen> form where?
[20:03:07 CET] <furq> or if you just have to buy it from them
[20:03:10 CET] <furq> from anywhere
[20:03:19 CET] <thebombzen> I mean it does have "cloud music storage"
[20:03:26 CET] <thebombzen> so you can sync your ituns library to the cloud
[20:03:31 CET] <thebombzen> and your phone with that as well
[20:03:43 CET] <thebombzen> and stream it from the cloud with the itunes library on your computer synced to it
[20:03:46 CET] <furq> does itunes let you have music you didn't buy off itunes in your library
[20:03:50 CET] <thebombzen> yes
[20:03:54 CET] <thebombzen> it has for years
[20:03:58 CET] <thebombzen> like since 2001
[20:04:00 CET] <furq> i guess if that's free then it's the same thing then
[20:04:04 CET] <thebombzen> it is
[20:04:09 CET] <thebombzen> but just years later
[20:04:23 CET] <thebombzen> it's totally a clone of what you just described
[20:04:31 CET] <thebombzen> I just hate cloud syncing like that so I disabled it
[20:04:42 CET] <furq> yeah there's no syncing here
[20:04:42 CET] <thebombzen> cause I don't want to stream music dependent on my internet connection
[20:04:48 CET] <thebombzen> well uploading
[20:04:52 CET] <thebombzen> it's either manual or automatic
[20:04:54 CET] <furq> there is that
[20:04:55 CET] <thebombzen> it's the same thing
[20:04:58 CET] <furq> i hate automatic syncing in general
[20:05:07 CET] <thebombzen> but it's not the automatic that I have an issue with
[20:05:10 CET] <furq> usually if i'm putting something on the cloud it's so i can delete it locally
[20:05:15 CET] <thebombzen> I just don't like having my media in the cloud
[20:05:23 CET] <thebombzen> I'd prefer to have it on the hard drive
[20:05:29 CET] <thebombzen> cause that makes it unrelated to my internet connection
[20:05:39 CET] <thebombzen> and doesn't use my finite data that I have to share with my family
[20:05:54 CET] <furq> shrug
[20:05:59 CET] <furq> i'm rarely away from wifi so it works for me
[20:11:40 CET] <DeathShot> I am back on my laptop
[20:11:44 CET] <DeathShot> let's see what the statuse of x is
[20:12:07 CET] <DeathShot> holy shit
[20:12:10 CET] <DeathShot> x is still building
[20:12:14 CET] <furq> why are you building it
[20:12:21 CET] <DeathShot> because I wanted hardware acceleration
[20:12:33 CET] <furq> so install the package
[20:12:36 CET] <DeathShot> I need it to isntall the nvidia drivers
[20:12:45 CET] <DeathShot> I want the most minimal x I can get
[20:12:50 CET] <thiagomaia> Hey, anyone has any idea about this problem I`m having? I`m losing it :P http://ffmpeg-users.933282.n4.nabble.com/DrawText-Not-Drawing-from-top-left-0-0-td4678874.html
[20:13:57 CET] <furq> what's wrong with xorg-minimal
[20:15:02 CET] <DeathShot> I didn't know it existed
[20:15:14 CET] <DeathShot> I litterally make x and deselected almost every option
[20:15:21 CET] <DeathShot> at this point should I stop or not
[20:15:27 CET] <furq> shrug
[20:15:28 CET] <DeathShot> its been running for like 2 hours I think?
[20:15:40 CET] <DeathShot> I'd have to clean up the mess it made probably
[20:15:42 CET] <furq> i've never compiled x because i assumed it would take a million years
[20:15:54 CET] <furq> if you did it from ports then make clean is all you need
[20:16:05 CET] <DeathShot> okay
[20:16:07 CET] <DeathShot> I'm killing x
[20:16:12 CET] <DeathShot> I wish they had a progress bar
[20:16:17 CET] <DeathShot> it's probably raping my pure nas
[20:16:19 CET] <DeathShot> poor*
[20:18:44 CET] <thebombzen> compiling x sounds like it would take forever yea
[20:18:52 CET] <thebombzen> the biggest thign I've ever built from scratch is gcc
[20:18:55 CET] <DeathShot> I gave up, getting xorg-minimal
[20:19:26 CET] <furq> i guess python is the biggest thing i've ever built from scratch
[20:22:15 CET] <bubonem> Hello
[20:23:12 CET] <DeathShot> for some reason when I'm trying to install nvidia drivers its telling me I'm missing linux support
[20:23:15 CET] <DeathShot> but its BSD
[20:23:17 CET] <DeathShot> what the heck?
[20:24:08 CET] <bubonem> Can I use ffmpeg for recording desktop with Wayland?
[20:24:27 CET] <thebombzen> DeathShot: don't think Nvidia has BSD Drivers
[20:24:31 CET] <furq> DeathShot: where are you getting the drivers
[20:24:32 CET] <DeathShot> they do
[20:24:36 CET] <DeathShot> pkg
[20:24:42 CET] <furq> pkg install nvidia-driver?
[20:24:43 CET] <DeathShot> also I can build them from nvidia
[20:24:45 CET] <DeathShot> or using portmaster
[20:24:47 CET] <DeathShot> yeah
[20:24:53 CET] <thebombzen> nvm it defintiely does
[20:24:54 CET] <arpu> hello what is the difference between h264_nvenc and nvenc_h264?
[20:25:02 CET] <furq> those are the linux drivers iirc
[20:25:07 CET] <thebombzen> they're the same but nvenc_h264 is deprecated
[20:25:10 CET] <thebombzen> and might be removed
[20:25:19 CET] <furq> you need the linux compatibility stuff enabled, but i figured pkg would install that
[20:25:22 CET] <arpu> thebombzen,  thx
[20:25:26 CET] <furq> maybe there's a kernel module or something you need to install
[20:25:32 CET] <DeathShot> I can't install kernel modules
[20:25:36 CET] <furq> that's generally a pretty dicey affair on freenas
[20:25:37 CET] <DeathShot> because its a freenas jail
[20:25:46 CET] <furq> you can but only if the host has that module
[20:25:53 CET] <DeathShot> yes but freenas doesn't
[20:25:59 CET] <furq> i think freenas does? i'm sure i've installed it in the past
[20:26:01 CET] <thebombzen> there's freebsd drivers on geforce.com if you want those
[20:26:04 CET] <DeathShot> and its really hard to isntall it
[20:26:05 CET] <thebombzen> but that might have the same issue
[20:26:06 CET] <furq> that was years ago though
[20:26:30 CET] <DeathShot> I'll try to build it
[20:28:00 CET] <DeathShot> you can disable it but you have to postmaster it
[20:28:52 CET] <furq> DeathShot: run `kldload linux` from a root shell on your host
[20:29:04 CET] <DeathShot> I juts installed them
[20:29:07 CET] <DeathShot> I will do that though
[20:29:12 CET] <furq> oh
[20:29:29 CET] <DeathShot> kldload linux returned nothing, so I guess it worked
[20:29:34 CET] <furq> yeah
[20:29:36 CET] <furq> kldstat | grep linux
[20:29:37 CET] <DeathShot> issue is
[20:30:13 CET] <bubonem> What I have to use instead of 'x11grab', if I use Wayland for screen recording on linux?
[20:30:47 CET] <DeathShot> I need ti enable nvidia in kernel
[20:31:04 CET] <DeathShot> and /that/ does not exist
[20:31:21 CET] <DeathShot> alirhgt need to get off my laptop
[20:31:26 CET] <DeathShot> we'll continue this later, thanks
[20:50:50 CET] <Nosomy> http://pastebin.com/0nT2jqQS nobody cares, right?
[20:54:14 CET] <ChocolateArmpits> Nosomy, you should try defining pixel_format as an input option
[20:54:39 CET] <ChocolateArmpits> it doesn't seem to be recognized
[20:54:46 CET] <Nosomy> i tried.
[20:54:53 CET] <Nosomy> no sucess.
[20:55:14 CET] <Nosomy> i thing is rgb8, by size of frame
[20:55:37 CET] <Nosomy> but is 1032 more bytes
[20:56:17 CET] <ChocolateArmpits> Nosomy, does it play in any player?
[20:57:05 CET] <Nosomy> only player thats use fraps vfw decodec
[20:57:33 CET] <Nosomy> to convert, i use avisource of avisynth
[20:57:47 CET] <Nosomy> but is need of avisythn installed
[20:59:00 CET] <furq> fraps is listed as a decodable codec, so it's probably worth reporting
[21:00:06 CET] <Nosomy> i can provide a sample
[21:00:31 CET] <Nosomy> is more compress sample on LZMA compression
[21:00:48 CET] <Nosomy> *is very compress
[21:39:57 CET] <Nosomy> furq
[21:40:14 CET] <Nosomy> need of sample?
[21:54:32 CET] <durandal_1707> Nosomy: yes
[21:55:01 CET] <Nosomy>  this a sample: https://drive.google.com/file/d/0B_vxqHXYayl9OEI5S3l2N0Z5WWM/view
[21:55:56 CET] <Nosomy> 1GiB on 7MiB, lzma miracles.
[22:01:09 CET] <Nosomy> one fun fact, none video lossless codec, compress this sample more  that 7zma, the last time i tested lossless video codecs
[22:01:22 CET] <Nosomy> *7z lzma
[22:02:20 CET] <Nosomy> video sample killer.
[22:06:52 CET] <atomnuker> Nosomy: clearly you haven't tried ffv1 at level 4 with the range coder
[22:07:26 CET] <Nosomy> ffv1?
[22:08:35 CET] <Nosomy> ffv1 support full range?
[22:08:53 CET] <atomnuker> yeah
[22:09:15 CET] <Nosomy> atomnuker
[22:09:27 CET] <Nosomy> make the test now for you
[22:11:19 CET] <Altabyte> Can someone tell me why ffmpeg downloads HLS streams (m3u8) very slowly compared to Streamlink
[22:13:24 CET] <Nosomy> but, notice the h264 and utvideo had the best results, although it did not compress as much as the lzma
[22:13:45 CET] <Nosomy> atomnuker cmdline suggetion?
[22:14:25 CET] <Nosomy> *suggestion
[22:15:43 CET] <atomnuker> -c:v ffv1 -level 4 -strict -2 -coder range_tab
[22:22:01 CET] <nadermx> Hey all, I'm having a problem when trying to make a gif with ffmpeg with text.
[22:22:21 CET] <nadermx> When I run the first pass to create the pallet it works fine, but when I run the second pass with filter_complex
[22:22:30 CET] <nadermx> it doesn't detect the font file, even though it detects it with the first pass
[22:24:47 CET] <nadermx> running these specific commands
[22:24:47 CET] <nadermx> http://superuser.com/a/1138740/535078
[22:24:48 CET] <Nosomy> atomnuker https://dpaste.de/2t1f
[22:35:49 CET] <cbsrobot> nadermx: what happens if you use -lavfi instead of -filter_complex ?
[22:38:41 CET] <nadermx> @cbsrobot still get these errors
[22:38:42 CET] <nadermx> [Parsed_drawtext_2 @ 0x39ac760] Either text, a valid file or a timecode must be provided
[22:38:42 CET] <nadermx> [AVFilterGraph @ 0x3966ce0] Error initializing filter 'drawtext' with args 'fontfile=font.ttf:'
[22:40:00 CET] <cbsrobot> nadermx: ah sure now I see it
[22:40:29 CET] <cbsrobot> ... drawtext="fontfile .... .... y=-1"[x];.....
[22:40:42 CET] <cbsrobot> ^get rid (or escape) the two "
[22:41:52 CET] <nadermx> ah sick! Awesome thank you
[22:43:08 CET] <Nosomy> atomnuker Any opinion?
[22:45:30 CET] <atomnuker> Nosomy: is it too larger?
[22:45:35 CET] <atomnuker> *large
[22:46:11 CET] <Nosomy> atomnuker
[22:46:18 CET] <Nosomy> mediainfo of source: http://pastebin.com/0nT2jqQS
[22:46:22 CET] <Nosomy> in this paste
[22:46:36 CET] <atomnuker> yeah, I saw it, what about it?
[22:46:43 CET] <atomnuker> it looks okay
[22:48:43 CET] <Nosomy> yet on h264 yuv420p crf 21 (lossy) is need 11Mbps, and is some things spins.
[22:49:38 CET] <atomnuker> yes, ffv1 is lossless, it's normal to be large
[22:49:56 CET] <Nosomy> but the source is to small
[22:50:52 CET] <Nosomy> others lossless videos codec no "win" of fraps lossless codec in the case
[22:54:48 CET] <durandal_1707> Nosomy: how decoded output should look like?
[22:55:08 CET] <furq> yeah that sample doesn't play here at all
[22:56:47 CET] <Nosomy> rgb0 or rgb24 for lossless.
[22:57:25 CET] <Nosomy> probably is rgb0 because is old game capture
[23:01:01 CET] <durandal_1707> Nosomy: nope its pal8
[23:01:18 CET] <Nosomy> pal8?
[23:01:18 CET] <durandal_1707> i got it decoded
[23:01:32 CET] <Nosomy> Hmmm
[23:01:59 CET] <durandal_1707> just need to figure out how is pal8 marked in bitstream
[23:03:21 CET] <Nosomy> how to you decoded?
[23:14:49 CET] <Nosomy> durandal_1707
[23:16:01 CET] <Nosomy> i think FPS1 is "dynamic", some cases is yuvj420p, some case is this.
[23:17:25 CET] <durandal_1707> Nosomy: i wrote patch its on ml
[23:18:45 CET] <Nosomy> ffmpeg with problem for decodec fraps samples, is old.
[23:21:51 CET] <durandal_1707> its just that specific format
[23:38:29 CET] <sopparus> when ffmpeg 3.3 gets out, will it first be cut from master at some point then polished a bit?
[23:39:43 CET] <sopparus> for example I have heard nothing of 3.3 so lets say it will be released in 3 months, atleast it will be cut from master as off today?
[23:39:49 CET] <sopparus> is that understandable?:)
[23:48:07 CET] <BtbN> release gets branched at some point, and is then maintained with bugfixes in that branch until nobody cares about it anymore.
[23:51:32 CET] <Nosomy> durandal_1707 i hope this problems no exists anymore, thanks for a help.
[23:53:22 CET] <sopparus> ok so I can assume that ffmpeg 3.3 will include everything thats in master as of today?
[23:59:21 CET] <__raven__> hi
[00:00:00 CET] --- Fri Jan 20 2017

More information about the Ffmpeg-devel-irc mailing list