[Ffmpeg-devel-irc] ffmpeg.log.20170120

burek burek021 at gmail.com
Sat Jan 21 03:05:01 EET 2017

[00:00:37 CET] <__raven__> i am recording live video with ffmpeg. (how) is possible to create a thumbnail every 10 seconds from what ffmpeg records live?
[00:08:12 CET] <Nosomy> __raven__ , yes, ffmepg support multiple outputs, example:  ffmpeg -i souce -c:v libx264 output1.mp4 -c:v mjpeg -r 0.1 output2.jpg
[00:08:51 CET] <Nosomy> For an idea.
[00:09:23 CET] <Nosomy> *output2%d.jpg
[00:13:51 CET] <__raven__> Nosomy: yeah thats the way
[00:14:35 CET] <__raven__> but it requires some kind of pattern. any pattern possible with only one updating output?
[00:14:45 CET] <__raven__> recent.jpg does not work
[00:15:19 CET] <Nosomy> "%d"
[00:15:51 CET] <Nosomy> __raven__ , yes, ffmepg support multiple outputs, example:  ffmpeg -i source.avi -c:v libx264 output1.mp4 -c:v mjpeg -r 0.1 output2-%d.jpg
[00:16:28 CET] <Nosomy> %01d -> tells use one lead zero.
[00:16:40 CET] <Nosomy> %02d -> tells use two lead zero.
[00:17:22 CET] <Nosomy> and so it goes
[00:17:37 CET] <__raven__> Nosomy: but %d gives me a numbered output?
[00:18:36 CET] <Nosomy> yes
[00:18:51 CET] <__raven__> no way to let it overwrite itself?
[00:19:03 CET] <__raven__> like a "webcam mode"?
[00:19:33 CET] <Nosomy> replace the pic each 10 seconds?
[00:19:39 CET] <__raven__> yes
[00:22:11 CET] <__raven__> how to?
[00:23:54 CET] <Nosomy> loop script to move pic to one pic.
[00:25:07 CET] <Nosomy> if exist output*.jpg then mv output*.jpg last_output.jpg
[00:25:26 CET] <__raven__> not sure how much overhead that will produce but ill test it tnx :)
[00:42:25 CET] <voip__> hi guys
[00:43:06 CET] <voip__> whats wrong with command: ffmpeg -i source c:v libx264 -maxrate 1800k -bufsize 3600k -g 2 -c:a copy -f flv output
[00:43:08 CET] <voip__> ?
[00:43:51 CET] <voip__> Unable to find a suitable output format for 'c:v'
[00:43:51 CET] <voip__> c:v: Invalid argument
[00:44:28 CET] <Nosomy> "-c:v" is correct
[00:44:35 CET] <Nosomy> "c:v" is incorrect
[00:45:18 CET] <Nosomy> just forget the "-"
[00:45:21 CET] <voip__> i see , but it was works on old bulds
[00:45:43 CET] <Nosomy> old build with parser bug then
[00:45:58 CET] <voip__> thank you !
[00:59:24 CET] <faLUCE> Hello. When I  do av_frame_alloc()  for a frame with AV_PIX_FMT_YUV420P I obtain the immediately the linesize[0, 1, 2]  (frame->linesize)  When the format is  AV_PIX_FMT_YUYV422 I have the linesize only when the frame is decoded. Why?
[01:00:40 CET] <faLUCE> I think this is a bug
[01:19:27 CET] <DHE> faLUCE: so immediately out of av_frame_alloc() you have linesize fields filled in?
[01:26:39 CET] <faLUCE> DHE: for YUV420P yes
[01:27:58 CET] <faLUCE> DHE: you can try yourself
[01:28:01 CET] <DHE> av_format_alloc() doesn't concern itself with the video format. the frame is format-less on creation.
[01:31:21 CET] <faLUCE> DHE: if you set fileds like width, height and fmt, for YUV420P, you have the linesize magically set
[01:32:02 CET] <faLUCE> or maybe this is a default, I dunno
[01:57:14 CET] <AnonBaiter> so
[01:57:31 CET] <AnonBaiter> which extension does ATRAC1 use?
[01:57:58 CET] <AnonBaiter> or an SDDS file?
[01:59:58 CET] <furq> probably .oma
[02:00:07 CET] <AnonBaiter> huh
[02:00:26 CET] <furq> http://vpaste.net/BXvAD
[02:00:33 CET] <AnonBaiter> does .oma use the ATRAC1 codec?
[02:00:37 CET] <furq> shrug
[02:00:44 CET] <AnonBaiter> ahh
[02:00:59 CET] <AnonBaiter> I heard SDDS used that codec
[02:01:32 CET] <furq> last time i saw the word "openmg" it was because i was putting a sonicstage cd in a microwave
[02:01:55 CET] <furq> it was very satisfying
[02:10:22 CET] <zhaojun> hi, I have a question. Does ffmpeg provide a way to use dma_fd? Since in arm architecture, memory copying costs expensive.
[02:54:43 CET] <xtina> hello! I have an ffmpeg command in a bash script to start at boot. if i run the cmd manually it succeeds. but if i run it in the bash script, it fails.
[02:54:50 CET] <xtina> the cmd is: sudo raspivid -o - -t 0 -vf -hf -fps 20 -b 6000000 | ffmpeg/./ffmpeg -f lavfi -re -i anullsrc -f h264 -thread_queue_size 512 -framerate 20  -probesize 100  -i - -vcodec copy -acodec aac -g 20  -f flv rtmp://
[02:55:06 CET] <xtina> here is the error if I execute it in the bash script:
[02:55:06 CET] <xtina> RTMP_ReadPacket, failed to read RTMP packet header rtmp:// Unknown error occurred
[02:56:23 CET] <xtina> if I just execute the cmd manually, it works perfectly
[02:56:25 CET] <xtina> what does that mean?
[02:57:34 CET] <xtina> whoops, realized i just need to put sudo in front of the ffmpeg cmd in the bash script...
[03:07:33 CET] <klaxa> sounds evil
[03:32:33 CET] <xtina> hey, wondering if anyone can help with my dilemma. i wrote a script to record video upon booting the Pi.
[03:32:39 CET] <xtina> the command for streaming works if I execute it manually
[03:32:55 CET] <xtina> but upon boot, I get the error     Stream #0:0: Audio: pcm_u8, 44100 Hz, stereo, u8, 705 kb/s mmal: mmal_vc_component_enable: failed to enable component: ENOSPC mmal: camera component couldn't be enabled mmal: main: Failed to create camera component mmal: Failed to run camera app. Please check for firmware updates
[03:33:09 CET] <xtina> it appears there are multiple raspivid processes getting started on boot, and maybe they are interfering
[03:33:17 CET] <xtina> $ ps aux | grep raspi root       156  0.1  2.9  91384 11092 ?        Ssl  02:28   0:00 /usr/bin/uv4l -k --sched-fifo --mem-lock --config-file=/etc/uv4l/uv4l-raspicam.conf --driver raspicam --driver-config-file=/etc/uv4l/uv4l-raspicam.conf --server-option=--server-config-file=/etc/uv4l/uv4l-server.conf root      1008  0.0  0.8   6768  3096 tty1     S+   02:29   0:00 sudo raspivid -o - -t 0 -vf -hf -fps 20 -b 6000000 root      1028  0.1
[03:33:28 CET] <xtina> to prevent this i added a lock to my script:
[03:33:40 CET] <xtina> sudo test -f /var/run/stream/script.sh.pid && exit 0 sudo echo $$ >/var/run/stream/script.sh.pid sudo raspivid -o - -t 0 -vf -hf -fps 20 -b 6000000 | sudo ffmpeg/./ffmpeg -f lavfi -re -i anullsrc -f h264 -thread_queue_size 512 -framerate 20  -probesize 100  -i - -vcodec copy -acodec aac -g 20  -f flv rtmp://$
[03:33:58 CET] <xtina> but no matter what, i still see multiple raspivid processes on boot, and the stream fails to start
[03:34:09 CET] <xtina> any suggestions?
[03:35:00 CET] <xtina> my script is getting called by ~/.bashrc, fyi
[03:56:50 CET] <BoomerBile> having problems with ffmpeg's -to option... it works for the first song, however when i go to do any other song in the first file, it's treating -to as a duration instead of a position using command ffmpeg -ss 5:37 -i The_Crimson_Armada-Guardians.flac -to 10:33 -vn The_Crimson_Armada-Guardians-Track-1.flac
[04:16:30 CET] <ffq> Hi - I'm running into an issue with av_frame_get_pkt_duration()
[04:16:51 CET] <ffq> specifically, I get an unreasonably large value only for the first frame, and then the ones that follow all appear to be correct
[04:17:15 CET] <ffq> anyone seen something like this? ffprobe -show_frames doesn't seem to suffer from the issue
[04:39:52 CET] <Hello71> BoomerBile: I thought it was supposed to be used as an input option now
[04:40:03 CET] <BoomerBile> i tried both
[04:40:25 CET] <Hello71> ffq: tried turning up log level?
[04:40:25 CET] <BoomerBile> it's ok, i wrote a python script to figure out the time differences and i'm feeding it that now
[04:41:01 CET] <thebombzen> "man ffmpeg" says it's an output option
[04:41:03 CET] <thebombzen> not an input option
[04:41:36 CET] <thebombzen> and BoomerBile as you have it before it works
[04:41:40 CET] <thebombzen> it should work at least
[04:41:42 CET] <thebombzen> sounds like a bug
[04:41:49 CET] <BoomerBile> yeah it's not working
[04:42:13 CET] <BoomerBile> i'm feeding it as an output option
[04:42:38 CET] <ffq> Hello71: is there logging to do with the API?
[04:43:52 CET] <Hello71> I mean the command line tool.
[04:44:04 CET] <thebombzen> BoomerBile: for the record, if you have a cue file, this has been done before
[04:44:20 CET] <BoomerBile> cue file?
[04:44:24 CET] <Hello71> they changed the behavior of seeking options in... somewhat recently
[04:44:51 CET] <BoomerBile> seems -to is now just a synonym for -t now only for output
[04:44:51 CET] <thebombzen> well usually when you rip a CD as one huge flac, the thing ripping it gives you a cuefile which has the .cue extension
[04:45:11 CET] <BoomerBile> so you can what feed the .cue file to ffmpeg and have it split?
[04:45:17 CET] <thebombzen> not to ffmpeg
[04:45:40 CET] <thebombzen> shnsplit can split up a flac based on a cuefile
[04:45:45 CET] <thebombzen> and then you can tag the flacs with cuetag.sh
[04:45:51 CET] <BoomerBile> ah
[04:46:52 CET] <BoomerBile> well i already got this script working for hours long <anytype> files, you have to manually feed the times you want to cut it at, it automatically figures out the durations, renames the files, and music brainz figures out what they are and tags and renames them
[04:47:48 CET] <BoomerBile> music brainz does one up on that and moves them to a directory based on the pattern you gave it
[04:48:00 CET] <BoomerBile> and downloads a cover
[04:48:49 CET] <thebombzen> ah
[04:48:55 CET] <thebombzen> well if you happen to have a cuefile
[04:48:58 CET] <thebombzen> you can always use: https://github.com/thebombzen/scripts/blob/master/src/cuesplit
[04:52:11 CET] <BoomerBile> nice
[04:55:20 CET] <BoomerBile> http://pastebin.com/53mT2SmR <-- if you don't have a .cue file and you sit in smplayer or some other player and watch for the starts of the new songs you can type the times in 00:00:00,00:00:00 format into this and it will figure it all out for you... took an hour or so to get working, no error checking or any fancy stuff
[04:55:47 CET] <BoomerBile> lol still has all the debug code in it
[05:31:51 CET] <Afdal> Can anyone tell me the -f flag for AVI real quick?
[05:32:17 CET] <Afdal> I can't seem to find it anywhere
[05:32:58 CET] <Afdal> I need to pipe AVI to another program and so can't specify the file extension
[05:35:54 CET] <Afdal> lol wait
[05:35:57 CET] <Afdal> it is -f avi isn't it
[05:36:13 CET] <Afdal> I was trying to pack an Opus stream in an AVI, nevermind :)
[05:48:41 CET] <thebombzen> xD
[06:42:23 CET] <DRK_lotus>  i was told there is some annoying person that comes here talking about vlc bug
[07:37:44 CET] <DeathShot> as it turns out, znc set to 15000 lines isn't a great idea?
[07:40:43 CET] <Threads> ask in #znc
[08:02:15 CET] <Diag> furq: you around
[09:25:07 CET] <kerio> ffmpeg can't decode a .SAM from curse of monkey island properly :(
[10:53:37 CET] <soulshock> when using "ffmpeg -i video.mov -i audio.wav -map 0:0 -map 1:0 -c copy muxedoutput.mov" and either audio is shorter or longer than video, what will ffmpeg do in each case? Will the audio track be filled with blanks to match video track or will the video track be shortened to match length of audio track?
[10:59:55 CET] <teratorn> soulshock: neither, I suspect. it will just copy all the packets
[11:00:32 CET] <soulshock> neither? so the audio track will end up being a shorter length than the video track?
[11:00:48 CET] <teratorn> well, test it
[11:01:17 CET] <teratorn> but I suspect it will just copy the video or audio streams... that is what copy does. if you need to trim it you'll need to use e.g. the `trim` filter
[11:01:27 CET] <teratorn> well that would be one way, anyway
[11:07:27 CET] <soulshock> ok thanks
[11:47:45 CET] <phil_> hi @all i have problem with ffmpeg on raspberry pi getting the following error: Dequeued v4l2 buffer contains corrupted data (691200 bytes). any ideas?
[12:31:55 CET] <cynn> hey all
[12:32:21 CET] <cynn> QQ if anyone is around
[12:32:38 CET] <cynn> When getting a live stream in C++ I keep getting "skipping 1 segments ahead, expired from playlists"
[12:32:56 CET] <cynn> The reason for this is I am doing some tasks on every frame that sometimes cause it to fall behind
[12:33:04 CET] <cynn> I dont really care about getting every frame
[12:33:18 CET] <cynn> Is there a way to just jump to the latest frame?
[12:34:01 CET] <kerio> are you referring to HLS segments
[12:34:07 CET] <cynn> yes
[12:34:31 CET] <kerio> well... jump to the last segment, jump to the last I-frame of the last segment
[12:34:45 CET] <kerio> then if it's really important, decode to the last actual frame
[12:35:01 CET] <cynn> Ok, how do I jump to the last segment?
[12:35:30 CET] <cynn> at the moment I am just calling "av_read_frame(pFormatCtx, &packet) >= 0" in a while
[13:31:32 CET] <cynn> When getting a live stream in C++ I keep getting "skipping 1 segments ahead, expired from playlists"
[13:31:42 CET] <cynn> The reason for this is I am doing some tasks on every frame that sometimes cause it to fall behind
[13:31:47 CET] <cynn> I dont really care about getting every frame
[13:31:53 CET] <cynn> Is there a way to just jump to the latest frame?
[15:19:42 CET] <DeathShot> so libass isn't found
[15:19:53 CET] <DeathShot> http://pastebin.com/pXVtHmys
[15:20:06 CET] <DeathShot> do I have to isntall it separately or should I file a bug?
[15:20:22 CET] <furq> the first one
[15:20:26 CET] <furq> as with all external libraries
[15:20:48 CET] <DeathShot> I thought it would be grabbed as a dependency
[15:20:53 CET] <DeathShot> why are there no guides for this :(
[15:20:57 CET] <furq> not by ffmpeg's build system
[15:21:14 CET] <furq> ports would do that, although you wouldn't want to do that because it'd build a ton of ports you could just grab from pkgng
[15:21:30 CET] <furq> i've still got no idea why you have 2.7 in ports
[15:21:35 CET] <DeathShot> so should I assume that even asked I install libass it would fail on something lame?
[15:22:05 CET] <DeathShot> I might have fixed that, possibly, but I still want to compile from source now :D
[15:22:09 CET] <furq> it'll fail on the next dependency you haven't installed
[15:22:46 CET] <furq> well if you do use ports
[15:22:47 CET] <DeathShot> should would pkg intall libass pkg install libx264 etc work?
[15:22:50 CET] <furq> after running make config
[15:23:01 CET] <furq> pkg install $(make build-depends-list | cut -d/ -f4,5)
[15:23:10 CET] <furq> i have no idea why there isn't a builtin way to do that, but that will save you a lot of time
[15:23:33 CET] <xzcvczx> ./configure seems to stall with the last lines being "mktemp -u XXXXXX \n RjvPoS"
[15:23:38 CET] <xzcvczx> anyone got any ideas why?
[15:23:54 CET] <xzcvczx> (last lines of config.log)
[15:23:57 CET] <furq> that's a new one
[15:24:05 CET] <furq> what os is that
[15:24:08 CET] <xzcvczx> osx
[15:24:14 CET] <DeathShot> well that's your problem
[15:24:16 CET] <xzcvczx> woops macOS :P
[15:24:16 CET] <DeathShot> jk
[15:24:27 CET] <DeathShot> should get a real OS anyways :P
[15:24:27 CET] <BtbN> it's normal for configure to think without any output
[15:24:39 CET] <xzcvczx> for minutes?
[15:24:42 CET] <furq> it shouldn't take a vast amount of time to run on osx
[15:25:11 CET] <furq> on cygwin or msys, sure, but osx has native fork(2)
[15:25:48 CET] <DeathShot> pkg install libfdk-aac
[15:25:49 CET] <DeathShot>  isn't working :(
[15:25:59 CET] <furq> it's fdk-aac
[15:26:04 CET] <furq> pkg search fdk
[15:26:38 CET] <DeathShot> compiling stuff on windows is so much eaiser
[15:26:46 CET] <xzcvczx> bahahahah
[15:26:49 CET] <BtbN> ohm, no, not at all
[15:26:53 CET] <BtbN> *uhm
[15:27:05 CET] <BtbN> Windows is a horrible mess when it comes to software development
[15:27:11 CET] <xzcvczx> ohm is just as valid...... representing resistance :P
[15:27:44 CET] <DeathShot> BtbN, not my experience with Visual Studio
[15:28:06 CET] <BtbN> Building a "hello world" sure works fine.
[15:28:19 CET] <BtbN> But building stuff with dependencies is hell
[15:28:38 CET] <BtbN> Primarily due to there being no standard paths and no package manager.
[15:29:07 CET] <DeathShot> tbf I never actually built anything non python on Windows that wasn't my own software
[15:29:25 CET] <DeathShot> and as complex as some of my software may be, that's easier than a random big application with no docs
[15:29:38 CET] <DeathShot> like FFmpeg
[15:29:42 CET] <DeathShot> ;)
[15:29:55 CET] <BtbN> just because you didn't read the docs doesn't mean they don't exist.
[15:30:02 CET] <DeathShot> they don't for FreeBSD
[15:30:06 CET] <DeathShot> they do for everything else
[15:30:09 CET] <DeathShot> and I've read them
[15:30:19 CET] <BtbN> FreeBSD is basically identical to Linux
[15:30:28 CET] <DeathShot> it's not though
[15:30:30 CET] <furq> it's close enough as far as this goes
[15:31:11 CET] <furq> also there's probably an assumption that you're building from ports, because why wouldn't you
[15:31:20 CET] <furq> it's way easier
[15:31:48 CET] <furq> ports are one of the few good reasons to use freebsd
[15:32:16 CET] <DeathShot> I honestly onlt gotinto freebsd because of freenas
[15:32:22 CET] <furq> same
[15:32:36 CET] <furq> i'm a big fan of the ports and pkgng integration though
[15:32:53 CET] <BtbN> I don't see any reason to ever use a BSD. It has no real-world advantage over Linux, but a bunch of additional complications along the way.
[15:33:07 CET] <furq> it doesn't use systemd
[15:33:12 CET] <furq> a lot of people would consider that an advantage
[15:33:19 CET] <BtbN> Yes, because you can't use Linux without systemd anymore.
[15:33:23 CET] <DeathShot> which is the perfered lame package?
[15:33:49 CET] <furq> lame isn't in pkgng for some reason, you have to build it from ports iirc
[15:33:53 CET] <DeathShot> BtbN, because it doesn't run on a shit license controlled by a bunch of evil clone minded software bigots
[15:34:19 CET] <BtbN> And that's how you get on my ignore list, congrats.
[15:34:31 CET] <furq> base system built by clang, kqueue, jails, native zfs
[15:34:50 CET] <furq> assuming the rest of linux continues to disapprove of what ubuntu is doing with zfs
[15:35:01 CET] <BtbN> Yeah, ZFS is nice. But zfs-on-linux works reasonably well for me so far.
[15:35:24 CET] <furq> kqueue is better than the linux equivalents, but most people just use abstractions over them anyway
[15:35:47 CET] <furq> which is good. if you use epoll directly then you suck
[15:35:58 CET] <BtbN> Sure, there are some theoretically quite nice features, but for real world usage they don't really matter
[15:36:23 CET] <xzcvczx> hmmm it does seem to always have a different value this time its mktemp -u XXXXXX \n mLq4ax
[15:36:28 CET] <furq> they're more historical advantages than current ones
[15:36:52 CET] <furq> aside from the no gpl (or less gpl) thing, which is important to some people i guess
[15:36:53 CET] <BtbN> Yeah, if there's a nice feature that's missing from Linux but exists somewhere else, chances are someone will just add it.
[15:37:18 CET] <furq> i'm not aware of any linux distro without systemd that i'd pick over freebsd
[15:37:32 CET] <BtbN> Gentoo
[15:37:37 CET] <furq> yeah that's definitely not on the list
[15:37:39 CET] <BtbN> They have systemd, but you can use whatever
[15:38:05 CET] <furq> systemd is here to stay though so there's not much point crusading against it
[15:38:37 CET] <furq> and it's fine when it isn't invading non-init-related things that you used to know how to use and now don't and the answer is buried somewhere in a mailing list post
[15:38:51 CET] <BtbN> With all the weird shit and breaking changes they pull off without prior notice, staying away from it for a couple more years seems a reasonable choice.
[15:39:04 CET] <furq> and when you ask about it someone will smugly tell you that it's on the mailing list, as if you're expected to read the systemd mailing list to be able to administer a linux system
[15:40:20 CET] <furq> but at this point the wise solution is to just learn how to use the damn thing
[15:40:44 CET] <xzcvczx> wooo down to a page of .configure the problem could exist in
[15:40:44 CET] <DeathShot> Sprint used to have full coverage of this station. Tmobile just drops.
[15:42:23 CET] <xzcvczx> meh that binary log crap that systemd thinks is a good idea is just insane
[15:42:42 CET] <furq> there are advantages and disadvantages
[15:42:49 CET] <furq> the user interface for systemd in general is terrible though
[15:43:40 CET] <DeathShot> I don't actuality hate gpl, I just think that the fsf is run like a closed dictatorship by a bunch of people who refuse to believe that there could possibly even exist such a possibility as them being wrong on a mater.
[15:43:41 CET] <furq> as usual with systemd it makes complicated stuff trivial and trivial stuff break
[15:43:43 CET] <xzcvczx> hmmmm ok..... something in "probe_cc as "$as" \n asflags_filter=$_flags_filter \n add_asflags $_flags $_cflags \n set_ccvars AS" its breaking
[15:44:38 CET] <DeathShot> So I've become a free bsd convert now that I've been introduced to it
[15:44:57 CET] <furq> i look forward to you finding out about /usr/local
[15:45:03 CET] <DeathShot> I'm only making life so hard for me because I hate myself and want to learn
[15:45:07 CET] <furq> that is easily the stupidest thing about freebsd
[15:45:07 CET] <xzcvczx> ok the line of fault is probe_cc as "$as"
[15:46:09 CET] <DeathShot> So far use/local/etc has served more or less like /etc/ in Linux
[15:46:17 CET] <furq> yeah it's dumb and i don't like it
[15:46:31 CET] <furq> it makes life harder and i don't see how it serves any useful purpose
[15:46:39 CET] <DeathShot> Couldn't you just make a link to it?
[15:46:53 CET] <furq> how would that work
[15:47:52 CET] <DeathShot> Make /etc/config or something symbolically link to /usr/local/etc saving you from having to type an extra /
[15:48:13 CET] <furq> that's really ugly and it also only solves /usr/local/etc
[15:48:18 CET] <furq> i have other issues with ports going in /usr/local
[15:48:40 CET] <DeathShot> Where should they go?
[15:48:45 CET] <DeathShot> Etc/ports?
[15:48:45 CET] <furq>  /
[15:48:59 CET] <DeathShot> That seems dirty to me too
[15:49:00 CET] <furq> it works fine for debian
[15:49:33 CET] <furq>  /usr/local should be for stuff i've installed manually
[15:49:34 CET] <DeathShot> ./ports seems wrong for some reason
[15:50:26 CET] <DeathShot> I mean its that + a library of what you can
[15:51:09 CET] Action: xzcvczx wonders if the test just doesn't like the osx as
[15:51:13 CET] <DeathShot> and the configs of those things
[15:51:54 CET] <DeathShot> It probably wouldn't seem weird to you if you didn't come from Linux
[15:51:56 CET] <furq> i don't mean /usr/ports
[15:52:01 CET] <furq> i mean installed ports
[15:52:09 CET] <furq> and packages
[15:52:15 CET] <furq> they can't touch anything outside /usr/local
[15:53:14 CET] <DeathShot> There are a bunch of things i find Linux does weird that windows does way better interface and structure wise. But they are different so I dont hold it against it.
[15:53:34 CET] <DeathShot> I'll admit that I'm not a unix master
[15:54:55 CET] <DeathShot> I know Linux way better than your average person, bsd too at this point. Osx as well. But mostly because I can Google. Windows is my primary os both for personal and professional use and the one I have developed on and for and hack the most.
[15:55:21 CET] <furq> well your average person thinks linux is a brand of detergent
[15:55:40 CET] <DeathShot> I don't think so
[15:55:58 CET] <DeathShot> They think it's a hacking geek platform
[15:56:08 CET] <DeathShot> It's common enough these days
[15:56:16 CET] <furq> i doubt your average person even understands what an operating system is
[15:56:24 CET] <furq> let alone that there are ones other than the one on their laptop
[15:56:49 CET] <DeathShot> They know mac and pc
[15:57:01 CET] <DeathShot> It's not a stretch to linux
[15:58:52 CET] <DeathShot> Most people know they have windows, even if they don't know the version
[16:18:19 CET] <thebombzen> I'm at uni at you meet a lot of people with silvery overpriced worthless macs who 1. have never heard of linux 2. say stuff like "macs are better for media" or something silly or 3. macs don't get viruses or something equally false nowadays
[16:19:34 CET] <thebombzen> and I open my laptop which has a Linux DE (I use MATE) and to them, they're looking at something that isn't MSW or OSX's UI and they have a does-not-compute moment
[16:22:26 CET] <furq> i use i3 on my laptop
[16:22:37 CET] <furq> i have genuinely had someone look at me and completely unironically say ARE YOU A HACKER
[16:23:38 CET] <furq> i've heard stories about people using tiling wms and bitmap fonts getting kicked out of starbucks because people thought they must obviously be hacking people's bank details
[16:24:12 CET] <furq> it is after all impossible to do that with wireshark on windows
[16:28:05 CET] <thebombzen> lol I don't even know what wireshark is
[16:28:15 CET] <thebombzen> but I can guess it's a thing designed for stealing money
[16:28:30 CET] <furq> it's just a packet sniffer
[16:28:37 CET] <thebombzen> oh okay
[16:28:49 CET] <thebombzen> I tried i3 - didn't like it as much as Marco (the default MATE window manager) but whatever
[16:29:01 CET] <furq> the trackpad on my laptop is garbage so i wanted something entirely keyboard-driven
[16:29:16 CET] <furq> i'm not completely sold on i3 but it does the job
[16:29:22 CET] <thebombzen> ah. I essentially work with all windows in fullscreen
[16:29:28 CET] <thebombzen> or rather maximized mode
[16:29:35 CET] <furq> yeah i never do that
[16:29:51 CET] <furq> that's what separate workspaces are for anyway
[16:29:58 CET] <thebombzen> I like fullsize windows and switching with alt-tab but I'm in the minority
[16:30:07 CET] <thebombzen> but those stories you mention have happened to me
[16:30:20 CET] <thebombzen> during a free period in high school I went to the library
[16:30:30 CET] <furq> well the idea is to also only use apps which are completely keyboard-driven, and those are often console apps
[16:30:38 CET] <furq> so a tiling wm works great for that
[16:30:52 CET] <thebombzen> I always try to do that, but sometimes you can't
[16:30:55 CET] <furq> yeah
[16:30:59 CET] <furq> that's where it starts to break down
[16:31:14 CET] <thebombzen> my trackpad works but I hate using it, so for me I just try to minimize the need for it
[16:31:31 CET] <thebombzen> but if you're looking about stories, I wanted to get some programming done on a project I was working on, but the source was sitting at home
[16:31:42 CET] <thebombzen> and I was in my high school library
[16:31:46 CET] <thebombzen> (this was a few years ago)
[16:32:09 CET] <thebombzen> so I just downloaded PuTTY, ssh-ed in and jsut started doing the work in the CLI
[16:32:29 CET] <thebombzen> about once every ten minute someone would say
[16:32:39 CET] <thebombzen> "Are you hacking?"
[16:33:04 CET] <thebombzen> and every time I would say, "no, if I was actually hacking I wouldnt' do it right here where everyone could see ._."
[16:47:25 CET] <furq> the #4 match on google images for "hacking" appears to be cmd.exe printing out digits of pi
[16:48:15 CET] <furq> http://www.coastdigital.co.uk/wp-content/uploads/2015/04/hacking-1024x682.jpg
[16:48:18 CET] <furq> along with this
[17:42:56 CET] <DeathShot> why you hate mate?
[17:43:05 CET] <DeathShot> wireshark is a packet sniffer, and its cross platform.
[17:43:45 CET] <furq> didn't i already say that
[17:44:33 CET] <DeathShot> I didn't see it
[17:44:38 CET] <DeathShot> oh yes you did
[17:44:58 CET] <DeathShot> I wish they just removed "Speration of church and state" from the law book
[17:45:01 CET] <DeathShot> since it obviously don't exist
[17:45:27 CET] <DeathShot> I am a big fan of transperacy, it gives me a little comfort when I cannot fix a broken system, that at least it's not trying to hide its corruption.
[17:45:56 CET] <DeathShot> They just spent 10 minutes praying during the innoguration, and now they are singing himes
[17:46:49 CET] <DeathShot> this is clearly a Christian government, always has been, but they keep saying it's not.
[17:47:45 CET] <thebombzen> DeathShot: well the lawbooks are prescriptive not descriptive
[17:48:13 CET] <thebombzen> if we have an establishment clause, and we have crap like "christmas is a national holiday"
[17:48:20 CET] <thebombzen> then it doesn't mean that the first amendment is wrong
[17:48:25 CET] <thebombzen> it means that the actions in violation of it are wrong
[17:48:41 CET] <thebombzen> the whole point of laws is that they're supposed to dictate, not document. they're prescriptive, not descriptive.
[17:48:52 CET] <thebombzen> but yea the Inaguration is pissing me off too
[17:48:56 CET] <thebombzen> but anyway -
[17:49:30 CET] <thebombzen> it appears the mpeg4 decoder is "Discarding excessive bitstream in packed xvid"
[17:50:14 CET] <thebombzen> and when I try to display the xvid-encoded file it's got lots of blocking errors
[17:51:20 CET] <thebombzen> see: https://imgur.com/a/QkY9X
[17:51:38 CET] <DeathShot> wow
[17:51:55 CET] <DeathShot> what is "Excessive bitstream"
[17:51:59 CET] <DeathShot> why is that a thing?
[17:52:02 CET] <thebombzen> another example
[17:52:03 CET] <thebombzen> https://i.imgur.com/9RDBi5l.png
[17:52:12 CET] <DeathShot> I can see it
[17:52:14 CET] <DeathShot> I wonder what its a thing
[17:52:15 CET] <thebombzen> these are the sort of blocking errors
[17:52:24 CET] <DeathShot> yeah I know what they are
[17:52:29 CET] <DeathShot> I'm asking why it would purposefully do it
[17:52:35 CET] <thebombzen> the sort of blocking errors  I'm talking about*
[17:52:43 CET] <thebombzen> I checked the CRC32 of the file and it agrees with the crc on the server I obtained it from
[17:52:58 CET] <DeathShot> i'm saying there is a difference between dropping packets and this happening and your decoder fucking it up on purpose
[17:53:16 CET] <thebombzen> it looks like it
[17:53:34 CET] <DeathShot> and the questino is why is your decoder fucking it up on purpose
[17:53:39 CET] <DeathShot> like why did they even implement this?
[17:53:42 CET] <thebombzen> it's also possible that the "excessive bitstream" is corrupt
[17:53:46 CET] <thebombzen> and provides no information
[17:53:50 CET] <DeathShot> its like adding a button to kill the breaks on your car
[17:54:49 CET] <DeathShot> "the greatest country on earth"
[17:54:59 CET] <DeathShot> that's what they say in China, and Iran, and North Korea
[17:55:08 CET] <DeathShot> every time they remind the population on who the people in power are
[17:56:09 CET] <thebombzen> oh it's a regression
[17:56:10 CET] <thebombzen> https://trac.ffmpeg.org/ticket/427
[17:56:13 CET] <thebombzen> from five years ago
[17:57:47 CET] <thebombzen> lol
[17:58:33 CET] <DeathShot> if I had a time machine, I would go back to expose the DNC earlier to make sure Berney got nominated
[17:58:46 CET] <DeathShot> also that says they fixed the problem
[17:59:11 CET] <DeathShot> so either you are using a version older than 5 years, or someone is a liar!
[17:59:26 CET] <c_14> or the problem got unfixed
[17:59:33 CET] <c_14> time to bisect
[17:59:48 CET] <DeathShot> c_14 shhhh!
[18:00:00 CET] <DeathShot> Donald Trump is about to be president, all logic is going out the door.
[18:00:09 CET] <DeathShot> Science and facts are going to become taboo
[18:00:11 CET] <c_14> Though I might go for a weighted bisect
[18:00:12 CET] <DeathShot> I'm trying to practice
[18:00:43 CET] <c_14> Not that it matters
[18:02:48 CET] <thebombzen> yea it's a regression in the sense that
[18:02:56 CET] <thebombzen> the sample that cehoyos provided still has artifacts
[18:03:07 CET] <thebombzen> which it shouldn't because they fixed that decoder error
[18:03:21 CET] <c_14> I couldn't get that file to decode...
[18:03:41 CET] <thebombzen> I just executed the command that cehoyos listed in bug report
[18:03:46 CET] <c_14> oh, wait
[18:03:50 CET] <c_14> It downloaded html...
[18:04:14 CET] <thebombzen> haha
[18:04:45 CET] <c_14> looks fine here?
[18:05:30 CET] <thebombzen> really? I just built ffmpeg 5 minutes ago and... lemme send you an ffplay screenshot
[18:05:41 CET] <c_14> Well, mine's 2 weeks old
[18:06:13 CET] <thebombzen> https://i.imgur.com/EE8o9LC.png
[18:06:31 CET] <c_14> oh my
[18:06:46 CET] <thebombzen> http://sprunge.us/FdIC
[18:07:02 CET] <thebombzen> well if yours is 2 weeks old and works
[18:07:11 CET] <thebombzen> sounds like your bisecting is a lot easier
[18:14:20 CET] <c_14> I just built from HEAD and it still works just fine
[18:14:28 CET] <thebombzen> really?
[18:14:29 CET] <thebombzen> then
[18:14:42 CET] <thebombzen> you can't get ffplay to show those artifacts?
[18:15:08 CET] <c_14> nope
[18:15:28 CET] <thebombzen> interesing...
[18:16:19 CET] <thebombzen> for you, is HEAD cf3affabb449671ce16cee61d98393c43ff171f4
[18:16:26 CET] <thebombzen> that's what I had after git pull
[18:16:31 CET] <c_14> cf3affabb4 yep
[18:16:52 CET] <thebombzen> well I'm rebuilding to see what happens
[18:18:31 CET] <thebombzen> nope, still visible artifacts. weird.
[18:20:21 CET] <thebombzen> https://i.imgur.com/AsIro3I.png
[18:20:26 CET] <thebombzen> ^ why would the above be happening?
[18:21:06 CET] <c_14> Your computer is haunted
[18:21:12 CET] <thebombzen> what compiler are you using?
[18:21:44 CET] <thebombzen> I'm using a very recent gcc. possible compiler bug
[18:21:45 CET] <c_14> gcc 5.4.0-r2
[18:21:55 CET] <thebombzen> I'll try with gcc5 instead of 6 and come back
[18:22:13 CET] <c_14> gcc updates do tend to break ffmpeg
[18:26:39 CET] <thebombzen> gcc updates tend to get progressively less forgiving to anything that isn't "perfect code"
[18:26:49 CET] <thebombzen> so while something might work fine in gcc5 it can break in gcc6
[18:27:01 CET] <thebombzen> let's hope that this is actually the case and that my computer isn't just haunted
[18:27:44 CET] <thebombzen> nope, same error with 5.4.0
[18:27:46 CET] <thebombzen> :(
[18:29:32 CET] <thebombzen> https://i.imgur.com/FxgS1Oj.png
[18:30:34 CET] <thebombzen> this is very strange
[18:30:38 CET] <c_14> If you reencode the video to h.264 and watch that do you get the artifacts?
[18:31:19 CET] <thebombzen> yea
[18:31:36 CET] <thebombzen> I tried that, and I tried not using SDL (mpv --vo=opengl)
[18:31:52 CET] <thebombzen> so I don't think it's ffplay, I don't think it's video out
[18:32:15 CET] <thebombzen> I think it's the avcodec mpeg4 decoder
[18:32:28 CET] <c_14> https://dl.c-14.de/t/out.mkv <- does that have artifacts for you?
[18:32:40 CET] <thebombzen> 404 so idk
[18:32:54 CET] <c_14> why is it 404ing ;_;
[18:35:46 CET] <c_14> It shouldn't 404 anymore
[18:37:11 CET] <c_14> (as in I fixed it, try again)
[18:57:47 CET] <thebombzen> c_14: no issue
[18:57:50 CET] <thebombzen> plays fine
[18:59:32 CET] <thebombzen> c_14: this si what I see: https://www.dropbox.com/s/j8t370k53uwjnz2/out2.mkv?dl=0
[19:00:28 CET] <thebombzen> and here's the conversion log: http://sprunge.us/hfTH
[19:00:53 CET] <Zypho> Quick question before I dive into this more, I am encoding various input formats mainly to HLS but some MP4. I have no idea how this would work but is there a percentage progress indicater already built into ffmpeg for me?
[19:01:11 CET] <Zypho> I quickly looked at the -progress flag but it seems to just spit out the current frame etc.
[19:01:28 CET] <asdas> Hello
[19:01:29 CET] <thebombzen> Zypho: afaik you need to know the duration
[19:01:49 CET] <thebombzen> and then you can divide the time by the duration
[19:02:11 CET] <Zypho> How would that work with multiple output streams ?
[19:02:30 CET] <thebombzen> now you see the issue with percent done ;-)
[19:02:30 CET] <Zypho> ie encoding multiple bitrates at once?
[19:03:15 CET] <thebombzen> do you see the issue with % done now? multiple outputs don't necessarily have the same duration
[19:03:23 CET] <asdas> i could need help because i could not find an tutorial for my usecase. I record a video with 4 different sound streams/sources in an mp4. With vlc i can select them all seperate but if i want to edit in blende i have to seperate them from the video because blender just uses the first one.
[19:04:02 CET] <asdas> it came to me that i could achieve something like that with ffmpeg but i could not find something. May someone help or point me in the right direction?
[19:04:10 CET] <Zypho> in my specific case they would all have the same duration, it's single input => multiple bitrates
[19:04:10 CET] <thebombzen> asdas: you can select streams with -map. so ffmpeg -i input -map v:0 -map a:0 will select the "0th" video and "0th" audio
[19:04:41 CET] <thebombzen> make sure you use -c copy so you don't reencode them, that's a waste of time and quality
[19:05:06 CET] <thebombzen> so if you have 4 different audio streams, you could use
[19:05:32 CET] <thebombzen> ffmpeg -i input.mp4 -map a:0 -c copy first_output -map a:0 -c copy second_output ...etc.
[19:05:44 CET] <thebombzen> sorry I mean
[19:05:48 CET] <thebombzen> ffmpeg -i input.mp4 -map a:0 -c copy first_output -map a:1 -c copy second_output ...etc.
[19:06:10 CET] <beastwick> Hi, I don't know what I am doing wrong. I want to use ffmpeg libav libraries straight from git so I cloned the repo and created a c source file to test a basic project. I keep getting errors that gcc cannot find the headers I specify, even after including them with -L and -I options.
[19:07:23 CET] <Zypho> thebombzen: I wonder if it's better to show progress of frames encoded
[19:07:41 CET] <Zypho> that way I can just to (frames * # of outputs)
[19:07:44 CET] <thebombzen> the advantage of using "time" rather than "frames" is it's more resilient to changing framerate or whatever
[19:07:58 CET] <asdas> thebombzen thanks. still not getting around how to use it properly. should i copy the mp4 container into the ffmpeg folder and then use the comand you told me via ff prompt?
[19:08:01 CET] <thebombzen> but it's honestly not that big of a difference
[19:08:06 CET] <c_14> Zypho: ffmpeg shows both by default
[19:08:37 CET] <thebombzen> c_14: were you able to read out2.mkv?
[19:08:47 CET] <c_14> yes, looks fine here
[19:08:56 CET] <thebombzen> it... looks fine?
[19:09:46 CET] <asdas> @thebombzen Thanks. So, drop vid into the ffmpeg folder and use command cia ff-prompt.bat ?
[19:09:59 CET] <c_14> thebombzen: are you referring to >(The initial artefacts are unrelated.)
[19:10:14 CET] <thebombzen> I mean the video out2.mkv I sent on my dropbox
[19:10:17 CET] <thebombzen> do you see artifacts on it
[19:10:27 CET] <c_14> The first second, yes. After that no.
[19:10:37 CET] <c_14> But the artifacts in the first second are part of the video stream
[19:10:39 CET] <thebombzen> yea that's where the corruption is
[19:10:43 CET] <c_14> It says so in the ticket
[19:11:35 CET] <thebombzen> then why were there no artifacts in out.mkv you sent me from c-14.de?
[19:11:42 CET] <c_14> I cut the first second
[19:11:46 CET] <thebombzen> ...
[19:12:14 CET] <c_14> Might have been misleading, but I was hoping to figure out if you had any artifacts later on in the video.
[19:12:57 CET] <thebombzen> wait
[19:12:58 CET] Last message repeated 1 time(s).
[19:12:58 CET] <thebombzen> hmmm
[19:13:08 CET] <thebombzen> so it appears the decoder error I had
[19:13:23 CET] <thebombzen> isn't a decoder error - the blocking artifacts are produced at the same time avcodec spits a warning
[19:13:41 CET] <thebombzen> because I think that the artifacts were encoded into the video when it was created
[19:15:11 CET] <thebombzen> cause the video was encoded probably 13 years ago
[19:16:36 CET] <asdas> OKay, figured out, i should put it into "bin"
[19:25:54 CET] <asdas> hm
[19:26:07 CET] <asdas> what do i put into first_output ?
[19:26:48 CET] <asdas> i tried now combined.mp3 (and 3 others ofc) but i got "could not write header for outpu file #0 <incorrect codec parameters ?>: Invalid argument
[19:27:28 CET] <Zypho> When I look at the progress out_time value, is that accounting for each of my outputs together?
[19:28:16 CET] <Zypho> I have two outputs
[19:28:29 CET] <Zypho> but I don't see two different out_time values in my progress log?
[19:29:39 CET] <c_14> asdas: file name
[19:32:12 CET] <asdas> yeah, i tried c_14 i put there combined.mp3
[19:32:48 CET] <beastwick> nevermind, ignore my question
[19:32:55 CET] <beastwick> (not being sarcastic, figured it out)
[19:36:15 CET] <Zypho> Ah I get it now, since I am doing multi rendition encodes. The out_time reported in progress events is overall. So I just need to pass a pipe reader for that -progress flag and parse the out_time against the duration of the video.
[19:36:18 CET] <Zypho> Nice!
[20:06:07 CET] <asdas> pastebin
[20:06:14 CET] <asdas> http://pastebin.com/5p8tY05T
[20:06:23 CET] <asdas> sry, haven't seen it
[20:07:21 CET] <c_14> try 0:a:0 instead of a:0 etc
[20:21:15 CET] <asdas> .
[20:35:09 CET] <thebombzen> asdas: that's because the input files are AAC audio
[20:35:13 CET] <thebombzen> and you're trying to write them to mp3s
[20:35:30 CET] <thebombzen> instead change the file extension on the output files to .m4a or something
[20:35:41 CET] <asdas> kk
[20:35:48 CET] <asdas> ah, okay, i will
[20:35:58 CET] <thebombzen> the input audio isn't mp3 audio so you can't put it inside an mp3 fiel
[20:36:35 CET] <asdas> sounds logical now.
[20:36:47 CET] <asdas> sems like its prozessing
[20:36:58 CET] <asdas> *writing it down* thanks guys
[21:41:28 CET] <faLUCE> hello. When I h264-encode frames, and stream them, I set packets' pts with gettimeofday() and dts = pts. Mplayer decodes correctly the stream, while VLC doesn't like dts = pts and skips some frames. How should I set dts for the encoded frames?
[21:42:59 CET] <Nosomy> VLC fail in most cases, don't horry, probably is vlc bug.
[21:43:49 CET] <Nosomy> VLC still have problems with blocks after seek.
[21:45:22 CET] <faLUCE> Nosomy: this problem happens when I make the stream with a C code. If I do the stream with ffmpeg command line, vlc correctly decodes frames, and ffmpeg sets dts != pts
[21:47:30 CET] <faLUCE> Nosomy: I really don't understand what I have to set in the stream. If pts or dts
[21:50:47 CET] <Maxz> is anyone using decklink devices with ffmpeg?
[21:52:16 CET] <Maxz> since I updated ffmpeg to the latest version, decklink started to fail
[21:52:17 CET] <Maxz> :/
[21:53:32 CET] <Nosomy> Maxz, rollback version
[21:53:40 CET] <Nosomy> if is possible
[22:03:21 CET] <Maxz> Nosomy: :(, I can't, I need use_fifo in tee muxer (introduced in oct 2016). I just need confirm I'm not alone with this issue. I wrote a patch months ago for decklink (https://ffmpeg.org/pipermail/ffmpeg-devel/2016-May/194063.html) but the maintainer replaced my patch later
[22:03:36 CET] <faLUCE> any suggestion?
[22:08:53 CET] <Nosomy> faLUCE make a issue report on vlc devel
[22:11:23 CET] <faLUCE> Nosomy: I can't report an issue if I don't know if it is an issue
[22:11:47 CET] <faLUCE> I don't understand if I have to set both pts and dts, and to which value
[22:34:27 CET] <nadermx> how would I add a black border around the text i put in with draw font
[22:34:35 CET] <nadermx> text='cool text':fontcolor=white:x=620:y=-1[x];[x][1:v]paletteuse
[22:47:31 CET] <nadermx> nvm found the drawbox
[22:57:04 CET] <faLUCE> If set pts = now and dts = pts , when I play the stream  with ffplay I obtain continously this  message:    mpegts @ 0x7f32d8009260] invalid dts/pts combination    . I don't understand how do I have to set pts and dts
[22:57:24 CET] <faLUCE> then Nosomy, the problem is not of vlc
[23:01:02 CET] <faLUCE> I see that in utils.c there's a comment:  "Some MPEG-2 in MPEG-PS lack dts (issue #171 / input_file.mpg). We take the conservative approach and discard both. Note: If this is misbehaving for an H.264 file, then possibly presentation_delayed is not set correctly. */"
[23:41:45 CET] <faLUCE> Well. I'm getting crazy. Is there anyone who know how to set pts and dts for a h264 mpegts LIVE stream? I tried many combination. I tried to set them both incremental with a simple index (and the stream can be correctly seen from ffplay and mplayer, but not from vlc). I tried to set them by computing the current time (gettimeofday), and I can see a good stream with mplayer, a huge delayed stream with ffplay and a stream
[23:41:47 CET] <faLUCE> that skips many frames with vlc..... is there a rule for that?
[23:42:53 CET] <faLUCE> who has to set these ts? the streamer or the player?
[23:46:39 CET] <faLUCE> I suppose that the streamer has only to set pts. Then, the receiver has enough information of how to order frames
[00:00:00 CET] --- Sat Jan 21 2017

More information about the Ffmpeg-devel-irc mailing list