[Ffmpeg-devel-irc] ffmpeg.log.20170126

burek burek021 at gmail.com
Fri Jan 27 03:05:01 EET 2017

[00:38:59 CET] <rafasc> I am trying to record audio and video from my webcam, But the audio is desync'd.
[00:39:02 CET] <rafasc> http://pastebin.com/xnUSrxbq
[00:41:25 CET] <rafasc> http://pastebin.com/3Jqvwpu5
[00:48:39 CET] <llogan> are you sure toy need -ts and -af?
[00:48:47 CET] <llogan> "you", not "toy"
[00:54:59 CET] <rafasc> I put those options trying to fix the issue.
[00:55:12 CET] <rafasc> but with no success.
[01:35:37 CET] <tdude51> Hi folks, I'm attempting to capture NTSC composite video from a USB UTV007 capture card on my Raspberry Pi 3 Model B, and I'm getting the error "Dequeued v4l2 buffer contains corrupted data (691200 bytes)". I built ffmpeg using this guide: http://hannes.enjoys.it/blog/2016/03/ffmpeg-on-raspbian-raspberry-pi/ . I'm using the command "ffmpeg -f v4l2 -s 720x480 -i /dev/video0 -vf yadif -c:v libx264 -preset ultrafast test_ffmpeg.flv -y".
[01:35:43 CET] <tdude51> The identical version of the command works fine when I use the version of avconv installed from the raspberry pi's built in package manager. The video generated by ffmpeg seems to have drops in framerate, but the video generated by avconv plays fine at 29.97fps. I ran both commands for ~10 seconds and they both had ~40% CPU usage throughout. I've included the commands and output from both in the following pastebin: http://pastebin.co
[01:38:28 CET] <llogan> your paste was cut off
[01:39:14 CET] <tdude51> What was in the pastebin, or one of my messages?
[01:45:31 CET] <furq> the url
[01:47:52 CET] <furq> https://www.johnvansickle.com/ffmpeg/
[01:48:09 CET] <furq> if you're not using the builtin h264 encoder then you might as well use the armhf builds on there
[01:49:07 CET] <furq> i'm not sure why that guide recommends building with --arch=armel, but i'm not sure if that actually does anything with ffmpeg's build system
[01:49:21 CET] <furq> or why it recommends building x264 with --host when you're not cross-compiling
[01:51:33 CET] <tdude51> http://pastebin.com/WMAfuuzV is the pastebin
[02:11:00 CET] <tdude51> i had the same issue with both static arm builds. I'll see what I can do about making use of the builtin h264 encoder, I was unaware of that. thanks for your help.
[02:43:00 CET] <Hexmind> Hi all. In a game I'm developing I want to implement video export. For now I save every frame to sequenced images and then from the command I create video with the images. I was wondering if it's possible to create a video directly from within the game using the ffmpeg api, and if so, what functions should I look into.
[02:50:50 CET] <DHE> Hexmind: you'll need to deal with the libavcodec layer to encode audio and video, and libavformat to deal with the file IO
[02:52:48 CET] <Hexmind> DHE, I'll look into those. thanks
[02:54:42 CET] <DHE> Hexmind: http://ffmpeg.org/doxygen/3.2/group__lavf__encoding.html#details  This gets you started on the file writing
[03:21:45 CET] <faLUCE> I'm really getting crazy with these pts. I think that I have done all properly, but there's something wrong. I encode (mp2) into an AVPkt a frame of 1152 samples at each cycle, taken from an audio device set at 1/16000 sample rate.  Then I compute the pkt's pts in this way:   encodedAudioPkt.pts = 1152*cycleCounter;   .  Then I don't understand how to rescale this to the mpegts (stream) time_base.   I tried with   av_
[03:21:46 CET] <faLUCE> rescale_q(encodedAudioPkt.pts, audioEncoderTimeBase, mpegtsTimeBase) , where audioEncoderTimeBase is 1/16000, but in this way the packets are not synced with the system clock.... What I have to do?  here's a very short snippet of my code, I don't understand what's wrong:   http://paste.ubuntu.com/23867038/
[06:16:12 CET] <damdai> i found a bug in VLC but they are not willing to fix it  :  http://imgur.com/a/yvyyO
[06:26:19 CET] <kepstin> damdai: so, why complain about it here?...
[06:26:33 CET] <the_k> hello
[06:26:55 CET] <damdai> kepstin  i think there are lot of vlc supports here
[07:14:16 CET] <Kuukunen> kepstin: he's been spamming that same thing to multiple unrelated channels for many days now
[07:38:20 CET] <the_k> i'm saving an rtsp stream to disk but would like to be able to play the recorded stream file as it's being recorded.. any ideas?
[08:24:38 CET] <xtina> hey guys. i have ffmpeg-3.1.4-armel-32bit-static.tar.xz on a Pi Zero and am having DNS issues streaming to rtmp urls that include domain names, so I've been forced to stream directly to IP addresses
[08:27:10 CET] <xtina> i'm finding this unreliable, and would like a better solution. any suggestions?
[08:27:39 CET] <xtina> is there a different version of ffmpeg that is compatible with the Zero, where I can stream directly to rtmp domains?
[08:32:49 CET] <bencoh> I somehow doubt your dns issues come from ffmpeg (?)
[08:37:53 CET] <xtina> @bencoh: i believe it does, i think i manually compiled ffmpeg with the help of some folks here, who realised the dns issues with my package
[08:38:03 CET] <xtina> but different ffmpeg packages can't build properly on the zero (?)
[08:38:06 CET] <xtina> my memory is a little hazy
[08:38:27 CET] <xtina> but i had this same conversation a while back with guys in here, who reproduced my issue on their own machines
[08:38:35 CET] <bencoh> okay
[08:39:37 CET] <xtina> if there's a way to find historical logs for this channel, I can bring up the conversation we had about this previously?
[08:43:19 CET] <xtina> @furq i think i remember us talking about this...
[10:26:25 CET] <hyponic> Hello.. I am having an issue that requires libzvbi to be modified. I am willing to pay someone to modify libzvbi / ffmpeg to do what i need. If you have the skill to do so or know who does please let me know.
[11:49:18 CET] <thebombzen> hyponic: well if libzvbi needs to be modded why are you asking in #ffmpeg
[11:51:08 CET] <hyponic> thebombzen because i am not sure what needs to be modded. i just want the solution to work and i know there is a lot of capable people here that might be able to get it done. and i am willing to pay a bit to get it done.
[11:51:55 CET] <thebombzen> well keep in mind you just waltzed into a FOSS channel and said "I will pay someone here to get this done"
[11:53:00 CET] <thebombzen> especially since you say "I want a modded version of zvbi/ffmpeg" but didn't say what you need
[11:53:27 CET] <thebombzen> most people will see that and be like "oh you need a modded version, that's nice, why don't you rename it or something then it'll be modified"
[11:53:51 CET] <thebombzen> if you don't ask the question you want answered and instead are extremely vague, nobody's going to be able to help you
[11:55:49 CET] <hyponic> thebombzen you are absolutely right.. i am sorry about that!
[11:56:44 CET] <hyponic> What i want done is to be able to covert teletext subtitles to dvbsubtiles.  https://trac.ffmpeg.org/ticket/5913
[11:57:00 CET] <hyponic> I am not sure how to explain it more to be honest.
[11:58:44 CET] <thebombzen> it looks like you can do that with swscale
[11:58:57 CET] <thebombzen> also when the maintainer changes the priority to "wish"
[11:59:06 CET] <thebombzen> don't go and change it back to "important" you're just wasting everyone's time
[11:59:22 CET] <thebombzen> that's a great way to get the ffmpeg devs to ignore the ticket
[12:00:28 CET] <hyponic> thebombzen swscale ? i am not sure what you mean!
[12:01:26 CET] <hyponic> thebombzen yeah.. i am new to the trac thing and it's not even my ticket. all i wanted to do was to say that i would sponsor a solution for it. My bad. :S
[12:02:08 CET] <thebombzen> so an issue is "important" if it's like "ffmpeg can't decode h.264 streams encoded with libx264"
[12:02:22 CET] <thebombzen> given that that issue will affect lots of people and break workflows, that's important
[12:02:43 CET] <thebombzen> an issue like "ffmpeg has a security hole CVE-X that's easily exploitable" would be critical
[12:02:58 CET] <thebombzen> something like "I want zvbi to do this one weird thing with ffmpeg for my own personal project" is neither
[12:03:00 CET] <thebombzen> and you should know that
[12:04:10 CET] <thebombzen> have faith and respect the people who know what they're doing - if a maintainer changes the priority to "wish" you should respect that they know what "wish" means and that they know that the ticket blongs there
[12:04:55 CET] <hyponic> thebombzen you are right.. sorry  about that.
[12:08:06 CET] <hyponic> thebombzen how can swscale do it?
[12:08:15 CET] <thebombzen> http://www.google.com/
[12:08:48 CET] <thebombzen> I'm not sure, that's just a guess
[12:08:54 CET] <thebombzen> but start by learning what swscale is
[12:09:03 CET] <thebombzen> meanwhile I'm going to get some sleep
[12:46:47 CET] <mixfix41> c\\
[13:48:57 CET] <dooome> hello!
[13:49:24 CET] <dooome> cant resize one of my testvideos for some reason
[13:49:27 CET] <dooome> [h264 @ 0x29112c0] Aspect ratio mismatch between muxer (3200/3213) and encoder layer (1/1)
[13:50:14 CET] <dooome> there must be something I can do to get it to work
[13:50:27 CET] <dooome> http://pastebin.com/htFxapME
[13:54:40 CET] <dooome> (I'm sorry for changing anamorphic, but I need to do that..)
[14:12:06 CET] <dooome> never ming
[14:12:08 CET] <dooome> mindÄ
[14:12:11 CET] <dooome> *
[14:12:16 CET] <dooome> think i've got it
[15:14:06 CET] <NermaN> Hello, why ffmpeg freezes just after start?
[15:14:22 CET] <NermaN> http://pastebin.com/2MmJBY04
[15:20:51 CET] <jkqxz> The encode driver hasn't produced any output?  "[h264_vaapi @ 0x55945a613760] Output buffer: 0 bytes (status 00000000)."
[15:21:31 CET] <jkqxz> What platform / driver is it using?
[15:21:56 CET] <jkqxz> Also maybe try with the encoder on its own, not using the decode hwaccel at the same time.
[15:23:11 CET] <NermaN> jkqxz: vainfo: VA-API version: 0.39 (libva 1.7.3) vainfo: Driver version: Intel i965 driver for Intel(R) Ivybridge Mobile - 1.7.3
[15:23:19 CET] <NermaN> jkqxz: linux
[15:25:04 CET] <NermaN> jkqxz: disabling hwaccel does not change anything =(
[15:27:36 CET] <jkqxz> Anything interesting about the input file?
[15:29:45 CET] <NermaN> jkqxz: no, just simple h264 1920x1080 file without audio
[15:29:49 CET] <jkqxz> Also how frozen is it?  Can you get a backtrace from gdb?  Are there any nasty messages in the kernel log?
[15:30:44 CET] <jkqxz> (Same command works for me on Haswell.)
[15:31:35 CET] <NermaN> jkqxz: it just stops on last message of log. Nothing on kernel log
[15:36:30 CET] <jkqxz> Run in gdb, control-c after it's frozen, backtrace?
[15:37:07 CET] <jkqxz> You could also try current git, though I don't think there will be any interesting difference.
[17:59:39 CET] <lacrymology> hellp
[17:59:42 CET] <lacrymology> hellO
[18:00:20 CET] <lacrymology> is there any easy way to create a video that's just a black square with a timestamp?
[18:03:43 CET] <furq> nullsrc and drawtext
[18:03:49 CET] <furq> or color and drawtext, rather
[18:17:03 CET] <phillipk> I have an issue with my script--I'm layering in a few audio files on top of a video that has audio and video.  The primary issue is the output puts audio in stream 1 and video in stream 2--I want it in the other order--see command: http://pastebin.com/uN5nnSCr
[18:42:31 CET] <IamTrying> 3 Books i bought on FFMpeg. But none of the book talks about how to use FFMpeg to create virtual webcam in Windows OS?
[18:47:24 CET] <durandal_1707> who told you to buy books about FFMpeg instead of FFmpeg?
[18:52:40 CET] <phillipk> are there any books?  I've learned the most on this irc, friends, stackoverflow (of course), and the ffmpeg wiki (ffmpeg docs too, but they're not set up the way I learn anyway).
[18:54:18 CET] <IamTrying> durandal_1707, phillipk no one, i am in the middle of project where i need to make a webcam source for directshow. i was 100% sure like FFMpeg is best expert multi media tool, it must have some sample. But i was obviously wrong even FFmpeg experts does not had any sample. was shocking
[18:56:07 CET] <durandal_1707> IamTrying: im not on windows so i cant help you
[18:56:56 CET] <IamTrying> http://www.e2esoft.cn/vcam/vcamsdk.asp - something like this i need but open-source, just to get the idea how its made. then i can write my own C++ prototype
[19:48:12 CET] <CesarSouza> Hello, anybody could help me find some information on how to debug an errorcode -22 when calling avcodec_open2() on Windows (using Zeranoe's builds)?
[19:49:13 CET] <Zeranoe> CesarSouza: How are you calling it?
[19:51:18 CET] <BtbN> using av_strerror would be a good start
[19:51:34 CET] <CesarSouza> well, passing a codecContext that is coming from a AVStream that I got from calling avformat_new_stream
[19:51:35 CET] <DHE> under linux that means Invalid Argument
[19:52:00 CET] <DHE> was there anything logged to stderr at the same time? (or if you redirect logging yourself, to your log target)
[19:52:04 CET] <CesarSouza> BtbN hey thanks I wasn't aware of strerror
[19:53:17 CET] <DHE> ah, you're on windows
[19:58:29 CET] <CesarSouza> I am trying to setup a better test environment, it seems VS wasn't capturing stdout or stderr when the code runs from a unit test
[20:25:18 CET] <kira666> hello i have a question related to embed h.265 with ffmpeg.
[20:26:46 CET] <llogan> what is your question?
[20:28:41 CET] <kira666> i changed the h.265 code for my college project and i want to embed with ffmpeg so i can use like streaming features but the video will encode with my customized h.265. please can you tell how i embed my h.265 with ffmpeg
[20:29:28 CET] <Zeranoe> kira666: The decoding H.264 code in FFmpeg, or libx264?
[20:29:30 CET] <spiderkeys> does anyone know if the HRD parameters in h264 SPS NALs are critical for decoding?
[20:30:40 CET] <kira666> H.265
[20:31:09 CET] <JEEB> spiderkeys: I think they're mostly meant for the decoder making sure it buffers enough (and for verification)
[20:31:22 CET] <kira666> @zeranoe H.265 encoder
[20:31:41 CET] <kira666> i am pretty noob
[20:31:54 CET] <JEEB> kira666: libavcodec itself doesn't contain HEVC encoding, you would have to patch one of the encoders that can be used through it (libx265, libkvazaar etc)
[20:32:04 CET] <JEEB> and then link your FFmpeg to that :P
[20:32:27 CET] <JEEB> of course, if you break the HEVC spec with your bit stream then good luck and have fun of course
[20:32:39 CET] <JEEB> because absolutely nothing will be able to decode your thing
[20:34:27 CET] <spiderkeys> JEEB: Yea, I ran into a situation where not having the bitstream_restriction_flag and max_frame_num_reorder fields set caused the hardware decoder to expect 15 frames, introducing a half second latency at 30fps. The library that I'm using to read and write SPS NALs has an incorrect implementation of read/write exponential golomb, so it fails to properly read and write bit_rate_value_minus1 and cpb_size_value_minus1, since the values in h264 can be
[20:34:27 CET] <spiderkeys> larger than it is written to handle. Since those are the only two problematic values, I was thinking of just leaving the HRD section out
[20:34:48 CET] <spiderkeys> But I don't want to run into a new latency problem by taking them out :P
[20:35:22 CET] <Zeranoe> spiderkeys: This is a library that isn't currently supported by FFmpeg?
[20:35:48 CET] <kira666> my customized code H.265 is working. i have encoded successfully and decoded using mplayer. but to stream it i want to use ffmpeg. please can you tell me how to libx265 with mycode
[20:35:49 CET] <JEEB> spiderkeys: it really depends on how your exact thing you're going to be using for decoding behaves :P
[20:35:54 CET] <spiderkeys> Zeranoe: it is h264bitsream: https://github.com/aizvorski/h264bitstream
[20:36:05 CET] <spiderkeys> It had a bunch of other bugs too, which I fixed
[20:36:39 CET] <spiderkeys> ffmpeg has a correct implementation for golomb exponentials, but it doesnt have a public API for parsing and modifying SPS NALs in the c library
[20:37:11 CET] <spiderkeys> I was going to work at upgrading h264bitstream to use ffmpeg's implementation, but that will take a while, so I'm exploring temporary solutions
[20:38:09 CET] <llogan> kira666: at the very least: "./configure --enable-gpl --enable-libx265"
[20:38:39 CET] <JEEB> spiderkeys: personally I would just poke the decoding thing so it would start playback ASAP if you know your network will always be way faster than what you're doing
[20:38:57 CET] <JEEB> unless you know your HRD info that the encoder is writing is incorrect
[20:39:11 CET] <JEEB> in which case I would propose a bug report or a patch to the encoder
[20:40:14 CET] <kira666> llogan can i have to compile my code with ffmpeg using --enable libx265
[20:40:40 CET] <llogan> you can haz ffmpeg use libx265
[20:42:00 CET] <kira666> llogan is there any thing so i can replace it from linux without recompiling whole ffmpeg with it
[20:42:29 CET] <furq> ./myencoder - | ffmpeg -f h265 -i -
[20:43:09 CET] <furq> if you have a patched libx265.so you can try replacing your system one with it, but that's probably going to break
[20:43:38 CET] <kira666> can you explain above command
[20:45:05 CET] <kira666> furq can you explain above command
[20:49:09 CET] <llogan> it is piping the output from "myencoder" into ffmpeg
[20:49:36 CET] <llogan> basic linux stuff
[20:50:15 CET] <Zeranoe> Hey, Windows has that too llogan
[20:50:24 CET] <Zeranoe> Basic computer usage?
[20:50:58 CET] <spiderkeys> JEEB: Yea, the only reason I found out there was an issue was that the Chromium team told us that the hardware decoder was buffering because of the bitstream restriction flag (we are feeding in fragmented mp4 frames one by one to get super low latency livestreaming in the browser). Unfortunately, our camera doesn't expose an API to the SPS settings that we need to change and the firmware is proprietary :(
[20:51:19 CET] <JEEB> rip you then
[20:51:28 CET] <JEEB> my condolences
[20:52:22 CET] <spiderkeys> I've successfully modified the SPS in the way I need, the only issue being I have to remove the HRD fields. I guess we'll see if that introduces any new problems haha
[20:52:24 CET] <kira666> Thankyou for your help llogan JEEB furq
[20:52:50 CET] <spiderkeys> I wish h264bitstream was still actively developed, really deserves some love and attention
[20:53:11 CET] <JEEB> those kinds of tools usually end up just being something used for a trick or two
[20:53:13 CET] <spiderkeys> or alternatively, I wish libx264 also had parsing functionality
[20:53:30 CET] <JEEB> also there's an ancient patch to add bit stream filters into libavcodec
[20:53:38 CET] <JEEB> that modify the contents of certain NAL units
[20:54:01 CET] <JEEB> (can be found on doom9)
[20:54:04 CET] <spiderkeys> Yea, unfortunately that patch didn't target the fields I needed
[20:54:33 CET] <spiderkeys> I think no support for VUI parameters
[23:17:41 CET] <throwaway> Hi, I am livestreaming from a Pi Zero, and I was instructed from this IRC channel to install the static ARMEL ffmpeg tar from https://www.johnvansickle.com/ffmpeg/. It is called ffmpeg-release-armel-32bit-static.tar.xz - md5
[23:18:14 CET] <throwaway> with this ffmpeg build, I'm forced to use the IP addresses in the RTMP URLs to avoid a DNS issue that others in this channel were able to Repro
[23:18:40 CET] <throwaway> using the IP addresses has been fine for the Twitch and Youtube Live RTMP urls, but isn't working for Facebook Live
[23:18:54 CET] <throwaway> I suspect it's because Facebook Live's URL seems to run across many IP addresses?
[23:19:38 CET] <throwaway> I'm wondering what I should do. I remember someone in this chat telling me I could try using the armhf ffmpeg build with my Zero, but I'd have to do some stuff first, and I don't recall the details...
[23:20:39 CET] <throwaway> furq: were we chatting about this? I recall your name, but it has been a while, haha
[23:24:45 CET] <furq> oh right i'm pretty sure that's a librtmp issue
[23:25:02 CET] <furq> actually maybe i'm thinking of something else
[23:25:58 CET] <kerio> throwaway: any particular reason you're not installing ffmpeg from the repo?
[23:26:08 CET] <furq> iirc the one from repos didn't work at all
[23:26:21 CET] <furq> if it's a pi zero then it'll be raspbian which i think is still using libav
[23:27:34 CET] <throwaway> right - and libav would not work for me, i tried for a very long time
[23:28:46 CET] <throwaway> kerio: Pi Zeros/Pi 1s use ARMEL, i think in the ffmpeg repo it was ARMHF, only compatible with Pi 2+?
[23:29:04 CET] <BtbN> armel just means little endian
[23:29:06 CET] <kerio> soft float/hard float is only a software thing
[23:29:09 CET] <furq> technically they're both armhf
[23:29:12 CET] <BtbN> armhf means it has a hardware float unit
[23:29:18 CET] <BtbN> But it's still little endian
[23:29:25 CET] <furq> but debian's armhf packages are for armv7
[23:29:33 CET] <kerio> isn't hard float vs soft float just a different way to use the fpu registers
[23:29:34 CET] <furq> the pi 1 and zero are armv6, which is why you need to use the armel packages
[23:29:38 CET] <kerio> in the calling convention
[23:29:40 CET] <BtbN> Yeah, the Pi CPU is a bit weird, being armv6 with hard floats
[23:29:54 CET] <BtbN> Debian does not build packages for that combination
[23:29:57 CET] <furq> that's why raspbian exists
[23:30:10 CET] <throwaway> this is the command I used with Twitch live, it works perfectly
[23:30:12 CET] <furq> running armel stuff on a hardfloat cpu is obviously less than ideal
[23:30:32 CET] <throwaway> Hmm, I don't know why it won't let me post it..
[23:30:44 CET] <throwaway> command: /usr/bin/raspivid  -o - -t 0 -vf -hf -fps 20 -b 6000000 | ./ffmpeg -f lavfi -re -i anullsrc -f h264 -thread_queue_size 512 -framerate 20  -probesize 100  -i - -vcodec copy -acodec aac -g 20  -f flv rtmp://
[23:31:06 CET] <throwaway> it works perfectly. but when I replace the twitch RTMP URL (note the IP addr) with the facebook live one, I start to get RTMP header packet errors
[23:31:09 CET] <furq> i know librtmp has some dns lookup issues but the one i'm thinking of is basic auth in rtmp urls
[23:31:32 CET] <furq> but iirc i checked your issue with a native rtmp build and it didn't work
[23:31:34 CET] <BtbN> you maybe should not share your streams credentials in a public IRC channel
[23:31:38 CET] <throwaway> the only thing I'm switching is the rtmp url from twitch to fb. suspiciously I've noticed that when I lookup the Ip addr for the fb live domain, it changes frequently...
[23:31:48 CET] <furq> yeah it'll do that
[23:31:56 CET] <throwaway> BtbN, yes, whoops. it's a totally empty channel, but yes :)
[23:32:31 CET] <throwaway> could that be causing this issue with facebook live? otherwise i'm not sure why it's the only domain causing rtmp header problems
[23:32:53 CET] <furq> what, the ip changing?
[23:32:56 CET] <furq> i doubt it
[23:33:09 CET] <furq> you'll get the same thing with youtube and any sufficiently large org
[23:33:11 CET] <BtbN> does rtmp send a Host-Header like http does?
[23:33:44 CET] <furq> i remember trying the domain you pasted and it didn't work here, so i doubt it's down to dns caching or something like that
[23:34:07 CET] <throwaway> I see. the FB Live RTMP url looks like this: rtmp://rtmp-api.facebook.com:80/rtmp/KEY
[23:34:29 CET] <throwaway> I am not sure what IP to use to replace rtmp-api.facebook.com, as there are many..
[23:34:38 CET] <BtbN> any of them
[23:34:51 CET] <BtbN> But why would DNS lookup not work? That makes no sense
[23:35:34 CET] <furq> yeah the ip will work but there's a good chance the one you pick will become invalid at some point
[23:36:09 CET] <throwaway> I am currently using rtmp://  here is the full pastebin of the log: http://pastebin.com/3CgEYwfJ
[23:36:46 CET] <throwaway> ultimately it says Opening an output file: rtmp://  [rtmp @ 0x2a7ba00] No default whitelist set  RTMP_ReadPacket, failed to read RTMP packet header  rtmp:// Unknown error occurred
[23:37:13 CET] <furq> well that's happening with the ip so it can't be a dns issue
[23:37:13 CET] <throwaway> BtbN: I see, I am indeed just trying some of the IP addresses associated with that domain.
[23:37:44 CET] <throwaway> it isn't a DNS issue, but i'm unsure what's causing the rtmp packet header issue, as I only see it with Facebook RTMP URL
[23:38:05 CET] <furq> that could be any number of things
[23:38:12 CET] <throwaway> could this indicate something wrong with how I configured the facebook livestream from the browser?
[23:38:15 CET] <furq> invalid key, someone's already streaming to that channel, etc etc
[23:38:20 CET] <throwaway> i'm unsure if it's related to ffmpeg
[23:38:26 CET] <throwaway> I see
[23:38:37 CET] <furq> afaik "failed to read packet header" normally just means the remote host closed the connection
[23:38:52 CET] <furq> which could be down to anything
[23:39:38 CET] <throwaway> I see. I'll investigate the configuration of the stream, then..
[00:00:00 CET] --- Fri Jan 27 2017

More information about the Ffmpeg-devel-irc mailing list