[Ffmpeg-devel-irc] ffmpeg.log.20170603

burek burek021 at gmail.com
Sun Jun 4 03:05:02 EEST 2017

[00:00:50 CEST] <furq> pro tip: don't paste the entire nicklist when nobody answers your question
[00:01:35 CEST] <furq> also what an unimaginative choice of fakenick. he has so many dinosaurs to choose from
[00:01:51 CEST] <tdr> furq, can we expand that to: don't email every email address everywhere to make sure you get your ex? ;)
[00:02:24 CEST] <furq> depends what the email says
[00:02:31 CEST] <furq> it sounds like it'll probably be quite entertaining
[00:15:47 CEST] <johnjay> hey furq I got ffmpeg, yay
[00:16:04 CEST] <johnjay> I think I still don't have mpv though. I'm rebuilding now with that mpv_build script thing
[00:41:19 CEST] <blue_misfit> hey guys! I'm working with MOV files that have edit lists - I believe ffmpeg has support for these now, but not sure what params I can adjust
[00:41:27 CEST] <blue_misfit> is there anything other than -ignore_editlist 1
[00:41:28 CEST] <blue_misfit> ?
[01:36:21 CEST] <zerodefect> kepstin: Are you about?
[01:36:37 CEST] <kepstin> yo.
[01:36:50 CEST] <zerodefect> Discovered the issue with B-Frames. :)
[01:37:47 CEST] <zerodefect> I was effectively doing a transcode.  What I didn't appreciate is that key_frame and pict_type on the AVFrame from the decoder have a direct affect on the sort of frame generated in the encoder
[01:38:37 CEST] <zerodefect> I was decoding a DV-PAL frame so each AVFrame was marked as 'key_frame' and 'pict_type was marked as I-Frame.
[01:39:28 CEST] <zerodefect> Live and learn :)
[01:40:25 CEST] <kepstin> huh, that hadn't occurred to me. but yeah, I guess that is the api used to request key frames in specific spots in the encoded video :/
[01:42:25 CEST] <zerodefect> Yeah. Are you familiar with dev change process? Would it be fairly easy to commit a change to update the doxygen docs?
[01:43:08 CEST] <kepstin> I've done patches for ffmpeg before yeah. For something simple like a doc update it shouldn't be too hard to do.
[01:43:35 CEST] <zerodefect> I'll give it a go :)
[01:43:37 CEST] <kepstin> (you might want to poke around in #ffmpeg-devel for that sort of thing)
[01:43:47 CEST] <zerodefect> Yes, will do.
[01:50:03 CEST] <zerodefect> Is it worth asking if this is expected behaviour in #ffmpeg-devel?
[02:00:43 CEST] <kepstin> zerodefect: looks like it is - e.g. ffmpeg.c has explicit code to reset the 'pict_type' field to 0
[02:01:32 CEST] <kepstin> (and an ffmpeg.c option exists that causes it to be set to AV_PICTURE_TYPE_I to force a keyframe in certain shots)
[02:03:24 CEST] <zerodefect> Ah ok. I'll check that out.
[02:08:24 CEST] <zerodefect> Yeah, I see what you mean.  It seems to do something with 'quality' too!
[02:08:32 CEST] <zerodefect> *something similar
[02:22:38 CEST] <kepstin> you should probably just go through the avframe docs and just make sure everything is set sanely; alternatively, you could do something like make a new avframe with cloned/moved buffers but copy over only specific values you want to set
[02:30:43 CEST] <zerodefect> That is a good suggestion.
[02:30:56 CEST] <zerodefect> I better hit they hay. It's late here. Thanks again for your help.
[02:56:32 CEST] <johnjay> kepstin: i got ffmpeg finally!
[03:52:02 CEST] <johnjay> furq any idea what I'm doing wrong? I got ffmpeg with that mpv-build thing but mpv itself isn't building
[03:52:56 CEST] <johnjay> buffer 4
[12:19:16 CEST] <pokmo> hi
[12:19:47 CEST] <pokmo> i'm trying to make segments from my CCTV stream using the command 'avconv -r 7 -i rtsp:// -acodec aac -strict -2 -vcodec copy -f segment -segment_time 300 -segment_format mp4 "mon1-%03d.mp4"'
[12:20:08 CEST] <pokmo> the first segment is fine, but all subsequent segments are black and have no audio
[12:20:17 CEST] <pokmo> does anyone know why this might be the case?
[12:20:29 CEST] <pokmo> the file sizes look reasonable
[12:26:03 CEST] <ChocolateArmpits> pokmo, what are you using to playback the segments ?
[12:26:21 CEST] <pokmo> ChocolateArmpits, i'm using quicktime and VLC. the first segment plays back fine.
[12:28:09 CEST] <pokmo> here's avconv's output, if that helps: https://dpaste.de/pq1r
[12:28:25 CEST] <pokmo> i'm now testing with just segments 5s long
[12:30:39 CEST] <pokmo> i wonder if that 'container format requires global headers' warning might be the cause?
[12:34:32 CEST] <pokmo> hmm funny. i can view it on dropbox but not VLC
[12:34:34 CEST] <pokmo> https://www.dropbox.com/s/1je2ex14l3smrxq/test-001.mp4?dl=0
[12:35:19 CEST] <pokmo> there's a long delay for VLC to play
[12:38:15 CEST] <ChocolateArmpits> pokmo, have you tried segmenting to mpegts ?
[12:40:22 CEST] <pokmo> ChocolateArmpits, oh! mpegts seems to be better. is it a known issue with mp4?
[12:41:14 CEST] <ChocolateArmpits> I didn't have trouble using mp4 with ffmpeg, but I don't the specifics of avconv
[12:41:26 CEST] <ChocolateArmpits> Might be some timestamp issue
[12:41:45 CEST] <ChocolateArmpits> don't know*
[12:42:27 CEST] <pokmo> ChocolateArmpits, mpegts files are somewhat larger than mp4, right?
[12:42:38 CEST] <BtbN> pokmo, avconv is not an ffmpeg tool btw.
[12:42:41 CEST] <ChocolateArmpits> segmenter is primarily used for hls and that relies on mpegts so I guess the intended compatibility is with that format
[12:43:26 CEST] <pokmo> BtbN, oh? is it not?
[12:43:30 CEST] <ChocolateArmpits> pokmo, yes it will because each packet has data attached
[12:43:30 CEST] <BtbN> no, ffmpeg is.
[12:43:53 CEST] <BtbN> And mp4 is not streamable. In theory, you could make a lot of small files every X seconds, but I think the segment muxer is very basic and just cuts the output from the underlying muxer into parts.
[12:44:07 CEST] <BtbN> If you really want mp4 segments, you can use the dash muxer
[12:46:23 CEST] <pokmo> right
[12:46:32 CEST] <pokmo> maybe i should try ffmpeg
[12:47:12 CEST] <pokmo> but i guess i'd get the same result, since avconv seems to use ffmpeg
[12:48:09 CEST] <pokmo> BtbN, but i'm not trying to stream mp4 though. i'm just trying to make segments in mp4
[12:48:33 CEST] <BtbN> but the format needs to be streamable for the segment muxer I believe
[12:49:21 CEST] <kerio> BtbN: fragmented isobmff is streamable tho
[12:49:47 CEST] <BtbN> but you still can't enter it at random locations
[12:49:52 CEST] <BtbN> that's how DASH works
[12:49:57 CEST] <pokmo> well, it's rtsp.. so i guess it's h264
[12:54:55 CEST] <pokmo> is there a way to set the fps of the output segments?
[12:55:00 CEST] <kerio> latest HLS also works like that, right
[12:55:04 CEST] <pokmo> i've tried "-r 10" but it doesn't seem to work
[12:55:25 CEST] <kerio> fragmented mp4 and playlist with fragment byte indices
[13:05:55 CEST] <pokmo> BtbN, you were saying how avconv isn't a ffmpeg tool, but if i run avconv --help i get
[13:05:57 CEST] <pokmo> ffmpeg version 2.8.11-0ubuntu0.16.04.1 Copyright (c) 2000-2017 the FFmpeg developers
[13:06:16 CEST] <BtbN> no idea how that would happen, I blame ubuntu.
[13:06:20 CEST] <BtbN> avconv is the libav tool.
[13:07:06 CEST] <pokmo> yeah. i installed it from libav-tools
[13:07:59 CEST] <pokmo> but then, my ffmpeg doesn't have the -framerate option
[13:08:42 CEST] <BtbN> Ubuntu removed libav, and is using ffmpeg again.
[13:08:54 CEST] <BtbN> And probably are providing simple symlinks for the old names
[13:10:58 CEST] <pokmo> hmm
[13:11:26 CEST] <pokmo> BtbN, but is -framerate meant to be a valid option?
[13:12:06 CEST] <BtbN> if it says it doesn't know it, probably not
[13:12:11 CEST] <pokmo> it's described here though https://en.wikibooks.org/wiki/FFMPEG_An_Intermediate_Guide/image_sequence#Framerate
[13:12:19 CEST] <pokmo> but not under my --help
[13:13:01 CEST] <BtbN> no idea if it was removed, is only in libav, or was added in a later version. But yours obviously doesn't have it.
[13:13:03 CEST] <BtbN> try -r
[13:13:55 CEST] <pokmo> BtbN, yeah, i have. it doesn't seem to affect the fps of my segments
[13:16:51 CEST] <pokmo> BtbN, avconv is just a symlink to ffmpeg
[15:46:17 CEST] <Guest92861> Hi. I'm trying to extract a frame (losslessly) of an MP4 at a specific time or specific frame (whatever works). I've tried various commands I've found online but I can't get them to work.
[15:57:52 CEST] <dystopia_> if you waited more than 5 mins you would have got the answer
[16:50:11 CEST] <kepstin> pokmo: framerate is an option specific to certain inputs, e.g. you'll see it if you run "ffmpeg -h demuxer=image2"
[16:50:22 CEST] <kepstin> and the same option name is used on e.g. v4l, x11grab, etc.
[16:51:05 CEST] <kepstin> but it's an input option, so it can only be used on specific inputs (placed before the -i)
[17:14:36 CEST] <kerio> dystopia_: how do you get the image to be lossless tho
[17:14:41 CEST] <kerio> does png support yuv420
[17:14:46 CEST] <kerio> or yuv in general
[17:16:04 CEST] <kepstin> png? no. But you could probably use jpeg2000 or even just a single-frame lossless h264, i guess.
[17:50:20 CEST] <DHE> is there a reason nvenc requirements were raised to nvidia driver version 378 or higher? 375 is still supported...
[18:43:35 CEST] <drozdziak1> Any nice free tools for analysing MPEG transport streams you could recommend? Sorry if that's not a good channel for this, but I'm looking at a *.ts's hexdump and it doesn't quite make sense for me.
[18:43:51 CEST] <drozdziak1> And I'd like something that would help me understand it better on a higher level first
[18:44:28 CEST] <drozdziak1> And I couldn't find any digital tv related IRC channels
[18:59:33 CEST] <DHE> wireshark
[18:59:38 CEST] <DHE> seriously, open a .ts file in wireshark
[19:01:55 CEST] <DHE> drozdziak1: name highlight, see above
[19:02:50 CEST] <drozdziak1> DHE: Cool! Thank you! :)
[19:03:10 CEST] <DHE> I take it you tried it
[19:04:35 CEST] <drozdziak1> Yes, it perfectly names the malformed packets. In fact I'm doing a forensics CTF channels to learn about various data formats. This particular one probably has a channel with missing size data
[19:04:53 CEST] <drozdziak1> s/channels challenge
[19:41:09 CEST] <SouLShocK> is there an option to make ffmpeg continue reading from the input file, until the input file is closed? i.e. input file is still being written to while ffmpeg reads from it. I already considered -re but that would slow down encoding of all the frames that have already been written to the file
[19:43:32 CEST] <c_14> by writing/reading from stdin or a pipe
[19:44:16 CEST] <SouLShocK> but not from a file on disk?
[19:44:40 CEST] <c_14> nothing that ffmpeg considers seekable really
[19:45:05 CEST] <SouLShocK> hm ok
[19:45:09 CEST] <DHE> there is a "-follow 1" option but I don't think the ffmpeg CLI will handle it gracefully. I think it's more for API usage
[19:46:26 CEST] <BtbN> tail -f ... | ffmpeg -i - ...
[19:46:34 CEST] <BtbN> I'd guess that works?
[19:46:50 CEST] <DHE> maybe, but can you force it to start from the beginning of the file?
[19:47:01 CEST] <BtbN> yeah
[19:47:20 CEST] <DHE> looks like -c +0
[19:48:13 CEST] <SouLShocK> interesting idea
[19:50:54 CEST] <SouLShocK> yeah tail -f -c +0 | ffmpeg -i - output.mp4 works
[19:50:57 CEST] <SouLShocK> thanks
[19:54:11 CEST] <BtbN> if you just want to remux, you will want -c copy
[19:55:35 CEST] <SouLShocK> nah I'd want to do MXF to MP4
[19:55:43 CEST] <SouLShocK> MPEG2 MXF files that is
[21:52:20 CEST] <kosha_> how to set overlay timestamp by mask?
[21:52:32 CEST] <kosha_> %h:%m
[21:55:05 CEST] <kosha_> like this text='%{localtime\:%T}' but without seconds
[21:59:45 CEST] <c_14> replace :T with %H:%M?
[21:59:51 CEST] <c_14> *%T
[22:01:26 CEST] <kosha_> text='%{localtime\:%H\\:%M}' ?
[22:01:47 CEST] <kosha_> ssory
[22:01:50 CEST] <kosha_> text='%{localtime\:%H:%M}' ?
[22:02:26 CEST] <kosha_> Unterminated %{} near '{localtime:%H'
[22:07:56 CEST] <DHE> missing the } at the end, or it's been absorbed by something
[22:09:41 CEST] <kosha_> if this text='%{localtime\:%H\:%M}'
[22:09:55 CEST] <kosha_> then %{localtime} requires at most 1 arguments
[22:10:59 CEST] <c_14> try putting it in quotes
[22:12:14 CEST] <kosha_> dont work
[22:18:14 CEST] <c_14> "drawtext=text='%{localtime\:%H\\\\\:%M}'" <- works for me
[22:18:23 CEST] <kosha_> Oo
[22:18:33 CEST] <kosha_> many slashes
[22:18:41 CEST] <c_14> If at first you don't succeed, you didn't escape enough
[22:19:25 CEST] <DHE> it's the shell's fault, really... :)
[22:21:33 CEST] <c_14> well, part of the blame is on shitty filtergraph syntax
[22:21:52 CEST] <c_14> if you %{ it should parse until the } in that escaping level
[22:23:15 CEST] <kosha_> work
[23:05:55 CEST] <arbol> Hi
[23:08:33 CEST] <arbol> the ffmpeg contrib tensorflow module keeps telling me that ffmpeg is not installed, although it is. Does anybody know how I could fix this?
[23:08:59 CEST] <c_14> probably not finding the include or library directory
[23:09:05 CEST] <c_14> is this when building or executing?
[23:27:42 CEST] <arbol> I think so too, yes
[23:28:47 CEST] <arbol> when executing. concretely, when I run the tensorflow.contrib.ffmpeg.decode_audio operator, it complains that ffmpeg is not installed
[23:29:13 CEST] <arbol> (in python)
[23:30:00 CEST] <c_14> if it happens during execution it's either looking for the ffmpeg binary and not finding it (check your PATH) or there's a dynamic library that's failing it's linking check your library paths and/or set LD_LIBRARY_PATH
[23:35:17 CEST] <arbol> I got it installed with homebrew on mac OS. THe binary is in my path and accessible through os.system so I gueass it should be accessible to tf too.  Do you know where is located the ffmpeg library I should add to my LD_LIBRARY_PATH?
[23:36:26 CEST] <c_14> eeeeh
[23:36:31 CEST] <c_14> /usr/lib /usr/local/lib maybe?
[23:36:47 CEST] <c_14> (I don't know where brew puts these things)
[23:37:16 CEST] <c_14> check where the binary is `which ffmpeg` , strip the /bin/ffmpeg and check in lib/
[23:38:57 CEST] <arbol> thanks, I think it is indeed /usr/local/lib and it is not in my LD_LIBRARY_PATH
[23:39:46 CEST] <c_14> LD_LIBRARY_PATH tends to be empty because that sort of thing is usually handled by setting the paths up in ld.conf
[23:43:58 CEST] <arbol> It didn't work but now you;ve said it, I remember seeing some waring fromn brew about including ffmpeg libraries
[23:44:26 CEST] <arbol> I'll look into it and maybe come back if I can't solve my problem
[23:44:50 CEST] <arbol> Thank you very much
[23:47:09 CEST] <arbol> \leave
[00:00:00 CEST] --- Sun Jun  4 2017

More information about the Ffmpeg-devel-irc mailing list