[Ffmpeg-devel-irc] ffmpeg.log.20170619

burek burek021 at gmail.com
Tue Jun 20 03:05:01 EEST 2017

[00:02:51 CEST] <fiem> I'm also on Windows. Unfortunately I can not get help here
[00:23:14 CEST] <Aprel> When ffprobe parses a 30-minute wtv file (Windows Recorded TV), it gives a strange number for the "duration" metadata: 23970931058. Any ideas what the time unit for this is?
[00:24:19 CEST] <Aprel> An hour-long file is 35957966678
[00:25:05 CEST] <Aprel> Sorry, the 30 minute should be 23972668992
[00:26:31 CEST] <Aprel> So it doesn't even scale linearly.... But is consistent and similar across files of the same duration. Can these values be converted to realtime?
[02:11:47 CEST] <kepstin> Aprel: is that just the file size (in bytes?)
[02:25:55 CEST] <Aprel> kepstin: file sizes are 3,633,577,984 and 5,446,565,888 bytes, so doesn't look like it
[02:28:25 CEST] <Aprel> The metadata has 2 duration fields, "Duration" and "WM/MediaOriginalRunTime". I almost always extend a recording by 2 minutes because US cable channels often run into the next hour by a few seconds. These fields seem to indicate the duration as specified by the tv guide data, and the actual length of the recording as I programmed it.
[02:32:39 CEST] <Aprel> For instance I have a 30-minute episode that recorded for 31min53secs according to vlc playback. ffprobe displays 19141140000 for duration and 19135700807 for "WM/MediaOriginalRunTime", so it in fact shows the discrepancy of the extention, but in unknown and baffling time units
[02:49:27 CEST] <Aprel> Here's the full ffprobe output: https://pastebin.com/T9EEVat9
[04:20:57 CEST] <hendry> hi there, I am keen to create a Custom Receiving Server for obs-studio using ffmpeg. However I noticed ffserver is deprecated? http://ffmpeg.org/index.html#ffserv
[04:21:23 CEST] <hendry> What should I be using to receive a stream and convert it into a basic m3u8 stream nowadays?
[06:55:35 CEST] <Aprel> To update on the WTV metadata thing: as for the original runtime attribute, in cases where the recording was interrupted (e.g. by loss of cable signal), it shows a discrepancy with the duration attribute, but otherwise isn't relevant. I still have no idea about the time unit for the duration integer, but have observed that recordings of similar length have similar values, and it scales linearly.
[07:04:59 CEST] <Aprel> Ahh, finally figured it out. The time unit is 10^(-7) seconds. So multiply the duration value by 10^(-7) and you get the duration of the recording in seconds.
[08:47:15 CEST] <peterburk> I'm using ffmpeg to make movie clips to study Chinese: https://pingtype.github.io/movie.html
[08:48:24 CEST] <peterburk> YouTube has a limit of 50 uploads per day, so I can't upload all 1119 clips on there. Right now I'm using Google Drive, but I wish I could use YouTube.
[08:49:09 CEST] <peterburk> Is there a chapter-based video format that I can use, so I can combine the clips for each level (0-6) into single videos, and have direct links to the word within the level?
[08:55:11 CEST] <peterburk> And second question: The slowest part is combining the word headings with the clips. The concat command doesn't work, so I have to use the filter_complex.
[08:55:48 CEST] <peterburk> This command is fast, but it gets stuck on the last frame of the first video, and doesn't show the second video (no video or audio). It works for making the clips, but not for combining the headings.
[08:56:00 CEST] <peterburk> ffmpeg -f concat -safe 0 -i <(printf "file '/WordHeadings/?.mp4'\nfile '/WordClips/?.mp4'\n") -c copy "test.mp4"
[08:56:09 CEST] <peterburk> This command works, but it's slow.
[08:56:11 CEST] <peterburk> ffmpeg -i "WordHeadings/?.mp4" -i "WordClips/?.mp4" -v debug -strict -2 -filter_complex "[0:v] [0:a:0] [1:v] [1:a:0] concat=n=2:v=1:a=1 [v] [a]" -map "[v]" -map "[a]" "Words/?.mp4"
[09:34:01 CEST] <thebombzen> peterburk: Matroska supports chapters, but I don't think YouTube understands Matroska chapters.
[09:34:23 CEST] <thebombzen> as for your concat command, why is there a leading /
[09:34:54 CEST] <thebombzen> the /WordHeadings/ directory almost certainly doesn't exist. Plus '?' is expanded by the shell
[09:35:23 CEST] <thebombzen> but it won't be expanded by the shell unless you have quotes. Most likely you want to do something like this:
[09:36:35 CEST] <peterburk> thebombzen: The full path is too long, so I cut it short to make it clearer for you.
[09:36:49 CEST] <thebombzen> most likely you want to do something like this: ffmpeg -f concat -i <(for fname in WordHeadings/?.mp4 WordClips/?.mp4; do printf "file '%s'\n" "$fname"; done)
[09:36:59 CEST] <peterburk> thebombzen: There isn't a ?, it's a Chinese character that your IRC client can't display.
[09:37:16 CEST] <thebombzen> No, it's definitely a ?. My client can display chinese characters.
[09:37:36 CEST] <thebombzen> Your client might convert it to a ? before sending though
[09:37:37 CEST] <peterburk> ??????
[09:38:11 CEST] <thebombzen> it does: “
[09:38:24 CEST] <thebombzen> your client is probably converting them to ?s before sending
[09:38:28 CEST] <thebombzen> because I can render chinese characters
[09:38:37 CEST] <peterburk> Ok, blame the X-Chat devs.
[09:39:09 CEST] <thebombzen> Probably. But either way, you say "it is slow"
[09:39:31 CEST] <thebombzen> er, I mean, you say the concat demuxer doesn't work
[09:39:42 CEST] <thebombzen> paste the complete command and output
[09:39:58 CEST] <thebombzen> because you clearly modified that command so there's no way I can try to debug what's wrong with it
[09:45:58 CEST] <peterburk> WordClipsWo.mp4 https://drive.google.com/open?id=0B60tEu1pyR9oajZrVFgxREs1Q3M
[09:46:11 CEST] <peterburk> WordHeadingsWo.mp4 https://drive.google.com/open?id=0B60tEu1pyR9oQmFKNFBLR2pzWVk
[09:46:26 CEST] <peterburk> WordsWoFailed.mp4 https://drive.google.com/open?id=0B60tEu1pyR9oM3BIak9MRmt4M00
[09:46:38 CEST] <peterburk> ffmpeg -f concat -safe 0 -i <(printf "file '/Users/peter/Desktop/WordHeadingsWo.mp4'\nfile '/Users/peter/Desktop/WordClipsWo.mp4'\n") -c copy "WordsWoFailed.mp4"
[09:46:58 CEST] <peterburk> Working, but slow (still running):
[09:46:58 CEST] <peterburk> ffmpeg -i "WordHeadingsWo.mp4" -i "WordClipsWo.mp4" -v debug -strict -2 -filter_complex "[0:v] [0:a:0] [1:v] [1:a:0] concat=n=2:v=1:a=1 [v] [a]" -map "[v]" -map "[a]" "WordsWo.mp4"
[09:51:16 CEST] <peterburk> WordsWo.mp4 https://drive.google.com/open?id=0B60tEu1pyR9obGlEc0RFYk9mcFE
[10:21:06 CEST] <thebombzen> peterburk: how did it fail?
[10:25:33 CEST] <peterburk> https://pastebin.com/nWJ0Wr6j
[10:25:52 CEST] <peterburk> thebombzen: Download and try to watch WordsWoFailed.mp4 from https://drive.google.com/open?id=0B60tEu1pyR9oM3BIak9MRmt4M00
[10:26:21 CEST] <peterburk> You still see that the first video clip (the heading) works fine, but the second (the movie clips) doesn't show at all. No audio, no video - nothing.
[10:27:42 CEST] <thebombzen> peterburk: third time saying this
[10:27:49 CEST] <thebombzen> " and the COMPLETE console output. "
[10:28:08 CEST] <thebombzen> you keep saying "it doesn't work" but there's absolutely no way to help you with that if you don't post the output
[10:28:51 CEST] <peterburk> thebombzen: Not working version: https://pastebin.com/wuYZcyrk
[10:29:29 CEST] <thebombzen> peterburk: you're using a version of FFmpeg from 2015
[10:29:33 CEST] <thebombzen> update and try again
[10:31:34 CEST] <peterburk> thebombzen: Have you even watched the WordsWoFailed.mp4 file?
[10:31:53 CEST] <thebombzen> no, and I'm not going to until you use a version that isn't two years out of date
[10:31:57 CEST] <thebombzen> update and try again
[10:32:15 CEST] <thebombzen> I'm not going to try to help you debug a two year old version of software that's in heavy active development
[10:32:49 CEST] <thebombzen> if it's still a problem when you're using the latest version *then* you should ask for help
[10:33:06 CEST] <peterburk> thebombzen: Send me a download link for your personal version of ffmpeg.
[10:33:22 CEST] <thebombzen> http://ffmpeg.org/
[10:33:36 CEST] <furq> https://evermeet.cx/ffmpeg/
[10:33:59 CEST] <thebombzen> furq: you're supposed to make him go onto the sidebar and click the "Downloads" panel
[10:34:06 CEST] <peterburk> I downloaded https://evermeet.cx/ffmpeg/ffmpeg-86499-g1edbf5e.7z
[10:34:23 CEST] <furq> thebombzen: https://vangogh.teespring.com/shirt_pic/13434219/10963543/6/619/480x9999/front.jpg?v=2017-03-08-22-03
[10:34:25 CEST] <peterburk> The Unarchiver says "Could not extract the file "ffmpeg": Unknown data format
[10:34:53 CEST] <thebombzen> that's because it's a 7z archive, which unarchiver doesn't natively support
[10:35:20 CEST] <thebombzen> I believe you can install p7zip with homebrew, but I don't use OS X so I can't help you extract a 7z archive on macOS
[10:35:35 CEST] <peterburk> update your file compression program and try again.
[10:35:47 CEST] <peterburk> Then send me a download link that works.
[10:35:51 CEST] <thebombzen> It does work
[10:36:00 CEST] <peterburk> It doesn't run.
[10:36:09 CEST] <peterburk> It's zero KB in size.
[10:36:26 CEST] <thebombzen> The download link you posted works
[10:36:31 CEST] <peterburk> The 7z archive is 9.9MB, but the binary when extracted is blank.
[10:36:43 CEST] <thebombzen> That's because unarchiver doesn't support 7z archives
[10:36:52 CEST] <thebombzen> you said that yourself
[10:37:07 CEST] <peterburk> Yeah. Upload ffmpeg in a binary format that I can use, and then I'll update to your personal version.
[10:37:27 CEST] <peterburk> Two years ago I wasted an afternoon figuring out how to compile it from source and fixing all the errors.
[10:37:46 CEST] <thebombzen> peterburk: I'm just some guy on the internet who is providing you tech service for free out of my own time
[10:37:47 CEST] <peterburk> You won't even run my commands, even though I sent them several times, and uploaded my example files to Google Drive.
[10:37:54 CEST] <thebombzen> I don't have to do this
[10:38:13 CEST] <thebombzen> I would really appreciate it if you don't demand that I upload a binary that you can use
[10:38:36 CEST] <thebombzen> because I've already stated that I don't use macOS. Do you want me to send you a Linux binary? I don't think you do
[10:38:53 CEST] <thebombzen> I've also already explained that the file you downloaded is a 7z archive, and I even suggested you install p7zip on homebrew
[10:38:56 CEST] <peterburk> Sure, send me the Linux binary, and I'll run it in my VM.
[10:39:13 CEST] <thebombzen> sure, how about all the shared libraries it links to?
[10:39:22 CEST] <peterburk> Exactly.
[10:39:35 CEST] <peterburk> You have to package those and send it all to me.
[10:39:51 CEST] <peterburk> And send me the entire dump of what's on your terminal window. Maybe some screenshots too.
[10:40:19 CEST] <thebombzen> peterburk: It's hard to tell when your seriousness stops and when your trolling starts
[10:40:26 CEST] <peterburk> Just so I can be absolutely sure that I'm using the exact same system as you, before I even try to reproduce your problem at my end.
[10:40:56 CEST] <thebombzen> I don't even know if you want help anymore
[10:41:01 CEST] <thebombzen> because trolling isn't how you get it
[10:41:30 CEST] <peterburk> peters-macbook-pro:Desktop peter$ sudo brew upgrade ffmpeg
[10:41:30 CEST] <peterburk> Error: ffmpeg 2.6.2 already installed
[10:41:44 CEST] <thebombzen> then it appears the version on homebrew is out of date
[10:41:49 CEST] <thebombzen> two years out of date
[10:41:49 CEST] <peterburk> If homebrew can't update to a newer version, you need to tell me exactly which version you want.
[10:42:01 CEST] <thebombzen> I believe both furq and I already provided links
[10:42:44 CEST] <thebombzen> in fact, the link furq provided even has a convenient "download as DMG" option
[10:42:59 CEST] <thebombzen> so why don't you try that
[10:43:21 CEST] <peterburk> When I finish shaving the yak, updating homebrew, installing a new 7z extraction program, and reinstalling ffmpeg, and confirm that I have the same problem, will you listen to me then?
[10:46:16 CEST] <peterburk> I upgraded homebrew, and it still thinks ffmpeg 2.6.2 is the latest version.
[10:46:29 CEST] <thebombzen> peterburk: *in fact, the link furq provided even has a convenient "download as DMG" option*
[10:46:49 CEST] <thebombzen> you seem to have a bad case of not listenening
[10:47:42 CEST] <thebombzen> in fact, it's a bit silly to try to argue that 2.6.2 is not out of date. literally the first thing it prints is the copyright date, which is 2015.
[10:48:15 CEST] <peterburk> you seem to have a bad case of blaming others. It's my IRC client's fault that Chinese characters aren't displayed. It's my fault that homebrew haven't got the latest version of ffmpeg. It's my fault that I'm using a Mac, and I should be using Linux (but which version, you won't tell me).
[10:48:39 CEST] <thebombzen> I didn't say any of those things.
[10:49:07 CEST] <thebombzen> Well, I did say that it isn't my fault the Chinese characters wouldn't render, but that's because my client does render chinese characters
[10:49:42 CEST] <thebombzen> but I didn't say it was your fault homebrew didn't have the latest version. I just merely stated that it appears it didn't have the latest version.
[10:49:56 CEST] <thebombzen> I didn't say it was your fault for using macOS, I merely said I don't use it and thus I'm unfamiliar with it
[10:50:20 CEST] <thebombzen> I didn't recommend you use Linux, and I'm not sure why you thought I did
[10:51:49 CEST] <thebombzen> You're tilting because you think I'm giving you unhelpful and accusatory answers. I am not, I'm just recommending you actually read the advice I provide
[10:52:19 CEST] <peterburk> With the latest version: https://pastebin.com/T3BsrMHi
[10:52:39 CEST] <thebombzen> that looks like it worked
[10:52:57 CEST] <peterburk> Yeah, did you watch the output?
[10:53:18 CEST] <thebombzen> No, because you didn't post it
[10:53:21 CEST] <peterburk> You can download it here: https://drive.google.com/open?id=0B60tEu1pyR9oZHpVdUFXeGJseVk
[10:53:29 CEST] <thebombzen> Also, your input video is 68 kbps
[10:53:31 CEST] <thebombzen> that looks wrong
[10:53:53 CEST] <peterburk> You mean like Apple said about the iPhone 4, "You're holding it wrong".
[10:54:00 CEST] <peterburk> The input is correct.
[10:54:08 CEST] <furq> that seems about right for a static image
[10:55:01 CEST] <thebombzen> peterburk: what's wrong with the output video?
[10:56:10 CEST] <thebombzen> It looks like a static image of  and then a 15 minute video of whatever
[10:56:13 CEST] <peterburk> The word heading looks fine (WordHeadingsWo.mp4, first 4 seconds). The movie clips (WordClipsWo.mp4, everything else) come out with no audio, and the video is all broken.
[10:56:30 CEST] <thebombzen> no it doesn't? The video file plays correctly
[10:56:57 CEST] <peterburk> This is what it should look like: https://drive.google.com/open?id=0B60tEu1pyR9obGlEc0RFYk9mcFE
[10:57:13 CEST] <peterburk> This is what it does look like: https://drive.google.com/open?id=0B60tEu1pyR9oZHpVdUFXeGJseVk
[10:58:58 CEST] <peterburk> The file is not corrupt, but the video has random squares all over it, and the audio is silent.
[11:02:12 CEST] <peterburk> Here's a screenshot showing the broken video: https://drive.google.com/open?id=0B60tEu1pyR9oMjFWUmN2QmlTVDQ
[11:06:48 CEST] <thebombzen> peterburk: that sounds like it's an issue with your player. I downloaded the video you produced and it works correctly
[11:07:27 CEST] <peterburk> Which player are you using?
[11:07:56 CEST] <thebombzen> mpv
[11:08:48 CEST] <thebombzen> here's a screenshot I took with my player
[11:08:48 CEST] <thebombzen> https://0x0.st/lOT.png
[11:09:02 CEST] <thebombzen> I don't see any corruption artifacts
[11:09:18 CEST] <peterburk> Indeed, mpv plays it just fine.
[11:10:02 CEST] <thebombzen> there you go
[11:10:03 CEST] <peterburk> All you have to do is persuade the rest of the world to use mpv, and that will be fine. My users will be using the built-in QuickTime Player (or maybe VLC).
[11:10:17 CEST] <peterburk> Or I can just use the slow command and then the whole world can watch it.
[11:10:23 CEST] <thebombzen> well, try remuxing it
[11:10:34 CEST] <thebombzen> ffmpeg -i bad.mp4 -c copy good.mov or something
[11:10:50 CEST] <peterburk> You mean, convert mp4 to mov?
[11:11:42 CEST] <thebombzen> I mean remux
[11:11:56 CEST] <peterburk> What command are you using?
[11:12:10 CEST] <peterburk> Please paste the exact command from your terminal window into Pastebin.
[11:12:15 CEST] <thebombzen> I literally just typed it
[11:12:25 CEST] <peterburk> I did that for you, why won't you do it for me?
[11:12:33 CEST] <thebombzen> I literally just typed it
[11:12:39 CEST] <thebombzen> ffmpeg -i bad.mp4 -c copy good.mov
[11:13:01 CEST] <peterburk> No, there is no file called bad.mp4
[11:13:09 CEST] <thebombzen> use your brain
[11:13:26 CEST] <peterburk> I didn't tell you to use your brain when you forced me to waste the last 2 hours updating everything.
[11:13:34 CEST] <peterburk> Send me the Pastebin link.
[11:13:45 CEST] <thebombzen> Wow, you're an asshole
[11:13:58 CEST] <peterburk> I'm expecting the same from you as what you demanded from me.
[11:14:46 CEST] <thebombzen> I'm going to repeat what I said before. I'm just some guy on the internet providing tech support to you, for free, on my own personal time.
[11:14:47 CEST] <peterburk> I don't want to use .mov format.
[11:14:48 CEST] <thebombzen> I don't have to do this.
[11:15:05 CEST] <thebombzen> and I'm not going to do this anymore
[11:15:05 CEST] <peterburk> Ok, then I'll ask someone else tomorrow. But you just wasted 2 hours of my time.
[11:15:15 CEST] <thebombzen> I really didn't
[11:15:22 CEST] <peterburk> And I'll add your name to the wall of shame in my documentation.
[11:15:53 CEST] <thebombzen> why don't you get a good night's sleep and look over the logs of this
[11:16:19 CEST] <peterburk> Why don't you stop being a generic "system manager" saying "it works alright for me"
[11:16:56 CEST] <thebombzen> Because "it works for me" means the file is not corrupt file, but rather something on your system is having trouble playing it back
[11:17:02 CEST] <thebombzen> that actually means something
[11:17:08 CEST] <peterburk> Not everybody who uses ffmpeg is an expert in the field of video and audio encodings.
[11:17:22 CEST] <peterburk> I want to concat two video files, and it's giving me problems.
[11:17:46 CEST] <thebombzen> Ah, but you see, I happen to have been using this software for about six years, and you have recognized your own lack of expertise.
[11:17:56 CEST] <thebombzen> But you also are demanding that I provide you the same information you provide me
[11:18:16 CEST] <thebombzen> unfortunately, this isn't quite symmetric, because I'm trying to debug your problem. My exact command is not relevent to you, but your exact command is relevant to me.
[11:18:37 CEST] <peterburk> You say "use Linux and mpv and you'll be 1337 and have no problems", but to me, that's just plain arrogant.
[11:18:49 CEST] <thebombzen> I didn't tell you to use Linux once
[11:19:02 CEST] <peterburk> You said it doesn't work because you're using Linux and I'm using Mac OS.
[11:19:03 CEST] <thebombzen> I also said that I use mpv. I did not actually ever tell you to use it
[11:19:17 CEST] <thebombzen> I also did not say that it doesn't work because you're on macOS.
[11:19:21 CEST] <peterburk> But you blamed my player, and said it only works in mpv.
[11:19:42 CEST] <peterburk> I have a working command, with 5 hours runtime.
[11:19:45 CEST] <thebombzen> Well, if a valid file does not play in your player, then it means your player is imperfect.
[11:19:55 CEST] <peterburk> Yeah, go and take that to Apple.
[11:20:02 CEST] <thebombzen> I also I even suggested a fix, which was to remux it
[11:20:10 CEST] <peterburk> I don't know what remux means.
[11:20:16 CEST] <peterburk> Does it mean to convert .mp4 to .mov?
[11:20:29 CEST] <thebombzen> not really
[11:20:39 CEST] <thebombzen> I did provide a command for you to use though
[11:20:50 CEST] <peterburk> Yeah, but I don't have the files, and you told me to use my brain.
[11:20:52 CEST] <thebombzen> which instead of trying, you just yelled that I didn't name the files exactly as they appeared on your system.
[11:21:04 CEST] <peterburk> Where is bad.mp4, and what do I do with good.mov?
[11:21:08 CEST] <peterburk> I want my output to be in mp4 format.
[11:21:10 CEST] <thebombzen> bad.mp4 is the file that doesn't work
[11:21:19 CEST] <thebombzen> I figured that would be pretty obvious
[11:21:31 CEST] <peterburk> Yeah. Let's call it thebombzen.mp4
[11:21:45 CEST] <thebombzen> You do you, man
[11:22:44 CEST] <peterburk> ffmpeg -i thebombzen.mp4 -c copy good.mov
[11:23:23 CEST] <peterburk> Same playback problem using QuickTime Player.
[11:23:36 CEST] <thebombzen> Well, then it sounds like QuickTime player is flawed.
[11:23:47 CEST] <peterburk> But the slow command works.
[11:23:58 CEST] <thebombzen> The slow command re-encodes the video
[11:24:00 CEST] <thebombzen> this one doesn't
[11:24:08 CEST] <peterburk> Well, it sounds like I need to re-encode the video.
[11:24:10 CEST] <thebombzen> You could also try another container like matroska
[11:24:21 CEST] <peterburk> No, my users require that my output must be mp4
[11:24:32 CEST] <thebombzen> who are your users, and why do they know that?
[11:24:41 CEST] <peterburk> You said at the beginning that YouTube doesn't support matroska.
[11:24:45 CEST] <thebombzen> I didn't say that
[11:24:57 CEST] <peterburk> <thebombzen> peterburk: Matroska supports chapters, but I don't think YouTube understands Matroska chapters.
[11:25:06 CEST] <thebombzen> Correct. YouTube supports Matroska
[11:25:10 CEST] <thebombzen> it just doesn't understand matroska chapters
[11:25:25 CEST] <thebombzen> You can upload matroska files to YouTube
[11:25:54 CEST] <peterburk> Ok, send me the command you want me to do to make a matroska file, and I'll upload it to YouTube for you.
[11:26:13 CEST] <thebombzen> the same as above, but call it good.mkv instead of good.mov
[11:27:01 CEST] <thebombzen> also, why do your users need mp4? YouTube supports mov files as well
[11:27:13 CEST] <thebombzen> in fact YouTube supports anything that ffmpeg should be able to read, sans licensing issues
[11:37:21 CEST] <peterburk> There you go: https://www.youtube.com/watch?v=THo-IZfX458
[11:39:01 CEST] <peterburk> But I'd still rather have a slow command that generates output files that are reliable, instead of a fast command that generates output files that look messed up on many platforms.
[11:43:00 CEST] <thebombzen> Well, it doesn't matter if you're distributing them through YouTube, right?
[11:43:14 CEST] <thebombzen> If YouTube is able to read them correctly, then it will handle that for you
[11:43:35 CEST] <thebombzen> Also, the YouTube link you provided is a deadlink
[11:45:51 CEST] <peterburk> The link works on my machine: https://drive.google.com/open?id=0B60tEu1pyR9oanhTZVdyTjUyeGc
[11:46:35 CEST] <thebombzen> Did you set the video to private? If so, I can't view it.
[11:46:42 CEST] <peterburk> YouTube is one possible file host, but only if I can fix the chapter issue you didn't answer above.
[11:47:00 CEST] <peterburk> Otherwise I'll keep using Google Drive to host it, which has the problem.
[11:47:18 CEST] <thebombzen> YouTube is not a file host, it's a streaming service. It doesn't support chapter markers either
[11:47:49 CEST] <peterburk> No it doesn't. But YouTube does support time offests e.g. "&t=231s"
[11:48:16 CEST] <peterburk> And it would have been faster for me to write my own script to handle those than arguing with you all afternoon.
[11:48:37 CEST] <thebombzen> Your impression is that this is an argument
[11:49:12 CEST] <thebombzen> What's really happening is I'm spending my time providing you free tech support, even though you're constantly being beligerent
[11:50:16 CEST] <peterburk> Belligerent? I met all your demands, to update my homebrew and ffmpeg versions, to share all my terminal output to PasteBin, and even to upload my input and output files.
[11:50:27 CEST] <peterburk> You wouldn't even write the correct command for me.
[11:50:34 CEST] <thebombzen> I didn't ask you to update homebrew
[11:50:47 CEST] <thebombzen> I also didn't ask you to upload your input and output files
[11:51:38 CEST] <thebombzen> I asked you to put the complete output on a paste service three times before you decided that maybe that was a good idea
[11:51:48 CEST] <peterburk> I'm sick of your trolling. I'll ask my same questions again later, when there's someone who will "use their brain" on the other end.
[11:52:15 CEST] <thebombzen> I am not trolling you. I am actually kind of surprised you think that
[11:52:57 CEST] <thebombzen> You're getting extremely tilted about this for some reason and are reading into everything I'm saying as a personal attack
[11:53:25 CEST] <thebombzen> oh, he left.
[11:53:27 CEST] <thebombzen> Okay
[11:58:37 CEST] <thebombzen> Guest69427: I think the easiest way to do that is to download the file to a temporary file on the hard drive, and then process it. That way you have the advantage of seekability and that sort of thing
[12:10:57 CEST] <fiera> help me, please, build ffplay. I have VC 2015. to configure solution and compile project?
[12:22:13 CEST] <thebombzen> fiera: do you want to build ffplay yourself or do you just want ffplay.exe?
[12:22:22 CEST] <thebombzen> because if you just want ffplay.exe, there's prebuilt binaries
[12:23:01 CEST] <thebombzen> if you want to build it yourself, it might be easier to use MinGW or something similar
[12:26:57 CEST] <fiera> ok, Aan you step by step tell me how to do it?
[12:28:26 CEST] <thebombzen> fiera: are you sure you want to build it yourself?
[12:28:34 CEST] <thebombzen> or do you just want to have ffplay.exe?
[12:29:58 CEST] <thebombzen> I can't actually tell you how to built FFmpeg on windows, because I don't know. I do know that you can download it prebuilt at https://ffmpeg.zeranoe.com/builds/
[12:29:58 CEST] <fiera> yes, i need build it itself
[12:30:11 CEST] <thebombzen> Consider this page, this might be helpful: https://www.ffmpeg.org/platform.html#Microsoft-Visual-C_002b_002b-or-Intel-C_002b_002b-Compiler-for-Windows
[12:33:46 CEST] <fiera> I do not need to download. I need to build this on Windows. I can build ffmpeg, but I do not know how to compile ffpay
[12:35:09 CEST] <durandal_1707> same as ffmpeg
[12:36:35 CEST] <fiera> You tried?
[12:37:30 CEST] <thebombzen> fiera: durandal is one of the developers
[12:37:39 CEST] <thebombzen> I would trust their judgement on this ^_^
[12:38:08 CEST] <thebombzen> but yes, ffmpeg.exe, ffprobe.exe, and ffplay.exe are all built at the same time
[12:38:46 CEST] <JEEB> sdl linking hasn't broken so far so all you need to do is make ffmpeg's configure find an sdl it can link against (preferably with pkg-config)
[12:43:25 CEST] <fiera> thebombzen,You are wrong, I did exactly as told here https://trac.ffmpeg.org/wiki/CompilationGuide/MSVC. But I received only ffmpeg and ffprobe
[12:44:23 CEST] <thebombzen> see JEEB's comment
[12:44:25 CEST] <thebombzen> ffplay needs SDL
[12:48:57 CEST] <fiera> i have sdl source, and sdl *.lib. Tell me, which parameter to specify the path to sdl, to compile ffplay. .\Configure --help  prints the "disable sdl2 autodetect", how specify it manually?
[12:52:38 CEST] <Kadigan_KSB> Hey. I'm having a bit of an understanding issue -- "Cannot connect video filter to audio output". Call + output is at https://paste.debian.net/plainh/1d4efed5 (should show as plaintext)
[12:53:22 CEST] <Kadigan_KSB> (manually inserted newlines to correct for readability, command not normally this vertical)
[12:54:40 CEST] <Kadigan_KSB> Also, is my understanding correct, if I'm aiming to combine video (of length X) with audio (of length Y > X) where audio will fade out as video ends w/ no additional audio w/o video?
[13:02:17 CEST] <fiera> JEEB: what means "pkg-config" on Windows?
[13:03:11 CEST] <JEEB> same thing?
[13:03:44 CEST] <JEEB> you get a binary, you get one with msys2 f.ex.
[13:03:54 CEST] <JEEB> but I'm not going to babysit you with build systems 101
[13:04:37 CEST] <JEEB> the installation of msys2 here is a sane thing, though: https://trac.ffmpeg.org/wiki/CompilationGuide/WinRT
[13:05:02 CEST] <JEEB> of course you don't have to follow the stuff after YASM setup and you can move to the windows compilation guide
[13:05:18 CEST] <thebombzen> Kadigan_KSB: being exactly as you wrote it is more important than modifying it to make it more readable
[13:05:24 CEST] <JEEB> https://trac.ffmpeg.org/wiki/CompilationGuide/MinGW
[13:07:11 CEST] <Kadigan_KSB> thebombzen: I only changed spaces to newlines, but sure -- https://pastebin.com/raw/FWTREvu8
[13:07:25 CEST] <thebombzen> Complete Console Output
[13:07:33 CEST] <thebombzen> I sound like a broken record here omg
[13:07:43 CEST] <Kadigan_KSB> Okay. What's incomplete about the output I pasted?
[13:07:52 CEST] <thebombzen> -hide_banner
[13:07:53 CEST] <thebombzen> don't do that
[13:08:28 CEST] <thebombzen> the banner is helpful
[13:08:38 CEST] <thebombzen> in particular because it has the version # in it
[13:11:05 CEST] <Kadigan_KSB> https://pastebin.com/raw/ajFKMjRS -- is this better/complete now?
[13:12:39 CEST] <thebombzen> Kadigan_KSB: yea
[13:12:48 CEST] <thebombzen> I think your error is caused because fade is a video filter
[13:13:03 CEST] <thebombzen> you probably want afade, not fade
[13:13:27 CEST] <Kadigan_KSB> Ah, I see.
[13:14:09 CEST] <Kadigan_KSB> Well, it doesn't error out any more...
[13:19:44 CEST] <fiera> JEEB: You do not understand me or do not want to understand. I successfully build ffmpeg and ffpobe. I need to build the fplay. This requires sdl and I have it. I ran vcvarsall.bat, added in the include the path to the sdl, but the ffplay does not compile. I'm a Windows user, I do not understand anything in msys. Help me configure that the output i
[13:19:44 CEST] <fiera> s not only ffmpeg, but also ffplay, please
[13:21:00 CEST] <durandal_1707> fiera: there are explanations on wiki
[13:21:34 CEST] <durandal_1707> besides you better use other player than ffplay
[13:25:42 CEST] <thebombzen> fiera: if you want a CLI video player, I'd recommend mpv rather than ffplay
[13:25:48 CEST] <thebombzen> ffplay is very primitive
[13:26:57 CEST] <fiera> thebombzen: for my task ffplay better than mpv, i need only ffplay
[13:27:14 CEST] <thebombzen> try reading the wiki articles linked then
[13:28:10 CEST] <fiera> thebombzen: see last my comment
[13:46:49 CEST] <Kadigan_KSB> Okay. It seems that it seeks around with the sound as well. Can I set seek for video but not for audio?
[13:50:17 CEST] <Kadigan_KSB> Okay. Let's try this: I have a situation where I first do a fast seek, then a slow seek. By adding the sound file, it -seems- that it slow-seeks in the sound file now. What can I do?
[13:53:45 CEST] <Kadigan_KSB> Ah, wait... wait, I'm confused. I used it as an output option because it was more accurate, so it makes sense it treats it as audio input... IIRC seek was improved, right?
[14:03:17 CEST] <Kadigan_KSB> Yes. It started working as I'd expect as soon as I removed my fix for the (previously inaccurate)] input seek.
[14:03:32 CEST] <thebombzen> Kadigan_KSB: "-ss" is an input option so if you put it before one input and not another, it'll only seek one of the inputs
[14:03:48 CEST] <thebombzen> or rather, that is, if you're using it as an input option
[14:04:00 CEST] <Kadigan_KSB> I completely forgot the entire meaning of using -ss -i -ss
[14:04:29 CEST] <Kadigan_KSB> and now that I remembered (and remembered a remark that this was actually fixed to be frame-accurate now), it works.
[14:04:54 CEST] <Kadigan_KSB> IIRC input seek was only keyframe-accurate or iframe-accurate or something before...
[14:05:25 CEST] <Kadigan_KSB> (so I used a script to input-seek to keyframe + output-seek to specific frame)
[14:07:21 CEST] <thebombzen> yea, it's as accurate as it can be. It fastseeks to the last I-frame before the timestamp, and decodes from there
[14:07:37 CEST] <thebombzen> you can use -no_accurate_seek to disable this so it only seeks to I-frames
[14:07:48 CEST] <thebombzen> this is enabled by default with -c copy
[14:13:44 CEST] <Kadigan_KSB> I see. That's good to know.
[14:13:57 CEST] <Kadigan_KSB> It's sort of obvious when you think about it.
[14:14:26 CEST] <Kadigan_KSB> (since it can't copy between I-frames w/o actually recompressing, I mean)
[15:29:36 CEST] <TyrfingMjolnir> How can I change the container of a file?
[15:29:45 CEST] <TyrfingMjolnir> mkv to m4v as an example
[15:30:04 CEST] <TyrfingMjolnir> I would like for the streams to me untouched
[15:32:16 CEST] <nido> assuming one video/audio/sub stream, i think: ffmpeg -i file.mkv -acodec copy -vcodec copy -scodec copy file.mp4
[15:35:53 CEST] <Mavrik> can be shortened to ffmpeg -i file.mkv -codec copy file.mp4
[15:35:59 CEST] <Mavrik> That'll also properly copy all streams :)
[15:39:56 CEST] <nido> i'll try to remember that; that sounds handy
[15:43:50 CEST] <Kadigan_KSB> I was under the impression that acodec/vcodec were beind deprecated in favor of -c:a and -c:v ?
[15:44:43 CEST] <Mavrik> -c:a is short for -codec:a :)
[15:44:44 CEST] <Mavrik> And yes.
[16:12:40 CEST] <fiera> Is there a normal way to build ffplay?
[16:13:05 CEST] <fiera> i get an error i686-w64-mingw32-gcc is unable to create an executable file.
[16:13:07 CEST] <fiera> wtf
[16:14:55 CEST] <fiera> I do not have enough patience. Can anyone explain how to compile it?
[16:40:51 CEST] <TyrfingMjolnir> fiera: use linux?
[16:41:09 CEST] <TyrfingMjolnir> or ?
[16:41:21 CEST] <fiera> TyrfingMjolnir: windows
[16:41:28 CEST] <TyrfingMjolnir> use the same platform that you would like to compile for
[16:41:44 CEST] <TyrfingMjolnir> Why is gcc unable?
[16:42:11 CEST] <TyrfingMjolnir> Always paste the full error if you'd like anyone to be able to give you an answer.
[16:48:49 CEST] <hendry> since ffserver is not more, what do people use to receive a rtmp stream in order to process it for HLS?
[16:53:09 CEST] <iive> is it?
[17:03:20 CEST] <DHE> nginx-rtmp might be able to help you. ffmpeg can connect to an rtmp server and pull content to convert to HLS itself. I'm using the ffmpeg method for an RTSP-based webcam
[17:04:43 CEST] <fiera> i need ffplay itself. I did exactly as told here https://trac.ffmpeg.org/wiki/CompilationGuide/But I received only ffmpeg and ffprobe.  after tried it https://trac.ffmpeg.org/wiki/CompilationGuide/MinGW/ and also do not build ffplay
[17:06:22 CEST] <DHE> you need libSDL (version 2) available for ffplay to work
[17:07:11 CEST] <fiera> i have sdl
[17:08:56 CEST] <fiera> in msys2 typed pacman -S mingw-w64-i686-SDL. what else is it?
[17:17:06 CEST] <iive> fiera: there is sdl1 and sdl2 and they are not api compatible
[17:17:17 CEST] <iive> you can have both installed at the same time
[17:17:27 CEST] <iive> ffplay works only with sdl2
[17:18:42 CEST] <fiera> here is verison 1.2 https://trac.ffmpeg.org/wiki/CompilationGuide/MinGW
[17:23:34 CEST] <iive> i'm quite sure that recent ffmpeg version support only sdl2
[17:25:07 CEST] <iive> check what `configure --help` says about --enable-sdl2
[17:25:52 CEST] <iive> or rather --disable-sdl2
[17:26:29 CEST] <fiera> iive
[17:26:29 CEST] Last message repeated 1 time(s).
[17:26:29 CEST] <fiera> iive: very tnx, I intuitively executed the command "pacman -S mingw-w64-i686-SDL2". then .\configured and  saw in the log "ffplay". COOL.
[17:26:52 CEST] <iive> :)
[17:28:02 CEST] <fiera> 2 days asked to tell this command
[17:31:55 CEST] <fiera> type "make" and get and error "AR      libavdevice/libavdevice.a
[17:33:00 CEST] <fiera> bin/sh: i686-w64-mingw32-ar: command not found
[20:57:36 CEST] <pacha> any help with this? [ffmpeg/demuxer] mov,mp4,m4a,3gp,3g2,mj2: Could not find codec parameters for stream 0 (Video: h264 (avc1 / 0x31637661), none, 1920x800, 2038 kb/s): unspecified pixel format
[21:02:19 CEST] <fiera> That you are all so greedy
[21:02:53 CEST] <pacha> fiera: are you responding me?
[21:04:02 CEST] <fiera> pacha: It's not you, you have a problem, but no one will help you
[21:04:45 CEST] <pacha> fiera: :(
[21:15:08 CEST] <Diego___> Hi there. I'm working in a project that requires output video recordings to be compiled into a single one in mosaic. I've been following this guide https://trac.ffmpeg.org/wiki/Create%20a%20mosaic%20out%20of%20several%20input%20videos and everything works fine. The problem now is that it takes too much time to compile and quality is kinda poor. If I specify the bitrate for each video, can I get a better quality and a faster compil
[21:15:51 CEST] <Diego___> Because it doesn't have to re-render frames when I change the video sizes, so it looks "logic" for myself.
[21:15:59 CEST] <Diego___> Setting the proper bitrate, I mean
[22:44:52 CEST] <kepstin> Diego___: hmm, that tutorial's kind of dated, you should probably use the hstack & vstack filters instead of overlay - that will speed it up somewhat
[22:45:36 CEST] <kepstin> other than that, it's just a matter of setting the output encoder speed settings correctly
[22:57:08 CEST] <fiera> how to remove dependencies libwinpthread-1.dll and othe, when build ffplayr?
[23:11:44 CEST] <Spring> This is curious. A user finds a different concatenation tool for MKV that outputs 44MB less than ffmpeg: https://hydrogenaud.io/index.php/topic,114217/topicseen.html
[23:12:00 CEST] <basisbit> by the way: time to updates and reboot all your linux or *bsd or mac os based systems. details see https://blog.qualys.com/securitylabs/2017/06/19/the-stack-clash
[23:12:18 CEST] <Spring> in that particular example, obviously
[23:15:58 CEST] <DHE> basisbit: interesting...
[23:18:13 CEST] <kepstin> Spring: huh. be interesting to see if they get the same effect by just remuxing one of the mkvs to a new mkv on its own using mkvmerge
[23:18:56 CEST] <kepstin> with mkvtoolnix*
[23:21:18 CEST] <kepstin> i'm guessing that something in the mkvmerge mpeg1/2 writer must be removing parsing and removing some (unnecessary?) extra data from the mpeg video stream that ffmpeg is just leaving in (copying as-is)..
[23:22:12 CEST] <kepstin> lets see, MakeMKV output, mpeg2 at 720x576, so this is probably a dvd rip.
[23:22:22 CEST] Action: kepstin will try poking around with that later.
[23:27:00 CEST] <fiera> help me, where get libavresample.lib. I not found it in the ffmpeg-3.3.1-win32-dev.zip ?
[23:27:37 CEST] <kepstin> the ffprobe bitrate being so close to 4500+192 makes me wonder whether the video is a padded cbr, and maybe mkvmerge is removing the padding?
[23:30:17 CEST] <kepstin> fiera: that the zeranoe ffmpeg build? It's build with libswresample enabled, rather than libavresample
[23:47:35 CEST] <fiera> kepstin: ffplay is compiled with libavresample
[23:49:41 CEST] <durandal_1707> lol   no its not
[23:57:43 CEST] <fiera> Very funny, like in a circus
[23:58:49 CEST] <fiera> cmdutils.c , #37  line "include libavresample/avresample.h"
[00:00:00 CEST] --- Tue Jun 20 2017

More information about the Ffmpeg-devel-irc mailing list