[Ffmpeg-devel-irc] ffmpeg.log.20170622

burek burek021 at gmail.com
Fri Jun 23 03:05:01 EEST 2017

[00:20:19 CEST] <ArsenArsen> Anyone knows why the ubuntu 16.04 FFMpeg doesnt have codecpar in AVStream and avcodec_parameters_from_contex
[05:17:30 CEST] <hendry> i need a testsrc but with the current date/time burnt in.. Want to test a streaming setup. Anyone have a clue how to achieve that?
[08:36:46 CEST] <MarkG> I am trying to write a script that checks mp3 files and reencodes them only if the sample rate is not 44.1k
[08:38:01 CEST] <MarkG> I have started playing with ffprobe (assuming this is the best way?), but got stuck with the syntax.  Using
[08:38:14 CEST] <MarkG> ffprobe -show_streams -select_streams a format=sample_rate -of default=noprint_wrappers=1:nokey=1 myfile.mp3
[08:50:39 CEST] <thebombzen> MarkG: try this: ffprobe -v error -select_streams a -show_entries stream=sample_rate
[08:51:26 CEST] <thebombzen> Or in your case, something like this: ffprobe -of default=noprint_wrappers=1:nokey=1 -select_streams a -show_entries stream=sample_rate
[08:53:34 CEST] <thebombzen> thanks?
[08:55:12 CEST] <thebombzen> MarkG: try this:  ffprobe -of default=noprint_wrappers=1:nokey=1 -select_streams a -show_entries stream=sample_rate
[08:55:51 CEST] <thebombzen> also you might want to use -v error, which hides the banners and the "Input #0" crap, and only prints errors to stderr
[08:56:09 CEST] <thebombzen> errors like "Is a directory" or "Invalid data found when processing input" or "No such file or directory" etc
[08:56:23 CEST] <thebombzen> does that work?
[08:57:29 CEST] <Markg1224> Thanks, that worked perfectly
[10:05:07 CEST] <Mathieu_> Hello everyone, I currently programming with opencv and I would like to make a live stream from my output. I can currently save this output to a jpg image always update so I thought to create a mjpeg stream with ffmpeg but I don't know how to do that, thank you for your help !
[10:05:30 CEST] <Mathieu_> updated*
[12:06:09 CEST] <verb5> hello everyone
[12:06:33 CEST] <verb5> i need help i am trying to capture live stream with /usr/local/bin/ffmpeg  -hwaccel cuvid -c:v mpeg2_cuvid -c:a mp2 -i "" -c:v h264_nvenc -preset llhq -c:a copy  "otest21.mp4"
[12:06:47 CEST] <verb5> but only the audio stream is recorded
[12:07:00 CEST] <verb5> any idea why ffmpeg maps only the audio stream ?
[12:07:14 CEST] <thebombzen> are you sure the input stream is mpeg2?
[12:07:36 CEST] <thebombzen> I'd recommend removing "-hwaccel cuvid -c:v mpeg2_cuvid -c:a mp2" and see what happens
[12:07:52 CEST] <thebombzen> and once you see what happens, do this:
[12:08:16 CEST] <verb5> ok sorry
[12:10:08 CEST] <verb5> what i am trying is load as less as possible the cpu that's why i am trying to use hwaccelerated decoder
[12:44:51 CEST] <styler2go> Hey everyone.. I guess this is the best channel where i can ask for help.. So, i have a camera which stores gps informations inside the video file. Can anyone think of a way to export it or to find out where in the video file it is being stores?
[12:45:39 CEST] <styler2go> Maybe just a hint where i could ask for help regarding this
[12:47:28 CEST] <styler2go> ffprobe output says this: https://p.styler2go.de/438538/ Where the subtitle stream looks pretty interesting
[12:50:02 CEST] <Nacht> Looks like Stream 0:2 is your GPS data
[12:50:19 CEST] <styler2go> Any idea how i could open it to look into it?
[12:50:37 CEST] <styler2go> Just selecting a subtitle in vlc palyer doesn't show anything
[12:52:51 CEST] <Nacht> Perhaps extracting them as subtitle.
[12:53:13 CEST] <Nacht> ffmpeg -i Movie.mkv -map 0:s:0 subs.srt
[12:53:17 CEST] <styler2go> can i just use ffmpeg like ffmpeg -i video.mp4 subtitlle.ass
[12:53:17 CEST] <Nacht> see what that gives
[12:53:24 CEST] <styler2go> ah nice, will try
[12:54:04 CEST] <styler2go> error while decoding stream
[12:54:59 CEST] <styler2go> https://p.styler2go.de/4627686/ looks like that
[12:56:24 CEST] <Nacht> Not really sure what else to do then
[12:57:15 CEST] <Nacht> Perhaps the others have a solution
[12:57:16 CEST] <styler2go> Any idea where i could ask in irc?
[12:58:24 CEST] <Nacht> This would be the correct place
[13:02:14 CEST] <furq> you should at least be able to extract it with mp4box
[13:02:32 CEST] <furq> mp4box -raw 3 src.mp4
[13:02:40 CEST] <furq> idk whether that'll give you a file you can do anything with
[13:02:49 CEST] <styler2go> gpac?
[13:02:51 CEST] <furq> yeah
[13:04:26 CEST] <styler2go> [isom] not enough bytes in box text: 8 left, reading 51 (file ..\..\src\isomedia\box_code_3gpp.c, line 339)
[13:04:52 CEST] <styler2go> Error opening file .\M0070116.MP4: Invalid IsoMedia File
[13:05:00 CEST] <furq> nice
[13:05:19 CEST] <furq> it might be -raw 2
[13:05:27 CEST] <furq> i forget whether mp4box starts numbering at 0 or 1
[13:05:38 CEST] <furq> doesn't sound like it'll work though
[13:06:02 CEST] <styler2go> it's the same for any number i try: https://p.styler2go.de/8553466/
[13:06:10 CEST] <furq> yeah i figured that'd be a generic error
[13:06:51 CEST] <furq> well i suspected that tomtom were just shoving binary data into a stream marked as mov_text, which would be awful
[13:07:00 CEST] <furq> but i guess it's just spitting out busted mp4s
[13:07:02 CEST] <styler2go> gopro and DJI does that to for their video files.. i migh tjust try to find some informaiton about them first maybe
[13:07:06 CEST] <furq> i can't decide if that's less awful
[13:07:26 CEST] <furq> you could maybe try remuxing it
[13:07:45 CEST] <bencoh> gpac might be "picky"
[13:07:47 CEST] <furq> with ffmpeg
[13:07:52 CEST] <furq> or l-smash
[13:08:14 CEST] <bencoh> (or "strict" depending on your view on this)
[13:08:24 CEST] <styler2go> https://github.com/stilldavid/gopro-utils maybe that can help somehow hmm
[13:08:37 CEST] <styler2go> it uses ffmpeg to export something too
[13:09:51 CEST] <furq> well that's just a data track
[13:10:07 CEST] <furq> yours shows up as a subtitle track, so i guess tomtom are doing some different kind of hell
[13:10:22 CEST] <styler2go> maybe they have the binary in a subtitle track
[13:10:27 CEST] <furq> maybe
[13:10:38 CEST] <styler2go> how could i export the subtitle as a binary?
[13:10:51 CEST] <furq> well that was what that mp4box command was supposed to do
[13:10:56 CEST] <styler2go> oh
[13:11:06 CEST] <styler2go> what about the command they show on the github readme
[13:11:08 CEST] <furq> i'm not sure if you can do that with ffmpeg if the stream is flagged incorrectly
[13:11:11 CEST] <styler2go> ffmpeg -y -i GOPR0001.MP4 -codec copy -map 0:m:handler_name:" GoPro MET" -f rawvideo GOPR0001.bin
[13:11:15 CEST] <styler2go> is this of any help?
[13:11:21 CEST] <furq> you could try that
[13:11:29 CEST] <furq> except it'd be -map 0:2
[13:11:31 CEST] <styler2go> Ok, just need to find the nadler name
[13:11:34 CEST] <styler2go> ah, nice
[13:12:00 CEST] <styler2go> it does export something
[13:12:00 CEST] <furq> genuinely curious if that works now
[13:12:24 CEST] <styler2go> got a 754mb file out of it o.O
[13:12:49 CEST] <furq> lol
[13:13:02 CEST] <furq> yeah i did notice ffprobe marked it as 6289kbps mov_text
[13:13:07 CEST] <furq> i guess it was true after all
[13:13:17 CEST] <styler2go> well it's a lot of informational text
[13:13:33 CEST] <styler2go> 18 minutes each second gps, temperature, gyro data etc.
[13:13:38 CEST] <styler2go> but 754mb i dunno
[13:13:53 CEST] <furq> yeah that's a fair old amount of text
[13:14:43 CEST] <furq> i've got 18 months of #ffmpeg logs here that are only 36MB
[13:14:53 CEST] <furq> and this channel is poppin'
[13:15:38 CEST] <styler2go> the gopro has 3-axis gyro at 400 Hz.. that's a lot at least
[13:16:02 CEST] <furq> oh right
[13:16:38 CEST] <furq> yeah that'll add up fast
[13:17:11 CEST] <styler2go> and a 3-axis accelerometer at 200 Hz and some more stuff.. maaaaybe it's that much.. wondering how i can chekc that now
[13:17:26 CEST] <styler2go> should i just be that guy and try the gopro converter on the tomtom?
[13:19:39 CEST] <bencoh> I'd go xxd and look for 0s and/or redundancy, but ... :)
[13:22:48 CEST] <furq> i'd be shocked if tomtom used a common format
[13:23:03 CEST] <furq> even if "common" means you need some rando on github's tool to extract it
[13:23:10 CEST] <styler2go> I think neither of those are "common"
[13:23:37 CEST] <furq> never underestimate the capacity of companies making consumer video equipment to invent their own fresh piece of shit
[13:23:41 CEST] <styler2go> Is there some official way to store something like those datas in a mp4 file? like, are there regulations/standards on such?
[13:23:57 CEST] <furq> well gopro just stores it as a data track
[13:24:10 CEST] <furq> and i've seen other cameras storing it as a timecode track
[13:24:21 CEST] <styler2go> and that's not too off?
[13:24:29 CEST] <furq> idk if i'd call either of them correct
[13:24:34 CEST] <furq> probably better than a subtitle track though
[13:24:46 CEST] <styler2go> yeah.. datat soudns about right at least
[13:24:47 CEST] <furq> a data track is supposed to just be opaque data so you can throw anything you want in there
[13:25:02 CEST] <furq> but obviously there's no generic way to read it
[13:25:25 CEST] <styler2go> seems like i have no way of obtaining that data
[13:30:16 CEST] <furq> probably just search for tomtom on github
[13:30:45 CEST] <furq> i found something that processes "ttbin" files off one of their gps watches
[13:30:51 CEST] <furq> https://github.com/ryanbinns/ttwatch
[13:31:14 CEST] <styler2go> wow nice
[13:31:14 CEST] <furq> if you're very lucky and you've been a very good boy all year then it'll be the same format
[13:31:28 CEST] <styler2go> i'll give it a shot
[13:31:40 CEST] <styler2go> is this someting i nee dto build?
[13:31:45 CEST] <furq> looks like it
[13:31:46 CEST] <styler2go> ok i see
[13:32:04 CEST] <styler2go> hmm
[13:32:17 CEST] <styler2go> wonder if it works on windows somehow
[13:35:55 CEST] <furq> oh hey
[13:35:58 CEST] <furq> https://developer.tomtom.com/camera-media-server/sensor-data-format
[13:36:04 CEST] <furq> this looks promising
[13:36:09 CEST] <styler2go> wow
[13:36:15 CEST] <styler2go> don't tell me they documented it
[13:37:37 CEST] <styler2go> i wouldn't have imaginated that hey even have a sdk
[13:38:18 CEST] <furq> i feel bad for calling them shits now
[13:38:22 CEST] <furq> sorry tom
[13:38:24 CEST] <furq> and sorry tom
[13:38:32 CEST] <styler2go> they still use it as subtitle stream
[13:42:12 CEST] <styler2go> https://github.com/Rupan/tomtom oh look
[13:42:27 CEST] <styler2go> oh well it's just firmware stuff :(
[13:50:45 CEST] <bencoh> looks like there's everything you need on this sdk page
[13:51:40 CEST] <styler2go> Yeah.. But my knowledge is not good enough to actually use it to be honest.. i do have the bin file i guess and i iknow how the data is in this bin file but i never worked with such a "low level" stuff..
[14:51:09 CEST] <ArsenArsen> How can I fix [swscaler @ 0x7f0d580a7060] Warning: data is not aligned! This can lead to a speedloss, I am using the libraries in my C++ code, and even though I get this printed the resulting file is perfectly fine
[14:51:40 CEST] <kerio> speed loss, not errors in the data
[14:54:29 CEST] <furq> ArsenArsen: https://github.com/FFmpeg/FFmpeg/blob/03ce71e4a1187340720e1569ac96c285c145a1f7/libswscale/swscale.c#L321-L332
[14:55:18 CEST] <ArsenArsen> o.O
[14:56:24 CEST] <ArsenArsen> so, it's probably my source buffer, which is comes from QImage's bits()
[14:58:03 CEST] <ArsenArsen> is coming*
[15:02:31 CEST] <kerio> is it fast enough for your purpose?
[15:02:48 CEST] <DHE> if you're using av_frame_get_buffer, are you specifying a large enough alignment value?
[15:03:02 CEST] <kerio> furq: hold on, why isn't warnedAlready checked as the first step?
[15:03:38 CEST] <furq> why are you asking me
[15:05:18 CEST] <ArsenArsen> DHE, I do it to allocate the buffer, and I use 32
[15:05:23 CEST] <furq> actually that makes sense
[15:05:33 CEST] <furq> HAVE_MMXEXT is guaranteed to short-circuit out more often than warnedAlready
[15:05:44 CEST] <furq> because warnedAlready is only set if HAVE_MMXEXT is true
[15:07:16 CEST] <ArsenArsen> av_frame_get_buffer(out->frame, 32); is what I use after allocating the frame
[16:45:55 CEST] <hiihiii> hello
[16:47:05 CEST] <hiihiii> I've been trying a command to get thumbnails at specific times but the images always come offset
[16:47:17 CEST] <hiihiii> for instance
[16:47:47 CEST] <hiihiii> ffmpeg -i input.mp4 -vf fps=1/30 img%03d.png
[16:48:55 CEST] <hiihiii> on a 60fps 02:30 long input video will result in 6 images
[16:49:29 CEST] <hiihiii> the first starting at 00:00:14.983
[16:50:09 CEST] <hiihiii> and the 2nd at 00:00:44.983 (1st + 30sec)
[16:51:34 CEST] <hiihiii> Question: I'd like to know if it's possible to get images at the exact times specified (or at least be very close)
[16:51:39 CEST] <hiihiii> i.e.
[16:51:40 CEST] <furq> !filter select @hiihiii
[16:51:40 CEST] <nfobot> hiihiii: http://ffmpeg.org/ffmpeg-filters.html#select_002c-aselect
[16:52:09 CEST] <furq> the fifth example
[16:53:50 CEST] <hiihiii> 00:00:30, 00:01:00, 00:01:30 ...etc
[16:54:17 CEST] <hiihiii> I tried ffmpeg -i input.mp4 -vf "setpts=PTS-STARTPTS,fps=1/30" img%%03d.png
[16:54:22 CEST] <hiihiii> but didt' work
[16:54:28 CEST] <hiihiii> so with select
[16:56:02 CEST] <hiihiii> ffmpeg -i input.mp4 -vf select='not(mod(n\,3600))' img%%03d.png
[16:57:47 CEST] <furq> 900 if it's 30fps
[16:58:23 CEST] <hiihiii> ? I got over 6000 files
[16:58:35 CEST] <hiihiii> maybe I should add fps=1 ?
[17:00:29 CEST] <furq> you might want to use t and prev_selected_t then
[17:01:15 CEST] <h0par> hi
[17:03:07 CEST] <hiihiii> furq: -vf "select='not(mod(n\,900))',fps=1/30" img%%03d.png did the job
[17:03:39 CEST] <hiihiii> not sure why -vf select='not(mod(n\,900))' alone wouldn't work
[17:03:49 CEST] <furq> it should work
[17:04:02 CEST] <furq> fps doesn't do anything there as far as i can tell
[17:05:04 CEST] <hiihiii> no bro I just get a huge number of files
[17:07:42 CEST] <furq> oh right
[17:07:44 CEST] <furq> add -vsync 0
[17:08:18 CEST] <hiihiii> and what does that do?
[17:09:01 CEST] <furq> -vsync 1 will duplicate frames
[17:09:10 CEST] <furq> obviously you don't want that
[17:10:08 CEST] <hiihiii> ok
[17:13:25 CEST] <hiihiii> it did work thx for the advice
[18:59:35 CEST] <styler2go> Is there any documentation to lavfi except for https://www.ffmpeg.org/ffmpeg-devices.html#lavfi ?
[18:59:52 CEST] <c_14> the doxygen
[19:00:07 CEST] <c_14> https://ffmpeg.org/doxygen/trunk/group__lavfi.html
[19:10:39 CEST] <DHE> styler2go: there's some examples in doc/examples
[19:59:52 CEST] <ChocolateArmpits> So I asked yesterday about encoding-transmission-playback latency. It seems a large part of what I had was caused by an older Decklink card that itself introduces around 120ms of latency. When removed from the result, then the overall latency is only 100-120ms.
[20:02:23 CEST] <ChocolateArmpits> Newer Decklink cards have the latency down to 1 frame if we go by information from blackmagic.
[20:02:43 CEST] <JEEB> yea, calculating that latency can get fun :P
[20:12:11 CEST] <ChocolateArmpits> the setup had a camera shoot a timecode counter along with the output and then taking screenshots the latency would get computed
[20:12:30 CEST] <ChocolateArmpits> the output as in the stream output via network
[21:00:31 CEST] <RandomCouch> I have a bit of a weird question for you guys
[21:01:06 CEST] <RandomCouch> So, I have an android application that can record gameplay of my mobile game, I want to then append another video to that recorded video
[21:01:17 CEST] <RandomCouch> the problem is every video that gets recorded does not have a fixed frame rate
[21:01:52 CEST] <RandomCouch> is there a way to adapt my second video (that I want to append to the game recording video) to the first one's dynamic frame rate?
[21:02:06 CEST] <RandomCouch> It uses h264 Constrained Baseline codec
[21:02:13 CEST] <RandomCouch> I'm not sure what constrained baseline means
[21:04:01 CEST] <kerio> mux to mpegts, concatenate files, mux back? idk
[21:13:33 CEST] <DHE> constrained baseline means a lot of encoder features are forced off
[21:13:52 CEST] <DHE> but variable framerate containers exist. mpegts is one. MKV is another
[21:15:35 CEST] <kerio> furq do i buy the radioheds
[21:16:03 CEST] <kerio> the price goes from 13¬ for MP3 320 to 19¬ for 24-bit wav
[21:16:04 CEST] <kerio> D:
[21:18:32 CEST] <ChocolateArmpits> 24bit audio has no practical use for listening purposes, eardrums will be blown before the full dynamic range is reached
[21:21:50 CEST] <durandal_1707> huh
[21:29:48 CEST] <kepstin> on the other hand, I'd probably buy the lossless copy just on principle
[21:30:28 CEST] <kerio> ye
[21:30:34 CEST] <kerio> but 24-bit costs more than 16 D:
[21:30:46 CEST] <kerio> like 3¬ more
[21:31:28 CEST] <kerio> fuck it i'll... obtain it... somewhere else
[21:32:14 CEST] <kepstin> the real question is whether there's any difference in the mastering between the 16 and 24bit copies. If they're the same master (e.g. both have clipping or have compressor/limitor applied) then no point in getting the 24bit at all
[21:32:33 CEST] <durandal_1707> yea
[21:32:54 CEST] <durandal_1707> even 16bit
[21:38:36 CEST] <furq> the real question is "should i pay 19 euros for a reissued radiohead album"
[21:38:39 CEST] <furq> and the answer is no
[21:38:47 CEST] <furq> same as it would be without the word reissued
[21:43:23 CEST] <kerio> hey furq
[21:43:40 CEST] <kerio> you're my man of war
[21:48:46 CEST] <furq> are you calling me a jellyfish
[21:57:35 CEST] <RandomCouch> I'm trying to change the major brand metadata on a mp4 file
[21:57:38 CEST] <RandomCouch> and it doesn't seem to work
[21:58:00 CEST] <RandomCouch> I'm using the command ffmpeg -i myVideo.mp4 -metadata major_brand="mp42" out.mp4
[21:58:11 CEST] <RandomCouch> but nothing is changing
[22:07:55 CEST] <JodaZ> RandomCouch, theres a -brand flag, did you try that?
[22:08:05 CEST] <RandomCouch> I did not, thank you I will try now
[22:08:38 CEST] <RandomCouch> that worked! JodaZ
[22:25:05 CEST] <kerio> furq: does this rerelease replace the old ok computer tho
[22:25:07 CEST] <kerio> i am confus D:
[23:53:22 CEST] <gwohl1> I am trying to encode a 4096x4096 ProRes 422 source to FFV1, but when I do, I get the following output repeatedly from FFmpeg: 'Cannot allocate worst case packet size, the encoding could fail'. Tried both 3.3.2 and today's git master, both builds do this. Any idea if this is bad or if I can safely ignore?
[23:54:11 CEST] <c_14> ignore it
[23:54:25 CEST] <c_14> (unless ffmpeg actually aborts)
[23:54:50 CEST] <gwohl1> c_14 thank you. Is it reporting this because of the frame size?
[23:55:37 CEST] <c_14> yeah
[23:55:53 CEST] <c_14> it just means that if the frame is basically uncompressable it won't fit in the allocated buffer
[23:56:15 CEST] <c_14> because width*height*37*4 + buffer is > INT_MAX
[00:00:00 CEST] --- Fri Jun 23 2017

More information about the Ffmpeg-devel-irc mailing list