[Ffmpeg-devel-irc] ffmpeg.log.20170624

burek burek021 at gmail.com
Sun Jun 25 03:05:01 EEST 2017

[01:34:49 CEST] <h0par> hello
[01:36:37 CEST] <durandal_1707> hello
[01:38:01 CEST] <h0par> I try to use ffmpeg to stream mjpeg to youtube rtmp
[01:38:23 CEST] <h0par> command I try is ffmpeg -f mjpeg -i http://localhost:8081 -f flv rtmp://a.rtmp.youtube.com/live2/KEY
[01:39:46 CEST] <h0par> here is output I get https://pastebin.com/UxmZ2Wke
[01:40:03 CEST] <h0par> seems like it's ok, but doesn't appear on youtube
[01:40:35 CEST] <h0par> haha, my key shows up there
[01:41:27 CEST] <durandal_1707> see  docs about flv muxer if it have streaming options
[01:44:15 CEST] <clearcut> i want to extract part of mkv video, from 10m:00s to 12m:00s - how?
[01:45:15 CEST] <durandal_1707> read docs
[01:45:18 CEST] <atomnuker> -ss 00:10:00.000 -i <file> -t 00:02:00.000
[01:45:21 CEST] <basisbit> use google
[02:07:24 CEST] <clearcut> atomnuker: thanks - it worked, however audio is missing - im doing something wrong
[02:08:35 CEST] <durandal_1707> clearcut: pastebin full command output
[02:10:07 CEST] <clearcut> durandal_1707: https://pastebin.com/imE4kE8g
[02:11:31 CEST] <durandal_1707> try adding -c:a copy
[02:14:18 CEST] <clearcut> durandal_1707: thanks ir worked - thank you guys, you are friendly crowd, may all your wished come true :D
[02:14:25 CEST] <clearcut> wishes*
[03:00:39 CEST] <MachinaeWolf> How would I record audio that is playing on my computer. I have pulse but no ~/.asoundrc
[07:49:24 CEST] <jimgray> Hi guys. My ffmpeg is built with libssh support. When `ffplay sftp://bobme/~/test.mp4', it reports [libssh @ 0x7f90100012c0] Authentication failed
[07:49:28 CEST] <jimgray> permission denied.
[07:49:45 CEST] <jimgray> `bobme' is from ~/.ssh/config host
[08:05:38 CEST] <tdr> if auth failed, the rsa/dsa pub key is prob bad
[08:06:12 CEST] <jimgray> tdr: But I can `ssh bobme' into remote host
[08:07:21 CEST] <tdr> that or the host/path is the wrong syntax
[08:08:23 CEST] <Aprel> have you checked the perms on test.mp4 to confirm it's accessible by the client?
[08:08:48 CEST] <tdr> that would say permission denied, not an auth error
[08:08:58 CEST] <jimgray> Aprel: the perms is 644
[08:09:35 CEST] <Aprel> well he says he gets both an auth failed and perm denied messages
[08:10:03 CEST] <obito> hello hay alguien?
[08:10:06 CEST] <tdr> the permission denied would come back if auth failed anyway
[08:10:13 CEST] <obito> hello hay alguien?
[08:10:28 CEST] <jimgray> tdr: I think so. The auth failure cause permission issue.
[08:10:46 CEST] <obito> is posible concatenate stream from socket in ffmpeg?
[08:11:08 CEST] <tdr> jimgray, check your server ssh log, see why it failed
[08:12:01 CEST] <jimgray> yep, let me see
[08:12:22 CEST] <obito> @tdr is posible concatenate stream from socket please helpme and thanks
[08:15:10 CEST] <tdr> obito, not an expert on this, but if you're outputing to a socket a series of streams and reading input from it, it would make sense you can treat them as one continuous stream sure.
[08:15:40 CEST] <jimgray> tdr: I found a line `localhost sshd[3603]: Received disconnect from my-pc-ip: 11: Bye Bye [preauth]'
[08:16:21 CEST] <tdr> jimgray, thats the system you're connecting from?
[08:16:36 CEST] <jimgray> tdr: this is the log on remote
[08:16:56 CEST] <jimgray> `my-pc-ip' is the system I am connecting from
[08:17:03 CEST] <tdr> thats what i meant, yeah
[08:17:58 CEST] <jimgray> It seems each time I execute ffplay sftp://, it report that line
[08:18:57 CEST] <obito>  The server what it does is, read several files and send them to ffmpeg the first file is read well but the second pull some errors Non-Monotunus I have researched but I do not find the solution because: C
[08:21:20 CEST] <jimgray> tdr: by the way, I can use `sftp bobme:test.mp4' to fectch the file locally. Dunnno why ffplay not.
[08:21:29 CEST] <tdr> jimgray, so on your client, ssh bobme   works without a password?
[08:22:03 CEST] <jimgray> tdr: yes. pretty sure. I use ssh key to login
[08:22:21 CEST] <tdr> (checking that its not silently asking you for a password input and not getting one so failing)
[08:22:33 CEST] <tdr> yeah if keys work, thats answering
[08:23:33 CEST] <tdr> jimgray, does ssh bobme 'cat filename' | ffplay  work?    ... your ~ may not be expanding or something
[08:24:01 CEST] <jimgray> let me test
[08:24:27 CEST] <tdr> try full path
[08:25:33 CEST] <jimgray> tdr: An input file must be specified. ffplay exit directly
[08:26:19 CEST] <tdr> jimgray, ssh bobme 'cat /path/to/file' | ffplay     <--- thats what you did?
[08:26:48 CEST] <jimgray> tdr: my exact command is `ssh jimgray 'cat ~/joke.mp4' | ffplay`
[08:27:17 CEST] <jimgray> ignore jimgray or bobme string diff
[08:27:45 CEST] <tdr> it may want -  after the ffplay to get stdin
[08:28:01 CEST] <tdr> er stdout .. whatever, to make it "catch it"
[08:28:48 CEST] <jimgray> tdr: ha, `-' works now
[08:29:01 CEST] <tdr> yeah some commands are picky like that
[08:29:18 CEST] <tdr> so its not a connection thing, try full path with your sftp thing
[08:29:51 CEST] <tdr> i dont know the syntax you should be using, but it has to be off since it plays if we pipe it back over ssh
[08:31:03 CEST] <jimgray> ffplay sftp://bobme/~/joke.mp4 failed
[08:31:31 CEST] <tdr> stop using the ~, give it a full path
[08:31:35 CEST] <tdr> 'to test :)
[08:32:17 CEST] <tdr> sftp is usually username at host:/path  .. the first / after bobme maybe should be a :
[08:34:29 CEST] <jimgray> tdr: all failed. Let me google first
[09:16:38 CEST] <thomedy> what i understand about audio codec isn't adding up
[09:16:48 CEST] <thomedy> is someone here who can help me make sense of it
[09:16:51 CEST] <thomedy> if i have 44100
[09:17:11 CEST] <thebombzen> 44100 is the sample rate, not the audio codec
[09:17:13 CEST] <thomedy> samples per second with 16 bits per samples that woudl be s/s * bd
[09:17:30 CEST] <thomedy> okay im not sure wht to call it im just trying to find out how many bits per second
[09:18:13 CEST] <thomedy> and my ogg isn't lining up with what makes sense to me and also neither is my .raw so tht meanse im wrong because im assuming ffmpeg -i will be accurate making me not so much
[09:18:20 CEST] <thomedy> so here is what makes sense....
[09:18:27 CEST] <thomedy> to me at least and im missing somethign i know it
[09:18:37 CEST] <thomedy> 44100 cd quality sampels per second at 16 bits per sample
[09:18:43 CEST] <thomedy> divide that by the chnanels
[09:18:45 CEST] <thomedy> 2 for exmple
[09:19:05 CEST] <thomedy> 352800
[09:19:39 CEST] <thomedy> but tht isnt right
[09:20:04 CEST] <thomedy> 8484377 is my ls -al on my file.ogg
[09:20:08 CEST] <thomedy> gives me file size
[09:20:30 CEST] <thebombzen> the bitrate of uncompressed audio is just a bunch of multiplication, as you have figured out
[09:20:51 CEST] <thomedy> the file is 4.13
[09:21:19 CEST] <thebombzen> 44100 samples per second * 16 bits per sample * 2 channels (stereo audio) is 1.411 kilobits per second. But that's uncompressed audio
[09:21:28 CEST] <thebombzen> ogg audio is comprssed, so the bitrate will bit considerably lower than that
[09:21:43 CEST] <thebombzen> (cause that's kind of, like, the whole point of compression)
[09:21:47 CEST] <thomedy> wouldnt ffmpeg tell me what i need to complete the equation
[09:22:18 CEST] <thomedy> for example when i ffmpeg the .ogg i get 8 bits 44100 and  im not seeing channels but
[09:23:17 CEST] <thomedy> well then actually i still have a question... i run command line to pcm raw audio... and it gives me 44734464
[09:23:37 CEST] <thomedy> as in im pretty sure that decompresses the content
[09:23:43 CEST] <thomedy> im honestly not sure yet
[09:28:07 CEST] <thebombzen> back up, do you know what compression is?
[09:29:08 CEST] <thomedy> yeah im pretty sure i understand a fair amount about compression i dont know exactly what algorithm ogg vorbis for example uses but i am reading bout it now
[09:29:35 CEST] <thomedy> for exmple lossless aaabbcccccccdde 3a2b8c2de
[09:29:39 CEST] <thomedy> i get that
[09:30:07 CEST] <thomedy> as an example but i guess i was assuming that ffmpeg -i would give me enough info to make my equation post compression
[09:30:08 CEST] <thebombzen> vorbis uses the vorbis algorithm
[09:30:14 CEST] <thebombzen> that's literally what an audio codec does
[09:30:21 CEST] <thebombzen> it's a compresion algorithm for audio
[09:30:28 CEST] <thomedy> right i think i knew that
[09:30:41 CEST] <thomedy> general concepts im prob good on
[09:30:47 CEST] <thebombzen> but it's lossy, so the original isn't perfectly reconstructable from the compressed file
[09:30:54 CEST] <thomedy> details and pragmatic applications are what im after now
[09:31:02 CEST] <thebombzen> then do you have an actual quesiton
[09:31:05 CEST] <thomedy> right because its lossy i know
[09:31:17 CEST] <thebombzen> or are you going to mess up arithmetic and mention how your bad arithmetic isnt' right
[09:31:26 CEST] <thebombzen> because right now you're just kind of mumbling about things
[09:31:45 CEST] <thomedy> you know im learning right... and reading and asking genuine questions im not an idiot..
[09:32:18 CEST] <thebombzen> you have yet to ask a direct question
[09:32:20 CEST] <thomedy> i was operating under the assumption that ffmpeg -i would give me enough info but i m learning now that it is not
[09:32:42 CEST] <thomedy> so i will probably have to read the vorbis algorithm
[09:32:50 CEST] <thebombzen> no you don't
[09:33:00 CEST] <thebombzen> you haven't actually asked what you want to know
[09:33:24 CEST] <thomedy> yes i did im trying to determine how many kb/s from file size and duration i have
[09:33:34 CEST] <thebombzen> do you want to know the bitrate of an OGG file? ffmpeg should tell you that if you run "ffmpeg -i file.ogg" unless it's not in the ogg header
[09:33:37 CEST] <thomedy> i.e. this song is 4:13
[09:33:38 CEST] <thebombzen> but it should be in the header
[09:34:06 CEST] <thomedy> here ill give you ane xample of wht confuses me
[09:34:15 CEST] <thomedy> and i saw the kb/s in ffmpeg -i
[09:34:16 CEST] <thomedy> one sec
[09:34:43 CEST] <thomedy> sound.ogg is 267 kb/s
[09:34:53 CEST] <thomedy> the song is 253.6 seconds
[09:35:13 CEST] <thebombzen> why is that confusing?
[09:35:35 CEST] <thomedy> the file size is 8484377 bits
[09:35:46 CEST] <thomedy> 267000 * 253.6 is not 8484377
[09:35:50 CEST] <thomedy> its 64---------
[09:36:13 CEST] <thomedy> so im missing something
[09:36:20 CEST] <thebombzen> it sounds like the file is 8 megabytes in size, not 8 megabits
[09:36:31 CEST] <thebombzen> remember there's 8 bits in a byte, and the filesize will be listed in bytes.
[09:36:35 CEST] <thomedy> right
[09:36:45 CEST] <thebombzen> you're off by a factor of 8, so that sounds about right.
[09:37:27 CEST] <thomedy> jesus it isn't me its that im assuming something about ls -al
[09:37:29 CEST] <thomedy> thank you
[09:37:35 CEST] <thomedy> i hadn't noticed precision on that
[09:37:46 CEST] <thomedy> i was right  and also resoundingly wrong
[09:37:50 CEST] <thomedy> thank you again
[09:37:53 CEST] <thomedy> oh my god...
[09:37:56 CEST] <thebombzen> 267000 * 253.6 divied by 8 is 8463900, which is close enough to 8484377 that it's right, because 267 kbps is an approximation
[09:37:56 CEST] <thomedy> okay let me test th
[09:39:29 CEST] <thomedy> what im going to assume until i read it
[09:39:39 CEST] <thomedy> is that ls -al is listing the file size in BYTES not bits
[09:39:49 CEST] <thomedy> which is the opposite of what i was assuming
[09:40:56 CEST] <thomedy> i just ran a test on sound.mp3 same thing
[09:40:57 CEST] <thomedy> roughly
[09:41:05 CEST] <thomedy> hmmm... good news
[09:41:11 CEST] <thebombzen> it should not surprise you that bitrate means bits per second
[09:41:20 CEST] <thebombzen> that is exactly what bitrate menas
[09:41:31 CEST] <thomedy> ha thats funny i forget sometimes what the internet is like.... no thata is not what is surprising me
[09:41:33 CEST] <thomedy> bu tthank you
[12:03:26 CEST] <kerio> itunes aac is the best encoder right
[12:03:35 CEST] <kerio> at 128kbps stereo
[12:06:40 CEST] <BtbN> Probably fdk
[12:06:48 CEST] <BtbN> But ffmpeg aac is just fine for lc as well
[16:05:37 CEST] <AnonBaiter> h
[16:05:51 CEST] <AnonBaiter> so
[16:06:40 CEST] <algun_> Is it possible to extract audio from an online mp4 file downloading just the chunks necessary?
[16:11:25 CEST] <AnonBaiter> anyway I`m just here to post a sample
[16:11:26 CEST] <AnonBaiter> https://www.sendspace.com/file/mcbfg4
[16:12:48 CEST] <AnonBaiter> these DUK+FRM+HDR+TBL pairs came from a 3DO game called "Slam 'N Jam '95"
[16:13:14 CEST] <AnonBaiter> that same format was used for the 3DO game called "The Horde"
[16:15:09 CEST] <durandal_1707> AnonBaiter: if its audio only,  try vgmstream
[16:16:22 CEST] <AnonBaiter> I don't think it stores just audio however
[16:17:15 CEST] <AnonBaiter> I tried to get .aif files from The Horde to work on foobar2000 with the vgmstream component installed(which is the latest version) and it didn't recognize it
[16:17:30 CEST] <AnonBaiter> ffmpeg recognized that .aif format
[16:23:10 CEST] <algun_> Guys?
[16:23:44 CEST] <JEEB> not sure if the demuxer just skips instead of going through all packets :P
[16:24:34 CEST] <JEEB> with enough logging you could check what lavf does there to test
[16:29:05 CEST] <AnonBaiter> heh
[18:06:37 CEST] <thebombzen> so, if I play an audio file using ffplay without the display, i.e, "ffplay -nodisp audio_file.ogg" then the CLI interface ignores Q
[18:06:48 CEST] <thebombzen> the usual keyboard shortcut to tell it to exit
[18:07:36 CEST] <thebombzen> as usual, ffplay doesn't exit when the audio file ends, but it also doesn't respond to q either with -nodisp, so I have to press ^C after the file is done
[18:07:38 CEST] <thebombzen> this sounds like a bug
[19:19:34 CEST] <lesshaste> I am trying to make ffmpeg in cygwin following http://www.mediaentertainmentinfo.com/2014/01/1-technical-series-how-to-compile-ffmpeg-under-cygwin.html/
[19:19:57 CEST] <lesshaste> I got to "make distclean" but I get Makefile:210: /tests/Makefile: No such file or directory
[19:19:57 CEST] <lesshaste> make: *** No rule to make target '/tests/Makefile'.  Stop.
[19:20:50 CEST] <lesshaste> what am I doing wrong?
[19:22:09 CEST] <Fenrirthviti> lesshaste: you don't really need to do a distclean for a new build
[19:22:38 CEST] <lesshaste> Fenrirthviti, so should it just be "make"?
[19:22:51 CEST] <Fenrirthviti> no, just ignore that command. but looks like you're not in the right directory
[19:23:02 CEST] <Fenrirthviti> did you cd to ffmpeg first after cloning the repo?
[19:23:34 CEST] <lesshaste> yes.... I just ran ./configure and am trying that
[19:23:43 CEST] <lesshaste> I mean configure then make
[19:24:40 CEST] <lesshaste> I assume  I need to run "make" to compile it?
[19:24:48 CEST] <Fenrirthviti> yes
[19:26:24 CEST] <lesshaste> it's doing something :)
[19:43:37 CEST] <lesshaste> how  would you cut out minute 1 to minute 2 of a video? Something like ffmpeg -ss 01:00 movie.mp4 -vcopy -acopy -o cut.mp4 ?
[19:44:47 CEST] <lesshaste> ffmpeg -i movie.mp4 -ss 00:00:03 -t 00:00:08 cut.mp4 cuts out 8 seconds I think
[19:44:59 CEST] <lesshaste> I would just like to specify an end time
[19:45:11 CEST] <dystopia_> -t before -ss
[19:45:54 CEST] <lesshaste> ffmpeg -i movie.mp4 -acodec copy -vcodec copy -t 00:00:08 -ss 00:00:03
[19:45:57 CEST] <lesshaste> ?
[19:45:57 CEST] <dystopia_> ffmpeg -t 60 -i input.mp4 -ss 00:01:00 -vcodec copy -acodec copy out.mp4
[19:46:12 CEST] <dystopia_> -t xx is how long you want, so 60s is 1m
[19:46:26 CEST] <dystopia_> -ss is your start time so 00:01:00 is start at 1m in
[19:46:32 CEST] <lesshaste> right but I can  I say why I actually want it to en instead of having to say how long??
[19:46:37 CEST] <dystopia_> so that would cut 1m of content from 1m to 2m
[19:46:51 CEST] <dystopia_> i don't think so
[19:46:51 CEST] <lesshaste> s/why/when
[19:46:54 CEST] <lesshaste> ok thanks
[19:53:42 CEST] <lesshaste> https://bpaste.net/show/79ab10e618d0 essentially failed
[19:53:46 CEST] <lesshaste> it gives a 262 byte output
[19:53:51 CEST] <lesshaste> any idea why?
[19:54:15 CEST] <lesshaste> are the h264 messages telling me there is a serious problem?
[20:05:04 CEST] <lesshaste> ffmpeg -t 240 -i Skt.\ Hans\ med\ Søren\ Ryge-skt-hans-med-soeren-ryge.mp4 -ss 00:05:00 -vcodec copy -acodec copy out.mp4  fails
[20:05:20 CEST] <lesshaste> but ffmpeg -t 240 -i Skt.\ Hans\ med\ Søren\ Ryge-skt-hans-med-soeren-ryge.mp4 -ss 00:00:00 -vcodec copy -acodec copy out.mp4  works
[20:05:22 CEST] <lesshaste> any ideas why?
[20:07:44 CEST] <dystopia_> how long is the video
[20:08:24 CEST] <dystopia_> your asking it to cut 4 mins of video, starting from 5mins into the source video, so 5m to 9m
[20:08:49 CEST] <dystopia_> but if that video doesn't exist there it will probably fail
[20:09:13 CEST] <lesshaste> 48 minutes long
[20:10:20 CEST] <lesshaste> dystopia_, https://bpaste.net/show/910b2f1b02be is the result of ffmpeg -i
[20:11:30 CEST] <lesshaste> this is very frustrating
[20:11:42 CEST] <lesshaste> what can I do?
[20:12:56 CEST] <dystopia_> https://trac.ffmpeg.org/wiki/Seeking
[20:12:58 CEST] <dystopia_> hmm
[20:13:14 CEST] <dystopia_> "-ss 60 -to 70" seems useful
[20:13:35 CEST] <dystopia_> ffmpeg -i Skt.\ Hans\ med\ Søren\ Ryge-skt-hans-med-soeren-ryge.mp4 -ss 00:05:00 -t 00:09:00 -vcodec copy -acodec copy out.mp4
[20:13:39 CEST] <dystopia_> give that a try
[20:14:09 CEST] <dystopia_> or try
[20:14:22 CEST] <lesshaste> that works!
[20:14:23 CEST] <dystopia_> ffmpeg -i Skt.\ Hans\ med\ Søren\ Ryge-skt-hans-med-soeren-ryge.mp4 -ss 300 -t 540 -vcodec copy -acodec copy out.mp4
[20:14:26 CEST] <dystopia_> nice :)
[20:14:39 CEST] <lesshaste> so the problem is where -t was?
[20:14:41 CEST] <dystopia_> -t was meant to be -to
[20:14:42 CEST] <dystopia_> heh
[20:14:59 CEST] <lesshaste> or -t was before -ss !!
[20:15:14 CEST] <lesshaste> something seems broken here :)
[20:17:04 CEST] <lesshaste> thanks dystopia_
[20:17:51 CEST] <dystopia_> np
[23:48:34 CEST] <ArsenArsen> I'm trying to compile my program which uses libav* stuff on Ubuntu 16.04 but the build fails, I get https://hastebin.com/viranuwuti.cs in the output, but it works perfectly fine on my local Arch machine
[23:49:16 CEST] <BtbN> 16.04 has an ancient version of libav, not even ffmpeg.
[23:49:23 CEST] <ArsenArsen> Oh shit
[23:49:57 CEST] <ArsenArsen> What about 16.10 or some other?
[23:51:43 CEST] <BtbN> https://packages.ubuntu.com/zesty/libavformat-dev
[23:51:45 CEST] <ArsenArsen> apt-cache search tells me otherwise though, libavcodec-dev - FFmpeg library with de/encoders for audio/video codecs - development files
[23:51:47 CEST] <ArsenArsen> yeah
[23:51:54 CEST] <ArsenArsen> That is what I used
[23:52:06 CEST] <BtbN> xenial switches from libav to ffmpeg
[23:52:11 CEST] <BtbN> trusty is still using libav
[23:52:26 CEST] <ArsenArsen> Oh I see
[23:52:32 CEST] <ArsenArsen> I'll do a release upgrade and pray
[23:52:38 CEST] <ArsenArsen> Thanks for letting me know!
[23:52:46 CEST] <BtbN> isn't 16.04 xenial?
[23:53:18 CEST] <BtbN> That is ffmpeg, just an old version, 2.8
[23:53:39 CEST] <BtbN> The send/recv packet API did not exist back then
[23:53:53 CEST] <ArsenArsen> Still, upgrade won't hurt
[23:54:05 CEST] <ArsenArsen> Actually, what version was the send/receive API introduced in?
[23:54:46 CEST] <BtbN> no idea, ask git
[23:54:55 CEST] <ArsenArsen> Ok, thanks
[00:00:00 CEST] --- Sun Jun 25 2017

More information about the Ffmpeg-devel-irc mailing list