[Ffmpeg-devel-irc] ffmpeg.log.20170831

burek burek021 at gmail.com
Fri Sep 1 03:05:01 EEST 2017

[00:00:29 CEST] <JEEB> x264 by default sets the minimum level that you bit stream (outside of VBV/HRD) complies to
[00:00:56 CEST] <JEEB> then you can set it to higher than that, but I think highest might be the same as auto - at least with profiles it could be like that
[00:01:02 CEST] <JEEB> don't quote me on this
[00:01:14 CEST] <JEEB> I just remember all those people setting -profile:v high and getting main :P
[00:02:11 CEST] <alexpigment> yeah, there are restrictions
[00:02:16 CEST] <alexpigment> but it's only one direction
[00:02:50 CEST] <alexpigment> so yes, i agree with you JEEB :)
[00:20:21 CEST] <alexpigment> well, I'm not really familiar with the patch submission process, and I don't even know if this is the clean way to do this - I'm just using diff between the original and the resultant file, but here's my pastebin:
[00:20:33 CEST] <alexpigment> https://pastebin.com/a3aQPF2Z
[00:21:03 CEST] <alexpigment> I've gotta head out. I've tested that the patch works. If anyone would like to submit it, feel free.
[00:22:06 CEST] <alexpigment> (specifically, I don't know how to reference the files at the top. my compile script just asks me which files I'm trying to patch and I point it at the file manually)
[01:22:03 CEST] <acos> ?
[01:22:45 CEST] <acos> Oh hi
[02:00:12 CEST] <acos> What do yall use ffmpeg for?
[02:04:14 CEST] <c3r1c3-Win> I use it as a way to frustrate my life, because if it wasn't for ffmpeg I would be perfectly happy.
[02:11:10 CEST] <redrabbit> lol.
[02:29:34 CEST] <dystopia_> acos, pretty much everything
[02:31:16 CEST] <acos>  dystopia_ wow sounds.  You don't get errors ? Lucky!
[02:32:26 CEST] <c3r1c3-Win> I only get errors with ffmpeg when I try to write code against it... and that's only because I suck.
[02:32:33 CEST] <c3r1c3-Win> Using it, it's awesome.
[02:33:11 CEST] <c3r1c3-Win> And I use it for converting files from one codec to another, and remuxing.
[02:54:19 CEST] <acos> c3r1c3-Win: nice nice
[03:20:51 CEST] <MrDave20161> Does anyone have any tips/example links for how to query a v4l2 device for capabilities via the API?  I wasn't able to find much on the "avdevice_capabilities_create" function and it is returning a "function not implemented".  Ultimately I need to determine whether a particular pixel format(h264) is supported by the device before I specify that as the "input_format" and open the device.
[03:38:55 CEST] <DHE> acos: over-the-air capture into a streaming format so I can watch it from anywhere
[07:28:28 CEST] <borsh> Hello!
[07:29:11 CEST] <borsh> I'm trying to stream to chaturbate.com but
[07:29:26 CEST] <borsh> How to geal with rtmp stream key? Can't figure out what to do with it.
[07:29:30 CEST] <borsh> s/geal/deal/
[07:32:39 CEST] <borsh> rtmp stream token
[07:33:37 CEST] <borsh> This thing does not really help as obs has a separate field for the token
[07:33:39 CEST] <borsh> https://support.chaturbate.com/customer/portal/articles/2831439-external-encoders-and-obs
[09:52:32 CEST] <borsh> this does not work: ... -f flv "rtmp://some/url token=$token_data_here"
[09:52:41 CEST] <borsh> [rtmp @ 0x56071008d850] Detected librtmp style URL parameters, these aren't supported by the libavformat internal RTMP handler currently enabled. See the documentation for the correct way to pass parameters.
[09:52:45 CEST] <borsh> no token here https://www.ffmpeg.org/ffmpeg-protocols.html#rtmp
[09:52:50 CEST] <borsh> Unrecognized option 'rtmp_token=
[09:53:02 CEST] <borsh> Is it just not supported?
[09:57:59 CEST] <Nacht> What version are you running ?
[09:59:52 CEST] <borsh> Nacht: N-82889-g54931fd
[10:00:31 CEST] <borsh> Nacht: do I need to rebuild?
[10:40:55 CEST] <Nacht> borsh: It wouldn't hurt to try.
[10:41:11 CEST] <borsh> Nacht: I'm now rebuilding
[10:41:20 CEST] <borsh> Nacht: but this ffmpeg is probably only a week old
[10:42:14 CEST] <borsh> Nacht: but I don't see the proper syntax in the docs
[10:43:41 CEST] <borsh> haha
[10:43:47 CEST] <borsh> I will try enabling librtmp :D
[10:47:30 CEST] <borsh> Nacht: I had no rtmpdump installed.
[10:48:00 CEST] <Nacht> I see. But I can't see N-82889 being a week old
[10:48:40 CEST] <borsh> ok, rebuilding again anyway
[10:49:41 CEST] <Nacht> You could just try the static ones ?
[10:49:56 CEST] <Nacht> Saves you the time building
[10:51:48 CEST] <borsh> But will the static one work with all these libs or does it include it's own lib set?
[10:54:44 CEST] <Nacht> The static ones have quite a few libs included, incl rmtp
[10:54:58 CEST] <Nacht> https://www.johnvansickle.com/ffmpeg/
[10:55:32 CEST] <Nacht> You can find the list of libs there
[10:59:22 CEST] <borsh> Thanks
[12:43:39 CEST] <dragmore> hi, the changelog for ffmpeg 3.3 says : - libvmaf video filter support, but when i run : ffmpeg -i source.mp4 -i dest.mp4 -lavfi libvmaf -f null - i get No such filter libvmaf, anyone know why?
[12:43:59 CEST] <thatandyrose> hey there! can anyone help with an audio issue I'm trying to fix? Basically I have an m4a file with a start time > 0. I'd like to add "padding" to the beginning of the audio file so that its start time is zeroed essentially. How do I do this?
[12:44:35 CEST] <thatandyrose> My first thought is to just pad it with silence. So say start time is 3.001 then I pad with 3.001 of silence?
[12:45:08 CEST] <thatandyrose> but how do I do this? I want the file to be as unchanged as possible, except for this "padding"
[12:45:34 CEST] <thatandyrose> for example... what would the command be? ffmpeg -i 1.m4a .... and then?
[12:47:02 CEST] <thatandyrose> the reason I'm asking is because I'm going to merge this audio file with another audio file. And I find that when I do this the start time on the merged file gets zeroed, but because the start time offsets haven't been taken into account the audio is off
[12:47:17 CEST] <thatandyrose> disclaimer: total n00b
[12:58:39 CEST] <borsh> Nacht: it is N-87141-gb34c16a now
[13:02:13 CEST] <borsh> Now I'm geting lots of [mjpeg @ 0x55f34d13f550] unable to decode APP fields: Invalid data found when processing input
[13:04:28 CEST] <borsh> used garbage as an rtmp option and got the list of valid rtmp options yay!
[13:04:44 CEST] <borsh> token is one of them so looks like I figured it out
[13:15:45 CEST] <borsh> Will try fixing unable to decode APP fields: error in mjpeg downgrading to 3.3.3
[13:16:11 CEST] <borsh> streaming works but the stream is not getting online.
[13:20:06 CEST] <borsh> Should I add any extra rtmp flags?
[13:48:12 CEST] <borsh> What am I doing wrong?
[14:16:33 CEST] <sloth_on_meth> helloooo
[14:17:08 CEST] <sloth_on_meth> getting strange errors.
[14:17:08 CEST] <sloth_on_meth> https://pastebin.com/iZSPWeMB
[14:17:56 CEST] <DHE> sloth_on_meth: you need a package whose name is likely "gnutls-dev" or such in order to build using gnutls
[14:18:05 CEST] <sloth_on_meth> okay, will try
[14:19:02 CEST] <sloth_on_meth> never used FFMPEG beofre i ran into letsrobot.tv haha
[14:19:11 CEST] <sloth_on_meth> for some reason, apt-get is extremely slow...
[14:19:57 CEST] <sloth_on_meth> https://thepasteb.in/p/oYhl3k0gJxPCZ
[14:20:40 CEST] <DHE> while I don't normally troubleshoot debian/ubuntu issues, I am guessing you have broken ipv6
[14:21:21 CEST] <sloth_on_meth> i have native IPV6 from my isp, that i work for. could this be a clientside issue on my rbp? i'll try disabling ipv6 just for testing
[14:21:56 CEST] <JEEB> that would explain the slowness with apt-get :P
[14:22:03 CEST] <JEEB> since it tries to connect through ipv6 first
[14:22:04 CEST] <JEEB> then times out
[14:22:17 CEST] <sloth_on_meth> oh. can i force ipv4?
[14:22:46 CEST] <JEEB> disabling ipv6 in the VM or whatever is probably simplest :)
[14:23:11 CEST] <sloth_on_meth> i've added -o Acquire::ForceIPv4=true
[14:23:28 CEST] <sloth_on_meth> yeah i did that but then it still tries to conenct to ipv6 making me wait for the timeouit
[14:24:07 CEST] <sloth_on_meth> you guys ever heard of letsrobot?
[14:38:45 CEST] <blap> +1 for nickname sloth
[14:40:59 CEST] <sloth_on_meth> ty ty
[15:43:12 CEST] <ForceRecon> how to config from 720 to 360
[15:44:35 CEST] <Kadigan> Just in case someone has the same issue I did w/ 50i material looking like 25fps (seemingly 25PsF) when deinterlaced w/ YADIF in mode 1 (recreate fields into frames to create a slow motion effect), check your shutter speed -- it didn't occur to me before (as I'm not the cam operator) that setting the exposure to anything longer than 1/fps would cause this effect. We were recording 50i and got 25PsF at any moment the exposure was longer than 1/50. A
[15:44:36 CEST] <Kadigan> small detail, but it matters.
[15:45:23 CEST] <ForceRecon> I have a guy in the debian channel asking for help.. I redirected him here, but I don't see him.. just trying to help him out..  I don't use ffmpeg.. he is to stream to youtube and asked
[15:45:26 CEST] <ForceRecon> i work on ffmpeg but 720p
[15:45:28 CEST] <ForceRecon> i need to config it to 360p?????
[15:45:37 CEST] <ForceRecon> can anyone help with this configuration
[15:45:54 CEST] <Kadigan> ForceRecon: he has 720p video and needs to recompress to 360p?
[15:46:38 CEST] <ForceRecon> Stream status Bad 720p Stream?
[15:46:56 CEST] <ForceRecon> that about all I can give you.. but it sounds like you are on the right track
[15:47:09 CEST] <Kadigan> Okay, I don't recognize that message. Sorry.
[15:47:35 CEST] <ForceRecon> if he wanted to recompress to 360 is there an option
[15:47:59 CEST] <Kadigan> yes, he needs to add -vf "scale=-1:360" to his call options.
[15:48:18 CEST] <Kadigan> (the -1 will preserve aspect ratio and rescale the width accordingly so that it fits the new height)
[15:49:24 CEST] <ForceRecon> Thanks Kadigan appreciated, he might come here.. just so you know doslas
[15:52:32 CEST] <doslas> hi
[15:52:47 CEST] <doslas> https://pastebin.com/F6WszwFz
[15:52:59 CEST] <doslas>  this is my ffmpeg conf
[15:53:14 CEST] <doslas> it is 720p
[15:53:32 CEST] <doslas> i need it 360p?????
[15:53:36 CEST] <doslas> how???
[15:54:23 CEST] <doslas> any one here??
[15:54:27 CEST] <doslas> plz
[15:54:32 CEST] <Kadigan> We're reading. Wait.
[15:54:44 CEST] <doslas> ok
[15:55:13 CEST] <Kadigan> Well, like we told ForceRecon, if you want it 360p, you'll need to add -vf "scale=-1:360" to the commands.
[15:55:14 CEST] <Nacht> -vcodec libx264 -vf "scale=-1:360" -pix_fmt yuv420p -preset $QUAL -r $FPS -g $(($FPS * 2)) -b:v $VBR \
[15:55:34 CEST] <Kadigan> Though I'm not sure whether this'll work as you expect, since it'll take some time encoding.
[15:55:34 CEST] <Nacht> Not sure why it needs to be 360 though
[15:56:27 CEST] <Kadigan> You might want to try -preset ultrafast, ... I think...
[15:56:56 CEST] <doslas> i will add it and try
[15:57:00 CEST] <Nacht> Youtube should be able to ingest 720p tho
[15:57:04 CEST] <Nacht> https://support.google.com/youtube/answer/2853702?
[15:57:20 CEST] <BtbN> you can stream 4K there if you want to
[15:57:48 CEST] <doslas> :)
[15:57:53 CEST] <BtbN> ultrafast ist overkill in terms of badness
[15:58:01 CEST] <BtbN> veryfast is usually a good compromise
[15:58:18 CEST] <BtbN> anything faster will disable features and look notably worse
[15:58:38 CEST] <doslas> no i need 360p & 240p
[15:59:00 CEST] <Nacht> You need both ?
[15:59:49 CEST] <doslas> no
[16:00:11 CEST] <doslas> once 360p
[16:00:20 CEST] <doslas> once 240p
[16:00:36 CEST] <doslas> if i need
[16:00:44 CEST] <Nacht> Just a question. But what exactly are you trying to do, and who says it needs to be 360p ?
[16:00:49 CEST] <Nacht> Is it live, or a vod ?
[16:01:45 CEST] <doslas> the Internet is slow
[16:02:08 CEST] <doslas> Stream status
[16:02:08 CEST] <doslas> Bad
[16:02:09 CEST] <doslas> 720p Stream
[16:03:14 CEST] <furq> lol this fucking script again
[16:03:32 CEST] <furq> i swear this thing gets pasted by someone new once a month
[16:03:38 CEST] <Nacht> heeh
[16:04:10 CEST] <furq> why -threads 6 in a blog post command? why -qscale 3? why 712kbps mp3? we will never know
[16:04:41 CEST] <bencoh> because!
[16:04:50 CEST] <furq> i can sort of understand the first two coming from not understanding the commands you cobbled this together from
[16:05:01 CEST] <furq> but how has anyone ever come to the conclusion that -b:a 712000 is a thing
[16:05:33 CEST] <furq> oh and i forgot -deinterlace
[16:05:40 CEST] <bencoh> haha
[16:05:47 CEST] <doslas> https://pastebin.com/aiVjh1tk
[16:05:55 CEST] <Nacht> Perhaps if for an Opera live channel :)
[16:06:05 CEST] <doslas> after tried
[16:06:12 CEST] <furq> doslas: basically get rid of almost all of that command because it sucks
[16:06:22 CEST] <furq> and also don't copy ffmpeg commands from blogs because they were all written by idiots
[16:06:27 CEST] <bencoh> furq: a lot of tv channels are still interlaced, but ... yeah :)
[16:07:07 CEST] <furq> ffmpeg -i "$SOURCE" -c:v libx264 -pix_fmt yuv420p -b:v 2500k -c:a aac -b:a 128k -f flv "$YOUTUBE_URL/KEY"
[16:07:20 CEST] <furq> then add -vf "scale=-2:360" as needed
[16:07:46 CEST] <furq> also that's going to make no difference to the bandwidth if you don't change -b:v to something lower
[16:08:29 CEST] <doslas> ok
[16:08:48 CEST] <Kadigan> furq: you mean "written for specific purposes" don'tcha ;)
[16:09:05 CEST] <furq> well no big chunks of that are just plain wrong
[16:09:09 CEST] <furq> you can't even have a 712kbps mp3
[16:09:11 CEST] <Kadigan> Like 90% of issues I see when it comes to configs or scripts is because people copy&paste w/o understanding what {X} does.
[16:09:14 CEST] <Kadigan> Yeah, that bit I know.
[16:09:26 CEST] <furq> but yeah
[16:09:35 CEST] <Kadigan> Looks like someone was writing some pro-formats script and ended up replacing sound w/ libmp3lame
[16:09:45 CEST] <furq> you start with that, then you get a second generation of blog cobbled together from the first
[16:10:08 CEST] <furq> and then you end up with some magnificent eighth-generation cluelessly assembled command like this
[16:10:16 CEST] <Nacht> I'm still in the dark as why Youtube would request 360p though
[16:10:20 CEST] <doslas> same prop
[16:10:24 CEST] <Kadigan> Hey, I just wasted 3 man-hours of Canon Support on operator error ;-)
[16:10:35 CEST] <furq> doslas: -2:360
[16:10:36 CEST] <doslas> in youtube
[16:10:36 CEST] <furq> not -1
[16:10:53 CEST] <doslas> Stream status Bad 720p Stream
[16:11:14 CEST] <doslas> 720p not 360p
[16:11:16 CEST] <Kadigan> furq: why -2? https://trac.ffmpeg.org/wiki/Scaling%20(resizing)%20with%20ffmpeg says -1
[16:11:23 CEST] <furq> -2 ensures it resizes to mod2
[16:11:27 CEST] <Kadigan> Ah.
[16:11:31 CEST] <Kadigan> Good to know.
[16:11:34 CEST] <furq> otherwise you get [libx264 @ 0x55cb734952c0] width not divisible by 2 (641x360)
[16:11:39 CEST] <Kadigan> (I do recall seeing it somewhere, just forgot about it)
[16:12:27 CEST] <doslas> -2 Worked
[16:12:36 CEST] <doslas> but 720p not 360p
[16:12:43 CEST] <Nacht> Ah, so it always better to use -2 then
[16:12:55 CEST] <furq> it is if you're using a pixel format that requires mod2
[16:13:19 CEST] <Nacht> TIL
[16:13:37 CEST] <furq> doslas: i have no idea what youtube error messages actually mean, but you should be able to see that the output is 360p
[16:14:05 CEST] <doslas> Can you fix me on the Iscript
[16:14:32 CEST] <doslas> i need image sit?
[16:14:36 CEST] <furq> Stream #0:0: Video: h264 (libx264), yuv420p, 640x360 [SAR 3:4 DAR 4:3], q=-1--1, 25 fps, 25 tbn, 25 tbc
[16:14:41 CEST] <furq> you should have something like that in the output
[16:15:01 CEST] <doslas> i upload photo
[16:20:06 CEST] <doslas> https://pasteboard.co/GIcYYqo.png
[16:20:45 CEST] <doslas> https://pasteboard.co/GIcZiHg.png
[16:21:01 CEST] <Kadigan> Ah. Well, that's not suprising. Transcoding takes time -- and if you're transcoding FROM a live stream TO a live stream, you're going to have a bad time.
[16:21:41 CEST] <Kadigan> Set "-b:a 128k" for starters -- youtube is telling you that what you have is too high and not needed.
[16:21:45 CEST] <doslas> https://pasteboard.co/GIcZJ7o.png
[16:21:45 CEST] <Nacht> You didn't change the bitrates
[16:22:16 CEST] <Kadigan> Yeah, video is also too high -- don't use -qscale, use the bitrate options (there are four in total, and you need to use three of them)
[16:22:37 CEST] <doslas> how?
[16:22:38 CEST] <Nacht> what does FFMPEG say about your input ?
[16:22:45 CEST] <Kadigan> Yes, I know they're not usually recommended, but in this case they're quite mandatory if you want to maintain constant output.
[16:22:47 CEST] <doslas> use the bitrate option???
[16:23:19 CEST] <Kadigan> doslas: you have three bitrate options that concern you -- max, min and avg - you'll want them at the same value, for starters.
[16:23:28 CEST] <Kadigan> (you can tweak min/max later, when it works)
[16:23:53 CEST] <doslas> https://pastebin.com/0a4rE8tQ
[16:24:02 CEST] <doslas> this is my script
[16:24:13 CEST] <doslas> make it for me
[16:24:25 CEST] <doslas> fix it plz
[16:24:29 CEST] <Kadigan> No.
[16:24:39 CEST] <Kadigan> We can HELP you, but if you need WORK, pay for it. ;)
[16:24:43 CEST] <doslas> fix it to 320p
[16:25:33 CEST] <Nacht> first run 'ffprobe -i udp://' and tell us what it says
[16:25:57 CEST] <doslas> I've been experimenting for a week, and there's been no success.
[16:25:57 CEST] <doslas>  
[16:26:45 CEST] <doslas> Nacht ok
[16:28:17 CEST] <doslas> https://pastebin.com/zY3q6fKb
[16:28:22 CEST] <doslas> Nacht
[16:31:14 CEST] <Nacht> Thats not everything
[16:33:18 CEST] <doslas> He freezes after this.
[16:34:37 CEST] <doslas> look
[16:34:40 CEST] <doslas> https://pasteboard.co/GId4TPk.png
[16:35:05 CEST] <doslas> Nacht
[16:35:11 CEST] <Nacht> ah yeah ofc, its a stream
[16:36:41 CEST] <Nacht> The thing is, I can't think of a reason why you have to send 360p to Youtube.
[16:37:03 CEST] <Nacht> You could prolly just transmux the video without even having to transcode it
[16:37:36 CEST] <Nacht> try 'ffmpeg -i udp:// -t 00:00:01'
[16:38:01 CEST] <doslas> Because I want to be broadcasting fast when viewers slow internet owners
[16:38:02 CEST] <doslas>  
[16:39:25 CEST] <doslas> look
[16:39:26 CEST] <doslas> https://pasteboard.co/GId6Sb6.png
[16:40:07 CEST] <Nacht> afaik Youtube transcodes for you
[16:41:39 CEST] <doslas> in youtube
[16:41:42 CEST] <doslas> We are not receiving video data at a fast enough rate. Your viewers may experience buffering. Ensure your connection is fast enough or consider using a lower bitrate.
[16:41:56 CEST] <doslas> youtube says
[16:42:01 CEST] <doslas> We are not receiving video data at a fast enough rate. Your viewers may experience buffering. Ensure your connection is fast enough or consider using a lower bitrate.
[16:42:53 CEST] <Nacht> okido
[16:43:53 CEST] <Nacht> try this: https://pastebin.com/ButxUDD5
[16:44:31 CEST] <doslas> ok
[16:44:34 CEST] <Martchus> Trying to (re)mux an AVI file to Mkv without reencoding. Is this a known bug or do I just miss some CLI flag? http://paste.opensuse.org/52110957 My files seem to be fine, at least mkvmerge can handle them well.
[16:48:26 CEST] <doslas> same problem
[16:48:29 CEST] <doslas> https://pasteboard.co/GIdarpp.png
[16:48:47 CEST] <doslas> Nacht
[16:49:09 CEST] <Nacht> doslas: Could be two things. Your upload speed is crap, or your PC cant transcode fast enough
[16:49:20 CEST] <Nacht> Martchus: try with -fflags +genpts
[16:51:11 CEST] <Martchus> Nacht: Works, thanks.
[16:51:17 CEST] <doslas> Why hasn't it changed to 320p?
[16:51:17 CEST] <doslas>  
[16:51:28 CEST] <doslas> look at image
[16:51:57 CEST] <doslas> Still 720p
[16:53:15 CEST] <doslas> my upload is 50k/s
[16:57:10 CEST] <Nacht> The ffmpeg command will def output 360p
[16:57:28 CEST] <Nacht> Just write it to a local mp4  '-f mp4 test.mp4' and you will see
[16:59:39 CEST] <doslas> I'm a live feed from a file already in the home
[17:00:23 CEST] <doslas> https://pastebin.com/SNqTHrNA
[17:02:33 CEST] <Nacht> nways, gotta go
[17:04:43 CEST] <doslas> Nacht What i do?
[18:48:02 CEST] <Vlad__> Hello, everyone! Can someone please explain what this ffmpeg command does? https://pastebin.com/7rpDH1xH
[18:49:41 CEST] <Mavrik> Hmm, takes the input test.mp4, decodes it into raw video, converts it to grayscale, resizes to 1280x720 and I think drops every 3rd and 4th frame?
[18:50:03 CEST] <Mavrik> Not sure about the last part, select= selects frames to output and I'd have to check the calculation a bit more in depth
[18:50:16 CEST] <Mavrik> It outputs the result on stdout
[18:52:30 CEST] <Vlad__> @Mavrik, yes, my main misunderstanding comes from that filtergraph, does it select every 3rd and 4th? or actually pick every 3rd and 4th?
[18:52:31 CEST] <bigx> hello there
[18:53:18 CEST] <bigx> Im trying ot do ffmpeg encoding with nvenc on an ec2 g3.4xlarge instance (with a Tesla M60 gpu)
[18:53:38 CEST] <bigx> but my encoding is only 8.5fps
[18:54:02 CEST] <bigx> it seems theres something wrong
[19:00:54 CEST] <bigx> here is the command and the ffmpeg output I have
[19:01:00 CEST] <bigx> https://pastebin.com/BzmVXctK
[19:01:53 CEST] <bigx> so it seems `--enable-nvenc` is indeed here, but it seems to have no effect, Im a bit lost
[19:05:19 CEST] <jkqxz> How fast is it if you don't do all the crazy overlay stuff?
[19:05:55 CEST] <bigx> thanks for your answer jkqxz , I havent tried it yet
[19:06:04 CEST] <jkqxz> Also note that the decode of the mov file is happening on the CPU; -hwaccel is a per-stream option applying to the next input file.
[19:06:37 CEST] <bigx> oh! nice catch, I wasnt aware of that
[19:07:23 CEST] <jkqxz> Oh, but it's qtrle so there is no hardware for that anyway.
[19:07:32 CEST] <jkqxz> I think you're just doing a lot on the CPU.
[19:07:58 CEST] <jkqxz> So however fast the encode itself is it doesn't really help much.
[19:08:40 CEST] <bigx> ok, so I should first transcode my video assets to h264 first I guess
[19:09:01 CEST] <bigx> (without the crazy overlay stuff, I run it at 30fps)
[19:09:13 CEST] <kerio> i thought qtrle was quite fast
[19:10:20 CEST] <jkqxz> Maybe.  But it's 3328x1664 at 58Mbps.
[19:10:58 CEST] <doslas> Nacht
[19:11:39 CEST] <doslas> Kadigan
[19:11:56 CEST] <Kadigan> doslas: ?
[19:11:57 CEST] <bigx> yup, these are 360 videos at the end
[19:12:33 CEST] <doslas> pleas say thanks to Nacht
[19:12:36 CEST] <kerio> thats a lot of pixels ;o
[19:12:41 CEST] <doslas> yeah
[19:12:56 CEST] <kerio> bigx: encode them
[19:12:59 CEST] <kerio> IN LOSSLESS H264
[19:13:01 CEST] <kerio> MWAHAHAHAHA
[19:13:04 CEST] <bigx> oh, on this topic I was a bit disapointed to see I need an external tool to inject 360° metadata (https://github.com/google/spatial-media/tree/master/spatialmedia)
[19:13:19 CEST] <Kadigan> Pardon?
[19:13:37 CEST] <bigx> I was thinking Id be able to inject it with ffmpeg, but I had no success
[19:13:41 CEST] <doslas> every thing is work by script Nacht
[19:14:52 CEST] <Kadigan> doslas: then you should thank him; it's cool that he helped
[19:15:05 CEST] <doslas> goodbye & thank you for all
[19:15:14 CEST] <doslas> ok
[19:15:16 CEST] <Kadigan> bigx: yeah, had the same problem when I pushing 360fly videos to YT after processing
[19:15:23 CEST] <Kadigan> s/I/I was
[19:15:28 CEST] <doslas> i will be back
[19:15:53 CEST] <bigx> Kadigan: you ended up using the same tool as me? something else?
[19:16:57 CEST] <Kadigan> I recall Google has this tool... or something.
[19:17:15 CEST] <Kadigan> (I'm on a Mac, so whatever Windows tools they propose are sort of useless to me)
[19:17:17 CEST] <bigx> well, yes the one I use too https://github.com/google/spatial-media/tree/master/spatialmedia
[19:17:36 CEST] <Kadigan> If that's the Google thing, then probably that.
[19:17:42 CEST] <bigx> theres a gui and a python script
[19:17:46 CEST] <Kadigan> (I do recall it being a GUI thing)
[19:17:49 CEST] <Kadigan> Yeah, I guess.
[19:17:50 CEST] <bigx> but yes, must be it
[19:17:59 CEST] <Kadigan> Point is,
[19:18:01 CEST] <Kadigan> it didn't work.
[19:18:30 CEST] <Kadigan> Or, rather, it sort of did... but it didn't. I had to go and publish through the 360fly camera app.
[19:18:40 CEST] <Kadigan> (which injected the <correct> data)
[19:20:13 CEST] <bigx> I tried, and posting to youtbue and facebook 360 is ok now
[19:20:20 CEST] <bigx> now as yesterday
[19:20:44 CEST] <Kadigan> Okay, if you say so. I was doing spherical videos, if it matters. Well, half-spherical.
[19:21:30 CEST] <bigx> mine are spherical
[19:21:31 CEST] <Kadigan> Well, "spherical sort-of". I'm <still> not quite sure where the middle of that thing is, or why it's so distorted as to be tilted to all possible sides by one or two degrees when in its "neutral" position... but meh. Birthing pains, I assume...
[19:21:43 CEST] <bigx> true that
[19:21:56 CEST] <Kadigan> Ended up doing a lil' Photoshop overlay w/ degrees and positions,
[19:22:03 CEST] <Kadigan> so that I could do animated titles.
[19:22:12 CEST] <Kadigan> (ie. warp stuff)
[19:22:47 CEST] <Kadigan> But I feel this is getting distinctly un-ffmpeg-y. ;)
[19:22:59 CEST] <bigx> :)
[19:24:55 CEST] <Vlad__> Can someone, please, clarify what the filtergraph in this command does? https://pastebin.com/7rpDH1xH
[19:27:06 CEST] <Kadigan> Filtergraph? I'm not familiar w/ that term. Anyone?
[19:31:55 CEST] <acos> Sup
[19:34:42 CEST] <Kadigan> Vlad__: if I'm not mistaken (I'm still a bit fuzzy on the + operation), it processes 2 frames every 2 frames, so 0, 1, 4, 5, 8, 9...
[19:35:02 CEST] <durandal_1707> Kadigan: read manual to learn more
[19:36:44 CEST] <Kadigan> durandal_1707: ah, so "filtergraph" is the proper name for what I consider the processing chain
[19:36:49 CEST] <Kadigan> Okay.
[19:37:10 CEST] <Kadigan> So, Vlad__ - it resizes the video to HD and then selects 2 frames every 2 frames
[19:37:18 CEST] <Kadigan> (starting at the first)
[19:38:37 CEST] <Kadigan> That's actually fairly cool... I never considered this, but it would seem I could use an 8k source as input, and then use ffmpeg to split this into four, resize into Full HD and feed into four devices attached to displays organized as slices of the bigger picture
[19:38:38 CEST] <Kadigan> cool.
[19:43:58 CEST] <Vlad__> Kadigan, thanks for your input
[19:51:04 CEST] <dongcarl> hi all, is there an option to have ffplay automatically resume when url finishes buffering?
[19:52:23 CEST] <furq> probably don't use ffplay
[19:52:31 CEST] <furq> it's not intended to be used for anything other than testing
[19:58:07 CEST] <dongcarl> furq: got it, thanks!
[20:57:45 CEST] <dragmore_> Anyone know when lib_VMAF will be released in ffmpeg?
[20:58:11 CEST] <dragmore_> says : - libvmaf video filter in the changelog for 3.4 but cant too find it in the nightlies..
[20:59:00 CEST] <durandal_170> dragmore_: you need to compile with libvmaf lib support enabled
[21:00:56 CEST] <pgorley> hi, is there a way to estimate the bitrate based on the crf value and resolution?
[21:01:32 CEST] <klaxa> not really
[21:02:57 CEST] <klaxa> highly depends on the content
[21:03:11 CEST] <klaxa> very static content will have a lower bitrate than highly dynamic content
[21:03:19 CEST] <pgorley> makes sense
[21:03:50 CEST] <klaxa> you could take an "average" scene and do short test-encodes to vaguely estimate the bitrate for different crfs for that file
[21:06:16 CEST] <acos> What's the way to set a constant bit rate and not variable?
[21:07:22 CEST] <klaxa> -b:v 1024k will set the video bitrate to 1 megabit/s
[21:07:44 CEST] <klaxa> although i'm not sure in how far each encoder honors that
[21:08:45 CEST] <furq> acos: what codec
[21:08:58 CEST] <furq> if you want proper cbr then it depends on the encoder
[21:16:47 CEST] <dragmore_> durandal_170: Any pre-compiled windows builds with it around?
[21:22:48 CEST] <durandal_170> dragmore_: no
[21:24:18 CEST] <BtbN> freenode sure is acting weird with changing the nick before killing it
[22:28:10 CEST] <acostres> Well was trying to do x264 stuff
[22:28:49 CEST] <klaxa> cbr and h264 is a bad idea tbh
[22:29:13 CEST] <klaxa> https://trac.ffmpeg.org/wiki/Encode/H.264#CBRConstantBitRate
[00:00:00 CEST] --- Fri Sep  1 2017

More information about the Ffmpeg-devel-irc mailing list