[Ffmpeg-devel-irc] ffmpeg.log.20170904

burek burek021 at gmail.com
Tue Sep 5 03:05:01 EEST 2017

[00:03:01 CEST] <relaxed> anybody here have an aarch64 system up and running?
[00:33:44 CEST] <sarnex> hi, im trying to output raw x11grab data into a v4l2loopback device. i get an error that v4l2loopback only supports raw video, but looking at the v4l2loopback page, there is a video format for h264 and hevc and others. am i missing something here?
[00:34:10 CEST] <sarnex> pixel format i mean
[00:54:49 CEST] <relaxed> sarnex: did you try,  ffmpeg -i input -f v4l2 -y /dev/video0
[00:55:06 CEST] <sarnex> relaxed: i need to use x11grab as input, my output is v4l2
[00:55:17 CEST] <sarnex> oh sorry i mistread
[00:55:19 CEST] <sarnex> one sec
[00:56:05 CEST] <relaxed> is this reverse webrtc?
[00:56:22 CEST] <sarnex> same error
[00:56:31 CEST] <sarnex> relaxed: yeah basically i need to create a fake webcam of my screen
[00:56:46 CEST] <relaxed> pastebin the command and all output
[00:56:48 CEST] <sarnex> because skype screen share is nonexistant now i have to use another service which uses webrtc
[00:57:10 CEST] <sarnex> relaxed: https://pastebin.com/raw/xtiB14GT
[00:58:00 CEST] <relaxed> oh, I think you have to have the v4l loopback device loaded via the kernel
[00:58:09 CEST] <sarnex> yep i have it loaded
[00:58:13 CEST] <relaxed> have you done that?
[00:58:16 CEST] <relaxed> ok
[00:58:16 CEST] <sarnex> otherwise /dev/video0 doesnt exist
[00:58:22 CEST] <acos> Hmmm
[00:58:54 CEST] <relaxed> you didn't post the command
[00:59:02 CEST] <sarnex> sorry
[00:59:36 CEST] <sarnex> relaxed: https://pastebin.com/raw/xcDHTV1k
[01:00:17 CEST] <relaxed> omit "-vcodec libx264 -pix_fmt yuv420p -threads 16"
[01:00:37 CEST] <relaxed> you can't send h264 to the loopback device
[01:00:50 CEST] <sarnex> right, im asking why that is because it looks like the loopback device supports it
[01:00:51 CEST] <relaxed> webrtc will handle the encoding
[01:01:10 CEST] <sarnex> for example https://github.com/umlaeute/v4l2loopback/blob/master/v4l2loopback_formats.h
[01:05:42 CEST] <relaxed> what does the software reading /dev/video0 expect ?
[01:06:02 CEST] <sarnex> im not sure, but i dont understand why it errors
[01:06:17 CEST] <sarnex> if webrtc expects raw thats fine
[01:08:58 CEST] <relaxed> you can send anything to /dev/video0, just use -f <format or container> -y /dev/video0
[01:09:24 CEST] <sarnex> if i use h264 for the format ffmpeg gives me an error telling me its not supported
[01:09:46 CEST] <sarnex> -y has no effect
[01:10:01 CEST] <relaxed> then send it raw by omitting "-vcodec libx264 -pix_fmt yuv420p -threads 16"
[01:10:33 CEST] <sarnex> yeah im not trying to get it to work, i understand that raw works, im wondering why i cant send h264 when it looks like the output supports it
[01:10:58 CEST] <sarnex> maybe this is better for #ffmpeg-devel
[01:12:03 CEST] <ZexaronS> hello
[01:12:17 CEST] <ZexaronS> does ffmpeg support m4s ?
[01:12:28 CEST] <JEEB> that's just fragmented ISOBMFF
[01:12:29 CEST] <ZexaronS> the segments streaming
[01:12:54 CEST] <JEEB> if you want specifically DASH with segments and separated initialization segments, then just set output file name to .mpd and -f dash
[01:13:03 CEST] <JEEB> in other words, yes
[01:13:04 CEST] <ZexaronS> Trying to put them together
[01:13:52 CEST] <ZexaronS> Not sure if it's dash, it's not youtube, the magic bits start with 4sidx
[01:15:24 CEST] <JEEB> that's ISOBMFF
[01:15:34 CEST] <ZexaronS> oh ok
[01:15:36 CEST] <JEEB> (in colloquial talk "mp4")
[01:15:58 CEST] <JEEB> ("ISO Base Media File Format")
[01:16:55 CEST] <ZexaronS> but it doesn't look like a simple concat will work in this case ?
[01:17:15 CEST] <ZexaronS> I've seen other fragmented video before, which can be playable, first time coming across this
[01:18:18 CEST] <JEEB> fragmented isobmff should be concat'able in quite a few cases. just concat the start segment first ("initialization segment"), and then the rest
[01:18:42 CEST] <JEEB> only problem could be clear key encryption or DRM
[01:18:52 CEST] <ZexaronS> actually i need to output as m4a or the raw audio codec, since this is the audio I need to merge with video which I was able to get with an utility, audio wasn't detected auto so I had to manually pull the segments myself
[01:19:05 CEST] <ZexaronS> Oh no this is free, it's not paid content
[01:19:35 CEST] <ZexaronS> but pretty much everything is moving to fragmented streaming these days
[01:20:16 CEST] <JEEB> because it lets them utilize the already available CDN resources for HTTP, mostly
[01:20:23 CEST] <JEEB> as in, infrastructure
[01:21:12 CEST] <ZexaronS> the init segment states it is a mp4a audio, but no info on codec
[01:23:56 CEST] <JEEB> ffprobe can tell you the details since it contains the initialization data :P I would probably do it after I concat a few of the data fragments after it, though
[01:24:01 CEST] <JEEB> just in case
[01:24:10 CEST] <JEEB> since audio doesn't really require as much initialization data
[01:24:31 CEST] <JEEB> (compared to the parameter sets etc in AVC/HEVC)
[01:26:09 CEST] <ZexaronS> JEEB: actually I want the other way around, put segments to one file, the -f dash thing is not what I want... confusion sorry
[01:27:18 CEST] <JEEB> yes, my answers were if you wanted to output m4s which is what most people who ask like that want :P
[01:27:51 CEST] <JEEB> and in theory you could feed the files to FFmpeg as one stream of bytes, but it will not currently read the manifest and do it automatically
[01:28:13 CEST] <JEEB> and if you're gonna just feed the bytes to it you might as well just concatenate the segments yourself
[01:28:14 CEST] <ZexaronS> is the -v 40 still the max loglevel or should -loglevel verbose work, because I heard -loglevel verbose might not catch everything ... but I don't want debug level either
[01:28:21 CEST] <ZexaronS> sorry if I jumped the topic a bit
[01:28:26 CEST] <JEEB> don't use the numbers
[01:28:31 CEST] <JEEB> the log levels are documented in help
[01:28:40 CEST] <JEEB> and I've always used -v NAME
[01:28:45 CEST] <JEEB> never -loglevel
[01:29:04 CEST] <JEEB> but they might be doing the same thing
[01:29:21 CEST] <JEEB> yea, they map to the same thing
[01:30:06 CEST] <JEEB> here, have the listing http://up-cat.net/p/24daca75
[01:30:27 CEST] <ZexaronS> JEEB: What does feeding the bytes mean, and what does "yourself" mean ... sorry, when talking concatenate I'm talking about the -concat thing, but then concat must be doing something to figure out, it's just just appending data as if I would copy paste hex from all files to one
[01:31:02 CEST] <JEEB> what I'm talking about is that the segments should be just concat'able without FFmpeg being anywhere
[01:31:16 CEST] <JEEB> cat init.m4s file1.m4s file2.m4s etc
[01:32:01 CEST] <ZexaronS> oh if that's the case then much easier ... but im on windows heh need to find an utility for that, probably already have one but never needed the feature
[01:32:58 CEST] <JEEB> copy /b seems to do something similar :P
[01:33:05 CEST] <ZexaronS> seems like it yeah
[01:33:37 CEST] <JEEB> just remember to put the initialization segment first and it should already be readable by ffprobe
[01:33:49 CEST] <JEEB> then after you get the first segment in, it should show some decoded audio
[01:37:02 CEST] <ZexaronS> uh it didn't work well without /b, outputed like 1.2 MB, but with /b it's not working either, it's the right size that's expected, but MPC-HC can't play it
[01:37:19 CEST] <ZexaronS> plus, from the looks if it, im not sure if it was going alphabetical order
[01:37:29 CEST] <ZexaronS> it could be broken even if it did play
[01:37:40 CEST] <JEEB> yea, if you didn't specify the file names :P
[01:38:03 CEST] <ZexaronS> well ofcourse because there's 1500 of them
[01:38:12 CEST] <ZexaronS> so i have to use a list or *.m4s
[01:38:18 CEST] <JEEB> scripting, ho
[01:38:26 CEST] <JEEB> that's why I said you should just put the audio stream's initialization segment first, then a single audio fragment
[01:38:31 CEST] <JEEB> that way you could have checked it
[01:38:41 CEST] <JEEB> with both ffprobe and if something was weird, with ffmpeg etc
[01:38:43 CEST] <JEEB> :P
[01:39:14 CEST] <ZexaronS> well, I'm used to doing fiddly diddly stuff manually that can take hours but need to figure out something here
[01:40:15 CEST] <ZexaronS> I was using excel to generate the iterated URL links, pasted results to Sheet2, exported to TXT, put that into a downloader, i could do the same to segment-1, segment-2, export that as .txt and find somethign that accepts a list then
[01:40:17 CEST] <JEEB> that's why I'm fucking telling you to start with the audio stream's init segment
[01:40:22 CEST] <JEEB> and then single audio fragment
[01:40:22 CEST] <JEEB> :V
[01:40:30 CEST] <JEEB> that way you can test if the shit works
[01:40:40 CEST] <ZexaronS> What does this init segment look like?
[01:40:42 CEST] <JEEB> if that works, then you can start working on your further concatenation
[01:40:52 CEST] <JEEB> it's marked in the DASH xml manifest as such
[01:41:10 CEST] <ZexaronS> there's no DASH xml manifest
[01:41:25 CEST] <JEEB> where there has to be something to control the player :P
[01:41:26 CEST] <ZexaronS> there's only master.json with a list of segments filenames
[01:41:35 CEST] <JEEB> also if this is something usually used then just fucking use youtube-dl
[01:41:39 CEST] <JEEB> which supports most of them fucking sites
[01:41:48 CEST] <ZexaronS> Oh, I'm not controlling any player, I'm pulling from remote
[01:41:56 CEST] <JEEB> I *know*
[01:42:06 CEST] <ZexaronS> It doesn't work, because it doesn't detect audio links
[01:42:15 CEST] <JEEB> youtube-dl?
[01:42:29 CEST] <ZexaronS> I got it down without having to deal with fragments, but video only
[01:42:56 CEST] <JEEB> anyways, I mean the motherfucking thing be it json or XML should have the initialization segment info *somewhere*, otherwise the motherfucking thing wouldn't be playable
[01:43:23 CEST] <ZexaronS> Indeed it might work with youtube-dl, but I'm way not experienced with it yet, I simply got the fragments down to be on the safe side while I take days/weeks to figure out youtube-dl
[01:43:23 CEST] <JEEB> it's possible for the first segment to be an init segment as well, but I generally don't see it being used
[01:43:33 CEST] <JEEB> uhh
[01:43:48 CEST] <ZexaronS> Yes there is an init_segment part and it's gibberish ... I tried to put it in URL but it said bad requesr or 404
[01:43:52 CEST] <ZexaronS> request*
[01:44:12 CEST] <JEEB> youtube-dl is literally `youtube-dl -F "URL"` to list all available formats (default is the highest quality shit), and `youtube-dl "URL" to dwnload that`
[01:44:15 CEST] <ZexaronS> the init_segment name is a very long string "ifdhsidsdsds8d//dsd7cd7dxxcsx7dc"
[01:44:40 CEST] <JEEB> it will save both you and me time if you just use motherfucking youtube-dl if it supports your fucking site
[01:45:39 CEST] <ZexaronS> I did tried all day, well, after a few attemtps i didn't bang my head on the wall ofcourse so I want another path, I'll try again
[01:45:55 CEST] <ZexaronS> I went another path*
[01:46:17 CEST] <JEEB> just make sure you have the newest youtube-dl, they release pretty often (and smetimes the sites change and that hasn't been yet updated to the app)
[01:46:23 CEST] <JEEB> in which case oyu go report an issue to them
[01:46:34 CEST] <JEEB> because I don't want to start telling you how to do base64 etc to get the init segment from that custom JSON shit, you know. it's not worth my fucking time if there
[01:47:11 CEST] <JEEB> esp. if youtube-dl supports that fucking site
[01:48:46 CEST] <ZexaronS> The first time I tried youtube-dl a couple of times in morning I didn't yet know as much, I didn't tried pointing to the master.json, doesn't work with only base url (cannot send HEAD request)
[01:49:02 CEST] <JEEB> youtube-dl generally takes in the normal URLs
[01:49:07 CEST] <JEEB> as in, what the browser would access
[01:49:34 CEST] <JEEB> then it accesses where needed to get the required information
[01:50:05 CEST] <ZexaronS> yeah the base url simply reports "not found" but it is actually connecting to a server, it's not a browser error, it's some server response
[01:51:37 CEST] <ZexaronS> okay i pointed it to master.json and it had same HEAD error and said "treating it as a generic webpage" extracging .. so it just downloaded master.json
[01:52:06 CEST] <ZexaronS> it said 403 Forbidden when trying to send HEAD request
[01:57:00 CEST] <ZexaronS> Okay i'll move this talk to youtube-dl but ... I tried all known url combinations and it's either 404 or 403, it does report the segment-1, but that's just one segment, it's not detecting the full thing
[02:59:45 CEST] <ZexaronS> JEEB: finally solved this thing omg it was a circus for an hour, I think I reinstalled python 3 times, did a buch of stuff, this worked https://github.com/alexeygrigorev/vimeo-download - I had to physicaly remove the video part def# from the script so it would just handle URL, I don't know what the script does yet, but it seems to be recoding the m4s audios to a mp3 file with ftypiso5 mp41, codec is AAC as expected, .mp3 might just
[02:59:46 CEST] <ZexaronS> be script bug
[03:00:25 CEST] <ZexaronS> but the point is, the audio is in one file ... it's being generated while segments are downloading and it works playable fine, MISSION SUCCESS this was one big day 3 AM asta lavista baby
[04:22:19 CEST] <ZexaronS> python is ridicolous, doesn't work if I run batch file, but it works if I paste the whole same command into an already open CMD, python probably is one of the most weird things ever for windows, it's just not meant to be on windows
[04:22:37 CEST] <ZexaronS> spent 30 minutes figuring this out, annoying as crap
[04:23:04 CEST] <ZexaronS> I lose so much time when i have to deal with python, the whole thing has been POS as long as I know it
[04:36:59 CEST] <acos> Rip.  ZexaronS sounds like it's not in the path variable.
[04:37:32 CEST] <ZexaronS> actually i was using the direct "C:program files -...exe" the whole time
[04:37:39 CEST] <ZexaronS> it pust out some error in module
[04:38:15 CEST] <ZexaronS> it runs and throws some traceback error on "resp.json" that the script is using
[04:38:55 CEST] <acos> Ooooo. Never used python
[04:38:58 CEST] <ZexaronS> jsondecoder error
[04:42:27 CEST] <ZexaronS> https://pastebin.com/RCUceGGJ
[05:46:26 CEST] <cryptodechange> Finally getting around to encoding IVTC dvd stuff
[05:46:39 CEST] <cryptodechange> using -vf fieldmatch,yadif=deint=interlaced,decimate, I get
[05:46:50 CEST] <cryptodechange> [Parsed_fieldmatch_0 @ 0x493d220] Frame #274 at 9.142 is still interlaced
[05:46:55 CEST] <cryptodechange> every now and then
[05:55:02 CEST] <cryptodechange> doing some googling, it seems that's what yadif is there for? to deinterlace any leftovers?
[08:38:10 CEST] <mozzarella> guys
[08:38:16 CEST] <mozzarella> is there anyone using windows in here?
[08:38:37 CEST] <dystopia_> yep
[08:39:41 CEST] <mozzarella> dystopia_: with mpv I can move forward/backward in a video, of one minute using the top and bottom arrow keys, and 5 seconds using the left and right arrow keys, is there anything like that with windows media player?
[08:40:27 CEST] <dystopia_> i havent used windows media player in over a decade
[08:40:40 CEST] <dystopia_> i use media player classic
[08:40:46 CEST] <mozzarella> does it still exist? is it the default player on windows 10?
[08:40:51 CEST] <dystopia_> im sure windows media player has shortcuts though
[08:41:01 CEST] <mozzarella> what's that
[08:41:02 CEST] <dystopia_> no, you have to install it
[08:41:07 CEST] <mozzarella> is that the one using the old gui
[08:41:20 CEST] <dystopia_> https://mpc-hc.org/
[08:41:41 CEST] <mozzarella> how do you watch videos on windows 10, then?
[08:42:18 CEST] <dystopia_> im on windows 7 and use media player classic
[08:42:27 CEST] <dystopia_> it also workd on 10 or any other version of windows
[08:43:18 CEST] <dystopia_> windows media player was a bloated mess the last time i looked at it
[08:43:23 CEST] <dystopia_> which was probably in win xp
[08:43:30 CEST] <dystopia_> i doubt it has improved since
[11:55:53 CEST] <next> Hey. I need to encode a video with rounded edges, which team does this? https://s26.postimg.org/6phtyllah/image.png
[12:07:03 CEST] <sagax> hi all!
[12:07:24 CEST] <sagax> how to convert x264 video to best images?
[12:07:51 CEST] <sagax> Stream #0:0: Video: h264 (Main), yuv420p, 1920x1080, 24.17 fps, 24 tbr, 1200k tbn, 48 tbc
[12:12:21 CEST] <klaxa> next: maybe you can use a transparent image with rounded corners as an overlay filter
[12:12:35 CEST] <klaxa> sagax: what are "best images"?
[12:14:09 CEST] <sagax> like as this ffmpeg -i video.h264 output_%d.jpg  but with best quality to image
[12:14:15 CEST] <klaxa> use png
[12:14:57 CEST] <sagax> to divide into frames
[12:15:38 CEST] <sagax> with minimum frame size as possible with best quality
[12:15:49 CEST] <klaxa> use png and then use a png optimizer
[12:16:31 CEST] <klaxa> png is lossless, so the frames will be pixel-perfect
[12:19:41 CEST] <sagax> ok, thanks, but how to divide to frame?
[12:19:50 CEST] <sagax> frames*
[12:20:19 CEST] <klaxa> it will output every frame as a single png
[12:20:32 CEST] <klaxa> is that not what you want?
[12:21:00 CEST] <mannasty> anyone here
[13:22:02 CEST] <velix> Is there a secure way to create an MP4 without audio? I've often seen players go insane without audio.
[13:22:30 CEST] <velix> maybe just with silence at lowest AAC compression rate?
[13:22:36 CEST] <velix> eehe lowest AAC bitrate
[13:25:03 CEST] <DHE> avfilter anullsrc can generate a silent audio stream which you can compress at low bitrate
[13:27:16 CEST] <velix> DHE: thanks. What's the lowest bitrate allowed in internal AAC encoder?
[13:30:02 CEST] <velix> How do I use anullsrc correctly? I tried -af
[13:30:20 CEST] <DHE> -filter_complex anullsrc[silence]   -map [silence] -map [0:v]
[13:30:31 CEST] <velix> oops thx
[13:30:54 CEST] <DHE> oops, -map 0:v  (no [braces])
[13:31:16 CEST] <velix> DHE: thx
[13:32:10 CEST] <velix> DHE: can I set =48000:mono ?
[13:33:03 CEST] <velix> DHE: maybe  -i anullsrc=r=48000 ?
[13:33:33 CEST] <velix> ah anullsrc=r=48000:cl=mono ?
[13:43:35 CEST] <velix> That's my complete line: ffmpeg -y -hide_banner -i "mov\01.mp4" -vf "scale=1280:720:force_original_aspect_ratio=decrease,pad=1280:720:(ow-iw)/2:(oh-ih)/2" -c:v libx264 -crf 23 -preset fast -framerate 25 -pix_fmt yuv420p -filter_complex anullsrc=r=11025:cl=mono[silence] -map [silence] -map 0:v -c:a aac -b:a 1k -ac 1 01.mkv
[13:44:15 CEST] <velix> illarbox/Letterbox to 720p + silence
[13:44:22 CEST] <velix> pillarbox
[13:45:57 CEST] <velix> Interesting, there seems to be a problem. It's stuck at Frame 2371 and encodes it since about 4 minutes now.
[13:46:16 CEST] <velix> the speed increses to 300x
[13:46:20 CEST] <velix> now it's 303
[13:46:41 CEST] <velix> now 400
[13:47:41 CEST] <velix> It doesn't like silence as it seems.
[14:11:25 CEST] <velix> Seems to be a bug.
[14:14:24 CEST] <Nacht> Cropping and scaling video so it fits on instagram (1080x1350) makes me feel so dirty
[14:16:05 CEST] <velix> Nacht: as long as the images aren't dirty, Instagram will accept it ;)
[14:16:16 CEST] <Nacht> I just hate vertical video :/
[14:16:44 CEST] <velix> Nacht: People are taller than wider, why use widescreen then. I don't care about the people around my girlfriend.
[14:31:28 CEST] <velix> Yeah, found a bug.
[14:31:54 CEST] <velix> "-filter_complex anullsrc" runs endless when not adding -shortest
[14:38:48 CEST] <durandal_1707> velix: thats not bug
[14:39:07 CEST] <velix> durandal_1707: but it's not an expected behavior.
[14:40:07 CEST] <durandal_1707> velix: really? for what?
[14:40:31 CEST] <velix> durandal_1707: Actually, I would expect it to stop, after the video has been processed. Just like a normal filter.
[14:41:14 CEST] <durandal_1707> use shortest
[14:41:26 CEST] <durandal_1707> anullsrc never endds
[14:42:47 CEST] <velix> durandal_1707: yeah, works fine with -shortest.
[14:51:51 CEST] <velix> durandal_1707: Do you like my line for pillar- and letterbox? ffmpeg -y -hide_banner -i "mov\01.mp4" -vf "scale=1280:720:force_original_aspect_ratio=decrease,pad=1280:720:(ow-iw)/2:(oh-ih)/2" -c:v libx264 -crf 23 -preset fast -framerate 25 -pix_fmt yuv420p -filter_complex anullsrc=r=11025:cl=mono[silence] -map [silence] -map 0:v -c:a aac -b:a 1k -ac 1 -shortest 01.mkv
[14:53:37 CEST] <durandal_1707> its fine from quick look
[14:54:17 CEST] <velix> durandal_1707: Also works nice. I love ffmpeg
[15:05:37 CEST] <velix> Hmm, shouldn't this work? I'm getting a big file, but I can see the png only.
[15:05:37 CEST] <velix> ffmpeg -i "concat:01.png|01.mkv" -c copy output_video.mp4
[15:09:52 CEST] <velix> need concat filter as it seems
[15:11:44 CEST] <velix> also doesn't work: ffmpeg -loop 1 -framerate 25 -t 3 -i 01.png -t 3 -f lavfi -i aevalsrc=0 -i 01.mkv -filter_complex '[0:0] [1:0] [2:0] [2:1] concat=n=2:v=1:a=1' -movflags faststart 01.mp4
[15:21:31 CEST] <velix> Got it: ffmpeg -r 25 -loop 1 -t 3 -i 01.png -i 01.mkv -f lavfi -t 3 -i aevalsrc=0 -filter_complex "[0:v] [2:a] [1:v] [1:a] concat=n=2:v=1:a=1 [v] [a]" -c:v libx264 -c:a aac -map "[v]" -map "[a]" 01.mp4
[15:22:00 CEST] <velix> nah, this reencodes anything :(
[15:24:51 CEST] <velix> Is this even possible?
[15:25:39 CEST] <velix> Do I need to convert the image to video firsT?
[15:27:36 CEST] <durandal_1707> yes, concat demuxer wotks only with same codecs
[15:28:21 CEST] <velix> durandal_1707: okay
[15:30:42 CEST] <velix> durandal_1707: ffmpeg -i 01.png -loop 1 -framerate 25 -t 3 -c:v libx264 -crf 23 -preset fast -framerate 25 -pix_fmt yuv420p -filter_complex anullsrc=r=11025:cl=mono[silence] -map [silence] -map 0:v -c:a aac -b:a 8k -ac 1 -shortest 01_title.mkv
[15:30:55 CEST] <velix> durandal_1707: this doesn't create a three second video :(
[15:31:55 CEST] <velix> durandal_1707: DONT ANSWER - found the bug
[15:32:01 CEST] <velix> eeh my failure
[15:32:31 CEST] <durandal_1707> yeah, try loop filter to loop single images
[15:34:51 CEST] <velix> durandal_1707: the order was wrong ;)
[15:40:55 CEST] <velix> durandal_1707: when concating two mkvs with same codec to MP4, why does it do a reeconde?
[15:41:55 CEST] <velix> oh hell, I need concat demuxer
[15:42:02 CEST] <durandal_1707> velix: yes
[15:42:23 CEST] <velix> durandal_1707: does this work on file level only? (input.txt)
[15:43:35 CEST] <durandal_1707> read documentation
[15:44:11 CEST] <velix> :(
[15:44:12 CEST] <velix> ok
[16:49:37 CEST] <Eldarko> Alloha! Could anyone give me a link to an explanation of ffmpeg writing files with timestamp in a future?
[16:50:29 CEST] <Eldarko> i mean EXT-X-PROGRAM-DATE-TIME
[17:41:44 CEST] <Eldarko> Oh, i got disconnected. Did anyone answer my question about time in ffmpeg-generated playlist?
[17:42:40 CEST] <c_14> No, but you might want to read the hls spec
[17:45:06 CEST] <c_14> https://tools.ietf.org/html/draft-pantos-http-live-streaming-23#section-
[17:45:09 CEST] <Eldarko> I did read it multiple times, can you specify spec page or something?
[17:45:55 CEST] <c_14> the one I just linked
[17:46:10 CEST] <JEEB> (the link contains a reference to a section)
[17:50:49 CEST] <Eldarko> Yep, thank you, except it does not help ) we have a same hls_time set for every instance, and on some cameras segment length in ±19seconds
[17:51:08 CEST] <Eldarko> is*
[17:53:16 CEST] <Eldarko> so instead of target time of 10 seconds we get from 13-19 seconds segments
[18:03:35 CEST] <sunny26> I have used value of reordered_opaque of avctx in av_frame in my custom hardware decoder. I am missing last frame of my video. can anyone please help ?
[18:04:36 CEST] <sunny26> I saw some of the example and none have used reordered_opaque in their decoder.
[18:05:05 CEST] <sunny26> I am too much stuck and confused.
[18:05:23 CEST] <sunny26> what should I do to make sure that my whole video plays perfectly
[18:05:33 CEST] <sunny26> Please help...
[18:08:14 CEST] <JEEB> sunny26: if you are developing a decoder module within avcodec then you should poke the -devel channel.
[18:37:13 CEST] <next> <next> Hey. I need to encode a video with rounded edges, which team does this? https://s26.postimg.org/6phtyllah/image.png
[18:37:13 CEST] <next> <sagax> hi all!
[18:43:03 CEST] <kepstin> next: not sure what you're asking
[18:43:16 CEST] <kepstin> next: what do you mean by "team"?
[18:44:36 CEST] <next> How to make the edges of video rounded? ffmpeg -i test.mkv ????
[18:45:52 CEST] <kepstin> next: you'll have to describe better what you want to do. What does your input look like? What do you want the output to look like?
[18:47:16 CEST] <kepstin> the picture you posted looks like a telecine of a misaligned film
[18:50:56 CEST] <next> http://pix.toile-libre.org/upload/original/1504543822.png
[18:52:50 CEST] <next> How to make edges round?
[18:53:05 CEST] <kepstin> the edges are already round in that picture...
[18:53:31 CEST] <next> This is an example of what I need.
[18:54:07 CEST] <alqemyst> Hi, does anybody has experience with nvenc and cuvid? My kernel is breaking after some uptime. All suggestion are more than welcome.
[18:54:30 CEST] <c3-Win> next: that's called loading your footage into a video editor and applying an effect... or you could create an overlay image and see if ffmpeg will apply it the way you want to.
[18:54:35 CEST] <BtbN> "your kernel is breaking"?
[18:54:38 CEST] <kepstin> oh, so you have a rectangular video source, and you want to apply a rounded corner film effect to it?
[18:54:39 CEST] <BtbN> Update it and the driver I'd say.
[18:55:23 CEST] <next> <c3-Win> ????
[18:55:32 CEST] <alqemyst> I'm using latest nvidia driver 384.69 and latest cuda toolkit with Debian Jessie stock kernel
[18:55:34 CEST] <kepstin> next: the easiest way to do that with ffmpeg is to make a transparent png the same size as your video frame with black to mask out the corners, then use the overlay filter to draw it over the frame.
[18:57:04 CEST] <next> <kepstin> All right. Is this the simplest solution?
[18:58:11 CEST] <next> Thenks kepstin.
[18:58:12 CEST] <alqemyst> this is what I mean by "breaking"
[18:58:24 CEST] <kepstin> using ffmpeg, i think so. If you're using a pro video editing suite they might just have a vignette effect you can apply
[18:58:28 CEST] <alqemyst> Sep  3 13:32:06 test-pc kernel: [2241066.865607] general protection fault: 0000 [#1] SMP
[18:58:40 CEST] <alqemyst> Sep  3 13:32:06 test-pc kernel: [2241066.866195] CPU: 4 PID: 5939 Comm: ffmpeg Tainted: P           O  3.16.0-4-amd64 #1 Debian 3.16.43-2+deb8u2
[18:58:58 CEST] <alqemyst> Sep  3 13:32:06 test-pc kernel: [2241067.031444] Fixing recursive fault but reboot is needed!
[18:59:01 CEST] <next> kepstin ffmpeg
[18:59:19 CEST] <alqemyst> after that system is unusable without hard reset
[19:02:33 CEST] <BtbN> The CUDA toolkit does not matter. It's not used.
[19:02:58 CEST] <BtbN> Looks like a driver bug to me
[19:03:07 CEST] <BtbN> Or a system instability.
[19:03:54 CEST] <alqemyst> it is latest ffmpeg cloned
[19:04:06 CEST] <BtbN> ffmpeg has no influence at that low level.
[19:04:18 CEST] <BtbN> If it hangs/crashes your Kernel, that's on the driver.
[19:04:37 CEST] <alqemyst> what I noticed is when I'm using cuvid decoder it happends
[19:04:44 CEST] <alqemyst> also libnpp
[19:04:56 CEST] <alqemyst> nvenc works perfectly all the way
[19:06:01 CEST] <alqemyst> when this message occurs in syslog, ffmpeg process goes into zombie state, it can't be killed
[19:06:23 CEST] <alqemyst> only hard reset will help
[19:06:44 CEST] <alqemyst> maybe I could try newer kernel?
[19:07:39 CEST] <BtbN> An older one would probably be more likely to help.
[19:11:13 CEST] <alqemyst> do you know which kernel version works best with nvidia, if this matters at all
[19:15:05 CEST] <BtbN> Whatever doesn't crash I guess
[19:15:38 CEST] <alqemyst> thanks
[19:40:50 CEST] <ChocolateArmpits> next you should look into avisynth or maybe vapoursynth, generally any programmatic video processing happens easier there
[19:43:18 CEST] <durandal_1707> vs and avs is crap
[20:02:14 CEST] <ChocolateArmpits> what a brave statement
[20:04:16 CEST] <durandal_1707> it even overlay cant do properly
[20:11:17 CEST] <ChocolateArmpits> Is there something hard about extracting alpha?
[20:19:29 CEST] <durandal_1707> ChocolateArmpits: no, its very slow
[20:20:22 CEST] <ChocolateArmpits> unthreaded avisynth is, multithreaded totally not
[20:22:51 CEST] <durandal_1707> mt have nothing to do with overlay
[20:23:20 CEST] <durandal_1707> it builds mask for whole frame
[20:38:44 CEST] <apus> hi, i'm trying to understand how ffmpeg with nvidia hardware acceleration is supposed to work. i found this https://developer.nvidia.com/ffmpeg  there is the following command: ffmpeg -hwaccel cuvid -c:v h264_cuvid -i <input.mp4> -vf scale_npp=1280:720 -c:v h264_nvenc <output.mp4>  -c:v is present twice, does the first with -hwaccel mean, that both decoding and encoding is hardware accelerated and otherwise only encoding would be hardware
[20:38:46 CEST] <apus> accelerated?
[21:02:17 CEST] <kepstin> apus: yes, many ffmpeg options have meaning based on their position. options before the input file apply to the input/decoder and options before the output file apply to the output/encoder
[21:03:37 CEST] <apus> kepstin: thank you!
[21:19:06 CEST] <apus> if transcoding a h264 encoded video to hevc using hevc_nvenc i can't use crf afaik. online i found the following suggestion: -c:v hevc_nvenc -preset llhq -rc:v vbr_minqp -qmin:v 19 -qmax:v 21 -b:v 2500k -maxrate:v 5000k -profile:v main  the original bitrate was 5500kb/s. this produced 5400kb/s and the video file was not really smaller in the end. are there suggestions how i should set the bitrate/options relative to the input file in x264 to get
[21:19:07 CEST] <apus> the "best" quality/size result?
[21:20:05 CEST] <BtbN> crf is a libx264 specific thing.
[21:20:34 CEST] <BtbN> also, transcoding h264 to hevc with hevc_nvenc is a highly questionable effort
[21:20:53 CEST] <BtbN> the input h264 is most likely going to look better at the same bitrate
[21:21:10 CEST] <kepstin> yeah, if the source h264 was done with good software encoder like x264.
[21:22:23 CEST] <apus> is hevc_nvenc not as good as the non-hardware accelerated version?
[21:24:05 CEST] <furq> if by that you mean x265 then no, it isn't
[21:24:13 CEST] <furq> it's not even as good as x264 really
[21:28:01 CEST] <BtbN> nvenc is not only hardware accelerated. It's a pure hardware encoder.
[21:28:05 CEST] <BtbN> They are bad, but fast.
[21:28:15 CEST] <apus> i have mts files from a video camera that i need to heavily compress. therefore i thought of hevc. as it takes quite a while to transcode i thought of using hardware acceleration. any suggestions?
[21:28:42 CEST] <apus> is there a hardware accelerated version, that is "good" and a bit faster than the pure software version?
[21:28:46 CEST] <BtbN> no
[21:29:08 CEST] <BtbN> If you want quality, x264 or x265 it is.
[21:30:17 CEST] <apus> ok, thank you all for your help!
[21:38:44 CEST] <PornBlog> can ffmpeg output a delta-sigma modulated signal?
[21:39:58 CEST] <durandal_1707> PornBlog: what signal?
[21:40:12 CEST] <PornBlog> audio
[21:41:04 CEST] <PornBlog> delta-sigma modulated NTSC would be quite impressive, tho
[21:41:32 CEST] <PornBlog> (but I don't think I have the storage for that)
[21:44:15 CEST] <durandal_1707> PornBlog: i still have no slightest idea is what you want
[21:44:30 CEST] <PornBlog> https://en.wikipedia.org/wiki/Delta-sigma_modulation
[21:45:15 CEST] <PornBlog> I wanna take 44.1kHz unsigned 8-bit PCM audio and output 441kHz 1-bit delta-sigma audio
[21:46:35 CEST] <durandal_1707> it  would still be digital?
[21:46:47 CEST] <PornBlog> yes, delta-sigma is digital
[21:47:12 CEST] <PornBlog> but that lets me shove it straight into my arduino, and then straight into an H-bridge, and then straight into a speaker
[21:47:51 CEST] <PornBlog> ... with some low-pass filtering
[21:48:12 CEST] <PornBlog> in other words I get to make my own hi-fi speaker
[22:35:20 CEST] <kepstin> ffmpeg has some "decoders" for DSD, a delta-sigma modulation format, but I don't think it has any encoders.
[23:01:40 CEST] <grublet> isn't DSD typically like, 2.6MHz sampling?
[23:01:43 CEST] <grublet> something like that
[23:24:21 CEST] <truexfan81> does ffmpeg master not have the dering filter listed here https://ffmpeg.org/ffmpeg-filters.html ? "[ffmpeg] No such filter: 'dering'"
[23:25:50 CEST] <BtbN> I don't see a dering filter listed on that page either.
[23:26:33 CEST] <truexfan81> i went to that page, hit ctrl+f typed in dering, its the 8th result
[23:26:47 CEST] <BtbN> That's a parameter to another filter, not a filter.
[23:27:28 CEST] <BtbN> Bit of a special case though, as it's for the libpostproc filter.
[23:30:30 CEST] <truexfan81> works, thanks
[23:39:52 CEST] <Soni> grublet: remember to compare bitrate not samplerate
[23:44:53 CEST] <markmedes2> Friends subtitle burning is not working. ffmpeg version 3.3.3. command ffmpeg -i guay.jpg -i audio.mp3 -r 1 -c:a copy -vf subtitles=zurda.srt output5.avi
[23:45:07 CEST] <markmedes2> any ideas?
[23:50:23 CEST] <markmedes2> it burns the very first subtitle but stays stuck with it, won't move to the next
[23:56:27 CEST] <klaxa> markmedes2: does it encode more than one frame?
[23:56:35 CEST] <markmedes2> yes
[23:57:30 CEST] <markmedes2> it encodes the whole video, but the subtitle is stuck at the first entry
[23:57:42 CEST] <klaxa> can you try adding -loop 1 before -i guay.jpg and use -shortest ?
[23:58:03 CEST] <markmedes2> yep, I tried that, but it will loop forever
[23:58:09 CEST] <markmedes2> ah
[23:58:10 CEST] <markmedes2> ok
[23:58:14 CEST] <markmedes2> shortest, didn't see that
[00:00:00 CEST] --- Tue Sep  5 2017

More information about the Ffmpeg-devel-irc mailing list