[Ffmpeg-devel-irc] ffmpeg.log.20170909

burek burek021 at gmail.com
Sun Sep 10 03:05:01 EEST 2017

[00:23:07 CEST] <m4t> hi, am am recording an h.264/pcm_mulaw stream to .mkv with -acodec flac -vcodec copy. i see a lot of '[matroska @ 0x568d23b820] Non-monotonous DTS in output stream 0:1;...' during recording. i tested alac instead of flac, and it doesn't do it at all. is that a limitation of flac (i guess when the framerate varies?) or is there something i can do to make it not give those warnings?
[00:31:40 CEST] <m4t> hmm...actually. my testing may be flawed. it's not doing it with flac at the moment, either. :(
[00:32:16 CEST] <m4t> wait..there it went :) heh. i need to run alac for longer to see if it's really not an issue there, though.
[00:41:38 CEST] <m4t> ok. so i fired up 4 instances of ffmpeg recording flac, and another 5 recording alac. the flac ones were outputting the 'Non-monotonous DTS in output stream' frequently (once every few seconds?) but the alac ones are silent. it looked like i was able to trigger it by turning the infrared on/off on the camera, which changes the framerate from 15/10fps, respectively. the messages seemed to stop when i turned
[00:41:40 CEST] <m4t> off the lights back off, and thus the camera exited infrared mode.
[03:23:28 CEST] <redrabbit> well. all i needed was -qp 21 -maxrate 4500k
[03:25:58 CEST] <redrabbit> well, i guess i need vbr for maxrate
[04:12:04 CEST] <lunaaa> Hi :)
[04:12:41 CEST] <lunaaa> I'm getting this error trying to run ffmpeg -i infile.mkv -codec copy outfile.mp4 and with -acodec copy -vcodec copy instead
[04:12:43 CEST] <lunaaa> Unrecognized option 'acodec copy'.
[04:13:00 CEST] <lunaaa> What's causing that?  Ubuntu 16.04.3
[04:13:07 CEST] <lunaaa> is there a package i'm missing, or...?
[04:23:27 CEST] <lunaaa> i'm using it programatically from golang
[04:23:38 CEST] <lunaaa> i think it's to do with how the arguments are passed to ffmpeg
[04:40:01 CEST] <Diag> For everyone on the suncoast (like me) http://tyronesbeefarm.com/images/2017231739.jpg\
[04:40:10 CEST] <Diag> well i screwed that up
[04:40:12 CEST] <Diag> http://tyronesbeefarm.com/images/2017231739.jpg
[04:40:18 CEST] <Diag> ignore the extra slash :(
[04:46:13 CEST] <commande`> i'm using an older version of ffmpeg and I'm trying to encode with aac codec but I get an error about it being experimental. i suspect this is something that maybe could be set with AVOptions, with strict or experimental flags. i'm not exactly sure where to start. any pointers?
[04:47:17 CEST] <Diag> commande`: is there any specific reason youre using old ffmpeg?
[04:48:16 CEST] <commande`> i'm using humble-video and it uses older ffmpeg
[04:49:05 CEST] <commande`> from what i've read the newer versions of ffmpeg dont mark aac as experimental
[04:51:43 CEST] <redrabbit> allright... -c:v h264_nvenc -b:v 4000k -maxrate 4500k -rc vbr_2pass -rc-lookahead 32
[04:51:52 CEST] <redrabbit> this is the best so far
[04:52:19 CEST] <redrabbit> image is crisp, it doesnt go above 4.8M
[04:56:36 CEST] <redrabbit> seems like maxrate has no effect though
[04:59:13 CEST] <commande`> nevermind. i ended up getting it to work
[04:59:33 CEST] <commande`> i was trying to set flag on muxer and i should've been doing it to encoder
[05:14:52 CEST] <redrabbit> in fact maxrate works
[05:15:05 CEST] <redrabbit> wew. took me a while to get it right
[06:24:46 CEST] <kepstin> lunaaa: I assume the api you're using takes a list of strings? It has to be "-acodec", "copy" not "-acodec copy"
[06:25:26 CEST] <lunaaa> i'm not using an API, i'm executing the shell command programatically
[06:25:29 CEST] <lunaaa> and yes it does
[06:25:32 CEST] <lunaaa> and i was using that
[06:26:25 CEST] <lunaaa> for some reason "-i infile", "-i", "infile", "-codec", "copy", "outfile" works but not with only "-i", "infile", "-codec", "copy", "outfile"
[06:26:31 CEST] <lunaaa> that's what i'm using at present
[06:26:37 CEST] <lunaaa> (first one)
[06:27:11 CEST] <lunaaa> https://www.irccloud.com/pastebin/ypNNoFoZ/
[06:32:26 CEST] <kepstin> line 12 you have a + which should be a ,
[06:32:57 CEST] <kepstin> (and remove the space after the -i)
[08:06:54 CEST] <thebombzen> I have some video that was de-interlaced rather than inverse telecined (I believe) so it's got two problems: it's 30 fps but every 5th frame is duplicated, and also there's deint artifacts (whoever deinterlaced it probably did a poor job)
[08:07:43 CEST] <thebombzen> I can fix the first problem with -vf decimate=5,dejudder=4, but I'm not sure what to do about the second one. I'm considering interlacing it to get it back to where it was, and then applying inverse telecine properly.
[08:08:33 CEST] <thebombzen> this is what I mean by de-interlacing artifacts: https://0x0.st/R5r.png
[08:31:35 CEST] <furq> thebombzen: qtgmc does a decent job of repairing deinterlacing artifacts
[08:31:59 CEST] <furq> those look particularly bad though
[08:33:11 CEST] <furq> that sort of looks like the artifacts were present when this was upscaled
[10:33:42 CEST] <thebombzen_> furq: I'm going to find a new source on this :P
[10:33:49 CEST] <thebombzen_> so apparently it's also crazy Unsharped
[10:35:19 CEST] <thebombzen_> look at this stupid unsharp masking http://0x0.st/R5w.png
[10:35:43 CEST] <thebombzen_> this is what happens when you let normies encode video
[10:53:52 CEST] <furq> lol
[10:53:55 CEST] <furq> what's the source of tht
[15:05:32 CEST] <Cracki> that's not so bad...
[15:07:39 CEST] <Cracki> at least the height isn't a prime number
[15:53:39 CEST] <Commander_Cody> How do you generate thumbnails for videos? I tried `ffmpeg -i inputfile -vf  'select=gt(scene,0.25)' -vsync vfr -vframes 20 inputfile_thumbnail_%02.png`
[15:54:06 CEST] <Commander_Cody> The results are not as spectacular as I'd like.
[15:58:12 CEST] <BtbN> by using the thumbnail filter
[15:58:51 CEST] <BtbN> and no idea what spectacular things you expect to happen?
[16:14:15 CEST] <Commander_Cody> BtbN: That thumbnails filter produces better results. Thanks for the tip.
[17:20:27 CEST] <SITM> hi!
[17:20:39 CEST] <SITM> I think I discovered a bug -- the glob matching appears broken:  ffmpeg -r 30 -pattern_type glob -i "goes-16_*_rgbhybrid_conus.gif" test.mp4
[17:21:36 CEST] <relaxed> SITM: did you try without the quotes?
[17:21:50 CEST] <SITM> let me try that
[17:22:09 CEST] <relaxed> that should be -framerate 30, not -r 30
[17:22:11 CEST] <SITM> I just get "Option pattern_type not found." error
[17:22:45 CEST] <SITM> I changed it to framerate and still get that error
[17:23:14 CEST] <relaxed> try glob_sequence
[17:24:20 CEST] <SITM> "Option pattern_type not found."
[17:25:08 CEST] <relaxed> ffmpeg -f image2 -framerate 30 -pattern_type glob -i goes-16_*_rgbhybrid_conus.gif test.mp4
[17:25:15 CEST] <SITM> maybe my version of ffmpeg is older
[17:25:18 CEST] <SITM> let me try yours
[17:25:35 CEST] <DHE> no you'll need quotes of some kind. ffmpeg needs to see the star
[17:25:52 CEST] <relaxed> oh right, the shell will expand the *
[17:25:59 CEST] <DHE> does .gif work? since a gif isn't necessarily a frame but can be a short video
[17:26:24 CEST] <SITM> getting closer -- [image2 @ 0x75b420] Could not find codec parameters for stream 0 (Video: none, none): unknown codec
[17:26:24 CEST] <SITM> Consider increasing the value for the 'analyzeduration' and 'probesize' options
[17:26:24 CEST] <SITM> goes-16_*_rgbhybrid_conus.gif: could not find codec parameters
[17:26:25 CEST] <relaxed> it may be using the gif demxuer
[17:26:41 CEST] <relaxed> SITM: quote the input
[17:26:55 CEST] <SITM> I did put quotes around the input gifs part
[17:26:58 CEST] <relaxed> pastebin.com the command and all console output
[17:27:11 CEST] <SITM> ok
[17:27:58 CEST] <relaxed> are these animated gifs?
[17:28:04 CEST] <SITM> https://pastebin.com/2Rktw8Cu
[17:28:13 CEST] <SITM> they are single frame gifs
[17:29:04 CEST] <SITM> is it complaining that it doesn't have the codecs to create an mp4?
[17:32:31 CEST] <DHE> I don't think the image2 demuxer supports GIF files. can you convert them to other formats?
[17:32:52 CEST] <relaxed> for i in *gif; do ffmpeg -i "$i" "${i%.*}".png; done
[17:32:55 CEST] <DHE> honestly gif is a poor choice. it's limited to 256 colours. use [almost] anything else. PNG is preferred
[17:33:38 CEST] <SITM> I put -c:v gif after image2 and it seems to be working now
[17:34:00 CEST] <SITM> let me see if we have pngs
[17:35:33 CEST] <SITM> it only used the first gif for the mp4 -- lol
[17:35:46 CEST] <SITM> thanks relaxed I'll try that
[17:37:09 CEST] <relaxed> your ffmpeg version is pretty old. https://www.johnvansickle.com/ffmpeg/
[17:37:09 CEST] <SITM> we have jpgs and this works perfectly:  ffmpeg -f image2 -framerate 30 -pattern_type glob -i "goes-16_*_rgbhybrid_conus.jpg" test3.mp4
[17:37:20 CEST] <SITM> yeah, I'll upgrade it
[18:02:25 CEST] <_Vi> How do I specify finishing position instead of length in `-t`? `-to` seems to be no that. I can't even insert formula into `-t`'s argument.
[18:02:54 CEST] <_Vi> How do I snip fragment from XX:XX:XX to YY:YY:YY without manually calculating length from XX:XX to YY:YY?
[18:30:54 CEST] <c_14> _Vi: you write a script that calculates it for you
[18:33:44 CEST] <_Vi> Would a patch to make `-to` also work for input files (for convenience) welcome?
[18:34:05 CEST] <c_14> probably
[18:34:39 CEST] <c_14> Only reason nobody's done it yet is probably laziness
[23:22:56 CEST] <SavinaRoja> per https://trac.ffmpeg.org/wiki/Map#Example4 , I would think that I could choose to re-encode only one video stream by using "-c:v:N ..." as opposed to "-c:v ...". but instead I am gettting output that drops the additional video streams
[23:25:08 CEST] <jkqxz> I think you need to explicitly copy the others, or it will think you just want that one video stream.
[23:26:24 CEST] <SavinaRoja> jkqxz: I will try listing them explicitly and report back
[23:51:42 CEST] <SavinaRoja> jkqxz: listed them explicitly, but also learned that you have to go from general to specific with codec opts
[00:00:00 CEST] --- Sun Sep 10 2017

More information about the Ffmpeg-devel-irc mailing list