[Ffmpeg-devel-irc] ffmpeg.log.20170910

burek burek021 at gmail.com
Mon Sep 11 03:05:01 EEST 2017

[02:06:40 CEST] <Sebas_> hi :)
[02:07:54 CEST] <Sebas_> I am splitting a mp4 using the segmenter.. but each segment now has non-zero starttime, and it will not load in the MediaSource using javascript.
[02:08:41 CEST] <Sebas_> How can I strip them of the segment times and make each it's own little 'movie' ? :)
[02:09:08 CEST] <Sebas_> This is my converter command (Node.js) args.push(['-i', vid.file,  '-movflags', '+faststart', '-vcodec', 'libx264', '-acodec', 'aac', '-preset', 'veryfast', '-vf', 'scale='+x+'x'+y, '-map', '0', '-profile:v', 'baseline', '-level', '3.0', '-segment_list_type', 'csv', '-segment_time', '15', '-f', 'segment', 'tmp/'+y+'_%03d.mp4']);
[02:10:11 CEST] <dystopia_> what is your scale command doing?
[02:12:13 CEST] <dystopia_> im unsure about your segment times, maybe split source video, then encode split source files ?
[02:12:25 CEST] <Sebas_> 1280x720 and some more resolutions
[02:12:59 CEST] <dystopia_> oh so the +x and +y are some form of variable?
[02:13:01 CEST] <Sebas_> gives me this on the duration line:  Duration: 00:00:13.97, start: 17.914000, bitrate: 2143 kb/s
[02:13:07 CEST] <dystopia_> i guess i should learn javascript heh
[02:13:09 CEST] <Sebas_> yes :)
[02:14:03 CEST] <Sebas_> I guess the start 17.914 is the issue.. because I am adding it to a html5 video element.. the browser gets confused I think and won't play.. clean mp4 files I can append to another in the browser, giving seamless transition
[02:14:10 CEST] <dystopia_> does each segment after the first have a valid header?
[02:14:24 CEST] <Sebas_> I am splitting the files so I can control loading of the segments using javascript
[02:15:12 CEST] <Sebas_> Yes, they will play in VLC and HTML5 video element, but now when appending them via MediaSource (same browser api that youtube uses)
[02:15:50 CEST] <Sebas_> now=not*
[02:16:00 CEST] <dystopia_> i am unsure :(
[02:16:17 CEST] <dystopia_> hopefully someone else knows if you hang around
[02:16:54 CEST] <Sebas_> Is there a way to copy the h264 data without the timestamps? I could write a simple loop that converts all files afterwards
[02:17:31 CEST] <dystopia_> you could try to copy each segment to a new file
[02:18:09 CEST] <dystopia_> ffmpeg -i seg_in.mp4 -vcodec copy -acodec copy seg_out.mp4
[02:19:05 CEST] <Sebas_> test file with a start stamp... try ffmpeg -i <file>    https://ufile.io/1pvpo
[02:21:18 CEST] <Sebas_> I think I got it.. ffmpeg -i in.mp4 -c copy out.mp4 ... let me check
[02:21:59 CEST] <Sebas_> I think it works :)
[02:28:31 CEST] <Sebas_> All start times are reset.. but still not working
[02:29:38 CEST] <Sebas_> I am encoding the same.. https://pastebin.com/m9vWH2jJ :) really thx anyway I will keep trying
[02:30:43 CEST] <klaxa> >At least one output file must be specified
[02:30:54 CEST] <klaxa> your command seems wrong
[02:31:07 CEST] <klaxa> unless you didn't want to encode?
[02:31:51 CEST] <Sebas_> did not want to encode indeed.. giving no output file shows stats :) including 'start' time when segments are created
[02:32:17 CEST] <klaxa> hmm... are you trying to do some live-streaming stuff?
[02:33:01 CEST] <Sebas_> Already got that working once xD but no, I am writing a browser video player, with segmented files I can better control buffering
[02:33:30 CEST] <klaxa> i see, well i'm not good with web-stuff
[05:43:50 CEST] <jeffw_> I am having trouble performing "./configure" on msys2.  I receive: "gcc is unable to create an executable file.  C compiler test failed."
[05:45:52 CEST] <jeffw_> I have performed: "pacman -S mingw-w64-x86_64-nasm mingw-w64-x86_64-gcc mingw-w64-x86_64-SDL2 mingw-w64-x86_64-yasm"  Although I had to use "--force".
[05:46:51 CEST] <jeffw_> I am on 64bit Windows 8.1, using Msys2 and mingw64
[05:47:35 CEST] <jeffw_> The program advises: "If gcc is a cross-compiler, use the --enable-cross-compile option. Only do this if you know what cross compiling means."
[05:49:49 CEST] <jeffw_> Upon running: "./configure --enable-cross-compile --arch=x64 --target-os=mingw-w64"  The same error occurs.   Also attempting with "--arch=x86 --target-os=mingw32"  fails, (as stated here: https://trac.ffmpeg.org/wiki/CompilationGuide/CrossCompilingForWindows  )
[06:22:35 CEST] <titbang> try x86_64
[06:26:35 CEST] <jeffw_> Trying it now.
[06:27:20 CEST] <jeffw_> What should "--target-os" be set to?
[06:33:04 CEST] <jeffw_> Same error occurs using --target-os=mingw32, --target-os=mingw64, --target-os=mingw-w64
[06:33:22 CEST] <jeffw_> And using --arch=x86_64.
[07:18:14 CEST] <JeffW_> Has anyone successfully compiled ffmpeg using a Windows machine?
[13:38:15 CEST] <Sebas_> hi :) I am segmenting a video into ~15 second pieces, this gives me files with lengths and starttimes (PTS data) but when I convert each part with  ffmpeg -i 240_001.mp4 -movflags frag_keyframe+empty_moov+default_base_moof -acodec copy -vcodec copy -copyts n240_001.mp4
[13:38:37 CEST] <Sebas_> the PTS data is erased, how can I keep the exact same duration AND starttime?
[14:57:47 CEST] <Sebas_> anyone know howto preserve starttime in a fragmented mp4? ffmpeg -i 240_001.mp4 -movflags frag_keyframe -acodec copy -vcodec copy n240_001.mp4
[14:59:52 CEST] <Sebas_> or is there a way to -movflag frag_keyframe when segmenting the original file?
[15:33:24 CEST] <c_14> -copyts
[15:36:15 CEST] <c_14> or when segmenting -segment_format_options movflags=+frag_keyframe
[15:42:18 CEST] <Martchus_> I'm trying to get rid of the first 9.125 seconds in the audio stream of the 2nd input file. However, the options -ss and -itsoffset don't have any effect.
[15:42:30 CEST] <Martchus_> So this is likely not correct: ffmpeg -i $avi -ss -9.125 -i $mkv -map 0:0 -map 1:1 -map 0:1 -c:v libx265 -preset medium -crf 24 -c:s:a:0 libfdk_aac -filter:a:0 atempo="1.04270937604270937604270937604" -c:s:a:1 libfdk_aac -metadata:s:a:0 language=eng -metadata:s:a:1 language=ger $output
[15:43:16 CEST] <Martchus_> Using -itsoffset doesn't have any effect either.
[15:44:07 CEST] <Sebas_> thx c14, i'll try it
[15:47:30 CEST] <furq> Martchus_: probably use -af atrim,adelay
[15:47:36 CEST] <c_14> Martchus_: your -ss value is negative
[15:47:45 CEST] <furq> oh yeah that probably doesn't help
[15:48:07 CEST] <furq> also you probably want atempo=25/(24000/1001)
[15:54:06 CEST] <Martchus_> furq: c_14: Thanks for your. I've already noticed that -ss requires a positive value and it works.
[15:55:51 CEST] <Martchus_> furq: I have already added atempo for that stream, but good to know it also supports the form 25/... .
[16:08:06 CEST] <Sebas_> thx c_14, that gave me propper split mp4's with start_time (PTS) intact! Not yet conintued playing(only first file plays) in the broswer MediaSource element yet, but working on it.
[18:39:06 CEST] <Sebas_> Just split up my mp4 file using -f dash, getting audio and video stream, got the video working in the browser using javascript + MediaSource, but the audio doesn't seem to work. any tips?
[18:39:48 CEST] <Sebas_> I tried 2 different MediaSource's and 2 different buffers within the same MediaSource. No results for audio(video works).
[18:40:06 CEST] <BtbN> aac should just work
[18:40:14 CEST] <BtbN> And why don't you just use dash.js?
[18:48:37 CEST] <Sebas_> because I am using websockets as a source :)
[18:51:55 CEST] <Sebas_> works with dash.js, made a quit test page
[18:52:12 CEST] <Sebas_> I'll keep debugging my own player :)
[18:56:21 CEST] <BtbN> using Websockets as source sounds needlessly complicated
[18:58:16 CEST] <Sebas_> also alot of fun :)
[00:00:00 CEST] --- Mon Sep 11 2017

More information about the Ffmpeg-devel-irc mailing list