[Ffmpeg-devel-irc] ffmpeg.log.20170913

burek burek021 at gmail.com
Thu Sep 14 03:05:01 EEST 2017

[01:33:25 CEST] <kkanungo17> homebrew ffmpeg fails to configure, ERROR: vda requested, but not all dependencies are satisfied: vda_framework pthreads
[04:58:00 CEST] <mistym> I'm trying to remux an MPEG-PS file while matching the contents of the original as closely as possible. Having trouble getting it to match the original, and the picky player I'm muxing for is barfing. Anyone have any advice?
[04:58:04 CEST] <mistym> I can provide samples and more specifics :)
[05:03:20 CEST] <c_14> Going to need more specifics
[05:03:26 CEST] <c_14> (like the ffprobe output of both files)
[05:14:18 CEST] <mistym> Default ffprobe output okay, or do you prefer JSON/XML?
[05:15:39 CEST] <mistym> The original file is a nonstandard mostly-VCD video designed for playback on a mid-90s era MPEG decoder card.
[05:16:00 CEST] <mistym> My goal is to remux the existing video as-is with a new audio track, encoded to the same specifications.
[05:17:05 CEST] <mistym> While I have encoded a new audio track which is identically-sized to the original, the muxing overhead that ffmpeg is producing with `-target ntsc-vcd` is substantially higher, and the new file is significantly larger than the original. It's also being rejected by the original player.
[05:17:26 CEST] <mistym> https://gist.github.com/mistydemeo/b2b4dcd410e29ff035d8b7eb0e410f3c - ffprobe output for the original video, with -show_format -show_streams
[05:17:47 CEST] <mistym> https://gist.github.com/mistydemeo/89f06dc501bfd82ee2bec8a138c45fa5 - ffprobe output for the original audio (as a separate M2A), with -show_format -show_streams
[05:21:06 CEST] <mistym> The original video is in an MPEG-PS/CDXA container so I'm using vcdgear to wrap the MPG produced by ffmpeg, but the major differences are at the MPEG-PS container level.
[05:21:13 CEST] <c_14> I'm pretty sure using -target reencodes all the data
[05:21:35 CEST] <c_14> You probably just want to copy the streams
[05:26:06 CEST] <mistym> Oh heh, yeah, it is! Went so fast I figured it couldn't be reencoding. Remuxing does indicate the sizes are around what I'm expecting
[05:26:36 CEST] <mistym> vcdgear rejects it now, but maybe it's just being picky. I'm assuming ffmpeg doesn't support MPEG-PS/CDXA so I'll look up something else to wrap it.
[05:30:21 CEST] <c_14> Does it give a reason for rejecting it?
[05:32:44 CEST] <mistym> Unfortunately not. That would have been convenient of it, hah. Gets a far as printing what it's going to do, then exits 1 without a message.
[05:48:14 CEST] <mistym> Hmm, interestingly vcdgear is happy with mjpegtools mplex's job. Wonder what's different, I should dig in with a hex editor.
[08:16:40 CEST] <FunkyBob> morning, all... am using the pyav wrapper, and the examples seem to indicate I can't rely on the frame.pts ... I'm hoping to be able to find a reliable frame sequence index value [or way to calculate it]
[08:21:42 CEST] <thebombzen> FunkyBob: ffmpeg counts frames, so a python wrapper should provide access to that information
[08:23:17 CEST] <FunkyBob> thebombzen: ok... in a stream object where would I find the frame count?
[08:23:23 CEST] <FunkyBob> s/object/struct/
[08:26:14 CEST] <FunkyBob> basically, in this application we need to seek to a position in the stream, and extract the frame...
[08:26:45 CEST] <FunkyBob> so if ffmpeg is counting frames, is it able to accurately count when I've skipped?
[08:28:34 CEST] <FunkyBob> gak... have to go catch a flight...
[08:28:38 CEST] <FunkyBob> thanks for your help so far, anywayt
[09:35:47 CEST] <jeffW_> I built ffplay.exe using MSYS2, but when I try to open a file with it, it starts to load up, showing my ./configure settings and the libs, but then crashes
[09:36:09 CEST] <jeffW_> Using Visual Studio 2015 to debug, I got errors:  An unhandled win32 exception occured in ffplay.exe [18012]
[09:36:15 CEST] <jeffW_> and   Unhandled exception at 0x0000000000000064 in ffplay.exe: 0xC0000005: Access violation executing location 0x0000000000000064.
[09:37:02 CEST] <jeffW_> My configure settings are:    ./configure --prefix=/c/ffmpeg-output --enable-gpl --enable-version3 --enable-asm --disable-encoders --arch=x86_64 --disable-ffserver --disable-ffmpeg --disable-ffprobe --disable-doc --disable-shared --enable-static --disable-bzlib --disable-libopenjpeg --disable-iconv --disable-zlib --pkg-config=pkg-config
[09:39:48 CEST] <jeffW_> I saw that on Zeranoe, he uses --disable-w32threads so I tried building it with this option, but this also did not work.
[09:42:30 CEST] <jkqxz> Do you have a backtrace?
[09:45:01 CEST] <oerg866> Hello, is it possibhle to change the playback speed of an mkv file without re-encoding. I have some 23.976fps content that I'd like to "speed up" to 25 fps, so it'll sync with my 25i display output.
[09:46:00 CEST] <jeffW_> @jkqxz, No I do not have a backtrace... I have the output of the MSYS2 window as ffplay.exe was being created...
[09:48:21 CEST] <thebombzen> oerg866: you will have to re-encode the audio, but you can dump the video as a raw stream and then feed it back into FFmpeg. Assuming it's H.264, you can do something like this:
[09:48:45 CEST] <thebombzen> ffmpeg -i input.mkv -map v -c copy -f h264 rawvideo.h264
[09:48:54 CEST] <oerg866> <thebombzen> oerg866: you will have to re-encode the audio <-- yeah that's what I was going for
[09:49:07 CEST] <thebombzen> then do: ffmpeg -f h264 -r 25 -i rawvideo.h264 -c copy another.mkv
[09:49:25 CEST] <oerg866> ahh, super
[09:49:26 CEST] <oerg866> thank you
[09:50:05 CEST] <thebombzen> you can re-do the audio with the atempo filter, but use the librubberband filter if your FFmpeg has that in. it works better than libavfilter's atempo filter
[09:50:50 CEST] <oerg866> alright
[09:50:51 CEST] <oerg866> tyvm
[09:51:37 CEST] <jeffW_> Do you know how I could go about getting a backtrace from an .exe ?
[09:52:24 CEST] <jkqxz> Doesn't visual studio just give it to you when something crashes?
[09:53:25 CEST] <jeffW_> let me crash it again
[09:56:31 CEST] <jeffW_> other than the Exception thrown at 0x0000000000000064 in ffplay.exe: 0xC0000005: Access violation executing location 0x0000000000000064.
[09:56:58 CEST] <jeffW_> The thread 0x4a6c has exited with code 0 (0x0).
[09:59:09 CEST] <jeffW_> The gods are against me
[09:59:23 CEST] <jeffW_> They simply do not want me to be able to compile ffplay.exe
[10:01:13 CEST] <jkqxz> Does ffmpeg work?  (If you don't set --disable-ffmpeg.)
[10:03:23 CEST] <jeffW_> Ok here is callstack:
[10:03:27 CEST] <jeffW_>  	0000000000000064()	Unknown
[10:03:31 CEST] <jeffW_>  	SDL2.dll!000000006c8358ce()	Unknown
[10:03:36 CEST] <jeffW_>  	SDL2.dll!000000006c7cebfa()	Unknown
[10:03:40 CEST] <jeffW_>  	ffplay.exe!0000000140b4c925()	Unknown
[10:03:44 CEST] <jeffW_>  	ffplay.exe!00000001400013f7()	Unknown
[10:03:47 CEST] <jeffW_> >	ffplay.exe!000000014000152b()	Unknown
[10:03:51 CEST] <jeffW_>  	[External Code]	
[10:04:37 CEST] <jkqxz> So it dies in SDL.  Does your SDL install work for anything else?
[10:04:49 CEST] <jeffW_> I have no idea
[10:04:59 CEST] <jeffW_> I'm pretty sure i got it via:  pacman -S SDL2
[10:06:25 CEST] <jeffW_> If i try to compile with ffmpeg, should i also remove --disable-encoders ?
[10:08:24 CEST] <jeffW_> I removed --disable-encoders and --disable-ffmpeg, should have the results in about 23 minutes or so :\
[10:15:45 CEST] <oerg866> thebombzen: [matroska @ 00000000027ec0c0] Timestamps are unset in a packet for stream 0. This is deprecated and will stop working in the future. Fix your code to set the timestamps properly
[10:15:45 CEST] <oerg866> [matroska @ 00000000027ec0c0] Can't write packet with unknown timestamp
[10:15:45 CEST] <oerg866> av_interleaved_write_frame(): Invalid argument
[10:15:58 CEST] <oerg866> well there goes that idea :S
[10:28:34 CEST] <thebombzen> oerg866: try using -framerate 25 instead of -r 25
[10:28:41 CEST] <thebombzen> although that *should* work
[10:29:35 CEST] <oerg866> nope, doesn't work either
[10:31:08 CEST] <jeffW_> :p beemo
[10:33:14 CEST] <FunkyBob> back
[10:34:57 CEST] <thebombzen> oerg866: alternatively, you can use L-smash
[10:35:18 CEST] <oerg866> what is that?
[10:35:50 CEST] <thebombzen> it's another program
[10:35:57 CEST] <thebombzen> I don't know how to use it though, you'd have to ask someone else
[10:36:03 CEST] <thebombzen> I just recall that you could do this with L-smash
[10:39:03 CEST] <jeffW_> what is a super dumb simple test I could do to verify that ffmpeg is working?
[10:39:36 CEST] <thebombzen> jeffW_: ffmpeg -f lavfi -i testsrc -c copy -f null -
[10:40:10 CEST] <jeffW_> where testsrc is the name of my file? or the filepath ?
[10:40:18 CEST] <thebombzen> copy that verbatim
[10:40:26 CEST] <jeffW_> oh...
[10:41:13 CEST] <jeffW_> will it then display psycadellic fractal patterns and spinning picture of Dick Cheyne  indicating that it is working properly?
[10:42:15 CEST] <jeffW_> (I can't test it right now, I'm waiting for it to compile)
[11:11:52 CEST] <jeffW_> OK, i copied verbatim what you told me, "ffmpeg -f lavfi -i testsrc -c copy -f null -"
[11:12:31 CEST] <jeffW_> And I get the message:  The application was unable to start correctly (0x000007b). Click OK to close the application.
[11:20:19 CEST] <u32> Hello. I'm trying to play a video stream with the lowest latency I can and have had some mild success with gstreamer (bottoming at ~300ms) and now i want to do the same with ffmpeg (ffplay)
[11:20:29 CEST] <u32> but i can't bring it below 1000ms or so.
[11:20:32 CEST] <furq> jeffW_: that's an incredibly vague error message which could mean lots of things
[11:20:48 CEST] <furq> but if these are the zeranoe builds then i suspect you've downloaded the wrong version for your architecture
[11:20:58 CEST] <u32> Any ideas on how to reduce latency whith all other considerations second?
[11:21:17 CEST] <furq> that normally means you're trying to load a 32-bit dll into a 64-bit binary or vice versa
[11:21:55 CEST] <BtbN> u32, ffplay is more a proof-of-concept than an actual player.
[11:22:04 CEST] <u32> The error is also typical when some applications (Qt comes to mind) fail to load some dlls
[11:22:05 CEST] <BtbN> For ultra-low-latency, you will always want to write your own player.
[11:22:12 CEST] <furq> if you've definitely got the right binary then it could be any number of different things
[11:22:39 CEST] <jeffW_> These are not zeranoe builds
[11:22:43 CEST] <furq> it's one of those typical MS error messages where the official advice is "do 21 different things and try it after every step and if it works, great!"
[11:22:55 CEST] <furq> and step 21 is "reinstall windows"
[11:23:19 CEST] <jeffW_> ffplay is proof that ffmpeg doesn't work on Windows.
[11:23:26 CEST] <u32> BtbN: Is there any reference app/tool to test ffmpeg?
[11:23:42 CEST] <BtbN> That's what ffmpeg and ffplay are for
[11:23:48 CEST] <furq> oh you're building this yourself
[11:24:33 CEST] <jeffW_> yes
[11:24:38 CEST] <jeffW_> using MSYS2
[11:25:30 CEST] <jeffW_> i established with jkqxz's help that SDL2 is causing the problem in ffplay
[11:25:44 CEST] <furq> i was going to suggest cross-compiling, but then i remembered my build script doesn't actually build ffplay
[11:26:00 CEST] <jeffW_> but now (several minutes later) ffmpeg does not work when compiled either.
[11:26:25 CEST] <furq> probably check dependency walker and see if you're missing a dll
[11:26:27 CEST] <jeffW_> As usual in the world of compiling, nothing ever works.
[11:26:53 CEST] <u32> So no real way to test wether ffmpeg will be of any advantage without making a custom app?
[11:27:17 CEST] <jeffW_> This is why I should have just stuck with Python and dared venture outside the house.
[11:27:33 CEST] <jeffW_> and never* dared
[11:28:06 CEST] <jeffW_> I just wanted to make a very simple video player, and ffplay is just such a player.
[11:28:36 CEST] <jeffW_> I dont care about fancy filiters, or changing bit-streams or YUV to RGB or any of that nonsense
[11:28:54 CEST] <jeffW_> I just want to play with mapping the keys on the keyboard to times in any given video
[11:29:22 CEST] <jeffW_> I did it already with Python using a "wrapper" for VLC.dll
[11:29:38 CEST] <jeffW_> Only problem is, it's slow as hell to start up
[11:30:04 CEST] <jeffW_> And when it does (when u start it up after not having started it in a while) the video begins to play the first second of the video over and over
[11:30:13 CEST] <jeffW_> and I have to quit out of the program and restart it
[11:31:10 CEST] <jkqxz> It think the answer to your complaint that compiling it is terrible is "don't use windows".
[11:31:43 CEST] <jeffW_> So then i decided, why not re-write it in C, it will be a good opportunity to learn C/C++ and change that "Python, MATLAB   (Some familiarity with C/C++)" on my resume to  "Python, MATLAB, C/C++"
[11:31:45 CEST] <jkqxz> It is certainly possible to make it work (Zeranoe does, after all), but it is not easy and rather fragile.
[11:32:03 CEST] <u32> well. Target people tend to dislike linux
[11:32:27 CEST] <jeffW_> @jkqxz, yes exactly. Windows -- the bane of all programmers.
[11:33:06 CEST] <jeffW_> Zeranoe makes it work with Debian :\
[11:33:18 CEST] <jkqxz> I build ffmpeg in msys2 for testing some stuff, but it's something I made work (possibly by luck) a while ago and now try not touch anything in case it breaks.
[11:33:22 CEST] <jeffW_> And all I have is my Windows 8.1 laptop.
[11:33:51 CEST] <furq> if you want to cross-compile it then do it in a vm
[11:34:22 CEST] <jeffW_> All I have is my Windows 8.1 laptop, what am I going to be cross-compiling for?
[11:34:25 CEST] <furq> for windows
[11:34:46 CEST] <furq> compile it in a linux vm running on windows for windows
[11:34:52 CEST] <jeffW_> My understanding was cross-compiling meant creating executables for various OSs.
[11:35:01 CEST] <furq> if that sounds ridiculous to you then blame this guy
[11:35:03 CEST] <furq> https://pbs.twimg.com/profile_images/889736688624312321/xVAFH9ZH_400x400.jpg
[11:35:52 CEST] <jeffW_> Nah, I'll blame the ppl running MS since... oh, let's say... idk.... 2008ish? 2013?
[11:36:19 CEST] <jeffW_> why the hell doesn't their coveted Visual Studio have the equivalent of MSYS2 already?
[11:36:35 CEST] <jeffW_> MS is living in denial of Unix/Linux's existance?
[11:37:06 CEST] <jeffW_> They refuse to accept that Linux systems are THE preferred method for cross-platform implementation
[11:37:10 CEST] <furq> msys sort of sucks tbh
[11:37:24 CEST] <jeffW_> well, its msys or vm
[11:37:30 CEST] <furq> yeah i picked the latter
[11:37:53 CEST] <c_14> Isn't there the fancy Ubuntu on Windows stuff now? Didn't that leave beta yet?
[11:38:01 CEST] <furq> he's on windows 8
[11:38:03 CEST] <jeffW_> vm sounded like over-kill/hassle/big-disk-space-hog/etc.
[11:38:05 CEST] <furq> WSL is only for 10
[11:38:17 CEST] <furq> and also it is still in beta iirc
[11:38:59 CEST] <furq> with that said, is there some reason you can't use the ffplay from zeranoe
[11:39:02 CEST] <furq> at least for testing and whatnot
[11:39:40 CEST] <jeffW_> So apparently I'm the first person on planet Earth to attempt to use MSYS2 to compile FFmpeg on a Windows 8.1 machine. Horray for me.
[11:39:55 CEST] <jeffW_> Well, in looking at ffplay.c
[11:40:23 CEST] <jeffW_> I saw that was where the keyboard code was, so i decided, "Perfect! This is what I need to mess with an compile."
[11:40:44 CEST] <jeffW_> And that was where innovation came to an end.
[11:42:49 CEST] <jeffW_> Could any of you explain this to me:  I downloaded Visual Studio 2015, and started a new C++ console application.  Open ffplay.c,  copy, paste it into MSVC as ffplayJeff.cpp,  rename it to ffplayJeff.c (now a bunch of red (errors) disappars.
[11:43:22 CEST] <c_14> Well, it's not C++
[11:43:25 CEST] <jeffW_> Go to Visual C++ settings
[11:43:51 CEST] <jeffW_> set Include Directories to include C:\ffmpeg  where i put the FFmpeg Snapshot
[11:44:00 CEST] <jeffW_> now more red disappars
[11:44:21 CEST] <jeffW_> Using the config.h from running /.configure with MSYS2
[11:44:31 CEST] <c_14> ffplay includes a bunch of ffmpeg headers
[11:44:45 CEST] <jeffW_> now that is no longer an issue. Perfect! All the red is gone, it should compile without problems
[11:45:50 CEST] <jeffW_> And instead i get  Unhandled Symbol _hide_banner  in Object line 1
[11:46:00 CEST] <jeffW_> Unhandled Symbol in blahblahblah in Object line 1
[11:46:20 CEST] Last message repeated 1 time(s).
[11:46:20 CEST] <jeffW_> ad nauseum
[11:46:42 CEST] <jeffW_> so i use Notepad++ to search C:\ffmpeg for "_hide_banner"
[11:47:29 CEST] <jeffW_> And... of course it returns results: 0 occurrences of "_hide_banner" found in "C:\ffmpeg\"
[11:48:12 CEST] <jeffW_> o rly? then where the f did msvc get "_hide_banner" from?
[11:48:35 CEST] <jkqxz> The windows ABI puts an underscore on the front of all C symbols.
[11:48:48 CEST] <jkqxz> So lost the leading underscore and search again.
[11:48:59 CEST] <jkqxz> *lose
[11:49:00 CEST] <c_14> I don't think ffplay.c is standalone
[11:49:02 CEST] <jeffW_> I had thought of doing that. damnit.
[11:49:06 CEST] <c_14> you probably need cmdutils.c and other stuff
[11:49:20 CEST] <jeffW_> yup. It does.
[11:49:24 CEST] <c_14> I'd guess ffmpeg_opt.c as well
[11:49:26 CEST] <jkqxz> Yeah, probably also some config.h stuff.
[11:49:27 CEST] <u32> C puts a leading underscore when linking symbols
[11:49:32 CEST] <u32> is a C thing actually
[11:49:43 CEST] <jkqxz> It's not a C thing, it's a Windows C ABI thing.
[11:50:34 CEST] <jeffW_> I'm just curious wtf it is
[11:50:49 CEST] <jeffW_> i think i had, in reading trying to figure out wtf Unhandled symbol" meant
[11:51:03 CEST] <jeffW_> that it might be calling out stuff that it doesn't even need
[11:51:17 CEST] <jeffW_> but it's "unhandled" so it bitches about it anyway
[11:51:47 CEST] <c_14> cmdutils.h hide_banner
[11:51:56 CEST] <c_14> It's an option
[11:51:56 CEST] <jeffW_> ah
[11:52:22 CEST] <jeffW_> So what needs to be done in msvc to make it stop complaining about it being "unhandled" ?
[11:53:29 CEST] <c_14> make sure cmdutils.* is in your cwd
[11:53:35 CEST] <c_14> in this case in your project or something
[11:56:34 CEST] <jeffW__> back. connection died.
[11:56:57 CEST] <jeffW__> Also, ffplay.c does not contain #include cmdutils.c, only #include cmdutils.h
[11:57:08 CEST] <c_14> Well, obviously
[11:57:12 CEST] <c_14> You don't include .c files
[11:57:20 CEST] <c_14> You link the resulting object files into your binary
[11:57:50 CEST] <jeffW__> Good to know. Thought someone had said they thought ffplay required cmdutils.c
[11:57:59 CEST] <c_14> yes
[11:58:01 CEST] <c_14> me
[11:58:03 CEST] <c_14> Because it does
[11:58:11 CEST] <c_14> Just not during compilation
[11:58:13 CEST] <c_14> But during linking
[11:58:31 CEST] <jeffW__> via cmdutils.h I presume.
[11:58:49 CEST] <c_14> yes and no, let's just say yes
[11:59:55 CEST] <jeffW__> Fair enough.
[12:00:25 CEST] <jeffW__> So what object files am I linking?
[12:00:49 CEST] <c_14> ffplay.o and cmdutils.o
[12:00:51 CEST] <jeffW__> I'm only seeing .o files
[12:01:10 CEST] <jeffW__> will msvc recognize .o files? or only .obj
[12:01:18 CEST] <c_14> .o files are the result of compiling .c files
[12:01:24 CEST] <c_14> You give msvc the .c files
[12:01:30 CEST] <c_14> And then it will create and link them
[12:01:35 CEST] <c_14> s/create/assemble/
[12:02:33 CEST] <c_14> (you'll probably also have to tell msvc somehow that ffplay.c wants to be linked against cmdutils.c)
[12:03:01 CEST] <jeffW__> I gave it ffplay.c (renamed as ffplayJeff.c since msvc only will compile Solutions, not individual files).
[12:03:37 CEST] <c_14> Then you have to create a Solution that contains ffplay.c and cmdutils.c and depends on their compilation and linking
[12:04:09 CEST] <jeffW__> well i opened ffplay.c ,  copy,  and pasted it into blank  ffplayJeff.c
[12:04:43 CEST] <jeffW__> well... ffplayJeff.cpp then renamed it to ffplayJeff.c  and watched as a bunch of red stuff disappared when i did that.
[12:04:47 CEST] <c_14> Well, MSVC has to have some sort of project Makefile or project structure that lets you tell it how to compile things and what depends on what
[12:05:25 CEST] <jeffW__> hmm
[12:06:00 CEST] <jeffW__> okay. more research on msvc "Properties Pages" dialog needs to be done.
[12:06:41 CEST] <jeffW__> so my "solution" needs a "makefile" ?
[12:06:47 CEST] <jeffW__> i thought makefiles were a Linux thing..
[12:07:18 CEST] <jeffW__> what with the whole "make" command and all that
[12:07:36 CEST] <c_14> Makefiles are a POSIX thing
[12:07:44 CEST] <jeffW__> ah
[12:08:29 CEST] <jeffW__> I noticed when you start a new project... er... solution, in msvc  Makefile Project is one of the options
[12:09:11 CEST] <jeffW__> Could this be the one and only concession Microsoft has made that Linux exists?
[12:10:30 CEST] <jeffW__> I mean other than having MS Word import .odf Open Document format
[12:11:57 CEST] <jkqxz> Microsoft copied make as nmake a very long time ago.
[12:12:27 CEST] <jeffW__> why am i not surprised...
[12:13:17 CEST] <jeffW__> ugh. i'm starting to lose conciousness, i need to copy the stuff c_14 said and put it in a .txt file
[12:15:41 CEST] <jeffW__> jkqxz, do you suppose deleting any/all folders with SDL in them from MSYS folders and  running  pacman -S SDL2  again would help?
[12:18:21 CEST] <jkqxz> Highly unlikely.  But possible, I guess, so it's probably in front of "sacrifice a second goat" on the list of things to try.
[12:20:08 CEST] <jeffW__> hmmm
[12:20:34 CEST] <jeffW__> alright then
[12:21:02 CEST] <jeffW__> I ask b/c i had been trying various other things
[12:21:15 CEST] <jeffW__> (reading old posts from back when FFmpeg used SDL1.2)
[12:21:28 CEST] <jeffW__> and following instructions on things to change
[12:21:31 CEST] <jeffW__> based on that
[12:22:23 CEST] <jeffW__> then  after reading one post about ffmpeg changing from sdl1.2 to sdl2.0 in ~version 3.0.2
[12:23:16 CEST] <jeffW__> i realized that the instructions someone posted that i was following, which had me download ffmpeg-3.0.2, which i was trying to get to compile for 3 days, was for sdl2.1
[12:24:16 CEST] <jeffW__> so i got sdl2.1 and tried messing with CFLAGS and LDFLAGS and --cflags=/c/msys64/home/Jeff/sdl/SDL-1.2.15/
[12:25:18 CEST] <jeffW__> and then realized, maybe i should just download ffmpeg again... and low and behold, it actually compiled ffplay! But of course it didn't work.
[12:28:00 CEST] <jeffW__> well it was a little more involved than that... but you get the idea.
[12:31:21 CEST] <jeffW__> Ah, I have another question... When msys2 is compiling ffmpeg, I get several warnings now and then
[12:31:33 CEST] <jeffW__> Should that not be happening? Or is that normal?
[12:31:53 CEST] <jeffW__> when compiling ffmpeg or ffplay*
[17:54:18 CEST] <thebombzen> ohey, there's an update to CUDA, I wonder if they unbroke nvcc with glibc 2.26
[17:56:57 CEST] <thebombzen> it appears that this has been unbroken
[18:43:00 CEST] <wouter> what format does ffmpeg's -framerate (with -f image2) accept? Can I just tell it to use 30000/1001 or some such?
[18:45:39 CEST] <wouter> apparently yes
[00:00:00 CEST] --- Thu Sep 14 2017

More information about the Ffmpeg-devel-irc mailing list