[Ffmpeg-devel-irc] ffmpeg.log.20180603

burek burek021 at gmail.com
Mon Jun 4 03:05:03 EEST 2018

[00:00:01 CEST] <Zexaron> for some reason the .exe still wants swresample-3.dll while I removed it completely, greped the files, no mentions
[00:00:45 CEST] <Zexaron> Well, there's this FindFFMPEG.cmake but it has other stuff defined which doesn't exist either
[00:03:16 CEST] <Zexaron> I cleaned and rebuilt, nothing
[00:04:17 CEST] <Zexaron> set(_FFmpeg_DEPS_postproc avutil)
[00:04:17 CEST] <Zexaron>  set(_FFmpeg_DEPS_swresample avutil)
[00:04:40 CEST] <Zexaron> there's device, etc, none of which existed before, and it wasn't needing them
[00:07:18 CEST] <Zexaron> also only avutil.h and log.h from avutils has some reference to swresample but doesn't look like it needs them
[00:19:24 CEST] <Zexaron> do other ffmpeg dlls need it?
[00:24:21 CEST] <Zexaron> Zeranoe's avcodec-58.dll has a string pointing to swresample-3.dll
[00:24:40 CEST] <Zexaron> I guess no "load it if I really need it" thing in there as well
[00:25:19 CEST] <Zexaron> JEEB: What if that's not intended, bug?
[00:25:40 CEST] <JEEB> some audio decoders (opus) need the resampling functions
[00:25:42 CEST] <Zexaron> Someone told me before swresample might not be needed and I can remove it
[00:25:55 CEST] <JEEB> also libavfilter can need swresample because the audio filtering code uses it
[00:26:08 CEST] <JEEB> I mean, you can disable all of that during build time, but otherwise it's all there, cross-library deps :P
[00:27:37 CEST] <Zexaron> That's fine, but could it be made to only have to load it when that component is used, such as opus, without having to do a custom build while disabling opus and etc
[00:28:06 CEST] <Zexaron> Which is what I'm having to do with Dolphin, so it only loads ffmpeg when needed.
[00:40:43 CEST] <Zexaron> I have a thing of being stubborn and persistent
[00:43:36 CEST] <Zexaron> I opened avcodec-58.dll in hex, found swresample, it was the last of dependency entries like .da.da.avutil-56.dll...xa.xa.xa.xa.xa.xa.swresample-3.dll........  with a few lines of the end dots representing NULL
[00:44:29 CEST] <Zexaron> so I nulled out the .xa ..swresample entry, it gave me an error about a missing ".DLL" so pretty much the same error just without the name
[00:45:42 CEST] <Zexaron> JEEB: Then I reverted back to official avcodec-58.dll and created an empty dummy swresample-3.dll - it works, tested and tried the feature inside Dolphing.
[00:46:11 CEST] <Zexaron> Now, are you thinking what I'm thinking ....
[00:46:47 CEST] <Zexaron> In order to make ffmpeg official ... all I have to do is to ship DUMMY ffmpeg shared libraries with Dolphin .... FINGERS CROSSED !!!
[00:49:23 CEST] <Zexaron> In order to make ffmpeg optional*
[00:49:55 CEST] <Zexaron> Well I'm still renaming/creating dummies ... drumroll any second
[00:52:37 CEST] <Zexaron> Bah, hard requirement, "is either not designed to run on Windows or is corrupt"
[01:47:47 CEST] <Zexaron> i'll probably have to do the pointers thing ... but next time, time to shutdown the powah, air conditioner installation, bye!
[01:51:34 CEST] <TheAMM> So I have a v4l2 video source and an alsa audio source, and they're not synced up
[01:51:56 CEST] <TheAMM> Is there any relevant magic I could do when recording, or do I just itsoffset manually afterwards
[04:14:44 CEST] <kepstin> TheAMM: if you the offset is consistent, you could correct for it my using setpts (or asetpts) filters during the capture.
[04:15:13 CEST] <kepstin> TheAMM: the problem's probably caused by how ffmpeg initializes inputs one at a time, so it'll always do one before the other :/
[04:15:32 CEST] <kepstin> although it's rare for it to be off far enough to be a problem with only 2 inputs
[10:32:55 CEST] <hellozee> I can generate slideshows from images but now I am trying to add transitions between them, specifically the sliding from top one, searched the web but they mostly talk about fades/zoom/pan, what would be the proper approach?
[11:19:46 CEST] <lesshaste> I have a video I want to cut out the first 20 seconds of. That I can do but I would like the sound to fade out, rather than just stop abruptly. Is that possible with ffmpeg?
[11:38:09 CEST] <Kam_> lesshaste: should be possible, have a look at the 'afade' audio filter.
[14:25:49 CEST] <anill> i have an raw stream of RTP packets captured into a file called mycapture.dump, how can i convert it into H.264 via ffmpeg.Do i need to save RTP packets in some specific format or need some development work at ffmpeg side
[14:37:59 CEST] <DHE> I don't think the answer has changed since you last asked
[14:56:34 CEST] <anill> DHE: iran the command u said, it says invalid data found while processing
[15:02:17 CEST] <DHE> when you said rtp I assumed you meant a connection to some internet service, not that you'd recorded a tcpdump/wireshark pcap
[15:10:43 CEST] <anill> DHE: i made a custom dump
[15:11:37 CEST] <JEEB> the RTP parser probably is in the protocol code
[15:11:39 CEST] <JEEB> since you know
[15:11:54 CEST] <JEEB> people generally don't rip that info and don't replay it but instead attempt to read it from a file
[15:12:12 CEST] <JEEB> so if you really want to do it without replaying the traffic, you will have to rip out the RTP parser from the protocol
[15:12:38 CEST] <JEEB> otherwise just open the protocol with a timeout, and start replaying the data to localhost
[15:15:52 CEST] <lesshaste> Kam_,  thanks!
[15:16:01 CEST] <lesshaste> Kam_,  can you fade the video too?
[15:18:31 CEST] <Kam_> lesshaste: 'fade' and 'tblend' can do this https://ffmpeg.org/ffmpeg-all.html#fade and https://ffmpeg.org/ffmpeg-all.html#blend_002c-tblend
[15:18:46 CEST] <lesshaste> Kam_, thanks!
[15:32:40 CEST] <anill> JEEB: ist for me right?
[15:34:11 CEST] <anill> JEEB: Its for me right?
[17:32:13 CEST] <zumba_ad_> morning all. I have few still pictures of an area throughout the day where shadow moves every hour. I'd like to make a nice transition on the timelapse. Can we use ffmpeg to make a nice transition between frames?
[17:33:25 CEST] <zumba_ad_> it's not a fade-in/out effect
[17:43:01 CEST] <DHE> so, fade between but without black in between?
[17:45:36 CEST] <Blacker47> zumba_ad_, maybe something with https://ffmpeg.org/ffmpeg-filters.html#blend_002c-tblend but i can't help futher with it.
[17:47:10 CEST] <kepstin> you could also try something like set the input to a really low framerate, then use the "framerate" filter with a higher fps to generate the blended frames between.
[18:01:09 CEST] <TheAMM> kepstin: -async 1 was enough
[18:01:24 CEST] <TheAMM> (regarding the audio sync on v4l2 and alsa I mentied yesterday)
[18:06:38 CEST] <zumba_ad_> ok, taking a look
[18:09:04 CEST] <ressected> hello!
[18:09:12 CEST] <ressected> long time ffmpeg user here
[18:09:37 CEST] <ressected> setup is plex server, chromecast
[18:09:39 CEST] <ressected> all linux
[18:10:30 CEST] <ressected> got a good copy of The Godfather and TV (for some reason) will not take the AC3 from chromecast and output is a LPCM to my d/a converter
[18:11:00 CEST] <ressected> so I need advice on the best way to get AC3 5.1 to two channel AAC for mp4 container
[18:11:41 CEST] <ressected> would like to go from AC3 to linear pcm but it doesn't look like the chromecast will take that in an mp4
[18:16:43 CEST] <kepstin> ressected: dunno about "best way", but just throwing "-ac 2" to remix to stereo along with the appropriate codec options should be sufficient.
[18:17:04 CEST] <DHE> -ac 2 -c:a aac -b:a 128k     # or a higher number for higher bitrate if you prefer
[18:18:14 CEST] <ressected> DHE, kepstin, that will do all the summing of the channels in some linear way?
[18:19:41 CEST] <kepstin> ressected: yeah, it's got a reasonable preset matrix that it'll use.
[18:19:44 CEST] <ressected> DHE, kepstin, e.g. does it just throw away the surround channels or does it try to be "smart" and mix it in like dolby pro-logic type thing
[18:19:53 CEST] <DHE> ac3 is an interesting codec. it may specify its own mixing matrix
[18:21:00 CEST] <ressected> kepstin, DHE, I will try it
[18:22:06 CEST] <ressected> kepstin, DHE, thanks for your help
[18:24:55 CEST] <anil> DHE: Hey
[18:26:28 CEST] <anil> This info, does JEEB referred to me
[18:26:28 CEST] <anil> <JEEB> the RTP parser probably is in the protocol code
[18:26:28 CEST] <anil> <JEEB> since you know
[18:26:28 CEST] <anil> <JEEB> people generally don't rip that info and don't replay it but instead attempt to read it from a file
[18:26:28 CEST] <anil> <JEEB> so if you really want to do it without replaying the traffic, you will have to rip out the RTP parser from the protocol
[18:26:28 CEST] <anil> <JEEB> otherwise just open the protocol with a timeout, and start replaying the data to localhost
[18:28:30 CEST] <anil> JEEB: are you there?
[18:29:04 CEST] <durandal_1707> anil: stop doing that, he will reply if he can
[18:29:27 CEST] <DHE> well officially he was nagging me and just quoting jeeeb....
[18:29:47 CEST] <anil> durandal_1707: sorry, will take care
[18:37:04 CEST] <ressected> anyway to sleep up the AAC encoding to use more than one core?
[18:37:07 CEST] <ressected> speed*
[18:38:25 CEST] <klaxa> run more than one encode at once?
[18:39:12 CEST] <ressected> klaxa, I'm converting single file from 5.1 ac3 to 2 channel AAC
[18:39:45 CEST] <kepstin> ressected: if it's really slow, you're probably accidentally re-encoding the video
[18:39:54 CEST] <kepstin> ressected: add a "-c:v copy" :)
[18:40:22 CEST] <kepstin> audio encoding is generally fast enough that you just live with it being single-threaded.
[18:41:04 CEST] <ressected> ffmpeg -i The.Godfather.1972.1080p.BluRay.x264.AC3.mp4 -ac 2 -c:a aac -b:a 384k -vcodec copy The.Godfather.1972.1080p.BluRay.x264.AAC.mp4
[18:41:07 CEST] <ressected> so thats not right?
[18:41:25 CEST] <kepstin> that should be fine, "-vcodec copy" and "-c:v copy" are the same thing
[18:41:29 CEST] <klaxa> you could possibly split it up into smaller parts without re-encoding, re-encode the single parts and then concatenate them back together, maybe timestamps get mangled though
[18:41:50 CEST] <kepstin> klaxa: doesn't actually work, because of how codecs like aac require preroll packets and padding :/
[18:41:53 CEST] <ressected> its only encoding it at 4x speed
[18:41:58 CEST] <klaxa> :V
[18:42:03 CEST] <klaxa> thank you bad standards
[18:42:05 CEST] <kepstin> (i mean it still can be done, but requires detailed knowledge of how the codec works)
[18:42:27 CEST] <ressected> klaxa, I appreciate the hacker mentality
[18:42:36 CEST] <kepstin> klaxa: pretty much all audio codecs are like that, because of the overlapped transforms they use
[18:42:51 CEST] <ressected> klaxa, by the time I figure that out I might as well just wait the 40 minutes for the encode
[18:42:56 CEST] <kepstin> ressected: are you limited by disk speed, maybe?
[18:43:35 CEST] <kepstin> ressected: also, that's a kinda ridiculously high bitrate, and the encoder might be running slower just because of that. Try something like 128-192 instead maybe.
[18:43:39 CEST] <ressected> kepstin, nah
[18:43:57 CEST] <ressected> I thought the higher bit rate the faster it is, due to less compression
[18:44:15 CEST] <klaxa> but it has to calculate more bits ;)
[18:44:31 CEST] <ressected> crap, okay I'll do 192
[18:44:42 CEST] <ressected> on that system you can hear the smallest artifacts
[18:44:44 CEST] <kepstin> depends on the codec, I don't know exactly how the internal aac encoder scales
[18:44:52 CEST] <ressected> wont hurt to try
[18:45:20 CEST] <kepstin> you might consider using fdk_aac instead, if you can build ffmpeg yourself (although that will probably take longer than the transcode...)
[18:45:46 CEST] <ressected> kepstin, I'll consider that in the future
[18:46:53 CEST] <kepstin> but yeah, I'd really expect you do be getting a lot faster than 4x unless you have other bottlenecks. What version of ffmpeg are you running?
[18:47:42 CEST] <ressected> ffmpeg version 3.1.9
[18:48:17 CEST] <ressected> I am doing it on an NFS share but that should give me 30MB/s bi-directional at minimum
[18:49:32 CEST] <BtbN> 3.1. wow.
[18:55:11 CEST] <ressected> BtbN, whats wrong with that?
[18:55:34 CEST] <ressected> latest avail on fedora 24
[18:55:51 CEST] <BtbN> it's old.
[18:56:15 CEST] <JEEB> also fedora 24 is EOL
[18:56:16 CEST] <JEEB> rip
[18:56:32 CEST] <ressected> thanks but it's what I got
[18:56:34 CEST] <JEEB> they only at max support current-2 and even 26 is soon going to end down
[18:56:47 CEST] <BtbN> you're not going to get anywhere with that version
[18:56:49 CEST] <JEEB> also for the record, Fedora itself doesn't ship FFmpeg
[18:56:54 CEST] <ressected> kepstin, from the aforementioned conversion, is the audio likely to be delayed?
[18:57:09 CEST] <ressected> kepstin, is there some offset I should be specifying?
[18:57:21 CEST] <JEEB> if the input file is OK it should work
[18:57:28 CEST] <JEEB> since it just utilizes the timestamps from input
[18:57:31 CEST] <kepstin> ressected: shouldn't be, you're not resampling (and ffmpeg sets the timestamps right, so it should be fine in any case)
[18:57:53 CEST] <ressected> kep, okay might be my TV then
[18:57:55 CEST] <ressected> kepstin,
[18:58:07 CEST] <ressected> kepstin, thank you
[18:58:28 CEST] <JEEB> well bugs are always possible but relatively unlikely. generally the first recommendation would be to try and build current master and try with it
[18:59:45 CEST] <ressected> oh yeah lowering the bitrate sped it up big time
[19:01:48 CEST] <EvanR> hello
[19:02:26 CEST] <ressected> EvanR, hi
[19:02:49 CEST] <EvanR> i think 2 years ago i had a problem with avfoundation capture
[19:03:21 CEST] <EvanR> someone in here kernrj i think provided assistance
[19:03:43 CEST] <EvanR> i think there was a partial fix, heres the thread https://trac.ffmpeg.org/ticket/5654
[19:03:56 CEST] <EvanR> i got notified about it since someone just commented
[21:52:51 CEST] <PaulHere> Hello, in my mp4 file 176 bytes in sequence are equal to FF (inside mdat). Anyone knows why?
[21:59:23 CEST] <PaulHere> I think it's the payload of a nal unit, but the nal-header has the forbidden_zero_bit set to 1... any ideas? should I just skip them?
[22:11:33 CEST] <PaulHere> ok, so I gues that forbidden_zero == 1 means that there was an error in transmission, and you are supposed to skip it
[22:32:31 CEST] <PaulHere> is it possible to rederict libavcoec messages to stdout instead of stderr?
[22:33:03 CEST] <BtbN> with ffmpeg.c? no
[22:33:27 CEST] <BtbN> as an API user there iirc is a log callback and you can do whatever in there
[22:33:37 CEST] <PaulHere> i just wanted to say there is av_log_set_callback
[22:33:50 CEST] <PaulHere> yes
[22:45:09 CEST] <JEEB> yea as an API client you can do whatever you want
[23:04:15 CEST] <DHE> can confirm, I do whatever I want with the API. :)
[00:00:00 CEST] --- Mon Jun  4 2018

More information about the Ffmpeg-devel-irc mailing list