[Ffmpeg-devel-irc] ffmpeg.log.20180610

burek burek021 at gmail.com
Mon Jun 11 03:05:01 EEST 2018

[00:17:01 CEST] <heliumclicks> furq: i'm out. Thanks again for your help!
[00:26:20 CEST] <sunzofman> furq: I wish to compile ffmpeg against libmp3lame. Can I do this without losing the existing ffmpeg customization? I have at least 6-7 different encoders setup for video and audio.
[00:27:16 CEST] <sunzofman> furq: I basically wish to encode opus files to mp3.
[00:30:48 CEST] <sunzofman> anyone have experience compiling ffmpeg?
[00:42:24 CEST] <csierra_> is it possible to see all possible entries for a stream in ffprobe?
[07:03:13 CEST] <allohol> ffmpeg -i INPUT_AAC_H.264 -c copy OUTPUT.mkv <- produces a file 1.5gb / h. Now, when I do: ffmpeg -i OUTPUT.mkv -c copy -t 00:10:00.00 CUT.mkv <- I'ld exspect that 2nd file to be 200-300mb, yet it ends up at around 700mb! How could that be?
[10:29:29 CEST] <Faith> I'm having trouble selecting a subtitle stream to hardsub using the subtitles filter, even though I'm getting the syntax right as outlined here https://ffmpeg.org/ffmpeg-filters.html#subtitles-1
[10:29:34 CEST] <Faith> https://pastebin.com/2GquK7H0
[10:29:44 CEST] <Faith> Does anyone know how I could get this to work?
[10:31:47 CEST] <durandal_1707> Faith: missing -vf
[10:32:10 CEST] <Faith> Welp
[10:32:13 CEST] <Faith> Thanks, I'm an idiot
[12:14:05 CEST] <waterworks> BtbN: JEEB: I solved the nvenc issue by removing --disable-autodetect to configure. I thought you could select which HW acceleration you wished to use through --enable-nvenc but the script doesn't like that.
[12:14:30 CEST] <JEEB> that sounds like a bug somewhere since you specifically enabled nvenc
[12:14:48 CEST] <JEEB> since I'm using multiple libraries and I /really/ like disable-autodetect
[12:15:01 CEST] <JEEB> since that way you know specifically what you're enabling out of the external stuff
[12:21:36 CEST] <waterworks> Okay, apparently ffnvcodec shows up under "External libraries providing hardware acceleration" so you can have --disable-autodetect if you do --enable--ffnvcodec and --enable-nvenc. It adds cuda there too even if you don't specify it so why can't it just add ffnvcodec automatically.
[15:15:41 CEST] <kepstin> allohol: your input file is probably using a variable rate encoding where more complex scenes have higher bitrate. that's pretty normal.
[16:25:58 CEST] <ben__> Hey People :-) ! i would like to convert a Divx into mp4,but commands from the web dont work :-( ....may can anybody help shortly,please ? :-)
[16:26:23 CEST] <ben__> btw.sorry for my bad english,im from Germany
[16:29:32 CEST] <transhuman> Hi, and thanks in advance, I have a question with ffmpeg. Rather an error. I think its the quotes or the order, anyone able to take a look and help?
[16:29:36 CEST] <transhuman> http://paste.debian.net/1028663/
[16:32:10 CEST] <kepstin> transhuman: at a minimum, you have a space in the filter options which shouldn't be there
[16:32:36 CEST] <kepstin> between a : and an option name
[16:34:39 CEST] <furq> that doesn't matter as long as it's quoted
[16:35:10 CEST] <furq> it's almost certainly the backslashes
[16:35:53 CEST] <furq> also you have \: instead of :\ in the fontfile path
[16:38:25 CEST] <transhuman> oh ok thanks
[16:44:59 CEST] <csierra_> https://paste.debian.net/hidden/912292c6/ extracting a frame 1 pixel wide results in the frame being tinted green, but only in Windows. Is there a fix for this?
[16:47:29 CEST] <transhuman> question how do I specify a space in the name of the font, (now its barking at the space in the font name I tried using \ or quotes around whole path or <6characters>~1.ttf but it doesnt work (this is on windows by the way)
[16:48:05 CEST] <transhuman> s/font name / font name)
[16:53:10 CEST] <JEEB> &33
[17:27:33 CEST] <Technicus> Hello, is it possible to create a v4l that is connected to a video file?
[17:40:17 CEST] <kerio> connected how
[18:35:02 CEST] <transhuman> ok so I hope this helps someone doing ffmpeg on windows, how to create scrolling text using ffmpeg on windows ffmpeg -y -i c:\Users\blues\Videos\-Split-Screens5\-Split-Screens5.mp4 -vf "drawtext=fontcolor=white:fontsize=40:fontfile='C\:\\Windows\\Fonts\\arial.ttf':textfile='C\:\\Users\\blues\\Videos\\-Split-Screens5\\Tickertxt.txt':reload=1:y=h-line_h-52:x=w-(mod(4*n\,w+tw)-tw/40),drawbox=y=ih-88:color=black at 0.4:width=iw:height
[18:35:02 CEST] <transhuman> =48:t=fill" -codec:v libx264 scrolling.mp4
[18:39:25 CEST] <ChocolateArmpits> it'd probably receive more longevity as an example in the documentation
[18:40:51 CEST] <ariyasu> whats with the weird path names transhuman
[18:41:03 CEST] <ariyasu> ChocolateArmpits congrats on having the best nick i've ever seen on irc
[18:44:04 CEST] <transhuman> it has to do with escaping characters
[18:44:22 CEST] <ariyasu> ahh
[18:44:29 CEST] <csierra_> ffprobe reports duration in the metadata, but not in streams. What causes this? And how can I pull that duration without having to grep for it? https://paste.debian.net/1028679/
[18:44:29 CEST] <transhuman> windows paths go the wrong way\
[18:44:40 CEST] <ariyasu> you shouldn't need to escape them in the command though
[18:44:57 CEST] <transhuman> still a small problem with it though, I cant use a time value for the speed of the ticker
[18:45:00 CEST] <furq> you do need to escape them because \s are interpreted by the filterchain parser
[18:45:07 CEST] <furq> as are :s
[18:45:22 CEST] <transhuman> that's weird because it wont run without it
[18:45:31 CEST] <ariyasu> ahh ok
[18:45:34 CEST] <transhuman> it tries and removes the paths
[18:45:41 CEST] <transhuman> err the slashes
[18:45:51 CEST] <furq> i said you do need to escape
[18:45:59 CEST] <transhuman> so doing that it removes one slash  and leaves the otheer
[18:46:06 CEST] <furq> or you might just be able to separately quote the path, i forget now
[18:46:25 CEST] <furq> generally on windows i just move everything into the working directory so i don't have to deal with the headache
[18:46:29 CEST] <transhuman> yeah it gets confused with the quotes too
[18:46:39 CEST] <transhuman> yeah I second that motion
[18:47:17 CEST] <transhuman> its funny the opposite is true with the -i switch
[18:52:53 CEST] <ChocolateArmpits> expressions extend functionality but are quite tedious to write
[21:43:48 CEST] <GuiToris> hello, I found this solution on the Internet. ffmpeg -i input.mp4 -lavfi '[0:v]scale=ih*16/9:-1,boxblur=luma_radius=min(h\,w)/20:luma_power=1:chroma_radius=min(cw\,ch)/20:chroma_power=1[bg];[bg][0:v]overlay=(W-w)/2:(H-h)/2,crop=h=iw*9/16' -vb 800K output.webm
[21:44:02 CEST] <GuiToris> Can you tell me how I can make the background less blurry?
[21:44:17 CEST] <GuiToris> which number controls the blurriness here?
[21:44:42 CEST] <durandal_1707> boxblur
[21:45:13 CEST] <GuiToris> durandal_1707, 20 is what I'm looking for?
[21:45:30 CEST] <durandal_1707> yes, try to increase it
[21:45:48 CEST] <GuiToris> you mean decrease, dont you
[21:46:53 CEST] <durandal_1707> no
[21:48:35 CEST] <GuiToris> okay, let's see
[21:49:30 CEST] <GuiToris> which 20 are you referring actually? luma_radius or chroma_radius?
[21:49:38 CEST] <furq> both
[21:49:57 CEST] <furq> i'm not sure why they're bothering to use the video dimensions in there
[21:51:46 CEST] <GuiToris> Ive changed both of them to 40
[21:52:10 CEST] <GuiToris> I'm waiting with excitement
[21:54:35 CEST] <GuiToris> hmm, it's still very blurry
[21:54:42 CEST] <GuiToris> I'll try to increase it even more
[21:56:49 CEST] <furq> try just replacing it with boxblur=2:1:2:1
[21:58:39 CEST] <GuiToris> ffmpeg -i input.mp4 -lavfi '[0:v]scale=ih*16/9:-1,boxblur=2:1:2:1:chroma_power=1[bg];[bg][0:v]overlay=(W-w)/2:(H-h)/2,crop=h=iw*9/16' -vb 800K output.webm
[21:58:43 CEST] <GuiToris> like this?
[21:59:14 CEST] <furq> boxblur=2:1:2:1[bg]
[21:59:51 CEST] <furq> https://ffmpeg.org/ffmpeg-filters.html#boxblur
[22:00:18 CEST] <furq> increase the values if it's not blurry enough
[22:00:42 CEST] <GuiToris> it's too blurry for me
[22:00:48 CEST] <GuiToris> I mean my original
[22:00:51 CEST] <GuiToris> 'my'
[22:01:00 CEST] <GuiToris> - it wasn't me who wrote that -
[22:01:13 CEST] <furq> yeah that was dividing the smaller video dimension by 20
[22:01:21 CEST] <furq> so for a 1080p video that'd be 54
[22:01:27 CEST] <furq> which is pretty high
[22:02:10 CEST] <furq> considering the default is 2
[22:02:10 CEST] <GuiToris> I'm about to fix horizontal videos with that line
[22:02:30 CEST] <furq> well specifically the blur was using the video dimensions, which seems unnecessary
[22:03:10 CEST] <GuiToris> I'd like to achieve this effect: http://www.youtube.com/watch?v=CgZsDLfzrTs
[22:03:31 CEST] <GuiToris> but this is way too blurry for me
[22:05:03 CEST] <furq> i've done a similar thing in the past and i just used boxblur=4:4:4:$
[22:05:04 CEST] <furq> 4
[22:06:23 CEST] <GuiToris> just to be on the safe side: ffmpeg -i input.mp4 -lavfi '[0:v]scale=ih*16/9:-1,boxblur=4:4:4:4[bg];[bg][0:v]overlay=(W-w)/2:(H-h)/2,crop=h=iw*9/16' -vb 800K output.webm
[22:06:27 CEST] <GuiToris> did you mean this?
[22:06:47 CEST] <GuiToris> I use ffmpeg on a much lower level
[22:06:58 CEST] <furq> more or less
[22:07:07 CEST] <GuiToris> I'll give it a try :)
[22:07:12 CEST] <furq> fwiw for debugging you probably want to use something faster than libvpx
[22:07:22 CEST] <furq> ideally you'd just use -c:v rawvide -f nut - | mpv -
[22:07:24 CEST] <furq> rawvideo
[22:07:40 CEST] <furq> but if you can't pipe into a player for whatever reason then use x264 ultrafast or something
[22:09:32 CEST] <GuiToris> hey this is quite good (4:4:4:4)
[22:09:36 CEST] <GuiToris> I like it
[22:09:40 CEST] <GuiToris> thank you very much :)
[22:26:38 CEST] <transhuman> hi! I have a similar command that works with ffmpeg on windows https://pastebin.com/Rpw4rwvH this one generates an error on linux, one of the options it doesn't like but it doesn't say which
[22:29:44 CEST] <furq> transhuman: there's no such argument boxcolor, it's just color
[22:30:03 CEST] <furq> i guess it got renamed and you're running an old build on windows
[22:30:43 CEST] <transhuman> thanks
[23:38:26 CEST] <nicolas17> looks like if I have two mono audio streams, and I want to turn them into channels in a stereo stream, I can use the amerge filter
[23:38:46 CEST] <nicolas17> but what if my inputs are stereo? how do I mix them into mono first?
[23:39:16 CEST] <JEEB> there's a filter to just take different channels from various inputs as some channel ampping
[23:39:38 CEST] <furq> !filter pan @nicolas17
[23:39:38 CEST] <nfobot> nicolas17: http://ffmpeg.org/ffmpeg-filters.html#pan-1
[23:39:44 CEST] <furq> or -map_channel
[23:39:58 CEST] <furq> or you can just use amix
[00:00:00 CEST] --- Mon Jun 11 2018

More information about the Ffmpeg-devel-irc mailing list