[Ffmpeg-devel-irc] ffmpeg.log.20180615

burek burek021 at gmail.com
Sat Jun 16 03:05:02 EEST 2018

[00:45:50 CEST] <sau> I am new with this.. is it ok to ignore the warnings for x264 when compiling ffmpeg?
[01:07:45 CEST] <sau> it works..
[02:25:33 CEST] <YokoBR> hi folks
[02:26:10 CEST] <YokoBR> please, I'm receiving blob parts and trying to write them to a file with ffmpy (python)
[02:26:29 CEST] <YokoBR> my cmd: ffmpeg -vcodec libx264 -pix_fmt yuv420p -s:v 640x480 -i pipe:0 -c:v libx264 -f mp4 teste.mp4
[02:26:57 CEST] <YokoBR> Input #0, lrc, from 'pipe:0':   Duration: N/A, bitrate: N/A     Stream #0:0: Subtitle: text Output #0, mp4, to 'teste.mp4': Output file #0 does not contain any stream
[02:27:22 CEST] <YokoBR> It's a blob from javascript (mediarecorder stream)
[02:45:43 CEST] <klaxa> try mkv? stream only contains subtitles?
[03:26:47 CEST] <YokoBR> klaxa: stream contain video from mediarecorder
[04:42:19 CEST] <bolds> can anyone help me with an error on ffmpeg built for android?
[06:24:40 CEST] <rngkll> Hi, I'm trying to use vaapi for hardware acceleration, but I'm facing a couple of problems, is there a way to identify the card?, I can see renderD128 but I don't know if this is the intel graphics or the radeon I have
[15:49:42 CEST] <kepstin> rngkll: there should be some info in sysfs that can tell you which nodes belong to which card.
[16:28:31 CEST] <leewdch> I'm working with webms and still images in videos, are there options I can use to save video bitrate and/or optimize the result? I sometime notice compression artifacts even if the image is still
[16:32:45 CEST] <furq> leewdch: not sure if you can change anything other than -deadline and -cpu-used
[16:32:54 CEST] <furq> and -crf but obviously that'll increase the bitrate
[16:33:41 CEST] <leewdch> I used 500k for start but didn't use crf
[16:34:13 CEST] <furq> https://trac.ffmpeg.org/wiki/Encode/VP9#speed
[16:34:22 CEST] <kepstin> make sure you're using vp9 not vp8
[16:34:25 CEST] <leewdch> using vp8 tho
[16:34:30 CEST] <furq> oh right
[16:34:32 CEST] <furq> don't do that then i guess
[16:34:47 CEST] <leewdch> wish I could but I'll have a read regardless
[16:48:27 CEST] <leewdch> using -vf scale triggers a warning saying I used a depcreated pixel format or at least that's what I think. what does it mean?
[16:49:09 CEST] <kepstin> leewdch: you're using jpeg images as input, eh. just ignore it unless you're an ffmpeg dev.
[16:50:41 CEST] <leewdch> ah ok so nothing wrong using vf scale instead of -s
[16:51:21 CEST] <kepstin> the -s output option just adds a scale filter on the end of the filter chain
[16:51:52 CEST] <leewdch> got it
[16:58:21 CEST] <TheAMM> I'm back to recording stuff with the capture device, doing -c:v copy for h264 video and alsa
[16:58:29 CEST] <TheAMM> How can I shift the video to fix "[matroska @ 0x12e9660] Non-monotonous DTS in output stream 0:0; previous: 0, current: -79; changing to 0."?
[16:58:38 CEST] <TheAMM> -copyts and -start_at_zero seem to do nothing
[16:59:21 CEST] <TheAMM> Full command is https://mygi.ga/bG0/aecCf.txt
[17:00:29 CEST] <TheAMM> which nets me https://mygi.ga/rm9/aecCg.txt
[17:01:36 CEST] <TheAMM> oh nvm, missed avoid_negative_ts, lessee
[17:04:09 CEST] <TheAMM> No dice
[17:16:07 CEST] <kepstin> TheAMM: yeah, I wouldn't expect copyts from arbitrary inputs to always work properly with different outputs, since what each container allows as timestamps is different
[17:17:28 CEST] <kepstin> weird that the device is providing negative timestamps, what kind of hardware is it?
[17:17:46 CEST] <TheAMM> Still the Avermedia LGP2
[17:17:55 CEST] <TheAMM> I would expect -avoid_negative_ts make_non_negative to do something, but it doesn't
[17:18:47 CEST] <TheAMM> I'm trying to find a hassle-free way to sync the video and audio, but it's troublesome
[17:21:41 CEST] <kepstin> hmm. according to that ffmpeg output, the timestamps actually went *backwards* in the input
[17:21:55 CEST] <kepstin> so it successuflly adjusted the first one to be zero, then the next was earlier
[17:22:44 CEST] <TheAMM> Then I'm shit out of luck
[17:25:31 CEST] <kepstin> hmm. so that device is usb, showing up as uvc + usb-audio?
[17:26:03 CEST] <TheAMM> Yes
[17:26:17 CEST] <kepstin> that's kind of a pain, but I'd normally expect the sync to be fairly close between the two unless it's really slow to initialize or something.
[17:26:20 CEST] <TheAMM> I hoped that I could have it sync up by fixing the early frames
[17:26:43 CEST] <TheAMM> All the menu transitions in the PS4 are damned fades and shifts and slides
[17:27:12 CEST] <TheAMM> So I'll have to go hunting for some sharp cue to manually sync the av
[17:31:18 CEST] <kepstin> you could maybe try the "-timestamps abs" or "-timestamps mono2abs" option on the v4l input, which might make it retimestamp the video in a way that'll work.
[17:31:28 CEST] <kepstin> (if you do that, drop the -copyts, etc. options)
[17:32:09 CEST] <Plug> Howdy, just wondering - when adding chapter names to a video via the ffmetadata files, is it part of how it works to add a subtitle track with the chapter names in the subs?
[17:32:15 CEST] <Plug> Or is that a VLC thing?
[17:57:36 CEST] <theonebobo> Using this command https://pastebin.com/QHQfMtU8 i am converting an mp3 to a mp4 with a static image it generates this file http://abls.boboland.info/paradigm/temp/fountains-from-drought-to-deluge.mp4 which firefox and roku both say are corupted
[17:58:50 CEST] <theonebobo> ffmpeg version N-91282-gc5e6c0b5f6 Copyright (c) 2000-2018 the FFmpeg developers
[18:00:22 CEST] <kepstin> theonebobo: the ffmpeg output helpfully warned you when you encoded that file that you might want to use yuv420p pixel format for compatibility reasons. Add the output option "-pix_fmt yuv420p" to do that.
[18:02:10 CEST] <kepstin> actually, huh, was that warning removed at some point? I'm not seeing it any more with 4.0
[18:03:49 CEST] <furq> looks like they did
[18:03:53 CEST] <furq> or it was, rather
[18:04:18 CEST] <kepstin> might have been an oversight when the work for multi-bit-depth x264 was done, i guess.
[18:06:19 CEST] <theonebobo> looks like it was using yuvj444p before will try thanks
[18:07:51 CEST] <theonebobo> glad i didn't miss the warning I may not know much but i can pay attention to red and yellow text :P
[18:14:53 CEST] <kepstin> hmm. with a quick look through the git history I can't see where that warning was added or removed. :/
[18:18:09 CEST] <furq> kepstin: git log -S No\ pixel\ format\ specified fftools/ffmpeg.c
[18:18:32 CEST] <furq> too lazy to update the repo here but that should work
[18:18:57 CEST] <kepstin> oh, no wonder, I was looking in the wrong place. I thought that was in the encoder not ffmpeg.c. Of *course* i'ts in ffmpeg.c :/
[18:19:03 CEST] <furq> lol
[18:19:07 CEST] <furq> yeah i looked there first as well
[18:27:22 CEST] <kepstin> hmm. the mailing list thread for that started with a patch to make NV12 (and possibly other 4:2:0 formats?) not trigger the warning, had a bunch of arguing about the fact that 4:2:0 sampling not being sufficient to ensure compatibility, and resulted in a patch that removed the check altogether
[18:27:51 CEST] <kepstin> leaving users who accidentally make 4:4:4 sampled videos from still image input the people who lose in the end :/
[18:28:46 CEST] <theonebobo> Thank you again that worked a treat.
[19:56:53 CEST] <BSODjunkie> anyone here can help me change this command to automatic bitrate with -crf 20?
[19:56:58 CEST] <BSODjunkie> "ffmpeg.exe -hwaccel cuvid -i input.mkv -pix_fmt p010le -c:v hevc_nvenc -preset slow -rc vbr_hq -b:v 5M -maxrate:v 10M -c:a aac -b:a 240k output2.mp4"
[20:07:09 CEST] <kepstin> BSODjunkie: nvenc doesn't support/use the crf option.
[20:07:13 CEST] <kepstin> (iirc)
[20:08:21 CEST] <furq> nvenc uses -cq iirc
[20:08:23 CEST] <furq> which is broadly similar
[20:08:27 CEST] <kepstin> apparently it does have a "constant quality" mode, yeah
[20:09:21 CEST] <furq> so i guess you want something like -preset hq -cq 20
[20:09:41 CEST] <furq> also 240k is a ridiculous bitrate for stereo aac
[20:09:51 CEST] <kepstin> i'd expect the -cq range to not be directly comparable to x265's crf range, so you might have to play around with the number.
[20:10:00 CEST] <furq> use 192k if you're really paranoid, but 128k should be fine
[20:10:17 CEST] <ariyasu> im watching world cup in uhd atm, and they are just using 128kbps aac audio
[20:10:36 CEST] <furq> yeah 128k stereo is pretty much transparent with a good encoder
[20:10:50 CEST] <furq> surprised they're not going with 5.1 though
[20:11:23 CEST] <ariyasu> bbc had an article saying they couldnt use 5.1 but didn't really explain why
[20:11:55 CEST] <ariyasu> "The audio will be stereo AAC-LC at 128 kbit/s. Whilst we would like to provide multi-channel sound we have found a number of issues with receivers which are difficult to work-around. We will continue to explore solutions for future events."
[20:12:03 CEST] <ariyasu> it's fine though
[20:12:04 CEST] <furq> is that broadcast or on iplayer
[20:12:18 CEST] <furq> oh nvm they're not broadcasting it at all are they
[20:12:25 CEST] <ariyasu> well im actually watching the broadcast on NPO 1 UHD
[20:12:33 CEST] <ariyasu> and there are 4k back haul feeds too
[20:12:37 CEST] <furq> oh fun
[20:12:54 CEST] <furq> i'm pretty sure they're not set up to broadcast it here
[20:13:57 CEST] <ariyasu> https://i.imgur.com/bgH3ggR.png
[20:14:13 CEST] <furq> really making use of that 4k there
[20:14:35 CEST] <ariyasu> lol well it gets maximised on a 4k monitor
[20:14:51 CEST] <ariyasu> but that would make the screenshot too big and hard to see the audio bitrate
[20:15:09 CEST] <furq> i was going to say, i hope you resized it for the screenshot because that scaling is ugly
[20:16:10 CEST] <BSODjunkie> guys when I encode to H.265 my files get bigger, I just copy pasted a command from a guide
[20:16:21 CEST] <BSODjunkie> ffmpeg.exe -hwaccel cuvid -i input.mkv -pix_fmt p010le -c:v hevc_nvenc -preset slow -rc vbr_hq -b:v 5M -maxrate:v 10M -c:a aac -b:a 240k output2.mp4
[20:16:41 CEST] <BSODjunkie> I tried removing the bitrate part, and I also tried removing the 10bit part, files still bigger than before
[20:17:07 CEST] <ariyasu> what is the source videos spec?
[20:17:21 CEST] <furq> i mean i have some better advice: don't do this at all
[20:17:23 CEST] <kepstin> BSODjunkie: why do you want to re-encode the source file? if it's already lossy, e.g. h264, there's probably no point.
[20:17:43 CEST] <BSODjunkie> kepstin: Well I managed to bring 1 huge high-def video down from 3gb to 1gb, but when I run the script on small video it gets bigger
[20:17:48 CEST] <furq> and especially don't do this with nvenc
[20:17:56 CEST] <furq> nvenc's hevc encoder is generally worse than x264
[20:17:57 CEST] <kepstin> BSODjunkie: and if you want high efficiency encoding, use x265, and expect to wait a long time
[20:18:07 CEST] <BSODjunkie> kepstin: oh I see
[20:18:15 CEST] <BSODjunkie> kepstin: so there is no good GPU accelerated one?
[20:18:20 CEST] <furq> not for archival
[20:18:39 CEST] <BSODjunkie> furq: I have 150gb of H.264 video, was hoping to get it down to around 60gb
[20:18:40 CEST] <furq> the gpu encoders are all intended for realtime
[20:18:42 CEST] <kepstin> hardware encoders (not gpu accelerated) are generally designed for high-speed or realtime encoding, not archival quality.
[20:19:12 CEST] <BSODjunkie> kepstin: What kind of performance would I get with gpu accelerated?
[20:19:19 CEST] <furq> there's no such thing really
[20:19:31 CEST] <kepstin> gpu accelerated stuff encoders are mostly not used nowadays, and don't provide much benefit over software for the ones that have been made
[20:19:47 CEST] <BSODjunkie> kepstin: damn I'm working with my 4 core laptop cpu, it's going to be really slow
[20:19:49 CEST] <furq> certainly none of the best-in-class encoders have any meaningful acceleration
[20:20:13 CEST] <BSODjunkie> furq: I see, so what settings do you suggest for encoding for H.264 -> H.265
[20:20:15 CEST] <furq> the only way you're going to get meaningful size reductions is by either ruining the quality or scaling to a lower resolution
[20:20:31 CEST] <BSODjunkie> furq: I'm fine with loss, the video files are pretty overkill
[20:20:58 CEST] <furq> even x265 veryslow (which will be something like 1fps for 1080p on a laptop cpu) isn't going to give very big gains unless you reduce the quality
[20:21:02 CEST] <kepstin> BSODjunkie: in general: "don't do that, it's a waste of time", and if you really want the file smaller, also "consider using x264 instead, it's faster and usually good enough"
[20:21:23 CEST] <BSODjunkie> kepstin: I thought x265 was supposed to be better than x264 in terms of file size?
[20:21:35 CEST] <furq> it is but only if you want to wait a day to encode an hour-long file
[20:21:37 CEST] <kepstin> BSODjunkie: yes, if you are prepared to wait a lot longer for the encode
[20:21:53 CEST] <furq> and also it's generally not that much better
[20:22:09 CEST] <kepstin> if you tune x265 to be as fast as x264, it's gonna give you very similar encoding efficiency.
[20:22:13 CEST] <furq> 150GB to 60GB with no quality loss is not going to happen
[20:22:19 CEST] <kepstin> (depending on video content, resolution, etc.)
[20:22:22 CEST] <BSODjunkie> My file is 13,381kbps, if I wanted to bring that down to around 5,000. Can I just use the script I have now?
[20:22:24 CEST] <furq> if you downscale then maybe
[20:22:26 CEST] <BSODjunkie> I am fine with quality loss
[20:22:43 CEST] <BSODjunkie> I am keeping the originals, my dad just wants a copy, he's going to play it on his projector anyway
[20:23:06 CEST] <BSODjunkie> trying to figure out how to get it small enough to ship on a 64gb usb stick
[20:23:28 CEST] <furq> i take it your internet isn't fast enough to make uploading it a viable option
[20:23:42 CEST] <BSODjunkie> furq: it would be but he can barely use a computer
[20:23:49 CEST] <furq> nice
[20:23:59 CEST] <kepstin> BSODjunkie: downscale it to 1080p or lower, encode with x264 with a target bitrate, 2-pass mode. save in mp4 file.
[20:24:05 CEST] <BSODjunkie> kepstin: it is 1080p bluray
[20:24:44 CEST] <BSODjunkie> kepstin: What does 2 pass mode do?
[20:25:17 CEST] <BSODjunkie> kepstin: also why x264 instead of x265
[20:25:27 CEST] <BSODjunkie> kepstin: oh cause of the time
[20:25:31 CEST] <furq> 2-pass mode lets you target a specific bitrate
[20:25:34 CEST] <kepstin> 2pass mode lets you set a target bitrate (file size) and make it as high quality as possible
[20:25:48 CEST] <BSODjunkie> didn't my original command have a target bitrate
[20:25:53 CEST] <BSODjunkie> ffmpeg.exe -hwaccel cuvid -i input.mkv -pix_fmt p010le -c:v hevc_nvenc -preset slow -rc vbr_hq -b:v 5M -maxrate:v 10M -c:a aac -b:a 240k output2.mp4
[20:25:57 CEST] <BSODjunkie> isn't that 5M the target?
[20:25:59 CEST] <furq> yeah but if it came out bigger than 13mbit then it's obviously being ignored
[20:26:00 CEST] <kepstin> and x264 is faster, and is more likely to play on the computer of someone who "can barely use a computer"
[20:26:18 CEST] <BSODjunkie> kepstin: I got him a recent XPS 13 so it'll be fine in terms of that
[20:26:51 CEST] <BSODjunkie> kepstin: okay thanks, also what is a good way to compare video quality?
[20:26:58 CEST] <kepstin> BSODjunkie: eyes
[20:26:59 CEST] <furq> your eyes
[20:27:11 CEST] <furq> that sounds facetious but there isn't a great automatic method to do it
[20:27:22 CEST] <BSODjunkie> weird cause I made the 3gb file go to 1gb with GPU and didn't see a difference
[20:27:26 CEST] <BSODjunkie> maybe I should wear my glasses haha
[20:27:48 CEST] <BSODjunkie> Thank you guys, if you want my python script I wrote to automate this (it's a bunch of vids), here it is https://paste.pound-python.org/show/68dBQAW5t3rdJuyXQ87q/
[20:27:50 CEST] <furq> honestly though if he's playing the files on his laptop then surely he can figure out how to download a file from a link
[20:27:50 CEST] <kepstin> blu-ray files are encoded with fairly poor efficiency so that things like seeking are fast given the slow media and hardware decoders
[20:27:58 CEST] <Blacker47> BSODjunkie, there is also no real use reencoding the audio unless you need a specific format.
[20:28:13 CEST] <kepstin> so you can usually re-encode blu-ray to be smaller with minimal visible quality loss
[20:28:16 CEST] <BSODjunkie> Blacker47: Thanks, I just copy pasted the command as I know nothing about encoding
[20:28:42 CEST] <BSODjunkie> kepstin: I guess that was it then
[20:28:50 CEST] <furq> i would at least send him a single file and see if he can figure it out before reencoding 130GB
[20:28:58 CEST] <Blacker47> BSODjunkie, buying an external drive would be an option too...
[20:28:59 CEST] <BSODjunkie> furq: What do you mean?
[20:29:16 CEST] <BSODjunkie> Blacker47: It's an issue of location he doesn't live in the same country, I am going to ship the USB
[20:29:34 CEST] <kepstin> also, 130GB is strange for a BD, for non-uhd (BDXL) stuff I thought they maxed out at 75 GB/disk?
[20:29:43 CEST] <BSODjunkie> kepstin: it's a bunch of files
[20:29:48 CEST] <BSODjunkie> kepstin: it's around 50 files 3gb each
[20:30:03 CEST] <kepstin> a, probably a tv series that was originally on multiple disks then
[20:30:09 CEST] <BSODjunkie> keptsin: exactly that
[20:30:18 CEST] <furq> BSODjunkie: i mean i would just upload the originals somewhere unless he absolutely can't figure out how to click a link
[20:30:28 CEST] <furq> i take it you've already tried that and it's not working for him
[20:30:41 CEST] <BSODjunkie> furq: To be honest it's not really a technical issue, I just can't convince him to download anything he thinks he'll get viruses and stuff. I've tried.
[20:30:46 CEST] <furq> nice
[20:31:17 CEST] <BSODjunkie> furq: it's because he got in trouble once downloading pirated software on a work laptop or something like that as well I think.
[20:31:54 CEST] <BSODjunkie> right thanks guys
[20:31:59 CEST] <Blacker47> usb flashdrives sendet over countries is of course total safe instead :-)
[20:32:03 CEST] <furq> lol
[20:32:31 CEST] <furq> just make sure there's no moscow postmark on it
[20:32:35 CEST] <BSODjunkie> Blacker47: it's not the same, someone told him he could get a software cheap and installed a pirated version, which is a big nono
[20:32:41 CEST] <BSODjunkie> nah the company doesn't care about movies
[20:32:46 CEST] <BSODjunkie> just no work can be done using pirates software
[20:32:50 CEST] <BSODjunkie> for obvious reasons
[20:33:16 CEST] <BSODjunkie> I'm not 100% sure of the story behind it, but either way, movies/shows are fine
[20:33:54 CEST] <BSODjunkie> plus actually it'll be his xps 13, so the work thing shouldn't matter.
[20:34:13 CEST] <BSODjunkie> anyway, can someone praise me for my python script so I can log off.
[20:34:25 CEST] <BSODjunkie> https://paste.pound-python.org/show/68dBQAW5t3rdJuyXQ87q/
[20:34:40 CEST] <YokoBR> guys, please, i'm trying to create a subproccess on python, running ffmpeg
[20:34:51 CEST] <BSODjunkie> YokoBr: Perfect! I've got a script for you
[20:34:55 CEST] <BSODjunkie> hahaha
[20:35:15 CEST] <BSODjunkie> the script I pasted there, will run ffmpeg on every file in a folder, and output to a new subfolder it creates :)
[20:35:28 CEST] <kepstin> BSODjunkie: ah, you're correctly running the subprocess using a method where you don't need to worry about string escaping, that's nice ;)
[20:35:52 CEST] <YokoBR> I'm doing like this https://gist.github.com/jersobh/06cad7527d07699b6a4f9f158cfbff60
[20:35:58 CEST] <BSODjunkie> kepstin: let's pretend I did that on purpose, can you tell me what that means? I'm new to python
[20:36:06 CEST] <YokoBR> and getting this output https://gist.github.com/jersobh/e059d5d1d95fedf2f4570bae5218d570
[20:36:09 CEST] <kepstin> BSODjunkie: it's windows specific script tho, so :/
[20:36:22 CEST] <BSODjunkie> kepstin: ah sorry
[20:36:47 CEST] <BSODjunkie> YokoBR: why are you writing defaults into args? like stdout=None?
[20:37:06 CEST] <YokoBR> args = ['ffmpeg', '-i', '-', '-pix_fmt', 'yuv420p', '-s', '720x480', '-framerate', '25 ', '-vcodec', 'libx264', '-preset', 'slow', '-async', '1', '-vsync', '1', '-f', 'flv', url]
[20:37:22 CEST] <YokoBR> I'm using getusermedia + websockets to send chunks
[20:37:35 CEST] <YokoBR> and then write the chunks with this stdin
[20:37:37 CEST] <Blacker47> BSODjunkie, just to run things in parallel there you don't need per-file specific parameters beside of filenames you can use the programm "parallel" or at least "xargs".
[20:37:39 CEST] <BSODjunkie> YokoBR: that's above my head, but if you look at my script you can get a working version
[20:37:55 CEST] <BSODjunkie> YokoBR: justlook at lines 42ish: https://paste.pound-python.org/show/68dBQAW5t3rdJuyXQ87q/
[20:37:58 CEST] <kepstin> YokoBR: all i can tell you is that the input isn't something that ffmpeg can handle in a pipe. What's the exact input format?
[20:38:01 CEST] <YokoBR> It works, but soon it starts to complain
[20:38:20 CEST] <YokoBR> it's webm/vp8 or vp9
[20:38:47 CEST] <furq> oh yeah that reminds me
[20:38:48 CEST] <kepstin> YokoBR: if each chunk is an independent webm file, then you're gonna have issues.
[20:39:04 CEST] <furq> is ffprobe guaranteed to output streams from 0..n in order with no gaps
[20:39:22 CEST] <YokoBR> if I just do a video = open('video.webm', 'wb') then video.write(chunk), it creates the video file locally
[20:39:25 CEST] <YokoBR> without issues
[20:40:34 CEST] <YokoBR> I've used mediarecorder to get the mediastream
[20:40:49 CEST] <YokoBR> and then I'm sending it to my python API
[20:41:12 CEST] <kepstin> YokoBR: if you write out the chunks to a file, then use that file as ffmpeg input, i'd expect the same output messages.
[20:41:53 CEST] <YokoBR> https://youtu.be/0fKglyoaiAU
[20:41:58 CEST] <YokoBR> i've recorded this
[20:42:03 CEST] <YokoBR> almost works
[20:42:21 CEST] <YokoBR> https://youtu.be/4ycJ07wdRjs
[20:42:35 CEST] <YokoBR> all of those are live recordings on youtube
[20:53:41 CEST] <YokoBR> kepstin: do you have any suggestion?
[20:54:44 CEST] <YokoBR> I just want to send video from my browser to rtmp
[20:54:47 CEST] <YokoBR> like youtube does
[20:58:14 CEST] <nicolas17> does it?
[21:02:56 CEST] <YokoBR> yep
[21:03:20 CEST] <nicolas17> I don't think there is any web API for rtmp
[21:06:37 CEST] <nicolas17> youtube streaming from the browser might use webrtc
[21:14:10 CEST] <YokoBR> nicolas17: yep, they may use
[21:15:11 CEST] <nicolas17> well that's not rtmp
[21:31:20 CEST] <kepstin> i'd assume if they're using webrtc, they're actually doing rtp video, not chunked video in websockets
[23:47:21 CEST] <GuiToris> hey, how can I rotate my video 1.5 degrees counterclockwise so I don't have any black borders?
[23:47:50 CEST] <nicolas17> 1.5 degrees? :|
[23:48:05 CEST] <GuiToris> if it's not possible 1 will do
[23:48:21 CEST] <furq> !filter rotate @GuiToris
[23:48:21 CEST] <nfobot> GuiToris: http://ffmpeg.org/ffmpeg-filters.html#rotate
[23:48:31 CEST] <nicolas17> -vf rotate=1.5*PI/180
[23:49:07 CEST] <GuiToris> nicolas17, it gives me borders
[23:49:18 CEST] <nicolas17> I guess you have to crop it afterwards then
[23:49:20 CEST] <furq> ^
[23:49:33 CEST] <furq> you always have to crop after rotate
[23:49:39 CEST] <furq> unless you rotate by 90 degrees or something
[23:49:48 CEST] <nicolas17> ohh maybe you don't need a separate crop filter
[23:50:14 CEST] <BtbN> rotate to get rid of black borders? what?
[23:50:45 CEST] <nicolas17> -vf "rotate=1.5*PI/180:ow=rotw(a):oh=roth(a)"
[23:52:15 CEST] <GuiToris> nicolas17, does this work for you?
[23:52:25 CEST] <nicolas17> no, I didn't test it
[23:52:27 CEST] <GuiToris> [aac @ 0x55c8f5bf89c0] 2 frames left in the queue on closing
[23:52:49 CEST] <GuiToris> Conversion failed!
[23:53:08 CEST] <nicolas17> that's an audio codec warning, so it can't be related to the rotate
[23:53:16 CEST] <nicolas17> aac is audio
[23:55:40 CEST] <GuiToris> why does ffmpeg -ss 00:00:38 -i 00121.MTS -t 00:00:10 -vf vidstabtransform=input="./thing.trf",rotate=1.5*PI/180 -crf 16  -deinterlace okay2.mp4 work but ...-vf vidstabtransform=input="./thing.trf","rotate=1.5*PI/180:ow=rotw(a):oh=roth(a)"... doesn't?
[23:56:13 CEST] <nicolas17> old ffmpeg without rotw?
[23:57:01 CEST] <GuiToris> local/ffmpeg 1:4.0-1
[23:59:20 CEST] <GuiToris> oh wait there's more message
[23:59:31 CEST] <GuiToris> my terminal was extremely small
[00:00:00 CEST] --- Sat Jun 16 2018

More information about the Ffmpeg-devel-irc mailing list