[Ffmpeg-devel-irc] ffmpeg.log.20180617

burek burek021 at gmail.com
Mon Jun 18 03:05:02 EEST 2018

[00:00:17 CEST] <furq> it's cross-platform
[00:00:48 CEST] <faLUCE> ok thanks
[04:21:28 CEST] <fa0> Hello
[04:22:05 CEST] <fa0> Don't mind the way the layout looks, I run the cmds in a shell script, and I was just running this to change an avi to mkv;
[04:22:07 CEST] <fa0> ffmpeg -i "$i" -c:v copy -c:a copy "$OUTPUT/${i%.*}.mkv"
[04:23:15 CEST] <fa0> then the mkv doesn't play in mpv
[04:23:42 CEST] <fa0> I get this at the terminal; http://dpaste.com/2S9FT0G
[04:23:59 CEST] <fa0> But if I remux the avi in mkvmerge, it plays in mpv, so I'm confused here... ;/
[05:01:56 CEST] <Darkclaw> I am trying to add a preview/thumbnail to a video so that it shows up when displaying the icon of the video. How can I set that up?
[06:29:06 CEST] <Shibe> hi, what does this mean "Internal frame allocation is not currently supported - all frames must be allocated by the user. Thus AVHWFramesContext is always NULL, though this may change if support for frame allocation is added in future. "
[12:31:21 CEST] <joshuaavalon> Do anyone know why ffmpeg keep adding "handle_name" to metadata? For example, if I run "ffmpeg -i 1.mp4 -map_metadata -1 -codec copy 2.mp4", it add  "handle_name" to metadata.
[12:31:39 CEST] <joshuaavalon> *handler_name
[13:41:47 CEST] <analogical> "ffmpeg -i input.mkv -c copy out.mp4" <- what does the copy command do and is it necessary?
[13:48:39 CEST] <analogical> I love FFmpeg but the documentation sucks!
[13:51:22 CEST] <klaxa> i've seen far worse documentation
[13:51:40 CEST] <klaxa> also -c copy tells ffmpeg to copy all codecs
[13:51:58 CEST] <klaxa> if you don't add it ffmpeg will use the default encoders for the container of the output resulting in re-encoding
[13:52:42 CEST] <analogical> klaxa, I see and what does the "-c" do?
[13:53:22 CEST] <klaxa> set codecs for the output
[13:54:11 CEST] <analogical> what codecs?
[13:54:22 CEST] <analogical> there are none specified in the example
[13:57:58 CEST] <klaxa> what do you mean "what codecs"? the codecs ffmpeg will use to encode the output file
[14:13:01 CEST] <analogical> when I use FFmpeg to create an mp3-file how to I specify the bitrate?
[14:14:31 CEST] <furq> analogical: -b:a 320k or preferably -q:a 0
[14:15:31 CEST] <analogical> thanks
[14:28:57 CEST] <kerio> even more preferably, -c:a opus
[14:32:04 CEST] <furq> libopus
[14:35:10 CEST] <kerio> is that different
[14:35:48 CEST] <furq> yes
[14:39:31 CEST] <kerio> :o
[15:10:02 CEST] <CoreX> analogical if the documentation sucks why not google what you need as pretty much 9/10 times its covered by another person wanting to know on stackoverflow
[15:26:27 CEST] <furq> and 9 times out of 10, the information on stackoverflow is either outdated or it was always wrong
[15:28:40 CEST] <furq> analogical: the encode/(codec) pages on the ffmpeg wiki are usually pretty good
[15:29:06 CEST] <furq> https://trac.ffmpeg.org/wiki/Encode/MP3
[15:29:10 CEST] <furq> for example
[15:31:57 CEST] <Orbstheorem> Hi, what method do you recommend to store loseless music with subtitles in a single file?
[15:32:15 CEST] <Orbstheorem> I've though of mkv, but mainly because I don't know about anything else
[15:32:30 CEST] <Orbstheorem> (mkv using wavpack)
[15:41:49 CEST] <furq> Orbstheorem: what are you hoping to play the subtitles back in
[15:42:26 CEST] <norbert> hi, I'm using CentOS 7 and I'm trying to follow the steps here https://linoxide.com/linux-how-to/install-ffmpeg-centos-7/
[15:42:47 CEST] <norbert> at step 1, it says I have to enable the Nux Dextop, but the second rpm command mentioned there doesn't do anything
[15:43:02 CEST] <furq> norbert: https://www.johnvansickle.com/ffmpeg/
[15:43:05 CEST] <furq> it's easier to just use those
[15:43:06 CEST] <norbert> is this a problem or can I just continue with step 2?
[15:43:31 CEST] <norbert> I prefer to yum install something, to keep the packages up to date
[15:44:49 CEST] <norbert> hm, this seems to work https://linuxadmin.io/install-ffmpeg-on-centos-7/
[15:45:19 CEST] <furq> http://li.nux.ro/download/nux/dextop/el7/x86_64/
[15:45:26 CEST] <furq> it looks like the newest ffmpeg in there is 2.6
[15:45:37 CEST] <furq> which is like two years old
[16:13:32 CEST] <Orbstheorem> furq: mpv in console mode
[16:13:44 CEST] <Orbstheorem> as in `mpv --no-video`
[16:15:46 CEST] <Hello71> rpmfusion has 2.8
[16:16:22 CEST] <Hello71> but really if you want something not assballs old you shouldn't be using rhel in the first place
[16:23:20 CEST] <furq> Orbstheorem: probably flac in mka is fine then
[16:23:34 CEST] <furq> i would suggest ogg flac but apparently ffmpeg doesn't support ogg subtitles
[16:23:47 CEST] <Guiardn> Hi, I've had some trouble with the WebVTT format. What I've gotten is a m3u8 link with a "playlist" of the WebVTT segments (around 300 segments). My trouble is getting ffmpeg to get the header and syncronize the individual segments to the right time. For some reason it just takes whatever time they say and therefore the "appended" result is just not right. Do anyone in here know how to fix that? (Tried newest version and older versi
[16:35:36 CEST] <Guiardn> I know m3u8x would solve my problem, but there is no commandline for that program. It's purely Gui. Is there any work arounds to use the one, that the answers suggest around.
[18:16:07 CEST] <Tzimmo> Is there a way to search for I-frame timestamps somehow? I'm trying to cut some .ts files and I'd like to use copy to avoid re-encoding most parts between I-frames and then re-encode a few frames before/after that point and concat those videos to get smooth end result.
[18:16:40 CEST] <Tzimmo> Or to list all frame types and their timestamps (to be used in -ss and -t options)
[18:42:11 CEST] <furq> Tzimmo: ffprobe -show_frames -show_entries frame=best_effort_timestamp_time,pict_type -of compact foo.mkv | grep pict_type=I
[19:12:23 CEST] <Tzimmo> furq: ok... then that .ts file doesn't start from timestamp 0 even though -ss 1 works to seek one second from the beginning... is there a way to make the output start from 0 or do I just need to calculate it myself?
[19:13:07 CEST] <Tzimmo> furq: Thanks for that cmdline, I would have never managed to figure that out myself... didn't even know about ffprobe :)
[20:32:30 CEST] <Mithgol> I've noticed that FFmpeg 4.0 produces worse animated GIFs than FFmpeg 3.4.2 using the custom palette approach explained in http://blog.pkh.me/p/21-high-quality-gif-with-ffmpeg.html especially obvious if "paletteuse=dither=bayer:bayer_scale=0" is used to fill the whole image with Bayer patterns. Should I suspect a recent regression in FFmpeg?
[20:42:01 CEST] <Cracki> show us "worse"
[20:47:32 CEST] <furq> none of the gif stuff in lavc has been touched for two years
[20:47:39 CEST] <furq> and paletteuse/palettegen haven't been touched in about six months
[20:47:48 CEST] <furq> so that'd be weird if there was a regression
[21:27:59 CEST] <Mithgol> Some examples:
[21:28:00 CEST] <Mithgol> http://410chan.org/b/src/152573166087.gif by v4 vs. http://410chan.org/b/src/152634060829.gif by v3.4.2
[21:28:02 CEST] <Mithgol> http://410chan.org/b/src/152573695457.gif by v4 vs. http://410chan.org/b/src/15263414061.gif by v3.4.2
[21:28:03 CEST] <Mithgol> http://410chan.org/b/src/152574212113.gif by v4 vs. http://410chan.org/b/src/152634383424.gif by v3.4.2
[21:28:05 CEST] <Mithgol> http://410chan.org/b/src/152579724662.gif by v4 vs. http://410chan.org/b/src/152634667546.gif by v3.4.2
[21:28:07 CEST] <Mithgol> (I had to keep the files' size under 5000 kB and thus the latter v4 examples are smaller pixel-wise than v3.4.2 counterparts.)
[21:29:20 CEST] <Cracki> different dithering algorithms.
[21:29:38 CEST] <Cracki> or parameters
[21:30:40 CEST] <Mithgol> Generated by exactly the same Windows batch file:
[21:30:42 CEST] <Mithgol> @echo off
[21:30:43 CEST] <Mithgol> ffmpeg -hide_banner -i %1 -ss %3 -to %4 -an -sn -crf 22 -b:v 0 -vf "scale=-1:%2:flags=lanczos" ibsrc4gif.webm
[21:30:45 CEST] <Mithgol> ffmpeg -hide_banner -i ibsrc4gif.webm -vf palettegen ibpalette4gif.png
[21:30:46 CEST] <Mithgol> ffmpeg -hide_banner -i ibsrc4gif.webm -i ibpalette4gif.png -lavfi "paletteuse=dither=bayer:bayer_scale=0" ibgif.%2.gif
[21:30:48 CEST] <Mithgol> del ibpalette4gif.png
[21:30:49 CEST] <Mithgol> del ibsrc4gif.webm
[21:31:17 CEST] <Cracki> might I suggest a pastebin site if you have more than a few lines to paste
[21:31:40 CEST] <furq> why on earth would you use webm as an intermediate format
[21:33:05 CEST] <Mithgol> https://pastebin.com/2Ftq1u4c
[21:35:38 CEST] <Mithgol> WebM introduces some information loss and thus makes resulting GIFs a bit smaller than a lossless alternative
[21:38:43 CEST] <Mithgol> And most imageboards, unlike Telegram, impose a size limit of 5MB / 10MB / 20MB or something, and thus I decided to use WebM.
[21:38:46 CEST] <GuardNas> Hi, I have a m3u8 link that has multiple WebVTT segments. I'm trying to get them appended into one vtt file, which also has the correct timecodes. ATM it can append (no problem), but it doesn't use the Timemap header in the segments. Which screws up the timings. Does anyone know how to fix this? I've seen a software called m3u8x, which works.. but need something that can be run as commandline...
[21:40:00 CEST] <furq> GuardNas: youtube-dl has some stuff for handling subtitles
[21:40:17 CEST] <GuardNas> Hmm, I tried it but didn't seem to work. Maybe I did it wrong then
[21:40:26 CEST] <furq> i've used it before on youtube itself, idk how well it works on other sites
[21:41:12 CEST] <GuardNas> The m3u8 link only includes the subtitles
[21:43:25 CEST] <furq> just --all-subs --skip-download works fine on youtube
[21:46:11 CEST] <GuardNas> Ye, though it's not a youtube link and for some reason it doesnt to much about it.
[21:47:03 CEST] <Mithgol> GuardNas: what's the URL?
[22:16:05 CEST] <Mithgol> It seems that the following command ignores X-TIMESTAMP-MAP in individual WebVTT segments, at least in FFmpeg v3.4.2.
[22:16:06 CEST] <Mithgol> ffmpeg -i "https://example.com/somefile.m3u8" -c copy "test.vtt"
[22:16:10 CEST] <Mithgol> Is it a bug report or a feature request?
[22:27:35 CEST] <Mithgol> Okay, gentlemen, I have a two-liner for you:
[22:27:36 CEST] <Mithgol> ffmpeg -hide_banner -i http://nowere.net/a/src/1529266885368.webm -vf palettegen palette4gif.png
[22:27:38 CEST] <Mithgol> ffmpeg -hide_banner -i http://nowere.net/a/src/1529266885368.webm -i palette4gif.png -lavfi "paletteuse=dither=bayer:bayer_scale=0" gif.gif
[22:27:39 CEST] <Mithgol> Can someone confirm or deny that it yields different GIF results in FFmpeg v4.0 and v3.4.2 and that v4.0's is obviously worse?
[22:27:41 CEST] <Mithgol> For me it definitely does.
[22:27:42 CEST] <Mithgol> I've used https://ffmpeg.zeranoe.com/builds/win64/static/ffmpeg-3.4.2-win64-static.zip as the v3.4.2 binary.
[22:27:44 CEST] <Mithgol> I've used https://ffmpeg.zeranoe.com/builds/win64/static/ffmpeg-4.0-win64-static.zip as the v4.0 binary.
[22:37:47 CEST] <Cracki> Mithgol, see if there are more options you can specify. perhaps some options got new defaults.
[22:56:06 CEST] <Mithgol> This is possible; but then these new defaults are bogus and lead to unclean animated GIFs.
[22:58:16 CEST] <Cracki> a case for the bug tracker
[23:16:44 CEST] <Mithgol> Could you write a bug report in that tracker for me? (I decided to write https://twitter.com/FidonetRunes/status/1008451439893581824 in Twitter instead of the tracker because it required less effort.)
[00:00:00 CEST] --- Mon Jun 18 2018

More information about the Ffmpeg-devel-irc mailing list