[Ffmpeg-devel-irc] ffmpeg.log.20180620

burek burek021 at gmail.com
Thu Jun 21 03:05:01 EEST 2018

[00:54:15 CEST] <anonffmpeg> Hi there. I have a weird issue for sometime now. I m a restreamer for many year, and I never had problems. I do it using livestreamer, then I pipe the data to ffmpeg, that send it to my rtmp server. But with the latest releases of ffmpeg, the processus get stalled after a while, cpu is maxing out, streams aren't working obviously. When I do a strace I see only x32 mode / 32bit mode.
[00:54:30 CEST] <anonffmpeg> I am using ubuntu xenial.
[00:55:05 CEST] <anonffmpeg> So the only work around I have is to use a previous version (from october 2017 I had in one of my server) so I can keep the work done..
[00:57:09 CEST] <anonffmpeg> https://i.gyazo.com/d55de5315b52c73559f4e976aec47352.png you can see how I started the cron at 11 and they all crash at 12. I then restart and same happen
[00:57:29 CEST] <anonffmpeg> last run seems stable, but this is with old version of ffmpeg
[00:58:57 CEST] <Cracki> that's nice but you should provide logs with useful verbosity level
[00:59:59 CEST] <anonffmpeg> right
[01:00:05 CEST] <Cracki> you could also name the affected/unaffected version numbers
[01:02:46 CEST] <anonffmpeg> my guess is this isn't just a version
[01:03:21 CEST] <anonffmpeg> except yes, yesterday I couldn't download a snapshot because it was offline, so I used the same version I used in february
[01:03:28 CEST] <anonffmpeg> maybe there is no issue anymore.. very possible
[01:04:31 CEST] <Cracki> just tell us which version works and which doesn
[01:04:33 CEST] <Cracki> t
[01:05:26 CEST] <Cracki> you have to give hard facts or it's impossible to help
[01:05:27 CEST] <anonffmpeg> ffmpeg version N-87723-gffc58b2 Copyright (c) 2000-2017 the FFmpeg developers . this one works, from server I installed in october
[01:05:35 CEST] <anonffmpeg> yea I know, I m not being precise enough
[01:05:55 CEST] <Cracki> precise, but more importantly, *forthcoming*
[01:06:05 CEST] <anonffmpeg> it's critical to me so I fix it the best way I could, as fast as possible, so no verbose logging etc..
[01:06:15 CEST] <anonffmpeg> and yea, I m unlucky I couldn't try the last snapshot
[01:06:28 CEST] <anonffmpeg> could be solved since february.. could be a broken release
[01:07:16 CEST] <Cracki> see if you can narrow down the range between working and broken versions
[01:08:17 CEST] <anonffmpeg> didn't install many server, just one in october , one in february and one emergency yesterday.  When I saw the process stalled in the morning, it remembers me what happens in february..
[01:08:31 CEST] <Cracki> get binaries, try them
[01:08:34 CEST] <Cracki> reproduce the bug
[01:09:22 CEST] <anonffmpeg> I compile ffmpeg
[01:09:29 CEST] <anonffmpeg> i don't use binaries
[01:09:35 CEST] <Cracki> that then
[01:10:44 CEST] <anonffmpeg> basically I m kinda afraid that some new changes in ffmpeg make my system not functional anymore and then I always have to use old version
[01:11:12 CEST] <furq> https://www.johnvansickle.com/ffmpeg/
[01:11:14 CEST] <furq> use those then
[01:11:36 CEST] <Cracki> determine the *steps to reproduce* the issue
[01:11:39 CEST] <anonffmpeg> I don't do anything special , just like :   livestramer hls://streamurl.m3u8 best -O  | ffmpeg -i pipe:0 -c copy -f flv "rtmp:destination-server"
[01:12:14 CEST] <furq> why are you piping from livestreamer and not just using ffmpeg's hls demuxer
[01:12:17 CEST] <anonffmpeg> never had issue.. now I get this x32 mode in strace, cpu is at max, if I kill one instance of ffmpeg, the other one will just use more of the cpu lol
[01:12:38 CEST] <anonffmpeg> well, livestreamer or streamlink. that brings some helpful plugin for specific sites
[01:13:17 CEST] <anonffmpeg> I would try this demuxer
[01:13:20 CEST] <furq> well yeah try using git head or something close to it before anything else
[01:13:31 CEST] <anonffmpeg> I m doing this for many years now and maybe there has been some improvement with ffmpeg
[01:13:47 CEST] <furq> then if it breaks again try attaching gdb to it or something like that
[01:13:49 CEST] <anonffmpeg> how would it looks like to use ffmpeg to grab that source
[01:14:09 CEST] <anonffmpeg> ffmpeg -re -i "hls:url.m3u8"
[01:14:10 CEST] <furq> there's not much we can really do with "an ffmpeg build from months ago stops working"
[01:14:30 CEST] <furq> ffmpeg -i http://foo.m3u8 -c copy -f flv rtmp://bar
[01:14:39 CEST] <anonffmpeg> yea
[01:14:49 CEST] <anonffmpeg> does it retry if one segment fail?
[01:15:09 CEST] <anonffmpeg> i always considered than livestreamer was built for that specific purpose
[01:15:16 CEST] <furq> i mean maybe livestreamer is better, idk
[01:15:22 CEST] <furq> but it's one less thing to worry about
[01:15:47 CEST] <anonffmpeg> never had issues with piping data?.   I m doing it right now with 60 channels
[01:16:14 CEST] <anonffmpeg> well it's weird anyway, but yea, I cannot provide good infos..
[01:32:13 CEST] <FishPencil> Is there a way to extract without converting the forced subtitles from a bluray with ffmpeg? I'm aware of the -forced_subs_only 1 option, but with -c:s copy, will that extract only the forced images and copy them to the output?
[01:57:29 CEST] <thexa4> Hi, I have copied streams from an rtsp stream to disk and am trying to downscale the video. Fmpeg seems to hang at a certain point of the stream with no output and 0% cpu. I've tried changing the output format but that didn't seem to help. Does anyone know how I can figure out what might cause this?
[01:57:38 CEST] <thexa4> The command I'm using is this: ffmpeg -i $1 -an -filter:v "scale=w=64:h=36:force_original_aspect_ratio=increase" -c:v libvpx-vp9 -lossless 1 $2/source/$1.webm
[02:00:28 CEST] <fengshaun> where can I read more about how html5 video works?
[02:00:58 CEST] <fengshaun> as in, what kind of data does it expect (e.g. chunk starting with I-frame, raw or encoded, what encoding)
[02:02:38 CEST] <fengshaun> I'm trying to write a live-transcoder with libav{format,codec,*} and trying to figure out how to play well with html5 video tag
[02:03:48 CEST] <bashprogfortysix> startx
[02:04:00 CEST] Last message repeated 1 time(s).
[02:04:33 CEST] <fengshaun> In a previous attempt, I tried to create a m3u8 playlist on keyframes with byterange (m3u8 v4) and serve an mp4 file by transcoding whatever byterange is requested on the fly
[02:04:37 CEST] <fengshaun> by that doesn't seem to work
[02:04:51 CEST] <fengshaun> ffmpeg generates a mpegts file to do that
[02:05:02 CEST] <fengshaun> but I want to keep the original mp4
[02:05:11 CEST] <fengshaun> without adding storage requirements
[02:08:19 CEST] <thexa4> @fengshaun: have you seen this? https://developer.mozilla.org/en-US/docs/Web/HTML/Supported_media_formats
[02:12:45 CEST] <fengshaun> thexa4, yes, but I haven't been able to find info on what payload is expected for each format
[02:13:06 CEST] <fengshaun> e.g. what does the browser expect when it requests byteranges?
[02:13:27 CEST] <fengshaun> does it want a chunk of data starting with an encoded I-frame or does it want something else?
[02:14:47 CEST] <fengshaun> or does it do its own decoding and really want a specific byte range
[02:17:29 CEST] <thexa4> As far as I know it mostly uses the byterange to seek to a specific time, then it searches for a keyframe. I'm not sure if you can generate an arbitrary file based on the offset without having trouble with caches etc
[02:19:42 CEST] <thexa4> Doesn't serving the mp4 directly work?
[02:21:13 CEST] <fengshaun> well, I was hoping to add transcoding to it
[02:21:58 CEST] <fengshaun> I can try mpeg-dash with fragmented mp4s and then transcode the fragments
[02:21:59 CEST] <thexa4> I know Emby does something similar but I'm not sure if that's because they have javascript support
[02:22:29 CEST] <fengshaun> I think emby just uses ffmpeg the commandline to transcode
[02:22:34 CEST] <fengshaun> they have their own player
[02:22:42 CEST] <fengshaun> so it's hard to know what parts do what
[02:23:13 CEST] <fengshaun> with fmp4 I would just need to add moof+mdata atoms with fragments before hand which ffmpeg can do
[02:23:44 CEST] <thexa4> I'm not sure how that works so I don't think I can help you with that
[02:44:36 CEST] <AuroraAvenue> I need to load rte radio player in my radio browser,
[02:44:45 CEST] <AuroraAvenue> I use Solus Os
[02:44:46 CEST] <AuroraAvenue> ,
[02:45:04 CEST] <AuroraAvenue> which is a linux baby operating system
[02:56:06 CEST] <chrysalis> im getting some warnings when using aac encoder - Qavg: 166
[02:56:14 CEST] <chrysalis> what does it mean?
[03:23:39 CEST] <fengshaun> hmm looks like MediaSourceExtension can decode stuff
[03:23:50 CEST] <fengshaun> so it'd need moof+mdata fragments to be able to decode
[03:24:23 CEST] <fengshaun> so if I take my fragments in 1s or 2s chunks, then I can re-encode and manipulate the fragment as I wish on the server and then feed it to MSE
[03:43:07 CEST] <Cracki> chrysalis, what do you encode?
[03:43:09 CEST] <Cracki> silence?
[05:57:46 CEST] <chrysalis> Cracki, encoding works fine, but ffmpeg spits that Qavg message everytime with the native aac encoder, just wondering what it means
[05:58:08 CEST] <Cracki> chrysalis, what do you encode?
[05:58:09 CEST] <Cracki> silence?
[05:59:04 CEST] <chrysalis> Cracki, audio files obviously, flacs
[05:59:23 CEST] <Cracki> dude, I'm asking about the content
[05:59:27 CEST] <Cracki> describe it
[05:59:43 CEST] <Cracki> low Qavg could indicate low complexity content
[05:59:43 CEST] <chrysalis> music?
[05:59:45 CEST] <atomnuker> chrysalis: its just debug info, generally more means more rate
[05:59:47 CEST] <Cracki> nevermind.
[05:59:57 CEST] <Cracki> *low/high
[05:59:58 CEST] <atomnuker> its the same with libx264 and libx265
[06:00:28 CEST] <Cracki> q stands for quantizer, so high quantizer means stronger compression
[06:02:01 CEST] <Cracki> might be mistaken :S https://slhck.info/video/2017/02/24/vbr-settings.html
[06:02:33 CEST] <Cracki> or the meaning of Qmin is worst value (largest)
[06:03:15 CEST] <chrysalis> trying to find something loud to encode end test
[06:03:28 CEST] <furq> chrysalis: -f lavfi -i anoisesrc
[06:07:44 CEST] <chrysalis> same thing and i dont think jimmi hendrix qualifies as 'quiet'
[06:08:01 CEST] <chrysalis> Qavg went from like 100-200, now 1000
[06:09:09 CEST] <furq> it's really not worth worrying about
[06:51:32 CEST] <Cracki> if you wanna explore: https://github.com/FFmpeg/FFmpeg/blob/master/libavcodec/aacenc.c#L903
[06:57:28 CEST] <Cracki> so that value doesn't really have to do with qscale/-q, it seems to be a measure of data complexity
[14:47:25 CEST] <Zexaron> Hello
[14:47:42 CEST] <Zexaron> Does anyone know if ffmpeg is able to burn-in DVB subtitles ?
[14:48:05 CEST] <Zexaron> they can be text, but the ones broadcast here are many times bitmap
[14:48:34 CEST] <Zexaron> generally, conversion tools take a lot of time and rare, since this is mostly europe only thing
[14:50:01 CEST] <Zexaron> MPEG-2 bitrates they use are so high compared to the quality, I found out compresing to H264 at 80% quality reduces size by 8 times, that makes it a lot easier for the PVR feature
[14:54:38 CEST] <Mavrik> IIRC yes
[14:55:08 CEST] <Mavrik> overlay filter should be able to burn in DVB subtitles
[14:55:13 CEST] <Mavrik> it's on the wiki
[15:22:04 CEST] <Zexaron> Mavrik: mentions only DVD not DVB
[15:22:17 CEST] <Mavrik> Same principle.
[15:22:20 CEST] <Zexaron> But I guess it could apply, if you know
[15:22:23 CEST] <Mavrik> Same subtitles really.
[15:22:42 CEST] <Mavrik> You pipe video and subtitle streams into the overlay filter and it does its magic.
[16:21:59 CEST] <Zexaron> Mavrik: What about scaling the subtitle layer, is that working properly, just found out some stuff about a bug, but it may be obsolete
[16:26:32 CEST] <Bombo> can ffmpeg use libdvdread? like for 'ffmpeg -i dvd://2 -c copy title2.mpg'
[16:36:09 CEST] <paulk-gagarine> hi
[16:36:18 CEST] <paulk-gagarine> first off, ffmpeg's great!
[16:36:45 CEST] <paulk-gagarine> second: does anyone have a clue about the encoding options to generate B frames with MPEG2?
[16:36:57 CEST] <paulk-gagarine> I tried messing with the levels but no luck
[16:37:54 CEST] <paulk-gagarine> I'm working on the Sunxi-Cedrus V4L2 M2M linux driver (for Allwinner hardware) and I'd like to encode a video with B frames
[16:38:00 CEST] <paulk-gagarine> to add to our standalone testing tool
[16:38:11 CEST] <Mavrik> paulk-gagarine: hmm, -bf 2 should work no?
[16:39:25 CEST] <paulk-gagarine> Mavrik, yay, it does!
[16:39:29 CEST] <paulk-gagarine> I just didn't know about that option
[16:39:32 CEST] <paulk-gagarine> thanks a lot
[16:40:03 CEST] <Mavrik> It seems like it's not well documented :)
[16:40:26 CEST] <Mavrik> paulk-gagarine: https://ffmpeg.org/faq.html#Which-are-good-parameters-for-encoding-high-quality-MPEG_002d1_002fMPEG_002d2_003f :)
[16:40:50 CEST] <YokoBR> hi folks
[16:41:16 CEST] <YokoBR> I'm converting on a server like ffmpeg -i /tmp/82c61456-b77e-43ad-9358-b2c1a2d4ebb3.webm -preset veryfast -movflags faststart -f mp4 /tmp/82c61456-b77e-43ad-9358-b2c1a2d4ebb3
[16:41:23 CEST] <YokoBR> from webm to mp4
[16:41:32 CEST] <YokoBR> is there a faster way to do that?
[16:41:56 CEST] <YokoBR> they're aways vp8 or vp9 vcode
[16:41:58 CEST] <YokoBR> codec
[16:42:35 CEST] <Mavrik> You can buy a faster CPU I guess
[16:42:54 CEST] <Mavrik> Also you're not setting any output quality, why?
[16:49:20 CEST] <paulk-gagarine> Mavrik, very nice
[16:55:45 CEST] <kalidasya> hey
[17:18:33 CEST] <YokoBR> Mavrik: how do I set the output quality?
[17:43:07 CEST] <jrf22> I'm using a wecam with a hardware encoder to stream with. Youtube takes the stream but complains about frequency of keyframes. I've tried adjusting -g but that doesn't seem to be fix the issue. I'm not encoding the webcams hardware h264 stream just passing it to youtube with FFMPEG. Is there any way to adjust keyframes or would I have to re-encode to do that?
[17:45:21 CEST] <Mavrik> Keyframes are a core of each encoded stream
[17:45:28 CEST] <Mavrik> So changing them requires full reencode by definition :P
[17:52:27 CEST] <jrf22> That's what I thought. Using a Rasp Pi so I don't have enough horsepower to re-encode the 1080p stream. I'll just leave it alone. Thanks for your response.
[17:58:14 CEST] <Mavrik> Rpi does have a HW encoder tho :/
[18:10:03 CEST] <chocolate-elvis> Hi, anyone know of any trouble with ffmpeg sourcing from s3 for files 3GB and larger? (other than painful, and slow )
[20:41:01 CEST] <Bombo> i'm trying to concat 3 vob files (ffmpeg -i "concat:VTS_01_1.VOB|VTS_01_2.VOB|VTS_01_3.VOB" -c copy -f mpeg out.mpg), what does this mean "[mpeg @ 0x5568bb632980] buffer underflow st=0 bufi=1270 size=15152"
[20:42:04 CEST] <Bombo> does that just mean it was not able to read enough bytes? 'i need 15152 bytes, but was just able to get 1270'?
[20:42:29 CEST] <Bombo> is this a hdd speed issue?
[20:45:13 CEST] <JEEB> Bombo: the MPEG-PS muxer bby default has some mux bufsize and maxrate
[20:45:34 CEST] <JEEB> it just means that whatever default limits there are were broken when muxing those streams
[20:45:45 CEST] <furq> Bombo: there's no real reason to use the mpegps muxer there
[20:45:49 CEST] <furq> use mkv or something
[20:48:02 CEST] <ChocolateArmpits> when concating vob files I use -f vob, gets around some errors
[20:49:23 CEST] <Bombo> hmmkay i get no errors when i directly encode to x264.mkv
[20:49:57 CEST] <Bombo> i just thought i shoult first have one .mpg file before encoding
[20:50:51 CEST] <furq> i meant you can just copy the streams into mkv
[20:50:57 CEST] <furq> and then work with that
[20:51:18 CEST] <Bombo> the mpeg streams?
[20:51:20 CEST] <furq> yes
[20:51:33 CEST] <furq> but you might as well just concat and encode in the same step if you didn't have any plans that depend on having a single mpeg file
[20:52:07 CEST] <Bombo> ffmpeg -i "concat:VTS_01_1.VOB|VTS_01_2.VOB|VTS_01_3.VOB" -c copy out.mkv?
[20:52:58 CEST] <furq> sure
[20:53:06 CEST] <Bombo> i get the same underflows with -f mpeg or -f vob
[20:53:36 CEST] <furq> those are basically the same muxer iirc
[20:53:39 CEST] <Bombo> [matroska @ 0x55abd8067100] Timestamps are unset in a packet for stream 0. This is deprecated and will stop working in the future. Fix your code to set the timestamps properly
[20:53:40 CEST] <furq> except with different defaults
[20:53:42 CEST] <Bombo> [matroska @ 0x55abd8067100] Can't write packet with unknown timestamp
[20:53:45 CEST] <furq> oh fun
[20:53:46 CEST] <Bombo> without -f
[20:54:16 CEST] <ChocolateArmpits> try -f vob then :3
[20:54:39 CEST] <Bombo> i did, same underflow msgs
[20:55:11 CEST] <ChocolateArmpits> I've had some vobs that had different format frames at the beginning, the file would continue with different format after that
[20:55:20 CEST] <Bombo> (ffmpeg version git-2018-06-18-e85c608)
[20:55:40 CEST] <furq> yeah i would normally pipe from tccat if i was working with dvd stuff
[21:01:23 CEST] <Bombo> debian doesn't have that cat
[21:01:47 CEST] <Bombo> i'll try that tomorrow ;)
[21:02:07 CEST] <Bombo> for now directly encoding to x264 will do
[21:02:23 CEST] <Bombo> thx guys
[21:05:16 CEST] <saml> https://www.ffmpeg.org/ffmpeg-all.html#Commands-12   hey what are commands in crop filter?
[21:05:27 CEST] <saml> can I send commands to the filter once filter graph is initialized?
[21:15:02 CEST] <ChocolateArmpits> saml, best way is to use zmq and azmq
[21:15:28 CEST] <ChocolateArmpits> You then use sendzmq found in the tools folder to send text commands to the corresponding address:port
[21:16:22 CEST] <saml> hrm i see. t hanks
[21:16:34 CEST] <ChocolateArmpits> check out https://ffmpeg.org/ffmpeg-filters.html#toc-Timeline-editing as well
[21:17:09 CEST] <ChocolateArmpits> I've used 'enable' command with overlay and volume, however some filters may not support it
[21:17:50 CEST] <ChocolateArmpits> some filter specific parameters may not be toggleable either
[21:34:18 CEST] <furq> Bombo: tccat is part of transcode, although for some reason debian pulled it from the repos
[21:35:08 CEST] <furq> https://bitbucket.org/france/transcode-tcforge/
[21:52:00 CEST] <lex> I am doing the following ffmpeg -i redSangria20180620.mp4 -filter:v "setpts=.35*PTS" slow.mp4  but the length of the video remains the same.  The video is being speed up.  But the play time remains the same,
[21:53:14 CEST] <furq> audio?
[21:53:58 CEST] <lex> OHHH the audio.  Yes it has.  I should remove it?
[21:54:18 CEST] <furq> if you don't want it, sure
[21:54:22 CEST] <furq> otherwise -af atempo
[21:54:47 CEST] <lex> Thanks you are the best.  I will check.
[21:55:09 CEST] <lex> furq :  it works perfectly!
[21:56:53 CEST] <lex> furq :  does this speed up the audio to match the video -af atempo
[21:56:59 CEST] <lex> I tried it and it did nothing.
[21:57:12 CEST] <lex> Sorry it kept the audio there.
[21:57:28 CEST] <kepstin> lex: you'd have to give it some options to say the speed adjustment you want, it doesn't have any way to know what you did to the video.
[21:57:29 CEST] <lex> Making the video the original length.
[21:58:27 CEST] <furq> you'd normally do atempo=1/.35
[21:58:37 CEST] <furq> but that's more than 2, and atempo doesn't like that
[21:58:53 CEST] <furq> so you'd need to chain two together
[21:59:27 CEST] <lex> How can speed up the audioOne sec I think I solved it.
[21:59:39 CEST] <lex> One sec I think I solved it.
[22:00:10 CEST] <furq> oh nvm i guess atempo takes values >2 now
[22:00:17 CEST] <furq> just atempo=1/.35 then
[22:01:31 CEST] <kepstin> if your ffmpeg build has the 'rubberband' filter, you might want to try it instead.
[22:02:05 CEST] <furq> if you want to change the pitch and speed, then asetrate=48000/.35,aresample=48000
[22:02:15 CEST] <furq> where the first 48000 should be the sample rate of the input
[22:07:22 CEST] <lex> I tried this and it did not work  :  ffmpeg -i redSangria20180620.mp4 -filter_complex "[0:v]setpts=0.35*PTS[v];[0:a]atempo=1/.35[a]" -map "[v]" -map "[a]"  -y slow.mp4
[00:00:00 CEST] --- Thu Jun 21 2018

More information about the Ffmpeg-devel-irc mailing list