[Ffmpeg-devel-irc] ffmpeg.log.20180624

burek burek021 at gmail.com
Mon Jun 25 03:05:02 EEST 2018

[00:26:43 CEST] <hiihiii> hello
[00:27:27 CEST] <hiihiii> I've got two inputs that are recorded in VFR
[00:27:40 CEST] <hiihiii> I want to overlay one on top of the other
[00:28:47 CEST] <hiihiii> but since they are in VFR I get a very bad case of desync, where even if I sync one part I end up with a new part out of sync
[00:32:40 CEST] <hiihiii> reading the answers here https://superuser.com/questions/1150276/trim-video-and-concatenate-using-ffmpeg-getting-non-monotonous-dts-in-output/1150548
[00:33:15 CEST] <hiihiii> I understand that I should find the PTS of my two inputs and regulate them before I do anything
[04:19:08 CEST] <Una-Rogg> Hello peoples
[10:32:57 CEST] <tomf> can ffmpeg stretch audio ripped from a PAL source so it matches with NTSC?
[10:49:42 CEST] <keglevich_> hey all...I'm using CasparCG with ffmpeg udp multicast mpegts output (mpeg2video, mp2audio)... If I try to use "-muxrate" parameter as well to produce CBR stream and right pcr interval, I get "DTS<PCR: TS in invalid" errors all the time in ffmpeg output console. Why is this warning/error, and how to avoid it? Thank you
[11:03:29 CEST] <keglevich> hey all...I'm using CasparCG with ffmpeg udp multicast mpegts output (mpeg2video, mp2audio)... If I try to use "-muxrate" parameter as well to produce CBR stream and right pcr interval, I get "DTS<PCR: TS in invalid" errors all the time in ffmpeg output console. Why is this warning/error, and how to avoid it? Thank you
[11:47:35 CEST] <diego4> hello I've noticed that sometimes when running ffmpeg (version 3.2.10-1) from beets (convert command) the console disables the echo, could someone please help me understanding this?
[13:02:36 CEST] <ralphcor> Hi, ffmpeg -i movie.mp4 frame-%04.png is creating png:pHYs: x_res=0, y_res=1, units=0 in the PNG header. x!=y so these are non-square pixels.  What does an x_res of 0 mean?  I suspect 0/1 is from the first entry in ff_h264_pixel_aspect[] pulled by decode_vui_parameters() that suggests the aspect_ratio_info_present_flag bit was set.  I can -v 9 -loglevel 99 and see [graph 0 input from stream 0:0 @ 0x...]
[13:02:37 CEST] <ralphcor> Setting 'pixel_aspect' to value '0/1'.  Is this a common value for MP4s or an indication of something wrong upstream?
[13:04:30 CEST] <JEEB> that is generally something like unset
[13:05:08 CEST] <ralphcor> I'm surprised `unset' doesn't mean 1/1 in a similar manner to PNG not having a pHYS header entry means 1/1 square pixels.
[13:05:46 CEST] <ralphcor> (Commands processing the PNGs downstream are complaining of non-square pixels.)
[13:10:13 CEST] <JEEB> anyways, not sure at which point that value gets set and due to which because I don't have magical pixie dust powers
[13:10:38 CEST] <JEEB> I just looked at my API code that was creating thumbnails from <random input> to f.ex. PNG or JPEG
[13:11:20 CEST] <JEEB> and I didn't really take care of aspect ratio at all. I seem to just take the values out of the input
[13:11:42 CEST] <JEEB> as in, the first input decoded AVFrame
[13:14:45 CEST] <JEEB> I could test ffmpeg.c and some random H.264 file I have around and see what it does with current master
[13:15:10 CEST] <ralphcor> I've just tried a different H264 video, this one off youtube, and 1/1 gets pulled from ff_h264_pixel_aspect[], so it seems to be something in the original.  I think that came from a youtube-dl off a tweet URL, so probably involved ffmpeg there too.  Will ask for the original URL.
[13:15:57 CEST] <ralphcor> ffmpeg 1:4.0.1-1 here on Arch Linux, though I don't think it's necessarily ffmpeg that's wrong, just trying to understand and how to remedy.
[13:16:43 CEST] <JEEB> well one of the simplest things is to try and just add a forced scaling to as close as possible to 1:1 SAR and then use the setsar filter to force that to 1:1 or something if you just want to work around it :P
[13:17:03 CEST] <ralphcor> Specifying sar with an explicit graph would seem to be the way.  Does ffmpeg always construct a graph from the command-line options, and can it be displayed?  It would be a starting point for augmenting it with sar.
[13:17:24 CEST] <JEEB> -v verbose and higher I think start showing the chain that's autogenerated
[13:17:56 CEST] <JEEB> basically there's an example I think in the docs to get SAR-applied output values, and then you just stick setsar at the end
[13:18:22 CEST] <JEEB> but the more interesting part is how do some values get through the whole thingamajig as-is
[13:18:34 CEST] <JEEB> sine 0/1 generally is the "unset" value for AVRationals
[13:18:44 CEST] <JEEB> because 0/0 can lead to division by zero things
[13:19:28 CEST] <JEEB> in my own API client I just wait all the way until I have an AVFrame in my hand and that way I know exactly what I'm building my filter chain with
[13:19:49 CEST] <JEEB> and I've tested it with random broadcast sources and mp4s and it seemed to work :P
[13:19:55 CEST] <JEEB> ffmpeg.c can be doing something completely different of course
[13:22:20 CEST] <ralphcor> Unrelated: -i foo-%06d.png tests for foo-000000.png to foo-000004.ng with access(2) and then errors if it starts at foo-000042.png.  Unexpected from the man page for -pattern_type.
[13:23:02 CEST] <JEEB> yes, that stuff is very limited
[13:23:46 CEST] <JEEB> there's a separate start_number param
[13:23:52 CEST] <JEEB> https://www.ffmpeg.org/ffmpeg-all.html#image2-1
[13:24:07 CEST] <JEEB> ffmpeg-all.html is generally what I ctrl+F through when I'm a lazy git
[13:24:49 CEST] <ralphcor> Ta.  Yes, that's what I've been using with man(1), but I didn't grasp the start_number it referred to in the formula was another option.
[13:25:13 CEST] <JEEB> all the base indentation level things are AVOptions
[13:25:32 CEST] <JEEB> values for AVOptions generally are +1 level indented
[13:38:51 CEST] <ralphcor> -aspect 1  looks convenient, but it's an output option that affects the container, but not the frames, so I guess that's why PNG's pHYS doesn't benefit.
[13:39:43 CEST] <JEEB> see the examples for the scale filter
[13:39:53 CEST] <JEEB> https://www.ffmpeg.org/ffmpeg-all.html#Examples-127
[13:39:55 CEST] <JEEB> last two
[13:41:04 CEST] <JEEB> add add a format=rgb24 in front of it to first convert to RGB
[14:32:38 CEST] <ralphcor> Interestingly, if I ffmpeg -i dodgy.mp4 -aspect 1 -c copy fixed.mp4 then the pixel_aspect is set to 16/9 when extracting PNGs, and pHYS is x_res=16, y_res=9, units=0.  So still non-square.  This is probably because fixed.mp4 is output as 720x1280 [SAR 16:9 DAR 1:1] whereas I'd expect SAR 1:1 DAR 16:9.
[17:06:09 CEST] <ariyasu> is "-http_proxy http://proxy:port" the correct format for setting a proxy?
[17:06:27 CEST] <ariyasu> because im doesn't appear to be using it, but im not getting any errors
[17:10:35 CEST] <ariyasu> Reading option '-http_proxy' ... matched as AVOption 'http_proxy' with argument ''.
[17:10:39 CEST] <ariyasu> hrm
[17:11:40 CEST] <JEEB> https://www.ffmpeg.org/ffmpeg-all.html#http if you are straightforwardly using the HTTP protocol, that probably matches, but sub-contexts might not get it for "meta" demuxers
[17:16:49 CEST] <ariyasu> yeah still not working :|
[17:17:46 CEST] <ariyasu> trying to download an m3u8 to mp4, but the content is geo locked to japan, ffmpeg gives 403 errors
[17:18:04 CEST] <ariyasu> firefox gives 403 also but when i set the proxy there, then it can download the ts segments
[17:18:16 CEST] <ariyasu> but for some reason ffmpeg is not routing through the proxy
[17:21:32 CEST] <ariyasu> if i set a jpn vpn at that same host and remove the "-http_proxy http://proxy:port" then it works, but would rather get it working with the proxy if possible
[17:21:49 CEST] <ralphcor> Is it HTTP that it's attempting?
[17:22:13 CEST] <JEEB> ariyasu: basically HLS is one of the "meta" demuxers which possibly will open other protocols
[17:22:14 CEST] <ralphcor> Perhaps  strace -fe %network ffmpeg ... ?
[17:22:36 CEST] <JEEB> so I wouldn't be surprised if the proxy part doesn't get passed to the other requests, not that I'm sure :P
[17:23:09 CEST] <ariyasu> ahh i see
[17:23:19 CEST] <ariyasu> thats probably the issue
[17:24:10 CEST] <JEEB> you see various facepalm-inducing things in all of those meta things where people randomly copy things from the main lavf context to the one further
[17:24:18 CEST] <JEEB> because of how the meta stuff works right now
[17:24:26 CEST] <JEEB> and if what you're setting in the version you have at hand
[17:24:34 CEST] <JEEB> doesn't have that, then "lol u"
[17:53:41 CEST] <rahal_> Hi guys, I have a weird problem with ffmpeg in Windows Server 2012R , when creating a video from a jpeg sequence, the generated video is always squized to 1*1 Ratio,  even if I specify a resize argument. The same command works perfectly on a macos, windows 8? I'm getting crazy.. does any body have any idea why this could happen? Thank you
[18:51:49 CEST] <rahal_> Nevermind.. It was about the SAR and DAR values, they were not the same in the different environments. ffmpeg picked SAR=3/4 for the output in windows server and 1/1 in mac and windows 8 which had the same SAR and DAR for the input files..
[19:01:11 CEST] <JEEB> rahal_: 100% up to the FFmpeg version or the input files
[19:01:20 CEST] <JEEB> match both to get exactly same results
[19:06:16 CEST] <rahal_> @JEED, thanks, I moved the images created in windows server to my laptop and my local ffmpeg output was the same as the one in the server, I need to make sure that the server generates the images in a good format...
[19:07:52 CEST] <rahal_> I don't understand why after effect ( with the same render settings and output modules ) will create images in a different SAR and DAR in winsrv.. maybe a media codec issue
[19:12:02 CEST] <kepstin> ffmpeg doesn't use system codecs on windows. if you're using the same static ffmpeg build on both systems, with the same input, it should give the same results.
[19:12:18 CEST] <JEEB> I think he was mentioning the thing that creates those images for him
[19:12:39 CEST] <kepstin> oh, the problem is the source images? :/
[19:12:42 CEST] <Celmor> I'm trying to convert a 2160p HEVC video but the result always has a lot of color removed (looks pale/faded), `... -map 0:0 -map 0:1 -c:v libx264 -b:v 10M -s:v 1920x1080 -filter:v "crop=3840:1609:0:275" -c:a ac3 -b:a 448k ...`, converted video vs original: https://puu.sh/ALbmv/1b34dcc37b.png
[19:14:01 CEST] <kepstin> Celmor: the original was probably HDR, and either you converted to 8bit without doing appropriate color mapping, or the hdr metadata wasn't preserved.
[19:14:30 CEST] Action: kepstin assumes this is an ultra-hd blu-ray rip.
[19:15:08 CEST] <JEEB> pretty sure currently with ffmpeg.c the metadata isn't preserved through lavfi and/or the encoder gets initialized before the first AVFrame is received
[19:15:29 CEST] <JEEB> and/or the encoders don't pass the data through
[19:15:39 CEST] <kepstin> when I was playing around with HDR source stuff and vp9, I had to add explicit encoder options to re-add the hdr metadata.
[19:15:57 CEST] <JEEB> s/encoders/encoder wrappers/
[19:16:11 CEST] <JEEB> basically if you see that BT.2020 / PQ get passed
[19:16:24 CEST] <JEEB> then that part is OK, and it's the HDR metadata side data that's not getting through
[19:17:52 CEST] <kepstin> if you're converting to 8 bit, you probably want to apply tone-mapping to the video stream and convert it to standard dynamic range. 8-bit would probably have lots of banding issues otherwise
[19:17:59 CEST] <Celmor> I don't need to "preserve" HDR, how do I tell ffmpeg to do 'appropriate color mapping'?
[19:20:32 CEST] <JEEB> there's two tone mapping filters in FFmpeg now
[19:20:46 CEST] <JEEB> the standard one which I'm not sure if it got updated with the later changes that mpv got
[19:20:46 CEST] <rahal_> @kepstin, yes, problem with the source images that I generate using after effect
[19:21:00 CEST] <JEEB> and then there's the opencl version by an intel guy that has the more up-to-date stuff that haasn did
[19:21:36 CEST] <JEEB> I think the tone mapping things require linear light with float tho
[19:21:45 CEST] <JEEB> so you need to first call zimg to convert the input to that
[19:21:50 CEST] <JEEB> well, zscale
[19:22:02 CEST] <JEEB> I think the tonemap filter has an example
[19:22:11 CEST] <kepstin> yeah, the example in the filter docs shows how to do that
[19:22:21 CEST] <JEEB> https://www.ffmpeg.org/ffmpeg-all.html#tonemap
[19:22:41 CEST] <JEEB> zscale that converts to floating point, linear light RGB
[19:22:48 CEST] <JEEB> or actually, not sure if RGB
[19:22:54 CEST] <JEEB> just linear light and float
[19:23:13 CEST] <JEEB> then the tonemap filter and finally zscale to BT.709
[19:24:35 CEST] <kepstin> tonemap filter works in linear RGB (actually planar 32-bit float GBR)
[19:24:50 CEST] <JEEB> yup, that's what I expected
[19:24:56 CEST] <JEEB> so yea
[19:25:21 CEST] <JEEB> will have to check if the "normal" filter got updated
[19:25:37 CEST] <JEEB> http://git.videolan.org/?p=ffmpeg.git;a=history;f=libavfilter/vf_tonemap.c;h=10308bdb16cf28fc3944755b5d5b9b6edfaae59c;hb=HEAD
[19:25:40 CEST] <JEEB> nope
[20:18:39 CEST] <ariyasu> when using -report can you speify the location of the output file?
[20:37:26 CEST] <Hello71> probably
[20:37:29 CEST] <Hello71> did you read the man page
[00:00:00 CEST] --- Mon Jun 25 2018

More information about the Ffmpeg-devel-irc mailing list