[Ffmpeg-devel-irc] ffmpeg.log.20180628

burek burek021 at gmail.com
Fri Jun 29 03:05:01 EEST 2018

[00:59:13 CEST] <Ars> Hi guys, pls help me.
[00:59:13 CEST] <Ars> I am transcoding and multicasting stream like: fmpeg RTMP_Stream   udp://
[00:59:13 CEST] <Ars> Also i have stream check script (ffprobe udp://, but when executing that command ffmpeg stops.
[00:59:13 CEST] <Ars> I understand there is port binding problem.
[00:59:13 CEST] <Ars> But how i can check that UDP stream alive or no? How to chek stream on udp:// ?
[01:03:02 CEST] <dmc> should I transcode TrueHD to DTS or AC3? I'm using S/PDIF (only have support for passing those through, apparently)
[01:03:52 CEST] <dmc> ffmpeg -i <file with DD+ or TrueHD> -f matroska -vcodec copy -acodec ac3 - | vlc -
[01:06:06 CEST] <dmc> hopefully that's the best way to do it
[01:12:04 CEST] <dmc> same question for FLAC
[01:14:09 CEST] <dmc> "ffmpeg ac3 encoder is better than DTS"
[01:24:29 CEST] <iive> transcoding will not improve quality
[01:24:54 CEST] <iive> flac is lossless, so it will not lower quality...
[01:27:03 CEST] <iive> oh, truehd is lossless too. and is dolby's format
[02:35:51 CEST] <dmc> didn't mention quality :p
[02:36:03 CEST] <dmc> S/PDIF doesn't support those
[02:40:56 CEST] <furq> just encode a sample with both and see if you can tell the difference
[02:42:41 CEST] <furq> the ac3 encoder is definitely pretty good quality
[02:42:55 CEST] <furq> i have no idea about the dts encoder, iirc it's a really old fork of dcaenc
[02:43:14 CEST] <furq> but idk if it's been worked on significantly since then
[02:44:31 CEST] <dmc> yeah, figured I should just experiment
[03:35:05 CEST] <Hello71> what's considered the least worst media container nowadays? matroska?
[03:44:24 CEST] <furq> Hello71: probably
[03:53:30 CEST] <ChChCherryBom1> mp4 :D
[03:54:05 CEST] <Hello71> mp4 seems to have lower overhead, but maybe I'm using matroska wrong
[03:54:51 CEST] <ChChCherryBom1> I find mp4 with fast start and ac3 just works on like everything really nicely
[03:55:14 CEST] <ChChCherryBom1> most dlna clients expect it properly handle metadata too if you aren't using custom media servers
[03:55:16 CEST] <furq> mp4 is fine if you've got supported codecs
[03:55:26 CEST] <furq> and it doesn't have the stupid timebase issue that matroska has
[03:55:52 CEST] <furq> and it's obviously much better supported
[04:10:45 CEST] <Hello71> how come remuxing my video from mp4 to mp4 increases the size by 20k (~0.17%)? I added -fflags +bitexact and -map_metadata -1, so if anything shouldn't it get smaller?
[04:11:16 CEST] <Hello71> also the duration changed... odd...
[04:14:55 CEST] <Hello71> and the "Total: x demuxed" and x muxed are the same numbers...
[04:16:14 CEST] <Hello71> looks like the input streams have slightly different duration, that's probably why
[10:46:52 CEST] <drkop> Hello! then i try code from smb:// to smb:// - got an error https://pastebin.com/zuruF7w6 and one second target video. if local to smb:// or vice versa - all is fine. what can i do? thank you!
[12:33:56 CEST] <ksj> hello, is it possible to make av codec drop frames if they are out of order?
[13:38:03 CEST] <roxlu> hi, probably a silly question :$ but I saw that there is a `delete_filler` option to remote filler nals. I'm curious how to actually use this? (adding -delete_filler clearly isn't the way to go). See https://gist.github.com/roxlu/998b7b3e014e49633d66052d74222337#file-gistfile1-txt-L20
[13:54:43 CEST] <roxlu> ah nvm, got it
[16:28:41 CEST] <reinaldorauch> Hello. I'm trying to convert mp4 files with audio streams only tagged with MusicBrainz Picard to mp4 files converting the audio stream to aac. But it seems that the codec does not support writing all the tags (the ones that picard adds) into the outfile. I tryied with libmp3lame and it added the metadata right. Is something that I'm missing?
[16:33:37 CEST] <reinaldorauch> The commands that I tryed: https://pastebin.com/C6LfAJAx
[16:58:36 CEST] <benlieb> Im trying to join two videos together that apparently have different SARs: Input link in1:v0 parameters (size 720x480, SAR 10:11) do not match the corresponding output link in0:v0 parameters (720x480, SAR 1:1)
[16:58:36 CEST] <benlieb> [Parsed_concat_4 @ 0x7ff1fd103e80] Failed to configure output pad on Parsed_concat_4 Error reinitializing filters!
[16:58:37 CEST] <benlieb> Failed to inject frame into filter network: Invalid argument Error while processing the decoded data for stream #0:0 Conversion failed!
[16:58:41 CEST] <benlieb> this is the command: ffmpeg -y -i file1.mp4 -i file.mp4 -filter_complex '[1:v]fade=t=in:st=0:d=2,fade=t=out:st=510:d=2[v];[1:a]afade=t=in:st=0:d=2,afade=t=out:st=510:d=2[a];[0:v][0:a][v][a]concat=a=1 [v][a]' -c:v libx264 -preset slow -crf 26 -r 30 -map '[v]' -map '[a]'  file3.mp4
[16:58:52 CEST] <benlieb> can anyone point me in the right direction?
[17:26:46 CEST] <atbd> hi, i'm using ffmpeg api to receive an udp stream and save images from it. I let the program run in background and it reboots periodically every 27h30min with "DTS %f / %f out of order" message. I saw this message in compute_pkt_fields but did not see how to correct my bug, furthermore it just mean the bug is after this but maybe not linked... Some of you have an idea on this please ?
[17:46:37 CEST] <kepstin> atbd: mpeg-ts in udp?
[17:47:18 CEST] <kepstin> that's the max value the mpeg-ts timestamps can have before they roll over
[17:47:42 CEST] <pomaranc> that's 26.5h
[17:47:54 CEST] <kepstin> er, well, it's pretty close anyways
[17:48:22 CEST] <atbd> yes it's mpegts
[17:48:56 CEST] <atbd> and when it roll over everything hang?
[17:49:53 CEST] <kepstin> applications just have to be designed to deal with the rollover and keep going :/
[17:51:12 CEST] <kepstin> one option is to use a larger timestamp value, and every time it rolls over or jumps back, save the previous value and then rewrite each new packet's pts to be prev_value + pts as
[17:51:43 CEST] <kepstin> (ffmpeg's normal pts values are 64bits, so that should work for long enough)
[17:52:29 CEST] <atbd> okay! thanks for your explanation
[17:52:37 CEST] <atbd> i'll try your solution
[18:52:25 CEST] <Chiefmas> Hello, I recently got a system with a Kaby Lake CPU, and I'm trying to get an idea for how much of the work of a transcode with a re-size I should be able to offload onto Quicksync. I had been hoping that I would have much lower CPU time used then I've been able to get. Example command I'm trying:
[18:52:55 CEST] <Chiefmas> ffmpeg -hwaccel qsv  -init_hw_device qsv=qsv:MFX_IMPL_hw_any -filter_hw_device qsv  -i "..\I Am Legend - Trailer.mp4" -vf "format=nv12,hwupload=extra_hw_frames=100,scale_qsv=640:360" -b:v 800k -c:v h264_qsv -c:a copy -y "..\test.mkv"
[18:54:14 CEST] <Chiefmas> so taking a 1008P source video, scale down and re-encode as h.264 again. This still seems to use 90%+ on CPU, although I am seeing a good amount of activity on the GPU offload (as reported by task manager).
[20:05:05 CEST] <bruce-> hey. should avdevice_list_input_sources return with a negative return value (-78) when querying the "avfoundation" device or am I doing something wrong?
[20:12:55 CEST] <teratorn> bruce-: probably
[20:13:14 CEST] <teratorn> bruce-: pastebin minimal example code plz
[20:32:09 CEST] <lemontea> I have a question about incorporating the DeckLink SDK into the build.  I am trying to create build a static DLL, but when building on windows visual studio 64bit, I get this => "Error	LNK2038	mismatch detected for '_ITERATOR_DEBUG_LEVEL': value '0' doesn't match value '2' in MyTestFunction.obj	ffmpegFuncDLL C:\dev\testffmpeg\libavdevice.a(decklink_enc.o)", when building it, i was using the following configure flags,...
[20:32:14 CEST] <roxlu> is it possible to show the packet number with `ffprobe` ? I have to inspect a specific nal and trying to find it :)
[20:40:16 CEST] <atomnuker> -show_packets
[20:41:53 CEST] <roxlu> atomnuker: that has no counter
[20:43:52 CEST] <atomnuker> welp, you can parse the json then and count 'em
[20:45:42 CEST] <roxlu> yeah I see there is also -read_intervals ... but specifying a range like: +START_OFFSET|+END_OFFSET (e.g. #200%#1) doesn't work
[20:45:56 CEST] <roxlu> I'm trying to figure out what the correct syntax is
[20:50:10 CEST] <lemontea> Anyone know about decklink SDK and building it in MSVC, then using the static lib files for visual studio project?
[20:51:33 CEST] <roxlu> lemontea: you want to use the decklink sdk? From what I remember there is a .idl file(?) that is used to generate a headers; it's been years that I looked at that
[20:52:49 CEST] <lemontea> roxlu: You are correct, i had to use midl from visual studio to generate the big header file on Windows.  Used it within Ffmpeg builds fine, and all, but weirdly only the decklink_enc.o is built with a different flag or something?
[20:53:35 CEST] <roxlu> what error do you get?
[21:01:06 CEST] <lemontea> roxlu:  "Error LNK2038 mismatch detected for '_ITERATOR_DEBUG_LEVEL': value '0' doesn't match value '2' in MyTestFunction.obj ffmpegFuncDLL C:\dev\testffmpeg\libavdevice.a(decklink_enc.o)"
[21:02:18 CEST] <lemontea> I was trying to compile MSVC with /MD flag, and got that error, and I will try it with /MT, but so many errors.  I think I am on the right path. But, I have to figure out how to do that with configure options building ffmpeg
[21:02:49 CEST] <roxlu> Ah I think that's due to a debug / release build
[21:03:15 CEST] <roxlu> Also check if the architecture of the library is similar as your project
[21:03:42 CEST] <roxlu> lemontea: at this page I've got some snippets that show how to do that http://roxlu.com/2013/017/working-set
[21:03:42 CEST] <bruce-> teratorn: that's a bit tricky because I am using ffmpeg through javacpp bindings. in the meanwhile I found http://ffmpeg.org/pipermail/libav-user/2018-March/010969.html which makes it look like it is not implemented.
[21:06:22 CEST] <lemontea> roxlu: nice page, like your use of Kalman Filter, I have used that before on an Arduino MCU. :)
[21:07:21 CEST] <lemontea> It is more like --enable-static --enable-debug sorta thing, but how to differentiate /MT and /MD for MSVC in configure scripts...hmmmm
[21:09:05 CEST] <roxlu> lemontea: there is probably a makefile which has those flags somewhere
[21:09:15 CEST] <roxlu> maybe try a "grep"
[21:14:02 CEST] <Ars> I am transcoding and multicasting stream like: fmpeg RTMP_Stream   udp://
[21:14:02 CEST] <Ars> Also i have stream check script (ffprobe udp://, but when executing that command ffmpeg stops.
[21:14:02 CEST] <Ars> I understand there is port binding problem.
[21:14:02 CEST] <Ars> But how i can check that UDP stream alive or no? How to chek stream on udp:// ?
[21:16:45 CEST] <lvlscape> Hi everyone, odd question. We've been learnign ffmpeg for the last week or two in our hackerspace. Curious for any recomended readings /books / reference materials relating to using which codecs for what. I've been web-searchign and grabbign other peoples config recomendations, tryign them out, and taco-belling them together.
[21:23:57 CEST] <lemontea> lvlscape: inside ffmpeg docs/examples is a very good place to start, pull from latest git, they updated their examples
[21:26:27 CEST] <lvlscape> @lemontea thanks, i'll dig down that direction. thankfully all the machiens are linux so capturing has been consistant with x11grab and v4l2 for grabbing the xorg desktops / webcams in our space...
[21:27:25 CEST] <lvlscape> related/unrelated question.. what do peopel hook into to stream the screen output of a headless server, thinking a tty-session, or a hdmi output.. was trying to research that but was lackign terms.
[21:30:13 CEST] <lemontea> lvlscape: I guess a simple approach is stream it out to a RTMP URL, and perhaps you have a rtmpdump server somewhere and people on the network can play it through vlc
[21:32:01 CEST] <lvlscape> yeah, already have a RTMP server setup, i got v4l2 to conenct to webcam devices, but unsure where to hook it to the terminal, web-searched for 2-4 hours yesterday ont he topic and was about to dive into that, wasnt sure if iw as even approachign it the right way or which 'f is the right tool, im like 90% sure its v4l2
[21:36:28 CEST] <lemontea> If you're using the API, avformat_open_input(rtmpurlhere); like this?
[21:45:36 CEST] <lvlscape> lemontea: can avformat access the hdmi-out / tty session and stream that correctly as video? .... and as i was typign this i was still web-searcign and i think my mind was just blown...     i think   x11grab doesnt just grab xserver stuff, and may be able to do what i need.. im goign to go read a lot more, order one of these books, check the docs, and keep hanging here, thanks for the direction
[22:10:47 CEST] <kepstin> lvlscape: with some graphics drivers on linux you can use 'kmsgrab' input device to grab the entire screen output (including console display)
[22:12:00 CEST] <lvlscape> kepstin: oh wow, i hadnt read anything about that one yet. thank you, im goign to test that too.
[22:12:14 CEST] <lvlscape> read about that now + test that today *
[22:21:08 CEST] <Ars> guys, how you monitoring ffmpeg process ?
[22:21:23 CEST] <Ars> and restart it ?
[22:21:56 CEST] <teratorn> Ars: exit code?
[22:23:12 CEST] <Ars> some time process die without exit, i am monitoring with monit but have problems
[22:24:42 CEST] <teratorn> dies how?
[22:24:59 CEST] <teratorn> you can use "-progress -" on the command line to get parsable progress output
[22:25:21 CEST] <BtbN> there is always an exit code if a proces quits
[23:03:51 CEST] <lemontea> roxlu:  still trying to find flags and hoping what im replacing in these two lines are making a difference. not a pro at building
[23:33:27 CEST] <lemontea> If anyone is interested, I solved my build problem by using /MT flag for importing the decklink SDK, and then making sure I am linking these files according to UCRT changes => https://blogs.msdn.microsoft.com/vcblog/2015/03/03/introducing-the-universal-crt/
[00:00:00 CEST] --- Fri Jun 29 2018

More information about the Ffmpeg-devel-irc mailing list