[Ffmpeg-devel-irc] ffmpeg.log.20180309

burek burek021 at gmail.com
Sat Mar 10 03:05:03 EET 2018

[00:57:26 CET] <doroudis> hey guys
[00:57:38 CET] <doroudis> Is it possible to get help here?
[00:58:08 CET] <DHE> you have to ask a specific question first
[00:58:16 CET] <doroudis> true
[00:59:10 CET] <doroudis> I'm trying to perform a pitch change operation on an audio clip with ffmpeg
[00:59:16 CET] <doroudis> without changing the duration of the clip
[00:59:43 CET] <doroudis> ffmpeg -i in.wav -af atempo=(3/4),asetrate=48000*(4/3) -y out.wav
[01:00:05 CET] <doroudis> this is the technique i'm using, and my input is a 48khz Mono WAV file
[01:00:58 CET] <doroudis> However this doesn't get me pitch shift, instead i get extremely slow indecipharable audio
[01:01:26 CET] <doroudis> Another option i've read up is rubberband but it seems like that's not included in the static ffmpeg builds
[01:34:43 CET] <notjagspargdon> why does this fail: ffmpeg -i testvid.mp4 -vcodec vp8 -qmin 0 -qmax 50 -b:v 1M -acodec vorbis -strict -2 vid.webm  with "could not find a valid device"
[01:35:09 CET] <notjagspargdon> copy pasted from some site ( but added the weird strict business at the end), everything else i try fails
[01:37:23 CET] <jkqxz> What vp8 encoders do you have built into that binary?
[01:37:42 CET] <jkqxz> Looks like it tried to use the v4l2m2m encoder, but you probably wanted libvpx.
[01:37:44 CET] <notjagspargdon> DEV.L. vp8                  On2 VP8 (decoders: vp8 vp8_v4l2m2m vp8_cuvid ) (encoders: vp8_v4l2m2m )
[01:38:10 CET] <DHE> if that doesn't work you'll have to build a copy with libvpx instead and do software encoding
[01:38:12 CET] <jkqxz> There you go.  The only vp8 encoder is the v4l2m2m one so it tried to use that.
[01:38:32 CET] <notjagspargdon> so why the f isn't vpx a default config option
[01:38:34 CET] <notjagspargdon> asgo;iyqergj
[01:39:02 CET] <notjagspargdon> thanks
[01:39:07 CET] <notjagspargdon> i will rebuiild now :(
[01:40:43 CET] <notjagspargdon> oh right, ffMPEG, so mp4 must be prioritized :\
[01:45:35 CET] <notjagspargdon> it's looking in /dev for some reason
[01:45:45 CET] <notjagspargdon> for that encoder?
[01:51:43 CET] <notjagspargdon> give out that commit access wisely
[01:51:45 CET] <notjagspargdon> buffer close
[01:52:25 CET] <bitblit> hey shouldn't copy without transcode be really fast? going from VOB to -f dvd, and it's slower than realtime...
[01:54:12 CET] <bitblit> nice ffmpeg -i "concat:$(echo $1/VIDEO_TS/*.VOB|tr \  \|)" -c copy -f dvd $1.mpg
[02:33:06 CET] <nicolas17> https://trac.ffmpeg.org/wiki/RemapFilter this looks pretty interesting but won't it cause aliasing?
[05:13:34 CET] <kurufu> this seemed like a good place to ask, but is there any tool that given an h264 video might guess at precisely what features are enabled?
[05:13:45 CET] <kurufu> for encoding*
[06:20:19 CET] <danieru98> How can I convert webm (opus) into mp3 and keep the metadata (at least tittle)?
[06:28:41 CET] <danieru98> is it possible in one line or it has to be a two step operation, first conversion and then copy the metadata?
[08:21:48 CET] <danieru98> so any ideas about keeping the metadata when converting containers?
[08:22:37 CET] <danieru98> i guess it's a bad hour to ask, everyone must be sleeping :P
[08:27:07 CET] <furq> danieru98: it should normally happen automatically
[08:27:34 CET] <furq> you can try -map_metadata 0 but maybe there's no mapping for the metadata you want to transfer
[08:28:27 CET] <danieru98> ffmpeg -i input.webm output.mp3 doesn't seem to save not even the title into output.mp3
[08:28:54 CET] <danieru98> even converting .mp3 to .mp3 seem to skip the metadata
[08:29:08 CET] <danieru98> i thought -map_metadata 0 was the default
[08:30:59 CET] <danieru98> no adding -map_metadata 0 doesn't seem to help. could it be my ffmpeg version?
[08:31:28 CET] <danieru98> "ffmpeg version 2.8.10-0ubuntu0.16.04.1"
[08:31:56 CET] <furq> yeah that's pretty old
[08:32:06 CET] <furq> i feel like it still worked in 2.8 but it's worth upgrading anyway
[08:32:12 CET] <furq> flac to mp3 definitely copies the audio metadata here
[08:34:38 CET] <danieru98> ill try updating my ffmpeg version then, thanks furq. I started to think ffmpeg couldn't do this
[08:34:58 CET] <furq> https://www.johnvansickle.com/ffmpeg/
[08:35:03 CET] <furq> grab those if your distro version is old
[08:35:53 CET] <danieru98> thanks, i thought i would have to manually compile
[08:36:22 CET] <danieru98> pre-build generic tarballs are so nice, everyone should use them, like openarena or blender
[08:37:00 CET] <danieru98> or firefox
[08:41:24 CET] <danieru98> no that doesn't seem to help either ./ffmpeg -i input.mp3 -map_metadata 0 output.mp3 skip the metadata
[08:42:12 CET] <danieru98> i used the build from git
[08:50:19 CET] <furq> not sure what to suggest, that works fine here
[08:50:33 CET] <furq> with or without -map_metadata
[08:50:39 CET] <danieru98> really? same command?
[08:50:42 CET] <furq> yeah
[08:51:08 CET] <danieru98> i dont know what to think either.
[08:51:20 CET] <danieru98> are you using linux too? what distro?
[08:51:28 CET] <furq> freebsd
[08:51:43 CET] <danieru98> maybe code paths or some library?
[08:51:53 CET] <furq> it's definitely not a library
[08:52:02 CET] <furq> is it maybe a weird id3 tag version
[08:52:36 CET] <danieru98> could you send me your mp3 and maybe i can send you mine?
[08:52:42 CET] <danieru98> do you have tox?
[09:00:07 CET] <furq> https://0x0.st/sm6_.mp3
[09:00:29 CET] <furq> that works fine and it even copies all the musicbrainz tag stuff
[09:00:36 CET] <danieru98> furq, https://we.tl/x9XbiWsvqR
[09:01:26 CET] <furq> yeah this doesn't have an id3v2.4 tag
[09:01:32 CET] <furq> that might be it
[09:02:05 CET] <furq> i'll pretend to be surprised that itunes would do something like that
[09:02:57 CET] <furq> that still seems to work though
[09:03:13 CET] <danieru98> that file i download, but some others i added metadata manually and none worked
[09:03:37 CET] <danieru98> so it works but ffmpeg is kinds picky?
[09:03:48 CET] <furq> i'm guessing it maybe just ignores id3v1
[09:03:57 CET] <furq> it looks like it just converted the 2.3 tag to a 2.4 tag
[09:04:10 CET] <danieru98> doesn't seem to work with matroska either
[09:04:20 CET] <furq> oh yeah that was the actual issue wasn't it
[09:04:58 CET] <danieru98> yes, i also needed flac, but specially webm
[09:05:07 CET] <furq> no that still works
[09:05:23 CET] <furq> flac to webm to mp3 keeps the metadata
[09:05:57 CET] <danieru98> hmm
[09:06:38 CET] <danieru98> including title?
[09:06:58 CET] <furq> yeah, looks like everything
[09:07:21 CET] <danieru98> thats the one im after, i got the webm by downloading from youtube using youtube-dl and saving the title inside the webm as metadata
[09:07:48 CET] <danieru98> maybe its youtube-dl using some weird formating or tags?
[09:07:52 CET] <furq> i was just going to say
[09:07:59 CET] <furq> i checked the webm and that's missing a couple of tags
[09:08:14 CET] <furq> even though they're there in the subsequent mp3
[09:08:21 CET] <furq> so maybe it's matroska tag mappings being weird
[09:08:34 CET] <danieru98> title is missing?
[09:08:37 CET] <furq> yeah
[09:08:48 CET] <danieru98> oh all the tags.. what luck
[09:09:13 CET] <furq> artist and track are missing, but album artist is still there
[09:09:35 CET] <furq> so yeah that's probably just different tools having different tag mappings
[09:09:44 CET] <danieru98> well, i guess ill just have to find some other way to do what i want
[09:10:14 CET] <danieru98> or i can configure ffmpeg into mapping how i want?
[09:10:39 CET] <furq> ffprobe shows a "title" tag as opposed to "TITLE"
[09:12:56 CET] <furq> that might merit a bug report actually
[09:13:10 CET] <furq> all my other tools expect ARTIST and TITLE for webm, but ffmpeg is setting them lowercase
[09:13:24 CET] <furq> and presumably ignoring the uppercase ones when transcoding
[09:13:53 CET] <danieru98> there's never enough case insensitive in this world
[09:14:14 CET] <furq> ok this is more confusing now
[09:14:25 CET] <furq> i set the right tags on the webm, transcoded it, and it's passing those through fine
[09:14:34 CET] <furq> so idk why it would be disappearing for you
[09:14:56 CET] <danieru98> ill be honest, i've never file a bug report, so if you volunteer it would be great :P
[09:15:18 CET] <danieru98> hmm
[09:16:39 CET] <danieru98> so setting the tags to upercase makes it work?
[09:16:56 CET] <danieru98> is there a way to do that without creating a new file?
[09:16:59 CET] <furq> it works either way after transcoding
[09:17:07 CET] <furq> they just don't show up properly in the webm in other tools
[09:17:16 CET] <danieru98> hmm
[09:17:34 CET] <furq> so yeah after all that i still don't know why they're not showing up for you
[09:18:03 CET] <danieru98> youtube-dl -f 249 --output "%(id)s.%(ext)s" --metadata-from-title "%(title)s" --add-metadata https://www.youtube.com/watch?v=DwVYMTvmiI0
[09:18:22 CET] <danieru98> thats basically what i did to obtain the webm im using
[09:19:20 CET] <danieru98> the webm has 2 tags "title           : Dr. Love Eurobeat
[09:19:21 CET] <danieru98>     encoder         : Lavf56.40.101"
[09:23:59 CET] <danieru98> oh
[09:24:03 CET] <danieru98> i got ya
[09:24:20 CET] <danieru98> yes the metadata is there
[09:24:51 CET] <danieru98> i just can't see it in smplayer and ezstream can't use it
[09:25:48 CET] <danieru98> "(ID3v1 only)"
[09:27:36 CET] <danieru98> so the actual question is how can i convert from webm to mp3 and also convert the metadata to ID3v1
[09:30:55 CET] <danieru98> or ID3v2
[09:31:04 CET] <danieru98> i just discover ID3v2 also work
[11:10:25 CET] <aularon> Hello! I am trying to use dash demuxer, the input url has multiple <representations>, how can I choose one of them?
[11:27:59 CET] <aularon> How may I use the -discard flag to discard streams, anyone?
[11:46:33 CET] <BtbN> I never heard of the discard flag, but if you only want some of the streams, select the ones you want explicitly with -map
[11:59:58 CET] <furq> he already left
[12:46:54 CET] <halvar> good day
[12:47:11 CET] <halvar> I am attempting to build ffmpeg using visual studio on windows (both 14 and 17) and running into all sorts of snags
[12:47:26 CET] <halvar> does someone have a link to the most up-to-date build instructions for building on windows ?
[12:57:32 CET] <ZexaronS> Hello
[12:57:59 CET] <ZexaronS> I'm trying to mux avc and ac3 and I get an error saying
[12:58:00 CET] <ZexaronS> [mpegts @ 0000025eec5d6d00] first pts value must be set
[12:58:00 CET] <ZexaronS> av_interleaved_write_frame(): Invalid data found when processing input
[12:58:33 CET] <ZexaronS> It was a MKV file, extracted with mkvextract from mkvtoolnix
[12:58:52 CET] <ZexaronS> VEGAS Pro can't open MKV files
[12:59:54 CET] <ZexaronS> if I try to mux to MP4 it kinda works but the video length is expanded and video goes slow, some kind of a frame delay or framerate slow
[13:00:52 CET] <ZexaronS> I tried -fflags +genpts but it doesn't work
[13:17:09 CET] <dl2s4> ZexaronS, not sure why you use mkvextract. for me ffmpeg -i in.mkv -c out.mp4 works fine(avc and ac3), but i am just a ffmpeg enduser cant say anything about "pts value mustbe set" and probably to pastebin your command and the output would be a good idea.
[13:18:25 CET] <ZexaronS> Maybe something changed recently, I don't think AC3 could go into MP4
[13:18:31 CET] <dl2s4> -c copy*
[13:18:41 CET] <ZexaronS> Or maybe I never used the right settings
[13:19:08 CET] <dl2s4> as i said worked fine here.. and i really have an old ffmpeg version
[13:19:32 CET] <ZexaronS> the command just has dobule inputs, and double copy, that's it
[13:19:42 CET] <ZexaronS> I'll try your way then
[13:26:42 CET] <ZexaronS> Heh maybe that's how i did it before, because I was doing it before, I just forgot
[13:26:49 CET] <ZexaronS> thanks dl2s4, it works
[13:27:23 CET] <dl2s4> nice, i am glad i was able to help
[13:29:53 CET] <furq> ac3 has always been supported in mp4
[13:30:49 CET] <ZexaronS> dl2s4, ah, the file conversion with ffmpeg worked, but VEGAS PRO still won't bulge, the audio works, but not video
[13:31:40 CET] <ZexaronS> I had vegas for a long time so I knew of this problem, but forgot how I did it last time, well, I remember I had to recode to MPEG2,
[13:31:58 CET] <ZexaronS> ive since upgraded to vegas pro 14, but still not better
[13:32:39 CET] <furq> are you particularly tied to vegas
[13:32:46 CET] <furq> there are ffmpeg-based NLEs out there
[13:33:58 CET] <furq> if you do need to use vegas then probably install x264vfw or something
[13:35:29 CET] <ZexaronS> furq: doesn't Vegas Pro have out of the box H264 support
[13:36:20 CET] <furq> shrug
[13:36:22 CET] <furq> i've never used it
[13:36:38 CET] <furq> i know it uses vfw codecs and x264vfw includes the ffmpeg h264 decoder as a vfw codec
[13:36:53 CET] <furq> the decoder it ships with might be baseline only or some bullshit
[13:36:54 CET] <ZexaronS> furq: I'm talking about importing this file into Vegas Pro for editing
[13:37:01 CET] <furq> i know
[13:39:04 CET] <ZexaronS> maybe it just has a problem with the properties of this particular H264 video
[13:39:17 CET] <ZexaronS> the way it was encoded originally
[13:46:16 CET] <ZexaronS> furq, dl2s4, Vegas PRO has a problem with AC3 indeed, M4V video alone works, if AC3 is packed in MP4 then this bug happens
[13:46:55 CET] <ZexaronS> so I recall now, ffmpeg works mp4 act, it's the Vegas Pro that has problem with this combination
[14:11:48 CET] <ZexaronS> So ffmpeg does not put metadata info that it was written with ffmpeg when encoding new file ?
[14:12:00 CET] <ZexaronS> Can I do that, it only adds Lavf info
[14:12:35 CET] <ZexaronS> the full version of ffmpeg
[14:13:15 CET] <ZexaronS> including date of the write
[14:16:37 CET] <ZexaronS> Okay OGG works fine with Vegas Pro, all 6 audio channels
[15:18:46 CET] <dragm__> anyone know of any buildscripts that will build ffmpeg, as well as x264 and x265 with 8 and 10bit support in 1 go ?
[15:21:11 CET] <relaxed> dragm__: my builds have both included, https://www.johnvansickle.com/ffmpeg/
[15:22:02 CET] <dragm__> cewl! thx! Vmaf included?
[15:22:45 CET] <relaxed> no
[15:31:28 CET] <DHE> relaxed: you know libx264 supports one binary with multiple bit depths now, right?
[15:31:41 CET] <DHE> since december
[15:32:57 CET] <dragm__> i heard some rumors about it
[15:33:28 CET] <dragm__> so x265 and x264 both support 8 and 10bit now by default in x64 mode ?
[15:33:36 CET] <DHE> it's likely only the git version for how recent it is, and there is an onus on user applications to support it as well...
[15:33:51 CET] <dragm__> and now i read somewhere that ffmpeg also supports 8 and 10bit ?
[15:33:58 CET] <dragm__> recently
[15:34:12 CET] <dragm__> onus ?
[15:34:21 CET] <DHE> responsibility
[15:34:39 CET] <DHE> ffmpeg's git version will support the x264 features
[16:40:16 CET] <relaxed> DHE: yes
[18:42:36 CET] <Leeroyescu> I'm trying to trim video with stream copy, directly on i-frames. Can someone explain if I-frames are what I'm looking for?
[18:43:18 CET] <DHE> stream copy isn't even smart enough to decide what is an i-frame and what isn't, beyond the basic seek capability of the container of the video
[18:49:37 CET] <Leeroyescu> @DHE I am well on my way, I have a semi-manual process with ffprobe to find I-frames which I then plug in to ffmpeg -ss -to commands. What I want to know is if it will work for most video files. Especially .mp4
[18:50:06 CET] <ChocolateArmpits> Leeroyescu, it will for mp4
[18:50:37 CET] <Leeroyescu> I want to decide if it's worth putting in the effort to turn this process into a batch file / powershell / nodejs program.
[18:51:27 CET] <DHE> there's a trick I sometimes use. the segment or hls muxers make multiple files that cut on keyframes. you can use that to make a collection of per-keyframe files which you can concatenate into a single video. especially with mpegts as a piece container
[18:51:36 CET] <ChocolateArmpits> well if the keyframe is quite far away, say 10 seconds you may be posed to actually reencode the part until the next keyfame
[18:52:57 CET] <Leeroyescu> The goal is to extract frame-accurate video fragments with minimal transcoding. I asked on StackOverflow too https://stackoverflow.com/questions/49151840/ffmpeg-extract-frame-accurate-video-fragments-with-minimal-transcoding
[18:53:32 CET] <Leeroyescu> Thank you for your answers!
[18:54:15 CET] <furq> DHE: how does that work with sound
[18:57:09 CET] <Leeroyescu> @ChocolateArmpits that's exactly my process. Encode from real start timestamp to nearest keyframe in, stream copy the main chunk from that keyframe to the last keyframe before the end timestamp, then do another encode for the end bit. Concatenate start.mp4, main.mp4 and end.mp4 and you have your video fragment with minimal transcoding done
[18:57:28 CET] <DHE> furq: it should be fine, with a possible slight cut at the start and/or end.
[18:58:26 CET] <ChocolateArmpits> Leeroyescu, I think the real trouble is actually matching the video quality and ratecontrol of the original. The last part is pretty dubious
[19:01:08 CET] <ChocolateArmpits> You could consider transcoding if given distance to the next keyframe is too large for your specific situation. If transcoding is not done and the additional preroll frame data is kept, you can opt for muting the audio before the original cut time
[19:02:06 CET] <ChocolateArmpits> And leas that's what I would do for speech-heavy material where you want to cut exact setences foremost rather than video content
[19:02:13 CET] <ChocolateArmpits> sentences *
[19:02:59 CET] <ChocolateArmpits> So the main issue is that no script is ever going to anticipate all situations people have
[19:05:51 CET] <Leeroyescu> I see
[19:07:39 CET] <Leeroyescu> I've only done a single test so far, cutting from a movie. And the cuts were not around dialogue, come to think of it. This is very helpful because I can't test by the 100s or 1000s yet.
[19:09:04 CET] <Leeroyescu> It worked decently. You can tell the encodes because of slight visual artefacts but the sound and fluidity was perfect.
[19:13:49 CET] <xq> Hello. When trying to record system sounds and microphone input (both into one stream) I end up with desynced audio. This is most probably caused by some stutter/gaps that occur at the beginning of recording of the system sound (it goes away after 3-5s). My question: is there a way to make ffmpeg substitute gaps/stutter in one of the input streams with silence, so that the end result contains synced audio?
[19:14:40 CET] <xq> My ffmpeg is 3.4.1-1+b1 (from debian). My command is http://paste.debian.net/hidden/52df928d/
[19:16:52 CET] <ChocolateArmpits> xq, is the desync constant each time your current command is run? If so if would be better to offset the input timestamps by that amount
[19:17:18 CET] <ChocolateArmpits> otherwise I don't think random variation can be fixed
[19:17:33 CET] <ChocolateArmpits> automatically
[19:18:12 CET] <xq> it's more or less constant, the system sounds end up 1-3 seconds ahead of the mic sound
[19:20:15 CET] <ChocolateArmpits> record them several times, measure and compare the sample distance in audacity
[19:21:30 CET] <ChocolateArmpits> based on sampling rate convert samples to time and then use -itsoffset for the delayed source with a timestamp offset value
[20:43:28 CET] <xq> ChocolateArmpits thanks. I did some more research and found a way to fix things that is less hacky
[20:44:29 CET] <xq> basically instead of capturing from two sources and merging them in ffmpeg, I created an already-merged source inside pulseaudio and simply capture that with ffmpeg as one input
[20:44:40 CET] <xq> seems to be working, no desynced audio anymore
[20:44:53 CET] <xq> this page describes exactly what I did https://www.linux.com/learn/weekend-project-record-skype-calls-and-other-apps-linux
[21:51:23 CET] <kiroma> Do I need to run configure every time I pull source or only when there's a creation/deletion?
[21:55:48 CET] <durandal_1707> kiroma: only when it fails to build
[22:01:37 CET] <kepstin> kiroma: the makefile will also print a warning occasionally to recommend re-running configure. (and you can type "make config" to re-run configure with the same options as you last used)
[22:02:45 CET] <kiroma> I've just been running ffmpeg to copy the config flags off of it for the whole time
[22:02:57 CET] <kiroma> Thanks dude.
[22:44:14 CET] <doroudis> hi there
[22:44:16 CET] <doroudis> i have a question
[22:45:55 CET] <doroudis> if I have "asetrate=44100*4/3"
[22:46:58 CET] <doroudis> how can i get the input audio rate
[22:54:36 CET] <kepstin> doroudis: not sure what you mean.
[22:55:01 CET] <kepstin> do you want to use asetrate with an expression based on input rate, rather than a constant value?
[22:56:41 CET] <kepstin> I don't think the asetrate filter supports that, but the atempo filter might work for you
[22:59:09 CET] <doroudis> yea
[22:59:11 CET] <doroudis> kepstin
[22:59:31 CET] <doroudis> i'm using atempo and asetrate
[22:59:33 CET] <doroudis> -af atempo=0.5,asetrate=48000*(2)
[22:59:36 CET] <doroudis> to pitch shift
[22:59:46 CET] <doroudis> haven't been able to compile rubberband..can't find a static lib with it
[23:00:21 CET] <kepstin> you cannot use atempo and asetrate to pitch shift without also changing audio length.
[23:00:32 CET] <utack> the netflix article on their shot based encoding feels like captain obvious episode 3....they should have figured that out about 5 years ago
[23:00:39 CET] <utack> sorry for the ot...
[23:01:50 CET] <kepstin> doroudis: you really just want to get something with rubberband support.
[23:03:08 CET] <doroudis> yea i understand
[23:03:09 CET] <kepstin> doroudis: note that atempo=2 does the exact same thing as a hypothetical asetrate=(inputrate)*2 would.
[23:03:16 CET] <kepstin> iirc
[23:03:34 CET] <kepstin> so, atempo=0.5,asetrate=(inputrate)*2 would be a no-op.
[23:03:50 CET] <doroudis> not true
[23:03:55 CET] <doroudis> when i do it
[23:04:00 CET] <doroudis> it pitches the audio higher
[23:05:19 CET] <doroudis> asetrate pitches it up when multiplied by 2 but also speeds it up
[23:05:32 CET] <doroudis> atempo=0.5 fixes the increased tempo while maintaining the pitch
[23:05:46 CET] <doroudis> then I -ar 48000 hz to maintain original sample rate
[23:06:30 CET] <kepstin> oh, huh, I misunderstood what the atempo filter does.
[23:06:37 CET] <kepstin> it scales speed without changing pitch
[23:06:44 CET] <kepstin> the docs for that are kinda unclear
[23:06:45 CET] <doroudis> yea
[23:06:52 CET] <doroudis> definitely tell me about it lol
[23:07:01 CET] <doroudis> i don't even know how to use rubberband inside a ffmpeg command
[23:07:07 CET] <doroudis> apparently you have to use a rubberband command
[23:07:28 CET] <kepstin> there's an ffmpeg filter named 'rubberband' that you can use if your ffmpeg was built appropriately
[23:07:40 CET] <kepstin> it will probably give better results than the ffmpeg filter combination
[23:07:57 CET] <doroudis> yea kepstin
[23:08:00 CET] <doroudis> it definitely would
[23:08:03 CET] <doroudis> but i don't know how to compile it in
[23:08:12 CET] <doroudis> i only have a static build on windows
[23:08:31 CET] <kepstin> is there any reason for you to preserve the input sample rate? if not, you could just do something like -af aresample=48000,atempo=0.5,asetrate=96000,aresample=48000
[23:09:09 CET] <doroudis> oh
[23:09:10 CET] <doroudis> great idea
[23:09:21 CET] <doroudis> basically enforce a sample rate i know
[23:09:26 CET] <doroudis> so that i can use it in setrate
[23:09:29 CET] <doroudis> and then resample back
[23:09:58 CET] <JEEB> &41
[23:11:31 CET] <doroudis> WORKS!!
[23:11:33 CET] <doroudis> thank you kepstin
[23:12:32 CET] <kepstin> if someone wants a simple ffmpeg patch to do to learn about filters, making asetrate= take an expression with a variable available with the input sample rate shouldn't be that hard, tho :)
[23:13:36 CET] <doroudis> well
[23:13:44 CET] <doroudis> i'm running this on android
[23:13:51 CET] <doroudis> it's already hard af even get a command running
[23:13:53 CET] <doroudis> on android
[23:14:50 CET] <doroudis> kepstin are on facebook?
[23:14:59 CET] <doroudis> do you mind i DM there
[23:15:21 CET] <kepstin> please don't, there's no reason for you to dm me anywhere.
[23:18:10 CET] <doroudis> fair enough
[23:18:24 CET] <doroudis> i'll keep things posted here
[00:00:00 CET] --- Sat Mar 10 2018

More information about the Ffmpeg-devel-irc mailing list