[Ffmpeg-devel-irc] ffmpeg.log.20180325

burek burek021 at gmail.com
Mon Mar 26 03:05:02 EEST 2018

[05:28:18 CEST] <memo1> hi, im using the opction segments to create portion of videos.  I like the optin segments_wrap but only works when the output files are out%03d.mp4.  I want to use wrap with output file names like web_cam-%Y%m%d-%H%M%S.mp4 but it nevers start again.
[06:01:07 CEST] <palomba> Hello! I have a text file that contains a sequence of numbers (one number per line). I would like to overlay these numbers on a video. The number of lines in the text file match exactly with the frame count of my video. I could not find how to do this via a Google search. Any help is appreciated, thanks in advance!
[06:09:48 CEST] <tdr> if you put a number on each frame you probably can't even read them
[06:11:46 CEST] <palomba> You are right, but most digits do not change between frames
[08:33:16 CEST] <mustafam> Hello everybody, I want to build a completely static ffmpeg binary, how can I do that?
[08:33:46 CEST] <mustafam> I used --pkg-config-flags="--static" but still not everything is packed into the binary
[08:45:01 CEST] <furq> mustafam: --extra-ldflags="-static"
[08:59:18 CEST] <mustafam> furq: I'm trying this now, thank you.
[09:00:12 CEST] <mustafam> But I am getting /usr/bin/ld: cannot find -lfreetype
[09:00:36 CEST] <mustafam> freetype-devel is already installed
[09:20:53 CEST] <mustafam> furq: I'm trying to build on Fedora 27, without the -static, it is built normally, but with -static, it complains with "/usr/bin/ld: cannot find -lfreetype"
[09:22:28 CEST] <kwizart> mustafam, freetype-devel is only provided as shared lib, you need to build a static one yourself if needed
[09:23:12 CEST] <mustafam> OK, will try that, thank you.
[09:24:08 CEST] Last message repeated 1 time(s).
[09:24:08 CEST] <kwizart> mustafam, the other way is to use -shared -lfreetype -static your_static_libs
[09:25:12 CEST] <mustafam> Can I use something to donate my_static_libs, or I should list them one by one?
[21:23:06 CEST] <user234234> Hi, I'm trying to record old PAL VHS videos with an USB-grabber video works but I can't seem to make audio work. Here's some output: https://pastebin.com/xEUywUn3
[21:29:43 CEST] <furq> user234234: there was a similar-looking bug fixed in 3.4, so you might want to try updating
[21:30:33 CEST] <furq> https://www.johnvansickle.com/ffmpeg/
[21:30:37 CEST] <furq> use those if your distro doesn't have 3.4
[21:31:19 CEST] <user234234> thanks for linking there, i already tried with that build, i do get the same error
[21:32:19 CEST] <user234234> https://pastebin.com/aYRsND24
[21:32:40 CEST] <user234234> but with hints to alsa source code
[21:39:16 CEST] <user234234> do i have to address the sound card differently than hw:2,0 when i am using "-f alsa -acodec pcm_s16le"?
[21:45:55 CEST] <user234234> could someone give me a tip how to record audio from the Empia 28xx capture device? It is in the S16_LE format.
[22:05:18 CEST] <debianuser> user234234: Does `arecord -v -Vstereo -fdat -Dhw:Em28xxAudio,0 somefile.wav` work and capture sound? Or does it print any error?
[22:08:03 CEST] <user234234> need a min - testing it
[22:13:36 CEST] <user234234> arecord: pcm_read:2103: read error: Input/output error   --  --  https://pastebin.com/QbQtS9Nd
[22:14:27 CEST] <user234234> after 5 seconds arecords exits after creating a 44 bytes big wav skeleton
[00:00:00 CEST] --- Mon Mar 26 2018

More information about the Ffmpeg-devel-irc mailing list