[Ffmpeg-devel-irc] ffmpeg.log.20180330

burek burek021 at gmail.com
Sat Mar 31 03:05:01 EEST 2018

[00:19:16 CEST] <wfbarksdale> anyone have general advice for creating a pipeline for realtime rendering of an "edited" video? i.e. combining multiple sections of multiple video files together, possibly doing some openGL transformations on frame output.
[00:25:56 CEST] <BtbN> OBS?
[00:41:41 CEST] <kepstin> wfbarksdale: it's pretty much impossible to say anything "general" about that
[00:42:00 CEST] <kepstin> other than that I suppose handling seeking in realtime playback is hard
[00:42:40 CEST] <wfbarksdale> yeah, I am thinking that AVStream is kind of the right entry point, and I keep an AVStream for each "clip" (read videofile + startTime + endTime)
[00:43:10 CEST] <wfbarksdale> for realtime playback, the AVStream keeps its start frame buffered
[00:45:34 CEST] <wfbarksdale> (working with C API)
[00:54:43 CEST] <wfbarksdale> will it be a problem to keep 2 AVStreams to the same video file and use them independently?
[04:27:34 CEST] <s5lt> hello
[04:30:20 CEST] <s5lt> Hello, I am trying to install FFmpeg-SIXEL and when I do "./configure --enable-libquvi --enable-libsixel" I get an error saying neither are found and it will use pkg-config. However I have both installed. Does anyone know what could cause this error
[04:33:53 CEST] <DHE> maybe you need to set PKG_CONFIG_PATH... /usr/local/lib/pkg-config is a common path to set when installing dependencies which are themselves built from source
[04:49:28 CEST] <s5lt> 1:m #ffmpeg Hello?
[04:54:23 CEST] <s5lt> are you receiving me?
[04:55:03 CEST] <DHE> yes...
[04:57:27 CEST] <s5lt> sorry just new to IRC stuff
[04:57:52 CEST] <s5lt> does any one here know anything about FFmpeg-SIXEL
[05:00:14 CEST] <DHE> I gave a (generic) suggestion above
[05:05:34 CEST] <s5lt> Thanks, I think I am going to use an alternative
[08:32:17 CEST] <brimestone> hello, has anyone tried to send an ffmpeg output to an s3 bucket?
[09:59:58 CEST] <random-drop-in> hello?
[11:03:49 CEST] <electronorbitals> When will av1 be supported by ffmpeg
[11:04:11 CEST] <pmjdebru1jn> encode or decode?
[11:06:02 CEST] <ritsuka> the av1 encoder is still a big work in progress, right now it's quite slow
[11:06:19 CEST] <pmjdebru1jn> electronorbitals:  ..V.L. av1                  Alliance for Open Media AV1
[11:06:28 CEST] <pmjdebru1jn> so git already has it
[11:07:03 CEST] <pmjdebru1jn> oh wait
[11:07:27 CEST] <pmjdebru1jn> DE aren't tagged yet
[11:07:31 CEST] <pmjdebru1jn> so I guess it doesn't work yet
[11:09:20 CEST] <durandal_1707> pmjdebru1jn: you need aom lib
[11:09:30 CEST] <pmjdebru1jn> ah :)
[11:15:24 CEST] <zyme> What about JEM previews, any methods on using /testing that?
[12:57:30 CEST] <meins> Hello
[12:57:43 CEST] <meins> Can someone helps me with the avformat_find_stream_info function?
[12:58:22 CEST] <meins> I will use ffmpeg for online Streaming but this function Needs too much time to Change from one to the other Stream.
[16:32:49 CEST] <killown> does ffmpeg already support https://en.wikipedia.org/wiki/AV1 ?
[16:33:28 CEST] <Mavrik> Not internally.
[16:33:40 CEST] <Mavrik> AV1 was not standardized until like a few days ago.
[16:33:54 CEST] <Mavrik> It does support libaom I think
[16:33:57 CEST] <killown> Mavrik, how could I enable this codec?
[16:34:47 CEST] <killown> can this really reduce 40% of the size
[16:36:17 CEST] <killown> it will speed up the internet a lot
[16:41:40 CEST] <JEEB> killown, Mavrik: AV1 support through libaom is in FFmpeg now. but as far as I know the format is /still/ not frozen
[16:41:57 CEST] <Mavrik> Ah.
[16:41:59 CEST] <JEEB> the PR piece they put out a few days ago was not managed with the technical folk at AOM
[16:42:06 CEST] <JEEB> it's because of NAB most likely
[16:42:09 CEST] <Mavrik> I didn't read the PR piece :)
[16:42:20 CEST] <killown> browsers doen't support av1 yet,
[16:42:22 CEST] <Mavrik> Any deadlines for AV1 standardization?
[16:42:27 CEST] <JEEB> https://news.ycombinator.com/item?id=16699481
[16:42:52 CEST] <JEEB> killown: both chromium and firefox added it up so it will hit stable within one-two releases. the primary issue is that the format is not yet frozen
[16:43:10 CEST] <JEEB> Mavrik: I heard from someone that there was supposed to be a final crunch on the spec right about now
[16:43:18 CEST] <JEEB> until the beginning of april or so
[16:43:49 CEST] <killown> JEEB, 2020 will be the year to use it maybe? because there are lots of people using old browsers yet
[16:44:27 CEST] <JEEB> whenever the ecosystem becomes good enough for it
[16:45:02 CEST] <JEEB> I wouldn't be surprised if some vendors started pushing out VoD video in AV1 for those devices / apps that can support it quicker, like GOOG most likely
[16:45:16 CEST] <JEEB> also netflix has been very interested in AV1 as far as I can see.
[16:46:01 CEST] <Mavrik> It'll take a bit for everything to catch up tough.
[16:46:04 CEST] <Mavrik> Couple of years?
[16:46:07 CEST] <JEEB> sure
[16:46:11 CEST] <Mavrik> For initial support
[16:46:35 CEST] <Mavrik> I wonder if YT guys will drop the annoying VP9.2 requirement for HDR and use AV1 instead.
[16:47:12 CEST] <JEEB> as soon as the encoders get usable for some use cases I will guess some sort of adoption will start, and then with time the amount of devices/apps getting AV1 will rise. but the starting point is "usable encoder"
[16:47:25 CEST] <transcodeine> Hey JEEB- thanks for the help on ffmpeg stuff days ago
[16:47:26 CEST] <JEEB> right now IIRC there's one encoder that's slow as hell and another encoder that's fast as hell but doesn't compress well :D
[16:48:01 CEST] <JEEB> and BBB of course is trying to find a business hole for himself so most likely he's making Eve2 for AV1 :P
[16:48:27 CEST] <Mavrik> I'd say that we need HW decoders first ?
[16:48:42 CEST] <Mavrik> Considering the fact that huge amount of media is watched on mobile/STB platforms.
[16:48:56 CEST] <Mavrik> No idea if morern HW video decoders can be reused to accelerate AV1
[16:49:11 CEST] <JEEB> that hasn't stopped VP9 adoption on certain places, and as I noted it will take time for the share of AV1 usage for various devices to rise
[16:49:34 CEST] <JEEB> so you will serve the stuff those devices can take for as long as needed
[16:49:56 CEST] <JEEB> they did keep some stuff the same as VP9 because the hw people threw a fit
[16:50:02 CEST] <JEEB> so most likely they can re-use some tools
[16:50:07 CEST] <JEEB> but not a full decoder
[16:50:20 CEST] <kiloreux> I am trying to encode a file with libaom-av1 codec but it's super slow. Over 7 minutes for 400kb video and still going. Any idea ?
[16:50:27 CEST] <JEEB> it is slow
[16:50:30 CEST] <JEEB> like super, super slow
[16:50:30 CEST] <kepstin> kiloreux: working as expected
[16:50:39 CEST] <JEEB> I mean, they're using it to test the tools
[16:50:47 CEST] <JEEB> as in, "how much compression can we get out of this feature"
[16:50:52 CEST] <JEEB> before optimizing for speed
[16:50:59 CEST] <kepstin> that's typical of reference encoders made during spec development
[16:51:03 CEST] <JEEB> yup
[16:51:10 CEST] <JEEB> rav1e is the one that has been made to validate the spec
[16:51:19 CEST] <JEEB> and that one went over 1000fps on HD last I checked
[16:51:20 CEST] <JEEB> lol
[16:51:26 CEST] <JEEB> but that is not a high compression encoder
[16:51:40 CEST] <kiloreux> kepstin, JEEB , wonderful information. Thank you very much.
[16:52:02 CEST] <JEEB> but yea, even if you encode AV1 now
[16:52:07 CEST] <JEEB> you might not be able to decode it tomorrow
[16:52:12 CEST] <JEEB> (with tomorrow's libaom)
[16:52:13 CEST] <kepstin> keep in mind also that the bitstream format isn't finalized, yeah
[16:52:19 CEST] <kepstin> what JEEB said :)
[16:52:42 CEST] <kepstin> (I'd expect it's probably pretty close at this point, tho)
[16:52:45 CEST] <JEEB> yes
[16:52:52 CEST] <JEEB> since I heard people talk about the last crunch and all
[16:53:26 CEST] <Mavrik> So, since I wasn't following, what made people adopt AV1 but not VP9?
[16:54:13 CEST] <JEEB> HEVC being a mess
[16:54:25 CEST] <JEEB> not format-wise but the companies deciding they wanted a bigger cut out of licensing
[16:54:36 CEST] Action: JEEB actually liked a lot of the sane'ification in HEVC
[16:54:45 CEST] <JEEB> Mavrik: the best part was when apple joined AOM
[16:54:53 CEST] <JEEB> since usually apple goes the exact opposite
[16:55:10 CEST] <kepstin> there's, what, 3 patent pools and at least 2 individual licensors involved in hevc? that we know of, so far.
[16:55:12 CEST] <azarus> HEVC is included in macOS?
[16:55:17 CEST] <Mavrik> Yeah, I'm familiar with HEVC craziness
[16:55:18 CEST] <azarus> so why do they need AV1?
[16:55:27 CEST] <Mavrik> JEEB, that actually surprised me a lot
[16:55:33 CEST] <Mavrik> since Apple very publicly pushed HEVC
[16:55:36 CEST] <Mavrik> and then joined AOM
[16:55:42 CEST] <kepstin> the weirdest bit is how Apple is listed as a "founding member"
[16:55:51 CEST] <JEEB> that's a level of membership I bet
[16:55:54 CEST] <JEEB> not age thing
[16:55:55 CEST] <JEEB> lol
[16:56:10 CEST] <JEEB> so they joined with the bigger contribution level or so
[16:56:33 CEST] <Mavrik> Giving apple the founding member title in exchange for them supporting the format seems like a cheap trade :P
[16:58:08 CEST] <JEEB> yea, even if it went like that
[16:58:13 CEST] <JEEB> it's good to have them on board
[16:58:59 CEST] <JEEB> also I don't really care if corps joined AOM to have a plan B or leverage on the HEVC situation, it's still a show of interest towards having such formats like AV1
[16:59:33 CEST] <JEEB> and AV1 is the next-gen right now, while HEVC is already current gen :) so in that sense "they already have HEVC so why would they want AV1?" gets explained
[16:59:44 CEST] <JEEB> companies want to have an alternative at the very least for the next format
[18:24:24 CEST] <tansa> hello, where do i download the latest Libavfilter ?
[18:24:42 CEST] <JEEB> it's part of FFmpeg
[18:24:52 CEST] <JEEB> so you build FFmpeg and one of the libraries you get is libavfilter
[18:24:59 CEST] <tansa> i see, thank you
[18:25:09 CEST] <JEEB> np
[18:25:34 CEST] <tansa> because i was using the command fade=t=in:st=5.5:d=0.5 from the documentation .. and it's saying its not correct
[18:25:48 CEST] <tansa> i immagined it's the library .. am i right ?
[18:25:58 CEST] <JEEB> unless seomeone disabled that filter, yes
[18:26:11 CEST] <tansa> ok
[18:28:05 CEST] <tansa> sorry for bothering, but is there a way to fade in the first 2 seconds of the video without rebuilding ffmpeg ?
[18:30:08 CEST] <tansa> i'm using it like this and it's giving an error
[18:30:11 CEST] <tansa> ffmpeg.exe -i "wonder.mp4" -vf 'fade=t=in:st=5.5:d=0.5' -c:a copy -c:v libx264 -f mpegts udp://
[18:30:35 CEST] <JEEB> post the full console output with -v verbose onto a pastebin or gist
[18:30:36 CEST] <JEEB> and link here
[18:30:54 CEST] <DHE> that's probably not going to go very well... mpegts over udp all over again...
[18:31:16 CEST] <JEEB> well that shouldn't fail in lavfi
[18:31:43 CEST] <JEEB> so if the error is in lavfi filter chain creation then I don't care about the unicast going wee-wee
[18:34:17 CEST] <tansa> https://pastebin.com/UjCa0uY7
[18:34:55 CEST] <tansa> what shall i use instead of mpegts for streaming over udp ?
[18:35:54 CEST] <TD-Linux> rav1e is now quite a bit slower, but still not any good :)
[18:36:27 CEST] <JEEB> tansa: for some reason it's parsing your whole fade thing is a single filter name?
[18:36:37 CEST] <JEEB> at least that's who I take No such filter: 'fade=t=in:st=5.5:d=0.5'
[18:37:00 CEST] <tansa> im streaming to a scrambler and i'm forced to use udp .. so what other option do i have
[18:37:50 CEST] <JEEB> although check if `ffmpeg -filters` returns fade
[18:42:21 CEST] <tansa> yes it does
[18:42:22 CEST] <tansa>  .S. fade              V->V       Fade in/out input video.
[18:42:37 CEST] <tansa> it's working with filter-complex... how weired
[18:46:13 CEST] <tansa> but without audio :(
[18:46:21 CEST] <tansa> something weired is happening
[19:26:17 CEST] <axew3> hello guys, i think to have succesfully install any possible mmpeg library and finally the installer on centos had a start, but when finished, seem that mmpeg executable has been not create, it isn't into usr/bin, nor into any other folder i assume, since find not find out any ffmpe 'green' executable/file. I remember last day i had a folder into home within ffmpeg executable, but i've delete
[19:26:17 CEST] <axew3> it. Assuming, that isn't sure, but quite sure, all is installed, how i can resolve this?
[19:27:03 CEST] <JEEB> if you compiled FFmpeg then you know what your prefix was
[19:27:11 CEST] <JEEB> if you didn't set a --prefix for configure
[19:27:15 CEST] <JEEB> then it's /usr/local
[19:27:23 CEST] <JEEB> if you set it, then it's what you set
[19:27:29 CEST] <JEEB> the binary then goes into <prefix>/bin
[19:27:36 CEST] <JEEB> (that is after `make install`
[19:29:01 CEST] <axew3> ok i try ... was better i had take a look into shh, before to start 2 days ago ... now i'm quite ok with, but still a newbie
[19:29:11 CEST] <axew3> ssh
[19:35:04 CEST] <axew3> nothing on /local/bin there are others executable, like, lame, nasm,ndisasm but not mmpeg, the same on usr/bin
[19:35:21 CEST] <axew3> ffmpeg sorry
[19:35:25 CEST] <JEEB> check ffbuild/config.log
[19:35:29 CEST] <JEEB> in your build directory
[19:35:43 CEST] <JEEB> that should contain whatever your prefix is
[19:35:54 CEST] <JEEB> and if you never ran make install, that will of course mean that the binaries never got installed :P
[19:36:30 CEST] <axew3> make install has been done i presume
[19:36:53 CEST] <JEEB> so  you don't even know?
[19:38:17 CEST] <JEEB> but anyways, if you see ffbuild/config.log in the build dir having --prefix set then you know the prefix
[19:38:52 CEST] <JEEB> if it's not then it's /usr/local and `make install` just hasn't been run :P
[19:43:06 CEST] <axew3> mhh... i'm little confused ... maybe not? only make?
[19:43:25 CEST] <axew3> the cat to log file say compilation terminated.
[19:43:25 CEST] <axew3> ERROR: libx264 not found
[19:43:36 CEST] <axew3> the same of last night
[19:43:44 CEST] <axew3> so it has not been changed
[19:43:52 CEST] <JEEB> then you never got to compilation :P
[19:44:25 CEST] <axew3> ok, before to start cry, i will re-try JEEB!
[19:44:46 CEST] <axew3> finally i will pay you to install maybe :)
[19:45:27 CEST] <axew3> 2 full days and still nothing
[19:45:41 CEST] <axew3> so i will see ...
[20:07:47 CEST] <axew3> i've restart so i expect now that make will follow for more then 1 hour to process
[20:07:59 CEST] <axew3> like this morning
[20:08:33 CEST] <axew3> the command already contain make install after make but maybe wasn't execute
[20:09:11 CEST] <axew3> the terminal say in red: C compiler failed test but after start like this morning
[20:09:56 CEST] <transcodeine> will ffmpeg allow inbound multicast > outbound unicast to itself on another server across a wan?
[20:17:26 CEST] <DHE> it doesn't care. it's a networking thing.
[20:21:04 CEST] <axew3> nothing now seem to work finally: i had ffmpeg_g and i had see that  install had fail on renaming the file (even i'm not a c programmer) so i've move and rename in /usr/bin into ffmpeg and i've run ffmpeg version ... it return the ffmpeg version now, and not that command not exist so i can assume all is fine finally?
[20:21:53 CEST] <JEEB> ffmpeg_g is just the non-stripped version so it's just larger than the "normal" ffmpeg binary
[20:22:00 CEST] <JEEB> no idea why the stripping would fail in your case
[20:22:23 CEST] <emcoder> Hi, I read in https://trac.ffmpeg.org/wiki/Encode/H.264#twopass about two-pass encoding, and at the end it says "choose the slowest -preset you can tolerate". Should I specify the `-preset` flag in both passes?
[20:22:52 CEST] <JEEB> yes
[20:22:57 CEST] <JEEB> it's not a flag, it's an option
[20:23:13 CEST] <JEEB> also you only want two-pass if you have a specific average bit rate (file size in other words) you want to hit
[20:23:52 CEST] <emcoder> Hm, then I don't really need two-pass
[20:24:17 CEST] <axew3> it say ffmpeg version N-90489-g759381d Copyright (c) 2000-2018 the FFmpeg developers ...
[20:24:23 CEST] <JEEB> if you just have a "quality level" you want to get to
[20:24:28 CEST] <axew3>  ffmpeg_g is just the non-stripped version so it's just larger than the "normal" ffmpeg binary .... it mean it is not ok?
[20:24:38 CEST] <axew3> i should not do it in this way?
[20:24:48 CEST] <JEEB> I have no idea why stripping would fail to you but the binary should work
[20:24:53 CEST] <JEEB> it's just the one with the debug symbols included
[20:25:18 CEST] <axew3> ok ... i'm so happy with this at moment, until not more skilled!
[20:25:24 CEST] <JEEB> emcoder: if you just have a quality level you need to hit you use -ss and -t to encode like a few minutes of content that's representative
[20:25:32 CEST] <JEEB> and tweak the crf value and preset
[20:25:34 CEST] <axew3> if it work, even not so efficetly is ok
[20:25:37 CEST] <JEEB> first preset, then crf
[20:25:53 CEST] <JEEB> after you've found the slowest preset that is still "fast enough" for your use case
[20:25:59 CEST] <JEEB> you start with crf 23
[20:26:08 CEST] <JEEB> then if the result of the test looks bad, you go down
[20:26:11 CEST] <JEEB> if it looks good, you go up
[20:26:23 CEST] <JEEB> then at some point you will find the highest value that still looks good
[20:26:33 CEST] <JEEB> which thus becomes your CRF value for that type of content
[20:26:43 CEST] <JEEB> (type, resolution, frame rate)
[20:28:53 CEST] <emcoder> That's very helpful, thanks!
[20:29:48 CEST] <axew3> JEEB thank you!
[21:13:40 CEST] <axew3> to link mmpeg into a wrapper for apache, should i follow this: https://trac.ffmpeg.org/wiki/PHP
[21:13:52 CEST] <axew3> or there is something new around?
[21:14:09 CEST] <axew3> i need in php
[21:14:27 CEST] <axew3> ffmpeg sorry
[21:14:36 CEST] <BtbN> what?
[21:17:04 CEST] <axew3> hello i've just install ffmpeg into a centos server and now i would like to pass to it streams to convert in mp4, from php
[21:19:55 CEST] <axew3> or i could just use exec i assume?
[21:20:05 CEST] <axew3> or shell_exec
[21:23:29 CEST] <BtbN> Yeah, it's easiest to just run an external process
[21:23:36 CEST] <BtbN> but make absolutely sure to sanitize your inputs.
[21:23:53 CEST] <BtbN> Putting user arguments into a shell command is otherwise extremely risky. If possible, do not use a shell, but spawn ffmpeg directly.
[21:24:39 CEST] <BtbN> "If you want to start an external program without starting cmd.exe use proc_open() with the bypass_shell option set." according to the docs
[21:28:50 CEST] <axew3> wow awesome!
[21:29:13 CEST] <axew3> this is exactly what was the complete meaning
[21:29:13 CEST] <BtbN> seems like even proc_open spawns a shell
[21:29:42 CEST] <BtbN> consider dumping PHP while you're at it. There is literally no way to spawn a process directly with it.
[21:31:34 CEST] <axew3> deu to my bad eng i've totally underdstand: resuming isn't quite sure to use?
[21:32:23 CEST] <axew3> if i let say, trim, passed values before to pass to ffmpeg, isn't sufficient
[21:32:28 CEST] <axew3> ??
[21:33:49 CEST] <axew3> http://php.net/manual/en/function.trim.php
[21:38:39 CEST] <axew3> i've totally underdstand: WAS i have NOT totally understand ... sorry
[21:41:57 CEST] <axew3> p.s  bypass_shell (windows only) on php
[22:15:40 CEST] <Swervz> Hey anyone know how to fix a video that has the wrong framerate written to the container that has audio desync issues?
[22:16:46 CEST] <BtbN> remux the video to raw .h264, and re-mux that back together with the audio, specifying the correct input framerate
[22:17:13 CEST] <Swervz> media info says the framerate is 29.970 (30000/1001) and the original framerate is  29.970 (29970/1000) but I'm not sure how I specify the part in the brackets
[22:19:55 CEST] <JEEB> pretty sure a lot of things that take in x/y take it as "xxx/yyy"
[22:20:11 CEST] <JEEB> but I could be incorrect
[22:20:20 CEST] <Swervz> From googling I found results on how to do it for different framerates but I don't understand what that part even means
[22:20:50 CEST] <BtbN> it's the exact framerate
[22:21:31 CEST] <Swervz> ah okay
[22:26:32 CEST] <Swervz> I don't really understand what It means by stream specifier in the documentation
[22:29:32 CEST] <furq> Swervz: https://ffmpeg.org/ffmpeg.html#Stream-specifiers-1
[22:30:01 CEST] <Swervz> furq, Oh that's a different site than I was using for docs
[22:30:02 CEST] <furq> https://ffmpeg.org/ffmpeg.html#Advanced-options
[22:30:06 CEST] <furq> there's some more examples under -map as well
[22:30:26 CEST] <Swervz> This one seems to have so much more than the other site I found
[22:30:47 CEST] <furq> i should hope so
[22:31:25 CEST] <Swervz> Yeah I could only find this one before for some reason https://linux.die.net/man/1/ffmpeg
[00:00:00 CEST] --- Sat Mar 31 2018

More information about the Ffmpeg-devel-irc mailing list