[Ffmpeg-devel-irc] ffmpeg.log.20181110

burek burek021 at gmail.com
Sun Nov 11 03:05:01 EET 2018

[04:44:30 CET] <`St0ner> how do i report the bug i mentioned above regarding converting OPUS audio inside a WEBM file directly to ALAC? it does not provide an MD5 match with the original audio and results in a file that is triple the size of the equivalent WAV, so i have to convert to WAV first, and then convert WAV to ALAC
[04:46:02 CET] <Pocari> I'm still not sure that's because of some bug in ffmpeg
[04:46:34 CET] <Pocari> when you tried to play that malformed ALAC, did it work=
[04:46:36 CET] <Pocari> ?*
[05:12:12 CET] <`St0ner> will remake and check
[05:14:10 CET] <Pocari> k
[11:52:00 CET] <roger21> hi there
[11:52:35 CET] <roger21> is it possible to convert idx/sub files into str?
[11:55:17 CET] <roger21> i tried "ffmpeg -i a.idx -c:s srt a.srt" doesn't work
[12:21:14 CET] <ariyasu> you need to ocr them roger21
[15:39:09 CET] <hwdyki> i'm building 4.1 from source with the following opts: --target-os=linux --enable-gpl --enable-version3 --enable-nonfree --enable-shared --disable-w32threads --enable-bzlib --enable-libfontconfig --enable-libfreetype --enable-libmp3lame --enable-libspeex --enable-libtheora --enable-libvorbis --enable-openssl --enable-libx264  --enable-zlib --disable-x86asm --disable-random
[15:39:43 CET] <durandal_1707> --disable-x86asm --> VERY BAD IDEA
[15:40:23 CET] <furq> i don't know what disable-w32threads or disable-random are doing there
[15:40:36 CET] <hwdyki> and i'm getting Unknown input format: 'concat' when running   ffmpeg -f concat -i chunks -c copy FILE
[15:41:00 CET] <hwdyki> do i need any ext libs for concat?
[15:41:01 CET] <furq> well yeah disable-random randomly disables components
[15:41:28 CET] <hwdyki> hmm.
[15:43:10 CET] <durandal_1707> hwdyki: from where you got source?
[15:45:11 CET] <furq> https://www.johnvansickle.com/ffmpeg/
[15:45:16 CET] <furq> you might just want to use the builds from here
[15:45:38 CET] <hwdyki> ffmpeg.org
[15:47:49 CET] <durandal_1707> hwdyki: than make sure you use right ffmpeg version and not some prahistoric one in path
[15:48:11 CET] <furq> well also don't use an option that randomly disables stuff
[15:48:41 CET] <hwdyki> 4.1 is prahistoric?
[15:49:33 CET] <relaxed> you could have an older version in your $PATH
[15:49:51 CET] <hwdyki> nope.
[15:51:47 CET] <durandal_1707> pastebin full uncut ffmpeg console output
[15:52:19 CET] <furq> uh
[15:55:51 CET] <hwdyki> took out --disable-random, still the same.
[15:57:12 CET] <relaxed> what does this return?  ffmpeg -formats 2>&1|grep concat
[15:58:22 CET] <hwdyki> nvm fixed it.
[16:11:35 CET] <dariken> nice, 4.1, no builds yet. av1 encoding on acceptable speeds now?
[16:11:56 CET] <JEEB> that's up to libaom or rav1e
[16:12:14 CET] <JEEB> although I don't think rav1e has a c api yet
[23:01:41 CET] <zinger> I'm trying to devoces some ALAC files to WAV. The ALAC files are 24-bit but FFmpeg makes the into 16-bit WAV files. How do I tell FFmpeg not to downgrade the files from 24-bit to 16-bit?
[23:01:53 CET] <zinger> devoces->decode
[23:05:28 CET] <Pocari_> zinger, try      ffmpeg -i in.m4a -af aformat=s24:44100 out.wav
[23:05:46 CET] <relaxed> zinger: try -c:a pcm_s24le -f wav output.wav
[23:06:33 CET] <Pocari_> zinger, that's assuming your sample rate is 44100 Hz, if not change it to whatever it is
[23:07:56 CET] <zinger> isn't there a setting that just tells FFmpeg to use the same settings as the source file?
[23:09:34 CET] <relaxed> zinger: the default codec for wav is pcm_s16le, changing it to -c:a pcm_s24le should keep it lossless
[23:10:20 CET] <Pocari_> does that also copy over the sampling rate (not just the word length) losslessly?
[23:11:58 CET] <relaxed> encode both to pcm and hash them to see if it's still lossless
[23:12:10 CET] <Pocari_> yeah, I was also going to suggest md5 too
[23:13:40 CET] <zinger> for some reason FFmpeg kept the original 88,2 kHz when it downgraded the ALAC from 24-bit to 16-bit
[23:14:28 CET] <Pocari_> ok, now md5 hash both the ALAC and the WAV to see if it's genuinely lossless
[23:14:28 CET] <relaxed> he tries to maintain as much as possible
[23:24:53 CET] <zinger> thanks for the help guys! :-)
[23:32:50 CET] <rom1v> hi
[23:33:37 CET] <rom1v> in doc/APIchanges: "2016-04-11 - 6f69f7a / 9200514 - lavf 57.33.100 / 57.5.0 - avformat.h "
[23:33:59 CET] <rom1v> how I am supposed to test it properly using LIBAVCODEC_VERSION_INT, since there are 2 versions?
[23:47:49 CET] <rom1v> missing: && LIBAVFORMAT_VERSION_MICRO == 100
[23:47:52 CET] <rom1v> ==
[23:47:54 CET] <rom1v> 0
[00:00:00 CET] --- Sun Nov 11 2018

More information about the Ffmpeg-devel-irc mailing list