[Ffmpeg-devel-irc] ffmpeg.log.20181122

burek burek021 at gmail.com
Fri Nov 23 03:05:03 EET 2018

[00:01:52 CET] <TheRock> can i compile ffmpeg-4.1 with openssl 1.0.2q?
[00:02:22 CET] <TheRock> LINK : fatal error LNK1181: cannot open input file 'crypto.lib'
[00:02:31 CET] <TheRock> this file doesn't exist at me pc
[04:25:51 CET] <cocktail> Can I put mp3 in ogg container without transcoding?
[05:45:42 CET] <cocktail> How can I know which codecs a muxer supports?
[05:45:54 CET] <cocktail> Is there a command-line option for that?
[05:55:06 CET] <cocktail> https://wiki.xiph.org/index.php/MIMETypesCodecs tells me that ogg doesn't support mp3.
[06:20:11 CET] <Renari> Hey guys I'm having an issue with metadata being corrupted when converting from wav files to flac files.
[06:21:12 CET] <Renari> I'm on ffmpeg N-88804, I originally was using a batch script in windows and read that it's likely command prompts fault. However using the script in powershell ended with the same results.
[06:21:39 CET] <Renari> Rather running the command in powershell, not using the batch script.
[06:25:28 CET] <Renari> e.g. before: ¤ôûô¡ëìüÌ, after: ýCýýýEýýý@ýýýýý[ýk;
[06:26:05 CET] <Renari> The command I'm running is pretty basic: ffmpeg -i filename.wav -c:a flac "filename.flac"
[13:28:52 CET] <tombb> hi all! was wondering if it's possible to use ffprobe to print a list of the audio levels in frames for every audio stream
[13:29:00 CET] <tombb> what would be the best way to approach this?
[13:29:57 CET] <remlap> Hi anyone successfully built ffmpeg with nvenc and cuda on Ubuntu 18.10?
[16:14:50 CET] <TheRock> "avpriv_snprintf" not found in avutil-56.dll
[16:14:56 CET] <TheRock> after I compiled ffmpeg
[16:16:06 CET] <TheRock> -/configure --disable-everything --extra-version=TS --disable-debug --enable-shared --enable-runtime-cpudetect --toolchain=msvc --enable-openssl --enable-decoders --enable-demuxers --enable-parsers --enable-protocol='file,https,http,ftp,ftps' --enable-stripping --strip --extra-libs='advapi32.lib gdi32.lib user32.lib Ole32.lib'
[16:34:36 CET] <TheRock>  according to dependency walker avpriv_strtod, avpriv_snprintf is not exported
[16:35:17 CET] <furq> isn't that only defined for mingw
[16:37:00 CET] <TheRock> i'm building with MSYS
[16:37:07 CET] <furq> yeah but you're building with msvc
[16:37:16 CET] <TheRock> I've configured MSVC
[16:37:18 CET] <furq> where are you actually getting that error
[16:37:21 CET] <TheRock> already built successful
[16:37:31 CET] <TheRock> but the those two exports are problematic
[16:37:36 CET] <furq> problematic how
[16:37:55 CET] <TheRock> they're not exported, but required on programm startup
[16:38:20 CET] <furq> if you get that error when you run ffmpeg then that's maybe a bug
[16:38:35 CET] <TheRock> i tried to run ffprobe, ffmpeg binaries they work perfect
[16:38:59 CET] <TheRock> i'm actually not sure what causes it
[16:39:10 CET] <furq> what causes this error message
[16:40:22 CET] <furq> is this your own code that's linked against the ffmpeg libs
[16:40:31 CET] <furq> and if so are you trying to call avpriv_snprintf directly
[16:42:11 CET] <TheRock> It's not my own code, i'll check for references in the third-party library now (uses ffmpeg as backend)
[16:42:40 CET] <TheRock> https://ffmpeg.org/pipermail/libav-user/2016-September/009616.html
[16:42:52 CET] <TheRock> > -Dstrtod=avpriv_strtod -Dsnprintf=avpriv_snprintf
[16:42:52 CET] <TheRock> > -D_snprintf=avpriv_snprintf -Dvsnprintf=avpriv_vsnprintf
[16:43:20 CET] <TheRock> may that help?
[16:43:29 CET] <furq> i doubt it
[16:44:08 CET] <furq> as far as i can tell from configure, those symbols only exist if you build with mingw
[16:45:17 CET] <TheRock> $ echo $PATH
[16:45:17 CET] <TheRock> .:/usr/local/bin:/mingw/bin:/bin:/c/Program Files/Microsoft Visual Studio 14.0/
[16:45:19 CET] <furq> or if you build with msvc < 15
[16:45:22 CET] <TheRock> maybe that's an issue?
[16:45:32 CET] <furq> honestly i've never touched msvc
[16:46:17 CET] <TheRock> i use VS 15, but g++, gcc is available in msys
[16:46:33 CET] <TheRock> eventually it mixes some mingw stuff in he build
[16:47:35 CET] <furq> my guess is the thing you're linking against libavutil expects msvc 13 and so it's trying to call avpriv_snprintf directly
[16:47:50 CET] <furq> which it shouldn't be doing
[16:48:06 CET] <furq> but like i said i've never touched msvc
[16:55:05 CET] <TheRock> yeah i'm gonna look into it
[17:00:24 CET] <TheRock> The project itself that uses ffmpeg doesn't use avpriv_ functions
[17:12:22 CET] <TheRock> i unset now everything related to mingw, gcc, g++, etc. giving it another try.
[17:16:49 CET] <rmbeer> hello...
[17:17:51 CET] <rmbeer> how to make a command for extract the video stream of the first video and apply a list of music in succession?...
[17:18:37 CET] <rmbeer> i can't found in the internet...
[17:30:03 CET] <rmbeer> The only possible way is to create a concatenated audio file before joining it to a video?...
[17:31:00 CET] <TheRock> I figured out avresample.dll (ffmpeg) tries to call from avutil.dll (ffmpeg) "avpriv_snprintf"
[17:31:08 CET] <TheRock> so, it's probably a bug
[17:31:26 CET] <TheRock> avutil doesn't export those functions
[17:32:52 CET] <TheRock> and ffprobe.exe & ffmpeg works since avresample.dll is not used
[17:33:09 CET] <TheRock> so i'll have to fix it in the ffmpeg src :|
[17:35:32 CET] <furq> uh
[17:35:36 CET] <furq> that build shouldn't have avresample
[17:36:14 CET] <furq> are you sure all these dlls came from the same place
[17:36:40 CET] <TheRock> yep
[17:36:59 CET] <furq> you shouldn't even have avresample without --enable-avresample
[17:37:02 CET] <furq> and you shouldn't be using that
[17:37:11 CET] <furq> that's just for compat with libav
[17:37:56 CET] <TheRock> there is a avresample-4.dll after make install
[17:38:07 CET] <TheRock> Libraries:
[17:38:08 CET] <TheRock> avcodec			avformat		swresample
[17:38:08 CET] <TheRock> avdevice		avutil			swscale
[17:38:08 CET] <TheRock> avfilter
[17:38:15 CET] <furq> yeah that's swresample
[17:38:18 CET] <TheRock> it's not included in configure
[17:38:19 CET] <furq> that's a different lib
[17:38:22 CET] <TheRock> but it exists
[17:38:26 CET] <furq> what version is this
[17:38:32 CET] <TheRock> yes, i know swresample is another lib
[17:38:37 CET] <TheRock> ffmpeg 4.1
[17:38:47 CET] <JEEB> avresample is still buildable if you enable it
[17:38:52 CET] <JEEB> I don't think it was ever enabled by default
[17:38:56 CET] <furq> yeah but his configure line doesn't enable it
[17:39:01 CET] <furq> unless --disable-everything is screwing something up
[17:40:03 CET] <TheRock> --disable-everything builds also d3d11va, dxva2, etc.
[17:40:22 CET] <TheRock> probably because of --enable-decoders
[17:40:26 CET] <JEEB> that's probably solvable with --disable-autodetect
[17:40:40 CET] <JEEB> that way you need to enable stuff like zlib etc
[17:40:45 CET] <JEEB> and d3d11va/dxva2
[17:41:20 CET] <rmbeer> is this correct for concatenate 4 musics? -lavfi "[0:a] [a1];[1:a] [a2];[2:a] [a3];[3:a] [a4];[a1][a2][a3][a4] concat=n=4;a=4[outa]"
[17:41:40 CET] <furq> uh
[17:42:03 CET] <furq> just [0:a][1:a][2:a][3:a]
[17:42:06 CET] <JEEB> yup
[17:42:15 CET] <furq> unless you're actually doing some filtering that you omitted
[17:42:31 CET] <TheRock> i just looked in another configuration, avresample is built although not listed in the configration overview
[17:42:36 CET] <TheRock> I never enabled it
[17:42:51 CET] <TheRock> with the configuration line, which i wrote above
[17:42:57 CET] <JEEB> check with current master, and file a bug on trac if it still does
[17:43:28 CET] <JEEB> since I for example will not start debugging the shell script right now
[17:43:47 CET] <TheRock> i'll wait until the current build finished
[17:44:40 CET] <rmbeer> i use this but can't work: ffmpeg -i f1.mp3 -i f2.mp3 -i f3.mp3 -i f4.mp3 -lavfi "[0:a][1:a][2:a][3:a]" outmusic.mp3
[17:44:52 CET] <TheRock> avresample is okay for me, but it asks for avpriv_snprintf from avutil, which is not exported there
[17:45:02 CET] <JEEB> rmbeer: you still need the concat
[17:45:17 CET] <JEEB> it's just that you had that other part that renamed 0:a to a1 :P
[17:45:18 CET] <JEEB> etc
[17:45:43 CET] <JEEB> TheRock: yea but it still sounds fishy :P
[17:46:13 CET] <rmbeer> "[0:a][1:a][2:a][3:a] concat=n=4[outa]" -> Stream specifier ':a' in filtergraph description [0:a][1:a][2:a][3:a] concat=n=4[outa] matches no streams.
[17:48:07 CET] <JEEB> sounds like something is either lacking or there that makes ffmpeg.c or lavfi misparse it
[17:48:49 CET] <sybariten> oh hai
[17:49:03 CET] <JEEB> ohai
[17:50:06 CET] <sybariten> i'm a bit confused by ffmpegs syntax. First i tried using an "alac" codec for some problematic mts files, just to get the audio, but that didnt work for my purpose. Syntax was ffmpeg -i ./00264.MTS -vn  -acodec alac 00262.m4a   ... now i want to try "Native FFmpeg AAC Encoder" as it's called on an ffmpeg wiki
[17:50:42 CET] <sybariten> but the syntaxc there, in the example, is ffmpeg -i input.wav -c:a aac -b:a 160k output.m4a   ... how come theres no "-acodec" used? Is there a shorthand?
[17:50:42 CET] <JEEB> instead of acodec -c:a aac (same for alac, "acodec" is just the old way of defining it)
[17:51:12 CET] <JEEB> so you have -c for all streams, -c:v for video, -c:a for audio etc
[17:51:25 CET] <JEEB> and :TYPE can be used generally with options
[17:51:30 CET] <JEEB> or other selectors
[17:51:39 CET] <sybariten> okay so i could use either -c:a aac , -c:a alac , -acodec aac and -acodec alac  ?
[17:51:43 CET] <JEEB> yes
[17:52:02 CET] <JEEB> so you can have -maxrate:v:3 which means that you want to set the 4th video track's maxrate :P
[17:52:04 CET] <sybariten> OK cool i'll go with the older way then as it's more ... uh... elaborate or whatever the english word is  :)
[17:52:46 CET] <rmbeer> then this not have solution?... Dx
[17:52:55 CET] <sybariten> And what is the correct container, by the way, if i'm "transcoding" .mts video to something using aac (just audio then i guess)
[17:53:12 CET] <JEEB> generally you may want to use mp4/m4a
[17:53:19 CET] <sybariten> aha. Thanks!
[17:53:22 CET] <JEEB> but it depends on if you need support on some plastic boxes
[17:53:31 CET] <JEEB> although most plastic boxes take exactly that in
[17:53:34 CET] <JEEB> for audio only
[17:53:41 CET] <sybariten> hardware? Nope. I'm having Adobe Premiere Pro problems
[17:53:45 CET] <JEEB> ok
[17:54:01 CET] <JEEB> if it's audio only might as well go for raw audio in mov or something :D
[17:54:20 CET] <JEEB> if lossless audio codecs are not supported
[17:54:22 CET] <sybariten> Well... it's 28 gb of video
[17:54:38 CET] <JEEB> yea, but audio is not exactly the largest part of that most likely?
[17:54:42 CET] <sybariten> So i was just trying to economize a bit
[17:54:51 CET] <sybariten> nah, true that, audio is often a tenth or soemthing maximum
[17:55:18 CET] <sybariten> So what was your idea with mov? put just audio into mov?
[17:55:33 CET] <JEEB> yea, raw audio in mov sounds like something that those things can ingest
[17:55:38 CET] <JEEB> not that I know :P
[17:55:51 CET] <sybariten> ok
[17:56:17 CET] <sybariten> I'd put raw audio in wav.. but i'm not sure if you can say that that is a container
[17:56:25 CET] <JEEB> yup
[17:56:30 CET] <JEEB> wav should work as well
[17:59:01 CET] <TheRock> ok guys
[17:59:13 CET] <TheRock> it didn't build it this time
[18:01:46 CET] <rmbeer> i fixed it with 'concat' command...
[18:08:58 CET] <TheRock> that avresample/swresample stuff is not important for video decoding, right?
[18:14:17 CET] <furq> no
[18:14:27 CET] <furq> i'm not sure why it's being built at all with that configure command
[18:16:33 CET] <TheRock> it isn't anymore
[18:16:39 CET] <TheRock> i have created a complete new build
[20:02:55 CET] <giaco> is there any dash mpd expert here? I am manually editing the stream.mpd file but I'm not achieving what I need, but it should be easy. I have a 12 minutes dash stream chunked in 5 seconds files, the original mpd file is a 1 period, 1 segment template barebone audio descriptor. What I would like to do is edit it so that it would play, according to an index value, the Nth minute. So if index is 5 the generated stream.mpd would pla
[20:02:55 CET] <giaco> y, starting from the same chunks, from minute 5:00 to 6:00 displaying a duration of 1 minute
[22:44:19 CET] <TheRock> I see that ffmpeg links to bcrypt. is there a way to avoid it?
[22:46:12 CET] <TheRock> http://www.ffmpeg.org/doxygen/4.1/random__seed_8c_source.html
[22:46:37 CET] <TheRock> through ./configure?
[22:46:58 CET] <TheRock> I build on WIN7 (which has bcrypt), but this doesn't run on XP
[22:47:28 CET] <JEEB> I think XP support was at some point specifically dropped for that
[22:48:10 CET] <JEEB> http://git.videolan.org/?p=ffmpeg.git;a=commit;h=9b121dfc32810250938021952aab4172a988cb56
[22:48:55 CET] <JEEB> basically the threading stuff was switched in december 2017 that only vista+ threading APIs would be utilized and thus xp was no longer supported
[22:49:12 CET] <TheRock> ah, ok
[22:49:27 CET] <TheRock> gonna drop xp support then
[00:00:00 CET] --- Fri Nov 23 2018

More information about the Ffmpeg-devel-irc mailing list