[Ffmpeg-devel-irc] ffmpeg.log.20181124

burek burek021 at gmail.com
Sun Nov 25 03:05:02 EET 2018

[02:22:09 CET] <wheelzi> How would I achieve this? i tried ffmpeg -i in *.mkv; do ffmpeg -i "$i" -c:a libfdk_aac -b:a 384k -c:v copy "${i%.mkv}.mp4"; done i get bash: syntax error near unexpected token do' any advice?
[02:22:22 CET] <wheelzi> I have a folder of mkvs with ac3 that I want to batch convert to mp4 with aac 5.1 leaving the video untouched.
[02:22:34 CET] <wheelzi> How would I achieve this? i tried ffmpeg -i in *.mkv; do ffmpeg -i "$i" -c:a libfdk_aac -b:a 384k -c:v copy "${i%.mkv}.mp4"; done i get bash: syntax error near unexpected token do' any advice?
[09:47:36 CET] <Daisae> Whiskey: That is a bash question rather than an FFMPEG one, so another channel would perhaps be better able to help you.
[09:47:50 CET] <Daisae> oops, that was meant for wheelzi, who is gone.
[09:48:35 CET] <linux_gnu> Hi , anyone could suggest command to use filter for altering voice in any cool way???thanks
[10:11:42 CET] <linux_gnu> anyone knows any ffmpeg commands to alter voice??? I don tknow anything about filters options...
[11:17:14 CET] <durandal_1707> linux_gnu: see tremolo and vibrato filter docs
[11:41:59 CET] <linux_gnu> anyone has advice for disquising voice recordings with ffmpeg????
[11:44:24 CET] <durandal_1707> linux_gnu: told you already
[11:47:26 CET] <linux_gnu> durandal ,if today I got disconnected
[11:48:44 CET] <linux_gnu> durandal ,you gave me 2 commands 2 months ago ,only one is working ,I wish I had more options..
[11:49:26 CET] <linux_gnu> this one doesn t work ffmpeg -i voice.wav -f lavfi -i sine=400 -lavfi amultiply out.wav
[11:50:26 CET] <linux_gnu> the one  -af vibrato=f=37  is nice!
[11:52:19 CET] <durandal_1707> "doesn't" work means nothing to me, probably you ffmpeg is too old
[11:58:30 CET] <linux_gnu> durandal ffmpeg -i a.mp3 -f lavfi -i sine=400 -lavfi amultiply out.mp3
[11:58:45 CET] <linux_gnu> gives No such filter: 'amultiply'
[11:58:45 CET] <linux_gnu> Error initializing complex filters.
[11:58:45 CET] <linux_gnu> Invalid argument
[11:59:31 CET] <linux_gnu> durandal ubuntu 18.10 up to date
[12:00:01 CET] <furq> you need 4.1 or newer for amultiply
[12:01:45 CET] <linux_gnu> durandal: 7:4.0.2-2  is my syntax wrong?
[12:03:05 CET] <pink_mist> what is 7:4.0.2-2 meant to be?
[12:03:12 CET] <pink_mist> some random number an punctuation?
[12:03:19 CET] <pink_mist> *numbers and
[12:03:40 CET] <linux_gnu> it s result of  dpkg -s ffmpeg | grep "Version:"
[12:04:09 CET] <pink_mist> well that doesn't look anything like 4.1
[12:05:08 CET] <linux_gnu> I get it , sorry  ): it means 4.0..
[12:06:19 CET] <linux_gnu> durandal: maybe an example with tremolo??
[12:10:40 CET] <durandal_1707> linux_gnu: you could alter more with afftfilt in frequency domain, but i dunno any simple command right now
[12:11:17 CET] <durandal_1707> and to have more options you really need at least 4.1 version
[12:11:51 CET] <durandal_1707> alternatively use aeval filter, but that too needs complex expessions
[12:16:24 CET] <linux_gnu> durandal thanks! (first time I m impeded by a sowtware being too old in ubuntu...learning arch at the moment so will play with it on it
[12:19:16 CET] <linux_gnu> durandal tremolo I did : ffmpeg -i a.mp3 -af tremolo=f=5 out2.mp3
[12:19:34 CET] <linux_gnu> and I don t notice any alteration ,any tip?
[12:34:53 CET] <durandal_1707> linux_gnu: you need to more experiment
[12:35:12 CET] <durandal_1707> bigger number, also change other options
[12:35:44 CET] <linux_gnu> durandal: thanks ,I will ,and look into all you pointed
[12:36:07 CET] <linux_gnu> durandal what options? you mean adding several filters?
[12:39:39 CET] <durandal_1707> no, see: ffmpeg -h filter=tremolo
[12:39:56 CET] <durandal_1707> there is 2nd option: depth/d
[12:43:04 CET] <linux_gnu> durandal: thanks!!! ,(I m really new to filters..)
[12:51:11 CET] <linux_gnu> durandal: ok tremolo is not altering much ,but I ll dig into all the others!
[17:39:06 CET] <Daisae> How do I get make FFMPEG produce VBR video and adjust the quality?  I tried # ffmpeg -i Input.mkv -codec:v libvpx-vp9 -crf 60 Output.webm
[17:39:06 CET] <Daisae> and the result is low visual quality. I suspect that it is constraining the bit rate.
[17:39:47 CET] <JEEB> I think you should look at the libvpx specific documentation on vp9's CRF range (or actually, what it maps against and what its range is)
[17:39:50 CET] <JEEB> among other things
[17:44:13 CET] <Daisae> I take your comment and the parenthesis in the FFMPEG doc to mean that it enables CQ mode.  That would answer why the throughput is constrained. A WWW site I read said that it would produce VBR output but apparently that was wrong.
[17:44:49 CET] <Daisae> It still leaves a mystery of how to enable VBR output.  I've read in https://www.webmproject.org/docs/encoder-parameters/
[17:45:17 CET] <Daisae> and the vpenc manual
[17:45:34 CET] <Daisae> vpxenc
[17:45:47 CET] <JEEB> and then the community wiki @ trac has these https://trac.ffmpeg.org/wiki/Encode/VP9
[17:45:58 CET] <JEEB> I've not used VP9 myself at all, though
[17:48:03 CET] <Daisae> That could be on the right trac.  Thanks, I will investigate it.
[17:49:10 CET] <Daisae> VBR section is empty. I guess they didn't find information either.
[17:49:12 CET] <furq> Daisae: short answer is you need to set -b:v 0 to use crf with vp9
[17:49:59 CET] <furq> recommended settings for vpx are still some kind of elusive mystery though
[17:56:52 CET] <Daisae> That -b:v 0 did cause crf to take effect for video.
[17:56:52 CET] <Daisae> However, with -b:a 0 , libopus still reports :  No bit rate set. Defaulting to 96000 bps.
[17:57:34 CET] <BtbN> I don't think opus supports vbr?
[17:58:17 CET] <JEEB> also generally vbr in audio is setting the quantizer
[17:58:27 CET] <JEEB> aka "don't expect all encoders do the same thing"
[17:58:35 CET] <Daisae> opusenc manual:  -vbr  Use variable bitrate encoding (default)
[17:58:47 CET] <JEEB> and libvpx is the more special case
[18:00:00 CET] <JEEB> if you had tried to set the quantizer
[18:00:00 CET] <JEEB>                "Quality-based encoding not supported, "
[18:00:01 CET] <JEEB>                "please specify a bitrate and VBR setting.\n")
[18:00:17 CET] <JEEB> so it needs a bit rate and the VBR setting (which is probably default looking at the AVOptions)
[18:00:33 CET] <furq> opus is vbr by default
[18:00:49 CET] <furq> -b:a sets the nominal bitrate but it's basically the same as using -q for vorbis or -V for lame
[18:01:04 CET] <furq> there's also an abr mode and a cbr mode if you really want to use them
[18:01:07 CET] <JEEB> Daisae: welcome to all encoders are different :P
[19:45:49 CET] <kerio> why am i getting a tbn of 10000k when remuxing an avi to mp4? :\
[19:45:52 CET] <kerio> quicktime is complaining
[19:47:45 CET] <JEEB> 10k I would understand but 10,000k is quite high of a time base
[19:47:48 CET] <JEEB> or wait
[19:47:51 CET] <JEEB> that's one of the time base things
[19:47:56 CET] <JEEB> although it still sounds high
[19:48:16 CET] <JEEB> I know movenc.c had a thing that artificially heightened the video time base for some reason
[19:48:25 CET] <JEEB> I even tried to remove that at one point
[19:49:48 CET] <JEEB> http://ffmpeg.org/pipermail/ffmpeg-devel/2018-March/226366.html
[19:50:01 CET] <JEEB> or not remove, but I brought up its weirdness on the mailing list
[19:51:30 CET] <kerio> do i just reencode this shit
[19:51:44 CET] <JEEB> you can set the output time base
[19:51:51 CET] <JEEB> IIRC ffmpeg.c had an option for that
[19:51:57 CET] <JEEB> although movenc will then still make it larger than 10k
[19:52:10 CET] <JEEB> just so it can position audio "correctly" (without edit lists) it seems
[19:52:31 CET] <JEEB> although there of course is an AVOption to override that behavior which makes it all more hilarious
[19:52:57 CET] <JEEB> I would be interested in what makes it think it needs a big enough time base for that, though
[19:53:00 CET] <JEEB> like 10,000k
[19:54:46 CET] <kerio> well apparently the audio is also an issue here
[19:54:51 CET] <kerio> quicktime refuses to play this mp3
[19:54:54 CET] <wheelzi> .
[19:54:55 CET] <kerio> who made this shit
[19:55:39 CET] <wheelzi> I got disconnected last night anybody know if anyone answered my batch convert question?
[19:56:21 CET] <kerio> oh hold ON
[19:56:29 CET] <kerio> this is XVID
[19:56:35 CET] <kerio> no wonder quicktime doesn't like it
[20:00:20 CET] <JEEB> lol
[20:03:19 CET] <ChocolateArmpits> wheelzi, there's an archive of this channel available, you may look into it
[20:03:58 CET] <wheelzi> where is it thanks
[20:05:02 CET] <ChocolateArmpits> somewhere, I forgot where
[20:06:37 CET] <ChocolateArmpits> can't find it :/ hmmm
[20:06:52 CET] <wheelzi> I'll re ask lol. I have a folder of mkvs with ac3 that I want to batch convert to mp4 with aac 5.1 leaving the video untouched.
[20:06:52 CET] <wheelzi> How would I achieve this?
[20:07:17 CET] <ChocolateArmpits> wheelzi, what OS are you using?
[20:07:54 CET] <wheelzi> linux mint. I've tried ffmpeg -i in *.mkv; do ffmpeg -i "$i" -c:a libfdk_aac -b:a 384k -c:v copy "${i%.mkv}.mp4"; done
[20:07:54 CET] <wheelzi> i get bash: syntax error near unexpected token do'
[20:08:21 CET] <ChocolateArmpits> sorry not familiar with bash
[20:09:55 CET] <wheelzi> I had 1 for Windows but it doesn't work for linux
[20:11:15 CET] <RemedyTomm> Well I just came into this channel to ask for help with a linking issue, but then i accidentally squirted coca cola up my nose and somehow i realised what I was doing wrong
[20:11:48 CET] <RemedyTomm> forgot extern C >.<
[20:12:05 CET] <ChocolateArmpits> >squirted coca cola up my nose
[20:12:11 CET] <ChocolateArmpits> Thanks, I'll try that next time my brain isn't working
[20:13:15 CET] <RemedyTomm> wrong channel anyway, i guess.. I probably wanted #ffmpeg-devel
[20:13:33 CET] <RemedyTomm> oh, or not
[20:13:40 CET] <RemedyTomm> #confuse
[20:52:27 CET] <jin> ffmpeg -i in.mp4 -filter:v "crop=in_w:in_h-100" -c:a copy out.mp4
[20:52:31 CET] <jin> this command crops 100 from top and bottom
[20:52:40 CET] <jin> what if I wanted to shave some pixels just off the top?
[21:15:47 CET] <misterunknown> Hi guys. I try to make a video like the amazon fire tv screensaver (i.e. an image slideshow with different zoompan filters). I already figured out how to achieve the zoompan effect and created four configurations (different directions, zoom in + out). My actual question: Is it possible to apply these four filters in round-robin order to an undefined amount of input images? I hope you understand what I mean.
[21:16:02 CET] <misterunknown> My command so far:
[21:16:31 CET] <misterunknown> ffmpeg -framerate 1/10 -r 30 -pattern_type glob -i '*.jpg' -c:v libx264 -filter_complex "scale=8000x4000,zoompan=d=300:z='min(zoom+0.00035,1.5)':x='if(gte(zoom,1.5),x,x+3/a)':y='if(gte(zoom,1.5),y,y+3)" slideshow.mp4
[21:16:45 CET] <misterunknown> I read already about the -map parameter but only found explanations for 1:1 mapping.
[23:59:26 CET] <djk> I'm trying to stream to Facebook at 720p but not sure where that is set? It is working but only 480
[00:00:00 CET] --- Sun Nov 25 2018

More information about the Ffmpeg-devel-irc mailing list